Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-01-2018 21:05:50

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.18.0-2-amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

[clos] au sujet des paquets 32 bits du systeme

bonsoir ,

j'ai tapé la commande  suivante :

dpkg-query -l > paquets.txt



elle a parfaitement fonctionné mais , dans mon fichier , je trouve ceci :

ii  libglvnd0:amd64                               1.0.0-1.1                           amd64        Vendor neutral GL dispatch library
ii  libglvnd0:i386                                1.0.0-1.1                           i386         Vendor neutral GL dispatch library
ii  libglx-mesa0:amd64                            17.3.3-1                            amd64        free implementation of the OpenGL API -- GLX vendor library
ii  libglx-mesa0:i386                             17.3.3-1                            i386         free implementation of the OpenGL API -- GLX vendor library
ii  libglx0:amd64                                 1.0.0-1.1                           amd64        Vendor neutral GL dispatch library -- GLX support
ii  libglx0:i386                                  1.0.0-1.1                           i386         Vendor neutral GL dispatch library -- GLX support


et ceci :

ii  libgnome-games-support-common                 1.2.3-2                             all          library for common functions of GNOME games (common files)
ii  libgnome-keyring-common                       3.12.0-1                            all          GNOME keyring services library - data files


par exemple .
je ne comprends pas ce que cela veut dire :
"ii" surement les paquets installés
"i386" et "amd64" , sans  doute le type de paquets (architecture)
mais "all" , ça veut dire quoi ?

j'ai tapé ceci :

~$ dpkg --print-foreign-architectures


et j'ai obtenu :

i386


la commande suivante me donne un résultat que je ne  comprends pas :

~$ sudo aptitude why-not vlc


[sudo] Mot de passe de alain : 
p   openssh-client:i386       Fournit             openssh-client                
p   openssh-client:i386       Suggère             ssh-askpass:i386              
p   lxqt-openssh-askpass:i386 Fournit             ssh-askpass:i386              
p   lxqt-openssh-askpass:i386 Suggère             lxqt:i386 | lxqt-core:i386    
p   lxqt:i386                 Suggère             vokoscreen:i386              
p   vokoscreen:i386           Suggère             vlc:i386 | dragonplayer:i386 |
                                                   kplayer:i386                
p   vlc:i386                  Est en conflit avec vlc
 


d'autant plus que :

ii  vlc                                           3.0.0~rc6-1+b1                      amd64        multimedia player and streamer
ii  vlc-bin                                       3.0.0~rc6-1+b1                      amd64        binaries from VLC
ii  vlc-data                                      3.0.0~rc6-1                         all          common data for VLC
ii  vlc-l10n                                      3.0.0~rc6-1                         all          translations for VLC
ii  vlc-plugin-base:amd64                         3.0.0~rc6-1+b1                      amd64        multimedia player and streamer (base plugins)
ii  vlc-plugin-notify:amd64                       3.0.0~rc6-1+b1                      amd64        LibNotify plugin for VLC
ii  vlc-plugin-qt:amd64                           3.0.0~rc6-1+b1                      amd64        multimedia player and streamer (Qt plugin)
ii  vlc-plugin-samba:amd64                        3.0.0~rc6-1+b1                      amd64        Samba plugin for VLC
ii  vlc-plugin-skins2:amd64                       3.0.0~rc6-1+b1                      amd64        multimedia player and streamer (Skins2 plugin)
ii  vlc-plugin-video-output:amd64                 3.0.0~rc6-1+b1                      amd64        multimedia player and streamer (video output plugins)
ii  vlc-plugin-video-splitter:amd64               3.0.0~rc6-1+b1                      amd64        multimedia player and streamer (video splitter plugins)
ii  vlc-plugin-visualization:amd64                3.0.0~rc6-1+b1                      amd64        multimedia player and streamer (visualization plugins)


il n'y a que un paquet "vlc" et il est en architecture amd64

alors que signifie :

p   vlc:i386                  Est en conflit avec vlc


je me demande ...
j'apprécierai beaucoup votre instruction et  vos commentaires .vos avis et vos connaissances sont les  bienvenus .

Dernière modification par Debian Alain (29-01-2018 23:04:00)


1498812139.jpg    Antonio Vivaldi - Winter (Trance Remix) 
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#2 25-01-2018 21:39:44

raleur
Membre
Inscription : 03-10-2014

Re : [clos] au sujet des paquets 32 bits du systeme

Debian Alain a écrit :

je ne comprends pas ce que cela veut dire :
"ii" surement les paquets installés
"i386" et "amd64" , sans  doute le type de paquets (architecture)


Les explications sont données dans les en-têtes de colonnes au début du fichier.

Debian Alain a écrit :

mais "all" , ça veut dire quoi ?


"all" est une pseudo-architecture pour les paquets indépendants de l'architecture, qui ne contiennent pas de binaires exécutables par le système. Par contre ils peuvent contenir des fichiers binaires non exécutables comme des images ou exécutables mais pas sur le système comme des firmwares. Ce sont notamment les paquets contenant de la documentation, des firmwares, des fichiers sources, des fichiers de données divers... où dont les exécutables ne sont que des scripts.

Debian Alain a écrit :

alors que signifie :

    p   vlc:i386                  Est en conflit avec vlc



Que l'architecture principale du système est amd64, que tu as ajouté l'architecture étrangère i386, que le paquet vlc de l'architecture i386 n'est pas installé et est en conflit avec le paquet vlc dfe l'architecture amd64, ce qui est normal pour les paquets autres que les bibliothèques partagées compatibles multi-arch dont plusieurs instances d'architectures différentes peuvent être installées simultanément afin de satisfaire aux dépendances des paquets binaires de ces différentes architectures.

Il ne serait pas très utile d'installer un même programme à la fois en amd64 et en i386. Par contre on peut vouloir installer deux programmes différents, l'un en i386 et l'autre en amd64, qui dépendent d'une même bibliothèque. Pour cela il faut pouvoir installer cette bibliothèque à la fois en i386 et en amd64.

Dernière modification par raleur (25-01-2018 21:40:07)

Hors ligne

#3 25-01-2018 21:43:01

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : [clos] au sujet des paquets 32 bits du systeme

Re bonsoir
all ça veut dire tous donc un paquet all s’installe sur toutes architectures : amd64 i386 et autres
Tu as ajouté l’architecture i386 à ton système donc tu as accès aux versions i386 des paquets même si ce n’est pas cette version que tu as installé mais la version amd64.
Ça veut dire que tu ne peux pas installer la version i386 avec la version amd64

Hors ligne

#4 25-01-2018 21:51:35

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.18.0-2-amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : [clos] au sujet des paquets 32 bits du systeme

merci chalu pour ta synthèse .

merci raleur pour tes connaissances .

1498812139.jpg    Antonio Vivaldi - Winter (Trance Remix) 
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#5 25-01-2018 21:52:42

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [clos] au sujet des paquets 32 bits du systeme

Tu peux consulter les pages du manuel

man dpkg


man dpkg-query


note que tu as la meme liste

dpkg -l

Dernière modification par Croutons (26-01-2018 11:46:41)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#6 25-01-2018 21:59:51

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : [clos] au sujet des paquets 32 bits du systeme

Je n’avais pas la réponse de raleur quand j’ai répondu wink sinon je ne l’aurais pas faite

Hors ligne

#7 25-01-2018 22:08:43

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.18.0-2-amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : [clos] au sujet des paquets 32 bits du systeme

tu as fait une faute croutons ,

tu voulais sans doute dire

dpkg -l



merci pour les pages du man . je n'y avais pas pensé .

malheureusement 

man dpkg

est en anglais

man dpkg-query

est déjà beaucoup plus compréhensible ( plus de français ) . mais très riche .

@ raleur :

dans la  commande  suivante :

~$ sudo aptitude why vlc:i386


p   openssh-client:i386       Fournit openssh-client                            
p   openssh-client:i386       Suggère ssh-askpass:i386                          
p   lxqt-openssh-askpass:i386 Fournit ssh-askpass:i386                          
p   lxqt-openssh-askpass:i386 Suggère lxqt:i386 | lxqt-core:i386                
p   lxqt:i386                 Suggère vokoscreen:i386                            
p   vokoscreen:i386           Suggère vlc:i386 | dragonplayer:i386 | kplayer:i386
 


aucun paquet n'est installé . tous sont suggérés pour aller de pair avec vlc:i386

on y trouve , si je vois bien , des paquets de openssh , lxqt , et vokoscreen qui installerait  vlc :i386 et  aussi dragonplayer  et kplayer .

tu confirmes ?

j'ai trouvé ceci dans le man :

why, why-not
           Expliquer pourquoi tel paquet peut ou ne peut pas être installé sur ce système.

           Cette commande cherche les paquets qui dépendent ou sont en conflit avec ce paquet. Il affiche
           la suite de dépendances qui s'enchaînent jusqu'au paquet visé, et une note indique l'état de
           chacun des paquets de la suite de dépendances.

               $ aptitude why kdepim
               i   nautilus-data Recommends nautilus
               i A nautilus      Recommends desktop-base (>= 0.2)
               i A desktop-base  Suggests   gnome | kde | xfce4 | wmaker
               p   kde           Depends    kdepim (>= 4:3.4.3)

           La commande why cherche la chaîne de dépendances pour l'installation du paquet indiqué sur la
           ligne de commande, comme ci-dessus. Sachez que les dépendances qu'indique aptitude dans ce cas
           de figure ne sont que des suggestions. C'est parce qu'aucun paquet installé sur cet ordinateur
           ne dépend ni ne recommande le paquet kdepim, car si une dépendance plus évidente était
           possible, aptitude l'aurait affichée.

           A contrario, why-not cherche la chaîne de dépendances qui conduit au conflit avec le paquet
           ciblé.

               $ aptitude why-not textopo
               i   ocaml-core          Depends   ocamlweb
               i A ocamlweb            Depends   tetex-extra | texlive-latex-extra
               i A texlive-latex-extra Conflicts textopo

           Si un ou plusieurs <motifs> sont présents (en plus du dernier argument qui est obligatoire, et
           qui doit être un nom de <paquet> valable), aptitude commencera sa recherche sur ces motifs.
           C'est à dire que le premier paquet affiché pour expliquer pourquoi le <paquet> est ou n'est
           pas installé, sera un paquet qui correspond au motif en question. Les motifs sont considérés
           comme des noms de paquet sauf s'ils contiennent un caractère tilde(« ~ ») ou un point
           d'interrogation (« ? »). Dans ce cas, ils seront alors traités comme un motif de recherche
           (consultez la section « Motifs de recherche » dans le manuel de référence d'aptitude).

           Si aucun motif n'est présent, aptitude cherchera une chaîne de dépendances commençant par les
           paquets installés manuellement. Cela affiche de manière effective les paquets qui ont causé ou
           auraient pu avoir causé l'installation d'un paquet donné.

               Note
               aptitude why ne réalise pas une recherche complète de dépendances. Il n'affiche que les
               relations directes entre paquets. Par exemple, si A dépend de B, que C dépend de D, et que
               B et C sont en conflit, « aptitude why-not D » ne trouvera pas la réponse « A dépend de B,
               B est en conflit avec C, et D dépend de C ».
           Par défaut, aptitude n'affiche que les chaînes de dépendances les plus « courtes », les plus
           « fortes » et les plus « installées ». Dans ce cas, il cherche une chaîne qui ne contient que
           les paquets qui sont installés ou qui seront installés. Il recherche les dépendances les plus
           fortes possibles dans ce cadre, et recherche les chaînes qui évitent les dépendances avec
           alternatives et Provides, et il recherche la chaîne de dépendance la plus courte qui respecte
           ces contraintes. Ces règles sont appliquées de façon de moins en moins stricte jusqu'à ce
           qu'une correspondance soit trouvée.

           Si le niveau de verbosité est à 1 ou plus, alors toutes les explications qu'aptitude trouvera
           seront affichées, dans l'ordre de pertinence décroissante. Si le niveau de mode verbeux est de
           2 ou plus, un très important niveau d'information de débogage sera affiché sur la sortie
           standard.

           Cette commande renvoie un 0 si elle réussit, 1 si aucune explication n'a pu être fournie, et
           -1 si une erreur est apparue.

Dernière modification par Debian Alain (26-01-2018 10:37:20)


1498812139.jpg    Antonio Vivaldi - Winter (Trance Remix) 
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

Pied de page des forums