Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 05-02-2018 19:15:40

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.18.0-2-amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

si ça peut aider calixtus06 , le résultat , grosso modo , doit ressembler à ça :
chez moi :

~$ dpkg -S /boot/vmlinuz-$(uname -r)


linux-image-4.15.1-amd64: /boot/vmlinuz-4.15.1-amd64


chez toi , le résultat doit être différent , tu n'as sans doute pas les mêmes logiciels que moi .
nous n'avons pas des configurations identiques .

~$ apt-cache policy  xserver-xorg-video-nouveau:i386


xserver-xorg-video-nouveau:i386:
  Installé : (aucun)
  Candidat : 1:1.0.15-2
 Table de version :
     1:1.0.15-2 500
        500 http://ftp.fr.debian.org/debian testing/main i386 Packages
        100 http://ftp.fr.debian.org/debian unstable/main i386 Packages
 



c'est normal , je n'utilise pas nouveau (forcément ....).

calixtus peut peut être nous poster ses retours ici ?



oups ! , j'avais pas fait attention mais au post #1 , tu précises :

Nom de modèle :      AMD Athlon(tm) II X3 440 Processor



du coup , enicar a peut être raison :

il se peut que tu gagnes à installer une debian 32 bits .

techniquement , c'est pas  dit que tu y perdes grand chose ...

pourtant , https://www.ldlc.com/fiche/PB00097001.html

je me demande si ce n'est pas quand même un 64 bits .

pour aller plus loin , il nous faudrait la marque et le type de ta carte mère .

(références complètes) .

Dernière modification par Debian Alain (05-02-2018 20:01:46)


1498812139.jpg    Antonio Vivaldi - Winter (Trance Remix) 
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#27 05-02-2018 20:07:48

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

Partons sur Nouveau:

Ajout des sources.list de Robert:

nano /etc/apt/sources.list



xserver-xorg-video-nouveau:
  Installé : 1:1.0.13-3
  Candidat : 1:1.0.13-3
 Table de version :
 *** 1:1.0.13-3 500
        500 [url]http://ftp.fr.debian.org/debian[/url] stretch/main amd64 Packages
        500 [url]http://deb.debian.org/debian[/url] stretch/main amd64 Packages
        100 /var/lib/dpkg/status
root@GASPARD:/home/nicolas#



apt policy firmware-misc-nonfree



firmware-misc-nonfree:
  Installé : (aucun)
  Candidat : 20161130-3
 Table de version :
     20161130-3 500
        500 [url]http://ftp.fr.debian.org/debian[/url] stretch/non-free amd64 Packages
        500 [url]http://ftp.fr.debian.org/debian[/url] stretch/non-free i386 Packages
root@GASPARD:/home/nicolas#
 



apt install firmware-misc-nonfree



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les NOUVEAUX paquets suivants seront installés :
  firmware-misc-nonfree
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 2 321 ko dans les archives.
Après cette opération, 8 154 ko d'espace disque supplémentaires seront utilisés.
Réception de:1 [url]http://ftp.fr.debian.org/debian[/url] stretch/non-free amd64 firmware-misc-nonfree all 20161130-3 [2 321 kB]
2 321 ko réceptionnés en 0s (2 727 ko/s)          
Sélection du paquet firmware-misc-nonfree précédemment désélectionné.
(Lecture de la base de données... 196056 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../firmware-misc-nonfree_20161130-3_all.deb ...
Dépaquetage de firmware-misc-nonfree (20161130-3) ...
Paramétrage de firmware-misc-nonfree (20161130-3) ...
update-initramfs: deferring update (trigger activated)
Traitement des actions différées (« triggers ») pour initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.9.0-5-amd64
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8402-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169
 



apt-get update && sudo apt-get install xserver-xorg-video-nouveau



sudo apt-get install libgl1-mesa-glx libgl1-mesa-dri



grep -B2 'Module class: X.Org Video Driver' /var/log/Xorg.0.log



grep: /var/log/Xorg.0.log: Aucun fichier ou dossier de ce type
root@GASPARD:/home/nicolas#
 



Le plus beau:

cd /etc/X11# ls



app-defaults         rgb.txt  Xreset      Xsession        xsm
default-display-manager  xinit      Xreset.d    Xsession.d    XvMCConfig
fonts             xkb      Xresources  Xsession.options    Xwrapper.config
root@GASPARD:/etc/X11#



Donc le seul .conf c'est Xwrapper.config...

Je "crée" un ficher de conf:

 nano /etc/X11/xorg.conf



Section "Device"
Identifier    "Video Card"
Driver        "nouveau"
EndSection
 







Qu'en faire ?

Dernière modification par calixtus06 (05-02-2018 20:22:29)


Il n'y a pas de mauvaises questions...

Hors ligne

#28 05-02-2018 20:15:30

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.16.2
(G)UI : openbox
Inscription : 26-08-2010

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

calixtus06 a écrit :


xserver-xorg-video-nouveau:
  Installé : 1:1.0.13-3
  Candidat : 1:1.0.13-3
 Table de version :
 *** 1:1.0.13-3 500
        500 [url]http://ftp.fr.debian.org/debian[/url] stretch/main amd64 Packages
        500 [url]http://deb.debian.org/debian[/url] stretch/main amd64 Packages
        100 /var/lib/dpkg/status
root@GASPARD:/home/nicolas#
 


Ce qui montre que tu as installé la version 64 bits du driver nouveau, mais il faudra aussi
installer la version 32 bits pour steam !
Que dit :


apt-cache policy server-xorg-video-nouveau:i386
 

Dernière modification par enicar (05-02-2018 20:18:09)


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#29 05-02-2018 20:18:32

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.18.0-2-amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

n'oublies pas la commande  de enicar :

apt-cache policy server-xorg-video-nouveau:i386



aussi , tu peux copier - coller ici la commande suivante et son résultat :

cat /etc/apt/sources.list



pour ton problème de module r8169 :  https://debian-facile.org/viewtopic.php?id=9400

apt-get install firmware-realtek



sauf erreur  https://wiki.debian.org/fr/Multiarch/HOWTO

pour ton architecture complementaire i:386 ,

tu peux faire ceci :

dpkg --add-architecture i386



apt update && apt upgrade



et tout devrait être à jour pour ton multi arch .

à confirmer .

Dernière modification par Debian Alain (05-02-2018 20:55:03)


1498812139.jpg    Antonio Vivaldi - Winter (Trance Remix) 
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#30 05-02-2018 20:40:43

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

Pour le noyau:

dpkg -S /boot/vmlinuz-$(uname -r)
linux-image-4.9.0-4-amd64: /boot/vmlinuz-4.9.0-4-amd64
 


linux-image-4.9.0-4-amd64: /boot/vmlinuz-4.9.0-4-amd64


Il n'y a pas de mauvaises questions...

Hors ligne

#31 05-02-2018 20:42:03

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.16.2
(G)UI : openbox
Inscription : 26-08-2010

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

Je ne comprends pas pourquoi tu insistes pour partir d'une installation 64bits. Steam
fonctionne en 32 bits, ça serait plus simple d'installer un linux 32 bits. Ça évite d'avoir
à activer une autre architecture avec « dpkg --add-archictecture » que tu as peut-être oublié
après l'une de tes réinstallations…

La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#32 05-02-2018 21:10:09

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.16.2
(G)UI : openbox
Inscription : 26-08-2010

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

calixtus06 a écrit :

Pour le noyau:


dpkg -S /boot/vmlinuz-$(uname -r)
 



linux-image-4.9.0-4-amd64: /boot/vmlinuz-4.9.0-4-amd64
 


Donc les headers du noyau que tu dois installé seront : linux-headers-4.9.0-4-amd64, soit :


apt install linux-headers-4.9.0-4-amd64
 


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#33 05-02-2018 22:01:54

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.18.0-2-amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

pour ton fichier de .conf  (post #29) ,

une fois tapé dans nano , tu fais  <CTRL>  <O> puis <enter>

O la lettre , pas le chiffre "0" zéro .

une fois fait , tu reboote , et normalement , c'est bon . avec un peu de chance .

nb: vu tes difficultés , fais toi un "live" de debian , ça pourra t'aider à (re)démarrer en graphique .

disques "live" de debian

en "live" justement . même si ta config est cassée  tu pourras la récupérer .

comme ça , tu n'es pas obligé de tout réinstaller constamment .

ou alors , si tu t'y connais , ce qui n'est pas mon cas , tu peux redémarer en "recovery mode" (mode texte , sans graphiques) .

mais il n'y a pas d'internet en recovery . il faut le lancer à  part .

network manager en recovery mode

Dernière modification par Debian Alain (05-02-2018 22:50:10)


1498812139.jpg    Antonio Vivaldi - Winter (Trance Remix) 
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#34 06-02-2018 00:07:58

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

debian gnome en 32 bits pour simplement le client de steam sur mon pc ?

Why not ? ça m'oblige à tout refaire, pour éviter une commande dpkg

A part ça est ce que tout est bon pour télécharger steam depuis les dépôts ?

Il n'y a pas de mauvaises questions...

Hors ligne

#35 06-02-2018 00:20:56

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

Bon ben steam se lance puis s'arrête. J'ai un écran pour indiquer mon compte et au moment d'apparaître ...le fond d'écran turquoise de ma debian forme un rectangle et puis plus plouf

Dernière modification par calixtus06 (06-02-2018 00:35:05)


Il n'y a pas de mauvaises questions...

Hors ligne

#36 06-02-2018 09:30:35

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

Re bonjour,

Ce matin j'ai tout repris
Installé une debian 32 bit
Mis à jour les source list
Installer le nvidia 304:

apt install nvidia-legacy-304xx-driver



 apt install nvidia-driver nvidia-glx nvidia-kernel-dkms xserver-xorg-video-nvidia
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Aucune version du paquet nvidia-glx n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  nvidia-driver-bin nvidia-driver

E: Le paquet « nvidia-glx » n'a pas de version susceptible d'être installée
root@GASPARD:/home/gaspard#



Editer le .cong dans xorg en indiquant le nvidia 304:

Section "Device"
Identifier    "Video Card"
Driver        nvidia-legacy-304xx-driver
EndSection
 



Installer le linux header qui va bien :

apt install linux-headers-4.9.0-4-686



Installer steam:i386
et là...

steam


ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2018-02-06 08:29:42] Startup - updater built Nov 23 2016 01:05:42
Xlib:  extension "NV-GLX" missing on display ":0".
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

 



Tentative de démarrer steam avec l'icône : rien ne se passe

Reboot: l'ordi plante

reboot sur la clef usb: plantage aussi

Merci à tous

Dernière modification par calixtus06 (06-02-2018 14:29:35)


Il n'y a pas de mauvaises questions...

Hors ligne

#37 06-02-2018 11:51:09

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.18.0-2-amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

si ça peut aider  :  https://debian-facile.org/doc:jeux:steam?s

Steam

dpkg --add-architecture i386
apt-get update
apt-get upgrade
apt-get install libgl1-nvidia-glx:i386
apt-get update
apt-get install steam
Lien: https://debian-facile.org/doc:jeux:steam



steam  est un peu "capricieux" à installer .

il faut bien suivre la procédure et , en cas de lézard , effacer  soigneusement tout steam ( le remettre à zero ) avant de le réinstaller .

et quand je dis remettre à zero , c'est pas seulement effacer le programme mais aussi le(s) répertoires (ou directories) de  steam .

redémarrage et réinstallation .

demandes confirmation et  soutien à robert2a s'il est  dispo .

à moins que quelqu'un d'autre puisse  t'aider .

tu as  déjà au moins le répertoire caché   ./steam à supprimer avant de tout réinstaller dans l'ordre .

voire ci-dessus et ci dessous (liens) .

https://wiki.debian.org/fr/Steam

https://www.debian-facile.org/viewtopic.php?id=13773

peux tu , calixtus06 , nous donner le retour de

glxinfo -B



je te donne l'exemple chez moi :

name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: X.Org (0x1002)
    Device: Radeon RX 550 Series (POLARIS12 / DRM 3.23.0 / 4.15.1-amd64, LLVM 5.0.1) (0x699f)
    Version: 17.3.3
    Accelerated: yes
    Video memory: 4011MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
OpenGL vendor string: X.Org
OpenGL renderer string: Radeon RX 550 Series (POLARIS12 / DRM 3.23.0 / 4.15.1-amd64, LLVM 5.0.1)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.3.3
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 17.3.3
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.3.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
 



merci

Dernière modification par Debian Alain (06-02-2018 13:14:04)


1498812139.jpg    Antonio Vivaldi - Winter (Trance Remix) 
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#38 06-02-2018 14:09:32

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

Bonjour smile
Tu te mélanges entre les drivers Nvidia

calixtus06 a écrit :

apt install nvidia-legacy-304xx-driver


 apt install nvidia-driver


Tu installes une Debian 32 bits avec un noyau 686-pae
A vérifier après l’intallation avec la commande

uname -a


Tu ajoutes les dépôts contrib et non-free au sources.list
Tu mets à jour la liste des paquets et le système

apt update && apt upgrade


Tu installes le driver

apt install linux-headers-686-pae nvidia-legacy-304xx-driver


Je n’ai pas compris des propos d’enicar et robert2a s’il faut toujours faire le fichier de configuration, dans la mesure où le paquet nvidi-xconfig indique qu’il est déprécié :

The NVIDIA drivers now automatically integrate with the Xorg Xserver configuration. Creating an xorg.conf is no longer needed for normal setups.


Tu peux toujours le faire ou non tu ne le fais pas puisque c'est inutile sur stretch et c'est confirmé par robert2a bon d’apres èfpé post #41 il faut le faire ce fichier de configuration tongue
Edit : on ne fait plus le fichier de configuration sous stretch d'après les derniers messages
et tu redémarres puis tu nous donnes le retour de la commande de Debian Alain

glxinfo -B

Dernière modification par chalu (07-02-2018 13:46:11)

En ligne

#39 06-02-2018 16:03:43

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

Bonjour
dans mon #2 je te donne la commande aptitude (en simulation ) pour installer steam avec le paquet debian
les dépendances sont géré par ce paquet , rien a faire a coté
pour savoir si nouveau est bien installé la commande glxinfo -B  (du paquet mesa-utils )
pour le fichier xorg.conf depuis stretch il est inutile  , si tu me fait pas confiance l'installation du driver non free te donne un avertissement (pour redémarrer et créer le xorg.conf )
si ce n'est pas le cas inutile
si tu poste le retour de "glxinfo -B" et de "aptitude -s install steam" je te dirais si tout est correct .


glxinfo -B
 



aptitude -s install steam
 



pour ce qui est de la version du driver , effectivement tu mélange tout

l'utilitaire "nvidia-detect" du meme paquet te donnera la version du driver a installer en fonction de ta carte


apt-get install nvidia-detect
 


lancer la commande


nvidia-detect
 


retour pour moi


Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM206 [GeForce GTX 960] [10de:1401] (rev a1)

Checking card:  NVIDIA Corporation GM206 [GeForce GTX 960] (rev a1)
Your card is supported by the default drivers.
It is recommended to install the
    nvidia-driver
package.
 



nota : tu peu poster le retour aussi pour aider les intervenants .

pour le nvidia-xconfig  ne plus utiliser  , tu a un utilitaire graphique "nvidia-settings" sur le bureau  (pour les versions legacy 304 , 340 et  actuel )

pour un driver nonfree utiliser cette commande "apt install nvidia-legacy-304xx-driver"  c'est pas la bonne méthode (surtout pour un débutant )

pour une machine en amd64 ceci doit fonctionner (pour la version 304 ) (un copie collé dans ta console graphique )


apt-get install nvidia-legacy-304xx-kernel-dkms nvidia-settings-legacy-304xx nvidia-legacy-304xx-driver xserver-xorg-video-nvidia-legacy-304xx linux-headers-$(uname -r)
 




Please see the nvidia-legacy-304xx-kernel-dkms or
nvidia-legacy-304xx-kernel-source packages
for building the kernel module required by this package.
This will provide nvidia-legacy-304xx-kernel-304.137.
 



dans la console (avant de la fermer tu dois retrouver ceci  (ne regarde pas les versions elles seront différentes pour toi)


Paramétrage de nvidia-kernel-dkms (384.111-4) ...
Loading new nvidia-current-384.111 DKMS files...
Building for 4.14.0-3-amd64
Building initial module for 4.14.0-3-amd64
Done.

nvidia-current:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-3-amd64/updates/dkms/

nvidia-current-modeset.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-3-amd64/updates/dkms/

nvidia-current-drm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-3-amd64/updates/dkms/

nvidia-current-uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-3-amd64/updates/dkms/

depmod...

DKMS: install completed.
 


dkms a fait son travail et sans erreur

ceci aussi pour t 'indiquer que les liens sont recréés  (avec nouveau aussi , lorsque une demande d utilisation du driver ça la dirige vers les bon paquets )


Traitement des actions différées (« triggers ») pour nvidia-alternative (384.111-4) ...
update-alternatives: avertissement: forçage de la réinstallation de l'alternative /usr/lib/nvidia/current car le groupe de liens nvidia est cassé
 



désolé d'etre un peu technique mais j'ai lu pas mal de bétises .......  roll

nota : avec de la bouteille , on installe le driver nonfree de plusieurs manière , mais pour un débutant la méthode officielle avec dkms est la plus sure.
avec nouveau il n'y a rien a faire , juste installer le paquet steam
pour info si tu a fait une installation neuve en 32 bits , nouveau doit fonctionner sans xorg.conf , identique pour le driver nonfree
c'est dommage de passer en 32 , meme si pour une vielle machine c'est pas vital
la prise en charge du multiarch fonctionne très bien.
en général steam bug sur un driver mal installé , manque de ressources vidéo (a cause de nouveau ou d une carte trop ancienne ) ou des restes d une vieille installation de steam.

Dernière modification par robert2a (06-02-2018 16:46:07)

En ligne

#40 06-02-2018 19:39:45

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

robert2a a écrit :

désolé d'etre un peu technique mais j'ai lu pas mal de bétises .......  roll


c'est pas gentil ça roll

robert2a a écrit :

pour un driver nonfree utiliser cette commande "apt install nvidia-legacy-304xx-driver"  c'est pas la bonne méthode (surtout pour un débutant )


La commande exacte que j'ai donné c'est :

apt install linux-headers-686-pae nvidia-legacy-304xx-driver


Et je ne vois pas pourquoi elle ne convient pas sur son installation ?
elle installera le linux-headers qui va bien avec son noyau 686-pae et maintiendra à jour ce linux-headers
Et quand je reprends les paquets de la très longue commande que tu donnes :
nvidia-legacy-304xx-kernel-dkms nvidia-settings-legacy-304xx xserver-xorg-video-nvidia-legacy-304xx
ce sont des  dépendances du paquets nvidia-legacy-304xx-driver ou pour nvidia-settings-legacy-304xx un paquet recommandé mais qui vont être installés sur une Debian standard faite par un débutant, alors je ne vois pas bien pourquoi il faut les ajouter dans la commande ?
Le wiki officiel debian.org donne d'ailleurs une commande plus courte comme la mienne :

 apt install linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') nvidia-legacy-304xx-driver


robert2a a écrit :

lancer la commande

nvidia-detect


retour pour moi


Pour le coup, je crois que donner ton retour embrouillera un peu plus calixtus06 car il a donné ce retour de commande post #6

calixtus06 a écrit :

Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G72 [GeForce 7200 GS / 7300 SE] [10de:01d3] (rev a1)

Checking card:  NVIDIA Corporation G72 [GeForce 7200 GS / 7300 SE] (rev a1)
Your card is only supported up to the 304 legacy drivers series.
It is recommended to install the
    nvidia-legacy-304xx-driver
package.
 

root@GASPARD:/home/nicolas#


donc pas la peine de lui parler de nvidia-driver qui ne correspond pas à sa carte wink

En ligne

#41 06-02-2018 22:04:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

Bonsoir,

@chalu : la commande que tu proposes en #38/40 relève du bon sens... toutefois avant de décréter péremptoirement qu'un fichier de configuration est inutile, il conviendrait de tester effectivement l'installation d'un pilote nvidia-legacy ;

apt show nvidia-xconfig

Package: nvidia-xconfig
Version: 375.26-1
Priority: extra
Section: contrib/x11
Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Installed-Size: 242 kB
Pre-Depends: nvidia-installer-cleanup
Depends: libc6 (>= 2.14)
Recommends: libgl1-nvidia-glx-any
Homepage: ftp://download.nvidia.com/XFree86/nvidia-xconfig/
Download-Size: 82,1 kB
APT-Sources: http://httpredir.debian.org/debian stretch/contrib amd64 Packages
Description: deprecated X configuration tool for non-free NVIDIA drivers
 This tool is deprecated. The NVIDIA drivers now automatically integrate with
 the Xorg Xserver configuration. Creating an xorg.conf is no longer needed for
 normal setups.
 .
 The nvidia-xconfig program helps with manipulation of X configuration
 files, primarily for systems that use the non-free drivers provided by
 NVIDIA.  It automatically changes the configuration to use the NVIDIA
 driver and can add additional options given on the command line.
 


La mention deprecated concerne explicitement une version 375.xx, de plus le wiki officiel distingue les versions 375, 340 et 304 (pas de fichier pour la première, fichier pour les deux autres), par ailleurs le retour d'enicar en #20 est parfaitement clair et sans ambiguïté, ce qui n'est pas le cas du retour fait sur un autre fil.

Dernière modification par èfpé (06-02-2018 22:24:42)

Hors ligne

#42 06-02-2018 22:21:51

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

péremptoire scratchhead.gif
J’ai corrigé d’après le message de robert2a qui semble avoir toute une collection de Nvidia à tester tongue
Il faut dire que le wiki officiel au sujet de cette configuration n’est pas très clair puisque le lien vers le fichier de configuration renvoie vers le même paragraphe où il est question pour une configuration automatique  du paquet nvidia-xconfig que l’on voit ensuite déprécié scratchhead.gif
Je re-rectifie alors peace_flag.gif
Et je teste pas, j’ai une ATI lol

En ligne

#43 06-02-2018 22:31:15

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.18.0-2-amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

chalu a écrit :

Et je teste pas, j’ai une ATI


oups ! merci chalu ops.gif

moi aussi  . out.gif

Dernière modification par Debian Alain (06-02-2018 23:16:51)


1498812139.jpg    Antonio Vivaldi - Winter (Trance Remix) 
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#44 07-02-2018 00:43:02

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

Bonsoir, je suis perdu dans vos messages. J'attends une carte plus récente et de meilleure qualité que cette bas de gamme de g72. On en reparle.

Il n'y a pas de mauvaises questions...

Hors ligne

#45 07-02-2018 01:41:37

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

èfpé a écrit :

Bonsoir,

@chalu : la commande que tu proposes en #38/40 relève du bon sens... toutefois avant de décréter péremptoirement qu'un fichier de configuration est inutile, il conviendrait de tester effectivement l'installation d'un pilote nvidia-legacy ;

apt show nvidia-xconfig

Package: nvidia-xconfig
Version: 375.26-1
Priority: extra
Section: contrib/x11
Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Installed-Size: 242 kB
Pre-Depends: nvidia-installer-cleanup
Depends: libc6 (>= 2.14)
Recommends: libgl1-nvidia-glx-any
Homepage: ftp://download.nvidia.com/XFree86/nvidia-xconfig/
Download-Size: 82,1 kB
APT-Sources: http://httpredir.debian.org/debian stretch/contrib amd64 Packages
Description: deprecated X configuration tool for non-free NVIDIA drivers
 This tool is deprecated. The NVIDIA drivers now automatically integrate with
 the Xorg Xserver configuration. Creating an xorg.conf is no longer needed for
 normal setups.
 .
 The nvidia-xconfig program helps with manipulation of X configuration
 files, primarily for systems that use the non-free drivers provided by
 NVIDIA.  It automatically changes the configuration to use the NVIDIA
 driver and can add additional options given on the command line.
 


La mention deprecated concerne explicitement une version 375.xx, de plus le wiki officiel distingue les versions 375, 340 et 304 (pas de fichier pour la première, fichier pour les deux autres), par ailleurs le retour d'enicar en #20 est parfaitement clair et sans ambiguïté, ce qui n'est pas le cas du retour fait sur un autre fil.



Donc tu me traite de menteur , 

pour ceci


 toutefois avant de décréter péremptoirement qu'un fichier de configuration est inutile, il conviendrait de tester effectivement l'installation d'un pilote nvidia-legacy ;
 



ce n'est pas un problème de driver  , puisque le driver fait partie de stretch . (304 , 340 et autres )
je pense que le sujet est clos pour moi

en #30 nonours confirme qu'il fonctionne sans xorg.conf => https://debian-facile.org/viewtopic.php … 83#p252083

pour ceci c'est faux , (je peu pas mettre a jour les tutos de debian tongue ) je parle a partir de stretch (pour jessie je n' affirme pas , pour wheezy le xorg.conf est obligatoire )


de plus le wiki officiel distingue les versions 375, 340 et 304 (pas de fichier pour la première, fichier pour les deux autres)
 


nota: j'ai commencé a triturer le xorg en 2014 (sous wheezy) sinon début des années 2000 avec une woodoo 2 et glide
le driver est chargé par KMS et ensuite le serveur X met sa couche .
il te suffit d installer une stretch minimale (type serveur) avec une carte reconnu par le noyau (sans serveur X) tu aura directement la résolution native de ton écran
Wayland fonctionne trés bien , tu expliquera comment il fait pour charger le bon driver (que ce soit driver libre ou propriétaire ça ne change rien )

pour enicar un peu d'explication , quelle debian , quelle carte graphique , quel driver
le xorg.cong ne sert que pour mettre des options , faire une configuration statique (pour le multi-écran) , résoudre un bug (pour certain gpu intel assez ancien etc ........ )

pour faire plaisir a tout le monde et ça ne change rien
pour nouveau


Section "Device"
Identifier    "Device0"
Driver        "nouveau"
EndSection
 


pour nvidia


Section "Device"
Identifier    "Device0"
Driver        "nvidia"
EndSection
 


pour amd radeon


Section "Device"
Identifier    "Device0"
Driver        "radeon"
EndSection
 


pour amd amdgpu


Section "Device"
Identifier    "Device0"
Driver        "amdgpu"
EndSection
 


pour intel


Section "Device"
Identifier    "Device0"
Driver        "intel"
EndSection
 


etc ....  je n'ai mit que les plus connu
ça fonctionne a tout les coup

@èfpé
tu a éffacé ton #9 c'est déja mieux , certain conseil sont a éviter avec des débutants meme si nous on jongle avec l'installation sans etre trés rigoureux (en général on connait bien notre affaire )

pour nvidia-detect je ne l'ai jamais pris en défaut mais pour confirmer il est toujours possible de faire un tour sur le site de nvidia et de faire une recherche de driver pour une référence de carte

@chalu
pour avoir toutes les dépendances peut etre comme ceci si dkms ne vous convient pas.


apt-get install xserver-xorg-video-nvidia-legacy-304xx nvidia-settings-legacy-304xx nvidia-legacy-304xx-driver
 


ps: le nvidia-setting c'est pour avoir l utilitaire graphique pour les cartes nvidia (sur le wiki il doit manquer le nvidia-legacy-304xx-driver sur la commande , qui est un méta paquet depuis stretch mais utile pour les dépendances )
le wiki a été mit a jour a l'époque de Jessie
nota : parfois il faut etre "pas gentil" pour faire avancer les choses (tout en restant poli wink   )
j'ai pas la prétention de tout savoir sur toutes les machines et toutes les cartes nvidia et toutes les versions de debian .
sur certaines machines le remplacement de la carte a résolu les problèmes (carte trop anciennes , noyau trop récent etc ..... )

Dernière modification par robert2a (07-02-2018 03:18:29)

En ligne

#46 07-02-2018 05:51:06

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

Bonjour

j'ai testé une 6800 nvidia sous nouveau (le paquet ) , puis KMS  (nouveau de modesetting) , installé steam  sans fichier /etc/X11/xorg.conf


apt-get install nvidia-legacy-304xx-kernel-dkms nvidia-settings-legacy-304xx nvidia-legacy-304xx-driver xserver-xorg-video-nvidia-legacy-304xx linux-headers-$(uname -r)
 


retour


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
linux-headers-4.9.0-4-amd64 is already the newest version (4.9.65-3+deb9u1).
The following additional packages will be installed:
  glx-alternative-mesa glx-alternative-nvidia glx-diversions libgl1-nvidia-legacy-304xx-glx libgl1-nvidia-legacy-304xx-glx:i386 libnvidia-legacy-304xx-cfg1
  libnvidia-legacy-304xx-cfg1:i386 libnvidia-legacy-304xx-glcore libnvidia-legacy-304xx-glcore:i386 libnvidia-legacy-304xx-ml1 libxv1:i386 libxvmc1
  libxvmc1:i386 nvidia-installer-cleanup nvidia-kernel-common nvidia-legacy-304xx-alternative nvidia-legacy-304xx-driver-bin
  nvidia-legacy-304xx-driver-libs nvidia-legacy-304xx-driver-libs:i386 nvidia-legacy-304xx-driver-libs-i386:i386 nvidia-legacy-304xx-kernel-support
  nvidia-legacy-304xx-vdpau-driver nvidia-modprobe nvidia-persistenced nvidia-support
Paquets suggérés :
  nvidia-driver
Les NOUVEAUX paquets suivants seront installés :
  glx-alternative-mesa glx-alternative-nvidia glx-diversions libgl1-nvidia-legacy-304xx-glx libgl1-nvidia-legacy-304xx-glx:i386 libnvidia-legacy-304xx-cfg1
  libnvidia-legacy-304xx-cfg1:i386 libnvidia-legacy-304xx-glcore libnvidia-legacy-304xx-glcore:i386 libnvidia-legacy-304xx-ml1 libxv1:i386 libxvmc1
  libxvmc1:i386 nvidia-installer-cleanup nvidia-kernel-common nvidia-legacy-304xx-alternative nvidia-legacy-304xx-driver nvidia-legacy-304xx-driver-bin
  nvidia-legacy-304xx-driver-libs nvidia-legacy-304xx-driver-libs:i386 nvidia-legacy-304xx-driver-libs-i386:i386 nvidia-legacy-304xx-kernel-dkms
  nvidia-legacy-304xx-kernel-support nvidia-legacy-304xx-vdpau-driver nvidia-modprobe nvidia-persistenced nvidia-settings-legacy-304xx nvidia-support
  xserver-xorg-video-nvidia-legacy-304xx
0 mis à jour, 29 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 22,0 Mo/22,2 Mo dans les archives.
Après cette opération, 116 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
 



la suite


update-alternatives: mise à jour de l'alternative /usr/lib/nvidia/legacy-304xx car le groupe de liens nvidia contient des liens esclaves modifiés
Paramétrage de nvidia-legacy-304xx-kernel-dkms (304.135-2) ...
Loading new nvidia-legacy-304xx-304.135 DKMS files...
Building for 4.9.0-4-amd64 4.9.0-5-amd64
Building initial module for 4.9.0-4-amd64
Done.

nvidia-legacy-304xx:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.9.0-4-amd64/updates/dkms/

depmod.........

DKMS: install completed.
Building initial module for 4.9.0-5-amd64
Done.

nvidia-legacy-304xx:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.9.0-5-amd64/updates/dkms/

depmod.........

DKMS: install completed.
Paramétrage de nvidia-legacy-304xx-driver (304.135-2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u1) ...
Traitement des actions différées (« triggers ») pour update-glx (0.7.4) ...
Traitement des actions différées (« triggers ») pour glx-alternative-nvidia (0.7.4) ...
update-alternatives: utilisation de « /usr/lib/nvidia » pour fournir « /usr/lib/glx » (glx) en mode automatique
Traitement des actions différées (« triggers ») pour menu (2.1.47+b1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u1) ...
Traitement des actions différées (« triggers ») pour initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.9.0-5-amd64
W: APT had planned for dpkg to do more than it reported back (150 vs 156).
   Affected packages: glx-diversions:amd64
 



je lance steam en console "user"


/usr/games/steam %U
 


retour


Running Steam on debian 9 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
[2018-02-07 05:07:07] Startup - updater built Dec 15 2017 11:47:44
[2018-02-07 05:07:08] Verifying installation...
[2018-02-07 05:07:08] Verification complete
[2018-02-07 05:07:28] Shutdown
 



le retour de glxinfo -B


glxinfo -B
 


retour


name of display: :0
display: :0  screen: 0
direct rendering: Yes
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 6800/PCIe/SSE2
OpenGL version string: 2.1.2 NVIDIA 304.135
OpenGL shading language version string: 1.20 NVIDIA via Cg compiler

OpenGL ES profile version string: OpenGL ES 2.0 NVIDIA 304.135 304.135
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.00
 



j'ai testé nouveau , steam se lance bien , en fonction de ta carte graphique et de la puissance de ta machine certain jeux risque de ne pas fonctionner

glxinfo -B sous le driver libre nouveau


glxinfo -B
 


retour


name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: nouveau (0x10de)
    Device: NV41 (0xc1)
    Version: 13.0.6
    Accelerated: yes
    Video memory: 238MB
    Unified memory: no
    Preferred profile: compat (0x2)
    Max core profile version: 0.0
    Max compat profile version: 2.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 2.0
OpenGL vendor string: nouveau
OpenGL renderer string: Gallium 0.4 on NV41
OpenGL version string: 2.1 Mesa 13.0.6
OpenGL shading language version string: 1.20

OpenGL ES profile version string: OpenGL ES 2.0 Mesa 13.0.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16
 



Après il reste le cas d une carte incompatible avec nouveau (ou/et KMS)  mais le driver propriétaire doit résoudre ce souci

le retour de lspci pour la machine


lspci
 


retour


00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890S/SR5650 Host Bridge (rev 02)
00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890/RD9x0/RX980 PCI to PCI bridge (PCI Express GFX port 0)
00:09.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890/RD9x0/RX980 PCI to PCI bridge (PCI Express GPP Port 4)
00:0a.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890/RD9x0/RX980 PCI to PCI bridge (PCI Express GPP Port 5)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 3d)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 5
00:19.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 0
00:19.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 1
00:19.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 2
00:19.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 3
00:19.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 4
00:19.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 5
01:00.0 VGA compatible controller: NVIDIA Corporation NV41 [GeForce 6800] (rev a2)
02:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
03:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
 



donc sur une installation neuve ça doit fonctionner sous nouveau (j'ai installé steam sous le driver libre et seulement après le driver propriétaire )

le log de l'installation de steam avec aptitude


aptitude install steam
 


retour


Note: selecting "steam:i386" instead of the virtual package "steam"
Les NOUVEAUX paquets suivants vont être installés :
  fonts-liberation{a} libbsd0:i386{a} libdrm-amdgpu1:i386{a} libdrm-intel1:i386{a} libdrm-nouveau2:i386{a} libdrm-radeon1:i386{a} libdrm2:i386{a}
  libedit2:i386{a} libelf1:i386{a} libexpat1:i386{a} libffi6:i386{a} libgcrypt20:i386{a} libgl1-mesa-dri:i386{a} libgl1-mesa-glx:i386{a}
  libglapi-mesa:i386{a} libgpg-error0:i386{a} libgpm2:i386{a} libllvm3.9:i386{a} libncurses5:i386{a} libpciaccess0:i386{a} libsensors4:i386{a}
  libstdc++6:i386{a} libtinfo5:i386{a} libtxc-dxtn-s2tc:i386{a} libudev1:i386{a} libx11-6:i386{a} libx11-xcb1:i386{a} libxau6:i386{a}
  libxcb-dri2-0:i386{a} libxcb-dri3-0:i386{a} libxcb-glx0:i386{a} libxcb-present0:i386{a} libxcb-sync1:i386{a} libxcb1:i386{a} libxdamage1:i386{a}
  libxdmcp6:i386{a} libxext6:i386{a} libxfixes3:i386{a} libxinerama1:i386{a} libxshmfence1:i386{a} libxss1:i386{a} libxxf86vm1:i386{a} steam:i386
  zlib1g:i386{a}
0 paquets mis à jour, 44 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 23,0 Mo/24,1 Mo d'archives. Après dépaquetage, 193 Mo seront utilisés.
Voulez-vous continuer ? [Y/n/?] y
 



une partie du log de X (prise en charge de la 3D pour les jeux )


[    31.091] (--) Depth 24 pixmap format is 32 bpp
[    31.099] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[    31.341] (==) NVIDIA(0): Disabling shared memory pixmaps
[    31.341] (==) NVIDIA(0): Backing store enabled
[    31.341] (==) NVIDIA(0): Silken mouse enabled
[    31.349] (==) NVIDIA(0): DPMS enabled
[    31.349] (II) Loading sub module "dri2"
[    31.349] (II) LoadModule: "dri2"
[    31.349] (II) Module "dri2" already built-in
[    31.349] (II) NVIDIA(0): [DRI2] Setup complete
[    31.349] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    31.350] (--) RandR disabled
[    31.359] (II) SELinux: Disabled on system
[    31.367] (II) Initializing extension GLX
[    31.367] (II) Indirect GLX disabled.
 



Faut persévérer , il n'y pas de raison que ça ne fonctionne pas

ps: aucune erreur sous nouveau ou le propriétaire nvidia


journalctl -r -p err
 


retour


-- Logs begin at Wed 2018-02-07 05:05:08 CET, end at Wed 2018-02-07 05:36:47 CET. --
févr. 07 05:06:00 debiantest1 pulseaudio[1042]: [pulseaudio] pid.c: Daemon already running.
févr. 07 05:05:14 debiantest1 kernel: kvm: disabled by bios
 

Dernière modification par robert2a (07-02-2018 06:39:18)

En ligne

#47 07-02-2018 07:59:01

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

@robert2a : dans la dernière commande de ton post #45 tu cites une dépendance ce qui est inutile et par contre tu oublies le paquet linux-headers-** qui va avec le noyau
Donc si tu veux tenir compte de celui qui aurait bidouillé la configuration par défaut de Debian pour ne pas installer les paquets recommandés, la bonne commande est :
Avec un noyau de stretch 686-pae :

apt install linux-headers-686-pae nvidia-legacy-304xx-driver nvidia-persistenced nvidia-settings-legacy-304xx


Avec un noyau stretch amd64 :

apt install linux-headers-amd64 nvidia-legacy-304xx-driver nvidia-persistenced nvidia-settings-legacy-304xx


Mais encore une fois les deux derniers sont des paquets recommandés qui s’installent sur une configuration standard.

@calixtus06 : en te voyant perdu dans les messages, je t’ai fait un résumé post#38 smile pour ta carte actuelle et tu ne fais pas le fichier de configuration, j’ai rayé ce point.
Ceci dit tu as raison sur un point , si ta carte est très vieille il y a un risque qu’elle ne suffise pas pour les jeux smile

En ligne

#48 07-02-2018 08:14:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

Bonjour,

robert2a a écrit :

Donc tu me traites de menteur,

Euh non... ce n'était pas mon propos, mais puisque nous avons tous deux passé l'âge des enfantillages, je te propose de ne pas épiloguer.

Quoi qu'il en soit, merci à toi d'avoir pris le temps de tester une vieille carte NV41 (2004, environ ?) ; tenter avec nouveau paraît plus que raisonnable, d'autant que j'avais constaté quelques bogues chiants avec le pilote propriétaire en version 340, sous Wheezy du moins (écran psychédélique et perte de la console en sortie de veille, notamment), bon d'accord, là c'est pour jouer.

Quant à persévérer, calixtus06 aurait certainement besoin d'un vrai tuto pas à pas, depuis la post-installation (comprenant la mise à jour et le redémarrage du système, parce que sauf erreur de ma part, le noyau stable actuel est le 4.9.0-5/4.9.65-3+deb9u2).

(Pour ce qui est de l'installation du pilote propriétaire, j'ai simulé et je ne vois toujours pas l'intérêt de cette commande à rallonge, mais bon, je n'insiste pas, je ne suis qu'un simple mortel.)

Dernière modification par èfpé (07-02-2018 08:24:42)

Hors ligne

#49 07-02-2018 08:52:53

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

@chalu

avec dkms pas besoin d installer les headers avant (dkms le fera automatiquement) et en plus sur mes machines il est toujours installé donc je l'ai oublié  tongue
sinon la commande a rallonge c'est du 100% sur , par exemple vous ne faite pas appel au xserver-xorg-video-nvidia-legacy-304xx dans votre commande , il peu arriver qu il soit absent et le driver ne fonctionnera pas .
j'installe les drivers avec synaptic donc je ne discute pas la méthode , mais quelqu un qui fait cela pour la première fois il faut quelque chose de sérieux , surtout quand je lit  "je réinstalle debian"
après un échec .
il y 4 ans il était plus compliqué d installer un serveur X et plus facile de se tromper.
sinon ce n'est pas la première fois que je teste de vieilles cartes vidéo , le forum en est plein de mes tests (des GT8800 par exemple ) en libre ou en propriétaires
sinon j'espère que calixtus06 va y arriver , sur Steam beaucoup de post n'ont pas de retour avec succès   hmm
Bon je vous laisse finir cet affaire  wink

Dernière modification par robert2a (07-02-2018 16:59:47)

En ligne

#50 07-02-2018 11:37:01

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.18.0-2-amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : [RESOLU]STEAM ne se lance pas, comment faire ?

j'ai pas  envie de f***** le b****l dans la  discussion mais si calixtus pouvait répondre à nos demandes ,

au lieu de s'éparpiller . ça pourrai aussi nous permettre de mieux le  conseiller .

je comprends son désir d'apprendre à se  débrouiller tout seul .

comme dit le dicton :

donne un poisson à un homme affamé , tu le nourris pour un repas ;
apprends à pêcher à un homme affamé , tu le nourriras pour la vie ;



malheureusement , son empressement le conduit tout droit dans la confusion .

calixtus devrait , avec l'aide  du forum bien sûr , procéder par étapes , progressivement .

et ne surtout pas les bûler . c'est le meilleur moyen d'entrer dans le désordre et la confusion et par là même , l'incompréhension .

déjà , pour ce problème d' O.S. 32 / 64 bits , si calixtus pouvait nous fournir les références complètes  de sa carte mère ( et / ou de son pc ) ,

ce serai chouette et ça règlerai un flou , présent depuis le départ dans ce fil .

Debian Alain  a écrit :

(post #26 , début page 2)
pour aller plus loin , il nous faudrait la marque et le type de ta carte mère .

(références complètes) .

Dernière modification par Debian Alain (07-02-2018 12:08:21)


1498812139.jpg    Antonio Vivaldi - Winter (Trance Remix) 
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

Pied de page des forums