Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-02-2010 18:03:00

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

(Résolu] Connexion internet très lente par livebox

Boujour à toutes et à tous,

J'ai un problème avec ma nouvelle livebox d'orange (accès internet + télévision +téléphone illimité). Celle que j'avais perdait de plus en plus souvent la connexion, et alors plus d'accès internet ni de télé. Je l'éteignais pour quelques minutes, puis je la rallumais et çà repartait. Comme cela se produisait plusieurs fois en quelques heures, je me suis décidé à demander à Orange d'échanger cette livebox, ce qui m'a été accordé, vu qu'elle est louée.

Vendredi dernier j'ai fait un premier échange, pour une du même modèle (inventel). Pas moyen de la faire marcher: un seul voyant s'allumait, celui du téléphone. J'appelle l'assistance technique qui, après m'avoir fait vérifier l'installation, déclare que la livebox est défectueuse et me donne un nouveau bon d'échange.

Hier samedi, deuxième échange. Plus de livebox inventel en magasin, je prends donc une livebox sagem.

L'installation se fait sans problème. La tv marche, je peux accéder à internet. le téléphone illimité n'a été mis en service que 24 heures plus tard, mais maintenant il marche.

Tout ne baigne pas pour autant! Mon accès internet est beaucou plus lent qu'avant. Par exemple, lorsque
dans le marque-pages de mon navigateur, je choisis Debian facile, çà rame pendant plus d'une minute et demie avant d'afficher la page d'accueil. Une fois qu'elle s'affiche et que je clique sur "Identifiez-vous", çà rame encore pendant au moins 45 secondes avant de me présenter la page demandant identifiant et mot de passe. Et c'est pareil chaque fois que je veux changer de page.

Comme j'ai une partition windows (dont je ne me sers presque jamais) j'ai essayé de surfer sur internet sous windows. Je passe sur les engueulades prodiguées par Norton lorsqu'il constate que je n'ai pas renouvelé mon abonnement antivirus! Mais une fois Firefox lancé, la navigation se fait à vitesse normale.

J'ai essayé de surfer sur internet après avoir démarré mon ordinateur avec un cd live (sidux). Je n'en suis pas tout à fait sûr parce que je ne suis pas familiarisé avec le navigateur de ce cd live (konqueror), mais il me semble bien que comme sous windows, la vitesse de navigation est normale;

J'ai un second ordinateur portable, un compaq armada E500, fonctionnant aussi sous Debian Lenny. J'ai essayé de surfer sur internet avec ce portable de secours: le même défaut se manifeste, c'est très lent.

J'ai aussi un très ancien compaq presario équipé d'un amdk6, fonctionnant sous Debian Lenny, mais je n'ai pas encore essayé de surfer sur internet avec. Je suis presque sûr que ce sera pareil qu'avec les portables.

Demain lundi j'appellerai l'assistance technique Orange, mais j'ai peu d'espoir de ce côté: vu que çà marche normalement sous windows, l'assistance estimera que tout va bien!

Toute suggestion pouvant m'aider à comprendre ce qui se passe sera reçue avec reconnaissance.

Amicalement,

C.-M. M.

Dernière modification par cmm (23-02-2010 10:41:59)

Hors ligne

#2 21-02-2010 23:35:00

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : (Résolu] Connexion internet très lente par livebox

Bonjour cmm smile

D'arès la description que vous nous en donnez, le problème semble bien lié aux machines sous Debian. Je suppose que vous avez des configurations fixes (par opposition à DHCP)? Pourriez vous confirmer ce point svp.

Un test simple:
Si vous faites un ping wanadoo.fr depuis une console, le système renvoie une première ligne du genre
PING wanadoo.fr (193.252.122.103) 56(84) bytes of data.

L'ip peut ne pas être la même que ci-dessus mais cela est sans importance.
Ensuite viennent en principe les lignes de ping
64 bytes from www.orange.fr.b2.fti.net (193.252.122.103): icmp_seq=1 ttl=247 time=63.3 ms
64 bytes from www.orange.fr.b2.fti.net (193.252.122.103): icmp_seq=2 ttl=247 time=64.0 ms


Le délai d'attente existe-il entre le lancement de la commande et l'affichage de la première ligne?
Si c'est le cas, il faudra investiguer du côté de la résolution de noms (DNS). Dans le cas contraire... j'y réfléchirai. big_smile

cordialement,

Hors ligne

#3 22-02-2010 00:15:33

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : (Résolu] Connexion internet très lente par livebox

Bonsoir tux12 et merci pour votre réponse.

La commande ping wanadoo.fr entraîne, immédiatement, la réponse:

PING wanadoo.fr (193.252.122.103) 56(84) bytes of data.

Le délai pour l'affichage de cette ligne est trop petit pour être mesuré avec ma montre (une fraction de seconde, çà paraît immédiat).

Puis 15 secondes environ après:

64 bytes from 193.252.122.103: icmp_seq=1 ttl=248 time=50.7 ms

Puis des lignes analogues, avec un "tme" en millisecondes variant entre 34.5 et 114, une nouvelle ligne toutes les 15 secondes environ.

Par ailleurs j'ai essayé un peu plus longuement de surfer sous sidux. Cela me semble plus rapide que sous debian mais je n'en suis pas très sûr car la machine se met parfois à lire le cdlive et alors çà ralentit.
Par contre sous windows, aucun doute, c'est bien plus rapide que sous debian, à peu près comme c'était avec ma précédente livebox.

Cordialement,

C.-M. M.

Hors ligne

#4 22-02-2010 00:50:42

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : (Résolu] Connexion internet très lente par livebox

Ok. Donc ça ne semble pas être lié au DNS. Il semblerait qu'une différence de configuration de la nouvelle LiveBox soit à l'origine du problème. Je propose de chercher à le résoudre à partir d'une des machines. On ne devrait plus avoir après qu'à adapter les autres, ou à retrouver l'ancienne configuration de box.

Ceci dit je n'ai pas d'idée précise. Quelques questions donc;
- Vous pouvez accéder à l'interface de gestion de la box (http://192.168.x.y) ?
- Qu'elle est l'IP de la box (192.168.x.y)?
- Contenu du /etc/network/interface
- les paquets avahi-daemon et network-manager sont-ils installés?

Hors ligne

#5 22-02-2010 09:24:02

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : (Résolu] Connexion internet très lente par livebox

Bonjour tux12, et merci de vous intéresser à mon problème.

J'ai oublié dans mon précédent message de répondre à votre question: configuration fixe ou DHCP. Je suis en DHCP, je crois. J'ai un boîtier D-Link avec plusieurs prises ethernet; normalement, le câble de sortie ethernet de la livebox est connecté à une de ces prises, et chacun de mes ordinateurs à une autre. Ainsi je peux, depuis un des ordinateurs, accéder à certains dossiers des autres. C'est ce boîtier (ou la livebox?) qui envoie à chaque ordinateur son adresse IP. J'ai remarqué que c'était toujours la même, mais que la nouvelle livebox donne des numéros différents de ceux que donnait l'ancienne. Du coup, comme je n'ai pas encore modifié les fichiers de réglage du réseau local, je ne peux plus, depuis un des ordinateurs, accéder aux autres. Mais là n'est pas le problème, je sais ce qu'il faut faire pour arranger çà.

J'ai bien sûr essayé de brancher direct la sortie ethernet de la livebox à la prise ethernet de l'ordinateur, sans passer par le boîtier D-Link. Cela ne change rien, la connexion est toujours aussi lente.

Je réponds maintenant aux questions de votre dernier message.

Oui, je peux accéder à l'interface de gestion de la livebox. Son IP est 192.168.1.1. Lorsque je tape cette adresse IP dans un onglet du navigateur la page s'affiche immédiatement, il n'y a pas ce délai d'une minute
environ qui existe à chaque changement de page lors d'une navigation sur internet.

Le contenu de /etc/network/interfaces est

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp


Le paquet avahi-daemon est installé. Le paquet network-manager ne l'est plus depuis quelques mois: je l'avais auparavant mais il me faisait des ennuis lorsque j'essayais, à l'extérieur de chez moi, de me connecter par wifi. Je l'ai remplacé par wicd network manager qui, pour moi, semble mieux fonctionner pour le wifi.

Un dernier mot: j'ai essayé de surfer sur internet en démarrant mon ordinateur avec un cd live ubuntu 8-10
(qui ressemble plus à la configuration à laquelle je suis habitué, que le cd live sidux). Pas de doute, la navigation est tout à fait normale, bien plus rapide que sous debian.

Amicalement,

C.-M. M.

Hors ligne

#6 22-02-2010 10:15:54

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : (Résolu] Connexion internet très lente par livebox

Salut cmm,

Comme tu peux le lire ici :
http://debian-facile.org/doc:reseau:network-manager

Section mise en garde, Wicd, bien que particulier, est l'égal dans son fonctionnement que network-manager.

Donc, dans une configuration à la mano ou exotique, il doit être désactivé, voire désinstallé pour ne plus perturber de ses irc personnelles les irc imposées dan le fichier interfaces.

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#7 22-02-2010 11:46:37

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : (Résolu] Connexion internet très lente par livebox

Merci Joël,  de m'indiquer ces mises en garde que je ne connaissais pas.

Je vais peut-être essayer de désinstaller wicd, dont je n'ai besoin que lorsque je me connecte par wifi hors de chez moi (ce qui est rare) afin de voir si c'est çà qui ralentit les connexions internet. Mais peut-être pas tout de suite car j'ai un travail (non informatique) à terminer.

Amitiés,

C.-M. M.

Hors ligne

#8 22-02-2010 22:23:38

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : (Résolu] Connexion internet très lente par livebox

Bonjour cmm,

Au vu des éléments que vous nous donnez ... je suis désemparé. J'espèrais une configuration fixe qui aurait pu contenir des réglages inadaptés, mais en DHCP c'est la box qui donne les paramètres (je suppose que le boitier D-link que vous mentionnez est un switch).

A tout hasard, pourriez vous m'indiquer
- le résultat d'un ifconfig eth0 (en root)
- le résultat d'un route -n (en root)
- le modéle/constructeur de la box depuis la liste des box dans le lien ci-avant.

Merci smile

Hors ligne

#9 23-02-2010 08:42:31

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : (Résolu] Connexion internet très lente par livebox

Bonjour tux 12,

Oui, le boîtier d-link que je mentionne est un switch (ou un hub? je ne sais pas bien la différence entre les deux).

Ne prenez pas trop à coeur mon problème: ce n'est pas si grave, mon courrier électronique, même avec des pièces jointes, se charge à vitesse normale; j'ai essayé de télécharger quelques gros fichiers (le dernier debian netinstall), les téléchargements se font à vitesse normale. Ce qui est lent, c'est le passage d'une page à une autre quand on surfe sur le web. C'est agaçant, mais pas dramatique.

Je me demande si mes ennuis ne viennent pas de la configuration de iceweasel. En effet, j'avais, il y a assez longtemps, sur mes deux ordinateurs portables, configuré iceweasel pour qu'ils utilisent le proxy de mon lieu de travail (l'institut de maths de Jussieu) pour avoir accès aux documents et aux abonnements aux journaux électroniques de la bibliothèque. En fait cette opération n'avait pas donné un très bon résultat: j'avais accès à certains documents depuis mon domicile,  mais pas à tous: il y en avait certains que j'arrivais à télécharger depuis un poste de travail sur place, mais pas depuis mon domicile. Cette configuration ne me sert plus à grand chose, je vais essayer de la modifier.

Je viens d'essayer de surfer sur le web avec un autre navigateur, epiphany, que je n'ai pas configuré pour passer par un proxy, et il me semble que çà surfe à vitesse normale! Si c'est cela l'explication, il reste à comprendre pourquoi, avec mon ancienne livebox, le problème ne se manifestait pas! à moins que, par hasard, il y ait eu des modifications sur le réseau de l'institut de maths, indépendamment, mais au moment où j'ai changé de livebox?

Voici les réponses à vos questions:

7:03 root@Lyra /home/charles# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:1b:24:65:77:a6  
          inet adr:192.168.1.10  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::21b:24ff:fe65:77a6/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1275 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1420 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:1110963 (1.0 MiB)  TX bytes:228578 (223.2 KiB)
          Interruption:252

7:03 root@Lyra /home/charles# route -n
Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0


La livebox que j'ai maintenant est une livebox sagem. Avant, j'avais une livebox thomson/inventel.

Merci encore pour votre aide. Je vais faire les modifications de configuration de iceweasel et je vous indiquerai les résultats.

Amicalement,

C.-M. M.

Hors ligne

#10 23-02-2010 10:40:12

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : (Résolu] Connexion internet très lente par livebox

Re-bonjour!

OK l'origine de mon problème est identifiée, c'est bien la configuration de iceweasel. Dans le menu "Préférences-Avancé-Réseau-Paramètres", la case "Adresse de configuration automatique du proxy"
était cochée, avec pour adresse http://math.jussieu.fr.revues.pac/.

Il a suffi de cocher, à la place, la case "Pas de proxy" (ce qui a automatiquement décoché la case
"Adresse de configuration automatique du proxy") pour que après reboot, la vitesse de navigation redevienne normale.

Je ne comprends toujours pas pourquoi le problème ne se manifestait pas avec mon ancienne livebox, mais cela fait sans doute partie des mystères insondables de l'informatique.

Merci à tux12 et à Joël pour leur aide. J'espère qu'ils voudront bien m'excuser d'avoir embêté tout le monde avec un problème qui, finalement, n'est pas lié à Debian!

Amicalement,

C.-M. M.

Hors ligne

#11 23-02-2010 11:35:34

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : (Résolu] Connexion internet très lente par livebox

Merci cmm !

Et d'avoir poser un problème et d'avoir fait le retour avec le résolu...

Ici, rien ne se perd, tout se transforme.. en entraide et en tuto même parfois. Te gêne de rien !

A la prochaine cmm !

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#12 23-02-2010 23:29:46

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : (Résolu] Connexion internet très lente par livebox

Bonjour,

Un hub est comparable à une multiprise: ce qui entre par un port est renvoyé sur tous les autres ports du hub. C'est un matériel pratique pour écouter les communications entre deux machines, il suffit d'intercaler le hub pour disposer sur un autre port de celui-ci d'une copie des transmissions.

Un switch gère une table de correspondance entre les adresses MAC des machines qui lui sont reliées et chacun de ses ports. ceci permet de ne renvoyer l'information que vers le port sur lequel se trouve la machine destinataire. L'avantage du switch est de désengorger les brins de réseau qui lui sont connectés; seuls les brins concernés verront en effet passer l'information.

Je constate avec plaisir que vous avez trouvé la solution au problème.

Si c'est cela l'explication, il reste à comprendre pourquoi, avec mon ancienne livebox, le problème ne se manifestait pas! à moins que, par hasard, il y ait eu des modifications sur le réseau de l'institut de maths, indépendamment, mais au moment où j'ai changé de livebox?


Je n'ai pas de meilleure explication à proposer. neutral

J'espère qu'ils voudront bien m'excuser d'avoir embêté tout le monde...


J'espère que vous nous excuserez de n'avoir pas su répondre à votre attente, et que malgré ces limites nous aurons le plaisir de vous retrouver prochainement parmis nous. wink

Cordialement

Hors ligne

#13 25-02-2010 14:50:47

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : (Résolu] Connexion internet très lente par livebox

Meri tux12 pour ces précisons. Mon boîtier est bien un switch.

Merci à toute l'équipe de debian facile qui, plusieurs fois, a résolu pour moi les problèmes que je rencontrais. Ne croyez pas que je me connecte à ce site seulement lorsque quelque chose ne va pas: je regarde aussi de temps en temps si je ne peux pas aider les autres, et si je n'interviens pas plus souvent c'est que je suis très ignorant!

Amicalement,

C.-M. M.

Hors ligne

#14 25-02-2010 15:14:04

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : (Résolu] Connexion internet très lente par livebox

Hop cmm !

Poser des questions c'est tout aussi bien participer que d'y répondre !
Que ferions-nous sans question sur un site d'entraide, un cercle de belote ? ah ah ah big_smile

A la prochaine donc, cher membre actif de not' site. Tu aussi peux y amener des amis, c'est sans complexe !

Tchibâââ ! lol

Amitié, Jojo

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums