Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-06-2013 18:49:46

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

wiki - Installation Cinnamon sur Gnome 3.4

Comme demandé pour compléter le tuto sur l'installation de Cinnamon sur une Debian minimale, je crée la page http://debian-facile.org/doc:environnem … n-gnome3.4 pour tutoter l'installation de Cinnamon sur une installation Debian standard (avec Gnome 3.4) pré-existante.

Bien évidemment, il reprendra beaucoup du premier mais il s'adresse à un public différent.

Ce topic regroupera les questions et remarques à ce sujet.

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#2 17-06-2013 19:14:33

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : wiki - Installation Cinnamon sur Gnome 3.4

Ne peux-tu mettre des liens entre les deux pour les actions identiques ?
Ainsi, en cas de correction, on n'agit que dans un seul tuto ! roll

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 17-06-2013 19:21:55

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

Dans l'absolu oui, je peux, c'est pas un problème, mais n'est-ce pas un peu confusant pour un débutant?
Je pensais que ça ferait plus clair deux tutos bien distincts même si certaines commandes sont les mêmes, mais c'est toi le patron smile

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#4 17-06-2013 19:33:20

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : wiki - Installation Cinnamon sur Gnome 3.4

Ah ah ah big_smile
Disons que cela a un sens de ne pas avoir à répéter les mêmes commandes si elles sont susceptibles d'évoluer bien sûr.
Si elles te paraissent définitives, alors oui, tu peux les répéter dans les deux tutos, c'est toi l'chef là ! tongue

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#5 18-06-2013 01:31:23

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : wiki - Installation Cinnamon sur Gnome 3.4

Ah ! toujours après chipoter le Jojo big_smile.

Dernière modification par martinux_qc (18-06-2013 01:43:15)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

En ligne

#6 18-06-2013 04:17:45

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : wiki - Installation Cinnamon sur Gnome 3.4

blblblbl tongue

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#7 18-06-2013 04:59:41

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

smile
Bah non c'est pas bête mais je pense que ne va porter que sur une seule section: la sélection des dépôts. Ce n'est pas un paragraphe très long, est-ce que ça vaut le coup de couper la lecture en faisant un renvoi pour si peu? D'autant que comme smolski (Joël, Jo ou smolski d'ailleurs? c'est quoi l'AOC en vigueur?) le dit, c'est un truc qui ne risque pas de devoir être corrigé...

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#8 18-06-2013 08:06:25

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

D'une manière générale, je pense qu'un tuto doit être d'un seul tenant, avec des liens pour les détails de certaines commandes.

C'est important en particulier si tu n'as pas de connexion et que tu disposes uniquement des paquets nécessaires et d'une seule page de tuto.
Je te dis pas le stress si faut courir après une autre page. mad

Bien sûr, cela veut dire plus de maintenance du wiki.
Mais nous le valons bien ! smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#9 18-06-2013 16:52:15

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

EDIT Tuto du 18/06:

- Premier jet du tuto réalisé;
- testé en 64bits par mes soins: Si quelqu'un veut bien se charger de tester ça en 32bits ça m'arrangerai, je n'ai testé qu'en VM et ma configuration matérielle s'accommode mal de Gnome (c'est pourquoi j'utilise XFCE wink alors Gnome en VM... ça raaaaaaaaaame
- étant donné que le public visé et, à mon avis, débutant, j'ai pris le parti d'indiquer 2 procédures: graphique (synaptic) et ligne de commande. Cependant l'installation de Nemo pose un problème en graphique, j'ai donc renvoyé vers la ligne de commande. Je suis conscient que ça ne fait pas très "propre". Si ça convient quand même, je laisse, sinon je veux bien un conseil pour résoudre ce petit soucis!
- pour illustrer j'ai utilisé deux gif, je trouve assez pédago pour les débutants, j'espère que ça convient à la ligne éditoriale du wiki wink

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#10 18-09-2013 18:49:53

df871
Membre
Lieu : Limousin
Distrib. : Debian Wheezy 7.1 32b
Noyau : Linux 3.2.0-4-486
(G)UI : Xfce 4.8
Inscription : 17-09-2013
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

Bonsoir smile

Je suis débutant, mais si quelqu'un m'explique longtemps, je comprends vite... surtout vers la fin lol

Je suis en train de tester, ou du moins, de tenter d'installer Cinnamon, en ayant suivi ton tuto, qui est bien expliqué :
+ par synaptic : il ne trouve rien, alors que j'ai installé les dépôts indiqués :

cat /etc/apt/sources.list



#

# deb cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ - Official i386 NETINST Binary-1 20130615-21:53]/ wheezy main

# wheezy-updates, previously known as 'volatile'

# dépot Epson
# deb http://mirror.home-dn.net/debian-multimedia wheezy main

deb http://security.debian.org/ wheezy/updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ wheezy main contrib non-free
deb http://ftp.fr.debian.org/debian/ wheezy-updates main contrib non-free
deb http://ftp.fr.debian.org/debian wheezy-proposed-updates main contrib non-free
deb http://ftp2.fr.debian.org/debian/ jessie main
deb-src http://ftp2.fr.debian.org/debian/ jessie main
deb http://ftp2.fr.debian.org/debian/ sid main
deb-src http://ftp2.fr.debian.org/debian/ sid main



cependant, voilà ce que me répond le terminal d'admin ou root (mais j'préfère le françois wink ) :

apt-get install cinnamon


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 cinnamon : Dépend: gir1.2-muffin-3.0 mais ne sera pas installé
            Dépend: libcogl-pango12 (>= 1.7.4) mais ne sera pas installé
            Dépend: libcogl12 (>= 1.9.6) mais ne sera pas installé
            Dépend: libgjs0c (>= 1.36.1) mais ne sera pas installé
            Dépend: libglib2.0-0 (>= 2.35.9) mais 2.33.12+really2.32.4-5 devra être installé
            Dépend: libmuffin0 (>= 1.7.1) mais ne sera pas installé
            Dépend: libpango-1.0-0 (>= 1.14.0) mais ne sera pas installé
            Dépend: libpangocairo-1.0-0 (>= 1.14.0) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».




ma version de gnome :

apt-cache policy gnome



gnome:
  Installé : 1:3.4+7
  Candidat : 1:3.4+7
 Table de version :
    1:3.8+3 0
        90 http://ftp2.fr.debian.org/debian/ jessie/main i386 Packages
        50 http://ftp2.fr.debian.org/debian/ sid/main i386 Packages
 *** 1:3.4+7 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main i386 Packages
        100 /var/lib/dpkg/status




Alors, si c'est impossible, pas de souci, je souhaitai juste tester Cinnamon, pour "voir" et comparer à Xfce et Gnome smile

A bientôt smile

Dernière modification par df871 (18-09-2013 18:51:19)


Cordialement
Bernard
Crées, Consolides... puis, Continues à Créer smile
Asus P4P800, P4C 2,6Ghz, Seagate laptop SSHD 500Go, Nvidia GF 6200 512 Mo avec Debian 7.0, Xfce 4.08

Hors ligne

#11 18-09-2013 20:25:14

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

Bonsoir

Peut-être faudrait-il essayer avec aptitude à la place de apt-get et voir les options proposées ?

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#12 18-09-2013 20:41:39

df871
Membre
Lieu : Limousin
Distrib. : Debian Wheezy 7.1 32b
Noyau : Linux 3.2.0-4-486
(G)UI : Xfce 4.8
Inscription : 17-09-2013
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

smile

Sitôt dit, sitôt fait :

root@Bernard:/home/bernard/Bureau# aptitude install cinnamon
Les NOUVEAUX paquets suivants vont être installés :
  cinnamon{b} gir1.2-muffin-3.0{a} libcogl-pango12{a} libcogl12{ab} libegl1-mesa{a} libegl1-mesa-drivers{a} libgbm1{a} libgjs0c{ab} libmuffin0{ab} libopenvg1-mesa{a}
  libpango-1.0-0{ab} libpangocairo-1.0-0{ab} libwayland0{a} muffin-common{a}
0 paquets mis à jour, 14 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 18,2 Mo d'archives. Après dépaquetage, 62,4 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 cinnamon : Dépend: libglib2.0-0 (>= 2.35.9) mais 2.33.12+really2.32.4-5 est installé.
            Dépend: cinnamon-common (= 1.7.4-2.2) mais il ne sera pas installé.
            Dépend: gir1.2-gnomedesktop-3.0 mais il ne sera pas installé.
            Dépend: libjs-jquery mais il ne sera pas installé.
            Dépend: python-lxml mais il ne sera pas installé.
            Dépend: python-pyinotify mais il ne sera pas installé.
 libcogl12 : Dépend: libc6 (>= 2.17) mais 2.13-38 est installé.
             Casse: libclutter-1.0-0 (< 1.14) mais 1.10.8-2 est installé.
 libpangocairo-1.0-0 : Dépend: libglib2.0-0 (>= 2.34.0) mais 2.33.12+really2.32.4-5 est installé.
                       Dépend: libpangoft2-1.0-0 (>= 1.28.1) mais il ne sera pas installé.
                       Est en conflit avec: libpango1.0-0 (< 1.32.5-2) mais 1.30.0-1 est installé.
 libmuffin0 : Dépend: libglib2.0-0 (>= 2.35.9) mais 2.33.12+really2.32.4-5 est installé.
 libpango-1.0-0 : Dépend: libglib2.0-0 (>= 2.35.9) mais 2.33.12+really2.32.4-5 est installé.
                  Est en conflit avec: libpango1.0-0 (< 1.32.5-2) mais 1.30.0-1 est installé.
 libgjs0c : Dépend: libc6 (>= 2.15) mais 2.13-38 est installé.
            Dépend: libffi6 (>= 3.0.4) mais il ne sera pas installé.
            Dépend: libgirepository-1.0-1 (>= 1.33.10) mais 1.32.1-1 est installé.
            Dépend: libglib2.0-0 (>= 2.36.0) mais 2.33.12+really2.32.4-5 est installé.
            Casse: libgjs0b mais 1.32.0-5 est installé.
ouverts : 45 ; fermés : 97 ; reportés : 14 ; en conflit : 15                                                                                                      
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     cinnamon [Non installé]                                  
2)     gir1.2-muffin-3.0 [Non installé]                        
3)     libcogl-pango12 [Non installé]                          
4)     libcogl12 [Non installé]                                
5)     libgjs0c [Non installé]                                  
6)     libmuffin0 [Non installé]                                
7)     libpango-1.0-0 [Non installé]                            
8)     libpangocairo-1.0-0 [Non installé]                      



Accepter cette solution ? [Y/n/q/?] n



si je réponds Y, il se "ferme" donc aucune install, si je réponds n, il est encore en train de chercher des solutions...


Cordialement
Bernard
Crées, Consolides... puis, Continues à Créer smile
Asus P4P800, P4C 2,6Ghz, Seagate laptop SSHD 500Go, Nvidia GF 6200 512 Mo avec Debian 7.0, Xfce 4.08

Hors ligne

#13 18-09-2013 20:50:15

df871
Membre
Lieu : Limousin
Distrib. : Debian Wheezy 7.1 32b
Noyau : Linux 3.2.0-4-486
(G)UI : Xfce 4.8
Inscription : 17-09-2013
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

J'ai bien tenté :


...
Faut-il résoudre ces dépendances manuellement ? [N/+/-/_/:/?] :
Les NOUVEAUX paquets suivants vont être installés :
  cinnamon{b} gir1.2-muffin-3.0{a} libcogl-pango12{a} libcogl12{ab} libegl1-mesa{a} libegl1-mesa-drivers{a} libgbm1{a} libgjs0c{ab} libmuffin0{ab}
  libopenvg1-mesa{a} libpango-1.0-0{ab} libpangocairo-1.0-0{ab} libwayland0{a} muffin-common{a}
0 paquets mis à jour, 14 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 18,2 Mo d'archives. Après dépaquetage, 62,4 Mo seront utilisés.
Faut-il résoudre ces dépendances manuellement ? [N/+/-/_/:/?] :
Les NOUVEAUX paquets suivants vont être installés :
  cinnamon{b} gir1.2-muffin-3.0{a} libcogl-pango12{a} libcogl12{ab} libegl1-mesa{a} libegl1-mesa-drivers{a} libgbm1{a} libgjs0c{ab} libmuffin0{ab}
  libopenvg1-mesa{a} libpango-1.0-0{ab} libpangocairo-1.0-0{ab} libwayland0{a} muffin-common{a}
0 paquets mis à jour, 14 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 18,2 Mo d'archives. Après dépaquetage, 62,4 Mo seront utilisés.
Faut-il résoudre ces dépendances manuellement ? [N/+/-/_/:/?] +
Les NOUVEAUX paquets suivants vont être installés :
  cinnamon{b} gir1.2-muffin-3.0{a} libcogl-pango12{a} libcogl12{ab} libegl1-mesa{a} libegl1-mesa-drivers{a} libgbm1{a} libgjs0c{ab} libmuffin0{ab}
  libopenvg1-mesa{a} libpango-1.0-0{ab} libpangocairo-1.0-0{ab} libwayland0{a} muffin-common{a}
0 paquets mis à jour, 14 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 18,2 Mo d'archives. Après dépaquetage, 62,4 Mo seront utilisés.
Faut-il résoudre ces dépendances manuellement ? [N/+/-/_/:/?] _
Les NOUVEAUX paquets suivants vont être installés :
  cinnamon{b} gir1.2-muffin-3.0{a} libcogl-pango12{a} libcogl12{ab} libegl1-mesa{a} libegl1-mesa-drivers{a} libgbm1{a} libgjs0c{ab} libmuffin0{ab}
  libopenvg1-mesa{a} libpango-1.0-0{ab} libpangocairo-1.0-0{ab} libwayland0{a} muffin-common{a}
0 paquets mis à jour, 14 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 18,2 Mo d'archives. Après dépaquetage, 62,4 Mo seront utilisés.
Faut-il résoudre ces dépendances manuellement ? [N/+/-/_/:/?] n
Abandon.
root@Bernard:/home/bernard/Bureau#



C'est la suite du commentaire précédent !


Cordialement
Bernard
Crées, Consolides... puis, Continues à Créer smile
Asus P4P800, P4C 2,6Ghz, Seagate laptop SSHD 500Go, Nvidia GF 6200 512 Mo avec Debian 7.0, Xfce 4.08

Hors ligne

#14 18-09-2013 21:10:54

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

Bonsoir

Jessie et Sid ont évolué depuis l'écriture du tuto en juin. Il semble donc qu'installer Cinnamon sous Wheezy soit à présent impossible. Une solution (non testée hmm ) serait de mettre un dépôt Snapshot d'une date qui va bien (date de la rédaction du tuto par exemple).
Problème, tu perd les avantages de stabilité et de sécurité de Debian Wheezy (même problème que XFCE 4.10 wink ).

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#15 18-09-2013 21:11:52

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

Oui, je propose de changer le tuto pour qu'il utilise un snapshot de l'époque de la rédaction du tuto smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#16 18-09-2013 22:28:38

df871
Membre
Lieu : Limousin
Distrib. : Debian Wheezy 7.1 32b
Noyau : Linux 3.2.0-4-486
(G)UI : Xfce 4.8
Inscription : 17-09-2013
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

Alors, je préfère passer la main... wink

Tant pis !

Cordialement
Bernard
Crées, Consolides... puis, Continues à Créer smile
Asus P4P800, P4C 2,6Ghz, Seagate laptop SSHD 500Go, Nvidia GF 6200 512 Mo avec Debian 7.0, Xfce 4.08

Hors ligne

#17 18-09-2013 22:38:24

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : wiki - Installation Cinnamon sur Gnome 3.4

T'en va pas comme ça... sans nous laisser la moindre chance !
Il y a ce nouveau tuto pour utiliser un dépot ancien :
snapshot les doigts dans l'nez !

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#18 18-09-2013 23:51:49

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

Bonsoir,
Effectivement, il semblerai que Cinnamon est purement et simplement disparu des dépôts Wheezy.
Et je suis désolé de cet état de fait et que tu aies rencontré des difficultés df871.
A moins que quelqu'un ayant déjà manipulé les dépôts snapshot (ce qui n'est pas mon cas) ne s'en charge, je m'occuperai de remettre le tutoriel à jour. Avant les vacances si possible (argh hmm ) sinon d'ici un mois.

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#19 19-09-2013 08:55:06

df871
Membre
Lieu : Limousin
Distrib. : Debian Wheezy 7.1 32b
Noyau : Linux 3.2.0-4-486
(G)UI : Xfce 4.8
Inscription : 17-09-2013
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

Rassurez-vous les Amis... je ne faisais que des essais... j'suis loin d'être un "fanatique" wink

Tiens, j'ai fait un essai de Lxde, et je l'ai abandonné... et supprimé... impossible de mettre le bureau dans la résolution que je veux... soit comme ici, Xfce ou Gnome, 1900x1200 !

Cependant, je vais regarder le tuto que tu indiques Joel smile

Et reviendrai ici, pour indiquer la manière dont cela c'est passé smile

Dernière modification par df871 (19-09-2013 09:01:35)


Cordialement
Bernard
Crées, Consolides... puis, Continues à Créer smile
Asus P4P800, P4C 2,6Ghz, Seagate laptop SSHD 500Go, Nvidia GF 6200 512 Mo avec Debian 7.0, Xfce 4.08

Hors ligne

#20 19-09-2013 08:59:14

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : wiki - Installation Cinnamon sur Gnome 3.4

df871 l'essayeur fou-facile ! big_smile
Merci !

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#21 19-09-2013 09:18:26

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

N'hésites pas à apporter tes commentaires sur ce fil et sur celui concernant les dépôts snapshots smile

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#22 19-09-2013 10:37:11

df871
Membre
Lieu : Limousin
Distrib. : Debian Wheezy 7.1 32b
Noyau : Linux 3.2.0-4-486
(G)UI : Xfce 4.8
Inscription : 17-09-2013
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

Me revoici smile

et voici tout le cheminement, c'est long... mais c'est bon...  lol :

choix de la version antérieure :
http://snapshot.debian.org/archive/debi … 3T220619Z/

j'ai pris la version, une journée avant la construction du tuto... logique wink

construction de l'entrée :
deb http://snapshot.debian.org/archive/debi … 20619Z/sid main

insertion de la source :
gedit /etc/apt/sources.list

qui devient :
+++++++++++++
#

# deb cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ - Official i386 NETINST Binary-1 20130615-21:53]/ wheezy main

# wheezy-updates, previously known as 'volatile'

# dépot Epson
# deb http://mirror.home-dn.net/debian-multimedia wheezy main

deb http://security.debian.org/ wheezy/updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ wheezy main contrib non-free
deb http://ftp.fr.debian.org/debian/ wheezy-updates main contrib non-free
deb http://ftp.fr.debian.org/debian wheezy-proposed-updates main contrib non-free
deb http://snapshot.debian.org/archive/debi … 20619Z/sid main
+++++++++++++

retour :
+++++++++++++
root@Bernard:/home/bernard/Bureau# apt-get update
E: Ligne 14 mal formée dans la liste des sources /etc/apt/sources.list (analyse de distribution)
E: La liste des sources ne peut être lue.
root@Bernard:/home/bernard/Bureau#
+++++++++++++

gedit /etc/apt/sources.list

je modifie la ligne en question en enlevant "/" avant sid et voici le résultat :

+++++++++++++
root@Bernard:/home/bernard/Bureau# apt-get update
Atteint http://ftp.fr.debian.org wheezy Release.gpg
Réception de : 1 http://security.debian.org wheezy/updates Release.gpg [836 B]                   
Atteint http://ftp.fr.debian.org wheezy-updates Release.gpg                                       
Réception de : 2 http://security.debian.org wheezy/updates Release [102 kB]                       
Atteint http://ftp.fr.debian.org wheezy-proposed-updates Release.gpg                             
Atteint http://ftp.fr.debian.org wheezy Release                                                   
Atteint http://ftp.fr.debian.org wheezy-updates Release                                           
Atteint http://ftp.fr.debian.org wheezy-proposed-updates Release                                 
Atteint http://ftp.fr.debian.org wheezy/main i386 Packages                                       
Réception de : 3 http://security.debian.org wheezy/updates/main i386 Packages [106 kB]           
Atteint http://ftp.fr.debian.org wheezy/contrib i386 Packages                                     
Atteint http://ftp.fr.debian.org wheezy/non-free i386 Packages                                   
Réception de : 4 http://security.debian.org wheezy/updates/contrib i386 Packages [14 B]           
Atteint http://ftp.fr.debian.org wheezy/contrib Translation-en                                   
Réception de : 5 http://security.debian.org wheezy/updates/non-free i386 Packages [14 B]         
Réception de : 6 http://snapshot.debian.org sid Release.gpg [1 571 B]                             
Atteint http://ftp.fr.debian.org wheezy/main Translation-fr                                       
Réception de : 7 http://security.debian.org wheezy/updates/contrib Translation-en [14 B]         
Réception de : 8 http://security.debian.org wheezy/updates/main Translation-en [60,4 kB]         
Atteint http://ftp.fr.debian.org wheezy/main Translation-en                                       
Réception de : 9 http://security.debian.org wheezy/updates/non-free Translation-en [14 B]         
Atteint http://ftp.fr.debian.org wheezy/non-free Translation-en                                   
Réception de : 10 http://snapshot.debian.org sid Release [203 kB]                                 
Atteint http://ftp.fr.debian.org wheezy-updates/main i386 Packages/DiffIndex                     
Atteint http://ftp.fr.debian.org wheezy-updates/contrib i386 Packages             
Atteint http://ftp.fr.debian.org wheezy-updates/non-free i386 Packages             
Atteint http://ftp.fr.debian.org wheezy-updates/contrib Translation-en             
E: Le fichier « Release » pour http://snapshot.debian.org/archive/debi … id/Release a expiré (plus valable depuis 100d 11h 22min 38s). Les mises à jour depuis ce dépôt  ne s'effectueront pas.
root@Bernard:/home/bernard/Bureau#
+++++++++++++

donc c'est ok !

heureusement que vous aviez prévu ce couac ;-)
"Et oui, seule solution : signifier à apt qu'il ne doit pas se soucier de l'âge de mon grand-père du dépôt :
apt-get -o 'Acquire::Check-Valid-Until=false' update"

voici son retour :
+++++++++++++
root@Bernard:/home/bernard/Bureau# apt-get -o 'Acquire::Check-Valid-Until=false' update
Atteint http://ftp.fr.debian.org wheezy Release.gpg
Réception de : 1 http://snapshot.debian.org sid Release.gpg [1 571 B]                           
Atteint http://ftp.fr.debian.org wheezy-updates Release.gpg                                     
Atteint http://snapshot.debian.org sid Release                                                   
Atteint http://security.debian.org wheezy/updates Release.gpg                                   
Atteint http://security.debian.org wheezy/updates Release                                       
Atteint http://ftp.fr.debian.org wheezy-proposed-updates Release.gpg                             
Atteint http://security.debian.org wheezy/updates/main i386 Packages                             
Atteint http://ftp.fr.debian.org wheezy Release                                     
Atteint http://security.debian.org wheezy/updates/contrib i386 Packages                         
Atteint http://ftp.fr.debian.org wheezy-updates Release                                         
Atteint http://security.debian.org wheezy/updates/non-free i386 Packages                         
Atteint http://ftp.fr.debian.org wheezy-proposed-updates Release                                 
Atteint http://security.debian.org wheezy/updates/contrib Translation-en                         
Atteint http://security.debian.org wheezy/updates/main Translation-en                           
Atteint http://ftp.fr.debian.org wheezy/main i386 Packages                                       
Atteint http://security.debian.org wheezy/updates/non-free Translation-en                       
Atteint http://ftp.fr.debian.org wheezy/contrib i386 Packages                                   
Réception de : 2 http://snapshot.debian.org sid/main i386 Packages [6 410 kB]       
Atteint http://ftp.fr.debian.org wheezy/non-free i386 Packages                       
Atteint http://ftp.fr.debian.org wheezy/contrib Translation-en                     
Atteint http://ftp.fr.debian.org wheezy/main Translation-fr                       
Atteint http://ftp.fr.debian.org wheezy/main Translation-en                       
Atteint http://ftp.fr.debian.org wheezy/non-free Translation-en                   
Atteint http://ftp.fr.debian.org wheezy-updates/main i386 Packages/DiffIndex     
Atteint http://ftp.fr.debian.org wheezy-updates/contrib i386 Packages             
Atteint http://ftp.fr.debian.org wheezy-updates/non-free i386 Packages           
Atteint http://ftp.fr.debian.org wheezy-updates/contrib Translation-en           
Atteint http://ftp.fr.debian.org wheezy-updates/main Translation-en/DiffIndex     
Atteint http://ftp.fr.debian.org wheezy-updates/non-free Translation-en             
Atteint http://ftp.fr.debian.org wheezy-proposed-updates/main i386 Packages/DiffIndex
Atteint http://ftp.fr.debian.org wheezy-proposed-updates/contrib i386 Packages     
Atteint http://ftp.fr.debian.org wheezy-proposed-updates/non-free i386 Packages/DiffIndex
Atteint http://ftp.fr.debian.org wheezy-proposed-updates/contrib Translation-en/DiffIndex
Atteint http://ftp.fr.debian.org wheezy-proposed-updates/main Translation-en/DiffIndex
Atteint http://ftp.fr.debian.org wheezy-proposed-updates/non-free Translation-en/DiffIndex
Réception de : 3 http://snapshot.debian.org sid/main Translation-fr [768 kB]         
Réception de : 4 http://snapshot.debian.org sid/main Translation-en [4 261 kB]
11,4 Mo réceptionnés en 18s (604 ko/s)                                                           
Lecture des listes de paquets... Fait
root@Bernard:/home/bernard/Bureau#
+++++++++++++


Comme je n'ai pas supprimé le fichier /etc/apt/preferences, je vais droit au but... ptdr
aptitude install cinnamon

et voici le résultat :
+++++++++++++
root@Bernard:/home/bernard/Bureau# aptitude install cinnamon
Les NOUVEAUX paquets suivants vont être installés :
  cinnamon cinnamon-common{a} gir1.2-gnomedesktop-3.0{a} gir1.2-muffin-3.0{a}
  javascript-common{a} libjs-jquery{a} libmuffin0{a} muffin-common{a} python-lxml{a}
  python-pyinotify{a} wwwconfig-common{a}
0 paquets mis à jour, 11 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 5 727 ko d'archives. Après dépaquetage, 19,0 Mo seront utilisés.
Voulez-vous continuer ? [Y/n/?] y
Prendre :  1 http://ftp.fr.debian.org/debian/ wheezy/main gir1.2-gnomedesktop-3.0 i386 3.4.2-1 [103 kB]
Prendre :  2 http://snapshot.debian.org/archive/debi … 3T220619Z/ sid/main muffin-common all 1.7.3-1 [1 440 kB]
Prendre :  3 http://ftp.fr.debian.org/debian/ wheezy/main libjs-jquery all 1.7.2+dfsg-1 [80,1 kB]
Prendre :  4 http://ftp.fr.debian.org/debian/ wheezy/main python-lxml i386 2.3.2-1 [1 143 kB]
Prendre :  5 http://ftp.fr.debian.org/debian/ wheezy/main python-pyinotify all 0.9.3-1.1 [29,5 kB]
Prendre :  6 http://ftp.fr.debian.org/debian/ wheezy/main wwwconfig-common all 0.2.2 [22,8 kB]
Prendre :  7 http://snapshot.debian.org/archive/debi … 3T220619Z/ sid/main libmuffin0 i386 1.7.3-1 [332 kB]
Prendre :  8 http://ftp.fr.debian.org/debian/ wheezy/main javascript-common all 7 [3 810 B]
Prendre :  9 http://snapshot.debian.org/archive/debi … 3T220619Z/ sid/main gir1.2-muffin-3.0 i386 1.7.3-1 [20,0 kB]
Prendre :  10 http://snapshot.debian.org/archive/debi … 3T220619Z/ sid/main cinnamon-common all 1.7.4-2 [1 918 kB]
Prendre :  11 http://snapshot.debian.org/archive/debi … 3T220619Z/ sid/main cinnamon i386 1.7.4-2 [635 kB]
5 727 ko téléchargés en 4s (1 305 ko/s)
Sélection du paquet muffin-common précédemment désélectionné.
(Lecture de la base de données... 187906 fichiers et répertoires déjà installés.)
Dépaquetage de muffin-common (à partir de .../muffin-common_1.7.3-1_all.deb) ...
Sélection du paquet libmuffin0 précédemment désélectionné.
Dépaquetage de libmuffin0 (à partir de .../libmuffin0_1.7.3-1_i386.deb) ...
Sélection du paquet gir1.2-muffin-3.0 précédemment désélectionné.
Dépaquetage de gir1.2-muffin-3.0 (à partir de .../gir1.2-muffin-3.0_1.7.3-1_i386.deb) ...
Sélection du paquet cinnamon-common précédemment désélectionné.
Dépaquetage de cinnamon-common (à partir de .../cinnamon-common_1.7.4-2_all.deb) ...
Sélection du paquet gir1.2-gnomedesktop-3.0 précédemment désélectionné.
Dépaquetage de gir1.2-gnomedesktop-3.0 (à partir de .../gir1.2-gnomedesktop-3.0_3.4.2-1_i386.deb) ...
Sélection du paquet libjs-jquery précédemment désélectionné.
Dépaquetage de libjs-jquery (à partir de .../libjs-jquery_1.7.2+dfsg-1_all.deb) ...
Sélection du paquet python-lxml précédemment désélectionné.
Dépaquetage de python-lxml (à partir de .../python-lxml_2.3.2-1_i386.deb) ...
Sélection du paquet python-pyinotify précédemment désélectionné.
Dépaquetage de python-pyinotify (à partir de .../python-pyinotify_0.9.3-1.1_all.deb) ...
Sélection du paquet cinnamon précédemment désélectionné.
Dépaquetage de cinnamon (à partir de .../cinnamon_1.7.4-2_i386.deb) ...
Sélection du paquet wwwconfig-common précédemment désélectionné.
Dépaquetage de wwwconfig-common (à partir de .../wwwconfig-common_0.2.2_all.deb) ...
Sélection du paquet javascript-common précédemment désélectionné.
Dépaquetage de javascript-common (à partir de .../javascript-common_7_all.deb) ...
Traitement des actions différées (« triggers ») pour « sgml-base »...
Traitement des actions différées (« triggers ») pour « man-db »...
Traitement des actions différées (« triggers ») pour « gconf2 »...
Traitement des actions différées (« triggers ») pour « libglib2.0-0:i386 »...
Traitement des actions différées (« triggers ») pour « desktop-file-utils »...
Traitement des actions différées (« triggers ») pour « gnome-menus »...
Paramétrage de muffin-common (1.7.3-1) ...
Paramétrage de cinnamon-common (1.7.4-2) ...
Paramétrage de gir1.2-gnomedesktop-3.0 (3.4.2-1) ...
Paramétrage de libjs-jquery (1.7.2+dfsg-1) ...
Paramétrage de python-lxml (2.3.2-1) ...
Paramétrage de python-pyinotify (0.9.3-1.1) ...
Paramétrage de wwwconfig-common (0.2.2) ...
Paramétrage de javascript-common (7) ...
Traitement des actions différées (« triggers ») pour « sgml-base »...
Paramétrage de libmuffin0 (1.7.3-1) ...
Paramétrage de gir1.2-muffin-3.0 (1.7.3-1) ...
Paramétrage de cinnamon (1.7.4-2) ...
                                             
root@Bernard:/home/bernard/Bureau#
+++++++++++++


test :
capturedcran-19092013-101450.png



Voilà, c'est fini smile

Pour le test, j'apprécie peu... cinnamon, presque aussi lent que gnome... personnellement, j'y vois peu d'intérêt, sauf à ce que vous souhaitiez faire une ou deux manips, je le supprime demain !

Maintenant, j'vais sur la discussion snapshot :
http://debian-facile.org/viewtopic.php?id=7432
pour y transcrire le même cheminement et que je rectifierai selon vos remarques, si cela ne vous convenez pas !

Dernière modification par df871 (19-09-2013 10:39:28)


Cordialement
Bernard
Crées, Consolides... puis, Continues à Créer smile
Asus P4P800, P4C 2,6Ghz, Seagate laptop SSHD 500Go, Nvidia GF 6200 512 Mo avec Debian 7.0, Xfce 4.08

Hors ligne

#23 19-09-2013 10:44:06

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

@df871: Un outil qui te permet de régler la résolution que tu veux quel que soit le l'environnement de bureau : arandr (ou en ligne de commande : xrandr)

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#24 19-09-2013 10:57:55

df871
Membre
Lieu : Limousin
Distrib. : Debian Wheezy 7.1 32b
Noyau : Linux 3.2.0-4-486
(G)UI : Xfce 4.8
Inscription : 17-09-2013
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

Merci pour l'info Fab smile

Cordialement
Bernard
Crées, Consolides... puis, Continues à Créer smile
Asus P4P800, P4C 2,6Ghz, Seagate laptop SSHD 500Go, Nvidia GF 6200 512 Mo avec Debian 7.0, Xfce 4.08

Hors ligne

#25 21-09-2013 09:28:34

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : wiki - Installation Cinnamon sur Gnome 3.4

Et quant tu seras sous LXDE, ce sera lxrandr smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums