Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-06-2014 17:28:18

TuxMips
Membre
Inscription : 08-09-2011

flashplayer et mise à jour

Bonjour,

Désolé si je pose une question très con ...
Mais le passage d'iceweasel 29 à iceweasel 30 génère des surprises comme la désactivation des plug'ins
Et là, jje m'aperçois que flashplayer n'est plus à jour. Le système me réponds que je suis encore en version 10 et qu'il me faut passer en version11

Synaptic indique que la version de flashplugin non free est en version 1.3.2 !
Version 1.3.2 qui semble dater de décembre 2012.

Comment mettre à jour ce plugin ? Le site d'Adobe ne propose qu'une version pour Ubuntu :-(

Quels sont les risques à rester dans cette version 1.3.2 ?

Merci beaucoup pour vos lumières .

Hors ligne

#2 15-06-2014 17:57:34

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : flashplayer et mise à jour

Regarde sur cette page:
https://debian-facile.org/doc:media:flash
Tu pourras aussi essayer la version spéciale Google, elle est parfois plus à jour.

Hors ligne

#3 15-06-2014 19:05:41

TuxMips
Membre
Inscription : 08-09-2011

Re : flashplayer et mise à jour

super

merci beaucoup

C'est résolu !

En fait je m'aperçois dans les plugins installés dans iceweasel que j'ai 2 plugins d'installés !

Un en version 10 et un en version 11. Le 11 n'était pas à jour. C'est fait grâce à la manip du wiki.

J'ai passé le 10 en "ne jamais activé". Mais je pense qu' idéalement je le désinstalle.

Merci beaucoup en tous cas smile

Hors ligne

#4 15-06-2014 23:28:26

david96
Invité

Re : flashplayer et mise à jour

En passant, j'avais ouïr que le flash proprio (adobe) avait décidé de ne plus supporterles plateformes sous GNU/Linux.
Que le html5 allait enterrer ce format…

On en est où, dans ce marasme transitionnel espodique ?

#5 16-06-2014 07:52:02

Mavrick
Membre
Lieu : Loin de ma Bretagne natale...
Distrib. : Debian 8 (Jessie)
Noyau : Linux 3.16 amd64
(G)UI : Xfce 4.10
Inscription : 18-11-2013

Re : flashplayer et mise à jour

Adobe n'apporte plus que des mises à jour de sécurité à Flash, plus de nouvelle version, que des patchs.
Le soucis c'est que le support pour Windows et Mac est toujours actif, du coup le html5 n'est pas encore implémenté partout...

Dernière modification par Mavrick (16-06-2014 07:55:16)


Adhérent April N° 9016

Hors ligne

#6 16-06-2014 08:54:17

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : flashplayer et mise à jour

Salut,

Une explication bassement commerciale de l'abandon de flash pour linux : Flash sous Linux va devenir une exclusivité Google Chrome
En complément, le comment debian s'est adapté : PepperFlashPlayer

smile

Hors ligne

#7 16-06-2014 17:30:53

Mavrick
Membre
Lieu : Loin de ma Bretagne natale...
Distrib. : Debian 8 (Jessie)
Noyau : Linux 3.16 amd64
(G)UI : Xfce 4.10
Inscription : 18-11-2013

Re : flashplayer et mise à jour

Le PepperFlashPlayer, c'est pas du Debian mais du Google il me semble, c'est le module flash qui se trouve dans chrome.
Sinon je trouve assez malsain de fournir flash uniquement à Chrome sous Linux. On à l'impression qu'on nous force la main, si tu veux du flash à jour, passe sur Chrome. Pas très professionnel.

Dernière modification par Mavrick (16-06-2014 17:34:05)


Adhérent April N° 9016

Hors ligne

#8 16-06-2014 17:40:41

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : flashplayer et mise à jour

C'est bien pour ça que l'on milite pour l'abandon du flash big_smile

Hors ligne

#9 16-06-2014 17:44:40

Mavrick
Membre
Lieu : Loin de ma Bretagne natale...
Distrib. : Debian 8 (Jessie)
Noyau : Linux 3.16 amd64
(G)UI : Xfce 4.10
Inscription : 18-11-2013

Re : flashplayer et mise à jour

kao a écrit :

C'est bien pour ça que l'on milite pour l'abandon du flash big_smile



J'avoue que je l'ai encore sur mon navigateur, j'ai essayé de faire sans mais Firefox ne semble pas gérer la HD en html5 au niveau des vidéos.


Adhérent April N° 9016

Hors ligne

#10 16-06-2014 17:53:57

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : flashplayer et mise à jour

Si, il le gère, il n'y pas de raison, mais souvent, un site comme Youtube ne propose pas de version 1080.
Pour activer le html5 pour youtube, il faut aller ici:
https://www.youtube.com/html5

Hors ligne

#11 16-06-2014 17:58:47

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : flashplayer et mise à jour

En fait il y a d'un côté Oracle qui ne tiens pas plus que ça à s'occuper du bébé et Google qui l'a repris, mais en mettant la main dessus (c'est en soit une faille de sécu trop utilisée pour collecter des données pour qu'ils le lâchent comme ça, c'est un atout concurrentiel majeur dans l'espionnage de clients).

« Un optimiste, explique Raymond Aubrac, n’est pas un être satisfait, content de la situation actuelle. C’est quelqu’un qui pense qu’il peut faire quelque chose qui servira. »

Hors ligne

#12 16-06-2014 18:03:06

Mavrick
Membre
Lieu : Loin de ma Bretagne natale...
Distrib. : Debian 8 (Jessie)
Noyau : Linux 3.16 amd64
(G)UI : Xfce 4.10
Inscription : 18-11-2013

Re : flashplayer et mise à jour

kao a écrit :

Si, il le gère, il n'y pas de raison, mais souvent, un site comme Youtube ne propose pas de version 1080.
Pour activer le html5 pour youtube, il faut aller ici:
https://www.youtube.com/html5



Chez moi sur Youtube toutes les vidéos sont proposés en 360p, sur Midori ça va jusqu'à 720p


Adhérent April N° 9016

Hors ligne

#13 16-06-2014 18:17:20

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : flashplayer et mise à jour

Tu as un exemple, j'ai essayé de comparer avec ce que me remontait cclive, mais je ne trouve pas le fichier 720p webm, alors que je l'ai bien disponible dans l'interface.
https://debian-facile.org/doc:systeme:cclive

Hors ligne

#14 16-06-2014 18:44:54

Mavrick
Membre
Lieu : Loin de ma Bretagne natale...
Distrib. : Debian 8 (Jessie)
Noyau : Linux 3.16 amd64
(G)UI : Xfce 4.10
Inscription : 18-11-2013

Re : flashplayer et mise à jour

https://www.youtube.com/watch?v=38peWm76l-U

Cette vidéo, sur Iceweasel je n'ai que du 360p et sur Midori j'ai le choix entre 240 - 360 ou 720p

Edit : sur la page d'activation de l'HTML5 de Youtube le H264 n'est pas présent sur Iceweasel mais est présent sur Midori.

Dernière modification par Mavrick (16-06-2014 18:47:11)


Adhérent April N° 9016

Hors ligne

#15 16-06-2014 18:58:03

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : flashplayer et mise à jour

Et je confirme dans le html5 pour du 720p c'est du H264.
J'ai fait clic-droit -> Statistiques avancées
Il faut donc le support H264 sinon, on est renvoyé sur le webm disponible en 360 seulement.

Hors ligne

#16 16-06-2014 19:02:30

Mavrick
Membre
Lieu : Loin de ma Bretagne natale...
Distrib. : Debian 8 (Jessie)
Noyau : Linux 3.16 amd64
(G)UI : Xfce 4.10
Inscription : 18-11-2013

Re : flashplayer et mise à jour

Du coup tout est normal, étrange tout de même que Iceweasel ne supporte pas le H264.

Adhérent April N° 9016

Hors ligne

#17 16-06-2014 19:05:31

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : flashplayer et mise à jour

Moi ça marche et j'ai fait les tests avec la 29.0.1.

Hors ligne

#18 16-06-2014 19:16:37

Mavrick
Membre
Lieu : Loin de ma Bretagne natale...
Distrib. : Debian 8 (Jessie)
Noyau : Linux 3.16 amd64
(G)UI : Xfce 4.10
Inscription : 18-11-2013

Re : flashplayer et mise à jour

J'avais déjà remarqué ça sur la 29 je doit avoir un truc qui cloche du coup.

Adhérent April N° 9016

Hors ligne

#19 17-06-2014 18:19:13

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : flashplayer et mise à jour

Mavrick a écrit :

On à l'impression qu'on nous force la main, si tu veux du flash à jour, passe sur Chrome.


De toute façon, firefox/iceweasel [**********] de adaube et de gogole ( pour la thune ! ), et des drm sont intégrés dans html5 -> DRM dans Firefox, annonce d'une défaite

pas glop ! sad -> 666

y'a du souci à se faire :
1403020552.jpg

No Pasaran ?

[Modération par Kao: Pas de gros mots chez nous, merci]

Dernière modification par nono47 (17-06-2014 18:30:55)

Hors ligne

#20 17-06-2014 18:34:14

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : flashplayer et mise à jour

@nono47 j'ai modéré ton post, pas de gros mot chez nous, on reste correct.

Hors ligne

#21 17-06-2014 19:15:54

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : flashplayer et mise à jour

Je pense que d'une certaine manière, les DRM dans le html5 étaient un compromis pour l'abandon de Flash.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#22 17-06-2014 19:57:16

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : flashplayer et mise à jour

Salut,

@ Kao : désolé, je voulais pas être grossier, je ferai attention - mea culpa - big_smile

@ captnfab : peux tu développer !, parce que c'est une interrogation pour moi, dans mon esprit de newbee, c'est comme avoir des blobs dans le kernel, quel impact au final ?  la NSA derrière comme sous windows ? ou  juste un compromis à surveiller ? L’hémogénie des multinationales sur un espace social ?,  Devons nous plier sous le dikatk ? les drm dans html5, c'est quand même la porte ouverte à la surveillance généralisée, ça d'accord, mais sauvons le soldat iceweasel de cela -> joe's garage

Le contrat social Debian a écrit :


Debian demeurera totalement libre.

Le document intitulé "Principes du logiciel libre selon Debian" énonce les critères grâce auxquels le projet Debian détermine si un travail est "libre". Nous promettons que le système Debian et tous ses composants seront libres selon ces principes et nous aiderons les personnes qui créent et utilisent à la fois des travaux libres et non libres sur Debian. Nous ne rendrons pas le système dépendant d'un composant non libre.



Avec flash comme sujet, c'est obligé que c'est polémique !

Dernière modification par nono47 (17-06-2014 20:27:29)

Hors ligne

Pied de page des forums