Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-07-2017 09:17:47

stigma
Membre
Lieu : Oise
Distrib. : dflinux-stretch
Noyau : Linux debian 3.16.0-4-586
(G)UI : xfce4
Inscription : 02-07-2017
Site Web

[Résolu]Modifier dualboot

Bonjour,
J'ai installé Windows Seven puis Linux 3.16.0-4-586 (Jessie)
J'ai donc un choix au démarrage Linux/Windows et ça marche bien.
Mais je n'arrive pas à modifier ce démarrage (choix OS au départ et délai).
Merci

Dernière modification par stigma (19-07-2017 17:51:12)

Hors ligne

#2 19-07-2017 09:34:44

Caribou22
Membre
Lieu : 22, Côtes d'Armor, Bretagne
Distrib. : Debian Stretch
Noyau : 4.9 amd64
(G)UI : XFCE
Inscription : 10-11-2014
Site Web

Re : [Résolu]Modifier dualboot

Bonjour smile

Cet écran de choix d'OS s'appelle le GRUB. Tout est paramétré dans son fichier de configuration, mais attention : En cas de mauvaise modification, tu peux te retrouver avec un système qui ne démarre plus... donc sauvegarde une copie du fichier avant tout.
Une doc détaillée : http://www.linuxpedia.fr/doku.php/expert/grub2

Hors ligne

#3 19-07-2017 10:10:05

Yanatoum
Membre
Lieu : Dyle
Distrib. : Debian 9 Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : xfce
Inscription : 10-07-2016

Re : [Résolu]Modifier dualboot

Bonjour,
j'avais trouvé cet échange sur le site:
https://debian-facile.org/viewtopic.php?id=7098
La commande

grep menuentry /boot/grub/grub.cfg

me renvoie:

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
  menuentry_id_option=""
export menuentry_id_option
menuentry 'Debian GNU/Linux' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-7cae4f65-4861-4fe4-bafb-d564f3b25b7c' {
submenu Options avancées pour Debian GNU/Linux' $menuentry_id_option 'gnulinux-advanced-7cae4f65-4861-4fe4-bafb-d564f3b25b7c' {
    menuentry 'Debian GNU/Linux, avec Linux 4.9.0-3-amd64' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.9.0-3-amd64-advanced-7cae4f65-4861-4fe4-bafb-d564f3b25b7c' {
    menuentry 'Debian GNU/Linux, with Linux 4.9.0-3-amd64 (recovery mode)' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.9.0-3-amd64-recovery-7cae4f65-4861-4fe4-bafb-d564f3b25b7c' {
    menuentry 'Debian GNU/Linux, avec Linux 4.9.0-2-amd64' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.9.0-2-amd64-advanced-7cae4f65-4861-4fe4-bafb-d564f3b25b7c' {
    menuentry 'Debian GNU/Linux, with Linux 4.9.0-2-amd64 (recovery mode)' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.9.0-2-amd64-recovery-7cae4f65-4861-4fe4-bafb-d564f3b25b7c' {
menuentry 'Windows Boot Manager (sur /dev/sdb2)' --class windows --class os $menuentry_id_option 'osprober-efi-CE65-444A' {
menuentry 'System setup' $menuentry_id_option 'uefi-firmware' {
 



Qui correspondt, en plus 'visuel', à mon écran de démarrage:    ( zut, flute ... toile libre inaccessible )
4 entrées:
- Debian GNU/Linux    GRUB_DEFAULT=0 de mon  /etc/default/grub
- Options avancées
- Windows Boot Manager
- System setup

Pour démarrer par défaut sur Windows, je devrais éditer avec nano (root) la ligne du fichier /etc/default/grub en GRUB_DEFAULT=2 pour pointer vers la troisième ligne.
Pour le délai, modifier la ligne timeout = 10 ou 15 ou .. au lieu des 5 secondes par défaut.
update grub puis redémarrage

Dernière modification par Yanatoum (19-07-2017 12:00:51)

Hors ligne

#4 19-07-2017 12:13:49

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu]Modifier dualboot

Bonjour
@Yanatoum... sujet a ne pas suivre il ne faut pas modier directement grub.cfg qui est un fichier généré par grub lors de l'update

Avant tout changement une petite copie du fichier que on pourra récupéré en console en cas de fausse manipe

cp /etc/default/grub /etc/default/grub_save



Il faut juste édité (avec nano par exemple) le fichier grub et changer la valeur par defaut qui est zéro

nano /etc/default/grub


GRUB_DEFAULT=2
GRUB_TIMEOUT=7


Il faut que tu indique sur quel position doit etre le curseur grub pour démarrer, exemple dans mon grub c'est la 3ème ligne
0 étant la premiére ligne
Puis tu ralonge un peu le temps de timeout, j'ai mis 7 secondes c'est pas trop mal quand je suis pas  éveillé big_smile
Apres avoir sauvegardé le fichier

update-grub


le fichier grub.cfg va être recréé avec les nouvelles valeurs


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#5 19-07-2017 14:50:20

stigma
Membre
Lieu : Oise
Distrib. : dflinux-stretch
Noyau : Linux debian 3.16.0-4-586
(G)UI : xfce4
Inscription : 02-07-2017
Site Web

Re : [Résolu]Modifier dualboot

Voici le fichier (que je ne peux pas modifier). et la commande pour la sauvegarde a echoué

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Hors ligne

#6 19-07-2017 15:05:42

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu]Modifier dualboot

J'ai testé mes commandes pas d'erreur de syntaxe
Tu dois les passé en root comme c'est dit dans l'encadrement rouge
tu passes en administrateur sur le compte root si compte root a été créé a l'installation

su


sinon c'est ton premier utilisateur créé qui est administrateur dans ce cas

sudo su


devrait fonctionner
Tu vois la ligne du terminale si $ tu es en simple utilisateur si # tu es passé en root

stephane@handylinux:~$ (simple utilisateur)
root@handylinux:/home/stephane# (passé en root)


sous XFCE tu dois meme avoir un icone dans le menu catégorie système qui t'ouvres un terminale administrateur

Donc a bien se rappeler pour tout les sujet que on lit sur le forum
Encadré gris= simple user
Encadré rouge = administrateur (root)

Dernière modification par Croutons (19-07-2017 15:06:39)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#7 19-07-2017 16:28:56

manet42
Membre
Lieu : Lorraine
Distrib. : DF Stretch 9
Noyau : i 386 et amd 64 + Win 7
(G)UI : Xfce
Inscription : 30-06-2017

Re : [Résolu]Modifier dualboot

Ce fil est d'un grand intérêt pour moi, peu doué..
J'explore  Stretch sur mon portable avant de l'installer en dual boot sur mon PC avec Win 7.
Je voulais donc pouvoir démarrer plus tard avec  win c.à d. arriver à savoir comment modifier  Grub.
Essai de mettre 10 secondes au lieu de 5 par exple sur mon portable pour me faire la main, sans succès depuis qlques jours.
Je viens de suivre ces consignes:
En console administrateur:

gedit /etc/default/grub


bloc à supprimer si la commande n’affiche rien


Une fenêtre s'ouvre avec le fichier
Je modifie le time out
Dans le coin en haut à droite , je clique sur "enregistrer"
Je ferme la fenètre et sur la console administrateur

update-grub.


bloc à supprimer si la commande n’affiche rien


Miracle ça marche, je vérifie et le temps est bien changé...
Me reste à installer Stretch en dual boot et de modifier l'ordre des OS pour que Win 7 démarre en premier.
Grand merci à Croutons de la part d'un vieux croutonold_geek.gif

Dernière modification par manet42 (19-07-2017 16:52:19)


Vieux HP 510; Intel Pentium M 2,26 Ghz; Memoire: 1 024 Mb, 533 Mhz avec DF Stretch 9 i386 + PC bureau H81M-S1, Intel Pentium cpu G342O 3,2 Ghz- Memoire  4 Go : Stretch 9 DDext + Win 7 DD int en dual boot.
En essayant continuellement, on finit par réussir. Donc plus ça rate, plus on a de chance que ça marche

Hors ligne

#8 19-07-2017 17:50:53

stigma
Membre
Lieu : Oise
Distrib. : dflinux-stretch
Noyau : Linux debian 3.16.0-4-586
(G)UI : xfce4
Inscription : 02-07-2017
Site Web

Re : [Résolu]Modifier dualboot

Merci, c'est parfait comme ça !

Hors ligne

Pied de page des forums