Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-09-2017 05:23:00

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

[BUG] Probleme Wayland & driver nvidia

Hello la compagnie,

Pour les grand connaisseurs, Wayland semble avoir disparu des menus de login.
1506136725.png
Alors on pourrait s'imaginer que Wayland se lance lorsque l'on clique sur "GNOME" car ce serait l'option par defaut.
Mais si j'entre en session sur "GNOME", dans la session, je fais ceci:

echo $XDG_SESSION_TYPE


je reçois ceci

x11


Est ce que Wayland a disparu?
Est ce que la commande "$XDG_SESSION_TYPE" est obsolete ou n'affiche pas les bonnes infos?

Merci, à bientôt.

d33p

Dernière modification par d33p (05-10-2017 09:00:47)


science sans conscience n'est que ruine de l'âme...

Hors ligne

#2 23-09-2017 06:15:48

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.13.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [BUG] Probleme Wayland & driver nvidia

Salut,

Sous sid :

echo $XDG_SESSION_TYPE


wayland


et il a disparu du login comme sur ta capture d'écran .

donc ça devrait bientôt arriver ! ( quand ce sera prêt .. ) smile

Hors ligne

#3 23-09-2017 11:32:22

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [BUG] Probleme Wayland & driver nvidia

hello,
ok, donc rien d'anormal apparemment, alors j'attends tongue

merci nono.

science sans conscience n'est que ruine de l'âme...

Hors ligne

#4 23-09-2017 12:40:52

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [BUG] Probleme Wayland & driver nvidia

Salut,
Sous Buster mis à jour ce matin :

echo $XDG_SESSION_TYPE


wayland



Au login j'ai toujours même chose que toi (enfin sauf plasma tongue ).
Sinon un truc pour le moment infaillible pour vérifier si on est sous Wayland : lancer Synaptic. Si après avoir tapé le mot de passe Synaptic ne s'ouvre pas alors c'est que Wayland rode par-là.


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#5 23-09-2017 17:25:41

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [BUG] Probleme Wayland & driver nvidia

Sinon un truc pour le moment infaillible pour vérifier si on est sous Wayland : lancer Synaptic. Si après avoir tapé le mot de passe Synaptic ne s'ouvre pas alors c'est que Wayland rode par-là.


hello mercredi, merci.
et bien alors je n'ai pas wayland car synaptic se lance bien.
j'ai essayé toutes les sessions et meme resultat... x11 apparait dans la console apres un "echo $XDG_SESSION_TYPE" ...
mercredi, mais toi t'as wayland si tu lances "GNOME" ou tu as encore un autre choix genre "GNOME wayland"
car avant, il y avait bien un choix "GNOME wayland", mais chez moi, cette option a disparu.

merci

d33p

Dernière modification par d33p (23-09-2017 18:15:33)


science sans conscience n'est que ruine de l'âme...

Hors ligne

#6 23-09-2017 18:17:17

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [BUG] Probleme Wayland & driver nvidia

(petite parenthese, j'ai testé KDE avec Wayland, c'est assez "horrible", c'est lent, parfois freeze ou "bug" graphique, tu sens qu'on est au debut ^^ )

science sans conscience n'est que ruine de l'âme...

Hors ligne

#7 23-09-2017 18:23:52

naguam
Membre
Distrib. : Plusieurs
Noyau : Un kernel
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : [BUG] Probleme Wayland & driver nvidia

Moi aussi j'adore kde mais je confirme que ce n'est pas au point.
il n'empèche que j'ai hâte de voir ce que cela donneras quand cela sera au point.

Hors ligne

#8 23-09-2017 23:04:18

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [BUG] Probleme Wayland & driver nvidia

d33p a écrit :

j'ai essayé toutes les sessions et meme resultat... x11 apparait dans la console apres un "echo $XDG_SESSION_TYPE" ...
mercredi, mais toi t'as wayland si tu lances "GNOME" ou tu as encore un autre choix genre "GNOME wayland"
car avant, il y avait bien un choix "GNOME wayland", mais chez moi, cette option a disparu.


J'ai comme sur ta capture :
System X11 Default
GNOME
GNOME Classique
GNOME sur Xorg

Seule l'entrée GNOME «tout court» me logue sur Wayland.

De mémoire, l'option GNOME Wayland a été remplacée par GNOME lors de la mise à jour de Gdm3 en version 3.25.quelque chose début septembre, avec cette version System X11 Default et GNOME me loguaient tous deux sur Wayland. System X11 Default s'était mis "par défaut" après la maj, je m'en étais rendue compte parce que Synaptic ne voulait pas s'ouvrir big_smile .
La maj récente de Gdm3 en 3.26 à remis le system X11 Default sur X11.

Ps : ton système est bien tout à jour ? /me se doute que oui mais c'est bizarre que l'entrée GNOME ne te logue pas sur Wayland.

Dernière modification par Mercredi (23-09-2017 23:07:44)


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#9 24-09-2017 01:03:57

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [BUG] Probleme Wayland & driver nvidia

Ps : ton système est bien tout à jour ? /me se doute que oui mais c'est bizarre que l'entrée GNOME ne te logue pas sur Wayland.


re-hello
chaque matin je lance mon "majjc"
qui fait ceci:

#alias jc mise a jour systeme
alias aptd='sudo apt-get update'
alias aptg='sudo apt-get upgrade'
alias aptf='sudo apt-get full-upgrade'
alias aptr='sudo apt-get autoremove'
alias aptc='sudo apt-get autoclean'
alias majjc='aptd && aptg && aptf && aptr && aptc'
 


(merci encore à la communauté de m'avoir fait decouvrir les alias bash tongue ) bref..
et lorsque je me logue sous "GNOME" il semble que je sois en X11
mais comme je fais les mises à jours avec un autoremove & un autoclean par la même occasion, la difference est peut etre là??

d33p

Dernière modification par d33p (30-09-2017 06:25:18)


science sans conscience n'est que ruine de l'âme...

Hors ligne

#10 24-09-2017 22:17:04

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [BUG] Probleme Wayland & driver nvidia

d33p a écrit :

mais comme je fais les mises à jours avec un autoremove & un autoclean par la même occasion, la difference est peut etre là??


Autoremove désinstalle les paquets devenus inutiles et autoclean supprime les anciennes versions de paquets gardés en cache par Apt. Il n'y a pas de raisons que ces 2 commandes suppriment Wayland.

Ton gestionnaire de connexion est bien gdm ?
Pas certaine mais il me semble que c'est sddm pour Plasma. Peut-être une piste si tu n'utilises pas gdm scratchhead.gif


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#11 25-09-2017 05:36:05

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [BUG] Probleme Wayland & driver nvidia

hello,
En fait je switche à chaque fois, si j'utilise Plasma je passe sous sddm et si j'utilise gnome je passe sous gdm3.
je ne sais pas si c'est vraiment optimisé mais j'ai pris cette habitude..

science sans conscience n'est que ruine de l'âme...

Hors ligne

#12 26-09-2017 17:03:30

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [BUG] Probleme Wayland & driver nvidia

Gdm3 est en version 3.26-0.1 chez moi. Je ne sais pas trop où chercher la cause de l'absence de Wayland scratchhead.gif

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#13 26-09-2017 18:18:28

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [BUG] Probleme Wayland & driver nvidia

je t'avoue que je seche aussi tongue
si je trouve un truc, entre temps, je posterai.

science sans conscience n'est que ruine de l'âme...

Hors ligne

#14 29-09-2017 13:35:40

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [BUG] Probleme Wayland & driver nvidia

hello mercredi,
sur quelques posts j'ai cru comprendre que certaines appli ne fonctionnaient pas bien sur wayland.
https://fedoraproject.org/wiki/How_to_d … d_problems
ici ils parlent de xwayland.
si ça peut t'aider.

science sans conscience n'est que ruine de l'âme...

Hors ligne

#15 29-09-2017 14:19:09

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : W$10 1709 / stretch / ubuntu 17.10 / buster-sid
Noyau : Linux 4.13.0-0.bpo.1-amd64
(G)UI : Mate / Gdm3
Inscription : 11-03-2017

Re : [BUG] Probleme Wayland & driver nvidia

pour ma part , que ce soit gnome kernel 4.9 ou mate kernel 4.12 sous buster , j'obtiens ceci :

$ echo $XDG_SESSION_TYPE


x11



gnome kernel 4.12 ne fonctionne tout simplement pas . dû , je pense , à ma carte graphique .

firmware-amd-graphics

par contre  sous mate , kernel 4.12 , firmware-amd-graphics :

$ dpkg -l | grep wayland



ii  libkf5waylandclient5:amd64                    4:5.37.0-2                           amd64        Qt library wrapper for Wayland libraries
ii  libkf5waylandserver5:amd64                    4:5.37.0-2                           amd64        Qt library wrapper for Wayland libraries
ii  libva-wayland1:amd64                          1.8.3-2                              amd64        Video Acceleration (VA) API for Linux -- Wayland runtime
ii  libwayland-client0:amd64                      1.14.0-1                             amd64        wayland compositor infrastructure - client library
ii  libwayland-cursor0:amd64                      1.14.0-1                             amd64        wayland compositor infrastructure - cursor library
ii  libwayland-egl1-mesa:amd64                    17.2.1-1                             amd64        implementation of the Wayland EGL platform -- runtime
ii  libwayland-server0:amd64                      1.14.0-1                             amd64        wayland compositor infrastructure - server library
ii  xwayland                                      2:1.19.3-2                           amd64        Xwayland X server
 

Dernière modification par Debian Alain (29-09-2017 17:05:07)


1498826560.jpg 1498812139.jpg Bip ! Bip !

Hors ligne

#16 29-09-2017 17:16:40

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [BUG] Probleme Wayland & driver nvidia

Bonjour


echo $XDG_SESSION_TYPE
 




wayland
 



Wayland est toujours la tongue , je sais pas pourquoi vous ne l'avez plus , faut bien choisir Gnome (sur buster ou sid )  comme bureau

Hors ligne

#17 29-09-2017 17:24:48

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : W$10 1709 / stretch / ubuntu 17.10 / buster-sid
Noyau : Linux 4.13.0-0.bpo.1-amd64
(G)UI : Mate / Gdm3
Inscription : 11-03-2017

Re : [BUG] Probleme Wayland & driver nvidia

sous ubuntu 17.04 (sans le firmware de la carte graphique) :

$ echo $XDG_SESSION_TYPE


x11


pourtant :

$ dpkg -l | grep wayland



ii  kwayland-data                                   4:5.31.0-0ubuntu1                                        all          Qt library wrapper for Wayland libraries - data files
ii  kwayland-integration:amd64                      4:5.9.5-0ubuntu0.1                                       amd64        kwayland runtime integration plugins
ii  libkf5waylandclient5:amd64                      4:5.31.0-0ubuntu1                                        amd64        Qt library wrapper for Wayland libraries
ii  libqt5waylandclient5:amd64                      5.7.1~20161021-2build1~1                                 amd64        QtWayland client library
ii  libqt5waylandcompositor5:amd64                  5.7.1~20161021-2build1~1                                 amd64        QtWayland compositor library
ii  libva-wayland1:amd64                            1.7.3-2                                                  amd64        Video Acceleration (VA) API for Linux -- Wayland runtime
ii  libwayland-bin                                  1.12.0-1                                                 amd64        wayland compositor infrastructure - binary utilities
ii  libwayland-client0:amd64                        1.12.0-1                                                 amd64        wayland compositor infrastructure - client library
ii  libwayland-cursor0:amd64                        1.12.0-1                                                 amd64        wayland compositor infrastructure - cursor library
ii  libwayland-dev:amd64                            1.12.0-1                                                 amd64        wayland compositor infrastructure - development files
ii  libwayland-egl1-mesa:amd64                      17.0.7-0ubuntu0.17.04.1                                  amd64        implementation of the Wayland EGL platform -- runtime
ii  libwayland-server0:amd64                        1.12.0-1                                                 amd64        wayland compositor infrastructure - server library
ii  qtwayland5:amd64                                5.7.1~20161021-2build1~1                                 amd64        QtWayland platform plugin
ii  wayland-protocols                               1.7-1                                                    all          wayland compositor protocols
ii  xwayland                                        2:1.19.3-1ubuntu1.1                                      amd64        Xwayland X server
 


à voir (si ça vous intéresse) :

http://linuxfr.org/news/petites-breves- … de-wayland

http://www.toshy.net/article/wayland-de … a-retraite

http://linuxfr.org/news/x-org-est-mort-vive-wayland-3

Dernière modification par Debian Alain (29-09-2017 18:00:14)


1498826560.jpg 1498812139.jpg Bip ! Bip !

Hors ligne

#18 29-09-2017 21:27:18

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [BUG] Probleme Wayland & driver nvidia

ce qui me dérange


les drivers pour les systèmes Linux sont développés pour un serveur X et devront donc être modifiés pour prendre en charge Wayland.
Si cela ne devait pas poser trop de problèmes pour les drivers open-source,
ce sera plus compliqué pour les drivers propriétaires dont les mises à jour dépendront du bon vouloir du fabricant du matériel.
 


il me semble que Nvidia avec son driver nonfree est compatible Wayland , pas testé avec Buster (mon Gnome est sous Stretch ) et le driver nonfree nvidia fonctionne (du moins le bureau pas tout testé les applications )
la nouvelle debian stable Buster , sera sous Gnome + Wayland (X juste pour la compatibilité pour l'instant )
Que vont devenir les bureaux comme Mate ou XFCE  hmm  si le serveur X n'est plus maintenu  roll
@Debian Alain
tu démarre sous  debian Buster + Gnome , tu sélectionne le bureau "Gnome" (par le petit engrenage) tu sera sous Wayland  sinon il y a problème  tongue

Hors ligne

#19 30-09-2017 05:36:37

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [BUG] Probleme Wayland & driver nvidia

tu démarre sous  debian Buster + Gnome , tu sélectionne le bureau "Gnome" (par le petit engrenage) tu sera sous Wayland  sinon il y a problème


hello, de mon coté je selectionne "GNOME" et X11 est affiché lorsque je lance

echo $XDG_SESSION_TYPE

... sad

mais il semblerait que je ne sois pas le seul?? Debian Alain, toi aussi lorsque tu cliques sur "GNOME" et que tu lances ceci:

echo $XDG_SESSION_TYPE

cela t'affiche X11 et non pas wayland??

Dernière modification par d33p (30-09-2017 05:52:22)


science sans conscience n'est que ruine de l'âme...

Hors ligne

#20 30-09-2017 05:55:26

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [BUG] Probleme Wayland & driver nvidia

pour ceux qui voient affiché wayland, vous avez weston d'installé?

science sans conscience n'est que ruine de l'âme...

Hors ligne

#21 30-09-2017 06:03:26

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [BUG] Probleme Wayland & driver nvidia

Debian Alain, tu as parlé d'AMD, c'est également sur ma machine avec mon processeur AMD que j'ai cette chose.
il y aurait peut etre un lien entre les config AMD et le fait qu'on ne soit pas sous wayland?

science sans conscience n'est que ruine de l'âme...

Hors ligne

#22 30-09-2017 06:08:06

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [BUG] Probleme Wayland & driver nvidia

il y en a des autres dans le meme cas...
https://bbs.archlinux.org/viewtopic.php?id=225690
mais dans mon cas, j'ai essayé leurs quelques manip, cela ne change rien...

Dernière modification par d33p (30-09-2017 06:27:41)


science sans conscience n'est que ruine de l'âme...

Hors ligne

#23 30-09-2017 07:13:31

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [BUG] Probleme Wayland & driver nvidia

Bonjour
je pense pas que ce soit lié au matériel AMD ou Nvidia , avant d'avoir une GTX750TI , j'avais une AMD RX550 avec Wayland , j'ai testé Gnome quand Mercredi a annoncé Wayland par défaut sur le bureau Gnome.
par contre sur le disque ou je teste je suis en driver libre "nouveau" ou "amdgpu" selon la carte graphique et en sid , ( hier plus de 400 paquets de mise a jour ) et le gestionnaire de session gdm3
Mercredi est aussi en gpu AMD/ATI
je vais regardé les liens  hmm

nota : dans mon #18 j ai testé Wayland avec 2 gpu gtx750ti et nouveau (peut etre que 2 gpu de type différent posent problème )

PS: j'ajoute ces 2 liens
le wiki (plutot pour Stretch)
https://wiki.debian.org/Wayland
le site de Wayland
https://wayland.freedesktop.org/

nota: il faut une carte graphique bien prise en charge au niveau matériel et plutot tester sur debian Buster (ou Sid) . (les autres distributions je sais pas si le projet est mature )
par exemple sans firmware , la carte est en vesa , ça ne fonctionnera pas correctement
je peut tester un mélange AMD/Nvidia  tongue   , pour les portables il me semble avoir lu que la gestion des 2 gpu sera plus souple que sous X

petit test avec 2 cartes graphiques (nvidia et amd) sur un système amd  sous debian sid
l'écran est branché sur le gpu amd rx550


lspci
 



00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1450
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Device 1451
00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1452
00:01.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 1453
00:02.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1452
00:03.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1452
00:03.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 1453
00:04.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1452
00:07.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1452
00:07.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 1454
00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1452
00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 1454
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 59)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1460
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1461
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1462
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1463
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1464
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1465
00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1466
00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1467
00:19.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1460
00:19.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1461
00:19.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1462
00:19.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1463
00:19.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1464
00:19.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1465
00:19.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1466
00:19.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1467
01:00.0 USB controller: Advanced Micro Devices, Inc. [AMD] Device 43ba (rev 02)
01:00.1 SATA controller: Advanced Micro Devices, Inc. [AMD] Device 43b6 (rev 02)
01:00.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43b1 (rev 02)
02:00.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43b4 (rev 02)
02:01.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43b4 (rev 02)
02:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43b4 (rev 02)
02:03.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43b4 (rev 02)
02:04.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43b4 (rev 02)
02:09.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43b4 (rev 02)
05:00.0 Ethernet controller: Intel Corporation I211 Gigabit Network Connection (rev 03)
08:00.0 USB controller: ASMedia Technology Inc. Device 2142
09:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)
09:00.1 Audio device: NVIDIA Corporation Device 0fbc (rev a1)
0a:00.0 Non-Essential Instrumentation [1300]: Advanced Micro Devices, Inc. [AMD] Device 145a
0a:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Device 1456
0a:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] USB3 Host Controller
0b:00.0 Non-Essential Instrumentation [1300]: Advanced Micro Devices, Inc. [AMD] Device 1455
0b:00.2 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 51)
0b:00.3 Audio device: Advanced Micro Devices, Inc. [AMD] Device 1457
40:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1450
40:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Device 1451
40:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1452
40:02.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1452
40:03.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1452
40:03.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 1453
40:04.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1452
40:07.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1452
40:07.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 1454
40:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1452
40:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 1454
41:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Lexa PRO [Radeon RX 550] (rev c7)
41:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device aae0
42:00.0 Non-Essential Instrumentation [1300]: Advanced Micro Devices, Inc. [AMD] Device 145a
42:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Device 1456
42:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] USB3 Host Controller
43:00.0 Non-Essential Instrumentation [1300]: Advanced Micro Devices, Inc. [AMD] Device 1455
43:00.2 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 51)
 



glxinfo -B
 



name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: X.Org (0x1002)
    Device: Radeon RX 550 Series (AMD POLARIS12 / DRM 3.15.0 / 4.12.0-2-amd64, LLVM 5.0.0) (0x699f)
    Version: 17.2.1
    Accelerated: yes
    Video memory: 2021MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
OpenGL vendor string: X.Org
OpenGL renderer string: Radeon RX 550 Series (AMD POLARIS12 / DRM 3.15.0 / 4.12.0-2-amd64, LLVM 5.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.2.1
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 17.2.1
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.2.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
 



echo $XDG_SESSION_TYPE
 



x11
 


je bascule sur gnome  smile


echo $XDG_SESSION_TYPE
 



wayland
 


le retour de Mesa sous Wayland


glxinfo -B
 



name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: X.Org (0x1002)
    Device: Radeon RX 550 Series (AMD POLARIS12 / DRM 3.15.0 / 4.12.0-2-amd64, LLVM 5.0.0) (0x699f)
    Version: 17.2.1
    Accelerated: yes
    Video memory: 2015MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
OpenGL vendor string: X.Org
OpenGL renderer string: Radeon RX 550 Series (AMD POLARIS12 / DRM 3.15.0 / 4.12.0-2-amd64, LLVM 5.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.2.1
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 17.2.1
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.2.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
 



pour Debian Alain , je pense qu il a un souci sur son installation (firmware-amd-graphics fait planter le système )

pour d33p  je sais pas d'ou vient ce souci  hmm

nota : je suppose que si je branche un deuxième écran sur la carte nvidia (bureau étendu) ça se passe bien mais ce sera pour une prochaine fois  wink
j'ai quelques paquets plus récent que Buster comme Mesa par exemple en version 17 sur sid

Dernière modification par robert2a (30-09-2017 10:01:09)

Hors ligne

#24 30-09-2017 11:33:21

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : W$10 1709 / stretch / ubuntu 17.10 / buster-sid
Noyau : Linux 4.13.0-0.bpo.1-amd64
(G)UI : Mate / Gdm3
Inscription : 11-03-2017

Re : [BUG] Probleme Wayland & driver nvidia

je n'ai , hélas , rien à répondre à robert2a .

si ça peut faire avancer le schmilblick :
(sous buster mate  kernel 4.12)

$ dpkg -l | grep wayland



ii  libkf5waylandclient5:amd64                    4:5.37.0-2                           amd64        Qt library wrapper for Wayland libraries
ii  libkf5waylandserver5:amd64                    4:5.37.0-2                           amd64        Qt library wrapper for Wayland libraries
ii  libva-wayland1:amd64                          1.8.3-2                              amd64        Video Acceleration (VA) API for Linux -- Wayland runtime
ii  libwayland-client0:amd64                      1.14.0-1                             amd64        wayland compositor infrastructure - client library
ii  libwayland-cursor0:amd64                      1.14.0-1                             amd64        wayland compositor infrastructure - cursor library
ii  libwayland-egl1-mesa:amd64                    17.2.1-1                             amd64        implementation of the Wayland EGL platform -- runtime
ii  libwayland-server0:amd64                      1.14.0-1                             amd64        wayland compositor infrastructure - server library
ii  xwayland                                      2:1.19.3-2                           amd64        Xwayland X server
 



(sous buster gnome kernel 4.9)

$ dpkg -l | grep wayland



ii  libkf5waylandclient5:amd64                    4:5.37.0-2                           amd64        Qt library wrapper for Wayland libraries
ii  libkf5waylandserver5:amd64                    4:5.37.0-2                           amd64        Qt library wrapper for Wayland libraries
ii  libva-wayland1:amd64                          1.8.3-2                              amd64        Video Acceleration (VA) API for Linux -- Wayland runtime
ii  libwayland-client0:amd64                      1.14.0-1                             amd64        wayland compositor infrastructure - client library
ii  libwayland-cursor0:amd64                      1.14.0-1                             amd64        wayland compositor infrastructure - cursor library
ii  libwayland-egl1-mesa:amd64                    17.2.1-1                             amd64        implementation of the Wayland EGL platform -- runtime
ii  libwayland-server0:amd64                      1.14.0-1                             amd64        wayland compositor infrastructure - server library
ii  xwayland                                      2:1.19.3-2                           amd64        Xwayland X server
 

Dernière modification par Debian Alain (30-09-2017 11:54:40)


1498826560.jpg 1498812139.jpg Bip ! Bip !

Hors ligne

#25 30-09-2017 17:10:47

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [BUG] Probleme Wayland & driver nvidia

Bonjour,

d33p a écrit :

hello mercredi,
sur quelques posts j'ai cru comprendre que certaines appli ne fonctionnaient pas bien sur wayland.
https://fedoraproject.org/wiki/How_to_d … d_problems
ici ils parlent de xwayland.
si ça peut t'aider.

Merci, ça confirme les problèmes en lien avec Gtk que j'avais lu je ne sais plus où.

d33p a écrit :

pour ceux qui voient affiché wayland, vous avez weston d'installé?

Weston n'est pas installé chez moi. Juste les paquets Wayland que Gnome installe par défaut.

robert2a a écrit :

la nouvelle debian stable Buster , sera sous Gnome + Wayland (X juste pour la compatibilité pour l'instant )
Que vont devenir les bureaux comme Mate ou XFCE  hmm  si le serveur X n'est plus maintenu  roll

J'imagine que les réfractaires à Wayland continuerons de maintenir le serveur X encore longtemps tongue plus sérieusement ces bureaux seront peut-être forcés de se rendre compatibles avec Wayland si ça devient la norme.


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

Pied de page des forums