Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).


L'icône rouge permet de télécharger chaque page du wiki visitée au format PDF et la grise au format ODT → ODT PDF Export

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
utilisateurs:nounours:tutos:imprimante-brother-hl-3040cn-pour-wheezy-et-jessie [26/12/2014 15:09]
nounours [Introduction]
utilisateurs:nounours:tutos:imprimante-brother-hl-3040cn-pour-wheezy-et-jessie [27/11/2018 21:01] (Version actuelle)
nounours [Introduction]
Ligne 1: Ligne 1:
-====== Imprimante brother hl-3040CN pour Wheezy ​et Jessie ======+====== Imprimante brother hl-3040CN pour WheezyJessie ​et Stretch ​======
  
-  * Objet : Installer une imprimante brother hl-3040CN pour Wheezy ​et Jessie+  * Objet : Installer une imprimante brother hl-3040CN pour WheezyJessie, Stretch
   * Niveau requis : {{tag>​débutant avisé}}   * Niveau requis : {{tag>​débutant avisé}}
   * Commentaires : // Installation d'un poste bureautique// ​   * Commentaires : // Installation d'un poste bureautique// ​
Ligne 9: Ligne 9:
 Cette imprimante n'est pas encore dans liste par défaut de cups, et il faut aller chercher les paquets sur le site **Solution Brother**.\\ Cette imprimante n'est pas encore dans liste par défaut de cups, et il faut aller chercher les paquets sur le site **Solution Brother**.\\
 Les paquets fournis par Brother sont prévus pour une architecture i386, uniquement. Les paquets fournis par Brother sont prévus pour une architecture i386, uniquement.
-===== Installation pour Wheezy =====+<note important>​Le 27/11/18, OS Debian Stretch XFCE, impossible d'​installer l'​imprimante avec le script du site officiel Brother. Le script de Démonipuch que l'on trouve sur le site Ubuntu marche (ne pas s'​inquiéter du message d'​erreur du script (2  FAILED).</​note> ​  
 +<note important>​Le 25/3/18, Brother à modifié ses paquets et mis au point un script d'​installation qui à fonctionné pour moi avec **Stretch Xfce**. Il suffit de suivre la notice fournie. 
 +(la traduction automatique par google est suffisante pour comprendre ce qu'il faut faire).\\ 
 +Bien indiquer le nom de l'​imprimante en respectant les majuscules/​minuscule HL-3040CN</​note> ​  
 + 
 +===== Installation pour Wheezy ​et Stretch ​=====
 On va utiliser la commande suivante pour introduire les paquets i386 dans une architecture amd64\\ On va utiliser la commande suivante pour introduire les paquets i386 dans une architecture amd64\\
 cette commande à rentrer qu'une seule fois, sert à rendre compatible les deux architectures. cette commande à rentrer qu'une seule fois, sert à rendre compatible les deux architectures.
Ligne 17: Ligne 22:
  
 <code root> apt-get update </​code>​ <code root> apt-get update </​code>​
-Maintenant on peut installer des paquets pour l'​architecture i386.\\ +Maintenant on peut installer des paquets pour l'​architecture i386 dans une architecture amd64.\\ 
-A installer dans l'​ordre ​(ces paquets ne sont pas dans les dépôts Débian mais dans le site solution Brother).\\+A installer dans l'​ordre.\\
  
 a)\\ a)\\
Ligne 25: Ligne 30:
 <code root> dpkg -i hl3040cncupswrapper-1.1.2-2.i386.deb </​code>​ <code root> dpkg -i hl3040cncupswrapper-1.1.2-2.i386.deb </​code>​
 ** **
-L'​imprimante s'​installe automatiquement dès les paquets installés.**+Pour Wheezy, l'​imprimante s'​installe automatiquement dès les paquets installés.**\\
  
 +
 +**Pour Stretch, il faut en plus, installer les paquets suivants :**
 +<code root>​apt-get install cups-filters:​i386 cups-filters-ippusbxd:​i386 cups-filters-core-drivers:​i386</​code>​
 +
 +
 +**Nota : En effet, il s'agit des paquets pour l'​architecture 32 bits qui ne sont plus installés par défaut dans Stretch.**
  
 __**Changer le format du papier Letter en A4 dans Cups**,__ pour cela, aller dans Cups en tapant dans le navigateur :​\\ __**Changer le format du papier Letter en A4 dans Cups**,__ pour cela, aller dans Cups en tapant dans le navigateur :​\\
Ligne 33: Ligne 44:
 ===== Installation pour Jessie ===== ===== Installation pour Jessie =====
 ==== a) Installation des paquets ==== ==== a) Installation des paquets ====
- 
- 
 On va utiliser la commande suivante pour introduire les paquets i386 dans une architecture amd64\\ On va utiliser la commande suivante pour introduire les paquets i386 dans une architecture amd64\\
 cette commande à rentrer qu'une seule fois, sert à rendre compatible les deux architectures. cette commande à rentrer qu'une seule fois, sert à rendre compatible les deux architectures.
Ligne 44: Ligne 53:
 Les paquets logiciel (.deb) de Brother ne sont plus compatibles tels quels avec Jessie.\\ Les paquets logiciel (.deb) de Brother ne sont plus compatibles tels quels avec Jessie.\\
 Il faut donc, au préalable, installer les paquets suivants :\\ Il faut donc, au préalable, installer les paquets suivants :\\
-<code root> apt-get install a2ps lib32zi ​</​code>​+<code root> apt-get install a2ps</​code>​
  
-Création du répertoire lpd+Création du répertoire lpd\\
 <code root> mkdir /​var/​spool/​lpd </​code>​ <code root> mkdir /​var/​spool/​lpd </​code>​
  
  
-Maintenant on peut installer des paquets pour l'​architecture i386.\\ +Maintenant on peut installer des paquets pour l'​architecture i386 dans une architecture amd64.\\
-A installer dans l'​ordre (ces paquets ne sont pas dans les dépôts Débian mais dans le site solution Brother).+
  
-a)\\ + 
-<code root> dpkg -i hl3040cnlpr-1.1.2-1.i386.deb </​code>​+**Il faut aller sur le site de Brother** et télécharger les paquets suivants :\\ 
 + 
 + 
 +**hl3040cnlpr-1.1.2-1.i386.deb**\\ 
 +et\\ 
 +**hl3040cncupswrapper-1.1.2-2.i386.deb** 
 + 
 + 
 +**__A installer dans l'​ordre.__**\\ 
 + 
 + 
 +a) 
 +<code root> dpkg -i hl3040cnlpr-1.1.2-1.i386.deb </​code>​\\
 b)\\ b)\\
 <code root> dpkg -i hl3040cncupswrapper-1.1.2-2.i386.deb </​code>​ <code root> dpkg -i hl3040cncupswrapper-1.1.2-2.i386.deb </​code>​
Ligne 73: Ligne 93:
 {{http://​pix.toile-libre.org/​upload/​original/​1419601494.png}} {{http://​pix.toile-libre.org/​upload/​original/​1419601494.png}}
 {{http://​pix.toile-libre.org/​upload/​original/​1419601515.png}} {{http://​pix.toile-libre.org/​upload/​original/​1419601515.png}}
 +
 +__**Nota :**__ Il se peut que CUPS soit en Anglais si on utilise Iceweasel.\\
 +Dans ce cas il faut aller dans préférence de Iceweasel\\ (les 3 barres horizontales en haut à droite) > contenu > ajouter une Langue,\\
 +Français/​France [Fr-Fr] et déplacer en haut de la liste.
  
utilisateurs/nounours/tutos/imprimante-brother-hl-3040cn-pour-wheezy-et-jessie.1419602952.txt.gz · Dernière modification: 26/12/2014 15:09 par nounours

Pied de page des forums

Propulsé par FluxBB