Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#151 02-02-2019 22:44:26

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Freeze au lancement de GNOME

il me semble que cela ne posait pas problème.
pour passer a buster
modifier le sources.list


#Buster10
deb http://deb.debian.org/debian/ buster main contrib non-free
deb http://security.debian.org/ buster/updates main contrib non-free
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
 



dans l'ordre


apt-get update
 




apt-get upgrade
 




apt-get dist-upgrade
 




reboot
 



dit moi quel est ton bureau actuel , j'ai oublié roll
sur ton profil il y a gnome

le retour de cette commande pour vérifier que tout est correct pour le gpu intel


glxinfo -B
 

Dernière modification par robert2a (02-02-2019 22:47:59)

Hors ligne

#152 02-02-2019 23:29:26

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Freeze au lancement de GNOME

si le #151 est correct

a priori pour l'instant tu est sous mate ?
sous buster la commande "su" est devenue "su -" pour passer en root
installer bumblebee


apt-get install bumblebee-nvidia primus
 


installer ces paquets


apt-get --reinstall install nvidia-driver libgl1-nvidia-glx
 



Ajouter ton utilisateur de connexion au groupe bumblebee
Ajoutez votre utilisateur au groupe bumblebee - là aussi, remplacez USER du tuto par votre nom d'utilisateur - :
tu remplace user par le nom de ton utilisateur
la commande root avec "su -"


adduser USER bumblebee
 


multiarch installé en #84  rien a faire (ainsi que le blacklist de tpm et nouveau)
et les firmwares sont présent depuis stretch
un reboot


reboot
 


tester bumblebee (a faire en utilsateur simple (pas en root) )


optirun glxinfo -B
 



normalement ça doit fonctionner
le #151 c'est pour migrer en Buster
le #152 c'est pour installer bumblebee-nvidia

on a réussi ici  =>  https://debian-facile.org/viewtopic.php?id=23548&p=4
déjà vérifier que la migration vers buster se passe bien.

Dernière modification par robert2a (02-02-2019 23:39:53)

Hors ligne

#153 03-02-2019 08:50:47

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

Alors je vais refaire un point ^^.

Je ne vois aucun inconvénient à passer sous buster si cela me permets d'obtenir l'autonomie nécessaire sur un portable.
Alors je suis bien sous mate. Mais j'ai également KDE/Plasma d'installé. Mais par défaut c'est ligtdm qui gère le tout. J'aime bien GNOME mais vu que ça à l'air vraiment galère de rester sur GNOME je pense in fine passé sous KDE/plasma.

Du coup malgré cette installation je peux quand même faire ta manip de migration sous buster ? Ou dois-je purger KDE d'abord ?

Hors ligne

#154 03-02-2019 08:53:17

Herve33
Membre
Lieu : Mérignac 33
Distrib. : Debian 10
(G)UI : Kde
Inscription : 21-09-2016

Re : [RESOLU] Freeze au lancement de GNOME

Bonjour,
que est l'intérêt de passer sous buster aujourd'huiscratchhead.gif, ça sera bientôt la version stable de debian ?

Acer Aspire 5733 - Debian 10 Kde

Hors ligne

#155 03-02-2019 09:05:27

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

Bah la pour mon cas particulier c'est pour essayer de faire fonctionner la technologie OPTIMUS. Et oui il me semble que c'est la prochaine version stable qui remplacera Stretch si j'ai bien compris.

Hors ligne

#156 03-02-2019 10:41:17

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Freeze au lancement de GNOME

Bonjour
pour migrer vers Buster ça va prendre un peu de temps , pour tout mettre a jour.
pour le bureau a mon avis tous fonctionnent quand le système est correct
hier actarkus a voulu rester sur Mate , donc on n'a pas testé mais aucune raison que cela ne fonctionne pas avec n'importe quel bureau
l'intérêt c'est que le matériel est mieux géré , le problème de conflit de paquets a disparut après la migration.
A priori on a trouvé le mode d'emploi pour que ça fonctionne correctement ( en #152)

Hors ligne

#157 03-02-2019 11:46:34

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Freeze au lancement de GNOME

Tu a commencé a faire la migration ?
a mon avis KDE est cassé
pour gnome , un simple "install gnome-core gdm3" va le réinstaller en mode minimal
mais il faut que la migration soit terminé et bumblebee fonctionnel
tu décide quel bureau tu veut et tu l'installe (gnome fonctionne mieux avec gdm3 qui est son gestionnaire de connexion officiel).
Pour Wayland sur gnome je suppose qu'il ne fonctionne pas avec bumblebee (uniquement sous X)
pour KDE je connais pas ce bureau sous debian

Hors ligne

#158 03-02-2019 12:26:57

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

Alors je vais la lancer la. Donc pour cette migration je m'en moque de KDE ? La je suis parti pour le virer en attendant de faire la migration histoire d'avoir un truc propre

Hors ligne

#159 03-02-2019 12:32:42

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

Voilà c'est fait j'ai suivi ca : https://wiki.debian-fr.xyz/Nettoyer_sa_Debian du coup je n'ai plus rien concernant KDE. Je vais lancer la migration maintenant.

Hors ligne

#160 03-02-2019 13:23:58

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Freeze au lancement de GNOME

Il ne faut pas casser debian , pour le nettoyage rien d'urgent mais si c'est fait tant mieux , quand tu a fait la mise a jour vers buster , il me faut le retour de cette commande avant de faire l'installation de bumblebee
a faire en utilisateur simple ne fonctionne pas en root


glxinfo -B
 



pour les commandes root (avec su) faire "su -" pour se connecter en root
ps: pour sudo rien n'a changé je suppose sous buster

Hors ligne

#161 03-02-2019 13:27:59

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

Voilà migration faite

glxinfo -B


name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel Open Source Technology Center (0x8086)
    Device: Mesa DRI Intel(R) HD Graphics 630 (Kaby Lake GT2)  (0x591b)
    Version: 18.3.2
    Accelerated: yes
    Video memory: 3072MB
    Unified memory: yes
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 630 (Kaby Lake GT2)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.3.2
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 18.3.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 18.3.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
 

Hors ligne

#162 03-02-2019 13:33:39

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Freeze au lancement de GNOME

c'est parfait suis le #152 pour bumblebee, je suppose que a la fin de la migration tu a fait un reboot  wink
nota: ce serait bien que le conflit de version ne soit plus avec les commandes de bumblebee roll

Dernière modification par robert2a (03-02-2019 13:38:23)

Hors ligne

#163 03-02-2019 14:19:32

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

Oui j'avais bien reboot avant ! Et c'est parti pour le bumblebee!!!

Hors ligne

#164 03-02-2019 14:23:39

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Freeze au lancement de GNOME

Pas finit encore ?  roll  tongue  wink

Hors ligne

#165 03-02-2019 14:27:45

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

Si fini et rebelote je suis sur la console tty1 complètement figé et plus d'interface graphique sad...  Je suis maudits ce n'est pas possible :'(

Dernière modification par Lam3ch (03-02-2019 14:28:45)

Hors ligne

#166 03-02-2019 14:31:14

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Freeze au lancement de GNOME

aucune erreurs a l'installation des paquets ?

il me faudrait le log de X => cat /var/log/Xorg.0.log

si tu peu le visualiser il charge quoi comme driver , les lignes commences par modeset , quelle carte intel ou nvidia ?
démarre avec l'option nomodeset voir si tu retrouve le bureau a partir du menu de grub touche "e"

Ne désinstalle rien on va essayé de trouver le bug

tu a aussi le mode sans échec a tester

le #56 il a récupéré le log d'installation => https://debian-facile.org/viewtopic.php?id=23548&p=3
avant de redémarré il aurait fallu vérifier , pas pensé  roll

Dernière modification par robert2a (03-02-2019 14:41:01)

Hors ligne

#167 03-02-2019 14:39:24

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

Du coup j'ai refais le #94 et me revoilà :'(

Hors ligne

#168 03-02-2019 14:45:39

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Freeze au lancement de GNOME

Bon tant pis
que donne ces deux commandes


apt-cache policy linux-image-amd64
 



linux-image-amd64:
  Installé : 4.19+101
  Candidat : 4.19+101
 Table de version :
 *** 4.19+101 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
 



apt-cache policy linux-headers-amd64
 



linux-headers-amd64:
  Installé : 4.19+101
  Candidat : 4.19+101
 Table de version :
 *** 4.19+101 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
 



et


apt-cache policy dkms
 



dkms:
  Installé : 2.6.1-4
  Candidat : 2.6.1-4
 Table de version :
 *** 2.6.1-4 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        500 http://deb.debian.org/debian buster/main i386 Packages
        100 /var/lib/dpkg/status
 



si tout est correct fait une simulation


apt-get -s install bumblebee-nvidia primus
 



et poste le retour

Dernière modification par robert2a (03-02-2019 14:50:20)

Hors ligne

#169 03-02-2019 16:20:36

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

Voici les retours demandés :

apt-cache policy linux-image-amd64


linux-image-amd64:
  Installé : 4.19+101
  Candidat : 4.19+101
 Table de version :
 *** 4.19+101 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
 



apt-cache policy linux-header-amd64


linux-headers-amd64:
  Installé : 4.19+101
  Candidat : 4.19+101
 Table de version :
 *** 4.19+101 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
 



apt-cache policy dkms


dkms:
  Installé : 2.6.1-4
  Candidat : 2.6.1-4
 Table de version :
 *** 2.6.1-4 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        500 http://deb.debian.org/debian buster/main i386 Packages
        100 /var/lib/dpkg/status
 



apt-cache policy dkms


dkms:
  Installé : 2.6.1-4
  Candidat : 2.6.1-4
 Table de version :
 *** 2.6.1-4 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        500 http://deb.debian.org/debian buster/main i386 Packages
        100 /var/lib/dpkg/status
 


Donc à priori tout est correccte.

apt*get -s install bumblebee-nvidia primus


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  bbswitch-dkms bumblebee gcc-8-base:i386 glx-alternative-mesa glx-alternative-nvidia
  glx-diversions libatomic1:i386 libbsd0:i386 libc6:i386 libdrm-amdgpu1:i386
  libdrm-intel1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386 libedit2:i386
  libelf1:i386 libexpat1:i386 libffi6:i386 libgcc1:i386 libgl1:i386 libgl1-mesa-dri:i386
  libgl1-mesa-glx:i386 libglapi-mesa:i386 libglvnd0:i386 libglx-mesa0:i386 libglx0:i386
  libidn2-0:i386 libllvm7:i386 libnvidia-glcore libnvidia-ml1 libpciaccess0:i386
  libsensors5:i386 libstdc++6:i386 libtinfo6:i386 libunistring2:i386 libx11-6:i386
  libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386
  libxcb-present0:i386 libxcb-sync1:i386 libxcb1:i386 libxdamage1:i386 libxdmcp6:i386
  libxext6:i386 libxfixes3:i386 libxnvctrl0 libxshmfence1:i386 libxxf86vm1:i386
  nvidia-alternative nvidia-installer-cleanup nvidia-kernel-common nvidia-kernel-dkms
  nvidia-kernel-support nvidia-legacy-check nvidia-modprobe nvidia-settings nvidia-support
  nvidia-vdpau-driver primus-libs primus-libs:i386 primus-libs-ia32:i386 socat update-glx
  xserver-xorg-video-nvidia zlib1g:i386
Paquets suggérés :
  nvidia-driver glibc-doc:i386 locales:i386 lm-sensors:i386 nvidia-driver-libs-nonglvnd
  | nvidia-legacy-390xx-driver-libs-nonglvnd
Paquets recommandés :
  nvidia-driver | libcuda1 libgl1-nvidia-glvnd-glx | libgl1-nvidia-glx nvidia-driver
Les NOUVEAUX paquets suivants seront installés :
  bbswitch-dkms bumblebee bumblebee-nvidia gcc-8-base:i386 glx-alternative-mesa
  glx-alternative-nvidia glx-diversions libatomic1:i386 libbsd0:i386 libc6:i386
  libdrm-amdgpu1:i386 libdrm-intel1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386
  libedit2:i386 libelf1:i386 libexpat1:i386 libffi6:i386 libgcc1:i386 libgl1:i386
  libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386 libglvnd0:i386
  libglx-mesa0:i386 libglx0:i386 libidn2-0:i386 libllvm7:i386 libnvidia-glcore libnvidia-ml1
  libpciaccess0:i386 libsensors5:i386 libstdc++6:i386 libtinfo6:i386 libunistring2:i386
  libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386
  libxcb-glx0:i386 libxcb-present0:i386 libxcb-sync1:i386 libxcb1:i386 libxdamage1:i386
  libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxnvctrl0 libxshmfence1:i386 libxxf86vm1:i386
  nvidia-alternative nvidia-installer-cleanup nvidia-kernel-common nvidia-kernel-dkms
  nvidia-kernel-support nvidia-legacy-check nvidia-modprobe nvidia-settings nvidia-support
  nvidia-vdpau-driver primus primus-libs primus-libs:i386 primus-libs-ia32:i386 socat
  update-glx xserver-xorg-video-nvidia zlib1g:i386
0 mis à jour, 70 nouvellement installés, 0 à enlever et 0 non mis à jour.
Inst bbswitch-dkms (0.8-8 Debian:testing [amd64])
Inst bumblebee (3.2.1-19 Debian:testing [amd64])
Inst update-glx (0.9.1 Debian:testing [amd64])
Inst glx-alternative-mesa (0.9.1 Debian:testing [amd64])
Inst nvidia-installer-cleanup (20151021+9 Debian:testing [amd64])
Conf nvidia-installer-cleanup (20151021+9 Debian:testing [amd64])
Inst glx-diversions (0.9.1 Debian:testing [amd64])
Inst glx-alternative-nvidia (0.9.1 Debian:testing [amd64])
Inst nvidia-legacy-check (390.87-6 Debian:testing [amd64])
Conf nvidia-legacy-check (390.87-6 Debian:testing [amd64])
Inst nvidia-alternative (390.87-6 Debian:testing [amd64])
Inst nvidia-kernel-common (20151021+9 Debian:testing [amd64])
Inst nvidia-modprobe (390.87-1 Debian:testing [amd64])
Inst nvidia-kernel-support (390.87-6 Debian:testing [amd64])
Inst nvidia-kernel-dkms (390.87-6 Debian:testing [amd64])
Inst libxnvctrl0 (390.87-1 Debian:testing [amd64])
Inst nvidia-settings (390.87-1 Debian:testing [amd64])
Inst nvidia-vdpau-driver (390.87-6 Debian:testing [amd64])
Inst libnvidia-glcore (390.87-6 Debian:testing [amd64])
Inst nvidia-support (20151021+9 Debian:testing [amd64])
Inst xserver-xorg-video-nvidia (390.87-6 Debian:testing [amd64])
Inst bumblebee-nvidia (3.2.1-19 Debian:testing [amd64])
Inst gcc-8-base:i386 (8.2.0-15 Debian:testing [i386])
Inst libgcc1:i386 (1:8.2.0-15 Debian:testing [i386]) []
Inst libc6:i386 (2.28-5 Debian:testing [i386])
Inst libatomic1:i386 (8.2.0-15 Debian:testing [i386])
Inst libbsd0:i386 (0.9.1-1 Debian:testing [i386])
Inst libdrm2:i386 (2.4.95-1 Debian:testing [i386])
Inst libdrm-amdgpu1:i386 (2.4.95-1 Debian:testing [i386])
Inst zlib1g:i386 (1:1.2.11.dfsg-1 Debian:testing [i386])
Inst libpciaccess0:i386 (0.14-1 Debian:testing [i386])
Inst libdrm-intel1:i386 (2.4.95-1 Debian:testing [i386])
Inst libdrm-nouveau2:i386 (2.4.95-1 Debian:testing [i386])
Inst libdrm-radeon1:i386 (2.4.95-1 Debian:testing [i386])
Inst libtinfo6:i386 (6.1+20181013-1 Debian:testing [i386])
Inst libedit2:i386 (3.1-20181209-1 Debian:testing [i386])
Inst libelf1:i386 (0.175-2 Debian:testing [i386])
Inst libexpat1:i386 (2.2.6-1 Debian:testing [i386])
Inst libffi6:i386 (3.2.1-9 Debian:testing [i386])
Inst libglapi-mesa:i386 (18.3.2-1 Debian:testing [i386])
Inst libstdc++6:i386 (8.2.0-15 Debian:testing [i386])
Inst libllvm7:i386 (1:7.0.1-4 Debian:testing [i386])
Inst libsensors5:i386 (1:3.5.0-3 Debian:testing [i386])
Inst libgl1-mesa-dri:i386 (18.3.2-1 Debian:testing [i386])
Inst libglvnd0:i386 (1.1.0-1 Debian:testing [i386])
Inst libxau6:i386 (1:1.0.8-1+b2 Debian:testing [i386])
Inst libxdmcp6:i386 (1:1.1.2-3 Debian:testing [i386])
Inst libxcb1:i386 (1.13.1-2 Debian:testing [i386])
Inst libx11-6:i386 (2:1.6.7-1 Debian:testing [i386])
Inst libxext6:i386 (2:1.3.3-1+b2 Debian:testing [i386])
Inst libx11-xcb1:i386 (2:1.6.7-1 Debian:testing [i386])
Inst libxcb-dri2-0:i386 (1.13.1-2 Debian:testing [i386])
Inst libxcb-dri3-0:i386 (1.13.1-2 Debian:testing [i386])
Inst libxcb-glx0:i386 (1.13.1-2 Debian:testing [i386])
Inst libxcb-present0:i386 (1.13.1-2 Debian:testing [i386])
Inst libxcb-sync1:i386 (1.13.1-2 Debian:testing [i386])
Inst libxfixes3:i386 (1:5.0.3-1 Debian:testing [i386])
Inst libxdamage1:i386 (1:1.1.4-3 Debian:testing [i386])
Inst libxshmfence1:i386 (1.3-1 Debian:testing [i386])
Inst libxxf86vm1:i386 (1:1.1.4-1+b2 Debian:testing [i386])
Inst libglx-mesa0:i386 (18.3.2-1 Debian:testing [i386])
Inst libglx0:i386 (1.1.0-1 Debian:testing [i386])
Inst libgl1:i386 (1.1.0-1 Debian:testing [i386])
Inst libgl1-mesa-glx:i386 (18.3.2-1 Debian:testing [i386])
Inst libunistring2:i386 (0.9.10-1 Debian:testing [i386])
Inst libidn2-0:i386 (2.0.5-1 Debian:testing [i386])
Inst libnvidia-ml1 (390.87-6 Debian:testing [amd64])
Inst socat (1.7.3.2-2 Debian:testing [amd64])
Inst primus-libs (0~20150328-7 Debian:testing [amd64])
Inst primus (0~20150328-7 Debian:testing [amd64])
Inst primus-libs:i386 (0~20150328-7 Debian:testing [i386])
Inst primus-libs-ia32:i386 (0~20150328-7 Debian:testing [i386])
Conf bbswitch-dkms (0.8-8 Debian:testing [amd64])
Conf bumblebee (3.2.1-19 Debian:testing [amd64])
Conf update-glx (0.9.1 Debian:testing [amd64])
Conf glx-alternative-mesa (0.9.1 Debian:testing [amd64])
Conf glx-diversions (0.9.1 Debian:testing [amd64])
Conf glx-alternative-nvidia (0.9.1 Debian:testing [amd64])
Conf nvidia-alternative (390.87-6 Debian:testing [amd64])
Conf nvidia-kernel-common (20151021+9 Debian:testing [amd64])
Conf nvidia-modprobe (390.87-1 Debian:testing [amd64])
Conf nvidia-kernel-support (390.87-6 Debian:testing [amd64])
Conf nvidia-kernel-dkms (390.87-6 Debian:testing [amd64])
Conf libxnvctrl0 (390.87-1 Debian:testing [amd64])
Conf nvidia-settings (390.87-1 Debian:testing [amd64])
Conf nvidia-vdpau-driver (390.87-6 Debian:testing [amd64])
Conf libnvidia-glcore (390.87-6 Debian:testing [amd64])
Conf nvidia-support (20151021+9 Debian:testing [amd64])
Conf xserver-xorg-video-nvidia (390.87-6 Debian:testing [amd64])
Conf bumblebee-nvidia (3.2.1-19 Debian:testing [amd64])
Conf gcc-8-base:i386 (8.2.0-15 Debian:testing [i386])
Conf libgcc1:i386 (1:8.2.0-15 Debian:testing [i386])
Conf libc6:i386 (2.28-5 Debian:testing [i386])
Conf libatomic1:i386 (8.2.0-15 Debian:testing [i386])
Conf libbsd0:i386 (0.9.1-1 Debian:testing [i386])
Conf libdrm2:i386 (2.4.95-1 Debian:testing [i386])
Conf libdrm-amdgpu1:i386 (2.4.95-1 Debian:testing [i386])
Conf zlib1g:i386 (1:1.2.11.dfsg-1 Debian:testing [i386])
Conf libpciaccess0:i386 (0.14-1 Debian:testing [i386])
Conf libdrm-intel1:i386 (2.4.95-1 Debian:testing [i386])
Conf libdrm-nouveau2:i386 (2.4.95-1 Debian:testing [i386])
Conf libdrm-radeon1:i386 (2.4.95-1 Debian:testing [i386])
Conf libtinfo6:i386 (6.1+20181013-1 Debian:testing [i386])
Conf libedit2:i386 (3.1-20181209-1 Debian:testing [i386])
Conf libelf1:i386 (0.175-2 Debian:testing [i386])
Conf libexpat1:i386 (2.2.6-1 Debian:testing [i386])
Conf libffi6:i386 (3.2.1-9 Debian:testing [i386])
Conf libglapi-mesa:i386 (18.3.2-1 Debian:testing [i386])
Conf libstdc++6:i386 (8.2.0-15 Debian:testing [i386])
Conf libllvm7:i386 (1:7.0.1-4 Debian:testing [i386])
Conf libsensors5:i386 (1:3.5.0-3 Debian:testing [i386])
Conf libgl1-mesa-dri:i386 (18.3.2-1 Debian:testing [i386])
Conf libglvnd0:i386 (1.1.0-1 Debian:testing [i386])
Conf libxau6:i386 (1:1.0.8-1+b2 Debian:testing [i386])
Conf libxdmcp6:i386 (1:1.1.2-3 Debian:testing [i386])
Conf libxcb1:i386 (1.13.1-2 Debian:testing [i386])
Conf libx11-6:i386 (2:1.6.7-1 Debian:testing [i386])
Conf libxext6:i386 (2:1.3.3-1+b2 Debian:testing [i386])
Conf libx11-xcb1:i386 (2:1.6.7-1 Debian:testing [i386])
Conf libxcb-dri2-0:i386 (1.13.1-2 Debian:testing [i386])
Conf libxcb-dri3-0:i386 (1.13.1-2 Debian:testing [i386])
Conf libxcb-glx0:i386 (1.13.1-2 Debian:testing [i386])
Conf libxcb-present0:i386 (1.13.1-2 Debian:testing [i386])
Conf libxcb-sync1:i386 (1.13.1-2 Debian:testing [i386])
Conf libxfixes3:i386 (1:5.0.3-1 Debian:testing [i386])
Conf libxdamage1:i386 (1:1.1.4-3 Debian:testing [i386])
Conf libxshmfence1:i386 (1.3-1 Debian:testing [i386])
Conf libxxf86vm1:i386 (1:1.1.4-1+b2 Debian:testing [i386])
Conf libglx-mesa0:i386 (18.3.2-1 Debian:testing [i386])
Conf libglx0:i386 (1.1.0-1 Debian:testing [i386])
Conf libgl1:i386 (1.1.0-1 Debian:testing [i386])
Conf libgl1-mesa-glx:i386 (18.3.2-1 Debian:testing [i386])
Conf libunistring2:i386 (0.9.10-1 Debian:testing [i386])
Conf libidn2-0:i386 (2.0.5-1 Debian:testing [i386])
Conf libnvidia-ml1 (390.87-6 Debian:testing [amd64])
Conf socat (1.7.3.2-2 Debian:testing [amd64])
Conf primus-libs (0~20150328-7 Debian:testing [amd64])
Conf primus (0~20150328-7 Debian:testing [amd64])
Conf primus-libs:i386 (0~20150328-7 Debian:testing [i386])
Conf primus-libs-ia32:i386 (0~20150328-7 Debian:testing [i386])
 



Je suis un cas désespéré pas vrai ? :'(

Hors ligne

#170 03-02-2019 16:46:56

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Freeze au lancement de GNOME

on va tester sans le multiarch


apt-get purge ".*:i386"
 



dpkg --remove-architecture i386
 



apt-get update
 



apt-get upgrade
 



apt-get autoremove --purge
 



apt-get autoclean
 

Dernière modification par robert2a (03-02-2019 20:21:42)

Hors ligne

#171 03-02-2019 16:58:12

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Freeze au lancement de GNOME

puis tu teste


apt-get -s install bumblebee-nvidia primus nvidia-driver libgl1-nvidia-glx
 


pour le faire


apt-get install bumblebee-nvidia primus nvidia-driver libgl1-nvidia-glx
 



tu met le log de la console dans un fichier texte et tu ne redémarre pas la machine

vers la fin du log tu dois trouver quelque chose de ce genre


Loading new nvidia-current-390.87 DKMS files...
Building for 4.19.0-1-amd64
Building initial module for 4.19.0-1-amd64
Done.

nvidia-current.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/dkms/

nvidia-current-modeset.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/dkms/

nvidia-current-drm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/dkms/

nvidia-current-uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/dkms/

depmod...

DKMS: install completed.
Paramétrage de bumblebee-nvidia (3.2.1-19) ...
update-alternatives: erreur: l'alternative /usr/lib/nvidia/bumblebee pour glx n'est pas enregistrée ; pas de configuration
Traitement des actions différées (« triggers ») pour libc-bin (2.28-5) ...
Traitement des actions différées (« triggers ») pour initramfs-tools (0.132) ...
update-initramfs: Generating /boot/initrd.img-4.19.0-1-amd64
Traitement des actions différées (« triggers ») pour systemd (240-4) ...
Traitement des actions différées (« triggers ») pour update-glx (0.9.1) ...
Traitement des actions différées (« triggers ») pour glx-alternative-nvidia (0.9.1) ...
update-alternatives: utilisation de « /usr/lib/nvidia » pour fournir « /usr/lib/glx » (glx) en mode automatique
Traitement des actions différées (« triggers ») pour glx-alternative-mesa (0.9.1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.28-5) ...
Traitement des actions différées (« triggers ») pour initramfs-tools (0.132) ...
update-initramfs: Generating /boot/initrd.img-4.19.0-1-amd64
Traitement des actions différées (« triggers ») pour bumblebee (3.2.1-19) ...
 



comme quoi la création des modules est correcte et aucune erreur

par exemple comme ceci parce que dans notre test le paquet "libgl1-nvidia-glx" n'était pas installé


update-alternatives: erreur: l'alternative /usr/lib/nvidia/bumblebee pour glx n'est pas enregistrée ; pas de configuration
 



les fichiers pour "blacklister" sont toujours présent ?  nouveau et tpm

si tu remarque quelque chose tu ne redémarre pas et tu poste la ou les erreurs
ps: soit vigilant pour le nettoyage au dessus , normalement il ne doit pas avoir grand chose ou rien avec l'autoremove

Dernière modification par robert2a (03-02-2019 17:01:10)

Hors ligne

#172 03-02-2019 17:08:37

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

dpkg --remove-architecture i386


dpkg: erreur: impossible de supprimer l'architecture « i386 »actuellement utilisée dans la base de données



c'est bizarre ça!

Hors ligne

#173 03-02-2019 17:18:31

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Freeze au lancement de GNOME

oui bizzare , il doit falloir faire quelque chose avant , je regarde ou si un barbu passe par la ......

Dernière modification par robert2a (03-02-2019 17:18:48)

Hors ligne

#174 03-02-2019 17:21:00

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Freeze au lancement de GNOME

j'ai trouvé tongue


Notez qu'avant d'effacer une architecture, vous devez en effacer tous les paquets correspondants :
 



il faut faire la deuxième commande en premier  roll


apt-get purge ".*:i386"
 



nota: j'ai modifié le #170

Dernière modification par robert2a (03-02-2019 20:21:09)

Hors ligne

#175 03-02-2019 18:50:48

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

ce ne serait pas i386 plutôt ???

la ça me renvoi ceci :

apt-get purge ".*:i36"


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet .*:i36
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « .* »
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « .* »

Dernière modification par Lam3ch (03-02-2019 18:55:32)

Hors ligne

Pied de page des forums