Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#201 04-02-2019 13:49:40

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

Je n'ai pas d'accès internet pour faire cette manip je vais tester ça se soir. Est-ce que j'enregistre un log ou autre avant de redémarrer ? big_smile Je mettrai au moins le retour console de l'apt-get

Hors ligne

#202 04-02-2019 13:59:59

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Freeze au lancement de GNOME

tu parle de faire ceci ?


apt-get install bumblebee-nvidia primus nvidia-driver libgl1-nvidia-glx
 



avec gnome et gdm3 et le fichier xorg.conf ?

En ligne

#203 04-02-2019 22:36:03

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

Yes c'est bien ça. Je lance ça maintenant.

Hors ligne

#204 04-02-2019 22:46:20

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

apt-get install bumblebee-nvidia primus nvidia-driver libgl1-nvidia-glx


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  bbswitch-dkms bumblebee glx-alternative-mesa glx-alternative-nvidia glx-diversions libegl-nvidia0
  libegl1-nvidia libgles-nvidia1 libgles-nvidia2 libgles1 libglx-nvidia0 libnvidia-cfg1 libnvidia-eglcore
  libnvidia-glcore libnvidia-ml1 libxnvctrl0 nvidia-alternative nvidia-driver-bin nvidia-driver-libs-nonglvnd
  nvidia-installer-cleanup nvidia-kernel-common nvidia-kernel-dkms nvidia-kernel-support nvidia-legacy-check
  nvidia-modprobe nvidia-persistenced nvidia-settings nvidia-support nvidia-vdpau-driver primus-libs socat
  update-glx xserver-xorg-video-nvidia
Paquets recommandés :
  nvidia-driver-libs-nonglvnd-i386 nvidia-nonglvnd-vulkan-icd primus-libs-ia32
Les NOUVEAUX paquets suivants seront installés :
  bbswitch-dkms bumblebee bumblebee-nvidia glx-alternative-mesa glx-alternative-nvidia glx-diversions
  libegl-nvidia0 libegl1-nvidia libgl1-nvidia-glx libgles-nvidia1 libgles-nvidia2 libgles1 libglx-nvidia0
  libnvidia-cfg1 libnvidia-eglcore libnvidia-glcore libnvidia-ml1 libxnvctrl0 nvidia-alternative
  nvidia-driver nvidia-driver-bin nvidia-driver-libs-nonglvnd nvidia-installer-cleanup nvidia-kernel-common
  nvidia-kernel-dkms nvidia-kernel-support nvidia-legacy-check nvidia-modprobe nvidia-persistenced
  nvidia-settings nvidia-support nvidia-vdpau-driver primus primus-libs socat update-glx
  xserver-xorg-video-nvidia
0 mis à jour, 37 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/31,8 Mo dans les archives.
Après cette opération, 123 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Extraction des modèles depuis les paquets : 100%
Préconfiguration des paquets...
Sélection du paquet bbswitch-dkms précédemment désélectionné.
(Lecture de la base de données... 282819 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../bbswitch-dkms_0.8-8_amd64.deb ...
Dépaquetage de bbswitch-dkms (0.8-8) ...
Sélection du paquet bumblebee précédemment désélectionné.
Préparation du dépaquetage de .../bumblebee_3.2.1-19_amd64.deb ...
Dépaquetage de bumblebee (3.2.1-19) ...
Sélection du paquet update-glx précédemment désélectionné.
Préparation du dépaquetage de .../update-glx_0.9.1_amd64.deb ...
Dépaquetage de update-glx (0.9.1) ...
Sélection du paquet glx-alternative-mesa précédemment désélectionné.
Préparation du dépaquetage de .../glx-alternative-mesa_0.9.1_amd64.deb ...
Dépaquetage de glx-alternative-mesa (0.9.1) ...
Sélection du paquet nvidia-installer-cleanup précédemment désélectionné.
Préparation du dépaquetage de .../nvidia-installer-cleanup_20151021+9_amd64.deb ...
Dépaquetage de nvidia-installer-cleanup (20151021+9) ...
Paramétrage de nvidia-installer-cleanup (20151021+9) ...
Sélection du paquet glx-diversions précédemment désélectionné.
(Lecture de la base de données... 282958 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../glx-diversions_0.9.1_amd64.deb ...
Dépaquetage de glx-diversions (0.9.1) ...
Sélection du paquet glx-alternative-nvidia précédemment désélectionné.
Préparation du dépaquetage de .../glx-alternative-nvidia_0.9.1_amd64.deb ...
Dépaquetage de glx-alternative-nvidia (0.9.1) ...
Sélection du paquet nvidia-legacy-check précédemment désélectionné.
Préparation du dépaquetage de .../nvidia-legacy-check_390.87-6_amd64.deb ...
Dépaquetage de nvidia-legacy-check (390.87-6) ...
Paramétrage de nvidia-legacy-check (390.87-6) ...
Sélection du paquet nvidia-alternative précédemment désélectionné.
(Lecture de la base de données... 282988 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../00-nvidia-alternative_390.87-6_amd64.deb ...
Dépaquetage de nvidia-alternative (390.87-6) ...
Sélection du paquet libnvidia-glcore:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../01-libnvidia-glcore_390.87-6_amd64.deb ...
Dépaquetage de libnvidia-glcore:amd64 (390.87-6) ...
Sélection du paquet nvidia-support précédemment désélectionné.
Préparation du dépaquetage de .../02-nvidia-support_20151021+9_amd64.deb ...
Dépaquetage de nvidia-support (20151021+9) ...
Sélection du paquet libgl1-nvidia-glx:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../03-libgl1-nvidia-glx_390.87-6_amd64.deb ...
Dépaquetage de libgl1-nvidia-glx:amd64 (390.87-6) ...
Sélection du paquet libnvidia-eglcore:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../04-libnvidia-eglcore_390.87-6_amd64.deb ...
Dépaquetage de libnvidia-eglcore:amd64 (390.87-6) ...
Sélection du paquet libegl-nvidia0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../05-libegl-nvidia0_390.87-6_amd64.deb ...
Dépaquetage de libegl-nvidia0:amd64 (390.87-6) ...
Sélection du paquet libegl1-nvidia:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../06-libegl1-nvidia_390.87-6_amd64.deb ...
Dépaquetage de libegl1-nvidia:amd64 (390.87-6) ...
Sélection du paquet nvidia-driver-libs-nonglvnd:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../07-nvidia-driver-libs-nonglvnd_390.87-6_amd64.deb ...
Dépaquetage de nvidia-driver-libs-nonglvnd:amd64 (390.87-6) ...
Sélection du paquet libnvidia-ml1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../08-libnvidia-ml1_390.87-6_amd64.deb ...
Dépaquetage de libnvidia-ml1:amd64 (390.87-6) ...
Sélection du paquet nvidia-driver-bin précédemment désélectionné.
Préparation du dépaquetage de .../09-nvidia-driver-bin_390.87-6_amd64.deb ...
Dépaquetage de nvidia-driver-bin (390.87-6) ...
Sélection du paquet xserver-xorg-video-nvidia précédemment désélectionné.
Préparation du dépaquetage de .../10-xserver-xorg-video-nvidia_390.87-6_amd64.deb ...
Dépaquetage de xserver-xorg-video-nvidia (390.87-6) ...
Sélection du paquet nvidia-vdpau-driver:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../11-nvidia-vdpau-driver_390.87-6_amd64.deb ...
Dépaquetage de nvidia-vdpau-driver:amd64 (390.87-6) ...
Sélection du paquet nvidia-kernel-common précédemment désélectionné.
Préparation du dépaquetage de .../12-nvidia-kernel-common_20151021+9_amd64.deb ...
Dépaquetage de nvidia-kernel-common (20151021+9) ...
Sélection du paquet nvidia-modprobe précédemment désélectionné.
Préparation du dépaquetage de .../13-nvidia-modprobe_390.87-1_amd64.deb ...
Dépaquetage de nvidia-modprobe (390.87-1) ...
Sélection du paquet nvidia-kernel-support précédemment désélectionné.
Préparation du dépaquetage de .../14-nvidia-kernel-support_390.87-6_amd64.deb ...
Dépaquetage de nvidia-kernel-support (390.87-6) ...
Sélection du paquet nvidia-kernel-dkms précédemment désélectionné.
Préparation du dépaquetage de .../15-nvidia-kernel-dkms_390.87-6_amd64.deb ...
Dépaquetage de nvidia-kernel-dkms (390.87-6) ...
Sélection du paquet nvidia-driver précédemment désélectionné.
Préparation du dépaquetage de .../16-nvidia-driver_390.87-6_amd64.deb ...
Dépaquetage de nvidia-driver (390.87-6) ...
Sélection du paquet libxnvctrl0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../17-libxnvctrl0_390.87-1_amd64.deb ...
Dépaquetage de libxnvctrl0:amd64 (390.87-1) ...
Sélection du paquet nvidia-settings précédemment désélectionné.
Préparation du dépaquetage de .../18-nvidia-settings_390.87-1_amd64.deb ...
Dépaquetage de nvidia-settings (390.87-1) ...
Sélection du paquet bumblebee-nvidia précédemment désélectionné.
Préparation du dépaquetage de .../19-bumblebee-nvidia_3.2.1-19_amd64.deb ...
Dépaquetage de bumblebee-nvidia (3.2.1-19) ...
Sélection du paquet libgles1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../20-libgles1_1.1.0-1_amd64.deb ...
Dépaquetage de libgles1:amd64 (1.1.0-1) ...
Sélection du paquet libgles-nvidia1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../21-libgles-nvidia1_390.87-6_amd64.deb ...
Dépaquetage de libgles-nvidia1:amd64 (390.87-6) ...
Sélection du paquet libgles-nvidia2:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../22-libgles-nvidia2_390.87-6_amd64.deb ...
Dépaquetage de libgles-nvidia2:amd64 (390.87-6) ...
Sélection du paquet libglx-nvidia0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../23-libglx-nvidia0_390.87-6_amd64.deb ...
Dépaquetage de libglx-nvidia0:amd64 (390.87-6) ...
Sélection du paquet libnvidia-cfg1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../24-libnvidia-cfg1_390.87-6_amd64.deb ...
Dépaquetage de libnvidia-cfg1:amd64 (390.87-6) ...
Sélection du paquet nvidia-persistenced précédemment désélectionné.
Préparation du dépaquetage de .../25-nvidia-persistenced_390.87-1_amd64.deb ...
Dépaquetage de nvidia-persistenced (390.87-1) ...
Sélection du paquet socat précédemment désélectionné.
Préparation du dépaquetage de .../26-socat_1.7.3.2-2_amd64.deb ...
Dépaquetage de socat (1.7.3.2-2) ...
Sélection du paquet primus-libs:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../27-primus-libs_0~20150328-7_amd64.deb ...
Dépaquetage de primus-libs:amd64 (0~20150328-7) ...
Sélection du paquet primus précédemment désélectionné.
Préparation du dépaquetage de .../28-primus_0~20150328-7_amd64.deb ...
Dépaquetage de primus (0~20150328-7) ...
Paramétrage de nvidia-kernel-common (20151021+9) ...
Paramétrage de libgles1:amd64 (1.1.0-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.61) ...
Paramétrage de libnvidia-eglcore:amd64 (390.87-6) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-4) ...
Paramétrage de nvidia-support (20151021+9) ...
Paramétrage de update-glx (0.9.1) ...
Paramétrage de socat (1.7.3.2-2) ...
Paramétrage de primus-libs:amd64 (0~20150328-7) ...
Paramétrage de libnvidia-glcore:amd64 (390.87-6) ...
Traitement des actions différées (« triggers ») pour initramfs-tools (0.132) ...
update-initramfs: Generating /boot/initrd.img-4.19.0-1-amd64
Traitement des actions différées (« triggers ») pour libc-bin (2.28-5) ...
Traitement des actions différées (« triggers ») pour systemd (240-4) ...
Paramétrage de nvidia-modprobe (390.87-1) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.5-1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.31.4-3) ...
Paramétrage de glx-alternative-mesa (0.9.1) ...
Paramétrage de bbswitch-dkms (0.8-8) ...
Loading new bbswitch-0.8 DKMS files...
Building for 4.19.0-1-amd64
Building initial module for 4.19.0-1-amd64
Done.

bbswitch.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/dkms/

depmod...

DKMS: install completed.
Paramétrage de libxnvctrl0:amd64 (390.87-1) ...
Paramétrage de glx-diversions (0.9.1) ...
Paramétrage de bumblebee (3.2.1-19) ...
Adding members from group(s) 'adm sudo admin' to 'bumblebee':

Created symlink /etc/systemd/system/graphical.target.wants/bumblebeed.service → /lib/systemd/system/bumblebeed.service.
Paramétrage de primus (0~20150328-7) ...
Traitement des actions différées (« triggers ») pour glx-alternative-mesa (0.9.1) ...
update-alternatives: utilisation de « /usr/lib/mesa-diverted » pour fournir « /usr/lib/glx » (glx) en mode automatique
Paramétrage de glx-alternative-nvidia (0.9.1) ...
update-initramfs: deferring update (trigger activated)
Traitement des actions différées (« triggers ») pour glx-alternative-nvidia (0.9.1) ...
Paramétrage de nvidia-alternative (390.87-6) ...
Traitement des actions différées (« triggers ») pour nvidia-alternative (390.87-6) ...
update-alternatives: utilisation de « /usr/lib/nvidia/current » pour fournir « /usr/lib/nvidia/nvidia » (nvidia) en mode automatique
Paramétrage de libglx-nvidia0:amd64 (390.87-6) ...
Paramétrage de nvidia-kernel-support (390.87-6) ...
Paramétrage de nvidia-settings (390.87-1) ...
Paramétrage de nvidia-vdpau-driver:amd64 (390.87-6) ...
Paramétrage de libegl-nvidia0:amd64 (390.87-6) ...
Paramétrage de libgles-nvidia2:amd64 (390.87-6) ...
Paramétrage de libnvidia-cfg1:amd64 (390.87-6) ...
Paramétrage de libnvidia-ml1:amd64 (390.87-6) ...
Paramétrage de libgles-nvidia1:amd64 (390.87-6) ...
Paramétrage de xserver-xorg-video-nvidia (390.87-6) ...
Paramétrage de nvidia-driver-bin (390.87-6) ...
Paramétrage de nvidia-persistenced (390.87-1) ...
Paramétrage de libgl1-nvidia-glx:amd64 (390.87-6) ...
Paramétrage de libegl1-nvidia:amd64 (390.87-6) ...
Paramétrage de nvidia-driver-libs-nonglvnd:amd64 (390.87-6) ...
Traitement des actions différées (« triggers ») pour nvidia-alternative (390.87-6) ...
update-alternatives: mise à jour de l'alternative /usr/lib/nvidia/current car le groupe de liens nvidia contient des liens esclaves modifiés
Paramétrage de nvidia-kernel-dkms (390.87-6) ...
Loading new nvidia-current-390.87 DKMS files...
Building for 4.19.0-1-amd64
Building initial module for 4.19.0-1-amd64
Done.

nvidia-current.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/dkms/

nvidia-current-modeset.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/dkms/

nvidia-current-drm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/dkms/

nvidia-current-uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/dkms/

depmod...

DKMS: install completed.
Paramétrage de bumblebee-nvidia (3.2.1-19) ...
update-alternatives: erreur: l'alternative /usr/lib/nvidia/bumblebee pour glx n'est pas enregistrée ; pas de configuration
Paramétrage de nvidia-driver (390.87-6) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.28-5) ...
Traitement des actions différées (« triggers ») pour initramfs-tools (0.132) ...
update-initramfs: Generating /boot/initrd.img-4.19.0-1-amd64
Traitement des actions différées (« triggers ») pour systemd (240-4) ...
Traitement des actions différées (« triggers ») pour update-glx (0.9.1) ...
Traitement des actions différées (« triggers ») pour glx-alternative-nvidia (0.9.1) ...
update-alternatives: utilisation de « /usr/lib/nvidia » pour fournir « /usr/lib/glx » (glx) en mode automatique
update-alternatives: utilisation de « /usr/lib/nvidia/bumblebee » pour fournir « /usr/lib/glx » (glx) en mode automatique
Traitement des actions différées (« triggers ») pour glx-alternative-mesa (0.9.1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.28-5) ...
Traitement des actions différées (« triggers ») pour initramfs-tools (0.132) ...
update-initramfs: Generating /boot/initrd.img-4.19.0-1-amd64
Traitement des actions différées (« triggers ») pour bumblebee (3.2.1-19) ...



Voilà le retour console, on voit la encore le fameux :

update-alternatives: erreur: l'alternative /usr/lib/nvidia/bumblebee pour glx n'est pas enregistrée ; pas de configuration



et par curiosité j'ai été jeter un oeil dans les dossiers cités ci-après :

update-alternatives: utilisation de « /usr/lib/nvidia » pour fournir « /usr/lib/glx » (glx) en mode automatique
update-alternatives: utilisation de « /usr/lib/nvidia/bumblebee » pour fournir « /usr/lib/glx » (glx) en mode automatique
 


Dans le /usr/lib/nvidia on a bien plusieur fichier dont le libglx.so, en revanche dans le /usr/lib/nvidia/bumblebee je fais un :

ls -a


.  ..
 


J'en déduis donc que c'est vide... Le problème ne viendrait il pas de là? Car si je comprend bien il vient chercher quelque chose dans ce dossier non ?

Hors ligne

#205 04-02-2019 22:47:44

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

journalctl -r -p err


-- Logs begin at Mon 2019-02-04 22:35:04 CET, end at Mon 2019-02-04 22:46:10 CET. --
févr. 04 22:35:28 debian gnome-session-binary[755]: Unrecoverable failure in required component org.gnome.Shell.desktop
févr. 04 22:35:20 debian bluetoothd[519]: RFCOMM server failed for :1.250/Profile/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb:
févr. 04 22:35:20 debian bluetoothd[519]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
févr. 04 22:35:05 debian bluetoothd[519]: sap-server: Operation not permitted (1)
févr. 04 22:35:05 debian bluetoothd[519]: Sap driver initialization failed.
févr. 04 22:35:05 debian avahi-daemon[563]: chroot.c: open() failed: No such file or directory

 



Et la je vais redémarrer pour voir.

Hors ligne

#206 04-02-2019 22:58:40

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

je vais pleurer....

J'ai redémarré sans problème *_*. Je vais re-redémarrer pour être sur big_smile

Hors ligne

#207 04-02-2019 23:01:55

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

Alors voici le retour de

glxinfo -B


name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel Open Source Technology Center (0x8086)
    Device: Mesa DRI Intel(R) HD Graphics 630 (Kaby Lake GT2)  (0x591b)
    Version: 18.3.2
    Accelerated: yes
    Video memory: 3072MB
    Unified memory: yes
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 630 (Kaby Lake GT2)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.3.2
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 18.3.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 18.3.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
 



lspci


00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 05)
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 05)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1c.3 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #4 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation CM238 HD Audio Controller (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev ff)
02:00.0 Network controller: Intel Corporation Dual Band Wireless-AC 3168NGW [Stone Peak] (rev 10)
03:00.0 Ethernet controller: Qualcomm Atheros QCA8171 Gigabit Ethernet (rev 10)
 



La geforce à l'ai reconnue.

Hors ligne

#208 04-02-2019 23:11:41

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

Et pour finir :

optirun glxinfo -B


name of display: :0
display: :0  screen: 0
direct rendering: Yes
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 2048 MB
    Total available memory: 2048 MB
    Currently available dedicated video memory: 1994 MB
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 1050/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 390.87
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6.0 NVIDIA 390.87
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
 



Et la je passe par un firefox lancer via optirun.

Je ne comprends absolument pas pourquoi maintenant ça marche sur gnome et pas avant si ce n'est le fichier xorg.conf (qui d'après la doc ne dois plus être créé) qui a été rajouté. En tout cas je ne peux que te dire 1000000000000000000000000000000000000000000000000000000000 merci ! J'ai cru que je ne m'en sortirai jamais. Mais j'avoue que je ne saisi pas trop le pourquoi du comment. Je ne sais pas ce que tu en pense^^.

J'imagine au vu des retours commande, et du fait que je peux redémarrer mon ordi sans freeze je dois pouvoir passer ce sujet en résolu non ? tonguelol

Encore merci pour ton aide et ta patience ! Mille merci.

Hors ligne

#209 05-02-2019 00:53:35

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Freeze au lancement de GNOME

Bonsoir

tu peut passer sur ton #1 en le modifiant  , avec [resolu] devant le titre.
si on fait le point :
ça commence avec gnome + gdm3 écran noir sur stretch
on blackliste  le module sécurité (tpm) et nouveau toujours mauvais (qui pose problème )
tu passe en mate + lightdm toujours mauvais seulement avec bumblebee installé .
ps: noyau et firmware de stretch-backports n'arrange rien
tu passe a Buster toujours mauvais avec bumblebee (mais bon sans bumblebee)
on retire le multiarch "i386" du système
On trouve sur le net un souci avec mate sur le cpu intel (seulement avec bumblebee)  , double ou triple buffer sur le gpu intel fait planté le bureau
on applique le remède , installer gnome plus gdm3
les fichiers de configuration pour nvidia sont dans /etc/bumblebee/ , je te fais mettre un fichier xorg.conf dans /etc/X11/xorg.conf pour désactiver les buffers pour intel .
voila pour ce que l'on a fait.

pour faire le point : (optionnel)
tu peu supprimer le blacklist de nouveau (le driver nvidia a mit le sien normalement )
pour tpm a mon avis vaut mieux le laisser ( si tu utilise pas ) mais normalement il est désactivé dans le bios aussi
pour le fichier xorg.conf tu peu le renommer en xorg.conf-backup.txt pour tester si toujours les erreurs (si gnome évite le problème n'est plus utile )
pour info : le xorg.conf est utile pour les cas désespéré (sinon absent) uniquement pour le cpu principal => intel
pour nvidia , bumblebee a configuré les xorg.conf pour ce gpu dans /etc/bumblebee/ (interdit d'en mettre un dans  /etc/X11/ pour nvidia )
voila pour les explications

il te reste a purger mate (+ lightdm) si plus besoin , compléter le bureau gnome selon tes besoins et garder ta buster bien a jours
installer apt-listbugs pour les paquets qui contiennent des bugs


apt-get --reinstall install apt-listbugs
 



je commençais a désespérer avec cette machine roll  (9 pages hmm  ).
le paquet bumblebee-nvidia sur debian demande a être amélioré mais bon j'ai pas de portable a équipé de debian + bumblebee mais maintenant je le sais roll
bonne soirée
@++

Dernière modification par robert2a (05-02-2019 00:58:06)

En ligne

#210 05-02-2019 09:31:31

Lam3ch
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome (gdm3)
Inscription : 08-01-2019

Re : [RESOLU] Freeze au lancement de GNOME

Je passe donc le sujet en résolu encore merci pour tout !

Hors ligne

#211 03-09-2019 23:39:43

Petit-Jean
Membre
Inscription : 03-09-2019

Re : [RESOLU] Freeze au lancement de GNOME

Bonjour,

Je me permets de déterrer ce topic. J'ai exactement la même machine et j'ai aussi le même problème... hmm
Après plusieurs tentatives je ne suis toujours pas ne mesure d'installer debian buster sans avoir de freeze complet de la machine.

J'ai essayé de reproduire exactement les étapes décrites dans ce fil de discussion mais sans succès.

Pouvez vous me dire ce qui vous à permis de faire fonctionner votre pilote graphique Nvidia ?

J'ai essayé avec KDE et blacklistant le pilote nouveau au démarrage, puis essayé d'installer bumblebee avec la doc debian ( https://wiki.debian-fr.xyz/NVidia_Optimus_Bumblebee et https://debian-facile.org/doc:materiel: … ia:optimus ).
Mais j'ai toujours des freeze au démarrage ou redémarrage.
Lorsque que je lance la commande

glxgears

, le processus graphique se lance bien avec la carte intégrée intel mais la commande

optirun glxgears


m'affiche un message d'erreur (il faudrait que je réinstalle le tout pour vous avoir l'erreur précise), qui insinuait qu'il manque "quelque chose".

Merci pour l'aide que vous pourrez m'apporter.

Hors ligne

#212 04-09-2019 21:49:36

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Freeze au lancement de GNOME

Bonsoir
le mieux c'est que tu ouvre ton sujet pour ta demande
tu est sur que tu a le même portable ?
si oui tu crée un lien qui pointe sur ce fil

de mémoire il avait plusieurs problèmes sur cette machine
le module "TPM" de sécurité , qu'il a désactivé dans le bios
et un bug sur le gpu intel ( créé un /etc/X11/xorg.conf )
on a eu des soucis aussi avec le mode i386 pour bumblebee-nvidia (installation sans le i386 activé) pour le multiarch .
de gnome on est passé a mate + lightdm puis revenu a gnome + gdm3
il faut une debian propre (installation neuve) en mode serveur (sans bureau ) pour commencer.
tu est en double boot avec windows ?
ps: au début on blacklisté le module "TPM" puis "nouveau" dans /etc/modprobe.d/ , désactivé nouveau dans grub avec "nouveau.modeset=0"
cela a  été laborieux roll

nota: a l'époque buster était en testing , il a commencé avec stretch , la passage a buster a amélioré les choses

Dernière modification par robert2a (04-09-2019 21:51:28)

En ligne

Pied de page des forums