Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#76 02-02-2020 20:33:32

saca35
Membre
Lieu : Guipel (35)
Distrib. : Debian Buster
Inscription : 14-01-2020

Re : Service qui ne se lance pas au démarrage

je viens de rebooter
au démarrage j'ai maintenant :

knockd.service - Port-Knock Daemon
   Loaded: loaded (/etc/systemd/system/knockd.service; enabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:knockd(1)



Mais donc toujours pas de knockd qui se lance au démarrage

Hors ligne

#77 02-02-2020 21:09:17

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Service qui ne se lance pas au démarrage

Il manque un morceau du message. Tu devrais avoir quelque chose comme cela :

● knockd.service - Port-Knock Daemon
   Loaded: loaded (/etc/systemd/system/knockd.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2020-02-02 21:09:50 CET; 18s ago
     Docs: man:knockd(1)
 Main PID: 974 (knockd)
    Tasks: 1 (limit: 4915)
   Memory: 408.0K
   CGroup: /system.slice/knockd.service
           └─974 /usr/sbin/knockd -i enp1s0f1

févr. 02 21:09:50 beta systemd[1]: Started Port-Knock Daemon.
févr. 02 21:09:50 beta knockd[974]: starting up, listening on enp1s0f1
 


Que donne  ? :

journalctl -xu knockd.service

Dernière modification par Beta-Pictoris (02-02-2020 21:11:47)

Hors ligne

#78 02-02-2020 21:19:56

saca35
Membre
Lieu : Guipel (35)
Distrib. : Debian Buster
Inscription : 14-01-2020

Re : Service qui ne se lance pas au démarrage

il manque un morceau uniquement lorsque c'est actif, je t'ai donné le status au démarrage (donc non lancé)
une fois le service lancé MANUELLEMENT, j'ai :

● knockd.service - Port-Knock Daemon
   Loaded: loaded (/etc/systemd/system/knockd.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2020-02-02 21:18:37 CET; 40s ago
     Docs: man:knockd(1)
 Main PID: 479 (knockd)
    Tasks: 1 (limit: 2346)
   Memory: 1000.0K
   CGroup: /system.slice/knockd.service
           └─479 /usr/sbin/knockd -i ens33

févr. 02 21:18:37 santiago systemd[1]: Started Port-Knock Daemon.
févr. 02 21:18:37 santiago knockd[479]: starting up, listening on ens33



journalctl -xu knockd.service

-- Logs begin at Sun 2020-02-02 20:29:53 CET, end at Sun 2020-02-02 21:19:04 CET. --
févr. 02 21:18:37 santiago systemd[1]: Started Port-Knock Daemon.
-- Subject: L'unité (unit) knockd.service a terminé son démarrage
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- L'unité (unit) knockd.service a terminé son démarrage, avec le résultat done.
févr. 02 21:18:37 santiago knockd[479]: starting up, listening on ens33
févr. 02 21:18:59 santiago knockd[479]: 192.168.22.11: openSSH: Stage 1
févr. 02 21:18:59 santiago knockd[479]: 192.168.22.11: openSSH: Stage 2
févr. 02 21:18:59 santiago knockd[479]: 192.168.22.11: openSSH: Stage 3
févr. 02 21:18:59 santiago knockd[479]: 192.168.22.11: openSSH: OPEN SESAME
févr. 02 21:18:59 santiago knockd[482]: openSSH: running command: /sbin/iptables -A INPUT -s 192.168.22.11 -p tcp --dport 1653 -j ACCEPT
 

Hors ligne

#79 02-02-2020 21:38:11

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Service qui ne se lance pas au démarrage

Désactive le service :

systemctl disable knockd.service


Modifie la section Install du fichier /etc/systemd/system/knockd.service et mets ceci :

[Install]
WantedBy=multi-user.target


Recharge la configuration dans systemd :

systemctl daemon-reload
 


Et réactive le service :

systemctl enable knockd.service


Puis reboote ta machine.

Hors ligne

#80 02-02-2020 21:52:18

saca35
Membre
Lieu : Guipel (35)
Distrib. : Debian Buster
Inscription : 14-01-2020

Re : Service qui ne se lance pas au démarrage

CA MARCHE ! démarrage de knockd au reboot
peux tu m'expliquer ce code ?

 [Install]
WantedBy=multi-user.target

Hors ligne

#81 02-02-2020 22:11:19

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Service qui ne se lance pas au démarrage

Dans systemd, les units de type target sont des groupes de service.

On a associé le service knockd au groupe multi-user.target. Cela équivaut au runlevel 3 System V avec réseau en linux lsb.

Dernière modification par Beta-Pictoris (02-02-2020 22:13:17)

Hors ligne

#82 02-02-2020 22:17:28

saca35
Membre
Lieu : Guipel (35)
Distrib. : Debian Buster
Inscription : 14-01-2020

Re : Service qui ne se lance pas au démarrage

Ok nickel et un grand merci toi

Néanmoins j'ai un grand regret, suite à une installation Debian Buster + knockd de me retrouver avec des réglages knockd qui ne correspondent pas a ce Debian de base mais qu'il faut plutôt passer à NetworkManager
Est ce qu'il y a une possibilité de pouvoir faire tourner correctement knockd sans contrecarrer l'installation Debian Buster par défaut ?

Hors ligne

#83 02-02-2020 22:24:39

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Service qui ne se lance pas au démarrage

Si tu utilises ifupdown, tu peux toujours essayer de démarrer le service knockd après le démarrage du service 'ifupdown-wait-online.service'

Active déjà le service 'ifupdown-wait-online.service' et regarde s'il est actif après un reboot.

Dernière modification par Beta-Pictoris (02-02-2020 22:27:37)

Hors ligne

#84 02-02-2020 22:41:46

saca35
Membre
Lieu : Guipel (35)
Distrib. : Debian Buster
Inscription : 14-01-2020

Re : Service qui ne se lance pas au démarrage

non, après reboot

● ifupdown-wait-online.service - Wait for network to be configured by ifupdown
   Loaded: loaded (/lib/systemd/system/ifupdown-wait-online.service; disabled; vendor preset: enabled)
   Active: inactive (dead)

Hors ligne

#85 02-02-2020 22:42:45

saca35
Membre
Lieu : Guipel (35)
Distrib. : Debian Buster
Inscription : 14-01-2020

Re : Service qui ne se lance pas au démarrage

mais j'aurais trouvé cela logique puisque ifup et NetworkManager sont quand même deux manières différentes et qu'il ne faudrait pas qu'elles se court-circuitent non ?

Hors ligne

#86 02-02-2020 23:09:25

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Service qui ne se lance pas au démarrage

Les cartes réseaux configurées dans /etc/network/interfaces* sont prises en charges par Ifupdown.
Les autres par Network-Manager.

Lance la commande suivante :

systemctl enable ifupdown-wait-online.service


Puis reboot ta machine pour voir s'il démarre bien.

Dernière modification par Beta-Pictoris (02-02-2020 23:09:42)

Hors ligne

#87 02-02-2020 23:33:40

saca35
Membre
Lieu : Guipel (35)
Distrib. : Debian Buster
Inscription : 14-01-2020

Re : Service qui ne se lance pas au démarrage

j'ai déjà répondu à cela
systemctl enable ifupdown-wait-online.service
puis reboot
donne

● ifupdown-wait-online.service - Wait for network to be configured by ifupdown
   Loaded: loaded (/lib/systemd/system/ifupdown-wait-online.service; disabled; vendor preset: enabled)
   Active: inactive (dead)

Hors ligne

#88 02-02-2020 23:56:42

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Service qui ne se lance pas au démarrage

Chez moi, il démarre. Ce service fait partie du groupe network-online.target.

As-tu bien installé les dernières mises à jour ? (apt update; apt full-upgrade)

Hors ligne

#89 03-02-2020 10:02:38

saca35
Membre
Lieu : Guipel (35)
Distrib. : Debian Buster
Inscription : 14-01-2020

Re : Service qui ne se lance pas au démarrage

je suis à jour et il ne démarre pas

Hors ligne

#90 03-02-2020 18:55:28

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Service qui ne se lance pas au démarrage

Hors ligne

#91 03-02-2020 19:12:50

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Service qui ne se lance pas au démarrage

A noter, le projet Debian reste très conservateur dans ses choix.

Cela fait belle lurette que Network-Manager est le gestionnaire des connexions réseaux par défaut sur la famille RedHat et consort.

Dernière modification par Beta-Pictoris (03-02-2020 23:03:30)

Hors ligne

#92 03-02-2020 20:59:18

saca35
Membre
Lieu : Guipel (35)
Distrib. : Debian Buster
Inscription : 14-01-2020

Re : Service qui ne se lance pas au démarrage

ok donc je vais laisser Network Manager
Merci bcp Beta Pictoris, pour ton aide patiente

Hors ligne

Pied de page des forums