Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 04-06-2020 18:34:07

MicP
Membre
Inscription : 29-02-2016

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

…avec les 5 touches du bas …

Donne moi les keycodes (par xev) et/ou les lignes de ton fichier ~/.Xmodmap qui correspondent à ces 5 touches.

(J'ai déjà fait ça il y a pas mal de temps)

Hors ligne

#27 04-06-2020 18:48:30

Protozion
Membre
Distrib. : Debian 10 Buster
(G)UI : XFCE
Inscription : 21-05-2020

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

Décidément, t'es calé dans le domaine du mappage de clavier. big_smile
Les keycodes des touches :
Copier : 133
Coller : 64
Zoom + : 108
Zoom - : 135
Imprimer : 105

Hors ligne

#28 04-06-2020 18:53:10

MicP
Membre
Inscription : 29-02-2016

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

On va essayer de leur faire faire,
respectivement :

XF86Copy
XF86Paste
XF86ZoomIn
XF86ZoomOut
XF86Print

keycode  64 = XF86Paste Meta_L XF86Paste Meta_L
keycode 105 = Control_R NoSymbol Control_R
keycode 108 = XF86ZoomIn NoSymbol XF86ZoomIn
keycode 133 = XF86Copy NoSymbol XF86Copy
keycode 135 = XF86ZoomOut NoSymbol XF86ZoomOut


Mais ça ne va pas encore fonctionner,
car il reste à relier au serveur X
les fonctionnalités des touches qui génèrent maintenant XF....
(pour celles qui ne sont pas encore prises en compte).

Je fais des essais et je reviens …

(Il y a un très gros orage chez moi en ce moment, le coin est en vigilance Orange,
j'espère que je ne serai pas coupé du réseau …)

Dernière modification par MicP (04-06-2020 19:07:08)

Hors ligne

#29 04-06-2020 19:02:52

Protozion
Membre
Distrib. : Debian 10 Buster
(G)UI : XFCE
Inscription : 21-05-2020

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

Je bouge pas !
Sinon j'ai trouvé une autre petite modif à faire, maintenant que j'ai compris un peu comment ça fonctionnait : keycode  35, il faut mettre dead_diaeresis et non diaeresis pour que le tréma ne s'affiche pas directement et attende la lettre à venir. Par exemple, avant j'obtenais ¨u et non pas ü.

Hors ligne

#30 04-06-2020 19:08:59

MicP
Membre
Inscription : 29-02-2016

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

…il faut mettre dead_diaeresis et non diaeresis …

Oui, et c'est d'ailleurs ce qu'on appelle les touches "mortes" (dead),
celles qui n'affichent rien tant qu'on n'a pas tapé sur la touche suivante.

Hors ligne

#31 04-06-2020 19:15:33

MicP
Membre
Inscription : 29-02-2016

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

Les deux définitions suivantes fonctionnent impécable :

keycode 108 = XF86ZoomIn NoSymbol XF86ZoomIn
keycode 135 = XF86ZoomOut NoSymbol XF86ZoomOut

Tu peux les ajouter à ton fichier ~/.Xmodmap pour vérifier leur fonctionnement sur ta machine.

Pour les autres fonctionalités, il va falloir créer un autre petit fichier…

Dernière modification par MicP (04-06-2020 19:17:04)

Hors ligne

#32 04-06-2020 19:27:00

Protozion
Membre
Distrib. : Debian 10 Buster
(G)UI : XFCE
Inscription : 21-05-2020

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

Ça fonctionne en partie seulement j'ai l'impression. Sur Firefox pas de soucis, ma page web répond aux 2 zooms mais par exemple dans Thunar ça ne fait rien du tout (alors que Ctrl + et Ctrl - agrandissent et réduisent la taille des icônes)

Pour le petit fichier, rien ne presse, tu as déjà fait beaucoup pour moi aujourd'hui. wink

Dernière modification par Protozion (04-06-2020 19:27:43)

Hors ligne

#33 04-06-2020 19:38:35

MicP
Membre
Inscription : 29-02-2016

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

Pour les 5 touches Copier Coller Zoom+ Zoom- et Imprimer :

Si il y a les 5 lignes suivantes dans le fichier ~/.Xmodmap

keycode 133 = XF86Copy NoSymbol XF86Copy
keycode  64 = XF86Paste Meta_L XF86Paste Meta_L
keycode 105 = Print NoSymbol Print
keycode 108 = XF86ZoomIn NoSymbol XF86ZoomIn
keycode 135 = XF86ZoomOut NoSymbol XF86ZoomOut


Il faudra créer un fichier ~/.config/gtk-3.0/gtk.css
contenant :

@binding-set gtk-xf86copy-paste
{
        bind "XF86Copy"  { "copy-clipboard" () };
        bind "XF86Paste" { "paste-clipboard" () };
}

* {
        gtk-key-bindings: gtk-xf86copy-paste
}


Et avec ça, les 5 touches Copier Coller Zoom+ Zoom- et Imprimer fonctionneront.

=======
NOTE : Pour la touche Imprimer
elle envoie bien le signal d'impression, mais il faudra peut-être faire en sorte
de relier ce signal à une macro pour envoyer le document sélectionné
ou/et la sélection de texte ou image à l'imprimante.
Je ne sais pas ce que provoquait cette touche sur l'Ordissimo

=======

Protozion a écrit :

… dans Thunar ça ne fait rien du tout (alors que Ctrl + et Ctrl - agrandissent et réduisent la taille des icônes) …

Il suffit d'ajouter les deux lignes suivantes
au fichier ~/.config/Thunar/accels.scm

(gtk_accel_path "<Actions>/ThunarWindow/zoom-out" "ZoomOut")
(gtk_accel_path "<Actions>/ThunarWindow/zoom-in" "ZoomIn")

puis de se déconnecter et se reconnecter.
(ce n'est pas indispensable pour cette dernière modification, mais pour celles au dessus dans ce message, oui)

Dernière modification par MicP (04-06-2020 23:26:13)

Hors ligne

#34 04-06-2020 21:00:37

Protozion
Membre
Distrib. : Debian 10 Buster
(G)UI : XFCE
Inscription : 21-05-2020

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

J'ai suivi ta procédure à la lettre mais ça ne veut pas...

Imprimer ne fait rien du tout, sur Ordissimo ça ouvrait la boîte de dialogue d'impression classique, équivalent au raccourci Ctrl+P.
Copier ne fait rien du tout (essayé sur Thunar, Libre Office, Firefox), par contre Coller fonctionne lorsque ça concerne du texte dans les même logiciels, mais si je copie un fichier, ça ne me le colle pas, et si je colle ce fichier dans une zone de texte ça colle son nom seulement. Je ne sais pas si je suis très clair. scratchhead.gif
Nickel pour les zoom sous Thunar, par contre pour info j'ai du déco/reco après avoir modifié ~/.config/Thunar/accels.scm

Hors ligne

#35 04-06-2020 22:26:07

MicP
Membre
Inscription : 29-02-2016

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

…Imprimer ne fait rien du tout …

Vu que les touches Zoom+ et Zoom- n'auront plus besoin d'êtres redéfinies,
tu peux supprimer du fichier ~/.config/Thunar/accels.scm
les deux lignes que je t'y avais fait ajouter :

(gtk_accel_path "<Actions>/ThunarWindow/zoom-out" "ZoomOut")
(gtk_accel_path "<Actions>/ThunarWindow/zoom-in" "ZoomIn")


et tu peux aussi supprimer le fichier ~/.config/gtk-3.0/gtk.css

puis enlever les deux lignes suivantes qui sont dans le fichier ~/.Xmodmap

keycode 108 = XF86ZoomIn NoSymbol XF86ZoomIn
keycode 135 = XF86ZoomOut NoSymbol XF86ZoomOut


=======
Puis tu installes le paquetage xdotool

et tu vas dans Applications -> Paramètres -> Clavier -> Onglet Raccourcis d'applications

tu cliques sur + Ajouter
et tu entres la ligne de commande suivante :

xdotool getactivewindow key Ctrl+p

puis tu cliques sur le bouton Valider
et la fenêtre qui s'affiche alors te demande d'appuyer
sur la touche à associer à cette ligne de commande

tu appuies donc sur la touche Imprime

Et tu recommences la même suite d'opérations
pour chacune des lignes de commande suivantes :

xdotool getactivewindow key ctrl+c
xdotool getactivewindow key ctrl+v
xdotool getactivewindow key Ctrl+plus
xdotool getactivewindow key Ctrl+minus


=======
Le caractère qui est entre % et =
est le caractère § (SECTION SIGN)

Mais je ne sais pas quel est le keycode
de la touche correspondante sur ton clavier.

Il te faudrait utiliser la commande xev et appuyer sur la touche §
pour récupérer son keycode et me le transmettre
de façon à ce que je puisse te créer la ligne à ajouter dans ton fichier ~/.Xmodmap

=======
J'ai pensé qu'il serait intéressant de pouvoir obtenir les signes < et >
en appuyant sur une des touches Maj. ou Majuscule
en même temps que sur une des touches ( et )

Pour la touche ) il suffira de remplacer dans le fichier ~/.Xmodmap la ligne suivante :

keycode  15 = parenright 6 parenright 6 bar brokenbar bar

par :

keycode  15 = parenright greater parenright greater bar brokenbar bar


et il faudra ajouter la ligne (manquante) qui permettra d'entrer ( et <

keycode  14 = parenleft less parenleft less bracketleft diaeresis bracketleft



Dernière modification par MicP (05-06-2020 22:44:20)

Hors ligne

#36 05-06-2020 17:24:32

Protozion
Membre
Distrib. : Debian 10 Buster
(G)UI : XFCE
Inscription : 21-05-2020

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

Je suis en train de faire les modifs. smile
Le keycode de § est : 96
et tant qu'à faire, et si ce n'est trop demander, le keycode pour le $ est : 127

Merci !

Edit :
Avant d'installer xdotool, je supprime peut-être aussi :

keycode  64 = XF86Paste Meta_L XF86Paste Meta_L
keycode 105 = Control_R NoSymbol Control_R
keycode 133 = XF86Copy NoSymbol XF86Copy




de mon fichier .Xmodmap ? vu que ça sera redéfini dans xdotool.

Dernière modification par Protozion (05-06-2020 17:37:02)

Hors ligne

#37 05-06-2020 18:01:45

Protozion
Membre
Distrib. : Debian 10 Buster
(G)UI : XFCE
Inscription : 21-05-2020

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

J'ai configuré les raccourcis en ayant effacé

keycode  64 = XF86Paste Meta_L XF86Paste Meta_L
keycode 105 = Control_R NoSymbol Control_R
keycode 133 = XF86Copy NoSymbol XF86Copy



de .Xmodmap


C'est bizarre parce que tout marche nickel sous Firefox ou Thunderbird, même la fenêtre d'impression s'ouvre, mais dans Mousepad, Thunar ou LibreOffice aucun des raccourcis ne fonctionnent. Et pourtant Ctrl+C marche bien sous Mousepad. Pas encore testé avec d'autres logiciels.

Dernière modification par Protozion (05-06-2020 19:19:05)

Hors ligne

#38 05-06-2020 19:25:03

MicP
Membre
Inscription : 29-02-2016

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

Bonjour

Je récapitule ce qu'il y a à faire
dans l'ordre :

- Dans le fichier ~/.Xmodmap
supprime toutes les lignes qui commencent par :

keycode  64
keycode 105
keycode 108
keycode 133
keycode 135


- supprime les deux lignes suivantes

(gtk_accel_path "<Actions>/ThunarWindow/zoom-out" "ZoomOut")
(gtk_accel_path "<Actions>/ThunarWindow/zoom-in" "ZoomIn")

   qui sont dans le fichier ~/.config/Thunar/accels.scm

- supprime le fichier ~/.config/gtk-3.0/gtk.css

- redémarre ta machine

- créé les raccourcis claviers

Dernière modification par MicP (05-06-2020 22:42:25)

Hors ligne

#39 05-06-2020 21:16:06

Protozion
Membre
Distrib. : Debian 10 Buster
(G)UI : XFCE
Inscription : 21-05-2020

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

Bonsoir,
C'est bien ce que j'ai fais, et j'obtiens toujours ce résultat :

C'est bizarre parce que tout marche nickel sous Firefox ou Thunderbird, même la fenêtre d'impression s'ouvre, mais dans Mousepad, Thunar ou LibreOffice aucun des raccourcis ne fonctionnent. Et pourtant Ctrl+C marche bien sous Mousepad. Pas encore testé avec d'autres logiciels.



J'en déduis que Mozilla utilise les même raccourcis que le système, mais ce n'est pas le cas des autres logiciels ?

Hors ligne

#40 05-06-2020 21:55:17

MicP
Membre
Inscription : 29-02-2016

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

Tu as bien supprimé les fichiers,
puis redémarré la machine
puis recréé les raccourcis avec,
en lettre minuscule, le c, v et p qui suivent Ctrl+
et tout ça dans cet ordre ?

Si c'est le cas, je ne vois pas du tout ce qui ne vas pas.
J'ai refais plusieurs fois la procédure,
et je n'ai rencontré aucun problème.

=======
Les deux lignes à ajouter à ~/.Xmodmap
pour les caractères § et $

keycode  96 = section F12 section F12 F12 F12 XF86Switch_VT_12
keycode 127 = dollar Break dollar Break



=======
Je n'arrive pas à comprendre ce qu'il a bien pu arriver
pour que ces raccourcis claviers ne fonctionnent pas sur ton système.

Je pense que tu pourrais essayer de lancer sur cette machine un autre système tout neuf du genre debian Live
puis faire juste (pas d'upgrade) une mise à jour de la liste des paquetages :

sudo apt update


pour pouvoir ensuite y installer xdotool :

apt install xdotool


et y copier/coller ton fichier ~/.Xmodmap
pour l'exécuter en ligne de commande :

xmodmap ~/.Xmodmap


Ensuite, tu créés les raccourcis claviers et tu vérifie comment ça fonctionne.

Dernière modification par MicP (05-06-2020 23:14:33)

Hors ligne

#41 06-06-2020 10:08:00

Protozion
Membre
Distrib. : Debian 10 Buster
(G)UI : XFCE
Inscription : 21-05-2020

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

MicP a écrit :

Tu as bien supprimé les fichiers,
puis redémarré la machine
puis recréé les raccourcis avec,
en lettre minuscule, le c, v et p qui suivent Ctrl+
et tout ça dans cet ordre ?

Si c'est le cas, je ne vois pas du tout ce qui ne vas pas.
J'ai refais plusieurs fois la procédure,
et je n'ai rencontré aucun problème.



Avant d'essayer avec un live Debian, je vais réessayer de refaire dans l'ordre... mais le seul truc qui m'a un peu étonné pendant la procédure, c'est que xdotool était déjà installé. Si je retire les 5 raccourcis, que je vérifie que les fichiers précédents ont bien été effacés (c'est le cas j'ai vérifié 10 fois), que je supprime ~/.Xmodmap et que je redémarre, on considère que je peux recommencer ta procédure depuis le début ? Je remets mon fichier ~/.Xmodmap, je redémarre, puis les raccourcis ?

Ce qui est fou c'est que dans Firefox tout marche nickel quand même.



Je suis en train de télécharger cet ISO pour les tests d'après.


edit : j'ai fais ce que j'ai dit plus haut dans ce message et j'arrive au même résultat. Les raccourcis fonctionnent dans Firefox, pas dans LibreOffice.

7cKUPkbf12Zf.png


Je viens aussi de m'apercevoir que Copier et Coller fonctionnent sur le bureau, j'ai réussi à dupliquer un raccourci.

Dernière modification par Protozion (06-06-2020 11:53:37)

Hors ligne

#42 06-06-2020 14:41:23

MicP
Membre
Inscription : 29-02-2016

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

Bonjour

Les lignes de commandes commandes associées aux raccourcis clavier que je vois dans ta capture d'écran
sont parfaitement bien rédigés. smile

=======
Alors, ce n'est plus qu'une question de prise en charge de ces raccourcis par les applications concernées.

Peut-être que les raccourcis claviers de certaines de ces applications ont été modifiés,
comme on l'avait fait pour Thunar en ajoutant les deux lignes dans le fichier ~/.config/Thunar/accels.scm
ou manuellement, par l'interface de ces application.

Mais comme on n'a modifié les raccourcis claviers d'aucune autre application …

=======
Par défaut, sur mon système dans lequel je n'ai modifié aucun raccourci,
les raccourcis Ctrl+C Ctrl+V Ctrl+P Ctrl+minus Ctrl+plus
ne sont assignés à aucune fonctionnalité de LibreOffice Writer

LibreOffice Writer :
Outils -> Personnaliser… -> Onglet Clavier :
1591451093.png

Si c'est la même chose sur ton système,
il suffirait de créer ces raccourcis pour LibreOffice

=======
Le fichier image ISO que tu as choisi
ira très bien pour les tests. smile

Dernière modification par MicP (06-06-2020 22:15:51)

Hors ligne

#43 07-06-2020 14:46:15

Protozion
Membre
Distrib. : Debian 10 Buster
(G)UI : XFCE
Inscription : 21-05-2020

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

Bonjour,

Par défaut, sur mon système dans lequel je n'ai modifié aucun raccourci,
les raccourcis Ctrl+C Ctrl+V Ctrl+P Ctrl+minus Ctrl+plus
ne sont assignés à aucune fonctionnalité de LibreOffice Writer



C'est pareil chez moi (aussi sur une Mint que j'ai pas loin), et même en définissant les raccourcis sur Outils -> Personnaliser… -> Onglet Clavier ça ne change rien.

J'ai donc ensuite démarré sur l'ISO et refais la procédure, et là ça marche sur LibreOffice (sans que ses raccourcis propres sur Ctrl+C et Ctrl+V ne soient définis) mais toujours pas sur Thunar. Ok aussi sur Firefox et le bureau.

Dernière modification par Protozion (07-06-2020 14:46:40)

Hors ligne

#44 07-06-2020 15:11:48

MicP
Membre
Inscription : 29-02-2016

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

Bonjour

… toujours pas sur Thunar.  …

Est-ce que tu peux vérifier que les raccourcis par défaut de Thunar n'ont pas été modifiés ?
On peut voir les raccourcis claviers juste à droite du curseur sur ces deux captures d'écran :
1591539529.png
1591539586.png

Dernière modification par MicP (07-06-2020 15:17:20)

Hors ligne

#45 07-06-2020 15:37:34

Protozion
Membre
Distrib. : Debian 10 Buster
(G)UI : XFCE
Inscription : 21-05-2020

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

Les raccourcis sous Thunar sont bien définis, je viens de vérifier (sur la Debian facile installée en dur, sur le Live j'ai pas regardé mais pas de raison que ce soit modifié).

Dernière modification par Protozion (07-06-2020 15:37:57)

Hors ligne

#46 07-06-2020 15:57:59

MicP
Membre
Inscription : 29-02-2016

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

C'est peut-être la ligne de commande xdotool à qui il manquerait quelques options
par exemple, l'option clearmodifiers que l'on pourrait ajouter.

Fais un essai en ajoutant cette option dans les lignes de commandes lancés par les raccourcis :

xdotool --clearmodifiers getactivewindow key ctrl+c

Hors ligne

#47 07-06-2020 16:29:42

Protozion
Membre
Distrib. : Debian 10 Buster
(G)UI : XFCE
Inscription : 21-05-2020

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

J'ai ajouté l'option --clearmodifiers à Copier et Coller, et ça les a rendu inutilisables.

Hors ligne

#48 07-06-2020 17:39:13

MicP
Membre
Inscription : 29-02-2016

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

Je n'ai peut-être pas mis cette option où il fallait.

Essaye avec :

xdotool getactivewindow key --clearmodifiers ctrl+c

Hors ligne

#49 07-06-2020 17:55:14

Protozion
Membre
Distrib. : Debian 10 Buster
(G)UI : XFCE
Inscription : 21-05-2020

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

Avec l'option à cet endroit c'est revenu comme avant. A noter que j'ai laissé décochée la mention Utiliser la notification de démarrage dans les raccourcis là où on indique la commande.
Ça doit quand même être propre à LibreOffice et Thunar (et peut-être d'autres que je n'ai pas forcément testé) cette non reconnaissance des raccourcis. Même à l'endroit où on indique les raccourcis clavier, les touches Copier et Coller fonctionnent.

Hors ligne

#50 07-06-2020 18:22:46

MicP
Membre
Inscription : 29-02-2016

Re : Mappage clavier Ordissimo sous Debian 10 XFCE

C'est peut-être tout simplement xdotool qui ne va pas bien pour faire ça sur ta machine.

Dernière modification par MicP (11-06-2020 12:55:26)

Hors ligne

Pied de page des forums