Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 25-05-2020 20:14:43

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

hum… ça sent la défaillance de secteurs du disque dur…

Hors ligne

#27 25-05-2020 20:20:36

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Essaye donc de le supprimer :

rm /var/lib/dpkg/info/blender-data.list



Si ton système de fichier est défectueux, tu vas devoir utiliser des outils comme badblocks et e2fsck.

Dernière modification par Beta-Pictoris (25-05-2020 20:22:13)

Hors ligne

#28 25-05-2020 20:46:37

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Si le problème subsiste, sauvegarde toutes tes données puis force un fsck au boot en passant les paramètres fsck.mode et fsck.repair au noyau linux.

Voir ici les paramètres exacts (section "Kernel Command Line")  : https://www.freedesktop.org/software/sy … rvice.html

Hors ligne

#29 25-05-2020 20:49:28

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Il faudrait tenter un fsck, mais vu que c'est la racine, il va falloir
louvoyer un peu. Pour cela il faudrait démarrer en mode single user
(recovery-mode dans grub). Une fois que le système a démarré ça
demande le mot de passe root. Tu entres le mot de mot passe tu tape «
Entrée ». Tu te retrouves dans un shell, mais attention c'est en
qwerty. Là tu peux lancer la commande


fsck -y /dev/sda1
 


Mais surtout ne pas tenter d'exécuter cette commande sur un système
qui n'est pas en mode single. Pour pouvoir le faire, il faut
que le système de fichier soit démonté ou en lecture seule. Quand on
démarre en mode single, les réglages dans grub font qu'il lance le
noyau pour avoir la racine du système montée en lecture seule. Ça
devrait aller.

Seconde option, la plus simple ; redémarrer la machine avec la
commande :


shutdown -F -r now
 


Ça rebootera et forcera un fsck au démarrage de la machine.
Je n'ai jamais essayé, mais c'est dans la doc wink

Dernière modification par enicar (25-05-2020 21:18:21)

Hors ligne

#30 25-05-2020 23:33:40

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Bon, voilà où j'en suis... y a du mieux...

après un

 rm /var/lib/dpkg/info/blender-data.list



ça a marché... plus de blender-data... dans muon j'ai désinstallé blender et inkscape... ça à marché

ensuite j'ai fait un apt-get update puis un apt-get upgrade (car il y avait des choses à mettre à jour qui étaient bloquées à cause, il semblerait par ce paquet blender-data...)
voici le résultat...

 Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  gdal-data libaec0 libarmadillo9 libarpack2 libblosc1 libboost-regex1.67.0
  libcharls2 libdap25 libdapclient6v5 libdapserver7v5 libdcmtk14 libepsilon1
  libfreexl1 libfyba0 libgc1c2 libgd3 libgdal20 libgdcm2.8 libgeos-3.7.1
  libgeos-c1v5 libgeotiff2 libgphoto2-6 libgphoto2-l10n libgphoto2-port12
  libgsl23 libgslcblas0 libgtkspell0 libhdf4-0-alt libhdf5-103
  libimage-magick-perl libimage-magick-q16-perl libjemalloc2 libkmlbase1
  libkmlconvenience1 libkmldom1 libkmlengine1 libkmlregionator1 libkmlxsd1
  liblog4cplus-1.1-9 libmariadb3 libminizip1 libnetcdf13 libodbc1 libogdi3.2
  libopencolorio1v5 libopencv-core3.2 libopencv-imgcodecs3.2
  libopencv-imgproc3.2 libopencv-videoio3.2 libopenimageio2.0 libopenvdb5.2
  libpotrace0 libproj13 libqhull7 libsocket++1 libspatialite7 libspnav0
  libsuperlu5 libsz2 libtbb2 libtinyxml2.6.2v5 liburiparser1 libxerces-c3.2
  libyaml-cpp0.6 mariadb-common mysql-common odbcinst odbcinst1debian2
  proj-bin proj-data python-scour python3-scour scour
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets suivants seront mis à jour :
  bind9-host dnsutils libbind9-161 libdns-export1104 libdns1104 libirs161
  libisc-export1100 libisc1100 libisccc161 libisccfg163 liblwres161
11 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/4904 ko dans les archives.
Après cette opération, 4096 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 100755 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../00-dnsutils_1%3a9.11.5.P4+dfsg-5.1+deb10u1_amd64.deb ...
Dépaquetage de dnsutils (1:9.11.5.P4+dfsg-5.1+deb10u1) sur (1:9.11.5.P4+dfsg-5.1) ...
Préparation du dépaquetage de .../01-bind9-host_1%3a9.11.5.P4+dfsg-5.1+deb10u1_amd64.deb ...
Dépaquetage de bind9-host (1:9.11.5.P4+dfsg-5.1+deb10u1) sur (1:9.11.5.P4+dfsg-5.1) ...
Préparation du dépaquetage de .../02-libbind9-161_1%3a9.11.5.P4+dfsg-5.1+deb10u1_amd64.deb ...
Dépaquetage de libbind9-161:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) sur (1:9.11.5.P4+dfsg-5.1) ...
Préparation du dépaquetage de .../03-libisccfg163_1%3a9.11.5.P4+dfsg-5.1+deb10u1_amd64.deb ...
Dépaquetage de libisccfg163:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) sur (1:9.11.5.P4+dfsg-5.1) ...
Préparation du dépaquetage de .../04-libisccc161_1%3a9.11.5.P4+dfsg-5.1+deb10u1_amd64.deb ...
Dépaquetage de libisccc161:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) sur (1:9.11.5.P4+dfsg-5.1) ...
Préparation du dépaquetage de .../05-libirs161_1%3a9.11.5.P4+dfsg-5.1+deb10u1_amd64.deb ...
Dépaquetage de libirs161:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) sur (1:9.11.5.P4+dfsg-5.1) ...
Préparation du dépaquetage de .../06-libdns1104_1%3a9.11.5.P4+dfsg-5.1+deb10u1_amd64.deb ...
Dépaquetage de libdns1104:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) sur (1:9.11.5.P4+dfsg-5.1) ...
Préparation du dépaquetage de .../07-libisc1100_1%3a9.11.5.P4+dfsg-5.1+deb10u1_amd64.deb ...
Dépaquetage de libisc1100:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) sur (1:9.11.5.P4+dfsg-5.1) ...
Préparation du dépaquetage de .../08-liblwres161_1%3a9.11.5.P4+dfsg-5.1+deb10u1_amd64.deb ...
Dépaquetage de liblwres161:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) sur (1:9.11.5.P4+dfsg-5.1) ...
Préparation du dépaquetage de .../09-libisc-export1100_1%3a9.11.5.P4+dfsg-5.1+deb10u1_amd64.deb ...
Dépaquetage de libisc-export1100:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) sur (1:9.11.5.P4+dfsg-5.1) ...
Préparation du dépaquetage de .../10-libdns-export1104_1%3a9.11.5.P4+dfsg-5.1+deb10u1_amd64.deb ...
Dépaquetage de libdns-export1104 (1:9.11.5.P4+dfsg-5.1+deb10u1) sur (1:9.11.5.P4+dfsg-5.1) ...
Paramétrage de libisc1100:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) ...
Paramétrage de liblwres161:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) ...
Paramétrage de libisc-export1100:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) ...
Paramétrage de libisccc161:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) ...
Paramétrage de libdns-export1104 (1:9.11.5.P4+dfsg-5.1+deb10u1) ...
Paramétrage de libdns1104:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) ...
Paramétrage de libisccfg163:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) ...
Paramétrage de libbind9-161:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) ...
Paramétrage de libirs161:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) ...
Paramétrage de bind9-host (1:9.11.5.P4+dfsg-5.1+deb10u1) ...
Paramétrage de dnsutils (1:9.11.5.P4+dfsg-5.1+deb10u1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.28-10) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.5-2) ...
gdbm fatal: Fin du fichier inattendue

Hors ligne

#31 25-05-2020 23:40:36

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

après un apt autoremove puis apt-get update pus apt-get upgrade ...

 Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.



cela semble être rentré dans l'ordre...
une idée?

Hors ligne

#32 25-05-2020 23:52:16

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

j'ai redémarré, puis à nouveau apt-get update, apt-get upgrade... tout est bien...
j'ai lancé muon et téléchargé un programme tout s'est bien passé...

merci à vous tous... sincèrement...
dois-je me contenter de ce résultat?

pour info, c'est quoi ce problème avec blender-data, blender que je n'ai jamais installé...??

Hors ligne

#33 26-05-2020 11:08:24

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.8 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Comme suggéré plus haut, tout ça ressemble à un souci lié au disque dur, et ce n'est que par hasard que c'est un fichier lié à Blender qui a été impacté.

La commande suggérée par enicar devrait je pense permettre d'en savoir un peu plus au sujet de l'état du disque, et donc de savoir s'il va falloir pousser le diagnostic plus loin :

shutdown -F -r now


(attention, cette commande va redémarrer ton système)

Pour l'instant on n'en sait pas assez pour affirmer avec certitude s'il s'agit d'un disque en fin de vie, qu'il faudra donc remplacer, ou un petit hoquet sans gravité qui n'aura pas de conséquences importantes.


Jouer sous Debian ? Facile !

En ligne

#34 26-05-2020 12:00:03

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Bonjour à tous,

Merci pour toutes ces infos. Oui en effet, j'espère rien de grave sur ce DD mais c'est une vieille machine récupérée et revenue à la vie ...
un optiplex 760 core 2 duo e7300 avec 7g de ram... il est peut être temps d'investir sur un ssd mais bon pour le moment je fais avec...

Pour le moment je suis au taf j'essaie le shutdown -F -r now ce soir en rentrant... j'ai quelques dossiers à sauvegarder, pas grand chose... l'installation ne date pas de longtemps en fait...

Merci à tous et à ce soir donc smile

Hors ligne

#35 26-05-2020 22:54:50

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Bonsoir,

Shutdown commande introuvable

Désolé je ne sais pas aller chercher çà et le rendre applicable...

Hors ligne

#36 26-05-2020 23:28:17

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

j’essaie demain

Hors ligne

#37 26-05-2020 23:36:51

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

shutdown est une commande qui s'utilise en étant root. Aurais tu
utilisé « su » pour devenir root ? Si non tu peux essayer :


su -c '/sbin/shutdown -F -r now'
 


Le mot de passe root te sera demandé. Une fois que tu auras
validé le mot de passe, le système redémarrera.

Dernière modification par enicar (26-05-2020 23:37:28)

Hors ligne

#38 27-05-2020 13:52:50

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Bonjour à tous,

oui j'utilise su pour passer en root, je n'ai pas de sudo...
Désolé pour mon manque de connaissance basique par rapport à certaines manip... je ne sais que dire...

je viens de lancer

su -c '/sbin/shutdown -F -r now'



redémarrage sans problème, pas de message, etc.

dois-je faire d'autres investigations?

Merci à vous.

Hors ligne

#39 27-05-2020 15:42:32

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

On pourrait regarder du côté de smart. Mais je ne connais pas vraiment.
Les rapports de smartctl sont plutôt abscons.
Le fait que tout ce soit bien passé est un très bon signe.
Donc je ne sais pas. Je regarderai quand même l'était de santé du DD
avec smart si j'étais toi.

Hors ligne

#40 27-05-2020 16:10:12

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Oui je comprend... je ne pense pas avoir assez de compétences pour investir une telle recherche...
Cela étant, c'est plutôt une bonne nouvelle... en attendant...
Pour mon info personnelle je vais aller voir ce que dit smart... de quoi ça parle, etc.
A l'évidence et au vu du matériel, un nouveau DD ne serait pas du luxe...
(depuis que j'utilise un ordi, (des dizaines d'ans), je n'utilise que du matériel de récup... un DD neuf serait un faible investissement  smile ...)

A ce propos, et ce sera ma dernière question du post, pour un DD ssd, j'ai lu qu'il vaut mieux n'y déposer que le système d'exploitation et avoir un autre DD pour les données personnelles.
Dans cet optiplex 760 il y a peu de place, je pourrais toujours travailler avec un DD externe, ce que je fais de toutes manières pour les sauvegardes, mais est-ce toujours le cas pour les DD ssd de nos jours?

Bon, merci pour les infos, le dépannage, vos réponses rapides et pertinentes, vôtre bienveillance avec les utilisateurs toujours "nouveaux face aux problèmes" comme moi...

je valide le post en résolut bien sur... !! ciao et à bientôt, c'est sur... smile

Hors ligne

#41 27-05-2020 17:09:29

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

al1 a écrit :

A ce propos, et ce sera ma dernière question du post, pour un DD ssd, j'ai lu qu'il vaut mieux n'y déposer que le système d'exploitation et avoir un autre DD pour les données personnelles.



un ssd fait gagner en rapidité donc il est tout indiqué de l'utiliser pour le système d'exploitation en effet ! si je ne dis pas trop de bêtises !

L'avantage d'un ssd, c'est qu'il est moins fragile q'un disque dur traditionnel, Je pense au choc qu'il pourrait recevoir !

Dernière modification par Jean-Pierre Pinson (27-05-2020 17:16:15)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#42 27-05-2020 22:15:52

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Ok, merci pour l'info !!

Hors ligne

#43 27-05-2020 23:16:20

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Je ne sais pas comment est organisé l'intérieur de ton optiplex. J'ai
aussi un vieil optiplex gx620 que je n'utilise pratiquement pas. Dans
le mien il y aurait moyen de mettre un second DD à la place du lecteur
de disquette (oui, j'ai encore un ordi qui fonctionne et qui possède
un lecteur de disquette !).  Je ne sais pas comment est fait le tiens,
mais c'est une piste pour avoir un ssd et un DD mécanique neuf.

Hors ligne

#44 29-05-2020 17:01:11

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Salut,

quelques news et questions en lien avec le post de départ,

pour les news, j'ai acheté un ssd, premier prix etc. ouais ça change l'avis (!) installation rapide, tout est rapide !
je n'ai pas la place pour un second DD alors je fais avec ce ssd uniquement... pour le moment...

pour la question, en réinstallant Debian avec openbox et tous les logiciels que j'utilise, en téléchargeant openshot, je me suis aperçu que le fichier blender-data se télécharge à ce moment là...
j'ai arrêté et je cherche un autre logiciel de montage vidéo...

par ailleurs, j'ai remarque un paquet qui se nomme geoclue quel rapport un logiciel de montage vidéo et ce paquet?

Hors ligne

#45 29-05-2020 17:35:59

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Pour savoir pourquoi un paquet est installé avec aptitude :


aptitude why blender-data
 


Ça ne marche que sur les paquets qui sont installés. Et il faut installer
aptitude qui n'est pas installé par défaut. Remarque que tu peux installer
openshot sans installer blender. C'est juste une recommandation :


apt-get --no-install-recommends install openshot
 


Ça doit aussi marcher avec apt, que je n'utilise pas donc je te laisse
le soin de vérifier.

Pour avoir une description du rôle que remplit un paquet :


apt-cache show geoclue-2.0
 


Quant au rapport avec le montage vidéo, je ne vois pas.  Encore une
fois tu peux utiliser :


aptitude why geoclue-2.0
 


pour voir pourquoi ce paquet est installé.

Hors ligne

#46 29-05-2020 18:01:58

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Ok je comprends!

Merci pour toutes ces infos!

je vais faire des tests !

Hors ligne

#47 29-05-2020 21:34:22

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Notez que 'apt depends <paquet>' et 'apt rdepends <paquet>', c'est pas mal aussi. smile

Dernière modification par Beta-Pictoris (29-05-2020 21:35:08)

Hors ligne

#48 29-05-2020 21:48:05

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Salut à tous,

j'ai installé openshot avec

apt-get --no-install-recommends install openshot



j'ai pu voir que dans les paquets recommandés il y avait bien blender-data et des paquets à propos de inkscape etc.
tout ceci ne s'est pas chargé et j'ai à priori une installation comme je le souhaite... ça fonctionne et c'est super, vraiment!
Merci enicar!

je prends bonne note de Beta-Pictoris, merci.

Notez que 'apt depends <paquet>' et 'apt rdepends <paquet>', c'est pas mal aussi.



Merci à tous!!

Hors ligne

#49 29-05-2020 21:52:33

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Beta-Pictoris a écrit :

Notez que 'apt depends <paquet>' et 'apt rdepends <paquet>', c'est pas mal aussi.


En effet, mais depends ne donne que les dépendances directes (si je ne me trompe pas). Et rdepends
donne toutes les dépendances inverses même celles qui correspondent à des paquets non installés.
Du coup, il faut soit faire plusieurs apt-cache depends… ou faire le trie (avec rdepends).
C'est pour cela que j'aime bien le « aptitude why ». Peut-être qu'il existe une solution à base
de dpkg-query. Il existe tellement d'outils qu'on en fait jamais tout le tour wink

Hors ligne

#50 29-05-2020 23:24:20

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.8 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Je confirme que aptitude why est un outil très pratique, je l’utilise par exemple avant chaque mise-à-jour de mon système via la boucle suivante pour repérer parmi les paquets à mettre à jour lesquels ne me sont en fait pas utiles :

sed_pattern='s#^\([^/]*\)/[-a-z,]* [-a-z0-9.+:~]* \(amd64\|i386\|all\) .*$#\1:\2#'

for package in \
    $(apt list --upgradable 2>/dev/null | \
    sed "$sed_pattern" | \
    tail +2)
do
    printf 'Why %s?\n' "$package"
    aptitude why "$package"
done


Jouer sous Debian ? Facile !

En ligne

Pied de page des forums