Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 11-07-2020 09:17:22

jce76350
Membre
Lieu : Rouen
Distrib. : Debian_Buster 10.4
Noyau : 4.19.0-9-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : [RESOLU]web en local ouverture index.php

@vv222 

Je vois que vous partez sur des serveurs Web complets (Apache et nginx),

Non pas du tout wink
et ensuite lancer un serveur sans savoir si la config du serveur est conforme c'est pas évident, et c'est en fait ici le soucis car le VirtualHost est mal configuré ...  car le tuto n'est pas suivi pas à pas  smile

Dernière modification par jce76350 (11-07-2020 09:20:29)


--
Jc E

Hors ligne

#27 11-07-2020 11:35:05

zancanarotrois
Membre
Distrib. : debian GNU/linux 10 (buster)
Noyau : linux 4.19.0.9-amd64
(G)UI : gnome 3.22.2
Inscription : 08-02-2018

Re : [RESOLU]web en local ouverture index.php

Salut à vous,
L'ordi est planté, après avoir tenté des modifications sur les disques. Comme je viens juste de faire l'installation je vais refaire une install complète. J'ai déjà eu ce genre de soucis et mon expérience me dit qu'une galère de ce genre tu te la traine pendant un moment.
Balle neuve...

Lors de la nouvelle installation je vais tenter d'alloué une partition pour /var/www/html/devs sur mon deuxième disque.

Merci pour votre aide.
Vincent

Hors ligne

#28 11-07-2020 12:57:26

jce76350
Membre
Lieu : Rouen
Distrib. : Debian_Buster 10.4
Noyau : 4.19.0-9-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : [RESOLU]web en local ouverture index.php

Lors de la nouvelle installation je vais tenter d'alloué une partition pour /var/www/html/devs sur mon deuxième disque.

Pourquoi faire compliqué quand on peut faire simple wink le tuto suivi pas à pas c'est 100% gagnant

Dernière modification par jce76350 (11-07-2020 13:00:45)


--
Jc E

Hors ligne

#29 11-07-2020 17:16:22

zancanarotrois
Membre
Distrib. : debian GNU/linux 10 (buster)
Noyau : linux 4.19.0.9-amd64
(G)UI : gnome 3.22.2
Inscription : 08-02-2018

Re : [RESOLU]web en local ouverture index.php

jce76350 a écrit :

Lors de la nouvelle installation je vais tenter d'alloué une partition pour /var/www/html/devs sur mon deuxième disque.

Pourquoi faire compliqué quand on peut faire simple wink le tuto suivi pas à pas c'est 100% gagnant


Je ne cherche pas à me compliquer la vie, c'est juste que je ne suis pas arrivé à faire l'installation avec sudo -s, j'ai utilisé su pour être en root. C'est là seule différence avec le tuto. Ca expliquerait mes soucis d'installation ???

Hors ligne

#30 11-07-2020 18:02:27

jce76350
Membre
Lieu : Rouen
Distrib. : Debian_Buster 10.4
Noyau : 4.19.0-9-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : [RESOLU]web en local ouverture index.php

Ca expliquerait mes soucis d'installation ???

NON rien a voir  le soucis c'est c'est que tu as mélangé les données dans ton VirtualHost wink

Dernière modification par jce76350 (11-07-2020 18:03:00)


--
Jc E

Hors ligne

#31 12-07-2020 17:26:28

zancanarotrois
Membre
Distrib. : debian GNU/linux 10 (buster)
Noyau : linux 4.19.0.9-amd64
(G)UI : gnome 3.22.2
Inscription : 08-02-2018

Re : [RESOLU]web en local ouverture index.php

Salut,
J'ai refait l'installation complète, et j'ai suivi les conseils de jce76350, auteur du tuto. J'ai fait ça pas à pas.
Je n'arrive pas à remplacer ou a redirigé  /var/www/html vers mon dossier /home/zanca/Devs.

J'ai créé un dossier /home/zanca/Devs sur un disque différent de celui hébergent /var/www/html, je précise au cas où cela aurait une incidence. J'ai bien tous les droits sur ce /Devs.
/var/www/html est vide, pour être bien sûr d'être redirigé vers /home/zanca/Devs, quand je tape localhost j'ai un index of vide. /Devs contient phpinfo.php entre autres. Lorsque j'essai d'ouvrir phpinfo.php en choisissant firefox j'ai une fenêtre qui me dit que c'est un dossier php et me demande ce que doit faire firefox avec ce fichier.

hosts:

127.0.0.1    localhost
127.0.0.1     Devs
127.0.1.1    debian

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
 




mousepad /etc/apache2/sites-available/Devs.local.conf

<VirtualHost *:80>
ServerAdmin sites@localhost
DocumentRoot /home/zanca/Devs
ServerName Devs
 <Directory /home/zanca/Devs/>
 Require all granted
 AllowOverride All
 # pour mode rewrite et autoriser les fichiers .htacces
 </Directory>
</VirtualHost>




Je ne suis pas arrivé à faire cette opération, je n'ai pas compris où la faire

C3. Activer le VirtualHost

a2ensite sites.local.conf
Enabling site sites.local.
To activate the new configuration, you need to run:
 systemctl reload apache2


J'ai fais dans root un systemctl reload apache2.

Trop penché dessus depuis quelques jours, je ne vois plus rien.
Je comprends bien la difficulté de vous mettre au niveau d'un bras cassé, Merci.

Si vous avez une idée je suis preneur.

Dernière modification par zancanarotrois (12-07-2020 18:05:39)

Hors ligne

#32 12-07-2020 20:56:04

jce76350
Membre
Lieu : Rouen
Distrib. : Debian_Buster 10.4
Noyau : 4.19.0-9-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : [RESOLU]web en local ouverture index.php

alors je vois pour le VirtualHost tu le fais en C2. Création d'un VirtualHost. Création d'un VirtualHost

mousepad /etc/apache2/sites-available/Devs.local.conf


et ensuite tu actives le VirtualHost en C3. Activer le VirtualHost  comme c'est indiqué
il y a des étapes qui sont indiquée donc C2  puis ensuite C3 wink
et tu fait fait bien attention à prendre le bon fichier (c'est indiqué "Ajuster les noms ....  suivant vos besoins")

a2ensite Devs.local.conf

Dernière modification par jce76350 (12-07-2020 21:37:47)


--
Jc E

Hors ligne

#33 13-07-2020 09:38:47

zancanarotrois
Membre
Distrib. : debian GNU/linux 10 (buster)
Noyau : linux 4.19.0.9-amd64
(G)UI : gnome 3.22.2
Inscription : 08-02-2018

Re : [RESOLU]web en local ouverture index.php

Bonjour,
J'avais bien repéré qu'il fallait changer

sudo mousepad /etc/apache2/sites-available/sites.local.conf


par mon dossier Devs

sudo mousepad /etc/apache2/sites-available/Devs.local.conf



Par contre je n'avais pas effectué de modification dans

a2ensite sites.local.conf


C'est la grande difficulté quand on ne comprend pas le fonctionnement d'un code, on copie sans chercher à savoir ce qui va s'exécuter. Manque de bases...

Par contre je ne sais pas où est mon erreur:

root@debian:/etc/apache2/sites-available# a2ensite Devs.local.conf
bash: a2ensite : commande introuvable
 


Essayé en dehors de /etc/apache2.....

root@debian:~# a2ensite Devs.local.conf
bash: a2ensite : commande introuvable
 


Même résultat.
Ça me dépasse.

Hors ligne

#34 13-07-2020 10:02:16

cyrille
Adhérent(e)
Distrib. : SID + FreeBSD
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [RESOLU]web en local ouverture index.php

bash: a2ensite : commande introuvable


Sans doute un soucis de $PATH

Comment passes tu en root ?
essaie

su -



Sinon

whereis a2ensite


Et utilise le chemin absolu

Hors ligne

#35 13-07-2020 10:12:30

zancanarotrois
Membre
Distrib. : debian GNU/linux 10 (buster)
Noyau : linux 4.19.0.9-amd64
(G)UI : gnome 3.22.2
Inscription : 08-02-2018

Re : [RESOLU]web en local ouverture index.php

Salut cyrille,
En cherchant j'ai effectivement trouvé qu'il me fallait utiliser su -. J'ai donc lancé la commande " a2ensite Devs.local.conf", et ça a fonctionné.
Par contre maintenant je n'arrive pas à ouvrir mon dossier "Devs" dans le moteur de recherche, il semblerait que j'ai un problème de permission. Par contre si je tape un dossier spécifique /Devs/flexbox en php ça fonctionne maintenant.
Donc le serveur local fonctionne, me reste à comprendre et régler le problème de permission.
Question dans mon moteur de recherche quand le tape Devs/flexbox il m'affiche devs/flexbox, il passe en minuscule automatiquement ou il s'agit de deux dossiers différents ???

Merci pour ton aide.

Hors ligne

#36 13-07-2020 10:44:29

zancanarotrois
Membre
Distrib. : debian GNU/linux 10 (buster)
Noyau : linux 4.19.0.9-amd64
(G)UI : gnome 3.22.2
Inscription : 08-02-2018

Re : [RESOLU]web en local ouverture index.php

mousepad /etc/apache2/sites-available/Devs.local.conf
Unable to init server: Impossible de se connecter : Connexion refusée

(mousepad:26646): Mousepad-ERROR **: 11:29:31.222: Impossible d’ouvrir l’affichage :
Trappe pour point d'arrêt et de trace



/etc/apache2/sites-available/Devs.local.conf,  existe bien

ls -l /etc/apache2/sites-available/
total 20
-rw-r--r-- 1 root root 1332 avril  2  2019 000-default.conf
-rw-r--r-- 1 root root 6338 avril  2  2019 default-ssl.conf
-rw-r--r-- 1 root root 1332 juil. 13 11:23 Devs.local.conf
-rw-r--r-- 1 root root 1332 juil. 13 10:46 sites.local.conf
root@debian:~#
 



Mais impossible de le modifier quelque soit l'utilisateur, root@debian:/etc/apache2/sites-available#,  su ou su - . Je ne peux donc pas faire  :
C2. Création d'un VirtualHost

Avant de modifier, un problème de permissions ou de propriétaire ou les deux ???

Dernière modification par zancanarotrois (13-07-2020 10:45:51)

Hors ligne

#37 13-07-2020 11:39:56

cyrille
Adhérent(e)
Distrib. : SID + FreeBSD
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [RESOLU]web en local ouverture index.php

nano /etc/apache2/sites-available/Devs.local.conf




Ctrl + O
Pour enreigsitrer + Entrée

Ctrl + X

pour quitter

Hors ligne

#38 13-07-2020 16:30:57

zancanarotrois
Membre
Distrib. : debian GNU/linux 10 (buster)
Noyau : linux 4.19.0.9-amd64
(G)UI : gnome 3.22.2
Inscription : 08-02-2018

Re : [RESOLU]web en local ouverture index.php

Je suis arrivé à changer /etc/apache2/sites-available/Devs.local.conf

<VirtualHost *:80>
 
ServerAdmin sites@localhost
DocumentRoot /home/zanca/Devs
ServerName Devs
 <Directory /home/zanca/Devs/>
 Require all granted
 AllowOverride All
 # pour mode rewrite et autoriser les fichiers .htacces
 </Directory>
</VirtualHost>
 


Si j'essaie d'ouvrir

http://devs/flexbox/


Ça fonctionne. Idem pour phpinfo.php ou tout autre dossier php. Mais je dois les nommer, impossible d'avoir le répertoire en entier

http://devs/ j'ai un problème de permission.

Forbidden

You don't have permission to access this resource./



root@debian:~# ls -l /home/zanca
total 36
drwxr-xr-x 2 zanca zanca 4096 juil. 12 16:47 Bureau
drwxrwxrwx 6 zanca zanca 4096 juil. 13 17:10 Devs
drwxrwxr-x 3 zanca zanca 4096 juil. 12 16:24 Documents
drwxrwxr-x 3 zanca zanca 4096 juil. 12 16:23 Images
drwxr-xr-x 2 zanca zanca 4096 juil. 12 16:47 Modèles
drwxr-xr-x 2 zanca zanca 4096 juil. 12 16:47 Musique
drwxr-xr-x 2 zanca zanca 4096 juil. 12 16:47 Public
drwxr-xr-x 2 zanca zanca 4096 juil. 12 19:17 Téléchargements
drwxrwxr-x 3 zanca zanca 4096 juil. 12 16:24 Vidéos
 


root@debian:~# ls -l /home/zanca/Devs
total 520
-rw-r--rw- 1 zanca zanca 491973 juil. 12 17:25 adminer.php
-rw-r--r-- 1 root  root    1332 juil. 12 17:43 copie_Devs.local.conf
drwxr-xrwx 2 zanca zanca   4096 mars  20 16:43 flexbox
drwxr-xrwx 2 zanca zanca   4096 mars  24 17:40 grip
drwxr-xrwx 2 zanca zanca  16384 juil. 12 16:24 lost+found
-rw-r--r-- 1 root  root      20 juil. 13 17:03 phpinfo.php
drwxr-xrwx 2 zanca zanca   4096 mars  31 18:11 transformation-animation
 


??????

Dernière modification par zancanarotrois (13-07-2020 16:31:57)

Hors ligne

#39 13-07-2020 17:17:48

cyrille
Adhérent(e)
Distrib. : SID + FreeBSD
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [RESOLU]web en local ouverture index.php

Forbidden

You don't have permission to access this resource./




Il faut passer comme option Indexes  dans ton rep virtuel

<Directory "/Path/to/your/virtual/host">
  Options Indexes FollowSymLinks
</Directory>




Ou créer un .htaccess avec ce contenu

Options +Indexes



cf https://httpd.apache.org/docs/2.4/fr/mo … #directory

Dernière modification par cyrille (13-07-2020 17:19:23)

Hors ligne

#40 13-07-2020 18:08:21

zancanarotrois
Membre
Distrib. : debian GNU/linux 10 (buster)
Noyau : linux 4.19.0.9-amd64
(G)UI : gnome 3.22.2
Inscription : 08-02-2018

Re : [RESOLU]web en local ouverture index.php

Je suppose que quand tu parle de rep virtuel tu parle de ce répertoire

<VirtualHost *:80>
ServerAdmin sites@localhost
DocumentRoot /home/linux/sites
ServerName sites
 <Directory /home/linux/sites/>
 Require all granted
 AllowOverride All
 # pour mode rewrite et autoriser les fichiers .htacces
 </Directory>
</VirtualHost>


Et que  c'est  dans ce répertoire qu'il me faut ajouter

<Directory "/Path/to/your/virtual/host">
  Options Indexes FollowSymLinks
</Directory>



Merci pour ton aide.

Hors ligne

#41 13-07-2020 18:20:06

cyrille
Adhérent(e)
Distrib. : SID + FreeBSD
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [RESOLU]web en local ouverture index.php

Essaie et recharge la config d'Apache

Hors ligne

#42 13-07-2020 18:33:00

zancanarotrois
Membre
Distrib. : debian GNU/linux 10 (buster)
Noyau : linux 4.19.0.9-amd64
(G)UI : gnome 3.22.2
Inscription : 08-02-2018

Re : [RESOLU]web en local ouverture index.php

cyrille a écrit :

Essaie et recharge la config d'Apache


Je viens d'essayer mais je n’ai pas de changement.

root@debian:~# nano /etc/apache2/sites-available/Devs.local.conf
root@debian:~# systemctl reload apache2
 


Est-ce que j'ai fait une erreur ?

<VirtualHost *:80> 
ServerAdmin sites@localhost
DocumentRoot /home/zanca/Devs
ServerName Devs
 <Directory /home/zanca/Devs/>
 Require all granted
 AllowOverride All
 # pour mode rewrite et autoriser les fichiers .htacces
 </Directory>
<Directory "/Path/to/your/virtual/host">
  Options Indexes FollowSymLinks
</Directory>
</VirtualHost>

Hors ligne

#43 13-07-2020 18:35:49

cyrille
Adhérent(e)
Distrib. : SID + FreeBSD
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [RESOLU]web en local ouverture index.php

il ne fallait pas ajouter un nouvel <Directory...> mais mettre à jour le tien....

Hors ligne

#44 13-07-2020 18:43:21

zancanarotrois
Membre
Distrib. : debian GNU/linux 10 (buster)
Noyau : linux 4.19.0.9-amd64
(G)UI : gnome 3.22.2
Inscription : 08-02-2018

Re : [RESOLU]web en local ouverture index.php

cyrille a écrit :

il ne fallait pas ajouter un nouvel <Directory...> mais mettre à jour le tien....


J'ai hésité. Ça ferait ça ?

<VirtualHost *:80>
ServerAdmin sites@localhost
DocumentRoot /home/zanca/Devs
ServerName Devs
 <Directory /home/zanca/Devs/>
 Require all granted
 AllowOverride All
 # pour mode rewrite et autoriser les fichiers .htacces
 "/Path/to/your/virtual/host"
  Options Indexes FollowSymLinks
</Directory>
</VirtualHost>



Non ne t'arrache pas les cheveux .

Hors ligne

#45 13-07-2020 19:28:06

zancanarotrois
Membre
Distrib. : debian GNU/linux 10 (buster)
Noyau : linux 4.19.0.9-amd64
(G)UI : gnome 3.22.2
Inscription : 08-02-2018

Re : [RESOLU]web en local ouverture index.php

Super ça marche.

<VirtualHost *:80> 
ServerAdmin sites@localhost
DocumentRoot /home/zanca/Devs
ServerName Devs
 <Directory /home/zanca/Devs/>
 Require all granted
 AllowOverride All
 # pour mode rewrite et autoriser les fichiers .htacces
  Options Indexes FollowSymLinks
</Directory>
</VirtualHost>
 



Un grand merci pour ta patience et votre aide.

Hors ligne

#46 13-07-2020 19:41:14

cyrille
Adhérent(e)
Distrib. : SID + FreeBSD
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [RESOLU]web en local ouverture index.php

pas de soucis, par contre n'hésite pas  à te pencher siur la doc wink

Hors ligne

Pied de page des forums