Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 11-04-2021 20:23:54

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

bonjour/re
voila ce que je vais utiliser


2 sondes nvme
sensors nvme-pci-4100 | awk '/Sensor 1/ {print $3}'
sensors nvme-pci-4100 | awk '/Sensor 2/ {print $3}'
2 sondes cpu
sensors k10temp-pci-00cb | awk '/Tctl/ {print $2}'
sensors k10temp-pci-00c3 | awk '/Tctl/ {print $2}'
 


pour les disques en sata je sais pas , /dev/sdX . (j'ai quelque chose avec hddtemp en root)
sinon conky tourne avec le fichier par défaut que j'ai adapté a mes préférences , placé dans mon home et lancé par le bureau mate
je ferais un fil pour poser des questions et je pense un peu de doc partout  sur le sujet  smile

Hors ligne

#27 11-04-2021 21:38:17

Tawal
Membre
Distrib. : Debian 10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Xfce4
Inscription : 25-02-2021

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

Pour hddtemp, tu peux retrouver la température sur ton localhost avec : (chez-moi)

nc localhost 7634


|/dev/sda|Hitachi HTS543216L9A300|24|C||/dev/sdb|ST9250311CS|42|C|


nc vient du paquet netcat je crois.

Plus besoin de root wink
.

Dernière modification par Tawal (11-04-2021 21:45:40)


Comme la science n'est pas infuse, elle se diffuse.

Hors ligne

#28 12-04-2021 11:45:24

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

Bonjour


nc localhost 7634
localhost [127.0.0.1] 7634 (?) : Connection refused
 



apt policy netcat-traditional
netcat-traditional:
  Installé : 1.10-46
  Candidat : 1.10-46
 Table de version :
 *** 1.10-46 500
        500 http://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
 

Hors ligne

#29 12-04-2021 14:17:05

Tawal
Membre
Distrib. : Debian 10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Xfce4
Inscription : 25-02-2021

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

HDDTEMP(8)                                                   System Manager's Manual                                                  HDDTEMP(8)

NAME
       hddtemp - Utility to monitor hard drive temperature

SYNOPSIS
       hddtemp [options] [type:]disk...
....

       -d, --daemon
              Execute hddtemp in TCP/IP daemon mode (port 7634 by default).
 


Comme la science n'est pas infuse, elle se diffuse.

Hors ligne

#30 12-04-2021 15:53:13

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-6-amd64
(G)UI : mutter 3.38.4-1
Inscription : 15-02-2016

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

robert2a a écrit :

re ,
je ne vois qu 'une solution pour récupérer l'info sans hddtemp
sensors me renvoie mes deux disques si je prend celui ci par exemple "drivetemp-scsi-9-0"
avec cette commande


sensors drivetemp-scsi-9-0
 



drivetemp-scsi-9-0
Adapter: SCSI adapter
temp1:        +40.0°C  (low  =  +0.0°C, high = +70.0°C)
                       (crit low =  -5.0°C, crit = +75.0°C)
                       (lowest = +28.0°C, highest = +66.0°C)
 


@golgot200  , tu pense que avec conky il est possible de prendre la valeur par exemple "temp1:        +40.0°C" et de l' afficher ou simplement "+40.0°C"
a mon avis ça règle le souci dans le futur du paquet "hddtemp"
j'ai parcouru avec admiration ceci => https://debian-facile.org/viewtopic.php?id=27092&p=6 
ps:  voir ici le #4 de pomme  =>  https://debian-facile.org/viewtopic.php … 16#p357916




Robert, bonjour, à  mon avis, cette commande devrait marcher avec sensors pour ton disque :

sensors drivetemp-scsi-9-0 | awk '/temp1/ {print $2}'





dérivée de la commande testée chez moi :

sensors drivetemp-scsi-0-0 | awk '/temp1/ {print $2}'

+26.0°C


Nos vies commencent à prendre fin le jour où nous devenons silencieux à propos des choses qui comptent. Martin Luther King

Hors ligne

#31 12-04-2021 16:52:34

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

Bonjour
j'ai une erreur "$2" inconnu  , et le print ne fonctionne pas dans conky
je me suis débrouillé avec "grep" voir ici => https://debian-facile.org/viewtopic.php … 97#p358097
j'ai parcouru un peu , find , awk , grep   roll
sinon dans la console awk est parfait ...........

ps: pour le disque grep me renvoie trop de choses
par exemple


temp1:        +34.0°C  (low  = +14.0°C, high = +55.0°C)
 


alors que je n'ai besoin que de " +34.0°C"
peut être avec un script et enregistrer la valeur dans une variable pour awk et lire la variable dans conky (a priori je sais pas faire   hmm   )

Hors ligne

#32 12-04-2021 17:17:26

Tawal
Membre
Distrib. : Debian 10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Xfce4
Inscription : 25-02-2021

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

Hello,

Bizarre, tes erreurs Robert2a roll

Chez moi, dans le conky, cette ligne fonctionne très bien :

${execi 15 sensors k10temp-pci-00c3 | awk '/temp1/ {print $2}'}


Et le retour "console" :

sensors k10temp-pci-00c3 | awk '/temp1/ {print $2}'


+71.9°C



Et l'image conky :
MUPbcQCl.png
.

Dernière modification par Tawal (12-04-2021 17:22:41)


Comme la science n'est pas infuse, elle se diffuse.

Hors ligne

#33 12-04-2021 17:29:56

jpt
Membre
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

Bonjour,

robert2a a écrit :

ps: pour le disque grep me renvoie trop de choses

par exemple


temp1:        +34.0°C  (low  = +14.0°C, high = +55.0°C)



alors que je n'ai besoin que de " +34.0°C"

Euh, (je m'en suis sorti, j'ai réussi au bout de 3 jours de combat acharné, à avoir drivetemp qui fonctionne), si je fais

sensors | grep temp1

j'ai tout ça

temp1:        +39.0°C  (low  = +14.0°C, high = +55.0°C)
temp1:        +34.0°C  
temp1:        +40.0°C  (low  = +14.0°C, high = +55.0°C)
temp1:        +16.8°C  (crit = +20.8°C)

et si je fais

sensors | awk '/temp1/ {print $2}' # à la manière de tawal [+1 !]

je n'ai plus que ce qui t'intéresse (sauf la dernière ligne, en trop, qui doit correspondre à un capteur sur la carte-mère.

+39.0°C
+34.0°C
+40.0°C
+16.8°C

EDIT ce capteur en trop, je pense que c'est celui dont j'ai parlé ici il y a qq jours (sans nouvelles depuis…)

jpt a écrit :

Parce que sur ma machine j'ai hwmon0, hwmon1 et hwmon2 et les résultats, dans l'ordre, donnent 38, 16.8, 37.

Dernière modification par jpt (12-04-2021 17:37:21)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#34 12-04-2021 17:32:27

Tawal
Membre
Distrib. : Debian 10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Xfce4
Inscription : 25-02-2021

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

@jpt:
Donne un retour de:

sensors


Et dis moi quelles températures t'intéressent ?
Je te donnerai les commandes wink


Comme la science n'est pas infuse, elle se diffuse.

Hors ligne

#35 12-04-2021 17:37:11

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

moi aussi , donc la ligne actuelle


${color grey}CPU Temp:$color ${execi 15 sensors k10temp-pci-00c3 | awk '/Tctl/ {print $2}'}
 



pourquoi Tctl (ou Tdie)


sensors
amdgpu-pci-0800
Adapter: PCI adapter
vddgfx:           N/A  
vddnb:            N/A  
edge:         +50.0°C  

k10temp-pci-00c3
Adapter: PCI adapter
Tctl:         +50.0°C  
Tdie:         +50.0°C  

drivetemp-scsi-0-0
Adapter: SCSI adapter
temp1:        +33.0°C  (low  = +14.0°C, high = +55.0°C)
                       (crit low = +10.0°C, crit = +60.0°C)
                       (lowest = +29.0°C, highest = +36.0°C)

drivetemp-scsi-9-0
Adapter: SCSI adapter
temp1:        +41.0°C  (low  =  +0.0°C, high = +70.0°C)
                       (crit low =  -5.0°C, crit = +75.0°C)
                       (lowest = +28.0°C, highest = +66.0°C)
 



l'utilisation de "execi" a résolu le problème (a la place de "execp" )
merci pour le test  smile  (et ça va prendre moins de ressources)

Hors ligne

#36 12-04-2021 17:46:02

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

il me reste les 2 disques a faire

ceci  ok


${color grey}CPU Temp:$color ${execi 15 sensors k10temp-pci-00c3 | awk '/Tctl/ {print $2}'}
${color grey}GPU Temp:$color ${execp sensors amdgpu-pci-0800 | awk '/edge/ {print $2}'}
 



pour les deux DD correct aussi


${color grey}ST3500413AS Temp:$color ${execi 15 sensors drivetemp-scsi-0-0 | awk '/temp1/ {print $2}'}
${color grey}CT275MX3 Temp:$color ${execi 15 sensors drivetemp-scsi-9-0 | awk '/temp1/ {print $2}'}
 



pour le raven 2200G terminer pour les infos , restera le threadripper , puis pour le fun améliorer la présentation de Conky  smile
pour les température toutes les 15 secondes , le reste a une seconde (que je pourrai mettre un peu plus long peut être )

Dernière modification par robert2a (12-04-2021 18:06:37)

Hors ligne

#37 12-04-2021 20:03:37

Tawal
Membre
Distrib. : Debian 10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Xfce4
Inscription : 25-02-2021

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

robert2a a écrit :

i

${color grey}GPU Temp:$color ${execp sensors amdgpu-pci-0800 | awk '/edge/ {print $2}'}


Il n'y a pas une erreur sur execp ?
Ce serait pas plutôt execpi ?

Edit:
execi  n  commande    veut dire de lancer la commande toutes les n secondes wink

Dernière modification par Tawal (12-04-2021 20:05:38)


Comme la science n'est pas infuse, elle se diffuse.

Hors ligne

#38 13-04-2021 00:39:10

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

je n'ai testé que "exec" et "execp" jusque au moment ou tu a fait la remarque pour "execi"  en #32

je sais pas si la commande bug ou si c'est moi , avec execp ou exec  roll
oui pour le "n" j'ai lu la doc de arpinux aujourd'hui de Conky .

Hors ligne

#39 13-04-2021 01:37:45

Tawal
Membre
Distrib. : Debian 10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Xfce4
Inscription : 25-02-2021

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

Pour execp, c'est normal que la commande awk ne fonctionne pas.
Car c'est un "mode" d'exécution de la commande en développant les variables pour conky, donc conky essaie de lire $2 wink

Comme la science n'est pas infuse, elle se diffuse.

Hors ligne

#40 13-04-2021 01:57:16

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

sur la deuxième machine il me manque sda et sdb


dmesg | grep sda
[    1.513180] sd 0:0:0:0: [sda] 1025610768 512-byte logical blocks: (525 GB/489 GiB)
[    1.513188] sd 0:0:0:0: [sda] Write Protect is off
[    1.513190] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    1.513201] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    1.537611]  sda: sda1 sda2 sda3
[    1.538838] sd 0:0:0:0: [sda] supports TCG Opal
[    1.538839] sd 0:0:0:0: [sda] Attached SCSI disk



dmesg | grep sdb
[    1.985466] sd 1:0:0:0: [sdb] 7814037168 512-byte logical blocks: (4.00 TB/3.64 TiB)
[    1.985468] sd 1:0:0:0: [sdb] 4096-byte physical blocks
[    1.985473] sd 1:0:0:0: [sdb] Write Protect is off
[    1.985474] sd 1:0:0:0: [sdb] Mode Sense: 00 3a 00 00
[    1.985484] sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    2.031614]  sdb: sdb1
[    2.032444] sd 1:0:0:0: [sdb] Attached SCSI disk
[    4.646377] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)



sensors ne me renvoie rien , uniquement le ssd  nvme , j'ai oublié quoi  hmm


sensors
k10temp-pci-00cb
Adapter: PCI adapter
Tctl:         +53.8°C  
Tdie:         +26.8°C  

nvme-pci-4100
Adapter: PCI adapter
Composite:    +29.9°C  (low  = -273.1°C, high = +76.8°C)
                       (crit = +78.8°C)
Sensor 1:     +29.9°C  (low  = -273.1°C, high = +65261.8°C)
Sensor 2:     +35.9°C  (low  = -273.1°C, high = +65261.8°C)

k10temp-pci-00c3
Adapter: PCI adapter
Tctl:         +53.8°C  
Tdie:         +26.8°C  
Tccd1:        +53.8°C  
 



je n'ai pas le gpu nvidia aussi "GTX750TI"

nota: pour certain cpu amd comme ici le threaripper (première génération) j'ai un offset de + 20 sur le firmware UEFI , il faudrait que j'affiche la valeur de (tctl -20) 53.8 - 20 =33.8°C
pourquoi deux k10temp-pci , j'ai un socket , mais 2 cpu (modules) de 8 cores , chaque module a une sonde

Dernière modification par robert2a (13-04-2021 02:09:39)

Hors ligne

#41 13-04-2021 03:27:16

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

j'ai trouvé la solution pour sda et sdb du #1 , la commande a faire


echo drivetemp > /etc/modules-load.d/drivetemp.conf
 


et le retour est correct maintenant (oublier sur cette machine)
ps:pour le gpu nvidia on verra (j'ai le driver nonfree)

Hors ligne

#42 13-04-2021 09:54:24

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-6-amd64
(G)UI : mutter 3.38.4-1
Inscription : 15-02-2016

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

Robert, puisque tu ne l'avais pas vu, mais comme c'est  pour le moment un pré-requis, j'ai mis encore plus en évidence la commande du chargement du module de noyau "drivetemp" dans le message #1.

modprobe drivetemp



echo drivetemp > /etc/modules-load.d/drivetemp.conf





Je viens de lire un peu le man de inxi, inxi aussi a aussi abandonné hdtemp pour les noyaux supérieurs à 5.6 et se base sur lm-sensors ( sensors ) pour récupérer les données de température qu'il affiche.

C'est indiqué à l'explication de l'option -x -D

 -x -D  - Adds HDD temperature with disk data.

              Method 1: Systems running Linux kernels ~5.6 and newer should have drivetemp module data available.  If  so,  drive  temps
              will  come  from /sys data for each drive, and will not require root or hddtemp. This method is MUCH faster than using hd‐
              dtemp.  Note that NVMe drives do not require drivetemp.

              If your drivetemp module is not enabled, enable it:

              modprobe drivetemp

              Once enabled, add drivetemp to /etc/modules or /etc/modules-load.d/***.conf so it starts automatically.

 




-x -D - Ajoute la température du disque dur avec les données du disque.

              Méthode 1 : Les systèmes exécutant des noyaux Linux ~5.6 et plus récents devraient avoir des données du module drivetemp disponibles.  Si c'est le cas, la température du disque
              proviendra des données /sys pour chaque disque, et ne nécessitera pas root ou hddtemp. Cette méthode est BEAUCOUP plus rapide que l'utilisation de hddtemp.
             Notez que les lecteurs NVMe ne nécessitent pas drivetemp.

              Si votre module drivetemp n'est pas activé, activez-le :

              modprobe drivetemp

              Une fois activé, ajoutez drivetemp à /etc/modules ou /etc/modules-load.d/***.conf pour qu'il démarre automatiquement.



Traduit avec www.DeepL.com/Translator (version gratuite)


Nos vies commencent à prendre fin le jour où nous devenons silencieux à propos des choses qui comptent. Martin Luther King

Hors ligne

#43 13-04-2021 14:41:35

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

Bonjour
pas de souci , j'ai fait la manipulation sur la première machine , puis oublié sur la seconde
pour être sincère je fais ceci "echo drivetemp > /etc/modules-load.d/drivetemp.conf" puis un reboot
sinon je confirme , tous les disques sata sont pris en charge par "drivetemp"  et le nvme est pris en charge par le noyau (pas besoin de drivetemp)
c'est beaucoup plus simple maintenant  smile

Hors ligne

#44 13-04-2021 18:32:24

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

Bonjour
sur l'avenir de k10temp dans le noyau
une recherche sur tccd1 (qui monte a 83 degrés) quand même .......
noyau => https://www.phoronix.com/scan.php?page= … -V-Current
Bon au vue des retours sur un noyau 5.10.26-1 c'est pas encore parfait  hmm
ps: moi c'est du zen1 mes machines
entre Asus (CM) qui utilise des circuits sans information et amd qui bouge pas trop pour ses cpu sous GNU Linux (kernel)

=> https://patchwork.kernel.org/project/li … ck-us.net/

sur un ryzen 3600 le retour de k10temp  roll


k10temp-pci-00c3
Adapter: PCI adapter
Vcore:        +1.33 V  
Vsoc:         +1.08 V  
Tdie:         +45.0°C  
Tctl:         +45.0°C  
Tccd1:        +48.0°C  
Icore:       +17.00 A  
Isoc:         +6.75 A
 



a priori les derniere génération sont mieux pris en charge par k10temp

Dernière modification par robert2a (13-04-2021 18:58:28)

Hors ligne

#45 17-04-2021 02:30:47

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

Bonjour
j'ai trouvé un petit bug avec "drivetemp"


hddtemp /dev/sda
/dev/sda: CT240BX200SSD1: 25°C
 



sensors drivetemp-scsi-1-0
drivetemp-scsi-1-0
Adapter: SCSI adapter
temp1:         +0.0°C  (low  =  +0.0°C, high = +100.0°C)
                       (crit low =  +0.0°C, crit = +100.0°C)
                       (lowest =  +0.0°C, highest =  +0.0°C)
 


ps: pas de température avec "sensors" et ok avec "hddtemp"  sous bullseye

le sensors complet avec les modules disponibles


sensors
nct6776-isa-0290
Adapter: ISA adapter
Vcore:           0.00 V  (min =  +0.00 V, max =  +1.74 V)
in1:           192.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
AVCC:            3.20 V  (min =  +2.98 V, max =  +3.63 V)
+3.3V:           3.20 V  (min =  +2.98 V, max =  +3.63 V)
in4:           800.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in5:             1.58 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in6:           744.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
3VSB:            3.31 V  (min =  +2.98 V, max =  +3.63 V)
Vbat:            3.26 V  (min =  +2.70 V, max =  +3.63 V)
fan1:             0 RPM  (min =    0 RPM)
fan2:             0 RPM  (min =    0 RPM)
fan3:             0 RPM  (min =    0 RPM)
SYSTIN:         +43.0°C  (high =  +0.0°C, hyst =  +0.0°C)  ALARM  sensor = thermistor
CPUTIN:        +123.5°C  (high = +80.0°C, hyst = +75.0°C)  ALARM  sensor = CPU diode
AUXTIN:         +38.5°C  (high = +80.0°C, hyst = +75.0°C)  sensor = thermistor
PCH_CHIP_TEMP:   +0.0°C  
PCH_CPU_TEMP:    +0.0°C  
PCH_MCH_TEMP:    +0.0°C  
intrusion0:    ALARM
intrusion1:    ALARM
beep_enable:   disabled

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +42.0°C  (high = +81.0°C, crit = +91.0°C)
Core 0:        +34.0°C  (high = +81.0°C, crit = +91.0°C)
Core 1:        +41.0°C  (high = +81.0°C, crit = +91.0°C)
Core 2:        +39.0°C  (high = +81.0°C, crit = +91.0°C)
Core 3:        +32.0°C  (high = +81.0°C, crit = +91.0°C)
Core 4:        +35.0°C  (high = +81.0°C, crit = +91.0°C)
Core 5:        +37.0°C  (high = +81.0°C, crit = +91.0°C)

i350bb-pci-0600
Adapter: PCI adapter
loc1:         +51.0°C  (high = +120.0°C, crit = +110.0°C)

nouveau-pci-8300
Adapter: PCI adapter
GPU core:      1.01 V  (min =  +0.60 V, max =  +1.20 V)
fan1:         930 RPM
temp1:        +32.0°C  (high = +95.0°C, hyst =  +3.0°C)
                       (crit = +105.0°C, hyst =  +5.0°C)
                       (emerg = +135.0°C, hyst =  +5.0°C)

coretemp-isa-0001
Adapter: ISA adapter
Package id 1:  +40.0°C  (high = +81.0°C, crit = +91.0°C)
Core 0:        +35.0°C  (high = +81.0°C, crit = +91.0°C)
Core 1:        +35.0°C  (high = +81.0°C, crit = +91.0°C)
Core 2:        +40.0°C  (high = +81.0°C, crit = +91.0°C)
Core 3:        +34.0°C  (high = +81.0°C, crit = +91.0°C)
Core 4:        +38.0°C  (high = +81.0°C, crit = +91.0°C)
Core 5:        +36.0°C  (high = +81.0°C, crit = +91.0°C)

drivetemp-scsi-1-0
Adapter: SCSI adapter
temp1:         +0.0°C  (low  =  +0.0°C, high = +100.0°C)
                       (crit low =  +0.0°C, crit = +100.0°C)
                       (lowest =  +0.0°C, highest =  +0.0°C)
 


nota: le premier ou je trouve ce souci

Hors ligne

#46 17-04-2021 10:05:52

jpt
Membre
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

Bonjour,

robert2a a écrit :

Bonjour
j'ai trouvé un petit bug avec "drivetemp"


hddtemp /dev/sda
/dev/sda: CT240BX200SSD1: 25°C
 



sensors drivetemp-scsi-1-0
drivetemp-scsi-1-0
Adapter: SCSI adapter
temp1:         +0.0°C  (low  =  +0.0°C, high = +100.0°C)
                       (crit low =  +0.0°C, crit = +100.0°C)
                       (lowest =  +0.0°C, highest =  +0.0°C)
 


ps: pas de température avec "sensors" et ok avec "hddtemp"  sous bullseye


Elle sort d'où, cette ligne ?

sensors drivetemp-scsi-1-0

D'un fichier de conf ? D'une ligne de commande ?
Parce que si tu n'as qu'un seul disque dans cette machine, il se pourrait fort que ça soit

sensors drivetemp-scsi-0-0

ou peut-être même autre chose -- si toujours tout à zéro, faut essayer 2, 3, etc.

Va donc jeter un coup d'œil (avec mc, c'est + confortable) dans /sys/class/scsi_disk où tu trouveras tes disques et leurs identifiants, exemple chez moi avec 3 disques :

~0:0:0:0
~1:0:0:0
~4:0:0:0





Tawal a écrit :

@jpt:
Donne un retour de:

sensors


Et dis-moi quelles températures t'intéressent ?
Je te donnerai les commandes wink

Désolé, j'ai complètement zappé cette demande sympathique. Mais ce n'est pas bien grave, je m'en dépatouille tout seul comme un grand. cool
Merci quand même, wink

Dernière modification par jpt (17-04-2021 10:09:20)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#47 17-04-2021 12:24:04

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

Bonjour
regarde le titre du sujet , et le #1
sensors fonctionne en user , pas hddtemp
hddtemp va disparaître de debian sur la prochaine testing
pour "sensors drivetemp-scsi-1-0" c'est la commande "sensors" qui me le donne "drivetemp-scsi-1-0" donc pas d'erreur (regarde sur le #45 mon retour complet de sensors)
oui seulement un disque sur cette machine

ps: j'ai cette température qui passe a "0" au bout d'un certain temps , je sais pas pourquoi


SYSTIN:         +43.0°C  (high =  +0.0°C, hyst =  +0.0°C)  ALARM  sensor = thermistor
 

Hors ligne

#48 18-04-2021 20:00:31

jpt
Membre
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

Bonsoir,

robert2a a écrit :

ps: j'ai cette température qui passe a "0" au bout d'un certain temps , je sais pas pourquoi

2 possibilités :
- bug matériel ;
- bug logiciel.

Si c'est matériel, ça peut être le capteur lui-même, ou le chip qui le pilote, ou quelque chose autour. Introuvable comme ça. Faudrait remplacer la CM pour voir si ça change qqchse. Et je n'ai pas parlé des mauvais contacts et autres soudures sèches…

Si c'est logiciel, c'est pas mieux : on part du driver du chip, on analyse le code, si on suspecte un truc bizarre on le modifie on recompile et on reteste -- et si c'est pas ça, on remet comme c'était et on répète ce process au niveau supérieur, jusqu'à ce que ça finisse par tomber en marche.


Une question : quand la temp tombe à 0°, est-ce qu'elle remonte toute seule plus tard ? Si "oui", au bout de combien de temps ? C'est régulier ? Si "non", comment fais-tu ? Power-off/power-on ou reboot ? Ou simplement logoff/logon ? Ou autre (claque sur le capot de la babasse) ?

Dernière modification par jpt (18-04-2021 20:02:47)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#49 18-04-2021 23:13:35

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

Bonsoir
c'est un serveur bi-xeon , je pense que la sonde bug
cette machine tourne 24/24 et 7/7 depuis 2014 , elle mérite un peu de repos smile
ce soir elle fonctionne ........
il y a un module IPMI pour la surveillance mais pas le courage (BMC)
sonde TR1 et TR2 , je pense aux VRM processeur mais pas sur (c'est TR1 qui se coupe )

Hors ligne

#50 19-04-2021 09:24:53

jpt
Membre
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : hddtemp désapprouvé à partir de debian 11 => Conkys avec sensors

Pas répondu :

jpt a écrit :

Une question : quand la temp tombe à 0°, est-ce qu'elle remonte toute seule plus tard ? Si "oui", au bout de combien de temps ? C'est régulier ? Si "non", comment fais-tu ? Power-off/power-on ou reboot ? Ou simplement logoff/logon ? Ou autre (claque sur le capot de la babasse) ?


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

Pied de page des forums