Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 26-07-2021 19:35:34

robert2a
Membre
Inscription : 15-11-2014

Re : nomodeset uniquement en mode recovery

voila le dernier , recovery + nomodeset


[    55.123]
X.Org X Server 1.20.11
X Protocol Version 11, Revision 0
[    55.123] Build Operating System: linux Debian
[    55.123] Current Operating System: Linux debian2 5.10.0-8-amd64 #1 SMP Debian 5.10.46-2 (2021-07-20) x86_64
[    55.123] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.10.0-8-amd64 root=UUID=dd6b9f3e-45f1-4071-99a2-4d5a7d2a256c ro nomodeset single
[    55.123] Build Date: 13 April 2021  04:07:31PM
[    55.123] xorg-server 2:1.20.11-1 (https://www.debian.org/support)
[    55.123] Current version of pixman: 0.40.0
[    55.123]  Before reporting problems, check http://wiki.x.org
  to make sure that you have the latest version.
[    55.123] Markers: (--) probed, (**) from config file, (==) default setting,
  (++) from command line, (!!) notice, (II) informational,
  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    55.123] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul 26 19:09:08 2021
[    55.126] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    55.127] (==) No Layout section.  Using the first Screen section.
[    55.127] (==) No screen section available. Using defaults.
[    55.127] (**) |-->Screen "Default Screen Section" (0)
[    55.127] (**) |   |-->Monitor "<default monitor>"
[    55.128] (==) No monitor specified for screen "Default Screen Section".
  Using a default monitor configuration.
[    55.128] (==) Automatically adding devices
[    55.128] (==) Automatically enabling devices
[    55.128] (==) Automatically adding GPU devices
[    55.128] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    55.133] (==) FontPath set to:
  /usr/share/fonts/X11/misc,
  /usr/share/fonts/X11/cyrillic,
  /usr/share/fonts/X11/100dpi/:unscaled,
  /usr/share/fonts/X11/75dpi/:unscaled,
  /usr/share/fonts/X11/Type1,
  /usr/share/fonts/X11/100dpi,
  /usr/share/fonts/X11/75dpi,
  built-ins
[    55.133] (==) ModulePath set to "/usr/lib/xorg/modules"
[    55.133] (II) The server relies on udev to provide the list of input devices.
  If no devices become available, reconfigure udev or disable AutoAddDevices.
[    55.133] (II) Loader magic: 0x56007aed3e40
[    55.133] (II) Module ABI versions:
[    55.133]  X.Org ANSI C Emulation: 0.4
[    55.133]  X.Org Video Driver: 24.1
[    55.133]  X.Org XInput driver : 24.1
[    55.133]  X.Org Server Extension : 10.0
[    55.133] (++) using VT number 7

[    55.133] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    55.137] (--) PCI:*(1@0:0:0) 10de:1381:1462:8a9c rev 162, Mem @ 0xfd000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/131072
[    55.137] (II) LoadModule: "glx"
[    55.138] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    55.146] (II) Module glx: vendor="X.Org Foundation"
[    55.146]  compiled for 1.20.11, module version = 1.0.0
[    55.146]  ABI class: X.Org Server Extension, version 10.0
[    55.267] (==) Matched nouveau as autoconfigured driver 0
[    55.267] (==) Matched nv as autoconfigured driver 1
[    55.267] (==) Matched modesetting as autoconfigured driver 2
[    55.267] (==) Matched fbdev as autoconfigured driver 3
[    55.267] (==) Matched vesa as autoconfigured driver 4
[    55.267] (==) Assigned the driver to the xf86ConfigLayout
[    55.267] (II) LoadModule: "nouveau"
[    55.267] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    55.269] (II) Module nouveau: vendor="X.Org Foundation"
[    55.269]  compiled for 1.20.10, module version = 1.0.17
[    55.269]  Module class: X.Org Video Driver
[    55.269]  ABI class: X.Org Video Driver, version 24.1
[    55.269] (II) LoadModule: "nv"
[    55.270] (WW) Warning, couldn't open module nv
[    55.270] (EE) Failed to load module "nv" (module does not exist, 0)
[    55.270] (II) LoadModule: "modesetting"
[    55.270] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    55.271] (II) Module modesetting: vendor="X.Org Foundation"
[    55.271]  compiled for 1.20.11, module version = 1.20.11
[    55.271]  Module class: X.Org Video Driver
[    55.271]  ABI class: X.Org Video Driver, version 24.1
[    55.271] (II) LoadModule: "fbdev"
[    55.271] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    55.271] (II) Module fbdev: vendor="X.Org Foundation"
[    55.271]  compiled for 1.20.0, module version = 0.5.0
[    55.271]  Module class: X.Org Video Driver
[    55.271]  ABI class: X.Org Video Driver, version 24.0
[    55.271] (II) LoadModule: "vesa"
[    55.271] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    55.272] (II) Module vesa: vendor="X.Org Foundation"
[    55.272]  compiled for 1.20.9, module version = 2.5.0
[    55.272]  Module class: X.Org Video Driver
[    55.272]  ABI class: X.Org Video Driver, version 24.1
[    55.272] (II) NOUVEAU driver Date:   Sat Jan 23 12:24:42 2021 -0500
[    55.272] (II) NOUVEAU driver for NVIDIA chipset families :
[    55.272]  RIVA TNT            (NV04)
[    55.272]  RIVA TNT2           (NV05)
[    55.272]  GeForce 256         (NV10)
[    55.272]  GeForce 2           (NV11, NV15)
[    55.272]  GeForce 4MX         (NV17, NV18)
[    55.272]  GeForce 3           (NV20)
[    55.272]  GeForce 4Ti         (NV25, NV28)
[    55.272]  GeForce FX          (NV3x)
[    55.272]  GeForce 6           (NV4x)
[    55.272]  GeForce 7           (G7x)
[    55.272]  GeForce 8           (G8x)
[    55.272]  GeForce 9           (G9x)
[    55.272]  GeForce GTX 2xx/3xx (GT2xx)
[    55.272]  GeForce GTX 4xx/5xx (GFxxx)
[    55.272]  GeForce GTX 6xx/7xx (GKxxx)
[    55.272]  GeForce GTX 9xx     (GMxxx)
[    55.272]  GeForce GTX 10xx    (GPxxx)
[    55.272] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    55.272] (II) FBDEV: driver for framebuffer: fbdev
[    55.272] (II) VESA: driver for VESA chipsets: vesa
[    55.410] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
[    55.410] (EE) open /dev/dri/card0: No such file or directory
[    55.410] (WW) Falling back to old probe method for modesetting
[    55.410] (EE) open /dev/dri/card0: No such file or directory
[    55.410] (II) Loading sub module "fbdevhw"
[    55.410] (II) LoadModule: "fbdevhw"
[    55.411] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    55.411] (II) Module fbdevhw: vendor="X.Org Foundation"
[    55.411]  compiled for 1.20.11, module version = 0.0.2
[    55.411]  ABI class: X.Org Video Driver, version 24.1
[    55.411] (EE) Unable to find a valid framebuffer device
[    55.411] (WW) Falling back to old probe method for fbdev
[    55.411] (II) Loading sub module "fbdevhw"
[    55.411] (II) LoadModule: "fbdevhw"
[    55.412] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    55.412] (II) Module fbdevhw: vendor="X.Org Foundation"
[    55.412]  compiled for 1.20.11, module version = 0.0.2
[    55.412]  ABI class: X.Org Video Driver, version 24.1
[    55.412] (II) FBDEV(2): using default device
[    55.412] vesa: Refusing to run on UEFI
[    55.412] (EE) Screen 0 deleted because of no matching config section.
[    55.412] (II) UnloadModule: "modesetting"
[    55.412] (EE) Screen 0 deleted because of no matching config section.
[    55.412] (II) UnloadModule: "fbdev"
[    55.412] (II) UnloadSubModule: "fbdevhw"
[    55.412] (II) FBDEV(0): Creating default Display subsection in Screen section
  "Default Screen Section" for depth/fbbpp 24/32
[    55.412] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
[    55.412] (==) FBDEV(0): RGB weight 888
[    55.412] (==) FBDEV(0): Default visual is TrueColor
[    55.412] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
[    55.412] (II) FBDEV(0): hardware: EFI VGA (video memory: 3072kB)
[    55.412] (DB) xf86MergeOutputClassOptions unsupported bus type 0
[    55.412] (II) FBDEV(0): checking modes against framebuffer device...
[    55.412] (II) FBDEV(0): checking modes against monitor...
[    55.412] (II) FBDEV(0): Virtual size is 1024x768 (pitch 1024)
[    55.412] (**) FBDEV(0):  Built-in mode "current": 78.7 MHz, 59.9 kHz, 75.7 Hz
[    55.412] (II) FBDEV(0): Modeline "current"x0.0   78.65  1024 1056 1184 1312  768 772 776 792 -hsync -vsync -csync (59.9 kHz b)
[    55.412] (==) FBDEV(0): DPI set to (96, 96)
[    55.412] (II) Loading sub module "fb"
[    55.412] (II) LoadModule: "fb"
[    55.413] (II) Loading /usr/lib/xorg/modules/libfb.so
[    55.414] (II) Module fb: vendor="X.Org Foundation"
[    55.414]  compiled for 1.20.11, module version = 1.0.0
[    55.414]  ABI class: X.Org ANSI C Emulation, version 0.4
[    55.414] (**) FBDEV(0): using shadow framebuffer
[    55.414] (II) Loading sub module "shadow"
[    55.414] (II) LoadModule: "shadow"
[    55.414] (II) Loading /usr/lib/xorg/modules/libshadow.so
[    55.414] (II) Module shadow: vendor="X.Org Foundation"
[    55.414]  compiled for 1.20.11, module version = 1.1.0
[    55.414]  ABI class: X.Org ANSI C Emulation, version 0.4
[    55.415] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by kernel - disabling)
[    55.417] (==) FBDEV(0): Backing store enabled
[    55.418] (==) FBDEV(0): DPMS enabled
[    55.418] (II) Initializing extension Generic Event Extension
[    55.419] (II) Initializing extension SHAPE
[    55.419] (II) Initializing extension MIT-SHM
[    55.419] (II) Initializing extension XInputExtension
[    55.420] (II) Initializing extension XTEST
[    55.420] (II) Initializing extension BIG-REQUESTS
[    55.420] (II) Initializing extension SYNC
[    55.421] (II) Initializing extension XKEYBOARD
[    55.421] (II) Initializing extension XC-MISC
[    55.421] (II) Initializing extension SECURITY
[    55.422] (II) Initializing extension XFIXES
[    55.422] (II) Initializing extension RENDER
[    55.422] (II) Initializing extension RANDR
[    55.423] (II) Initializing extension COMPOSITE
[    55.423] (II) Initializing extension DAMAGE
[    55.423] (II) Initializing extension MIT-SCREEN-SAVER
[    55.424] (II) Initializing extension DOUBLE-BUFFER
[    55.424] (II) Initializing extension RECORD
[    55.424] (II) Initializing extension DPMS
[    55.424] (II) Initializing extension Present
[    55.424] (II) Initializing extension DRI3
[    55.424] (II) Initializing extension X-Resource
[    55.425] (II) Initializing extension XVideo
[    55.425] (II) Initializing extension XVideo-MotionCompensation
[    55.425] (II) Initializing extension SELinux
[    55.425] (II) SELinux: Disabled on system
[    55.425] (II) Initializing extension GLX
[    55.425] (II) AIGLX: Screen 0 is not DRI2 capable
[    55.594] (II) IGLX: Loaded and initialized swrast
[    55.594] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[    55.594] (II) Initializing extension XFree86-VidModeExtension
[    55.594] (II) Initializing extension XFree86-DGA
[    55.594] (II) Initializing extension XFree86-DRI
[    55.595] (II) Initializing extension DRI2
 



ceci , en mode auto sans /etc/X11/xorg.conf le système tente de charger divers modules


[    55.267] (==) Matched nouveau as autoconfigured driver 0
[    55.267] (==) Matched nv as autoconfigured driver 1
[    55.267] (==) Matched modesetting as autoconfigured driver 2
[    55.267] (==) Matched fbdev as autoconfigured driver 3
[    55.267] (==) Matched vesa as autoconfigured driver 4
[    55.267] (==) Assigned the driver to the xf86ConfigLayout
[    55.267] (II) LoadModule: "nouveau"
 



ceci avec une installation EFI (secure-boot désactiver)


[    55.412] vesa: Refusing to run on UEFI
 



mon bureau est en mode dégrader , mais je peu bosser
le test => menu grub => touche e , => ajouter l'option nomodeset => F10 => mdp root => blabla maintenance => ctrl + d => invite de connexion => bureau


la commande du noyau (en début du log )


[    55.123] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.10.0-8-amd64
root=UUID=dd6b9f3e-45f1-4071-99a2-4d5a7d2a256c ro nomodeset single
 



donc pour moi tout est lier , la perte de l'écran en recovery et la perte de X avec nomodeset
ton installation "et ou" ton gpu pose problème

ma carte graphique (matériel ) est bien la


[    55.137] (--) PCI:*(1@0:0:0) 10de:1381:1462:8a9c rev 162, Mem @ 0xfd000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/131072
 



toi elle disparait avec "nomodeset" , je parle du matériel détecter par le noyau

=> https://fr.wikipedia.org/wiki/Framebuffer_Linux

=> https://packages.debian.org/fr/buster/x … ideo-fbdev

je pense que ta carte est compatible avec fbdev  =>  https://www.x.org/releases/current/doc/ … ev.4.xhtml

sur ma machine le paquet


apt policy xserver-xorg-video-fbdev
 



xserver-xorg-video-fbdev:
  Installé : 1:0.5.0-1
  Candidat : 1:0.5.0-1
 Table de version :
 *** 1:0.5.0-1 500
        500 http://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
 



voila je peu rien de plus pour toi , et je n'ai pas de carte graphique comme la tienne pour test

ps : pour le fun j'ai rajouter les fonts (xfonts) en cour de test , mais il s'agit bien de la même machine  wink


[    55.133] (==) FontPath set to:
  /usr/share/fonts/X11/misc,
  /usr/share/fonts/X11/cyrillic,
  /usr/share/fonts/X11/100dpi/:unscaled,
  /usr/share/fonts/X11/75dpi/:unscaled,
  /usr/share/fonts/X11/Type1,
  /usr/share/fonts/X11/100dpi,
  /usr/share/fonts/X11/75dpi,
 

Dernière modification par robert2a (26-07-2021 19:58:04)

Hors ligne

#27 27-07-2021 10:30:48

phlinux
Membre
Distrib. : Buster
Noyau : 4.19
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : nomodeset uniquement en mode recovery

Merci pour toutes ces info. Je vais étudier tout ça.
Par contre qu'il y ait un problème d'installation est peu probable. Avec la carte précédente ati9250 et le driver radeon pas de souci du recovery (en même temps je ne l'utilise que très rarement, signe de pas si mauvaise "santé" que ça).
Je vois aussi que tu es sous kernel 5.10.0-8-amd64 (je ne l'installe pas car aux premiers essais il inversait sr0 et sr1!!!!). Mais c'est peut être une donnée à prendre en compte
Enfin, pas de xorg.conf c'est bien, mais pour l'instant ça fonctionne pas sur ma bécane (voir le retour du #21). A ce propos

ls -l /usr/lib/xorg/modules/drivers/

-rw-r--r-- 1 root root  22444 juin   7  2018 fbdev_drv.so
-rw-r--r-- 1 root root 117484 avril 19 11:34 modesetting_drv.so
-rw-r--r-- 1 root root 235368 janv. 31  2019 nouveau_drv.so
-rw-r--r-- 1 root root  34716 août  18  2018 vesa_drv.so


@ tob


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#28 27-07-2021 12:31:07

robert2a
Membre
Inscription : 15-11-2014

Re : nomodeset uniquement en mode recovery

Bonjour
pour les modules a priori c'est correct
la carte est de 2006 environ en agp
mon matériel le plus ancien environ 2012 et en PCIe ne correspond pas trop a ta configuration
toutes mes machines sont en EFI (gpt)
ta remarque a propos de "ati 9250" ou tout est correct
pour le noyau , toutes mes machines sont en bullseye (testing) , aucun intérêt pour de toi de mettre un noyau trop récent .
pour le bi-écran en mode étendu ça devrait fonctionner
la prise charge de gpu amd (ati) est meilleure que pour nvidia avec nouveau
ps: hier un freeze avec nouveau sur la machine de test et la gtx750 , c'est pour cela que j'utilise toujours le driver propriétaire qu'il va falloir que je remette
pas ce genre de souci avec le driver libre amd

Hors ligne

#29 27-07-2021 13:08:51

phlinux
Membre
Distrib. : Buster
Noyau : 4.19
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : nomodeset uniquement en mode recovery

Une p'tite question : quand le driver du kernel, donc modesetting si j'ai bien compris, gère correctement la carte graphique, donc pas de driver X, et qu'il n'y a pas de xorg.conf, est-ce qu'il y a du paramétrage à effectuer ? et si oui où ?

Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#30 27-07-2021 15:31:19

robert2a
Membre
Inscription : 15-11-2014

Re : nomodeset uniquement en mode recovery

re,
rien a faire en mode auto par défaut de debian
vérifier si besoin d un firmware nonfree
par exemple avec


journalctl -r -p err
 


pour amd conseiller d'avoir KMS = kernel modeseting et le paquet xserver-xorg-video-amdgpu , ati et radeon
pour intel , sauf gpu très ancien (avant 1987 environ ) juste KMS (le paquet xserver-xorg-video-intel inutile )
pour nvidia , nouveau a souvent des soucis (par le noyau ou par le paquet xserver-xorg-video-nouveau ) , une alternative le driver propriétaire nvidia

pour le firmware , firmware-misc-nonfree pour intel et nvidia ( DRM du gpu)
firmware-amd-graphics pour amd (idem DRM du gpu)

par expérience , a part le firmware nonfree , besoin de rien faire sur une installation neuve de debian
debian supporte tous les matériels du moment qu'ils ne sont pas trop récent.
ps: seul les firmwares posent problème et parfois leur absence provoque un écran noir ou un freeze du système

attention si tu utilise X , le driver donc est présent (noyau ou paquet de X.)
juste que le noyau initialise le gpu a son chargement en mémoire (avec le driver vidéo)
alors que X l'initialise a l'invite de connexion (avec son driver vidéo)

ps: il est même possible d'avoir le driver du gpu avant le chargement du noyau mais jamais fait
donc ta remarque ci dessous pas correcte


donc pas de driver X
 


il n'y a que wayland (remplace X ) qui a un fonctionnement  différent  =>  https://fr.wikipedia.org/wiki/Wayland
mais c'est hors sujet ici   smile

Dernière modification par robert2a (27-07-2021 15:42:00)

Hors ligne

Pied de page des forums