Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 03-08-2022 00:01:58

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] VirtualBox bug avec le Kernel 5.10.0-15

totoZero7 a écrit :

Si j'utilise le noyau linux version 16 avec le paquet headers version 16 mais que VirtualBox ait besoin des modules du headers de la version 14 pour fonctionner correctement, et que ce headers version 14 est installé et marqué sur mon pc. Est-ce que VirtualBox utilisera ce headers version 14 avec le noyau 16 ?


Non. Il utilisera les headers v14 pour compiler les modules pour le noyau v14, les headers v16 pour compiler les modules pour le noyau v16 (si compatible)...

totoZero7 a écrit :

Ou est-ce que chaque headers n'est compatible qu'avec leur même version de noyau ?


Oui. On ne peut pas charger un module compilé pour une version/variante de noyau différente de celle du noyau actif. (on peut essayer de forcer, mais ça risque de mal se passer)

totoZero7 a écrit :

Dit autrement, est-ce qu'on peut cumuler différentes versions headers avec un seul noyau ?


La question n'est pas claire. Tu peux installer autant de versions de headers que tu veux et compiler un module pour autant de versions de noyau que tu veux, mais un module compilé pour une version du noyau n'est compatible qu'avec celle-ci.


Il vaut mieux montrer que raconter.

Hors ligne

#27 03-08-2022 19:42:52

totoZero7
Membre
Distrib. : Debian 11 bullseye
Noyau : 5.10.0-16-amd64
(G)UI : Mate 1.24.1
Inscription : 05-07-2020

Re : [résolu] VirtualBox bug avec le Kernel 5.10.0-15

Je viens de constater que les paquets linux-image + linux-headers font ~300Mo ensemble. Il faut donc en ternir compte sinon ça peut vite manger de la place.

Encore merci pour raleur pour ces explications.

Hors ligne

Pied de page des forums