Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#51 29-07-2022 13:48:52

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

raleur a écrit :

D777 a écrit :

Peut-être ouvrir le fichier "statoverride" et le lobotomiser ?


Il y a une méthode plus civilisée : la commande dpkg-statoverride. Consulter sa page de manuel pour les détails.

D777 a écrit :

adduser clamav


clamav devrait être créé comme un utilisateur système avec création du groupe système correspondant, et non comme un utilisateur normal. Consulter la page de manuel d'adduser pour les détails.




Salut Râleur,

root@debian:~# dpkg-statoverride


dpkg-statoverride: erreur: requiert une option d'action

Utiliser --help pour de l'aide sur la façon de ne pas tenir compte des informations relatives au fichier (« file stat information »).
 

Hors ligne

#52 29-07-2022 13:51:57

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Tawal a écrit :

Oui, je pense que tu peux supprimer ce groupe.
Mais je doute que ça résolve ton problème.



Salut Tawal,

root@debian:~# delgroup clamsmtp


/usr/sbin/delgroup: « clamsmtp » possèdent toujours « clamsmtp » en tant que groupe primaire !
 

Hors ligne

#53 29-07-2022 13:53:52

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Je tente :

adduser dom clamsmtp



bof ?

Hors ligne

#54 29-07-2022 16:01:38

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Je tente :

adduser dom clamsmtp



et alors ? l'ordinateur a implosé ?

Hors ligne

#55 29-07-2022 16:11:08

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

ubub a écrit :

Je tente :

adduser dom clamsmtp



et alors ? l'ordinateur a implosé ?



ah non je n'ai pas tenté sans l'avis d'un toubib big_smile

Hors ligne

#56 29-07-2022 16:53:36

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

root@debian:~# adduser dom clamsmtp


Ajout de l'utilisateur « dom » au groupe « clamsmtp »...
Adding user dom to group clamsmtp
Fait.
 


Maintenant je redémarre la bécane et  je vais essayer de refaire les màj via synaptic et le terminal.

Dernière modification par D777 (29-07-2022 16:54:18)

Hors ligne

#57 29-07-2022 17:08:29

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Same same !

root@debian:~# apt-get upgrade



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  libreoffice-sdbc-firebird linux-headers-686-pae linux-image-686-pae
Les paquets suivants seront mis à jour :
  avahi-daemon libavahi-client3 libavahi-common-data libavahi-common3
  libavahi-core7 libavahi-glib1 libavahi-gobject0 libavahi-ui-gtk3-0
  libdbi-perl libglib2.0-0 libglib2.0-bin libglib2.0-data libglib2.0-dev
  libjpeg62-turbo libnss-myhostname libntfs-3g871 libpam-systemd libpurple-bin
  libpurple0 libsndfile1 libsystemd0 libudev1 libvlc-bin libvlc5 libvlccore9
  linux-kbuild-4.9 ntfs-3g pidgin-data systemd systemd-sysv tzdata udev
  vim-common vim-tiny vlc vlc-bin vlc-data vlc-l10n vlc-plugin-base
  vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba vlc-plugin-skins2
  vlc-plugin-video-output vlc-plugin-video-splitter vlc-plugin-visualization
  xxd
47 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
Il est nécessaire de prendre 0 o/37,7 Mo dans les archives.
Après cette opération, 694 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
Lecture des fichiers de modifications (« changelog »)... Terminé
Extraction des modèles depuis les paquets : 100%
Préconfiguration des paquets...
dpkg: unrecoverable fatal error, aborting:
 utilisateur « clamav » inconnu dans le fichier des permissions (« statoverride »)
localepurge: Disk space freed in /usr/share/locale: 0 KiB
localepurge: Disk space freed in /usr/share/man: 0 KiB
localepurge: Disk space freed in /usr/share/gnome/help: 0 KiB
localepurge: Disk space freed in /usr/share/omf: 0 KiB
localepurge: Disk space freed in /usr/share/doc/kde/HTML: 0 KiB

Total disk space freed by localepurge: 0 KiB

E: Sub-process /usr/bin/dpkg returned an error code (2)

 



Le "update" semble se faire...

root@debian:~# apt-get update



Ign:1 http://ftp.fr.debian.org/debian stretch InRelease
Atteint:2 http://security.debian.org stretch/updates InRelease                
Ign:3 http://deb.debian.org/debian stretch InRelease                          
Atteint:4 http://ftp.fr.debian.org/debian stretch Release                      
Atteint:5 http://deb.playonlinux.com stretch InRelease                        
Atteint:6 http://deb.debian.org/debian stretch-updates InRelease              
Ign:7 http://ftp.de.debian.org/debian stretch InRelease                        
Atteint:8 http://deb.debian.org/debian stretch-backports InRelease            
Atteint:9 http://deb.debian.org/debian stretch Release                        
Atteint:10 http://ftp.de.debian.org/debian stretch Release                    
Atteint:11 https://deb.nodesource.com/node_11.x stretch InRelease              
Lecture des listes de paquets... Fait

 

Dernière modification par D777 (29-07-2022 17:13:09)

Hors ligne

#58 29-07-2022 17:14:23

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Via Synaptic toujours le même message d'erreur.

Gtk-Message **: Failed to load module "canberra-gtk-module" at /usr/lib/i386-linux-gnu/perl5/5.24/Gtk2.pm line 126, <> line 52.
Gtk-Message **: Failed to load module "canberra-gtk-module" at /usr/lib/i386-linux-gnu/perl5/5.24/Gtk2.pm line 126, <> line 52.
Extraction des modèles depuis les paquets : 100%
Préconfiguration des paquets...
dpkg: unrecoverable fatal error, aborting:
utilisateur « clamav » inconnu dans le fichier des permissions (« statoverride »)
localepurge: Disk space freed in /usr/share/locale: 0 KiB
localepurge: Disk space freed in /usr/share/man: 0 KiB
localepurge: Disk space freed in /usr/share/gnome/help: 0 KiB
localepurge: Disk space freed in /usr/share/omf: 0 KiB
localepurge: Disk space freed in /usr/share/doc/kde/HTML: 0 KiB

Total disk space freed by localepurge: 0 KiB

E: Sub-process /usr/bin/dpkg returned an error code (2)
Échec de l'installation d'un paquet. Tentative de récupération :

Hors ligne

#59 29-07-2022 17:16:39

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

via Synaptic je tente de "supprimer pour réinstallation" le paquet dpkg

Hors ligne

#60 29-07-2022 17:17:33

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Résultat ...même message d'erreur !!!!

Gtk-Message **: Failed to load module "canberra-gtk-module" at /usr/lib/i386-linux-gnu/perl5/5.24/Gtk2.pm line 126, <> line 53.
Gtk-Message **: Failed to load module "canberra-gtk-module" at /usr/lib/i386-linux-gnu/perl5/5.24/Gtk2.pm line 126, <> line 53.
Extraction des modèles depuis les paquets : 100%
Préconfiguration des paquets...
dpkg: unrecoverable fatal error, aborting:
utilisateur « clamav » inconnu dans le fichier des permissions (« statoverride »)
localepurge: Disk space freed in /usr/share/locale: 0 KiB
localepurge: Disk space freed in /usr/share/man: 0 KiB
localepurge: Disk space freed in /usr/share/gnome/help: 0 KiB
localepurge: Disk space freed in /usr/share/omf: 0 KiB
localepurge: Disk space freed in /usr/share/doc/kde/HTML: 0 KiB

Total disk space freed by localepurge: 0 KiB

E: Sub-process /usr/bin/dpkg returned an error code (2)
Échec de l'installation d'un paquet. Tentative de récupération :

Hors ligne

#61 29-07-2022 17:18:17

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

non ... dpkg n'a rien à voir avec ton problème ...
(trop tard ...)

Dernière modification par ubub (29-07-2022 17:19:29)

Hors ligne

#62 29-07-2022 17:19:32

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

ubub a écrit :

non ... dpkg n'a rien à voir avec ton problème ...



j’essaie ce que je peux faire ;-)

Hors ligne

#63 29-07-2022 17:21:27

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

t'as essayé adduser dom clammachin ?
ca me semblait une meilleure idée ...

Hors ligne

#64 29-07-2022 17:24:02

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

D777 a écrit :

root@debian:~# adduser dom clamsmtp


Ajout de l'utilisateur « dom » au groupe « clamsmtp »...
Adding user dom to group clamsmtp
Fait.
 


Maintenant je redémarre la bécane et  je vais essayer de refaire les màj via synaptic et le terminal.



Ubub regarde soit disant le user "dom" est créé dans le groupe "clamsmtp" , mais bon voilà après les màj ne se font toujours pas.
J'ai redémarré ma bécane avant.

Hors ligne

#65 29-07-2022 17:26:00

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

j'ai trouvé le paquet "clamsmtp" dans Synaptic mais il n'est pas installé (case à cocher blanche)....

Hors ligne

#66 29-07-2022 17:28:00

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

j'ai essayé de le supprimer complètement (via Synaptic tjrs), la bécane fait le job et puis le même message d'erreur :

Gtk-Message **: Failed to load module "canberra-gtk-module" at /usr/lib/i386-linux-gnu/perl5/5.24/Gtk2.pm line 126, <> line 52.
Gtk-Message **: Failed to load module "canberra-gtk-module" at /usr/lib/i386-linux-gnu/perl5/5.24/Gtk2.pm line 126, <> line 52.
Extraction des modèles depuis les paquets : 100%
Préconfiguration des paquets...
dpkg: unrecoverable fatal error, aborting:
utilisateur « clamav » inconnu dans le fichier des permissions (« statoverride »)
localepurge: Disk space freed in /usr/share/locale: 0 KiB
localepurge: Disk space freed in /usr/share/man: 0 KiB
localepurge: Disk space freed in /usr/share/gnome/help: 0 KiB
localepurge: Disk space freed in /usr/share/omf: 0 KiB
localepurge: Disk space freed in /usr/share/doc/kde/HTML: 0 KiB

Total disk space freed by localepurge: 0 KiB

E: Sub-process /usr/bin/dpkg returned an error code (2)
Échec de l'installation d'un paquet. Tentative de récupération :

Hors ligne

#67 29-07-2022 17:39:47

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Le message d’erreur est plutôt clair :

utilisateur « clamav » inconnu dans le fichier des permissions (« statoverride »)


Le fichier /var/lib/dpkg/statoverride contient des mentions d’un utilisateur "clamav" qui n’existe pas sur le système, probablement à cause d’une désinstallation partielle de ClamAV. Il suffit de retirer de ce fichier les lignes commençant par "clamav", sans toucher aux autres, pour corriger cette erreur.

N‘utilisant ni Debian Stretch, ni ClamAV, je ne saurais pas dire ce qui a permis à ces lignes de subsister lors de la désinstallation du paquet clamav. Probablement une mauvaise manipulation de l’admin du système, ou un bug dans le paquet.

---

Comme précisé par raleur, ce serait plus propre de passer par la commande dpkg-statoverride plutôt que d’éditer directement le fichier.


Jouer sous Debian ? Facile !

Hors ligne

#68 29-07-2022 17:42:46

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

vv222 a écrit :

Le message d’erreur est plutôt clair :

utilisateur « clamav » inconnu dans le fichier des permissions (« statoverride »)


Le fichier /var/lib/dpkg/statoverride contient des mentions d’un utilisateur "clamav" qui n’existe pas sur le système, probablement à cause d’une désinstallation partielle de ClamAV. Il suffit de retirer de ce fichier les lignes commençant par "clamav", sans toucher aux autres, pour corriger cette erreur.

N‘utilisant ni Debian Stretch, ni ClamAV, je ne saurais pas dire ce qui a permis à ces lignes de subsister lors de la désinstallation du paquet clamav. Probablement une mauvaise manipulation de l’admin du système, ou un bug dans le paquet.



Salut w222 !

Ok je regarde pour ouvrir le fichier et supprimer ce qui commence par "clamav" uniquement.

C'est l'admin probablement !

Hors ligne

#69 29-07-2022 17:49:41

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

J'ai trouvé ce lien, je cherche doucement mais sûrement....

https://debian-facile.org/doc:systeme:commandes:creer

root@debian:~# locate statoverride



/root/statoverride.save
/usr/bin/dpkg-statoverride
/usr/share/man/fr/man1/dpkg-statoverride.1.gz
/usr/share/man/man1/dpkg-statoverride.1.gz
/var/backups/dpkg.statoverride.0
/var/backups/dpkg.statoverride.1.gz
/var/backups/dpkg.statoverride.2.gz
/var/backups/dpkg.statoverride.3.gz
/var/backups/dpkg.statoverride.4.gz
/var/backups/dpkg.statoverride.5.gz
/var/backups/dpkg.statoverride.6.gz
/var/lib/dpkg/statoverride
/var/lib/dpkg/statoverride-old

 

Hors ligne

#70 29-07-2022 17:53:37

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

root@debian:~# cat /var/lib/dpkg/statoverride




geoclue geoclue 755 /var/lib/geoclue
root lp 775 /var/log/hp/tmp
clamav clamav 700 /var/lib/clamav-unofficial-sigs/gpg-key
clamav clamav 755 /var/cache/clamav-unofficial-sigs/si-dbs
root crontab 2755 /usr/bin/crontab
root Debian-exim 640 /etc/exim4/passwd.client
root mlocate 2755 /usr/bin/mlocate
root root 1733 /var/lib/php/sessions
root ssl-cert 710 /etc/ssl/private
clamav clamav 755 /var/cache/clamav-unofficial-sigs/add-dbs
clamav clamav 755 /var/cache/clamav-unofficial-sigs/ss-dbs
hplip root 755 /var/run/hplip
root messagebus 4754 /usr/lib/dbus-1.0/dbus-daemon-launch-helper
clamav clamav 755 /var/cache/clamav-unofficial-sigs/msrbl-dbs
clamav clamav 755 /var/lib/clamav-unofficial-sigs/configs
clamav clamav 755 /var/cache/clamav-unofficial-sigs/mbl-dbs
root root 4755 /usr/lib/spice-gtk/spice-client-glib-usb-acl-helper
 



je vais chercher comment ouvrir le fichier statoverride maintenant

Hors ligne

#71 29-07-2022 17:58:36

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

t'avais pas réussi jadis (hier?) avec nano ?

Hors ligne

#72 29-07-2022 17:59:14

Tawal
Membre
Distrib. : Debian Stable à jour
Noyau : amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Hello,

Pour supprimer les lignes concernant clamav :

sed -i '/^clamav/d' /var/lib/dpkg/statoverride


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

En ligne

#73 29-07-2022 18:03:28

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Il vaudrait mieux passer par les outils dédiés. Par exemple pour retirer cette ligne :

clamav clamav 700 /var/lib/clamav-unofficial-sigs/gpg-key

de ce que je comprends du manuel la commande à utiliser serait :

dpkg-statoverride --remove /var/lib/clamav-unofficial-sigs/gpg-key



Le manuel de dpkg-statoverride est très court et en français, donc ce n‘est pas bien compliqué de comprendre comment s’en servir.


Jouer sous Debian ? Facile !

Hors ligne

#74 29-07-2022 18:19:28

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

ubub a écrit :

t'avais pas réussi jadis (hier?) avec nano ?



nop !

j'ai un éditeur de texte mais je l'ouvre et puis voilà.....je ne sais pas comment ouvrir un fichier directement dans un logiciel avec lequel je pourrais supprimer des lignes.

je cherche sur le cahier du débutant mais pas de commande pour faire cette manip pour l'instant.

Hors ligne

#75 29-07-2022 18:24:13

D777
Membre
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux debian 4.19.0-21-686-pae
(G)UI : LXDE (en test)
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

J'ai trouvé cette commande


root@debian:~# ls -l /var/lib/dpkg/statoverride


-rw-r--r-- 1 root root 831 mars  10 11:35 /var/lib/dpkg/statoverride

 

Hors ligne

Pied de page des forums