Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 Re : Matériel » Problème clé USB avec VirtualBox ou VMware sous Bullseye » 23-09-2022 17:33:35

Croutons a écrit :

Ce que tu peux faire , mais c'est pas propre
c'est monté ta clé sous Debian et partagé le point de montage sur ta VM, après ils faut voir comment se comporte la VM quand la clé n'est pas connecté vu que le répertoire est créé a la volé sous media , a moins que ce soit toi qui définisse le point de montage



Aarrrgh ! J'ai essayé de la mettre en dossier partagé. Cela fonctionne mais si j'éteins mon Windows ou si je débranche la clé cela ne fonctionne plus.
Tout à refaire à chaque fois.

Je crois que la Bullseye capture la clé dès que je la branche et ne veut pas la laisser. Même umount ne marche pas.

Il n'y a que avec "fuser -kimuv /media/disk" que cela fonctionne.
Mais bon, cela dépasse mes compétences pour comprendre.

#2 Re : Matériel » Problème clé USB avec VirtualBox ou VMware sous Bullseye » 23-09-2022 14:12:15

Croutons a écrit :

même si ta clé était monté sur ta Debian elle est automatiquement démonté et rendu disponible exclusivement pour ta VM et plus accessible par Debian tant que la clé est coché dans la barre d'état de virtualbox
https://i.imgur.com/2IedwN4.png


puis coché la clé usb ( attention a ne pas coché le clavier ou la souris big_smile )
https://debian-facile.org/images/file-R … 1ea620fa84



Cela, je l'ai fait des dizaines de fois dans VirtualBox. Cocher, décocher, redémarrer.... Toujours le même problème.
Dans les menus XFCE la clé était démontée. Pareil.

Mais quand je testais en ligne de commande dans Debian j'avais toujours la réponse : clé active.
Et avec ma dernière trouvaille, fuser, là ça marche. Ce n'est pas pratique.

#3 Re : Matériel » Problème clé USB avec VirtualBox ou VMware sous Bullseye » 23-09-2022 10:48:15

Bon, j'ai trouvé comment avoir ma clé mais j'aimerais trouver un truc plus pratique.

Je mets ma clé, sous Debian. La VM et Virtualbox éteints.
Je fais un fuser -kimuv /media/disk dans un terminal.
Je lance VirtualBox et mon Windows. Il installe la clé et ça marche.
On dirait que dès qu’elle est branchée, même non montée, Debian ne veut pas la lâcher.
J'utilise XFCE et le montage automatique n'est pas coché.

#5 Re : Matériel » Problème clé USB avec VirtualBox ou VMware sous Bullseye » 22-09-2022 13:45:39

Croutons a écrit :

laverdarie a écrit :

je les vois dans les périphériques mais la coche n'apparait pas au clic.


tu veux dire quand tu fais un clique droite sur l’icône de clé usb dans la barre d'état de Virtualbox?
Edit: ce que tu pourrais testé c'est sur une VM Debian voir si tu as aussi le soucis , si c'est pas le cas on est sur que sa bloque seulement avec Windows 7
j'ai pas de VM en win7 mais sous winxp aucun problème chez moi



Oui. Du coup je vais installer une VM XP.

#6 Re : Matériel » Problème clé USB avec VirtualBox ou VMware sous Bullseye » 22-09-2022 11:01:48

Croutons a écrit :

tu as bien un contrôleur usb dans les paramètres de ta VM ? je suppose que oui sinon tu ne verrais même pas le clé sous virtualbox
Oracle VM Extention Pack doit bien correspondre avec ta version de Virtualbox installé, l'extention pack s'installe sur le systeme hote (ta Debian)
alors que les additions invités s'installe sur le système invités , d'ailleurs tu dois le voir dans la barre des taches de Windows
est ce que c'est tout bon?
sinon je vois pas trop ce qui pourrait bloquer , a part certaine clé usb qui on besoin d'un pilote particulier et la Windows a besoin d'une connexion internet, j'ai déja eu le cas sur une de mes clé
est ce que c'est un message de Windows ou un message de Virtualbox?
a noté que une clé usb ne sera pas opérationnel sans être coché dans le menu au niveau de la barre d'état de Virtualbox, dans ce menu tu vois tout les périphériques connecté a ton ordi , la souris et le clavier ne sont pas cochés car il sont capturés , ce qui permet de les utiliser sur le système hôte et le système invités en même temps

vérifier aussi que les modules pour Virtualbox sont bien actif

lsmod|grep vbox


vboxnetadp             28672  0
vboxnetflt             32768  0
vboxdrv               573440  3 vboxnetadp,vboxnetflt



Alors, pour l'extension_pack c'est bien la version 6.1.38 qui correspond à la version VirtualBox que j'ai d'ailleurs installée avec Synaptic.
Pour les additions je l'installe bien depuis Windows. Je vois les drivers qui s'installent.
Pour les clés (j'ai essayé avec 3 marques différentes) je les vois dans les périphériques mais la coche n'apparait pas au clic.
Et l'échec de la connexion c'est bien un message Windows 7.
Pour les modules c'est bien ce que tu as affiché, tout pareil.
Mystère ! Mais c'est pareil avec VMware à la place de VirtualBox.

#7 Re : Matériel » Problème clé USB avec VirtualBox ou VMware sous Bullseye » 22-09-2022 10:24:13

Croutons a écrit :

Hello
Il faut être  précis et pour faire avancer les choses
Sur ton système hote Debian qu'est ce que te renvoie la commande suivante

id


vérifie que tu fasses bien partie du groupe vboxusers
si ce n'est pas le cas il faudra ajouter ton utilisateur Debian au groupe

usermod -G vboxusers -a ton_nom_d'utilisateur


il te faut aussi t'assurer que ta clé ne soit pas montée en automatique sous Debian, une clé déjà monté ne sera plus accessible dans une VM , voir ce que te renvoie

findmnt


attention toutefois a ne pas éjecter la clé , utiliser la commande umount
idem une clé en fonction dans une VM ne sera plus disponible pour le système hôte, pour la rendre de nouveau disponible il faudra décocher la clé dans le menu contextuel de ta VM (clique droite sur l’icône en forme de cle USB sur la barre d'état de  Virtualbox)



Bonjour,
Déjà, merci beaucoup de t'intéresser à mon problème !
Sous Debian, j'utilise XFCE. Dans les paramètres, le montage automatique n'est pas activé. Donc quand je mets une clé sous Debian, l'icône apparait sur le bureau et soit je fais un clic droit dessus pour la monter soit un double clic.
J'ai fait ceci : mis une clé sous Debian, montée puis démontée. Je l'ai laissée en place et lancé VirtualBox puis Windows.
Windows trouve la clé et affiche "Echec de la connexion USB du périphérique à la machine virtuelle."

Pour le groupe vboxusers, je l'avais fait. C'est dans les premières solutions que j'avais testées.

Pour les commandes id et findmnt, voila :

id
uid=1000(michel) gid=1000(michel) groupes=1000(michel),24(cdrom),25(floppy),27(sudo),29(audio),30(dip),44(video),46(plugdev),108(netdev),115(lpadmin),118(scanner),122(vboxusers)

findmnt
TARGET                        SOURCE         FSTYPE   OPTIONS
/                             /dev/nvme0n1p2 ext4     rw,relatime,errors=remount-ro
├─/sys                        sysfs          sysfs    rw,nosuid,nodev,noexec,relatime
│ ├─/sys/kernel/security      securityfs     security rw,nosuid,nodev,noexec,relatime
│ ├─/sys/fs/cgroup            cgroup2        cgroup2  rw,nosuid,nodev,noexec,relatime,nsdele
│ ├─/sys/fs/pstore            pstore         pstore   rw,nosuid,nodev,noexec,relatime
│ ├─/sys/firmware/efi/efivars efivarfs       efivarfs rw,nosuid,nodev,noexec,relatime
│ ├─/sys/fs/bpf               none           bpf      rw,nosuid,nodev,noexec,relatime,mode=7
│ ├─/sys/kernel/debug         debugfs        debugfs  rw,nosuid,nodev,noexec,relatime
│ ├─/sys/kernel/tracing       tracefs        tracefs  rw,nosuid,nodev,noexec,relatime
│ ├─/sys/kernel/config        configfs       configfs rw,nosuid,nodev,noexec,relatime
│ └─/sys/fs/fuse/connections  fusectl        fusectl  rw,nosuid,nodev,noexec,relatime
├─/proc                       proc           proc     rw,nosuid,nodev,noexec,relatime
│ └─/proc/sys/fs/binfmt_misc  systemd-1      autofs   rw,relatime,fd=29,pgrp=1,timeout=0,min
├─/dev                        udev           devtmpfs rw,nosuid,relatime,size=8120308k,nr_in
│ ├─/dev/pts                  devpts         devpts   rw,nosuid,noexec,relatime,gid=5,mode=6
│ ├─/dev/shm                  tmpfs          tmpfs    rw,nosuid,nodev
│ ├─/dev/mqueue               mqueue         mqueue   rw,nosuid,nodev,noexec,relatime
│ └─/dev/hugepages            hugetlbfs      hugetlbf rw,relatime,pagesize=2M
├─/run                        tmpfs          tmpfs    rw,nosuid,nodev,noexec,relatime,size=1
│ ├─/run/lock                 tmpfs          tmpfs    rw,nosuid,nodev,noexec,relatime,size=5
│ └─/run/user/1000            tmpfs          tmpfs    rw,nosuid,nodev,relatime,size=1635368k
└─/boot/efi                   /dev/nvme0n1p1 vfat     rw,relatime,fmask=0077,dmask=0077,code

#8 Re : Matériel » Problème clé USB avec VirtualBox ou VMware sous Bullseye » 21-09-2022 23:56:26

vincen a écrit :

Tu es sûr que le système hôte n'a pas un automount pour les périphériques amovibles ? ce qui le rendrait ensuite inaccessible pour ta VM et à fortiori pour le système invité !


Tu as peut-être trouvé le problème !
Quand la VM est active, si je branche la clé j'ai le message "Echec de la connexion du périphérique" mais si je vais voir dans Debian, avec le gestionnaire de fichiers elle est là !
J'ai essayé de la démonter et de l'éjecter. Elle disparait. Mais si je la rebranche, au lieu d'apparaître dans Windows elle apparaît dans Linux.
En fait je ne sais pas ce que je peux faire.

#9 Re : Matériel » Problème clé USB avec VirtualBox ou VMware sous Bullseye » 21-09-2022 20:19:35

vincen a écrit :

vincen a écrit :

As-tu installé l'extension dans Virtualbox pour le support USB ? Une fois la clé USB inséré dans l'ordi il te suffit dans les propriétés de la VM d'assigner la clé USB au système invité et il va apparaitre alors dans Windows sans soucis !


as-tu essayé ça ? cas c'est quasi sûr que c'est ça le problème ! Ta clé est formatée au moins dans un format lisible par le système Fenêtres ? lol



J'ai cherché des solutions et je les ai testées. L'installation de l'extension et ensuite la partie "additions". Je le fais les yeux fermés ! big_smile
Les clés fonctionnent ailleurs, j'en ai trois de différentes.
Je vois les clés dans les périphériques dans VirtualBox.
Quand je l'insère, sous Windows, le driver s'installe, j'ai le message "installation du périphérique" et puis il y a un message d'erreur.
Genre Echec de la connexion....
J'ai vérifié dans les périphériques Windows, tout a l'air normal.
C'est une panne vraiment spéciale. Je peux la reproduire si j'installe VMware Workstation qui est semblable à VirtualBox. Pareil.

#10 Re : Matériel » Problème clé USB avec VirtualBox ou VMware sous Bullseye » 21-09-2022 16:40:06

vincen a écrit :

As-tu installé l'extension dans Virtualbox pour le support USB ? Une fois la clé USB inséré dans l'ordi il te suffit dans les propriétés de la VM d'assigner la clé USB au système invité et il va apparaitre alors dans Windows sans soucis !


Sans souci ! big_smile
En fait je l'ai fait bien sûr. Dans les périphériques VirtualBox je vois la clé que j'ai branchée avec le nom.
C'est après, quand je la branche dans Windows, le driver s'installe ou commence, il y a le message et puis gnagnagna, clé non reconnue, échec de l'installation ou autre.
Dans VMware Workstation, analogue à VirtualBox j'en arrive à la même panne.

#11 Re : Matériel » Problème clé USB avec VirtualBox ou VMware sous Bullseye » 21-09-2022 16:37:06

Yanatoum a écrit :

Dans le menu 'périphériques' de la machine virtuelle, il faut utiliser 'insérer l'image CD des additions invité' et installer l'application dans win7.



J'ai fait ça plusieurs fois. Tout s'installe bien. C'est après le branchement de la clé, elle est reconnue, le driver commence à s'installer mais cela n'aboutit pas.

#12 Re : Matériel » Problème clé USB avec VirtualBox ou VMware sous Bullseye » 21-09-2022 16:35:30

Oula ! J'ai installé et réinstallé VirtualBox plus les extensions.
Ensuite j'ai installé dans Windows 7 le "Additions machin". Je vois les drivers qui s'installent bien...
C'est après, quand je branche la clé, j'ai le message habituel d'installation du driver mais à la fin j'ai le message "clé USB non reconnue" ou "driver non reconnu"
ou "échec de la connexion du périphérique USB"...
Et c'est pareil avec VMware au lieu de VirtualBox. Je choisis bien le USB 2.0 ou 3.1, j'ai tout essayé.
Mais c'est pareil, la clé est reconnue au branchement mais elle ne se monte pas.
Comme si quelque chose empêchait ça... j'ai même trouvé une "solution" dans la base de registres Windows que j'ai testée sans résultat.

#13 Matériel » Problème clé USB avec VirtualBox ou VMware sous Bullseye » 21-09-2022 11:44:19

laverdarie
Réponses : 23
Bonjour,
Après pas mal de recherches et d'installations de VirtulaBox ou de VMware sous Debian Bullseye j'arrive toujours au même problème :
Je mets Windows 7 dans la VM, le driver de la clé USB s'installe mais j'ai un message d'erreur genre "Echec de la connexion du périphérique USB
à la VM Windows."
"Failed to create à proxy device for the USB device."
Ou Echec de connexion de la clé USB.
Et la clé n'apparait pas dans Windows.
C'est pareil dans les deux systèmes VirualBox et VMware.
Si quelqu'un avait une piste.... Merci !

#14 Re : Installation de Debian » Dual boot Windows 10 - Bullseye raté à chaque fois. » 11-09-2022 18:19:17

VBrice a écrit :

Il m'est aussi arriver de galérer avec les disques lors de l'installation de windows.
Le plus simple et efficace consiste à débrancher tout les disques sauf celui de l'installation.



Oui, en effet. Parce que quand on est sûr de soi ce n'est jamais bon !

#15 Re : Installation de Debian » Dual boot Windows 10 - Bullseye raté à chaque fois. » 11-09-2022 14:25:09

raleur a écrit :

laverdarie a écrit :

J'ai fait la détection des disques pendant l'installation de Debian. Et je l'ai faite deux fois avec des résultats différends !


C'est-à-dire ?

laverdarie a écrit :

En fait malgré le choix du disque 1 pour installer Windows, celui-ci, subrepticement s'était installé sur le disque 2.


Quel rapport avec l'installateur Debian ?



1) Avec Graphic Expert, quand j'ai fait "Détecter les disques" le premier était vide et le second présentait les partitions Windows.
Je suis revenu en arrière et j'ai refait. Le premier contenait les partitions Windows et le second aussi.
J'ai donc effacé toutes les partitions et tout recommencé.

2) Windows s'installait sur le disque 2 alors que je choisissais le 1 (peut-être le NVMe ?).
L'installateur Debian, l'automatique, ne montre pas les partitions existantes mais celles qu'il propose sur le disque choisi. Alors on valide.
Du coup Debian s'installait sur Windows.

#16 Re : Installation de Debian » Dual boot Windows 10 - Bullseye raté à chaque fois. » 10-09-2022 20:04:43

Problème résolu bêtement. J'ai fait la détection des disques pendant l'installation de Debian. Et je l'ai faite deux fois avec des résultats différends !
En fait malgré le choix du disque 1 pour installer Windows, celui-ci, subrepticement s'était installé sur le disque 2.
Donc j'ai effacé toutes les partitions existantes à la main, j'ai installé Debian sur le disque 1 et c'est bon.
Après au moins dix essais. Merci pour vos réponses.

#17 Installation de Debian » Dual boot Windows 10 - Bullseye raté à chaque fois. » 10-09-2022 18:10:42

laverdarie
Réponses : 8
Bonjour à la noble assemblée. En tant que nouveau je suis poli...
J'ai une carte mère Gigabyte B550, un disque M2 NVMe, un disque M2 normal.
J'installe Windows sur le premier disque dur. Il s'installe bien. Je le vois dans le setup de la carte. Il démarre bien.
J'installe Debian, sur le deuxième disque, install normale ou expert, je vérifie que la partition EFS/EFI est bien là. L'installation se passe bien. Cela redémarre bien.
Mais dans le setup de la carte, soit Windows n'est plus là soit, s'il est là et il ne démarre plus et les options de réparation ne fonctionnent pas (bon, c'est normal).
Et le Grub ne propose pas Windows. Juste Debian.
Merci pour toute piste...

Pied de page des forums

Propulsé par FluxBB