Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 Téléphones, tablettes, raspberry et autres systèmes à poil ras » [OPENMEDIAVAULT]: Letsencrypt » 12-10-2019 22:47:24

spartiate
Réponses : 0
Hi!

J'ai installé un OMV toute fraîche, je commence donc pas l'installation d'un certificat ssl via letencrypt, comme déjà fait sur une autre machine sous Debian...

lors de la génération du certificatk j'obtiens cette erreur :

Command: export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; /usr/bin/certbot certonly --non-interactive --rsa-key-size 4096 --text --keep-until-expiring --agree-tos --allow-subset-of-names --cert-name /etc/letsencrypt/ --email spartiate@protonmail.com --webroot -w /var/www/openmediavault/ -d nas.leblais.net 2>&1

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for nas.leblais.net
Using the webroot path /var/www/openmediavault for all unmatched domains.
Waiting for verification...
Challenge failed for domain nas.leblais.net
Cleaning up challenges
Challenges failed for all domains
Terminé...



a priori, letsencrupt doit vérifier le port 80 mais celui est déjà utilisé pour un autre domaine de mon réseau sad

que faire donc svp ?

#2 KDE » konqueror: filtres AdBlock » 28-07-2019 12:49:48

spartiate
Réponses : 0
Hello,

sous konqueror 5.0.97, les filtres anti pubs AdBlock ne fonctionnent pas.

pourtant activé tous les filtres mais sans résultats, les pubs s'affichent toujours....

avez-vous le soucis chez vous ?

#3 Re : Réseau » [RESOLU] [NEXTCLOUD]: plus d'accès depuis MàJ Buster » 23-07-2019 16:51:40

sujet résolu!! j'ai écrit les commandes dans le lien ci dessus

#4 Re : Réseau » [RESOLU] [NEXTCLOUD]: plus d'accès depuis MàJ Buster » 23-07-2019 15:59:53

d'après le topic que j'ai ouvert ici https://help.nextcloud.com/t/nextcloud- … 0/56987/10 on me propose cette solution :

Tu étais sur une Debian 9, avec donc PHP 7.0
    Tu passes maintenant sur Debian 10, avec PHP 7.3
    Le paquet php-apcu est donc maintenant celui de PHP 7.3
    Cependant ton Nextcloud utilise toujours ton PHP 7.0, et c’est ça qu’il faut changer :smile:

La solution à ton problème sera donc probablement :

    Changement de config Apache pour utiliser le module php 7.3
    Redémarrage Apache
    Désinstallation de PHP 7.0



comment procéder concrètement d'après vous ?

initialement, j'avais suivi le tuto nextcloud sur debian-facile mais en parcourant ce tuto, je ne trouve  pas de réponses.

#5 Re : Le bar » Vos screenshots!! » 19-07-2019 17:34:44

Fall66 a écrit :



quel est l'outil pour afficher toutes ces informations dans un terminal stp ?

#6 Réseau » [RESOLU] [NEXTCLOUD]: plus d'accès depuis MàJ Buster » 19-07-2019 17:25:58

spartiate
Réponses : 2
Bonjour,

J'ai migré mon "p'tit serveur maison" de stretch vers buster et, depuis, nextcloud n'est plus accessible:

https://cloud.leblais.net/ donne :

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.



Du coup, je me pose la question d'un soucis avec php....

Je ne sais pas où chercher, j'ai regardé un peu partout sur la toile mais pas de problèmes similaires au mien.

Globalement, j'ai accès à phpMyAdmin sur https://madb.leblais.net/, j'ai créé un petit

test.php

qui donne donc https://leblais.net/test.php

L'accès à la console de MariaDB fonctionne aussi

14:44 root@matrix /home/neo# mariadb -v
Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 896
Server version: 10.3.15-MariaDB-1 Debian 10

Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Reading history-file /root/.mysql_history
Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]>
 



Qu'est ce qui peut clocher selon vous ?

Merci pour votre aide

#7 Re : Matériel » [Résolu]Encore la clé wifi Realtek RTL8192EU... » 19-07-2019 17:18:50

avec le log en question :

1 DKMS make.log for rtl8192eu-1.0 for kernel 4.19.0-5-amd64 (x86_64)
  2 vendredi 19 juillet 2019, 18:12:08 (UTC+0200)
  3 make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.19.0-5-amd64/build M=/var/lib/dkms/rtl8192eu/1.0/build  modules
  4 make[1] : on entre dans le répertoire « /usr/src/linux-headers-4.19.0-5-amd64 »
  5   CC [M]  /var/lib/dkms/rtl8192eu/1.0/build/core/rtw_cmd.o
  6 In file included from /var/lib/dkms/rtl8192eu/1.0/build/include/osdep_service.h:45,
  7                  from /var/lib/dkms/rtl8192eu/1.0/build/include/drv_types.h:32,
  8                  from /var/lib/dkms/rtl8192eu/1.0/build/core/rtw_cmd.c:22:
  9 /var/lib/dkms/rtl8192eu/1.0/build/include/osdep_service_linux.h: In function ‘_init_timer’:
10 /var/lib/dkms/rtl8192eu/1.0/build/include/osdep_service_linux.h:253:8: error: ‘_timer’ {aka ‘struct timer_list’} has no member named ‘data’
11   ptimer->data = (unsigned long)cntx;
12         ^~
13 /var/lib/dkms/rtl8192eu/1.0/build/include/osdep_service_linux.h:254:2: error: implicit declaration of function ‘init_timer’; did you mean ‘_init_timer’?     [-Werror=implicit-function-declaration]
14   init_timer(ptimer);
15   ^~~~~~~~~~
16   _init_timer
17 cc1: some warnings being treated as errors
18 make[4]: *** [/usr/src/linux-headers-4.19.0-5-common/scripts/Makefile.build:309: /var/lib/dkms/rtl8192eu/1.0/build/core/rtw_cmd.o] Error 1
19 make[3]: *** [/usr/src/linux-headers-4.19.0-5-common/Makefile:1539: _module_/var/lib/dkms/rtl8192eu/1.0/build] Error 2
20 make[2]: *** [Makefile:146: sub-make] Error 2
21 make[1]: *** [Makefile:8: all] Error 2
22 make[1] : on quitte le répertoire « /usr/src/linux-headers-4.19.0-5-amd64 »
23 make: *** [Makefile:1335: modules] Error 2

#8 Re : Matériel » [Résolu]Encore la clé wifi Realtek RTL8192EU... » 19-07-2019 17:16:46

j'espère que je pourrai avoir votre aide, ce topic date!

j'ai donc le même soucis que mth, je suis les indications de èfpé mais ça plante sur cette commande

dkms build rtl8192eu/1.0


cela retourne

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
'make' all KVER=4.19.0-5-amd64....(bad exit status: 2)
Error! Bad return status for module build on kernel: 4.19.0-5-amd64 (x86_64)
Consult /var/lib/dkms/rtl8192eu/1.0/build/make.log for more information.
zsh: exit 10    dkms build rtl8192eu/1.0

#9 Re : Suivi du Wiki et des Projets Git » wiki - Installer Nextcloud » 24-09-2018 13:55:08

Bonjour,

Merci à l'auteur de ce tuto magnifique big_smile

Cela m'a permit d'installer nextcloud, qui est génial au passage, sur mon p'tit serveur perso Debian 9 cool

J'ai toutefois un message (en rouge) concernant la configuration :

Votre dossier de données et vos fichiers sont probablement accessibles depuis internet. Le fichier .htaccess ne fonctionne pas. Nous vous recommandons vivement de configurer votre serveur web de façon à ce que ce dossier de données ne soit plus accessible, ou de le déplacer hors de la racine du serveur web



L'avez vous eu également ?

Il est question de .htaccess, s'il ne fonctionnait pas, je me dis que je ne pourrais pas m'identifier ?

Avez-vous des pistes de résolutions svp ?

Merci d'avance.

#10 Re : Réseau » [SITE WEB DOWN]: site perso plus accessible » 12-12-2015 23:21:32

Bon! je viens de faire le ménage dans le /etc/nginx/site-enabled et relancer le fichier de sauvegarde avec un ln -s dans ce dossier, relancé nginx et le revoilou big_smile

J'ai dû m'emmêler les pinceaux roll

Merci à vous pour votre assistance en tout cas!:cool:

#11 Re : Réseau » [SITE WEB DOWN]: site perso plus accessible » 11-12-2015 20:50:37

L'IP est bien celle-ci

lynx -dump www.monip.org


IP : 81.66.203.113



Un script vérifie régulièrement cette IP et met à jour l'IP sur OVH.

De l'extérieur, mon serveur sftp est accessible, et mon serveur bien dans la liste des serveurs du réseau TOR

http://torstatus.blutmagie.de/router_de … 97f53c19f2

Le problème est donc spécifique à Nginx.

service nginx status



[ ok ] nginx is running.



Les commandes autour de Netstat permettent de vérifier que les ports 80/443 ne sont pas ouvert, je ne vois pas ce qui a pu les mettre sur Off....Il ne me semble pas avoir fait de configuration particulière....

#12 Re : Réseau » [SITE WEB DOWN]: site perso plus accessible » 10-12-2015 23:03:02

Bonsoir à vous,

J'ai un nom de domaine acheté chez OVH, je fais de l'auto-hébergement sur un PC tournant sous Wheezy derrière une Box Numericable.

Mon serveur web est sur Nginx.

L'adresse IP mentionnée ci dessus est bien renseignée sur mon dashboard OVH.

Effectivement, la commande

nmap -v -A www.leblais.net

ne révèle pas les ports 80/443 notamment.

Ils font l'objet d'une redirection de ports sur ma Box.

J'accèdes en ssh sur ce serveur via un autre PC en local (pas tenté de l'extérieur) et la connection en sftp fonctionne également.

Cela ne semble pas, a priori?, se caractériser par un piratage? Les dégâts seraient tout autre non??

Merci à vous pour votre assistance!

#13 Réseau » [SITE WEB DOWN]: site perso plus accessible » 09-12-2015 22:26:47

spartiate
Réponses : 16
Bonjour à toutes et à tous,

Depuis quelques jours (environs une semaine), mon petit site perso n'est plus accessible à l'adresse www.leblais.net

Pouvez-vous me donner quelques pistes pour chercher où le problème peut se situer svp? Peux-être ai-je été la cible d'une attaque réseau??

Merci d'avance

#14 Re : Réseau » [PARTAGE DE FICHIERS]: BitTorrent? » 04-09-2015 20:26:12

Merci pour vos réponses mais je voudrais installer sur mon serveur maison un serveur bittorent avant tout.

La solution de Thuban induit un soft avec interface graphique.

Y a t-il un paquet debian qui le permet? Faut-il passer par l'installation d'un "tracker"? C'est un peu flou pour moi; les seules recherche sur le net me retournent souvent des résultats sur l'installation d'une seedbox plutôt...

#15 Réseau » [PARTAGE DE FICHIERS]: BitTorrent? » 02-09-2015 21:37:57

spartiate
Réponses : 4
Hello tous,

Je partage avec mon entourage des fichiers assez volumineux en passant par sftp.

Mais je me rend compte que cela peut être assez lourd pour certaines personnes voire peu accessible...

Ainsi, je voulais adopter une solution de type P2P sous torrent.

C'est très pratique, les personnes n'ont qu'à charger le torrent sur un client et ça roule...

Je ne sais pas trop où orienter mes recherches : quel serveur pour mettre à dispo du torrent? est-ce la configuration d'un tracker à faire sur mon serveur? comment créé t-on un fichier torrent?

je ne trouve rien de probant sur la toile hormis des sites qui expliquent comment créer sa seedbox...

Des avis/aides please?

Merci d'avance tongue

#16 Re : Réseau » Syn Flood » 10-07-2015 21:12:35

Merci pour ces solutions kawer wink

je met en place un script/cron qui m'avertira d'autres SYN_FLOOD éventuels.

J'avais également changé le port par défaut de SSH, c'est une sécurité par l'aveugle je sais....

L'installation+configuration de fail2ban sera nécessaire à moyen terme, avec d'autres aussi je pense (portsentry, snort....)

#17 Re : Réseau » Syn Flood » 10-07-2015 20:46:05

OK, c'est mis en place (je n'ai pas de configuration iptables!!).

Au bout de quelques temps, je me reprends des SYN_FLOOD sur ce port malgré tout...jusque 130. Qu'est ce qui peut expliquer cela malgré ton script?

Je devrais me plonger dans iptables, mais je trouve cela très difficile!

J'ai choisi une solution de contournement: j'ai changé le port de privoxy.

Pour le moment, plus d'alertes; mais c'est jusque quand? Je ne pense pas cette solution perenne dans le temps!

#18 Re : Réseau » Syn Flood » 03-07-2015 21:38:59

Merci pour ton aide kawer, concernant le fichier iptable, j'ai

iptables v1.4.14: unknown option "--syn"

#19 Réseau » Syn Flood » 02-07-2015 21:37:40

spartiate
Réponses : 6
Hello à tous!!

Sur mon PC-serveur, j'ai installé tor/privoxy.

J'ai des syn flood sur le port 8118 et cela fait ramer le PC.

La commande

netstat -atpn |grep SYN | wc -l

 montre des chiffres pouvant aller jusque 60

j'ai passé la valeur à "1" dans tcp_syncookies et installé et exécuter le script "floodmon" mais cela ne les stop pas complètement bien que leur nombre soit réduit de moitié.

Comment lutter efficacement contre ces nuisances?

#20 Re : Système » [Résolu] dvtm: unknown terminal type » 29-06-2015 21:35:21

Bon, j'ai copié les fichiers dvtm et dvtm-256color du laptop sur le serveur, en changeant les droits forcément et avec la commande export... c'est bon!!

Je ne comprends pas toutefois pas pourquoi cela fonctionnait "avant" et plus après roll

Merci wink

#21 Re : Système » [Résolu] dvtm: unknown terminal type » 29-06-2015 21:26:02

Hello enicar!

Alors, sur le laptop, j'ai bien

usr/share/terminfo/d/dvtm

mais rien sur le serveur, je ne comprends pas roll

les versions de paquets :

laptop

dvtm:
Installé : 0.12-1
Candidat : 0.12-1
Table de version :
*** 0.12-1 0
500 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages
100 /var/lib/dpkg/status
 



serveur

dvtm:
Installé : 0.6-1
Candidat : 0.6-1
Table de version :
*** 0.6-1 0
500 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages
100 /var/lib/dpkg/status
 

#22 Système » [Résolu] dvtm: unknown terminal type » 25-06-2015 21:05:30

spartiate
Réponses : 4
Hello World!

Depuis mon laptot (sous jessie) j'accède en ssh sur mon pc-serveur (wheezy). Cela fait quelques temps (je ne sais pas ce qui a pu provoquer ce changement, MàJ du laptop wheezy->Jessie peut être), que la console en ssh me signale

'dvtm': unknown terminal type.



je lance la console sur le laptop avec dvtm embarqué

urxvt -e dvtm

via un raccourci clavier (j'utilise spectWM).

Sur le serveur, le term 'dvtm' n'est a priori plus reconnue.

Si je lance la console sur le laptop sans dvtm, pas de soucis en ssh sur le serveur avec cette console.

Comment faire "reconnaître" dvtm en ssh sur le serveur?

Je n'ai jamais dû configurer quoique ce soit à ce niveau auparavant...mais bon il s'agit peut être d'un modification suite à des updates de paquets??? (voir mon 1er post à ce sujet).

ps: un

echo $TERM

dvtm



la commande mc donne plus de précisions

neo@matrix ~ % mc
Unknown terminal: dvtm
Check the TERM environment variable.
Also make sure that the terminal is defined in the terminfo database.
Alternatively, set the TERMCAP environment variable to the desired
termcap entry.
zsh: exit 1     mc

#23 Re : Réseau » [Résolu] MàJ Debian Wheezy impossible via sudo » 25-06-2015 10:11:25

Fait!

Par contre, ton lien n'est pas le bon. C'est ...atelier:resolu et non manuel:resolu...

Pourquoi ne pas mettre d'icône "résolu" à cliquer pour passer un fil en "résolu" comme sur certains forums?

#24 Re : Réseau » [Résolu] MàJ Debian Wheezy impossible via sudo » 25-06-2015 08:51:03

Bonjour captnfab,

C'est parfait, cela refonctionne!!

je ne sais pas ce qui a pû changer, à part une mise à jour dans un paquet apt*??

Merci beaucoup en tout cas.

Je vais reposter certainement d'autres messages au sujet d'autres problèmes, mais pas avant d'avoir cherché un maximum sur la toile....

#25 Re : Réseau » [Résolu] MàJ Debian Wheezy impossible via sudo » 24-06-2015 20:59:55

Hello!

Merci pour ton aide

1)
/etc/apt/sources.list

deb http://ftp.fr.debian.org/debian/ wheezy main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ wheezy main contrib non-free

# Security
deb http://security.debian.org/ wheezy/updates main contrib non-free
#deb-src http://security.debian.org/ wheezy/updates main contrib non-free

# wheezy-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ wheezy-updates main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ wheezy-updates main contrib non-free

#Multimédia
deb http://www.deb-multimedia.org wheezy main
#deb-src http://www.debian-multimedia.org/ wheezy main

#Backports
deb http://ftp.debian.org/debian/ wheezy-backports main contrib non-free
 



> /etc/apt/sources.list.d/* NEANT

> /etc/apt/apt.conf NEANT

> /etc/apt/apt.conf.d/ :
00CDMountPoint

Acquire::cdrom {mount "/media/cdrom";};Dir::Media::MountPath "/media/cdrom";



00trustcdrom

APT::Authentication::TrustCDROM "true";



01autoremove

 APT
{
   NeverAutoRemove
   {
         "^firmware-linux.*";
         "^linux-firmware$";
         "^linux-image.*";
         "^kfreebsd-image.*";
         "^linux-restricted-modules.*";
         "^linux-ubuntu-modules-.*";
         "^gnumach$";
         "^gnumach-image.*";
   };
 
   Never-MarkAuto-Sections
   {
         "metapackages";
         "restricted/metapackages";
         "universe/metapackages";
         "multiverse/metapackages";
         "oldlibs";
         "restricted/oldlibs";
         "universe/oldlibs";
         "multiverse/oldlibs";
   };
 };



20listechanges

 DPkg::Pre-Install-Pkgs { "/usr/bin/apt-listchanges --apt || test $? -ne 10"; };
DPkg::Tools::Options::/usr/bin/apt-listchanges::Version "2";



70debconf

  // Pre-configure all packages with debconf before they are installed.
 // If you don't like it, comment it out.
 DPkg::Pre-Install-Pkgs {"/usr/sbin/dpkg-preconfigure --apt || true";};



90rkhunter

 // Makes sure that rkhunter file properties database is updated after each remove or install only APT_AUTOGEN is enabled
 DPkg::Post-Invoke { "if [ -x /usr/bin/rkhunter ] && grep -qiE '^APT_AUTOGEN=.?(true|yes)' /etc/default/rkhunter; then /usr/share/rkhunter/scripts/rkhu
 pd.sh; fi"
}



2)

wget -O/dev/null 'http://www.deb-multimedia.org/dists/wheezy/main/binary-amd64/Packages'


 --2015-06-24 21:53:06--  http://www.deb-multimedia.org/dists/wheezy/main/binary-amd64/Packages
 Résolution de localhost (localhost)... 127.0.0.1, ::1
 Connexion vers localhost (localhost)|127.0.0.1|:8118...connecté.
 requête Proxy transmise, en attente de la réponse...200 OK
 Longueur: 455032 (444K)
 Sauvegarde en : «/dev/null»
 
 100%[============================================================================================================>] 455 032     --.-K/s   ds 0,002s  
 
 2015-06-24 21:53:07 (201 MB/s) - «/dev/null» sauvegardé [455032/455032]



Pour le 3) effectivement, une remise en question est peut être nécessaire wink mon serveur sert aussi de relais TOR smile

Pied de page des forums

Propulsé par FluxBB