Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-12-2017 14:23:38

roulioo
Membre
Distrib. : Debian GNU/Linux 9 \n \l
Noyau : Linux 4.9.0-4-amd64
(G)UI : DESKTOP_SESSION=LXDE XDG_SESSION_DESKTOP=lightdm-x
Inscription : 14-12-2017

installation de expressvpn

Bonjour smile

Je débute sur Debian et ne sais même pas comment installer un logiciel
J'ai pris connaissance de la commande  "apt-get install" et j'ai téléchargé express vpn pour linux .
après la commande "su",  quand je lance la commande "apt-get install" , voila ce qu'il me dit :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet expressvpn_1.3.1_amd64
E: Couldn't find any package by glob 'expressvpn_1.3.1_amd64'
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « expressvpn_1.3.1_amd64

 »

Puis-je avoir un petit peu d'aide s'il vous plait ?   

Merci !

Edit à toto : Mis le retour de la commande dans la balise Autre code du forum.

Hors ligne

#2 14-12-2017 15:44:07

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : installation de expressvpn

J'ai pris connaissance de la commande  "apt-get install" et j'ai téléchargé express vpn pour linux .
après la commande "su",  quand je lance la commande "apt-get install"


Bonjour
La commande apt-get install "nomdu paquet" permet d'installer un paquet présent dans les dépôts Debian
Le logiciel provient surement du site internet https://www.expressvpn.com/fr/support/v … for-linux/
Par défaut le fichier.deb que tu as téléchargé est dans ton dossier Téléchargement
Tu peux l'installer avec avec apt install en spécifiant l'emplacement du fichier comme sur ce poste
https://debian-facile.org/viewtopic.php … 87#p243187

apt install /home/identifiant-USER/Téléchargements/fichier.deb



PS: l'offre de gratuité est valable 30 jours pour le vpn

Dernière modification par Croutons (14-12-2017 15:44:34)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 14-12-2017 15:55:56

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : installation de expressvpn

Croutons a écrit :

le fichier.deb que tu as téléchargé


Ou utiliser la commande dpkg :
Le lien vers le tuto :
https://debian-facile.org/doc:systeme:apt:dpkg

Les paquets debian sont eux disponibles directement dans les serveurs debian qui sont indiqués dans tes sources.
Voir le tuto des sources :
https://debian-facile.org/doc:systeme:apt:sources.list

Force et courage wink


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#4 16-12-2017 19:38:04

roulioo
Membre
Distrib. : Debian GNU/Linux 9 \n \l
Noyau : Linux 4.9.0-4-amd64
(G)UI : DESKTOP_SESSION=LXDE XDG_SESSION_DESKTOP=lightdm-x
Inscription : 14-12-2017

Re : installation de expressvpn

salut smile
Merci pour vos réponses ,
avec la commande dpkg l'installation c'est bien passée... pas d'interface de mon logiciel mais j'ai reussi a m'en servir et j'ai reussi a installer l'appli de firefox  smile

merci pour tout !

Hors ligne

#5 16-12-2017 23:17:25

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : installation de expressvpn

roulioo a écrit :

avec la commande dpkg l'installation c'est bien passée


Super !
Si c'est résolu, alors il faut l'indiquer dans le titre.
Le lien vers le tuto :
    \o/
    Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre. smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#6 22-02-2022 16:38:33

Novice.deb
Membre
Distrib. : Debian 11 "Bullseye"
Noyau : Linux 5.10.0-11-amd64
Inscription : 19-02-2022

Re : installation de expressvpn

Croutons a écrit :

J'ai pris connaissance de la commande  "apt-get install" et j'ai téléchargé express vpn pour linux .
après la commande "su",  quand je lance la commande "apt-get install"


Bonjour
La commande apt-get install "nomdu paquet" permet d'installer un paquet présent dans les dépôts Debian
Le logiciel provient surement du site internet https://www.expressvpn.com/fr/support/v … for-linux/
Par défaut le fichier.deb que tu as téléchargé est dans ton dossier Téléchargement
Tu peux l'installer avec avec apt install en spécifiant l'emplacement du fichier comme sur ce poste
https://debian-facile.org/viewtopic.php … 87#p243187

apt install /home/identifiant-USER/Téléchargements/fichier.deb



PS: l'offre de gratuité est valable 30 jours pour le vpn



Bonjour pourrais tu m'aider stp ou si il y à une autre personne qui peut apporter la solution à mon problème merci d'avance

Je viens d'installer Debian 11 récemment et voici le retour que j'ai après un

sudo dpkg -i expressvpn_3.18.1.0-1_amd64.deb



dpkg: avertissement: « ldconfig » introuvable dans la variable PATH ou non exécutable
dpkg: avertissement: « start-stop-daemon » introuvable dans la variable PATH ou non exécutable
dpkg: erreur: 2 programmes attendus non trouvés dans la variable PATH ou non exécutables
Note : la variable PATH du superutilisateur doit normalement contenir /usr/local/sbin, /usr/sbin et /sbin

Hors ligne

#7 22-02-2022 16:57:16

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : installation de expressvpn

Bonjour

essaie de passer en root avec "su -"  puis entrer ton mdp pour root

sinon une commande en simulation


apt -s install expressvpn_3.18.1.0-1_amd64.deb
 



sinon tu a aussi l'utiltaire graphique "gdebi" du paquet du même nom , pour installer un ".deb"

mais ton souci est celui ci


Note : la variable PATH du superutilisateur doit normalement contenir /usr/local/sbin, /usr/sbin et /sbin
 


ce qui arrive avec l'utilisation de "su" et pas "su -"
comme je n'utilise pas "sudo" je pourrai pas t'en dire plus smile

ps: il faut te mettre bien sur dans la console ou ce trouve ton ".deb" (le bon dossier) mais je pense que tu le sais smile

Dernière modification par robert2a (22-02-2022 17:02:10)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#8 22-02-2022 17:25:47

Novice.deb
Membre
Distrib. : Debian 11 "Bullseye"
Noyau : Linux 5.10.0-11-amd64
Inscription : 19-02-2022

Re : installation de expressvpn

robert2a a écrit :

Bonjour

essaie de passer en root avec "su -"  puis entrer ton mdp pour root

sinon une commande en simulation


apt -s install expressvpn_3.18.1.0-1_amd64.deb
 



sinon tu a aussi l'utiltaire graphique "gdebi" du paquet du même nom , pour installer un ".deb"

mais ton souci est celui ci


Note : la variable PATH du superutilisateur doit normalement contenir /usr/local/sbin, /usr/sbin et /sbin
 


ce qui arrive avec l'utilisation de "su" et pas "su -"
comme je n'utilise pas "sudo" je pourrai pas t'en dire plus smile

ps: il faut te mettre bien sur dans la console ou ce trouve ton ".deb" (le bon dossier) mais je pense que tu le sais smile



Bonjour et merci de ta réponse c'est bon, problème résolu et ça venais bien de

/usr/local/sbin, /usr/sbin et /sbin



Merci de ta réactivité et bonne journée à toi

Hors ligne

Pied de page des forums