Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 16-09-2018 17:42:38

MoxSite
Membre
Distrib. : Debian Buster (Testing+SID)
Noyau : Linux 4.18.0-1-amd64
(G)UI : Gnome 3.30
Inscription : 28-07-2015

[Résolu] Problème de dépendences pour installer certains paquets

Bonjour,

J'ai essayé d'installer libgtk-3-dev sur Debian, mais impossible, de même pour la librairie Qt


sudo apt install libgtk-3-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libgtk-3-dev : Dépend: libegl1-mesa-dev mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 



Apparemment le problème vient de "libegl1-mesa-dev" qui lui dépend de d'autres paquets qui ne peuvent pas être installés :


sudo apt install libegl1-mesa-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances        
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libegl1-mesa-dev : Dépend: libegl1-mesa (= 13.0.6-1+b2) mais 18.1.6-1~bpo9+1 devra être installé
                    Dépend: libwayland-egl1-mesa (= 13.0.6-1+b2)
                    Dépend: libdrm-dev (>= 2.4.69) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

 


Mon fichier sources.list :


deb http://ftp.fr.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free

# stretch-backports
deb http://httpredir.debian.org/debian stretch-backports main contrib non-free
 



Vous avez une idée ?

Pour information j'utilise Gnome Shell.

Dernière modification par MoxSite (16-09-2018 22:07:38)


Debian Stretch sur mes serveurs. Buster (Testing+SID) sur mon PC. Config mini ITX :
CM : ASRock Fatal1ty AB350 Gaming ITX/ac. Ram : Corsair 8GB DDR4. CPU : Ryzen 5 1600. CG : MSI GeForce GT 1030 2GH OC. 120GB SSD + 1TB pour la partition home.
Usage : programmation, bureautique, compatibilité,  photoshop (virtualisation).

Hors ligne

#2 16-09-2018 17:54:59

bendia
Chadministrateur
Distrib. : Buster, Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : [Résolu] Problème de dépendences pour installer certains paquets

Salut smile

Utilise peut-être aptitude au lieu de apt pour le coup, tu auras différentes propositions pour éventuellement résoudre le conflit. Attention, les propositions sont à étudier attentivement et peuvent avoir des conséquences non désirées !

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#3 16-09-2018 18:00:21

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : [Résolu] Problème de dépendences pour installer certains paquets

Tu as certainement des paquets venant de stretch-backports installés. Tu peux installer et utiliser aptitude pour régler ça.

Cela dit, on peut, aussi, y arriver manuellement.

Que donne ?

apt --installed list | grep -v '/stable'

Dernière modification par Beta-Pictoris (16-09-2018 18:00:41)

Hors ligne

#4 16-09-2018 18:11:26

MoxSite
Membre
Distrib. : Debian Buster (Testing+SID)
Noyau : Linux 4.18.0-1-amd64
(G)UI : Gnome 3.30
Inscription : 28-07-2015

Re : [Résolu] Problème de dépendences pour installer certains paquets

J'ai utilisé le dépôt stretch-backports pour le pilote de ma carte graphique, car elle n'est pas prise en charge par le pilote  "nouveau".


sudo apt --installed list | grep -v '/stable'

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

En train de lister…
brscan-skey/now 0.2.4-1 amd64  [installé, local]
brscan4/now 0.4.5-1 amd64  [installé, local]
glx-alternative-mesa/now 0.8.7~bpo9+1 amd64  [installé, local]
glx-alternative-nvidia/now 0.8.7~bpo9+1 amd64  [installé, local]
glx-diversions/now 0.8.7~bpo9+1 amd64  [installé, local]
libdrm-common/now 2.4.91-2~bpo9+1 all  [installé, local]
libdrm2/now 2.4.91-2~bpo9+1 amd64  [installé, local]
libegl-nvidia0/now 390.77-1~bpo9+1 amd64  [installé, local]
libegl1/now 1.0.0+git20180308-2~bpo9+1 amd64  [installé, local]
libegl1-mesa/now 18.1.6-1~bpo9+1 amd64  [installé, local]
libgl1/now 1.0.0+git20180308-2~bpo9+1 amd64  [installé, local]
libgl1-mesa-glx/now 18.1.6-1~bpo9+1 amd64  [installé, local]
libgl1-nvidia-glvnd-glx/now 390.77-1~bpo9+1 amd64  [installé, local]
libglapi-mesa/now 18.1.6-1~bpo9+1 amd64  [installé, local]
libgles-nvidia2/now 390.77-1~bpo9+1 amd64  [installé, local]
libgles2/now 1.0.0+git20180308-2~bpo9+1 amd64  [installé, local]
libgles2-mesa/now 18.1.6-1~bpo9+1 amd64  [installé, local]
libglvnd0/now 1.0.0+git20180308-2~bpo9+1 amd64  [installé, local]
libglx-mesa0/now 18.1.6-1~bpo9+1 amd64  [installé, local]
libglx-nvidia0/now 390.77-1~bpo9+1 amd64  [installé, local]
libglx0/now 1.0.0+git20180308-2~bpo9+1 amd64  [installé, local]
libnvidia-cfg1/now 390.77-1~bpo9+1 amd64  [installé, local]
libnvidia-egl-wayland1/now 390.77-1~bpo9+1 amd64  [installé, local]
libnvidia-eglcore/now 390.77-1~bpo9+1 amd64  [installé, local]
libnvidia-glcore/now 390.77-1~bpo9+1 amd64  [installé, local]
libnvidia-ml1/now 390.77-1~bpo9+1 amd64  [installé, local]
libopengl0/now 1.0.0+git20180308-2~bpo9+1 amd64  [installé, local]
libvulkan1/now 1.1.70+dfsg1-1~bpo9+1 amd64  [installé, local]
libwayland-egl1/now 1.15.0-2~bpo9+1 amd64  [installé, local]
libwayland-egl1-mesa/now 18.1.6-1~bpo9+1 amd64  [installé, local]
libxnvctrl0/now 390.48-2~bpo9+1 amd64  [installé, local]
mfcj4410dwcupswrapper/now 3.0.1-1 i386  [installé, local]
mfcj4410dwlpr/now 3.0.1-1 i386  [installé, local]
nvidia-alternative/now 390.77-1~bpo9+1 amd64  [installé, local]
nvidia-driver/now 390.77-1~bpo9+1 amd64  [installé, local]
nvidia-driver-bin/now 390.77-1~bpo9+1 amd64  [installé, local]
nvidia-driver-libs/now 390.77-1~bpo9+1 amd64  [installé, local]
nvidia-egl-common/now 390.77-1~bpo9+1 amd64  [installé, local]
nvidia-egl-icd/now 390.77-1~bpo9+1 amd64  [installé, local]
nvidia-egl-wayland-common/now 390.77-1~bpo9+1 amd64  [installé, local]
nvidia-egl-wayland-icd/now 390.77-1~bpo9+1 amd64  [installé, local]
nvidia-kernel-dkms/now 390.77-1~bpo9+1 amd64  [installé, local]
nvidia-kernel-support/now 390.77-1~bpo9+1 amd64  [installé, local]
nvidia-legacy-check/now 390.77-1~bpo9+1 amd64  [installé, local]
nvidia-settings/now 390.48-2~bpo9+1 amd64  [installé, local]
nvidia-vdpau-driver/now 390.77-1~bpo9+1 amd64  [installé, local]
nvidia-vulkan-common/now 390.77-1~bpo9+1 amd64  [installé, local]
nvidia-vulkan-icd/now 390.77-1~bpo9+1 amd64  [installé, local]
update-glx/now 0.8.7~bpo9+1 amd64  [installé, local]
virtualbox-5.2/now 5.2.18-124319~Debian~stretch amd64  [installé, local]
xserver-xorg-video-nvidia/now 390.77-1~bpo9+1 amd64  [installé, local]

 


Debian Stretch sur mes serveurs. Buster (Testing+SID) sur mon PC. Config mini ITX :
CM : ASRock Fatal1ty AB350 Gaming ITX/ac. Ram : Corsair 8GB DDR4. CPU : Ryzen 5 1600. CG : MSI GeForce GT 1030 2GH OC. 120GB SSD + 1TB pour la partition home.
Usage : programmation, bureautique, compatibilité,  photoshop (virtualisation).

Hors ligne

#5 16-09-2018 18:15:15

MoxSite
Membre
Distrib. : Debian Buster (Testing+SID)
Noyau : Linux 4.18.0-1-amd64
(G)UI : Gnome 3.30
Inscription : 28-07-2015

Re : [Résolu] Problème de dépendences pour installer certains paquets

Je pense que c'est une histoire de versions de certains paquets qui pose problème :


sudo aptitude install libgtk-3-dev
Les NOUVEAUX paquets suivants vont être installés :    
  autoconf{a} automake{a} autopoint{a} autotools-dev{a} debhelper{a} dh-autoreconf{a} dh-strip-nondeterminism{a} gettext{a} icu-devtools{a} intltool-debian{a} libarchive-zip-perl{a} libatk-bridge2.0-dev{a}
  libatk1.0-dev{a} libatspi2.0-dev{a} libdbus-1-dev{a} libdrm-dev{ab} libegl1-mesa-dev{ab} libepoxy-dev{a} libfile-stripnondeterminism-perl{a} libgdk-pixbuf2.0-dev{a} libgraphite2-dev{a} libgtk-3-dev
  libharfbuzz-dev{a} libharfbuzz-gobject0{a} libicu-dev{a} libltdl-dev{a} libmail-sendmail-perl{a} libpango1.0-dev{a} libsys-hostname-long-perl{a} libtool{a} libwayland-bin{a} libwayland-dev{a}
  libx11-xcb-dev{a} libxcb-dri2-0-dev{a} libxcb-dri3-dev{a} libxcb-glx0-dev{a} libxcb-present-dev{a} libxcb-randr0-dev{a} libxcb-shape0-dev{a} libxcb-sync-dev{a} libxcb-xfixes0-dev{a} libxcomposite-dev{a}
  libxcursor-dev{a} libxdamage-dev{a} libxfixes-dev{a} libxft-dev{a} libxi-dev{a} libxinerama-dev{a} libxkbcommon-dev{a} libxrandr-dev{a} libxshmfence-dev{a} libxtst-dev{a} libxxf86vm-dev{a} m4{a}
  po-debconf{a} wayland-protocols{a} x11proto-composite-dev{a} x11proto-damage-dev{a} x11proto-dri2-dev{a} x11proto-fixes-dev{a} x11proto-gl-dev{a} x11proto-randr-dev{a} x11proto-record-dev{a}
  x11proto-xf86vidmode-dev{a} x11proto-xinerama-dev{a}
0 paquets mis à jour, 65 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 27,8 Mo d'archives. Après dépaquetage, 139 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 libegl1-mesa-dev : Dépend: libegl1-mesa (= 13.0.6-1+b2) but 18.1.6-1~bpo9+1 is installed
                    Dépend: libwayland-egl1-mesa (= 13.0.6-1+b2) but 18.1.6-1~bpo9+1 is installed
 libdrm-dev : Dépend: libdrm2 (= 2.4.74-1) but 2.4.91-2~bpo9+1 is installed
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     libdrm-dev [Non installé]                                
2)     libegl1-mesa-dev [Non installé]                          
3)     libgtk-3-dev [Non installé]                              

Accepter cette solution ? [Y/n/q/?]
 



Je n'ai pas validé, j'ai peur de casser mon système. Devrais-je essayer quand-même ?


Debian Stretch sur mes serveurs. Buster (Testing+SID) sur mon PC. Config mini ITX :
CM : ASRock Fatal1ty AB350 Gaming ITX/ac. Ram : Corsair 8GB DDR4. CPU : Ryzen 5 1600. CG : MSI GeForce GT 1030 2GH OC. 120GB SSD + 1TB pour la partition home.
Usage : programmation, bureautique, compatibilité,  photoshop (virtualisation).

Hors ligne

#6 16-09-2018 18:31:50

bendia
Chadministrateur
Distrib. : Buster, Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : [Résolu] Problème de dépendences pour installer certains paquets

Tu peux regarder les autres propositions en répondant non. Si tu réponds non à tout, rien ne se passe donc, tu n'as pas de risque. Tu peux aussi utiliser le mode simulation avec l'option -s en simple utilisateur, et pas de soucis wink

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#7 16-09-2018 18:45:15

MoxSite
Membre
Distrib. : Debian Buster (Testing+SID)
Noyau : Linux 4.18.0-1-amd64
(G)UI : Gnome 3.30
Inscription : 28-07-2015

Re : [Résolu] Problème de dépendences pour installer certains paquets

Quand je réponds non, cela me propose de supprimer le pilote graphique nvidia, sauf que le pilote libre ne reconnaît pas ma carte graphique.

sudo aptitude install libgtk-3-dev
Les NOUVEAUX paquets suivants vont être installés :    
  autoconf{a} automake{a} autopoint{a} autotools-dev{a} debhelper{a} dh-autoreconf{a} dh-strip-nondeterminism{a} gettext{a} icu-devtools{a} intltool-debian{a} libarchive-zip-perl{a} libatk-bridge2.0-dev{a}
  libatk1.0-dev{a} libatspi2.0-dev{a} libdbus-1-dev{a} libdrm-dev{ab} libegl1-mesa-dev{ab} libepoxy-dev{a} libfile-stripnondeterminism-perl{a} libgdk-pixbuf2.0-dev{a} libgraphite2-dev{a} libgtk-3-dev
  libharfbuzz-dev{a} libharfbuzz-gobject0{a} libicu-dev{a} libltdl-dev{a} libmail-sendmail-perl{a} libpango1.0-dev{a} libsys-hostname-long-perl{a} libtool{a} libwayland-bin{a} libwayland-dev{a}
  libx11-xcb-dev{a} libxcb-dri2-0-dev{a} libxcb-dri3-dev{a} libxcb-glx0-dev{a} libxcb-present-dev{a} libxcb-randr0-dev{a} libxcb-shape0-dev{a} libxcb-sync-dev{a} libxcb-xfixes0-dev{a} libxcomposite-dev{a}
  libxcursor-dev{a} libxdamage-dev{a} libxfixes-dev{a} libxft-dev{a} libxi-dev{a} libxinerama-dev{a} libxkbcommon-dev{a} libxrandr-dev{a} libxshmfence-dev{a} libxtst-dev{a} libxxf86vm-dev{a} m4{a}
  po-debconf{a} wayland-protocols{a} x11proto-composite-dev{a} x11proto-damage-dev{a} x11proto-dri2-dev{a} x11proto-fixes-dev{a} x11proto-gl-dev{a} x11proto-randr-dev{a} x11proto-record-dev{a}
  x11proto-xf86vidmode-dev{a} x11proto-xinerama-dev{a}
0 paquets mis à jour, 65 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 27,8 Mo d'archives. Après dépaquetage, 139 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 libegl1-mesa-dev : Dépend: libegl1-mesa (= 13.0.6-1+b2) but 18.1.6-1~bpo9+1 is installed
                    Dépend: libwayland-egl1-mesa (= 13.0.6-1+b2) but 18.1.6-1~bpo9+1 is installed
 libdrm-dev : Dépend: libdrm2 (= 2.4.74-1) but 2.4.91-2~bpo9+1 is installed
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     libdrm-dev [Non installé]                                
2)     libegl1-mesa-dev [Non installé]                          
3)     libgtk-3-dev [Non installé]                              



Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                                                    
1)      libegl1 [1.0.0+git20180308-2~bpo9+1 (now)]                                        
2)      libgl1 [1.0.0+git20180308-2~bpo9+1 (now)]                                        
3)      libgl1-nvidia-glvnd-glx [390.77-1~bpo9+1 (now)]                                  
4)      libglx-mesa0 [18.1.6-1~bpo9+1 (now)]                                              
5)      libglx-nvidia0 [390.77-1~bpo9+1 (now)]                                            
6)      libglx0 [1.0.0+git20180308-2~bpo9+1 (now)]                                        
7)      libwayland-egl1 [1.15.0-2~bpo9+1 (now)]                                          
8)      nvidia-driver [390.77-1~bpo9+1 (now)]                                            
9)      nvidia-driver-libs [390.77-1~bpo9+1 (now)]                                        
10)     nvidia-egl-icd [390.77-1~bpo9+1 (now)]                                            
11)     nvidia-vulkan-icd [390.77-1~bpo9+1 (now)]                                        

      Réinstaller à une version antérieure les paquets suivants :                        
12)     libdrm2 [2.4.91-2~bpo9+1 (now) -> 2.4.74-1 (stable)]                              
13)     libegl1-mesa [18.1.6-1~bpo9+1 (now) -> 13.0.6-1+b2 (stable)]                      
14)     libgl1-mesa-glx [18.1.6-1~bpo9+1 (now) -> 13.0.6-1+b2 (stable)]                  
15)     libglapi-mesa [18.1.6-1~bpo9+1 (now) -> 13.0.6-1+b2 (stable)]                    
16)     libwayland-egl1-mesa [18.1.6-1~bpo9+1 (now) -> 13.0.6-1+b2 (stable)]              

      Leave the following dependencies unresolved:                                        
17)     nvidia-settings recommande libgl1-nvidia-glvnd-glx | libgl1-nvidia-glx            
18)     nvidia-kernel-dkms recommande nvidia-driver (>= 390.77) | libcuda1 (>= 390.77)    
19)     nvidia-vulkan-common recommande nvidia-vulkan-icd | nvidia-legacy-390xx-vulkan-icd
20)     xserver-xorg-video-nvidia recommande nvidia-driver (>= 390.77)                    
21)     nvidia-driver-bin recommande nvidia-driver                                        

Accepter cette solution ? [Y/n/q/?]



Si je réponds que secondes fois non :

Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                                                                    
1)      libegl1 [1.0.0+git20180308-2~bpo9+1 (now)]                                                        
2)      libgl1 [1.0.0+git20180308-2~bpo9+1 (now)]                                                        
3)      libglx-mesa0 [18.1.6-1~bpo9+1 (now)]                                                              
4)      libglx0 [1.0.0+git20180308-2~bpo9+1 (now)]                                                        
5)      libwayland-egl1 [1.15.0-2~bpo9+1 (now)]                                                          

      Installer les paquets suivants :                                                                    
6)      libegl1-glvnd-nvidia [384.130-1 (stable)]                                                        
7)      libgl1-glvnd-nvidia-glx [384.130-1 (stable)]                                                      
8)      libgles-nvidia1 [384.130-1 (stable)]                                                              
9)      libgles1-glvnd-nvidia [384.130-1 (stable)]                                                        
10)     libglx0-glvnd-nvidia [384.130-1 (stable)]                                                        

      Réinstaller à une version antérieure les paquets suivants :                                        
11)     glx-alternative-mesa [0.8.7~bpo9+1 (now) -> 0.8.3~deb9u1 (stable)]                                
12)     glx-alternative-nvidia [0.8.7~bpo9+1 (now) -> 0.8.3~deb9u1 (stable)]                              
13)     glx-diversions [0.8.7~bpo9+1 (now) -> 0.8.3~deb9u1 (stable)]                                      
14)     libdrm2 [2.4.91-2~bpo9+1 (now) -> 2.4.74-1 (stable)]                                              
15)     libegl-nvidia0 [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                                      
16)     libegl1-mesa [18.1.6-1~bpo9+1 (now) -> 13.0.6-1+b2 (stable)]                                      
17)     libgl1-mesa-glx [18.1.6-1~bpo9+1 (now) -> 13.0.6-1+b2 (stable)]                                  
18)     libgl1-nvidia-glvnd-glx [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                            
19)     libglapi-mesa [18.1.6-1~bpo9+1 (now) -> 13.0.6-1+b2 (stable)]                                    
20)     libgles-nvidia2 [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                                    
21)     libglx-nvidia0 [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                                      
22)     libnvidia-cfg1 [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                                      
23)     libnvidia-egl-wayland1 [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                              
24)     libnvidia-eglcore [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                                  
25)     libnvidia-glcore [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                                    
26)     libnvidia-ml1 [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                                      
27)     libwayland-egl1-mesa [18.1.6-1~bpo9+1 (now) -> 13.0.6-1+b2 (stable)]                              
28)     nvidia-alternative [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                                  
29)     nvidia-driver [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                                      
30)     nvidia-driver-bin [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                                  
31)     nvidia-driver-libs [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                                  
32)     nvidia-egl-icd [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                                      
33)     nvidia-egl-wayland-icd [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                              
34)     nvidia-kernel-dkms [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                                  
35)     nvidia-kernel-support [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                              
36)     nvidia-vdpau-driver [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                                
37)     nvidia-vulkan-icd [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                                  
38)     update-glx [0.8.7~bpo9+1 (now) -> 0.8.3~deb9u1 (stable)]                                          
39)     xserver-xorg-video-nvidia [390.77-1~bpo9+1 (now) -> 384.130-1 (stable)]                          

      Leave the following dependencies unresolved:                                                        
40)     xserver-xorg-video-nvidia recommande nvidia-driver (>= 390.77)                                    
41)     xserver-xorg-video-nvidia recommande nvidia-vdpau-driver (>= 390.77)                              
42)     xserver-xorg-video-nvidia recommande nvidia-kernel-dkms (= 390.77-1~bpo9+1) | nvidia-kernel-390.77
 


Debian Stretch sur mes serveurs. Buster (Testing+SID) sur mon PC. Config mini ITX :
CM : ASRock Fatal1ty AB350 Gaming ITX/ac. Ram : Corsair 8GB DDR4. CPU : Ryzen 5 1600. CG : MSI GeForce GT 1030 2GH OC. 120GB SSD + 1TB pour la partition home.
Usage : programmation, bureautique, compatibilité,  photoshop (virtualisation).

Hors ligne

#8 16-09-2018 19:27:29

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : [Résolu] Problème de dépendences pour installer certains paquets

Les paquets suivants ont des dépendances non satisfaites :
 libegl1-mesa-dev : Dépend: libegl1-mesa (= 13.0.6-1+b2) but 18.1.6-1~bpo9+1 is installed
                    Dépend: libwayland-egl1-mesa (= 13.0.6-1+b2) but 18.1.6-1~bpo9+1 is installed
 libdrm-dev : Dépend: libdrm2 (= 2.4.74-1) but 2.4.91-2~bpo9+1 is installed


Tu peux simuler l'installation des versions de paquets stables comme ceci:

apt -s install libegl1-mesa/stable libwayland-egl1-mesa/stable libdrm2/stable

Dernière modification par Beta-Pictoris (16-09-2018 19:31:42)

Hors ligne

#9 16-09-2018 19:42:45

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : [Résolu] Problème de dépendences pour installer certains paquets

Essaye, aussi de simuler l'installation de la version stable de ton paquet:

apt -s install libgtk-3-dev/stable


Normalement, les backports sont en priorité 100. Cela dit, que donne ? :

apt policy

Dernière modification par Beta-Pictoris (16-09-2018 19:47:06)

Hors ligne

#10 16-09-2018 20:06:05

MoxSite
Membre
Distrib. : Debian Buster (Testing+SID)
Noyau : Linux 4.18.0-1-amd64
(G)UI : Gnome 3.30
Inscription : 28-07-2015

Re : [Résolu] Problème de dépendences pour installer certains paquets

Beta-Pictoris a écrit :

Les paquets suivants ont des dépendances non satisfaites :
 libegl1-mesa-dev : Dépend: libegl1-mesa (= 13.0.6-1+b2) but 18.1.6-1~bpo9+1 is installed
                    Dépend: libwayland-egl1-mesa (= 13.0.6-1+b2) but 18.1.6-1~bpo9+1 is installed
 libdrm-dev : Dépend: libdrm2 (= 2.4.74-1) but 2.4.91-2~bpo9+1 is installed


Tu peux simuler l'installation des versions de paquets stables comme ceci:

apt -s install libegl1-mesa/stable libwayland-egl1-mesa/stable libdrm2/stable


Là j'ai l'impression que ça va tout casser :


sudo apt -s install libegl1-mesa/stable libwayland-egl1-mesa/stable libdrm2/stable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Version choisie « 13.0.6-1+b2 » (Debian:9.5/stable [amd64]) pour « libegl1-mesa »
Version choisie « 13.0.6-1+b2 » (Debian:9.5/stable [amd64]) pour « libwayland-egl1-mesa »
Version choisie « 2.4.74-1 » (Debian:9.5/stable [amd64]) pour « libdrm2 »
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  apg bogofilter bogofilter-bdb bogofilter-common cheese-common
  evolution-common folks-common fonts-linuxlibertine fonts-sil-gentium
  fonts-sil-gentium-basic gir1.2-gfbgraph-0.2 gir1.2-gmenu-3.0
  gnome-control-center-data gnome-video-effects hyphen-en-us libbsh-java
  libclutter-1.0-common libcogl-common libcryptui0a libdrm-common
  libegl-nvidia0 libfolks-eds25 libfolks-telepathy25 libfolks25 libglapi-mesa
  libgles-nvidia2 libgnome-autoar-gtk-0-0 libgnome-menu-3-0 libmusicbrainz5-2
  libmusicbrainz5cc2v5 libnss-myhostname libnvidia-cfg1 libnvidia-egl-wayland1
  libnvidia-eglcore libopengl0 libpst4 libreoffice libreoffice-help-en-us
  libreoffice-librelogo libreoffice-nlpsolver libreoffice-ogltrans
  libreoffice-pdfimport libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python
  libreoffice-wiki-publisher libvulkan1 libytnef0 mousetweaks mythes-en-us
  nvidia-driver-bin nvidia-egl-common nvidia-egl-wayland-common
  nvidia-egl-wayland-icd nvidia-persistenced nvidia-vulkan-common
  nvidia-vulkan-icd seahorse-daemon totem-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  caribou cheese evolution evolution-plugins gir1.2-champlain-0.12
  gir1.2-clutter-1.0 gir1.2-clutter-gst-3.0 gir1.2-cogl-1.0
  gir1.2-coglpango-1.0 gir1.2-gtkchamplain-0.12 gir1.2-gtkclutter-1.0
  gir1.2-totem-1.0 gnome gnome-contacts gnome-control-center gnome-core
  gnome-games gnome-maps gnome-nibbles gnome-shell-extensions gnome-sushi
  gstreamer1.0-clutter-3.0 libchamplain-0.12-0 libchamplain-gtk-0.12-0
  libcheese-gtk25 libcheese8 libclutter-1.0-0 libclutter-gst-3.0-0
  libclutter-gtk-1.0-0 libcogl-pango20 libcogl-path20 libcogl20 libegl1
  libevolution libgl1-mesa-glx libglx-mesa0 libtotem0 libwayland-egl1
  lightsoff nvidia-driver nvidia-driver-libs nvidia-egl-icd quadrapassel
  swell-foop task-gnome-desktop totem totem-plugins
Les paquets suivants seront mis à une VERSION INFÉRIEURE :
  libdrm2 libegl1-mesa libwayland-egl1-mesa
0 mis à jour, 0 nouvellement installés, 3 remis à une version inférieure, 47 à enlever et 0 non mis à jour.
Remv gnome [1:3.22+3]
Remv task-gnome-desktop [3.39]
Remv gnome-core [1:3.22+3]
Remv caribou [0.4.21-1+b1]
Remv cheese [3.22.1-1+b1]
Remv evolution-plugins [3.22.6-1+deb9u1]
Remv evolution [3.22.6-1+deb9u1]
Remv gnome-maps [3.22.2-1]
Remv gir1.2-gtkchamplain-0.12 [0.12.15-1]
Remv gir1.2-champlain-0.12 [0.12.15-1]
Remv gnome-sushi [3.21.91-2]
Remv gnome-shell-extensions [3.22.2-1]
Remv gir1.2-clutter-1.0 [1.26.0+dfsg-3] [gir1.2-clutter-gst-3.0:amd64 gir1.2-gtkclutter-1.0:amd64 ]
Remv gir1.2-clutter-gst-3.0 [3.0.24-1] [gir1.2-gtkclutter-1.0:amd64 ]
Remv gir1.2-coglpango-1.0 [1.22.2-2] [gir1.2-gtkclutter-1.0:amd64 ]
Remv gir1.2-cogl-1.0 [1.22.2-2] [gir1.2-gtkclutter-1.0:amd64 ]
Remv gir1.2-gtkclutter-1.0 [1.8.2-2]
Remv totem-plugins [3.22.1-1]
Remv gir1.2-totem-1.0 [3.22.1-1]
Remv gnome-contacts [3.22.1-1+b2]
Remv gnome-control-center [1:3.22.2-3]
Remv gnome-games [1:3.22+3]
Remv gnome-nibbles [1:3.22.2.2-1]
Remv totem [3.22.1-1]
Remv libcheese-gtk25 [3.22.1-1+b1]
Remv gstreamer1.0-clutter-3.0 [3.0.24-1]
Remv libevolution [3.22.6-1+deb9u1]
Remv libchamplain-gtk-0.12-0 [0.12.15-1]
Remv libchamplain-0.12-0 [0.12.15-1]
Remv libcheese8 [3.22.1-1+b1]
Remv libtotem0 [3.22.1-1]
Remv swell-foop [1:3.22.2-1]
Remv libclutter-1.0-0 [1.26.0+dfsg-3] [libclutter-gst-3.0-0:amd64 lightsoff:amd64 quadrapassel:amd64 libclutter-gtk-1.0-0:amd64 ]
Remv libclutter-gst-3.0-0 [3.0.24-1] [lightsoff:amd64 quadrapassel:amd64 libclutter-gtk-1.0-0:amd64 ]
Remv quadrapassel [1:3.22.0-1.1] [lightsoff:amd64 libclutter-gtk-1.0-0:amd64 ]
Remv libclutter-gtk-1.0-0 [1.8.2-2] [lightsoff:amd64 ]
Remv libcogl-pango20 [1.22.2-2] [lightsoff:amd64 ]
Remv libcogl-path20 [1.22.2-2] [lightsoff:amd64 ]
Remv libcogl20 [1.22.2-2] [lightsoff:amd64 ]
Remv nvidia-driver [390.77-1~bpo9+1] [lightsoff:amd64 ]
Remv nvidia-driver-libs [390.77-1~bpo9+1] [lightsoff:amd64 ]
Inst libegl1-mesa [18.1.6-1~bpo9+1] (13.0.6-1+b2 Debian:9.5/stable [amd64]) [libegl1:amd64 on libegl1-mesa:amd64] [libegl1:amd64 lightsoff:amd64 ]
Remv libwayland-egl1 [1.15.0-2~bpo9+1] [libegl1:amd64 lightsoff:amd64 libwayland-egl1-mesa:amd64 ]
Inst libwayland-egl1-mesa [18.1.6-1~bpo9+1] (13.0.6-1+b2 Debian:9.5/stable [amd64]) [libegl1:amd64 on libegl1-mesa:amd64] [libegl1:amd64 lightsoff:amd64 ]
Remv libegl1 [1.0.0+git20180308-2~bpo9+1] [nvidia-egl-icd:amd64 lightsoff:amd64 ]
Remv nvidia-egl-icd [390.77-1~bpo9+1] [lightsoff:amd64 ]
Remv libgl1-mesa-glx [18.1.6-1~bpo9+1] [lightsoff:amd64 ]
Remv libglx-mesa0 [18.1.6-1~bpo9+1] [lightsoff:amd64 ]
Inst libdrm2 [2.4.91-2~bpo9+1] (2.4.74-1 Debian:9.5/stable [amd64]) [lightsoff:amd64 ]
Remv lightsoff [1:3.22.2-1]
Conf libegl1-mesa (13.0.6-1+b2 Debian:9.5/stable [amd64])
Conf libwayland-egl1-mesa (13.0.6-1+b2 Debian:9.5/stable [amd64])
Conf libdrm2 (2.4.74-1 Debian:9.5/stable [amd64])
 


Debian Stretch sur mes serveurs. Buster (Testing+SID) sur mon PC. Config mini ITX :
CM : ASRock Fatal1ty AB350 Gaming ITX/ac. Ram : Corsair 8GB DDR4. CPU : Ryzen 5 1600. CG : MSI GeForce GT 1030 2GH OC. 120GB SSD + 1TB pour la partition home.
Usage : programmation, bureautique, compatibilité,  photoshop (virtualisation).

Hors ligne

#11 16-09-2018 20:07:34

MoxSite
Membre
Distrib. : Debian Buster (Testing+SID)
Noyau : Linux 4.18.0-1-amd64
(G)UI : Gnome 3.30
Inscription : 28-07-2015

Re : [Résolu] Problème de dépendences pour installer certains paquets

Toujours le même problème :


sudo apt -s install libgtk-3-dev/stable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Version choisie « 3.22.11-1 » (Debian:9.5/stable [amd64]) pour « libgtk-3-dev »
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libgtk-3-dev : Dépend: libegl1-mesa-dev mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

 


Debian Stretch sur mes serveurs. Buster (Testing+SID) sur mon PC. Config mini ITX :
CM : ASRock Fatal1ty AB350 Gaming ITX/ac. Ram : Corsair 8GB DDR4. CPU : Ryzen 5 1600. CG : MSI GeForce GT 1030 2GH OC. 120GB SSD + 1TB pour la partition home.
Usage : programmation, bureautique, compatibilité,  photoshop (virtualisation).

Hors ligne

#12 16-09-2018 20:08:23

MoxSite
Membre
Distrib. : Debian Buster (Testing+SID)
Noyau : Linux 4.18.0-1-amd64
(G)UI : Gnome 3.30
Inscription : 28-07-2015

Re : [Résolu] Problème de dépendences pour installer certains paquets

sudo apt policy
Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://packages.microsoft.com/repos/vscode stable/main amd64 Packages
     release o=vscode stable,a=stable,n=stable,l=vscode stable,c=main,b=amd64
     origin packages.microsoft.com
 500 https://deb.opera.com/opera-stable stable/non-free amd64 Packages
     release o=Opera Software ASA,a=stable,n=stable,l=The Opera web browser,c=non-free,b=amd64
     origin deb.opera.com
 500 http://ftp.fr.debian.org/debian stretch-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=stretch-updates,l=Debian,c=main,b=amd64
     origin ftp.fr.debian.org
 500 http://security.debian.org/debian-security stretch/updates/non-free amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=non-free,b=amd64
     origin security.debian.org
 500 http://security.debian.org/debian-security stretch/updates/contrib amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=contrib,b=amd64
     origin security.debian.org
 500 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://ftp.fr.debian.org/debian stretch/non-free amd64 Packages
     release v=9.5,o=Debian,a=stable,n=stretch,l=Debian,c=non-free,b=amd64
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian stretch/contrib amd64 Packages
     release v=9.5,o=Debian,a=stable,n=stretch,l=Debian,c=contrib,b=amd64
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian stretch/main amd64 Packages
     release v=9.5,o=Debian,a=stable,n=stretch,l=Debian,c=main,b=amd64
     origin ftp.fr.debian.org
Paquets épinglés :
 


Debian Stretch sur mes serveurs. Buster (Testing+SID) sur mon PC. Config mini ITX :
CM : ASRock Fatal1ty AB350 Gaming ITX/ac. Ram : Corsair 8GB DDR4. CPU : Ryzen 5 1600. CG : MSI GeForce GT 1030 2GH OC. 120GB SSD + 1TB pour la partition home.
Usage : programmation, bureautique, compatibilité,  photoshop (virtualisation).

Hors ligne

#13 16-09-2018 20:50:57

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : [Résolu] Problème de dépendences pour installer certains paquets

MoxSite a écrit :

Là j'ai l'impression que ça va tout casser :


Tout a l'air de bien se passer. Mais, il est vrai que ça retire pas mal de choses.

A toi de voir.

Si tu veux faire l'opération, relance la commande sans l'option '-s'. Ensuite, essaye d'installer ton paquet.

Enfin, tu pourras nettoyer ton système de cette façon:

apt autoremove
 

Dernière modification par Beta-Pictoris (16-09-2018 20:54:41)

Hors ligne

#14 16-09-2018 20:59:59

MoxSite
Membre
Distrib. : Debian Buster (Testing+SID)
Noyau : Linux 4.18.0-1-amd64
(G)UI : Gnome 3.30
Inscription : 28-07-2015

Re : [Résolu] Problème de dépendences pour installer certains paquets

Beta-Pictoris a écrit :

MoxSite a écrit :

Là j'ai l'impression que ça va tout casser :


Tout a l'air de bien se passer. Mais, il est vrai que ça retire pas mal de choses.

A toi de voir.

Si tu veux faire l'opération, relance la commande sans l'option '-s'. Ensuite, essaye d'installer ton paquet.

Enfin, tu pourras nettoyer ton système de cette façon:

apt autoremove
 


Merci pour ton retour.

En ajoutant "/stable/" à mon paquet ou ce n'est plus nécessaire ?


Debian Stretch sur mes serveurs. Buster (Testing+SID) sur mon PC. Config mini ITX :
CM : ASRock Fatal1ty AB350 Gaming ITX/ac. Ram : Corsair 8GB DDR4. CPU : Ryzen 5 1600. CG : MSI GeForce GT 1030 2GH OC. 120GB SSD + 1TB pour la partition home.
Usage : programmation, bureautique, compatibilité,  photoshop (virtualisation).

Hors ligne

#15 16-09-2018 21:03:40

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : [Résolu] Problème de dépendences pour installer certains paquets

L'idéal serait que tu repasses un maximum de paquets en stable.
Essaye de simuler l'installation avec les versions de paquets 'stable' suivantes:

apt -s install libegl1-mesa/stable libwayland-egl1-mesa/stable libdrm2/stable nvidia-alternative/stable nvidia-driver/stable nvidia-driver-bin/stable nvidia-driver-libs/stable nvidia-egl-common/stable nvidia-egl-icd/stable nvidia-egl-wayland-common/stable nvidia-egl-wayland-icd/stable nvidia-kernel-dkms/stable nvidia-kernel-support/stable nvidia-legacy-check/stable nvidia-settings/stable nvidia-vdpau-driver/stable nvidia-vulkan-common/stable nvidia-vulkan-icd/stable update-glx/stable


J'ai mis tous les paquets nvidia pour voir ce que ça donne.

Dernière modification par Beta-Pictoris (16-09-2018 21:06:10)

Hors ligne

#16 16-09-2018 21:36:28

MoxSite
Membre
Distrib. : Debian Buster (Testing+SID)
Noyau : Linux 4.18.0-1-amd64
(G)UI : Gnome 3.30
Inscription : 28-07-2015

Re : [Résolu] Problème de dépendences pour installer certains paquets

Beta-Pictoris a écrit :

L'idéal serait que tu repasses un maximum de paquets en stable.
Essaye de simuler l'installation avec les versions de paquets 'stable' suivantes:

apt -s install libegl1-mesa/stable libwayland-egl1-mesa/stable libdrm2/stable nvidia-alternative/stable nvidia-driver/stable nvidia-driver-bin/stable nvidia-driver-libs/stable nvidia-egl-common/stable nvidia-egl-icd/stable nvidia-egl-wayland-common/stable nvidia-egl-wayland-icd/stable nvidia-kernel-dkms/stable nvidia-kernel-support/stable nvidia-legacy-check/stable nvidia-settings/stable nvidia-vdpau-driver/stable nvidia-vulkan-common/stable nvidia-vulkan-icd/stable update-glx/stable


J'ai mis tous les paquets nvidia pour voir ce que ça donne.


La commande précédente m'a supprimé (cassé ?) le pilote nvidia installé depuis backports et gnome aussi, du coup j'ai du réinstaller gnome et le pilote nouveau à la place de nvidia, car j'avais un écran noir au démarrage.

Ces commandes vont me supprimer gnome une nouvelle fois je pense. Sinon il semblerait que le kernet supérieur à 3.15 reconnaît ma carte graphique. Je vais peut-être installer un nouveau kernel + le pilote nouveau pour ne plus avoir de problème à cause du pilote nvidia.

sudo apt -s install libegl1-mesa/stable libwayland-egl1-mesa/stable libdrm2/stable nvidia-alternative/stable nvidia-driver/stable nvidia-driver-bin/stable nvidia-driver-libs/stable nvidia-egl-common/stable nvidia-egl-icd/stable nvidia-egl-wayland-common/stable nvidia-egl-wayland-icd/stable nvidia-kernel-dkms/stable nvidia-kernel-support/stable nvidia-legacy-check/stable nvidia-settings/stable nvidia-vdpau-driver/stable nvidia-vulkan-common/stable nvidia-vulkan-icd/stable update-glx/stable
[sudo]
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
libdrm2 is already the newest version (2.4.74-1).
libegl1-mesa is already the newest version (13.0.6-1+b2).
libegl1-mesa passé en « installé manuellement ».
libwayland-egl1-mesa is already the newest version (13.0.6-1+b2).
Version choisie « 13.0.6-1+b2 » (Debian:9.5/stable [amd64]) pour « libegl1-mesa »
Version choisie « 13.0.6-1+b2 » (Debian:9.5/stable [amd64]) pour « libwayland-egl1-mesa »
Version choisie « 2.4.74-1 » (Debian:9.5/stable [amd64]) pour « libdrm2 »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « nvidia-alternative »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « nvidia-legacy-check » à cause de « nvidia-alternative »
Version choisie « 0.8.3~deb9u1 » (Debian:9.5/stable [amd64]) pour « glx-alternative-nvidia » à cause de « nvidia-alternative »
Version choisie « 0.8.3~deb9u1 » (Debian:9.5/stable [amd64]) pour « glx-diversions » à cause de « glx-alternative-nvidia »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « nvidia-driver »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « nvidia-driver-bin »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « nvidia-driver-libs »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « nvidia-egl-common »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « nvidia-egl-icd »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « libegl-nvidia0 » à cause de « nvidia-egl-icd »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « nvidia-egl-wayland-common »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « nvidia-egl-wayland-icd »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « nvidia-kernel-dkms »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « nvidia-kernel-support »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « nvidia-legacy-check »
Version choisie « 384.111-1~deb9u1 » (Debian:9.5/stable [amd64]) pour « nvidia-settings »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « nvidia-vdpau-driver »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « nvidia-vulkan-common »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « nvidia-vulkan-icd »
Version choisie « 384.130-1 » (Debian:9.5/stable [amd64]) pour « libglx-nvidia0 » à cause de « nvidia-vulkan-icd »
Version choisie « 0.8.3~deb9u1 » (Debian:9.5/stable [amd64]) pour « update-glx »
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  apg bogofilter bogofilter-bdb bogofilter-common cheese-common evolution-common folks-common
  fonts-linuxlibertine fonts-sil-gentium fonts-sil-gentium-basic gir1.2-gfbgraph-0.2 gir1.2-gmenu-3.0
  gnome-control-center-data gnome-video-effects hyphen-en-us libbsh-java libclutter-1.0-common libcogl-common
  libcryptui0a libfolks-eds25 libfolks-telepathy25 libfolks25 libglapi-mesa libgnome-autoar-gtk-0-0
  libgnome-menu-3-0 libmusicbrainz5-2 libmusicbrainz5cc2v5 libnss-myhostname libpst4 libreoffice
  libreoffice-help-en-us libreoffice-librelogo libreoffice-nlpsolver libreoffice-ogltrans
  libreoffice-pdfimport libreoffice-script-provider-bsh libreoffice-script-provider-js
  libreoffice-script-provider-python libreoffice-wiki-publisher libytnef0 mousetweaks mythes-en-us
  seahorse-daemon totem-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
The following additional packages will be installed:
  dkms glx-alternative-mesa glx-alternative-nvidia glx-diversions libegl-nvidia0 libegl1-glvnd-nvidia libgl1
  libgl1-nvidia-glvnd-glx libgles-nvidia1 libgles-nvidia2 libgles1-glvnd-nvidia libglx-nvidia0 libglx0
  libnvidia-cfg1 libnvidia-egl-wayland1 libnvidia-eglcore libnvidia-glcore libnvidia-ml1 libopengl0 libvulkan1
  libxnvctrl0 nvidia-installer-cleanup nvidia-kernel-common nvidia-modprobe nvidia-persistenced nvidia-support
  xserver-xorg-video-nvidia
Paquets suggérés :
  python3-apport menu vulkan-utils
Paquets recommandés :
  nvidia-driver-libs-i386
Les paquets suivants seront ENLEVÉS :
  caribou cheese evolution evolution-plugins gir1.2-champlain-0.12 gir1.2-clutter-1.0 gir1.2-clutter-gst-3.0
  gir1.2-cogl-1.0 gir1.2-coglpango-1.0 gir1.2-gtkchamplain-0.12 gir1.2-gtkclutter-1.0 gir1.2-totem-1.0 gnome
  gnome-contacts gnome-control-center gnome-core gnome-games gnome-maps gnome-nibbles gnome-shell-extensions
  gnome-sushi gstreamer1.0-clutter-3.0 libchamplain-0.12-0 libchamplain-gtk-0.12-0 libcheese-gtk25 libcheese8
  libclutter-1.0-0 libclutter-gst-3.0-0 libclutter-gtk-1.0-0 libcogl-pango20 libcogl-path20 libcogl20
  libevolution libgl1-mesa-glx libtotem0 lightsoff quadrapassel swell-foop task-gnome-desktop totem
  totem-plugins
Les NOUVEAUX paquets suivants seront installés :
  dkms glx-alternative-mesa glx-alternative-nvidia glx-diversions libegl-nvidia0 libegl1-glvnd-nvidia libgl1
  libgl1-nvidia-glvnd-glx libgles-nvidia1 libgles-nvidia2 libgles1-glvnd-nvidia libglx-nvidia0 libglx0
  libnvidia-cfg1 libnvidia-egl-wayland1 libnvidia-eglcore libnvidia-glcore libnvidia-ml1 libopengl0 libvulkan1
  libxnvctrl0 nvidia-alternative nvidia-driver nvidia-driver-bin nvidia-driver-libs nvidia-egl-common
  nvidia-egl-icd nvidia-egl-wayland-common nvidia-egl-wayland-icd nvidia-installer-cleanup
  nvidia-kernel-common nvidia-kernel-dkms nvidia-kernel-support nvidia-legacy-check nvidia-modprobe
  nvidia-persistenced nvidia-settings nvidia-support nvidia-vdpau-driver nvidia-vulkan-common
  nvidia-vulkan-icd update-glx xserver-xorg-video-nvidia
0 mis à jour, 43 nouvellement installés, 41 à enlever et 0 non mis à jour.
Remv gnome [1:3.22+3]
Remv task-gnome-desktop [3.39]
Remv gnome-core [1:3.22+3]
Remv caribou [0.4.21-1+b1]
Remv cheese [3.22.1-1+b1]
Remv evolution-plugins [3.22.6-1+deb9u1]
Remv evolution [3.22.6-1+deb9u1]
Remv gnome-maps [3.22.2-1]
Remv gir1.2-gtkchamplain-0.12 [0.12.15-1]
Remv gir1.2-champlain-0.12 [0.12.15-1]
Remv gnome-sushi [3.21.91-2]
Remv gnome-shell-extensions [3.22.2-1]
Remv gir1.2-clutter-1.0 [1.26.0+dfsg-3] [gir1.2-clutter-gst-3.0:amd64 gir1.2-gtkclutter-1.0:amd64 ]
Remv gir1.2-clutter-gst-3.0 [3.0.24-1] [gir1.2-gtkclutter-1.0:amd64 ]
Remv gir1.2-coglpango-1.0 [1.22.2-2] [gir1.2-gtkclutter-1.0:amd64 ]
Remv gir1.2-cogl-1.0 [1.22.2-2] [gir1.2-gtkclutter-1.0:amd64 ]
Remv gir1.2-gtkclutter-1.0 [1.8.2-2]
Remv totem-plugins [3.22.1-1]
Remv gir1.2-totem-1.0 [3.22.1-1]
Remv gnome-contacts [3.22.1-1+b2]
Remv gnome-control-center [1:3.22.2-3]
Remv gnome-games [1:3.22+3]
Remv gnome-nibbles [1:3.22.2.2-1]
Remv totem [3.22.1-1]
Remv libcheese-gtk25 [3.22.1-1+b1]
Remv gstreamer1.0-clutter-3.0 [3.0.24-1]
Remv libevolution [3.22.6-1+deb9u1]
Remv libchamplain-gtk-0.12-0 [0.12.15-1]
Remv libchamplain-0.12-0 [0.12.15-1]
Remv libcheese8 [3.22.1-1+b1]
Remv libtotem0 [3.22.1-1]
Remv swell-foop [1:3.22.2-1]
Remv libclutter-1.0-0 [1.26.0+dfsg-3] [libclutter-gst-3.0-0:amd64 lightsoff:amd64 quadrapassel:amd64 libclutter-gtk-1.0-0:amd64 ]
Remv libclutter-gst-3.0-0 [3.0.24-1] [lightsoff:amd64 quadrapassel:amd64 libclutter-gtk-1.0-0:amd64 ]
Remv quadrapassel [1:3.22.0-1.1] [lightsoff:amd64 libclutter-gtk-1.0-0:amd64 ]
Remv libclutter-gtk-1.0-0 [1.8.2-2] [lightsoff:amd64 ]
Remv libcogl-pango20 [1.22.2-2] [lightsoff:amd64 ]
Remv libcogl-path20 [1.22.2-2] [lightsoff:amd64 ]
Remv libcogl20 [1.22.2-2] [lightsoff:amd64 ]
Inst nvidia-installer-cleanup (20151021+4 Debian:9.5/stable [amd64]) [lightsoff:amd64 ]
Conf nvidia-installer-cleanup (20151021+4 Debian:9.5/stable [amd64]) [lightsoff:amd64 ]
Inst nvidia-legacy-check (384.130-1 Debian:9.5/stable [amd64]) [lightsoff:amd64 ]
Inst update-glx (0.8.3~deb9u1 Debian:9.5/stable [amd64]) [lightsoff:amd64 ]
Inst glx-alternative-mesa (0.8.3~deb9u1 Debian:9.5/stable [amd64]) [lightsoff:amd64 ]
Remv libgl1-mesa-glx [13.0.6-1+b2] [openjdk-8-jre:amd64 xserver-xorg-core:amd64 libreoffice-gtk3:amd64 libreoffice-core:amd64 mesa-utils:amd64 lightsoff:amd64 libwxgtk3.0-0v5:amd64 xserver-xephyr:amd64 libreoffice-ogltrans:amd64 libreoffice-impress:amd64 libqt5gui5:amd64 libvdpau-va-gl1:amd64 libglew2.0:amd64 xwayland:amd64 libgltf-0.0-0v5:amd64 libwebkit2gtk-4.0-37:amd64 libglu1-mesa:amd64 xorg:amd64 gnome-session-bin:amd64 x11-utils:amd64 virtualbox-5.2:amd64 libgstreamer-plugins-bad1.0-0:amd64 ]
Inst libgl1 (1.0.0+git20180308-2~bpo9+1 Debian Backports:stretch-backports [amd64]) [lightsoff:amd64 ]
Inst glx-diversions (0.8.3~deb9u1 Debian:9.5/stable [amd64]) [lightsoff:amd64 ]
Inst glx-alternative-nvidia (0.8.3~deb9u1 Debian:9.5/stable [amd64]) [lightsoff:amd64 ]
Conf nvidia-legacy-check (384.130-1 Debian:9.5/stable [amd64]) [lightsoff:amd64 ]
Inst nvidia-alternative (384.130-1 Debian:9.5/stable [amd64]) [lightsoff:amd64 ]
Inst libnvidia-glcore (384.130-1 Debian:9.5/stable [amd64]) [lightsoff:amd64 ]
Inst libglx-nvidia0 (384.130-1 Debian:9.5/stable [amd64]) [lightsoff:amd64 ]
Inst libglx0 (1.0.0+git20180308-2~bpo9+1 Debian Backports:stretch-backports [amd64]) [lightsoff:amd64 ]
Remv lightsoff [1:3.22.2-1]
Inst libgl1-nvidia-glvnd-glx (384.130-1 Debian:9.5/stable [amd64])
Inst nvidia-egl-common (384.130-1 Debian:9.5/stable [amd64])
Inst libegl1-glvnd-nvidia (384.130-1 Debian:9.5/stable [amd64])
Inst libnvidia-eglcore (384.130-1 Debian:9.5/stable [amd64])
Inst libegl-nvidia0 (384.130-1 Debian:9.5/stable [amd64])
Inst nvidia-egl-icd (384.130-1 Debian:9.5/stable [amd64])
Inst nvidia-driver-libs (384.130-1 Debian:9.5/stable [amd64])
Inst libnvidia-ml1 (384.130-1 Debian:9.5/stable [amd64])
Inst nvidia-driver-bin (384.130-1 Debian:9.5/stable [amd64])
Inst nvidia-support (20151021+4 Debian:9.5/stable [amd64])
Inst xserver-xorg-video-nvidia (384.130-1 Debian:9.5/stable [amd64])
Inst nvidia-vdpau-driver (384.130-1 Debian:9.5/stable [amd64])
Inst dkms (2.3-2 Debian:9.5/stable [all])
Inst nvidia-kernel-common (20151021+4 Debian:9.5/stable [amd64])
Inst nvidia-modprobe (384.111-2~deb9u1 Debian:9.5/stable [amd64])
Inst nvidia-kernel-support (384.130-1 Debian:9.5/stable [amd64])
Inst nvidia-kernel-dkms (384.130-1 Debian:9.5/stable [amd64])
Inst nvidia-driver (384.130-1 Debian:9.5/stable [amd64])
Inst libxnvctrl0 (384.111-1~deb9u1 Debian:9.5/stable [amd64])
Inst nvidia-settings (384.111-1~deb9u1 Debian:9.5/stable [amd64])
Inst libgles1-glvnd-nvidia (384.130-1 Debian:9.5/stable [amd64])
Inst libgles-nvidia1 (384.130-1 Debian:9.5/stable [amd64])
Inst libgles-nvidia2 (384.130-1 Debian:9.5/stable [amd64])
Inst libnvidia-cfg1 (384.130-1 Debian:9.5/stable [amd64])
Inst libnvidia-egl-wayland1 (384.130-1 Debian:9.5/stable [amd64])
Inst libopengl0 (1.0.0+git20180308-2~bpo9+1 Debian Backports:stretch-backports [amd64])
Inst libvulkan1 (1.0.39.0+dfsg1-1 Debian:9.5/stable [amd64])
Inst nvidia-egl-wayland-common (384.130-1 Debian:9.5/stable [amd64])
Inst nvidia-egl-wayland-icd (384.130-1 Debian:9.5/stable [amd64])
Inst nvidia-persistenced (384.111-1~deb9u1 Debian:9.5/stable [amd64])
Inst nvidia-vulkan-common (384.130-1 Debian:9.5/stable [amd64])
Inst nvidia-vulkan-icd (384.130-1 Debian:9.5/stable [amd64])
Conf update-glx (0.8.3~deb9u1 Debian:9.5/stable [amd64])
Conf glx-alternative-mesa (0.8.3~deb9u1 Debian:9.5/stable [amd64])
Conf libgl1 (1.0.0+git20180308-2~bpo9+1 Debian Backports:stretch-backports [amd64])
Conf glx-diversions (0.8.3~deb9u1 Debian:9.5/stable [amd64])
Conf glx-alternative-nvidia (0.8.3~deb9u1 Debian:9.5/stable [amd64])
Conf nvidia-alternative (384.130-1 Debian:9.5/stable [amd64])
Conf libnvidia-glcore (384.130-1 Debian:9.5/stable [amd64])
Conf libglx-nvidia0 (384.130-1 Debian:9.5/stable [amd64])
Conf libglx0 (1.0.0+git20180308-2~bpo9+1 Debian Backports:stretch-backports [amd64])
Conf libgl1-nvidia-glvnd-glx (384.130-1 Debian:9.5/stable [amd64])
Conf nvidia-egl-common (384.130-1 Debian:9.5/stable [amd64])
Conf libegl1-glvnd-nvidia (384.130-1 Debian:9.5/stable [amd64])
Conf libnvidia-eglcore (384.130-1 Debian:9.5/stable [amd64])
Conf libegl-nvidia0 (384.130-1 Debian:9.5/stable [amd64])
Conf nvidia-egl-icd (384.130-1 Debian:9.5/stable [amd64])
Conf nvidia-driver-libs (384.130-1 Debian:9.5/stable [amd64])
Conf libnvidia-ml1 (384.130-1 Debian:9.5/stable [amd64])
Conf nvidia-driver-bin (384.130-1 Debian:9.5/stable [amd64])
Conf nvidia-support (20151021+4 Debian:9.5/stable [amd64])
Conf xserver-xorg-video-nvidia (384.130-1 Debian:9.5/stable [amd64])
Conf nvidia-vdpau-driver (384.130-1 Debian:9.5/stable [amd64])
Conf dkms (2.3-2 Debian:9.5/stable [all])
Conf nvidia-kernel-common (20151021+4 Debian:9.5/stable [amd64])
Conf nvidia-modprobe (384.111-2~deb9u1 Debian:9.5/stable [amd64])
Conf nvidia-kernel-support (384.130-1 Debian:9.5/stable [amd64])
Conf nvidia-kernel-dkms (384.130-1 Debian:9.5/stable [amd64])
Conf nvidia-driver (384.130-1 Debian:9.5/stable [amd64])
Conf libxnvctrl0 (384.111-1~deb9u1 Debian:9.5/stable [amd64])
Conf nvidia-settings (384.111-1~deb9u1 Debian:9.5/stable [amd64])
Conf libgles1-glvnd-nvidia (384.130-1 Debian:9.5/stable [amd64])
Conf libgles-nvidia1 (384.130-1 Debian:9.5/stable [amd64])
Conf libgles-nvidia2 (384.130-1 Debian:9.5/stable [amd64])
Conf libnvidia-cfg1 (384.130-1 Debian:9.5/stable [amd64])
Conf libnvidia-egl-wayland1 (384.130-1 Debian:9.5/stable [amd64])
Conf libopengl0 (1.0.0+git20180308-2~bpo9+1 Debian Backports:stretch-backports [amd64])
Conf libvulkan1 (1.0.39.0+dfsg1-1 Debian:9.5/stable [amd64])
Conf nvidia-egl-wayland-common (384.130-1 Debian:9.5/stable [amd64])
Conf nvidia-egl-wayland-icd (384.130-1 Debian:9.5/stable [amd64])
Conf nvidia-persistenced (384.111-1~deb9u1 Debian:9.5/stable [amd64])
Conf nvidia-vulkan-common (384.130-1 Debian:9.5/stable [amd64])
Conf nvidia-vulkan-icd (384.130-1 Debian:9.5/stable [amd64])
 


Debian Stretch sur mes serveurs. Buster (Testing+SID) sur mon PC. Config mini ITX :
CM : ASRock Fatal1ty AB350 Gaming ITX/ac. Ram : Corsair 8GB DDR4. CPU : Ryzen 5 1600. CG : MSI GeForce GT 1030 2GH OC. 120GB SSD + 1TB pour la partition home.
Usage : programmation, bureautique, compatibilité,  photoshop (virtualisation).

Hors ligne

#17 16-09-2018 22:05:00

MoxSite
Membre
Distrib. : Debian Buster (Testing+SID)
Noyau : Linux 4.18.0-1-amd64
(G)UI : Gnome 3.30
Inscription : 28-07-2015

Re : [Résolu] Problème de dépendences pour installer certains paquets

Bon, j'ai réglé le problème. Le coupable c'était le pilote nvidia qui installait des paquets d'une version compatible avec mon paquet (GTK+ ou Qt). Du coup j'ai désinstallé le pilote nividia, installé le pilote nouveau et surtout le Kernel 4.17 depuis le dépôt backports, qui lui reconnaît ma carte graphique. Du coup j'ai pu installé le paquet "libgtk-3-dev" sans problème et tous les autres paquets nécessaires pour programmer en utilisant GTk+ :-).

Au passage, pour ceux qui galèrent avec la carte "MSI GeForce GT 1030 2GH OC", faut installer le dernier kernel de préférence.

Merci d'avoir essayé de m'aider.

Dernière modification par MoxSite (16-09-2018 22:06:53)


Debian Stretch sur mes serveurs. Buster (Testing+SID) sur mon PC. Config mini ITX :
CM : ASRock Fatal1ty AB350 Gaming ITX/ac. Ram : Corsair 8GB DDR4. CPU : Ryzen 5 1600. CG : MSI GeForce GT 1030 2GH OC. 120GB SSD + 1TB pour la partition home.
Usage : programmation, bureautique, compatibilité,  photoshop (virtualisation).

Hors ligne

Pied de page des forums