Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-10-2018 10:50:17

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Dépendances cassées sur serveur en production, dépendances python

Bonjour,
j'ai un grave soucis, si vous pouvez m'aider...
Sur un serveur en production que l'on vient d'upgrader de Debian 7 Wheezy à Debian 8 Jessie, des soucis déjà avec les lises à jour de python et python-django pour un serveur mumble (non-résolu encore); mais surtout après avoir essayé d'installer certbot, c'est la catastrophe.
Après avoir lancé un

apt-get install python-certbot-apache -t jessie-backports


...................................................................
E: Sub-process /usr/bin/dpkg returned an error code (1)


des paquets python auraient du aussi être upgrader vers une version backport, je suis coincé...
la dernière tentative mise à jour renvoi ceci:

apt upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
18 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/681 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Paramétrage de python-augeas (0.5.0-1~bpo8+1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-augeas (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: erreur de traitement du paquet python-cffi (--configure) :
 le paquet est dans un état vraiment incohérent; vous devriez
 le réinstaller avant de tenter de le configurer.
Paramétrage de python-configargparse (0.11.0-1~bpo8+1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-configargparse (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: erreur de traitement du paquet python-pkg-resources (--configure) :
 le paquet est dans un état vraiment incohérent; vous devriez
 le réinstaller avant de tenter de le configurer.
dpkg: erreur de traitement du paquet python-six (--configure) :
 le paquet est dans un état vraiment incohérent; vous devriez
 le réinstaller avant de tenter de le configurer.
dpkg: des problèmes de dépendances empêchent la configuration de python-cryptography :
 python-cryptography dépend de python-cffi ; cependant :
 Le paquet python-cffi n'est pas encore configuré.
 python-cryptography dépend de python-pkg-resources ; cependant :
 Le paquet python-pkg-resources n'est pas encore configuré.
 python-cryptography dépend de python-six ; cependant :
 Le paquet python-six n'est pas encore configuré.

dpkg: erreur de traitement du paquet python-cryptography (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de python-dnspython (1.15.0-1~bpo8+1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-dnspython (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de python-enum34 (1.0.3-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-enum34 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de python-funcsigs (1.0.2-3~bpo8+1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-funcsigs (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de python-idna (2.0-3~bpo8+1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-idna (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de python-ipaddress (1.0.16-1~bpo8+1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-ipaddress (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de python-openssl :
 python-openssl dépend de python-cryptography ; cependant :
 Le paquet python-cryptography n'est pas encore configuré.
 python-openssl dépend de python-six ; cependant :
 Le paquet python-six n'est pas encore configuré.

dpkg: erreur de traitement du paquet python-openssl (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de python-parsedatetime (1.4-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-parsedatetime (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de python-psutil (4.1.0-1~bpo8+1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-psutil (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: erreur de traitement du paquet python-pyasn1 (--configure) :
 le paquet est dans un état vraiment incohérent; vous devriez
 le réinstaller avant de tenter de le configurer.
Paramétrage de python-pyicu (1.8-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-pyicu (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de python-rfc3339 (1.0-4~bpo8+1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-rfc3339 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de python-setuptools :
 python-setuptools dépend de python-pkg-resources (= 5.5.1-1) ; cependant :
 Le paquet python-pkg-resources n'est pas encore configuré.

dpkg: erreur de traitement du paquet python-setuptools (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 python-augeas
 python-cffi
 python-configargparse
 python-pkg-resources
 python-six
 python-cryptography
 python-dnspython
 python-enum34
 python-funcsigs
 python-idna
 python-ipaddress
 python-openssl
 python-parsedatetime
 python-psutil
 python-pyasn1
 python-pyicu
 python-rfc3339
 python-setuptools




J'ai essayé tout pour m'en sortir un peu en panique.

apt-get autoclean

,

apt-get clean

,

apt -f install

,
supprimer aussi les fichier .posinst de paquets concernés dans /var/lib/dpkg/info/, avant de lancer

apt-get -f install

, j'ai essayé de revenir en arrière, aussi un

dpkg --remove --force-remove-reinstreq python-augeas python-cffi python-six python-cryptography python-pyasn1 python-setuptools python-openssl pyrhon-certbot

, j'ai aussi essayé avec aptitude, échec récurrent

Je vous donne l'historique des commandes apt da /var/log/apt/history.log:

Start-Date: 2018-10-03  23:44:02
Commandline: apt-get install python-certbot-apache -t jessie-backports
Install: python-funcsigs:amd64 (1.0.2-3~bpo8+1, automatic), python-acme:amd64 (0.10.2-1~bpo8+2, automatic), python-mock:amd64 (2.0.0-3~bpo8+1, automatic), python-pbr:amd64 (1.8.0-4.1~bpo8+1, automatic), python-certbot:amd64 (0.10.2-1~bpo8+1, automatic), python-dnspython:amd64 (1.15.0-1~bpo8+1, automatic), python-configargparse:amd64 (0.11.0-1~bpo8+1, automatic), certbot:amd64 (0.10.2-1~bpo8+1, automatic), python-psutil:amd64 (4.1.0-1~bpo8+1, automatic), python-pyicu:amd64 (1.8-1, automatic), python-cffi-backend:amd64 (1.9.1-2~bpo8+1, automatic), python-zope.component:amd64 (4.2.1-2, automatic), python-augeas:amd64 (0.5.0-1~bpo8+1, automatic), python-certbot-apache:amd64 (0.10.2-1~bpo8+1), python-zope.interface:amd64 (4.1.1-3.1, automatic), python-configobj:amd64 (5.0.6-1, automatic), python-zope.event:amd64 (4.0.3-2, automatic), python-idna:amd64 (2.0-3~bpo8+1, automatic), python-ipaddress:amd64 (1.0.16-1~bpo8+1, automatic), python-parsedatetime:amd64 (1.4-1, automatic), python-enum34:amd64 (1.0.3-1, automatic), python-rfc3339:amd64 (1.0-4~bpo8+1, automatic)
Upgrade: python-cffi:amd64 (0.8.6-1, 1.9.1-2~bpo8+1), python-pyasn1:amd64 (0.1.7-1, 0.1.9-1~bpo8+1), python-pkg-resources:amd64 (5.5.1-1, 33.1.1-1~bpo8+1), python-setuptools:amd64 (5.5.1-1, 33.1.1-1~bpo8+1), python-cryptography:amd64 (0.6.1-1+deb8u1, 1.7.1-3~bpo8+1), python-six:amd64 (1.8.0-1, 1.10.0-3~bpo8+1), python-openssl:amd64 (0.14-1, 16.0.0-1~bpo8+1)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-10-03  23:44:19

Start-Date: 2018-10-03  23:55:08
Commandline: apt-get -f install
Remove: python-acme:amd64 (0.10.2-1~bpo8+2), python-mock:amd64 (2.0.0-3~bpo8+1), python-pbr:amd64 (1.8.0-4.1~bpo8+1), python-certbot:amd64 (0.10.2-1~bpo8+1), certbot:amd64 (0.10.2-1~bpo8+1), python-cffi-backend:amd64 (1.9.1-2~bpo8+1), python-certbot-apache:amd64 (0.10.2-1~bpo8+1)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-10-03  23:55:16

Start-Date: 2018-10-03  23:57:05
Commandline: apt remove python-certbot-apache -t jessie-backports
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-10-03  23:57:06

Start-Date: 2018-10-03  23:58:37
Commandline: apt-get autoremove
Remove: python-funcsigs:amd64 (1.0.2-3~bpo8+1), python-dnspython:amd64 (1.15.0-1~bpo8+1), python-configargparse:amd64 (0.11.0-1~bpo8+1), python-psutil:amd64 (4.1.0-1~bpo8+1), python-pyicu:amd64 (1.8-1), python-zope.component:amd64 (4.2.1-2), python-augeas:amd64 (0.5.0-1~bpo8+1), python-zope.interface:amd64 (4.1.1-3.1), python-configobj:amd64 (5.0.6-1), python-zope.event:amd64 (4.0.3-2), python-idna:amd64 (2.0-3~bpo8+1), python-ipaddress:amd64 (1.0.16-1~bpo8+1), python-parsedatetime:amd64 (1.4-1), python-enum34:amd64 (1.0.3-1), python-rfc3339:amd64 (1.0-4~bpo8+1)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-10-03  23:58:39

Start-Date: 2018-10-04  00:01:51
Commandline: apt-get -f install
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-10-04  00:01:53

Start-Date: 2018-10-04  00:15:02
Commandline: apt-get autoremove
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-10-04  00:15:04

Start-Date: 2018-10-04  00:15:41
Commandline: apt install -f
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-10-04  00:15:43

Start-Date: 2018-10-04  00:18:06
Commandline: apt upgrade
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-10-04  00:18:08

Start-Date: 2018-10-04  01:08:53
Commandline: apt-get --purge remove
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-10-04  01:08:54

Start-Date: 2018-10-04  01:12:40
Commandline: apt-get autoremove
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-10-04  01:12:41

Start-Date: 2018-10-04  01:18:03
Commandline: apt-get -f install
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-10-04  01:18:05

Start-Date: 2018-10-04  01:23:13
Commandline: apt-get -f install
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-10-04  01:23:14

Start-Date: 2018-10-04  02:04:17
Commandline: apt upgrade
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-10-04  02:04:19

Start-Date: 2018-10-04  10:23:34
Commandline: apt upgrade
Upgrade: imagemagick-6.q16:amd64 (6.8.9.9-5+deb8u13, 6.8.9.9-5+deb8u14), imagemagick:amd64 (6.8.9.9-5+deb8u13, 6.8.9.9-5+deb8u14), libmagickwand-6.q16-2:amd64 (6.8.9.9-5+deb8u13, 6.8.9.9-5+deb8u14), imagemagick-common:amd64 (6.8.9.9-5+deb8u13, 6.8.9.9-5+deb8u14), libmagickcore-6.q16-2-extra:amd64 (6.8.9.9-5+deb8u13, 6.8.9.9-5+deb8u14), libmagickcore-6.q16-2:amd64 (6.8.9.9-5+deb8u13, 6.8.9.9-5+deb8u14)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-10-04  10:23:52

Start-Date: 2018-10-04  10:40:49
Commandline: apt upgrade
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-10-04  10:40:51



Bref, comment m'en sortir ???

Dernière modification par rodinux (04-10-2018 11:39:18)


La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#2 04-10-2018 11:05:10

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : Dépendances cassées sur serveur en production, dépendances python

Que donne ? :

apt --installed list | grep -v '/stable'


Que donne ? :

apt policy


As tu fait une sauvegarde de ton système ?
.

Dernière modification par Beta-Pictoris (04-10-2018 11:07:41)

Hors ligne

#3 04-10-2018 11:16:23

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Dépendances cassées sur serveur en production, dépendances python

Pour upgrader, as-tu utilisé la commande apt-get comme il a été recommandé de le faire entre ces deux branches anciennes ?
Ceci dit pour que tu testes avec cette commande... Si ça pouvait arranger le truc. smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 04-10-2018 12:04:11

Invité-X
Invité

Re : Dépendances cassées sur serveur en production, dépendances python

Juste une question

tu veut tout passer en debian 8?

j'ai un tuto réparation ou tu regarde mes recents posts qui explique comment sauver une debian.

#5 04-10-2018 12:10:12

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : Dépendances cassées sur serveur en production, dépendances python

Beta-Pictoris a écrit :

Que donne ? :

apt --installed list | grep -v '/stable'



je narrive pas à tout voir la liste est trop longue...
en fin je vois ceci:

liblqr-1-0/oldstable,now 0.4.2-2 amd64  [installé, automatique]
liblsan0/oldstable,oldstable,now 4.9.2-10+deb8u1 amd64  [installé]
libltdl-dev/oldstable,now 2.4.2-1.11+b1 amd64  [installé, automatique]
libltdl7/oldstable,now 2.4.2-1.11+b1 amd64  [installé, automatique]
liblua5.1-0/oldstable,now 5.1.5-7.1 amd64  [installé, automatique]
liblua5.2-0/oldstable,now 5.2.3-1.1 amd64  [installé]
liblwp-mediatypes-perl/oldstable,now 6.02-1 all  [installé, automatique]
liblwp-protocol-https-perl/oldstable,now 6.06-2 all  [installé, automatique]
liblwres80/now 1:9.8.4.dfsg.P1-6+nmu2+deb7u20 amd64  [installé, local]
liblwres90/oldstable,now 1:9.9.5.dfsg-9+deb8u16 amd64  [installé]
liblzma5/oldstable,now 5.1.1alpha+20120614-2+b3 amd64  [installé]
libmagic1/oldstable,now 1:5.22+15-2+deb8u4 amd64  [installé]
libmagickcore-6.q16-2/oldstable,now 8:6.8.9.9-5+deb8u14 amd64  [installé]
libmagickcore-6.q16-2-extra/oldstable,now 8:6.8.9.9-5+deb8u14 amd64  [installé]
libmagickwand-6.q16-2/oldstable,now 8:6.8.9.9-5+deb8u14 amd64  [installé]
libmail-sendmail-perl/oldstable,now 0.79.16-1 all  [installé]
libmailtools-perl/oldstable,now 2.13-1 all  [installé, automatique]
libmcpp0/oldstable,now 2.7.2-4 amd64  [installé, automatique]
libmcrypt4/oldstable,now 2.5.8-3.3 amd64  [installé, automatique]
libmime-lite-perl/oldstable,now 3.030-2 all  [installé]
libmime-types-perl/oldstable,now 2.09-3 all  [installé]
libmodule-build-perl/oldstable,oldstable,now 0.421000-2+deb8u1 all  [installé]
libmodule-implementation-perl/oldstable,now 0.09-1 all  [installé]
libmodule-pluggable-perl/oldstable,now 5.1-1 all  [installé]
libmodule-runtime-perl/oldstable,now 0.014-1 all  [installé]
libmodule-signature-perl/oldstable,oldstable,now 0.73-1+deb8u2 all  [installé]
libmount1/oldstable,now 2.25.2-6 amd64  [installé]
libmpc2/now 0.9-4 amd64  [installé, local]
libmpc3/oldstable,now 1.0.2-1 amd64  [installé]
libmpdec2/oldstable,now 2.4.1-1 amd64  [installé]
libmpfr4/oldstable,now 3.1.2-2 amd64  [installé]
libmro-compat-perl/oldstable,now 0.12-1 all  [installé]
libmysqlclient18/oldstable,oldstable,now 5.5.60-0+deb8u1 amd64  [installé, automatique]
libnamespace-clean-perl/oldstable,now 0.25-1 all  [installé]
libncurses5/oldstable,now 5.9+20140913-1+deb8u3 amd64  [installé]
libncursesw5/oldstable,now 5.9+20140913-1+deb8u3 amd64  [installé]
libnet-cidr-perl/oldstable,now 0.17-1 all  [installé]
libnet-http-perl/oldstable,now 6.07-1 all  [installé, automatique]
libnet-server-perl/oldstable,now 2.008-1 all  [installé]
libnet-smtp-ssl-perl/oldstable,now 1.01-3 all  [installé]
libnet-snmp-perl/oldstable,now 6.0.1-2 all  [installé, automatique]
libnet-ssleay-perl/oldstable,now 1.65-1+deb8u1 amd64  [installé, automatique]
libnetpbm10/oldstable,now 2:10.0-15.2 amd64  [installé, automatique]
libnettle4/oldstable,now 2.7.1-5+deb8u2 amd64  [installé]
libnfnetlink0/oldstable,now 1.0.1-3 amd64  [installé, automatique]
libnfsidmap2/oldstable,now 0.25-5 amd64  [installé]
libnspr4/oldstable,oldstable,now 2:4.12-1+debu8u1 amd64  [installé]
libnss-mdns/oldstable,now 0.10-6 amd64  [installé, automatique]
libnss3/oldstable,oldstable,now 2:3.26-1+debu8u3 amd64  [installé]
libnuma1/oldstable,now 2.0.10-1 amd64  [installé]
libogg0/oldstable,now 1.3.2-1 amd64  [installé]
libonig2/oldstable,now 5.9.5-3.2+deb8u1 amd64  [installé, automatique]
libopenexr6/oldstable,now 1.6.1-8 amd64  [installé, automatique]
libp11-kit0/oldstable,now 0.20.7-1 amd64  [installé, automatique]
libpackage-constants-perl/oldstable,now 0.04-1 all  [installé]
libpackage-deprecationmanager-perl/oldstable,now 0.13-1 all  [installé]
libpackage-stash-perl/oldstable,now 0.37-1 all  [installé]
libpackage-stash-xs-perl/oldstable,now 0.28-2+b1 amd64  [installé]
libpam-cap/oldstable,now 1:2.24-8 amd64  [installé]
libpam-ck-connector/oldstable,now 0.4.6-5 amd64  [installé]
libpam-modules/oldstable,now 1.1.8-3.1+deb8u2+b1 amd64  [installé]
libpam-modules-bin/oldstable,now 1.1.8-3.1+deb8u2+b1 amd64  [installé]
libpam-runtime/oldstable,now 1.1.8-3.1+deb8u2 all  [installé]
libpam-systemd/oldstable,now 215-17+deb8u7 amd64  [installé]
libpam0g/oldstable,now 1.1.8-3.1+deb8u2+b1 amd64  [installé]
libpango-1.0-0/oldstable,now 1.36.8-3 amd64  [installé]
libpangocairo-1.0-0/oldstable,now 1.36.8-3 amd64  [installé]
libpangoft2-1.0-0/oldstable,now 1.36.8-3 amd64  [installé]
libpangox-1.0-0/oldstable,now 0.0.2-5 amd64  [installé]
libpangoxft-1.0-0/oldstable,now 1.36.8-3 amd64  [installé]
libpaper-utils/oldstable,now 1.1.24+nmu4 amd64  [installé, automatique]
libpaper1/oldstable,now 1.1.24+nmu4 amd64  [installé, automatique]
libparams-classify-perl/oldstable,now 0.013-4+b2 amd64  [installé]
libparams-util-perl/oldstable,now 1.07-2+b1 amd64  [installé]
libparams-validate-perl/oldstable,now 1.13-1+b1 amd64  [installé]
libparse-debianchangelog-perl/oldstable,now 1.2.0-1.1 all  [installé, automatique]
libparted2/oldstable,now 3.2-7 amd64  [installé]
libpcap0.8/oldstable,now 1.6.2-2 amd64  [installé, automatique]
libpci3/oldstable,now 1:3.2.1-3 amd64  [installé]
libpcre3/oldstable,now 2:8.35-3.3+deb8u4 amd64  [installé]
libpcre3-dev/oldstable,now 2:8.35-3.3+deb8u4 amd64  [installé]
libpcrecpp0/oldstable,now 2:8.35-3.3+deb8u4 amd64  [installé]
libpcsclite1/oldstable,oldstable,now 1.8.13-1+deb8u1 amd64  [installé, automatique]
libperl4-corelibs-perl/oldstable,now 0.003-1 all  [installé]
libperl5.20/oldstable,oldstable,now 5.20.2-3+deb8u11 amd64  [installé]
libpipeline1/oldstable,now 1.4.0-1 amd64  [installé, automatique]
libpixman-1-0/oldstable,now 0.32.6-3 amd64  [installé, automatique]
libpng12-0/oldstable,now 1.2.50-2+deb8u3 amd64  [installé, automatique]
libpod-latex-perl/oldstable,now 0.61-1 all  [installé]
libpod-readme-perl/oldstable,now 0.11-1 all  [installé]
libpolkit-gobject-1-0/oldstable,now 0.105-15~deb8u3 amd64  [installé]
libpopt0/oldstable,now 1.16-10 amd64  [installé, automatique]
libpq5/oldstable,now 9.4.19-0+deb8u1 amd64  [installé, automatique]
libprocps0/now 1:3.3.3-3+deb7u1 amd64  [installé, local]
libprocps3/oldstable,oldstable,now 2:3.3.9-9+deb8u1 amd64  [installé]
libprotobuf9/oldstable,now 2.6.1-1 amd64  [installé]
libpsl0/oldstable,now 0.5.1-1 amd64  [installé]
libpulse0/oldstable,now 5.0-13 amd64  [installé]
libpython-dev/oldstable,now 2.7.9-1 amd64  [installé]
libpython-stdlib/oldstable,now 2.7.9-1 amd64  [installé]
libpython2.7/oldstable,now 2.7.9-2+deb8u2 amd64  [installé, automatique]
libpython2.7-dev/oldstable,now 2.7.9-2+deb8u2 amd64  [installé]
libpython2.7-minimal/oldstable,now 2.7.9-2+deb8u2 amd64  [installé]
libpython2.7-stdlib/oldstable,now 2.7.9-2+deb8u2 amd64  [installé]
libpython3-stdlib/oldstable,now 3.4.2-2 amd64  [installé]
libpython3.4/oldstable,now 3.4.2-1+deb8u1 amd64  [installé, automatique]
libpython3.4-minimal/oldstable,now 3.4.2-1+deb8u1 amd64  [installé]
libpython3.4-stdlib/oldstable,now 3.4.2-1+deb8u1 amd64  [installé]
libqca2/oldstable,now 2.0.3-6 amd64  [installé, automatique]
libqca2-plugin-cyrus-sasl/oldstable,now 2.0.0-beta3-2 amd64  [installé]
libqdbm14/oldstable,now 1.8.78-5+b1 amd64  [installé, automatique]
libqt4-dbus/oldstable,now 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 amd64  [installé, automatique]
libqt4-network/oldstable,now 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 amd64  [installé, automatique]
libqt4-sql/oldstable,now 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 amd64  [installé, automatique]
libqt4-sql-mysql/oldstable,now 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 amd64  [installé, automatique]
libqt4-sql-sqlite/oldstable,now 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 amd64  [installé, automatique]
libqt4-xml/oldstable,now 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 amd64  [installé, automatique]
libqtcore4/oldstable,now 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 amd64  [installé, automatique]
libqtdbus4/oldstable,now 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 amd64  [installé, automatique]
libquadmath0/oldstable,oldstable,now 4.9.2-10+deb8u1 amd64  [installé]
libreadline5/oldstable,now 5.2+dfsg-2 amd64  [installé, automatique]
libreadline6/oldstable,now 6.3-8+b3 amd64  [installé]
librecode0/oldstable,now 3.6-21 amd64  [installé, automatique]
libregexp-common-perl/oldstable,now 2013031301-1 all  [installé]
librrd4/oldstable,now 1.4.8-1.2 amd64  [installé]
librrds-perl/oldstable,now 1.4.8-1.2 amd64  [installé]
librsvg2-2/oldstable,oldstable,now 2.40.5-1+deb8u2 amd64  [installé, automatique]
librsvg2-common/oldstable,oldstable,now 2.40.5-1+deb8u2 amd64  [installé, automatique]
librtmp1/oldstable,oldstable,now 2.4+20150115.gita107cef-1+deb8u1 amd64  [installé]
libsasl2-2/oldstable,oldstable,now 2.1.26.dfsg1-13+deb8u1 amd64  [installé, automatique]
libsasl2-modules/oldstable,oldstable,now 2.1.26.dfsg1-13+deb8u1 amd64  [installé]
libsasl2-modules-db/oldstable,oldstable,now 2.1.26.dfsg1-13+deb8u1 amd64  [installé]
libsasl2-modules-sql/oldstable,oldstable,now 2.1.26.dfsg1-13+deb8u1 amd64  [installé]
libselinux1/oldstable,now 2.3-2 amd64  [installé]
libsemanage-common/oldstable,now 2.3-1 all  [installé]
libsemanage1/oldstable,now 2.3-1+b1 amd64  [installé]
libsensors4/oldstable,now 1:3.3.5-2 amd64  [installé, automatique]
libsepol1/oldstable,now 2.3-2 amd64  [installé]
libsigc++-2.0-0c2a/oldstable,now 2.4.0-1 amd64  [installé, automatique]
libsigsegv2/oldstable,now 2.10-4+b1 amd64  [installé, automatique]
libslang2/oldstable,now 2.3.0-2 amd64  [installé]
libslice35/oldstable,now 3.5.1-6+b3 amd64  [installé]
libsm6/oldstable,now 2:1.2.2-1+b1 amd64  [installé, automatique]
libsmartcols1/oldstable,now 2.25.2-6 amd64  [installé]
libsndfile1/oldstable,now 1.0.25-9.1+deb8u1 amd64  [installé]
libsnmp-base/oldstable,oldstable,now 5.7.2.1+dfsg-1+deb8u1 all  [installé, automatique]
libsnmp30/oldstable,oldstable,now 5.7.2.1+dfsg-1+deb8u1+b1 amd64  [installé]
libsocket-perl/oldstable,now 2.016-1 amd64  [installé, automatique]
libsocket6-perl/oldstable,now 0.25-1+b1 amd64  [installé, automatique]
libsoftware-license-perl/oldstable,now 0.103010-3 all  [installé]
libsqlite3-0/oldstable,now 3.8.7.1-1+deb8u2 amd64  [installé]
libss2/oldstable,now 1.42.12-2+b1 amd64  [installé]
libssh2-1/oldstable,oldstable,now 1.4.3-4.1+deb8u1 amd64  [installé, automatique]
libssl-dev/oldstable,now 1.0.1t-1+deb8u9 amd64  [installé]
libssl-doc/oldstable,now 1.0.1t-1+deb8u9 all  [installé, automatique]
libssl1.0.0/oldstable,now 1.0.1t-1+deb8u9 amd64  [installé]
libstdc++-4.9-dev/oldstable,oldstable,now 4.9.2-10+deb8u1 amd64  [installé]
libstdc++6/oldstable,oldstable,now 4.9.2-10+deb8u1 amd64  [installé]
libsub-exporter-perl/oldstable,now 0.986-1 all  [installé]
libsub-exporter-progressive-perl/oldstable,now 0.001011-1 all  [installé]
libsub-identify-perl/oldstable,now 0.08-1 amd64  [installé]
libsub-install-perl/oldstable,now 0.928-1 all  [installé]
libsub-name-perl/oldstable,now 0.12-1 amd64  [installé, automatique]
libsvm-tools/oldstable,now 3.12-1 amd64  [installé, automatique]
libswitch-perl/oldstable,now 2.17-2 all  [installé]
libsys-hostname-long-perl/oldstable,now 1.4-3 all  [installé]
libsystemd-login0/oldstable,now 215-17+deb8u7 amd64  [installé]
libsystemd0/oldstable,now 215-17+deb8u7 amd64  [installé]
libtasn1-6/oldstable,oldstable,now 4.2-3+deb8u3 amd64  [installé]
libterm-readkey-perl/oldstable,now 2.32-1+b1 amd64  [installé]
libterm-ui-perl/oldstable,now 0.42-1 all  [installé]
libtext-charwidth-perl/oldstable,now 0.04-7+b3 amd64  [installé]
libtext-iconv-perl/oldstable,now 1.7-5+b2 amd64  [installé]
libtext-soundex-perl/oldstable,now 3.4-1+b2 amd64  [installé]
libtext-template-perl/oldstable,now 1.46-1 all  [installé]
libtext-wrapi18n-perl/oldstable,now 0.06-7 all  [installé]
libthai-data/oldstable,now 0.1.21-1 all  [installé, automatique]
libthai0/oldstable,now 0.1.21-1 amd64  [installé, automatique]
libtidy-0.99-0/oldstable,oldstable,now 20091223cvs-1.4+deb8u1 amd64  [installé, automatique]
libtiff5/oldstable,now 4.0.3-12.3+deb8u6 amd64  [installé]
libtimedate-perl/oldstable,now 2.3000-2 all  [installé]
libtinfo5/oldstable,now 5.9+20140913-1+deb8u3 amd64  [installé]
libtirpc1/oldstable,now 0.2.5-1+deb8u2 amd64  [installé]
libtool/oldstable,now 2.4.2-1.11 all  [installé, automatique]
libtry-tiny-perl/oldstable,now 0.22-1 all  [installé]
libtsan0/oldstable,oldstable,now 4.9.2-10+deb8u1 amd64  [installé]
libubsan0/oldstable,oldstable,now 4.9.2-10+deb8u1 amd64  [installé]
libudev0/now 175-7.2 amd64  [installé, local]
libudev1/oldstable,now 215-17+deb8u7 amd64  [installé]
libunistring0/oldstable,now 0.9.3-5.2+b1 amd64  [installé]
liburi-perl/oldstable,now 1.64-1 all  [installé, automatique]
libusb-0.1-4/oldstable,now 2:0.1.12-25 amd64  [installé]
libusb-1.0-0/oldstable,now 2:1.0.19-1 amd64  [installé]
libustr-1.0-1/oldstable,now 1.0.4-3+b2 amd64  [installé]
libuuid1/oldstable,now 2.25.2-6 amd64  [installé]
libv8-3.14.5/oldstable,now 3.14.5.8-8.1 amd64  [installé]
libvariable-magic-perl/oldstable,now 0.55-1 amd64  [installé]
libvorbis0a/oldstable,oldstable,now 1.3.4-2+deb8u1 amd64  [installé]
libvorbisenc2/oldstable,oldstable,now 1.3.4-2+deb8u1 amd64  [installé]
libvpx1/oldstable,oldstable,now 1.3.0-3+deb8u1 amd64  [installé]
libwebp5/oldstable,now 0.4.1-1.2+b2 amd64  [installé]
libwebpdemux1/oldstable,now 0.4.1-1.2+b2 amd64  [installé]
libwebpmux1/oldstable,now 0.4.1-1.2+b2 amd64  [installé]
libwmf0.2-7/oldstable,now 0.2.8.4-10.3+deb8u2 amd64  [installé, automatique]
libwrap0/oldstable,now 7.6.q-25 amd64  [installé, automatique]
libwww-perl/oldstable,now 6.08-1 all  [installé, automatique]
libwww-robotrules-perl/oldstable,now 6.01-1 all  [installé, automatique]
libx11-6/oldstable,now 2:1.6.2-3+deb8u2 amd64  [installé]
libx11-data/oldstable,now 2:1.6.2-3+deb8u2 all  [installé]
libx11-xcb1/oldstable,now 2:1.6.2-3+deb8u2 amd64  [installé]
libxapian22/oldstable,now 1.2.19-1+deb8u1 amd64  [installé, automatique]
libxau6/oldstable,now 1:1.0.8-1 amd64  [installé]
libxaw7/oldstable,now 2:1.0.12-2+b1 amd64  [installé, automatique]
libxcb-render0/oldstable,now 1.10-3+b1 amd64  [installé, automatique]
libxcb-shm0/oldstable,now 1.10-3+b1 amd64  [installé, automatique]
libxcb1/oldstable,now 1.10-3+b1 amd64  [installé]
libxcomposite1/oldstable,now 1:0.4.4-1 amd64  [installé]
libxcursor1/oldstable,now 1:1.1.14-1+deb8u2 amd64  [installé]
libxdamage1/oldstable,now 1:1.1.4-2+b1 amd64  [installé]
libxdmcp6/oldstable,now 1:1.1.1-1+b1 amd64  [installé]
libxext6/oldstable,now 2:1.3.3-1 amd64  [installé, automatique]
libxfixes3/oldstable,now 1:5.0.1-2+deb8u1 amd64  [installé]
libxft2/oldstable,now 2.3.2-1 amd64  [installé, automatique]
libxi6/oldstable,now 2:1.7.4-1+deb8u1 amd64  [installé]
libxinerama1/oldstable,now 2:1.1.3-1+b1 amd64  [installé]
libxml-namespacesupport-perl/oldstable,now 1.11-1 all  [installé, automatique]
libxml-parser-perl/oldstable,now 2.41-3 amd64  [installé, automatique]
libxml-sax-base-perl/oldstable,now 1.07-1 all  [installé, automatique]
libxml-sax-expat-perl/oldstable,now 0.40-2 all  [installé, automatique]
libxml-sax-perl/oldstable,now 0.99+dfsg-2 all  [installé, automatique]
libxml-simple-perl/oldstable,now 2.20-1 all  [installé, automatique]
libxml2/oldstable,now 2.9.1+dfsg1-5+deb8u7 amd64  [installé]
libxmu6/oldstable,now 2:1.1.2-1 amd64  [installé, automatique]
libxmuu1/oldstable,now 2:1.1.2-1 amd64  [installé, automatique]
libxpm4/oldstable,oldstable,now 1:3.5.12-0+deb8u1 amd64  [installé, automatique]
libxrandr2/oldstable,now 2:1.4.2-1+deb8u1 amd64  [installé]
libxrender1/oldstable,now 1:0.9.8-1+b1 amd64  [installé, automatique]
libxslt1.1/oldstable,now 1.1.28-2+deb8u3 amd64  [installé, automatique]
libxt6/oldstable,now 1:1.1.4-1+b1 amd64  [installé, automatique]
libxtables10/oldstable,now 1.4.21-2+b1 amd64  [installé]
libxtst6/oldstable,now 2:1.2.2-1+deb8u1 amd64  [installé]
libyaml-syck-perl/oldstable,now 1.27-2+b2 amd64  [installé]
libzeroc-ice35/oldstable,now 3.5.1-6+b3 amd64  [installé]
linux-base/oldstable,now 4.5~deb8u1 all  [installé, automatique]
linux-image-3.16.0-6-amd64/oldstable,now 3.16.57-2 amd64  [installé]
linux-image-3.2.0-6-amd64/now 3.2.102-1 amd64  [installé, local]
linux-image-amd64/oldstable,oldstable,now 3.16+63+deb8u2 amd64  [installé]
linux-libc-dev/oldstable,now 3.16.57-2 amd64  [installé]
locales/oldstable,oldstable,now 2.19-18+deb8u10 all  [installé]
locate/oldstable,now 4.4.2-9+b1 amd64  [installé]
login/oldstable,oldstable,now 1:4.2-3+deb8u4 amd64  [installé]
logrotate/oldstable,now 3.8.7-1+b1 amd64  [installé, automatique]
lsb-base/oldstable,now 4.1+Debian13+nmu1 all  [installé]
lsb-release/oldstable,now 4.1+Debian13+nmu1 all  [installé]
lsof/oldstable,now 4.86+dfsg-1 amd64  [installé, automatique]
lynx/oldstable,now 2.8.9dev1-2+deb8u1 all  [installé]
lynx-cur/oldstable,now 2.8.9dev1-2+deb8u1 amd64  [installé, automatique]
m4/oldstable,now 1.4.17-4 amd64  [installé, automatique]
make/oldstable,now 4.0-8.1 amd64  [installé]
man-db/oldstable,now 2.7.0.2-5 amd64  [installé]
manpages/oldstable,now 3.74-1 all  [installé]
manpages-dev/oldstable,now 3.74-1 all  [installé]
mawk/oldstable,now 1.3.3-17 amd64  [installé]
mc/oldstable,now 3:4.8.13-3 amd64  [installé]
mc-data/oldstable,now 3:4.8.13-3 all  [installé, automatique]
mime-support/oldstable,now 3.58 all  [installé]
mlock/oldstable,now 8:2007f~dfsg-4 amd64  [installé, automatique]
module-init-tools/oldstable,now 18-3 all  [installé]
mount/oldstable,now 2.25.2-6 amd64  [installé]
multiarch-support/oldstable,oldstable,now 2.19-18+deb8u10 amd64  [installé]
mumble-django/oldstable,now 2.13-1 all  [installé]
mumble-server/oldstable,now 1.2.8-2 amd64  [installé]
munin/oldstable,oldstable,now 2.0.25-1+deb8u3 all  [installé]
munin-common/oldstable,oldstable,now 2.0.25-1+deb8u3 all  [installé, automatique]
munin-doc/oldstable,oldstable,now 2.0.25-1+deb8u3 all  [installé]
munin-node/oldstable,oldstable,now 2.0.25-1+deb8u3 all  [installé, automatique]
munin-plugins-core/oldstable,oldstable,now 2.0.25-1+deb8u3 all  [installé, automatique]
munin-plugins-extra/oldstable,oldstable,now 2.0.25-1+deb8u3 all  [installé, automatique]
mysql-client-5.5/oldstable,oldstable,now 5.5.60-0+deb8u1 amd64  [installé, automatique]
mysql-common/oldstable,oldstable,now 5.5.60-0+deb8u1 all  [installé, automatique]
mysql-server/oldstable,oldstable,now 5.5.60-0+deb8u1 all  [installé]
mysql-server-5.5/oldstable,oldstable,now 5.5.60-0+deb8u1 amd64  [installé, automatique]
mysql-server-core-5.5/oldstable,oldstable,now 5.5.60-0+deb8u1 amd64  [installé, automatique]
nano/oldstable,now 2.2.6-3 amd64  [installé]
ncurses-base/oldstable,now 5.9+20140913-1+deb8u3 all  [installé]
ncurses-bin/oldstable,now 5.9+20140913-1+deb8u3 amd64  [installé]
ncurses-term/oldstable,now 5.9+20140913-1+deb8u3 all  [installé, automatique]
ndiff/oldstable,now 6.47-3+deb8u2 all  [installé]
net-tools/oldstable,now 1.60-26+b1 amd64  [installé]
netbase/oldstable,now 5.3 all  [installé]
netpbm/oldstable,now 2:10.0-15.2 amd64  [installé, automatique]
nfs-common/oldstable,now 1:1.2.8-9 amd64  [installé]
nmap/oldstable,now 6.47-3+deb8u2 amd64  [installé]
nodejs/now 0.10.48-1nodesource1~wheezy1 amd64 [installed,upgradable to: 4.8.2~dfsg-1~bpo8+1]
openjdk-6-jre/now 6b38-1.13.10-1~deb7u1 amd64  [installé, local]
openjdk-6-jre-headless/now 6b38-1.13.10-1~deb7u1 amd64  [installé, local]
openjdk-6-jre-lib/now 6b38-1.13.10-1~deb7u1 all  [installé, local]
openssh-client/oldstable,now 1:6.7p1-5+deb8u7 amd64  [installé]
openssh-server/oldstable,now 1:6.7p1-5+deb8u7 amd64  [installé]
openssh-sftp-server/oldstable,now 1:6.7p1-5+deb8u7 amd64  [installé]
openssl/oldstable,now 1.0.1t-1+deb8u9 amd64  [installé]
os-prober/oldstable,now 1.65+deb8u1 amd64  [installé, automatique]
parted/oldstable,now 3.2-7 amd64  [installé]
passwd/oldstable,oldstable,now 1:4.2-3+deb8u4 amd64  [installé]
patch/oldstable,now 2.7.5-1+deb8u1 amd64  [installé]
pciutils/oldstable,now 1:3.2.1-3 amd64  [installé]
perl/oldstable,oldstable,now 5.20.2-3+deb8u11 amd64  [installé]
perl-base/oldstable,oldstable,now 5.20.2-3+deb8u11 amd64  [installé]
perl-modules/oldstable,oldstable,now 5.20.2-3+deb8u11 all  [installé]
php-auth-sasl/oldstable,now 1.0.6-1+deb8u1 all  [installé, automatique]
php-db/oldstable,now 1.7.14-3 all  [installé]
php-gettext/oldstable,now 1.0.11-1 all  [installé]
php-http-request/oldstable,now 1.4.4-4 all  [installé]
php-log/oldstable,now 1.12.8-2 all  [installé]
php-mail/oldstable,now 1.2.0-7 all  [installé]
php-mail-mime/oldstable,now 1.8.9-1+deb8u1 all  [installé, automatique]
php-mdb2/oldstable,now 2.5.0b5-1 all  [installé, automatique]
php-net-dime/oldstable,now 1.0.2-2 all  [installé]
php-net-sieve/oldstable,now 1.3.2-4 all  [installé]
php-net-smtp/oldstable,now 1.6.2-2 all  [installé, automatique]
php-net-socket/oldstable,now 1.0.14-1 all  [installé, automatique]
php-net-url/oldstable,now 1.0.15-3 all  [installé]
php-patchwork-utf8/oldstable,now 1.1.25-1 all  [installé]
php-pear/oldstable,now 5.6.38+dfsg-0+deb8u1 all  [installé]
php-soap/oldstable,now 0.13.0-1 all  [installé]
php-tcpdf/oldstable,now 6.0.093+dfsg-1+deb8u1 all  [installé]
php5/oldstable,now 5.6.38+dfsg-0+deb8u1 all  [installé]
php5-cli/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-common/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-curl/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-dev/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-gd/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-imagick/oldstable,now 3.2.0~rc1-1 amd64  [installé]
php5-imap/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-intl/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-json/oldstable,now 1.3.6-1 amd64  [installé]
php5-mcrypt/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-memcache/oldstable,now 3.0.8-5 amd64  [installé]
php5-mysql/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-pgsql/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-pspell/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-readline/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-recode/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-snmp/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-sqlite/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-tidy/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-xcache/oldstable,now 3.2.0-1 amd64  [installé]
php5-xmlrpc/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
php5-xsl/oldstable,now 5.6.38+dfsg-0+deb8u1 amd64  [installé]
pkg-config/oldstable,now 0.28-1 amd64  [installé]
pkg-php-tools/oldstable,now 1.28 all  [installé]
po-debconf/oldstable,now 1.0.16+nmu3 all  [installé]
poppler-data/oldstable,now 0.4.7-1 all  [installé, automatique]
postfix/oldstable,now 2.11.3-1+deb8u2 amd64  [installé]
postfix-doc/oldstable,now 2.11.3-1+deb8u2 all  [installé]
postfix-mysql/oldstable,now 2.11.3-1+deb8u2 amd64  [installé]
postfix-pcre/oldstable,now 2.11.3-1+deb8u2 amd64  [installé]
postfixadmin/oldstable,now 2.3.7-1 all  [installé]
procps/oldstable,oldstable,now 2:3.3.9-9+deb8u1 amd64  [installé]
psmisc/oldstable,now 22.21-2 amd64  [installé]
psutils/oldstable,now 1.17.dfsg-2 amd64  [installé, automatique]
python/oldstable,now 2.7.9-1 amd64  [installé]
python-apt/oldstable,now 0.9.3.12 amd64  [installé, automatique]
python-apt-common/oldstable,now 0.9.3.12 all  [installé, automatique]
python-augeas/jessie-backports,now 0.5.0-1~bpo8+1 all  [installé]
python-cffi/oldstable,now 0.8.6-1 amd64  [installé]
python-chardet/oldstable,now 2.3.0-1 all  [installé, automatique]
python-chardet-whl/oldstable,now 2.3.0-1 all  [installé]
python-colorama/oldstable,now 0.3.2-1 all  [installé, automatique]
python-colorama-whl/oldstable,now 0.3.2-1 all  [installé]
python-configargparse/jessie-backports,now 0.11.0-1~bpo8+1 all  [installé]
python-cryptography/oldstable,now 0.6.1-1+deb8u1 amd64  [installé]
python-debian/oldstable,now 0.1.27 all  [installé, automatique]
python-dev/oldstable,now 2.7.9-1 amd64  [installé]
python-distlib/oldstable,now 0.1.9-1 all  [installé, automatique]
python-distlib-whl/oldstable,now 0.1.9-1 all  [installé]
python-django/oldstable,oldstable,now 1.7.11-1+deb8u3 all  [installé, automatique]
python-django-common/oldstable,oldstable,now 1.7.11-1+deb8u3 all  [installé, automatique]
python-django-extdirect/oldstable,now 0.10-1 all  [installé, automatique]
python-django-mumble/oldstable,now 2.13-1 all  [installé, automatique]
python-django-registration/oldstable,now 1.0+dfsg-2 all  [installé, automatique]
python-dnspython/jessie-backports,now 1.15.0-1~bpo8+1 all  [installé]
python-enum34/oldstable,now 1.0.3-1 all  [installé]
python-funcsigs/jessie-backports,now 1.0.2-3~bpo8+1 all  [installé]
python-gamin/oldstable,now 0.1.10-4.1 amd64  [installé, automatique]
python-html5lib/oldstable,now 0.999-3 all  [installé, automatique]
python-html5lib-whl/oldstable,now 0.999-3 all  [installé]
python-idna/jessie-backports,now 2.0-3~bpo8+1 all  [installé]
python-imaging/oldstable,oldstable,now 2.6.1-2+deb8u3 all  [installé, automatique]
python-ipaddress/jessie-backports,now 1.0.16-1~bpo8+1 all  [installé]
python-lxml/oldstable,now 3.4.0-1 amd64  [installé]
python-minimal/oldstable,now 2.7.9-1 amd64  [installé]
python-ndg-httpsclient/oldstable,now 0.3.2-1 all  [installé, automatique]
python-openssl/oldstable,now 0.14-1 all  [installé]
python-parsedatetime/oldstable,now 1.4-1 all  [installé]
python-pil/oldstable,oldstable,now 2.6.1-2+deb8u3 amd64  [installé]
python-pip/oldstable,now 1.5.6-5 all  [installé]
python-pip-whl/oldstable,now 1.5.6-5 all  [installé]
python-pkg-resources/oldstable,now 5.5.1-1 all  [installé, automatique]
python-ply/oldstable,now 3.4-5 all  [installé, automatique]
python-psutil/jessie-backports,now 4.1.0-1~bpo8+1 amd64  [installé]
python-pyasn1/oldstable,now 0.1.7-1 all  [installé]
python-pycparser/oldstable,now 2.10+dfsg-3 all  [installé, automatique]
python-pyicu/oldstable,now 1.8-1 amd64  [installé]
python-pyinotify/oldstable,now 0.9.4-1 all  [installé]
python-requests/oldstable,now 2.4.3-6 all  [installé, automatique]
python-requests-whl/oldstable,now 2.4.3-6 all  [installé]
python-rfc3339/jessie-backports,now 1.0-4~bpo8+1 all  [installé]
python-setuptools/oldstable,now 5.5.1-1 all  [installé]
python-setuptools-whl/oldstable,now 5.5.1-1 all  [installé]
python-simplejson/oldstable,now 3.6.5-1 amd64  [installé, automatique]
python-six/oldstable,now 1.8.0-1 all  [installé]
python-six-whl/oldstable,now 1.8.0-1 all  [installé]
python-sqlparse/oldstable,now 0.1.13-2 all  [installé]
python-support/oldstable,now 1.0.15 all  [installé, automatique]
python-tz/oldstable,now 2012c+dfsg-0.1 all  [installé]
python-urllib3/oldstable,now 1.9.1-3 all  [installé, automatique]
python-urllib3-whl/oldstable,now 1.9.1-3 all  [installé]
python-virtualenv/oldstable,now 1.11.6+ds-1 all  [installé]
python-wheel/oldstable,now 0.24.0-1 all  [installé, automatique]
python-xapian/oldstable,now 1.2.19-2 amd64  [installé, automatique]
python-zeroc-ice/oldstable,now 3.5.1-6+b3 amd64  [installé, automatique]
python2.7/oldstable,now 2.7.9-2+deb8u2 amd64  [installé]
python2.7-dev/oldstable,now 2.7.9-2+deb8u2 amd64  [installé, automatique]
python2.7-minimal/oldstable,now 2.7.9-2+deb8u2 amd64  [installé]
python3/oldstable,now 3.4.2-2 amd64  [installé]
python3-django/oldstable,oldstable,now 1.7.11-1+deb8u3 all  [installé]
python3-minimal/oldstable,now 3.4.2-2 amd64  [installé]
python3-pkg-resources/oldstable,now 5.5.1-1 all  [installé]
python3-sqlparse/oldstable,now 0.1.13-2 all  [installé, automatique]
python3-tz/oldstable,now 2012c+dfsg-0.1 all  [installé, automatique]
python3-virtualenv/oldstable,now 1.11.6+ds-1 all  [installé]
python3.4/oldstable,now 3.4.2-1+deb8u1 amd64  [installé]
python3.4-minimal/oldstable,now 3.4.2-1+deb8u1 amd64  [installé]
qdbus/oldstable,now 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 amd64  [installé, automatique]
qtchooser/oldstable,now 47-gd2b7997-2 amd64  [installé]
qtcore4-l10n/oldstable,now 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 all  [installé]
readline-common/oldstable,now 6.3-8 all  [installé]
reiser4progs/oldstable,now 1.0.9-2 amd64  [installé]
reiserfsprogs/oldstable,now 1:3.6.24-1 amd64  [installé]
rename/oldstable,now 0.20-3 all  [installé]
rlwrap/oldstable,now 0.41-1 amd64  [installé]
roundcube/jessie-backports,now 1.1.5+dfsg.1-1~bpo8+5 all  [installé]
roundcube-core/jessie-backports,now 1.1.5+dfsg.1-1~bpo8+5 all  [installé, automatique]
roundcube-mysql/jessie-backports,now 1.1.5+dfsg.1-1~bpo8+5 all  [installé, automatique]
rpcbind/oldstable,oldstable,now 0.2.1-6+deb8u2 amd64  [installé]
rrdtool/oldstable,now 1.4.8-1.2 amd64  [installé]
rsync/oldstable,oldstable,now 3.1.1-3+deb8u1 amd64  [installé]
rsyslog/oldstable,now 8.4.2-1+deb8u2 amd64  [installé]
sasl2-bin/oldstable,oldstable,now 2.1.26.dfsg1-13+deb8u1 amd64  [installé]
screen/oldstable,oldstable,now 4.2.1-3+deb8u1 amd64  [installé]
sed/oldstable,now 4.2.2-4+deb8u1 amd64  [installé]
sensible-utils/oldstable,oldstable,now 0.0.9+deb8u1 all  [installé]
sgml-base/oldstable,now 1.26+nmu4 all  [installé]
shared-mime-info/oldstable,now 1.3-1 amd64  [installé]
shtool/oldstable,now 2.0.8-6 all  [installé, automatique]
sqlite3/oldstable,now 3.8.7.1-1+deb8u2 amd64  [installé]
ssl-cert/oldstable,now 1.0.35 all  [installé, automatique]
startpar/oldstable,now 0.59-3 amd64  [installé]
sudo/oldstable,now 1.8.10p3-1+deb8u5 amd64  [installé]
systemd/oldstable,now 215-17+deb8u7 amd64  [installé]
systemd-sysv/oldstable,now 215-17+deb8u7 amd64  [installé]
sysv-rc/oldstable,now 2.88dsf-59 all  [installé]
sysvinit/oldstable,now 2.88dsf-59 amd64  [installé]
sysvinit-utils/oldstable,now 2.88dsf-59 amd64  [installé]
tar/oldstable,oldstable,now 1.27.1-2+deb8u1 amd64  [installé]
tcpd/oldstable,now 7.6.q-25 amd64  [installé, automatique]
telnet/oldstable,now 0.17-36 amd64  [installé]
ttf-dejavu/oldstable,now 2.34-1 all  [installé]
ttf-dejavu-core/oldstable,now 2.34-1 all  [installé, automatique]
ttf-dejavu-extra/oldstable,now 2.34-1 all  [installé, automatique]
tzdata/oldstable,now 2018e-0+deb8u1 all  [installé]
tzdata-java/oldstable,now 2018e-0+deb8u1 all  [installé]
ucf/oldstable,now 3.0030 all  [installé, automatique]
udev/oldstable,now 215-17+deb8u7 amd64  [installé]
ufraw-batch/oldstable,now 0.20-2+deb8u1 amd64  [installé, automatique]
ufw/oldstable,now 0.33-2 all  [installé]
unrar/oldstable,now 1:5.2.7-0.1+deb8u1 amd64  [installé]
unzip/oldstable,now 6.0-16+deb8u3 amd64  [installé, automatique]
usbutils/oldstable,now 1:007-2 amd64  [installé]
util-linux/oldstable,now 2.25.2-6 amd64  [installé]
vim/oldstable,now 2:7.4.488-7+deb8u3 amd64  [installé]
vim-common/oldstable,now 2:7.4.488-7+deb8u3 amd64  [installé, automatique]
vim-runtime/oldstable,now 2:7.4.488-7+deb8u3 all  [installé, automatique]
virtualenv/oldstable,now 1.11.6+ds-1 all  [installé]
webalizer/oldstable,now 2.23.08-1+b1 amd64  [installé]
wget/oldstable,oldstable,now 1.16-1+deb8u5 amd64  [installé]
whois/oldstable,now 5.2.7 amd64  [installé, automatique]
wwwconfig-common/oldstable,now 0.2.2 all  [installé, automatique]
x11-common/oldstable,now 1:7.7+7 all  [installé, automatique]
xauth/oldstable,now 1:1.0.9-1 amd64  [installé, automatique]
xdg-user-dirs/oldstable,now 0.15-2 amd64  [installé]
xfsprogs/oldstable,now 3.2.1 amd64  [installé]
xml-core/oldstable,now 0.13+nmu2 all  [installé]
xz-utils/oldstable,now 5.1.1alpha+20120614-2+b3 amd64  [installé]
zendframework/oldstable,now 1.12.9+dfsg-2+deb8u7 all  [installé]
zip/oldstable,now 3.0-8 amd64  [installé]
zlib1g/oldstable,now 1:1.2.8.dfsg-2+b1 amd64  [installé]
zlib1g-dev/oldstable,now 1:1.2.8.dfsg-2+b1 amd64  [installé, automatique]
 



Beta-Pictoris a écrit :

Que donne ? :

apt policy


Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 https://download.webmin.com/download/repository/ sarge/contrib amd64 Packages
     release v=3.1,o=Jamie Cameron,a=stable,n=sarge,l=Webmin,c=contrib
     origin download.webmin.com
 500 http://mirrors.gandi.net/gandi/debian/ jessie/main amd64 Packages
     release o=Gandi,a=jessie,n=jessie,l=Gandi,c=main
     origin mirrors.gandi.net
 500 http://mirrors.gandi.net/debian/ jessie-backports/non-free Translation-en
 500 http://mirrors.gandi.net/debian/ jessie-backports/main Translation-en
 500 http://mirrors.gandi.net/debian/ jessie-backports/contrib Translation-en
 100 http://mirrors.gandi.net/debian/ jessie-backports/non-free amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=non-free
     origin mirrors.gandi.net
 100 http://mirrors.gandi.net/debian/ jessie-backports/contrib amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=contrib
     origin mirrors.gandi.net
 100 http://mirrors.gandi.net/debian/ jessie-backports/main amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
     origin mirrors.gandi.net
 500 http://mirrors.gandi.net/debian-security/ jessie/updates/non-free Translation-en
 500 http://mirrors.gandi.net/debian-security/ jessie/updates/main Translation-en
 500 http://mirrors.gandi.net/debian-security/ jessie/updates/contrib Translation-en
 500 http://mirrors.gandi.net/debian-security/ jessie/updates/non-free amd64 Packages
     release v=8,o=Debian,a=oldstable,n=jessie,l=Debian-Security,c=non-free
     origin mirrors.gandi.net
 500 http://mirrors.gandi.net/debian-security/ jessie/updates/contrib amd64 Packages
     release v=8,o=Debian,a=oldstable,n=jessie,l=Debian-Security,c=contrib
     origin mirrors.gandi.net
 500 http://mirrors.gandi.net/debian-security/ jessie/updates/main amd64 Packages
     release v=8,o=Debian,a=oldstable,n=jessie,l=Debian-Security,c=main
     origin mirrors.gandi.net
 500 http://mirrors.gandi.net/debian/ jessie/non-free Translation-en
 500 http://mirrors.gandi.net/debian/ jessie/main Translation-fr
 500 http://mirrors.gandi.net/debian/ jessie/main Translation-en
 500 http://mirrors.gandi.net/debian/ jessie/contrib Translation-en
 500 http://mirrors.gandi.net/debian/ jessie/non-free amd64 Packages
     release v=8.11,o=Debian,a=oldstable,n=jessie,l=Debian,c=non-free
     origin mirrors.gandi.net
 500 http://mirrors.gandi.net/debian/ jessie/contrib amd64 Packages
     release v=8.11,o=Debian,a=oldstable,n=jessie,l=Debian,c=contrib
     origin mirrors.gandi.net
 500 http://mirrors.gandi.net/debian/ jessie/main amd64 Packages
     release v=8.11,o=Debian,a=oldstable,n=jessie,l=Debian,c=main
     origin mirrors.gandi.net
Paquets épinglés :
 



Beta-Pictoris a écrit :


As tu fait une sauvegarde de ton système ?
.



Oui, un snapshot, mais avant l'upgrade, c'est à dire sur une version Gandi de wheezy... Et depuis, il se passe des chose sur le serveur...


La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#6 04-10-2018 12:13:08

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : Dépendances cassées sur serveur en production, dépendances python

celp a écrit :

Juste une question

tu veut tout passer en debian 8?

j'ai un tuto réparation ou tu regarde mes recents posts qui explique comment sauver une debian.



Le problème est que c'est fait, on est passé à Debian 8, avec un peu de perte et fracas pour des configs apache2 et python-django, surtout un serveur mumble qui a subit des tracas...


La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#7 04-10-2018 12:19:30

Invité-X
Invité

Re : Dépendances cassées sur serveur en production, dépendances python

voila j'ai taper la doc

tu peut la consulter ici : https://docs.google.com/document/d/e/2P … HCWgOy/pub

si tu as besoin, n'hesite pas

#8 04-10-2018 12:25:22

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : Dépendances cassées sur serveur en production, dépendances python

Un détail important, avant la migration vers Debian 8, j'avais fait une tentative d'installation de letsencrypt avec un script auto-certbot qui a peut-être laissé des traces, mais j'avais supprimer le dossier /etc/letsencrypt pour désinstallé le ssl qui foirait... par contre il est peut-être à l'origine de ces paquets python qui coincent qui en plus ont peut-être été supprimés avec un apt-get auto-remove mais pas leurs configuration ?? je ne sais pas, j'aimerai décoincer tout cela, mais python nous joue des tours...

La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#9 04-10-2018 12:44:02

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : Dépendances cassées sur serveur en production, dépendances python

celp a écrit :

voila j'ai taper la doc

tu peut la consulter ici : https://docs.google.com/document/d/e/2P … HCWgOy/pub

si tu as besoin, n'hesite pas



J'ai essayé, mais ça ne change rien... en fait la migration a bien été effectuée, mais le soucis est arrivé en voulant installé python-certbot des dépôts backports, du coup il y a des paquets python (18 paquets) qui n'arrivent pas à s'installer...


La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#10 04-10-2018 12:48:31

Invité-X
Invité

Re : Dépendances cassées sur serveur en production, dépendances python

Il faut pas laisser les depot backports activé lors de la procédure.

tu les remettra apres.

Dernière modification par Invité-X (04-10-2018 12:48:46)

#11 04-10-2018 12:53:42

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : Dépendances cassées sur serveur en production, dépendances python

celp a écrit :

Il faut pas laisser les depot backports activé lors de la procédure.

tu les remettra apres.



La migration wheezy => jessie c'était bien passée, avec des soucis tout de même de configs, elle a eu lieu en début de semaine (peut-être même fin de semaine dernière), c'est depuis hier où j'ai voulu installer python-certbot que tout déconne...


La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#12 04-10-2018 13:00:32

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : Dépendances cassées sur serveur en production, dépendances python

rodinux a écrit :

celp a écrit :

Il faut pas laisser les depot backports activé lors de la procédure.

tu les remettra apres.



La migration wheezy => jessie c'était bien passée, avec des soucis tout de même de configs, elle a eu lieu en début de semaine (peut-être même fin de semaine dernière), c'est depuis hier où j'ai voulu installer python-certbot que tout déconne...



Pardon, tu veux dire pour réparer, ton tutto... je vais re-essayer....


La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#13 04-10-2018 13:08:16

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : Dépendances cassées sur serveur en production, dépendances python

Pourtant, tu as encore pleins de paquets oldstable installés selon la commande "apt --installed list | grep -v '/stable'".   Mais il est possible que certains paquets obsolètes n'ont pas de mises à jour dans jessie.

Dans ton source.list, tu devrais, dans un premier temps, mettre que des dépôts jessie et repasser tous les paquets en stable.

Tu peux le faire en ajoutant le suffixe '/stable' à toute la liste de paquets passés en paramètre:

apt install liblqr-1-0/stable liblsan0/stable libltdl-dev/stable........


Ou utilise la commande aptitude qui est capable de faire ça automatiquement.

Tu devrais cloner ton système dans une VM et faire les opérations dans la VM pour voir si ça fonctionne correctement.

Dernière modification par Beta-Pictoris (04-10-2018 13:08:55)

Hors ligne

#14 04-10-2018 13:22:05

Invité-X
Invité

Re : Dépendances cassées sur serveur en production, dépendances python

Beta-Pictoris a écrit :

Pourtant, tu as encore pleins de paquets oldstable installés selon la commande "apt --installed list | grep -v '/stable'".   Mais il est possible que certains paquets obsolètes n'ont pas de mises à jour dans jessie.

Dans ton source.list, tu devrais, dans un premier temps, mettre que des dépôts jessie et repasser tous les paquets en stable.

Tu peux le faire en ajoutant le suffixe '/stable' à toute la liste de paquets passés en paramètre:

apt install liblqr-1-0/stable liblsan0/stable libltdl-dev/stable........


Ou utilise la commande aptitude qui est capable de faire ça automatiquement.

Tu devrais cloner ton système dans une VM et faire les opérations dans la VM pour voir si ça fonctionne correctement.



au pire il save juste /etc.

#15 04-10-2018 13:27:36

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : Dépendances cassées sur serveur en production, dépendances python

Les backports sont commentés maintenant, un update ne renvoie pas d'erreurs... Par contre un upgrade me renvoi toujours des erreurs !!
J'ai voulu installer des paquets que je pensais enlevés suite à  apt-get autoremove.
J'ai toujours des soucis

apt install --reinstall python-funcsigs python-dnspython python-configargparse python-psutil:amd64 python-pyicu python-zope.component python-augeas python-zope.interface python-configobj python-zope.event python-idna python-ipaddress python-parsedatetime python-enum34 python-rfc3339


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
La réinstallation de python-dnspython est impossible, il ne peut pas être téléchargé.
La réinstallation de python-idna est impossible, il ne peut pas être téléchargé.
La réinstallation de python-rfc3339 est impossible, il ne peut pas être téléchargé.
La réinstallation de python-configargparse est impossible, il ne peut pas être téléchargé.
La réinstallation de python-augeas est impossible, il ne peut pas être téléchargé.
La réinstallation de python-psutil est impossible, il ne peut pas être téléchargé.
La réinstallation de python-funcsigs est impossible, il ne peut pas être téléchargé.
La réinstallation de python-ipaddress est impossible, il ne peut pas être téléchargé.
0 mis à jour, 0 nouvellement installés, 7 réinstallés, 0 à enlever et 0 non mis à jour.
21 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/614 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
E: Internal Error, No file name for python-configobj:amd64



Par exemple pour le premier paquet:

apt search python-dnspython


En train de trier... Fait
Recherche en texte intégral... Fait
python-dns/oldstable 2.3.6-3 all
  DNS client module for Python

python-dnspython/now 1.15.0-1~bpo8+1 all  [installé, local]
  DNS toolkit for Python

python3-dns/oldstable 3.1.0-1 all
  DNS client module for Python 3



apt-cache policy python-dnspython


python-dnspython:
  Installé : 1.15.0-1~bpo8+1
  Candidat : 1.15.0-1~bpo8+1
 Table de version :
 *** 1.15.0-1~bpo8+1 0
        100 /var/lib/dpkg/status
     1.12.0-1 0
        500 http://mirrors.gandi.net/debian/ jessie/main amd64 Packages



Bref et toujours les même messages


La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#16 04-10-2018 13:31:54

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : Dépendances cassées sur serveur en production, dépendances python

Là, je suis très embêtté:

apt install --reinstall python-funcsigs/stable python-dnspython/stable python-configargparse/stable python-psutil/stable python-pyicu/stable python-zope.component/stable python-augeas/stable python-zope.interface/stable python-configobj/stable python-zope.event/stable python-idna/stable python-ipaddress/stable python-parsedatetime/stable python-enum34/stable python-rfc3339/stable


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: La version « stable » de « python-funcsigs » est introuvable
E: La version « stable » de « python-dnspython » est introuvable
E: La version « stable » de « python-configargparse » est introuvable
E: La version « stable » de « python-psutil » est introuvable
E: La version « stable » de « python-pyicu » est introuvable
E: La version « stable » de « python-zope.component » est introuvable
E: La version « stable » de « python-augeas » est introuvable
E: La version « stable » de « python-zope.interface » est introuvable
E: La version « stable » de « python-configobj » est introuvable
E: La version « stable » de « python-zope.event » est introuvable
E: La version « stable » de « python-idna » est introuvable
E: La version « stable » de « python-ipaddress » est introuvable
E: La version « stable » de « python-parsedatetime » est introuvable
E: La version « stable » de « python-enum34 » est introuvable
E: La version « stable » de « python-rfc3339 » est introuvable


La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#17 04-10-2018 13:35:17

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : Dépendances cassées sur serveur en production, dépendances python

dpkg --configure -a



dpkg: dependency problems prevent configuration of python-configobj:
python-configobj depends on python-six; however:
Package python-six is not configured yet.

dpkg: error processing package python-configobj (--configure):
dependency problems - leaving unconfigured
dpkg: error processing package python-pkg-resources (--configure):
package is in a very bad inconsistent state; you should
reinstall it before attempting configuration
dpkg: dependency problems prevent configuration of python-zope.interface:
python-zope.interface depends on python-pkg-resources; however:
Package python-pkg-resources is not configured yet.

dpkg: error processing package python-zope.interface (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-zope.event:
python-zope.event depends on python-pkg-resources; however:
Package python-pkg-resources is not configured yet.

dpkg: error processing package python-zope.event (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-zope.component:
python-zope.component depends on python-zope.interface; however:
Package python-zope.interface is not configured yet.
python-zope.component depends on python-pkg-resources; however:
Package python-pkg-resources is not configured yet.
python-zope.component depends on python-zope.event; however:
Package python-zope.event is not configured yet.

dpkg: error processing package python-zope.component (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
python-configobj
python-pkg-resources
python-zope.interface
python-zope.event
python-zope.component


La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#18 04-10-2018 13:47:42

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Dépendances cassées sur serveur en production, dépendances python

Dans la commande du #16 :
stable c’est stretch
oldstable c’est jessie

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#19 04-10-2018 13:53:48

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : Dépendances cassées sur serveur en production, dépendances python

est-ce que je ne devrais pas utiliser dkpg --force ?

La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#20 04-10-2018 13:57:48

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : Dépendances cassées sur serveur en production, dépendances python

apt install --reinstall python-funcsigs/oldstable python-dnspython/oldstable python-configargparse/oldstable python-psutil/oldstable python-pyicu/oldstable python-zope.component/oldstable python-augeas/oldstable python-zope.interface/oldstable python-configobj/oldstable python-zope.event/oldstable python-idna/oldstable python-ipaddress/oldstable python-parsedatetime/oldstable python-enum34/oldstable python-rfc3339/oldstable


oldstable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Le paquet python-augeas doit être réinstallé, mais il est impossible de trouver son archive.


La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#21 04-10-2018 14:32:07

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : Dépendances cassées sur serveur en production, dépendances python

rodinux a écrit :

apt install --reinstall python-funcsigs/oldstable python-dnspython/oldstable python-configargparse/oldstable python-psutil/oldstable python-pyicu/oldstable python-zope.component/oldstable python-augeas/oldstable python-zope.interface/oldstable python-configobj/oldstable python-zope.event/oldstable python-idna/oldstable python-ipaddress/oldstable python-parsedatetime/oldstable python-enum34/oldstable python-rfc3339/oldstable


oldstable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Le paquet python-augeas doit être réinstallé, mais il est impossible de trouver son archive.



Je vois que le paquet vient des backports, mais je viens de commenter les backports

apt-cache policy python-augeas


Installé : 0.5.0-1~bpo8+1
  Candidat : 0.5.0-1~bpo8+1
 Table de version :
 *** 0.5.0-1~bpo8+1 0
        100 http://ftp.debian.org/debian/ jessie-backports/main amd64 Packages
        100 /var/lib/dpkg/status
     0.4.1-2 0
        500 http://mirrors.gandi.net/debian/ jessie/main amd64 Packages



il faudrait que je le dowgrade...


La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#22 04-10-2018 15:08:13

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : Dépendances cassées sur serveur en production, dépendances python

Du coup j'essaie ceci:

apt-get -o Dpkg::Options::="--force-overwrite" install --reinstall python-augeas=0.4.1-2


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants seront mis à une VERSION INFÉRIEURE :
  python-augeas
0 mis à jour, 0 nouvellement installés, 1 remis à une version inférieure, 0 à enlever et 1 non mis à jour.
19 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/545 ko dans les archives.
Après cette opération, 1 024 o d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 115828 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python-augeas_0.4.1-2_all.deb ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/python-augeas_0.4.1-2_all.deb (--unpack) :
 le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg : erreur lors du nettoyage :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/python-augeas_0.4.1-2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#23 04-10-2018 15:15:41

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Dépendances cassées sur serveur en production, dépendances python

rodinux a écrit :

Je vois que le paquet vient des backports, mais je viens de commenter les backports


il faut après avoir commenté refaire un

apt update


car dans ton retour la version backport est toujours indiquée :

Table de version :
 *** 0.5.0-1~bpo8+1 0
        100 http://ftp.debian.org/debian/ jessie-backports/main amd64 Packages


Tu es certain d'avoir commenté toutes les lignes backports ?

Edit : et si tu supprimais/purgeais tous ces paquets pour les réinstaller aussitôt ? apt purge lepaquet && apt install lepaquet
dans le cadre de la migration et du serveur, je ne mesure si c'est une bonne idée ou pas


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#24 04-10-2018 15:28:09

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : Dépendances cassées sur serveur en production, dépendances python

apt-get -o Dpkg::Options::="--force-all" install python-augeas=0.4.1-2


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Le paquet python-augeas doit être réinstallé, mais il est impossible de trouver son archive.



Mais qu'est-ce qui ce passe !!!kernal_panic.gif


La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#25 04-10-2018 15:37:20

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : Dépendances cassées sur serveur en production, dépendances python

chalu a écrit :

rodinux a écrit :

Je vois que le paquet vient des backports, mais je viens de commenter les backports


il faut après avoir commenté refaire un

apt update


car dans ton retour la version backport est toujours indiquée :

Table de version :
 *** 0.5.0-1~bpo8+1 0
        100 http://ftp.debian.org/debian/ jessie-backports/main amd64 Packages


Tu es certain d'avoir commenté toutes les lignes backports ?

Edit : et si tu supprimais/purgeais tous ces paquets pour les réinstaller aussitôt ? apt purge lepaquet && apt install lepaquet
dans le cadre de la migration et du serveur, je ne mesure si c'est une bonne idée ou pas



Bon, j'attends un peu car on était deux sur le serveur et en effet, entre temps les backports étaient là...
Je m'arrête un peu et je reviens quand la pression aura descendue...


La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

Pied de page des forums