Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-10-2018 18:12:58

pixoumax
Membre
Lieu : Savoie
Distrib. : Debian Strech 9
Noyau : Linux max 4.9.0-8-amd64
Inscription : 01-09-2018

[RESOLU] Aide pour alsa. pas de version susceptible d'être installé

Bonjour,

J'ai installé debian 9.5 stretch sur mon ordi en dual boot avec Windows.

Je suis débutant dans debian, mais j'aime chercher et comprendre aussi ce que je fais.

Alors voila mon problème, je n'est pas de son.

Je vais vous donner les étapes que j'ai suivi pour y résoudre (sans succès pour l'instant) :

J'ai d'abord vérifier le niveau de son : il n'est pas sur muet.
J'ai ensuite vérifier la présence d'une carte audio via la commande :

max@max:~$ lspci | grep -i audio
00:1f.3 Audio device: Intel Corporation Device a171 (rev 31)
max@max:~$


bloc à supprimer si la commande n’affiche rien



En lisant des forums sur internet, j'ai essayé la commande :

root@max:~$ dpkg-reconfigure alsa-base :
dpkg-query: le paquet « alsa-base » n'est pas installé et aucune information n'est disponible
Utilisez dpkg --info (= dpkg-deb --info) pour examiner les fichiers
archives, et dpkg --contents (= dpkg-deb --contents) pour afficher leur
contenu.
/usr/sbin/dpkg-reconfigure: alsa-base n'est pas installé


bloc à supprimer si la commande n’affiche rien




j'essaie donc de l'installer avec apt-get

root@max:/home/max# sudo apt-get install alsa-base
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Aucune version du paquet alsa-base n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'
il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « alsa-base » n'a pas de version susceptible d'être installée
 


bloc à supprimer si la commande n’affiche rien



J'ai donc vérifier mon fichier sources.file

#

# deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official Multi-architecture amd$

#deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official Multi-architecture amd6$

deb http://ftp.fr.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/debian-security stretch/updates main contrib non$
deb-src http://security.debian.org/debian-security stretch/updates main contrib$

# stretch-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free




Je ne sais pas trop si mon nano est correct ou pas. Et voila j'ai plus trop d'idée. Sur les forums ont trouve de tout et n'importe quoi mais je reste toujours bloqué ici.

Dernière modification par pixoumax (09-10-2018 11:10:34)


Débutant debian

Hors ligne

#2 08-10-2018 20:26:26

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : [RESOLU] Aide pour alsa. pas de version susceptible d'être installé


deb http://security.debian.org/debian-security stretch/updates main contrib non$
deb-src http://security.debian.org/debian-security stretch/updates main contrib$


Le symbole $ à la fin de ces deux lignes n'est pas correct, tu devrais avoir main contrib non-free comme  sur les autres
Ceci le paquet alsa-base n'est pas présent dans les dépôts de stretch donc c'est normal de ne pas l'avoir trouvé. Une info périmée sur internet smile

Hors ligne

#3 08-10-2018 22:00:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU] Aide pour alsa. pas de version susceptible d'être installé

Bonsoir,

chalu a écrit :

Ceci [dit] le paquet alsa-base n'est pas présent dans les dépôts de stretch donc c'est normal de ne pas l'avoir trouvé. Une info périmée sur internet :)


Oh ! il n'est pas nécessaire d'aller se perdre sur le grand ternet pour la trouver l'info périmée (wiki).

pixoumax a écrit :

Alors voilà mon problème, je n'ai pas de son.


Le description du problème est un petit peu succincte mais sous Stretch tu peux exécuter alsa-info.

Hors ligne

#4 09-10-2018 06:49:10

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : [RESOLU] Aide pour alsa. pas de version susceptible d'être installé

èfpé a écrit :

Bonsoir,

chalu a écrit :

Ceci [dit] le paquet alsa-base n'est pas présent dans les dépôts de stretch donc c'est normal de ne pas l'avoir trouvé. Une info périmée sur internet smile


Oh ! il n'est pas nécessaire d'aller se perdre sur le grand ternet pour la trouver l'info périmée (wiki).


Bonjour smile
Effectivement le wiki DF est périmé mad mais je connais un membre très connaisseur de ces problèmes audio et de leurs solutions qui va sûrement le mettre à jour dès qu’il aura le temps smile
Voyons voir comment c’est son pseudo ? Ça commence par èf.. question.gif
merci.gifmerci.gif

Hors ligne

#5 09-10-2018 09:45:15

pixoumax
Membre
Lieu : Savoie
Distrib. : Debian Strech 9
Noyau : Linux max 4.9.0-8-amd64
Inscription : 01-09-2018

Re : [RESOLU] Aide pour alsa. pas de version susceptible d'être installé

Bonjour a tous,


chalu a écrit :


deb http://security.debian.org/debian-security stretch/updates main contrib non$
deb-src http://security.debian.org/debian-security stretch/updates main contrib$


Le symbole $ à la fin de ces deux lignes n'est pas correct, tu devrais avoir main contrib non-free comme  sur les autres
Ceci le paquet alsa-base n'est pas présent dans les dépôts de stretch donc c'est normal de ne pas l'avoir trouvé. Une info périmée sur internet smile



J'ai bien contrib non-free sur les deux lignes. C'est de ma faute j'ai pas agrandi assez la fenêtre, et je pense que ma console affiche le caractère '$' quand il y a encore des choses a afficher.

J'ai suivi la proposition de èfpé sur l'exécution alsa-info et je te remercie parce que ça fonctionne.

Je suis donc aller sur ton lien que je remet ici au cas où

https://debian-facile.org/atelier:chant … -9-stretch et en suivant la procédure pour debian 9 stretch.

alsa-info m'a générer un lien URL dans la console, j'ai ouvert ce lien. J'ai récupérer des informations sur les cartes son reconnu par alsa.

J'ai créé et modifier mon fichier caché. J'ai redémarrer, tester le son avec et sans écouteurs et ça à fonctionné.

Je vous remercie les gas


Débutant debian

Hors ligne

#6 09-10-2018 10:21:33

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [RESOLU] Aide pour alsa. pas de version susceptible d'être installé

pixoumax a écrit :

ça à fonctionné.


Super !
Alors :
\o/
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre. wink


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#7 09-10-2018 11:27:54

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : [RESOLU] Aide pour alsa. pas de version susceptible d'être installé

Ah oui, il va falloir le sortir du chantier ce wiki ! wink
bon pas trop le temps là maintenant mais si ce n'est pas fait, dès que j'ai un moment je le ferai smile

Hors ligne

#8 10-11-2018 22:04:42

maxmc25
Membre
Lieu : Besançon
Distrib. : debian stretch
Noyau : linux 4.9.0-8-686-pae
(G)UI : xfce4
Inscription : 10-11-2018

Re : [RESOLU] Aide pour alsa. pas de version susceptible d'être installé

Bonjour à tous,

je me permets de relancer ce topic car je suis exactement dans la même situation que pixoumax, en tout points. J'ai donc tenté de résoudre mon problème de la même manière, seulement je suis bloqué après avoir consulté la page générée par alsa-info, que dois-je en tirer ? Je ne comprends pas quel fichier caché il faut "créer et éditer" neutral
Pouvez-vous m'éclairer ?

Hors ligne

#9 11-11-2018 06:43:26

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [RESOLU] Aide pour alsa. pas de version susceptible d'être installé

maxmc25 a écrit :

je me permets de relancer ce topic car je suis exactement dans la même situation


Le mieux est d'ouvrir un nouveau topic t'appartenant où tu peux mettre en lien celui-ci qui lui est résolu. smile

Attention, un problème, un utilisateur, un sujet à part!
Merci de créer un nouveau sujet pour exposer ton problème.
Voir le tuto : On ne bernacle pas le post d'autrui. Plop !


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums