Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-10-2018 16:12:46

rodinux
Membre
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

upgrade de clamav, source pas à jour ?[Résolu]

Bonjour,
je ne comprends pas pourquoi je n'ai pas encore la version upgrader de clamav qui devrait être présente dans le dépôt stretch-updates https://packages.debian.org/stretch-updates/clamav
Alors que chez moi j'ai:

apt-cache policy clamav


clamav:
  Installé : (aucun)
  Candidat : 0.100.0+dfsg-0+deb9u2
 Table de version :
     0.100.2+dfsg-0+deb9u1 500
        500 http://ftp.fr.debian.org/debian stretch-updates/main amd64 Packages
     0.100.0+dfsg-0+deb9u2 1000
       1000 http://ftp.fr.debian.org/debian stretch/main amd64 Packages



Si j'essaie d'installer la version 0.100.2

sudo apt install -t stretch-updates clamav clamav-base clamav-freshclam libclamav7


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libtext-csv-perl procmail
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Paquets suggérés :
  clamav-docs libclamunrar7
Les NOUVEAUX paquets suivants seront installés :
  clamav clamav-base clamav-freshclam libclamav7
0 mis à jour, 4 nouvellement installés, 0 à enlever et 1 non mis à jour.
Il est nécessaire de prendre 1 155 ko dans les archives.
Après cette opération, 3 352 ko d'espace disque supplémentaires seront utilisés.
Réception de:1 http://ftp.fr.debian.org/debian stretch/main amd64 clamav-base all 0.100.0+dfsg-0+deb9u2 [66,5 kB]
Réception de:2 http://ftp.fr.debian.org/debian stretch/main amd64 libclamav7 amd64 0.100.0+dfsg-0+deb9u2 [758 kB]
Réception de:3 http://ftp.fr.debian.org/debian stretch/main amd64 clamav-freshclam amd64 0.100.0+dfsg-0+deb9u2 [167 kB]
Réception de:4 http://ftp.fr.debian.org/debian stretch/main amd64 clamav amd64 0.100.0+dfsg-0+deb9u2 [164 kB]
1 155 ko réceptionnés en 2s (532 ko/s)
Préconfiguration des paquets...
Sélection du paquet clamav-base précédemment désélectionné.
(Lecture de la base de données... 381663 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../clamav-base_0.100.0+dfsg-0+deb9u2_all.deb ...
Dépaquetage de clamav-base (0.100.0+dfsg-0+deb9u2) ...
Sélection du paquet libclamav7:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libclamav7_0.100.0+dfsg-0+deb9u2_amd64.deb ...
Dépaquetage de libclamav7:amd64 (0.100.0+dfsg-0+deb9u2) ...
Sélection du paquet clamav-freshclam précédemment désélectionné.
Préparation du dépaquetage de .../clamav-freshclam_0.100.0+dfsg-0+deb9u2_amd64.deb ...
Dépaquetage de clamav-freshclam (0.100.0+dfsg-0+deb9u2) ...
Sélection du paquet clamav précédemment désélectionné.
Préparation du dépaquetage de .../clamav_0.100.0+dfsg-0+deb9u2_amd64.deb ...
Dépaquetage de clamav (0.100.0+dfsg-0+deb9u2) ...
Paramétrage de clamav-base (0.100.0+dfsg-0+deb9u2) ...
Paramétrage de libclamav7:amd64 (0.100.0+dfsg-0+deb9u2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u3) ...
Traitement des actions différées (« triggers ») pour systemd (232-25+deb9u4) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Paramétrage de clamav-freshclam (0.100.0+dfsg-0+deb9u2) ...
Paramétrage de clamav (0.100.0+dfsg-0+deb9u2) ...



Par défaut, il ma garde la version 0.100.0 du dépôt main...

Comment puis-je forcer l'installation de clamav avec le dépôt stretch-updates ??

Dernière modification par rodinux (30-10-2018 17:12:49)


La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#2 30-10-2018 16:53:36

rodinux
Membre
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : upgrade de clamav, source pas à jour ?[Résolu]

Bon, j'ai trouvé mon erreur. J'avais configuré un fichier /etc/apt/preferences avec une priorité pour le dépôt stable. Comme je n'ai plus besoin de Pinning, je l'ai effacé et la version paquet de stretch-updates est proposée naturellement...

La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#3 30-10-2018 17:52:57

empanada
Membre
Distrib. : Debian 10 (Buster)
Noyau : 4.19.0-6-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : upgrade de clamav, source pas à jour ?[Résolu]

rodinux a écrit :

Bon, j'ai trouvé mon erreur. J'avais configuré un fichier /etc/apt/preferences avec une priorité pour le dépôt stable. Comme je n'ai plus besoin de Pinning, je l'ai effacé et la version paquet de stretch-updates est proposée naturellement...



yes.gif Parfait. Merci de partager la solution.

Ce n'était pas la meilleure solution à ton problème, mais je signale que tu peut forcer un nº version , même avec le pinning avec :

apt-get install nomdupaquet=nºversion



Dans ton cas, par exemple ça aurait été:

apt-get install clamav=0.100.2+dfsg-0+deb9u1



Salut

Dernière modification par empanada (30-10-2018 18:03:34)


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#4 30-10-2018 19:58:05

raleur
Membre
Inscription : 03-10-2014

Re : upgrade de clamav, source pas à jour ?[Résolu]

rodinux a écrit :

J'avais configuré un fichier /etc/apt/preferences avec une priorité pour le dépôt stable


Je trouvais aussi bizarre que stretch et stretch-updates aient des priorités différentes.
Mais je ne comprends pas pourquoi l'option -t était sans effet. C'est pourtant ce que j'utilise pour forcer l'installation de paquets de backports qui a une priorité inférieure à stable, et ça marche.


Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums