Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-11-2018 21:17:17

sizy458
Membre
Distrib. : Debian Stretch
Noyau : 4.9.0-11-amd64
(G)UI : gnome
Inscription : 16-06-2018

Erreur de rafraichissement de mise à jour

Bonjour,

J'ai Debian 9.5 Stretch installé.

Dans le gestionnaire de paquet synaptics ,
quand je clique sur "Recharger" ,j'ai l'erreur :
Échec du téléchargement de tous les fichiers d'index

Le dépôt ne semble plus être disponible ou ne peut être contacté à cause de problèmes de réseau. S'il existe un fichier d'index plus ancien, il sera utilisé. Sinon, le dépôt sera ignoré. Vérifiez votre connexion réseau et corrigez l'adresse du dépôt dans les préférences.

The repository 'http://deb.debian.org/debian stretch/updates Release' does not have a Release file.


Dans le fichier sources.list j'ai :

cat sources.list



#

# deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 NETINST 20180714-10:25]/ stretch main

# deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 NETINST 20180714-10:25]/ stretch main

deb http://deb.debian.org/debian/ stretch main

deb http://deb.debian.org/debian/ stretch/updates main
deb-src http://deb.debian.org/debian/ stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ stretch-updates main


#Added by my

# stretch-backports
#deb http://httpredir.debian.org/debian stretch-backports main contrib non-free

#https://blog.programster.org/debian-9-install-nvidia-drivers
#deb http://deb.debian.org/debian/ stretch contrib non-free

#deb http://deb.debian.org/debian/ stretch-updates contrib non-free

#deb http://security.debian.org/ stretch/updates main contrib non-free

 



Comment résoudre ce soucis ?

Merci

Dernière modification par sizy458 (11-11-2018 21:17:44)

Hors ligne

#2 12-11-2018 06:38:30

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Erreur de rafraichissement de mise à jour

Bonjour,
Il y a une adresse de dépôt à corriger

deb http://deb.debian.org/debian/ stretch/updates main


et une dépréciée avec httprdir mais qui n’a pas ici d’action car elle est commentée.
On va simplifier ton sources.list en supprimant les lignes inutiles avec la commande
Si tu veux les paquets non-free pour avoìr les firmwares par exemple, tu fais un copier coller de ce qui suit dans un terminal root


cat > /etc/apt/sources.list.d/test.list <<EOF
# Debian Stretch, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ stretch main contrib non-free
# Debian Stretch, mises à jour de sécurité + paquets non libres
deb http://security.debian.org/ stretch/updates main contrib non-free
# Debian Stretch, mises à jour "volatiles" + paquets non libres
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
EOF

 


Si tu n’as pas besoin des non-free, c’est ce qui suit qu’il faut copier coller


cat > /etc/apt/sources.list.d/test.list <<EOF
# Debian Stretch, dépôt principal
deb http://deb.debian.org/debian/ stretch main
# Debian Stretch, mises à jour de sécurité
deb http://security.debian.org/ stretch/updates main
# Debian Stretch, mises à jour "volatiles"
deb http://deb.debian.org/debian/ stretch-updates main
EOF

 


Ensuite tu fais la commande

apt update


et tu nous dis.

Hors ligne

#3 12-11-2018 22:46:13

sizy458
Membre
Distrib. : Debian Stretch
Noyau : 4.9.0-11-amd64
(G)UI : gnome
Inscription : 16-06-2018

Re : Erreur de rafraichissement de mise à jour

apt update me retourne :

apt update


bRéception de:1 http://security.debian.org stretch/updates InRelease [94,3 kB]
Ign:2 http://deb.debian.org/debian stretch InRelease              
Ign:3 http://deb.debian.org/debian stretch/updates InRelease      
Réception de:4 http://deb.debian.org/debian stretch-updates InRelease [91,0 kB]
Atteint:5 http://deb.debian.org/debian stretch Release            
Err:6 http://deb.debian.org/debian stretch/updates Release    
  404  Not Found [IP : 151.101.120.204 80]
Lecture des listes de paquets... Fait
E: The repository 'http://deb.debian.org/debian stretch/updates Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target Translations (main/i18n/Translation-fr_FR) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target Translations (main/i18n/Translation-fr) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target DEP-11 (main/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target DEP-11-icons-hidpi (main/dep11/icons-128x128.tar) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target Translations (main/i18n/Translation-fr_FR) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target Translations (main/i18n/Translation-fr) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target DEP-11 (main/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target DEP-11-icons-hidpi (main/dep11/icons-128x128.tar) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target Translations (main/i18n/Translation-fr_FR) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target Translations (main/i18n/Translation-fr) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target DEP-11 (main/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target DEP-11-icons-hidpi (main/dep11/icons-128x128.tar) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target Translations (main/i18n/Translation-fr_FR) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target Translations (main/i18n/Translation-fr) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target DEP-11 (main/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
W: Target DEP-11-icons-hidpi (main/dep11/icons-128x128.tar) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6
 



et j'ai ça :

The repository 'http://deb.debian.org/debian stretch/updates Release' does not have a Release file.Updating from such a repository can't be done securely, and is therefore disabled by default.See apt-secure(8) manpage for repository creation and user configuration details.Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6Target Translations (main/i18n/Translation-fr_FR) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6Target Translations (main/i18n/Translation-fr) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6Target DEP-11 (main/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6Target DEP-11-icons-hidpi (main/dep11/icons-128x128.tar) is configured multiple times in /etc/apt/sources.list:13 and /etc/apt/sources.list.d/test.list:6Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2Target Translations (main/i18n/Translation-fr_FR) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2Target Translations (main/i18n/Translation-fr) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2Target DEP-11 (main/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2Target DEP-11-icons-hidpi (main/dep11/icons-128x128.tar) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/test.list:2




Je pense que les liens deb sont configurer dans le sources.list et test.list,
je regarde ça demain.

Edit à toto : Modifié le second retour de commande en utilisant le bouton Citation pour le rendre plus lisible.

Dernière modification par sizy458 (12-11-2018 22:58:42)

Hors ligne

#4 13-11-2018 05:47:39

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Erreur de rafraichissement de mise à jour

sizy458 a écrit :

Je pense que les liens deb sont configurer dans le sources.list et test.list


Exactement.
Que donne le retour des commandes user :

cat /etc/apt/sources.list


cat /etc/apt/sources.list.d/test.list



Pour info sur la commande cat : https://debian-facile.org/doc:systeme:cat smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#5 13-11-2018 22:31:55

sizy458
Membre
Distrib. : Debian Stretch
Noyau : 4.9.0-11-amd64
(G)UI : gnome
Inscription : 16-06-2018

Re : Erreur de rafraichissement de mise à jour

Cela me donne :

cat /etc/apt/sources.list


#

# deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 NETINST 20180714-10:25]/ stretch main

# deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 NETINST 20180714-10:25]/ stretch main

deb http://deb.debian.org/debian/ stretch main

deb http://deb.debian.org/debian/ stretch/updates main
deb-src http://deb.debian.org/debian/ stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ stretch-updates main


#Added by my

# stretch-backports
#deb http://httpredir.debian.org/debian stretch-backports main contrib non-free

#https://blog.programster.org/debian-9-install-nvidia-drivers
#deb http://deb.debian.org/debian/ stretch contrib non-free

#deb http://deb.debian.org/debian/ stretch-updates contrib non-free

#deb http://security.debian.org/ stretch/updates main contrib non-free




cat /etc/apt/sources.list.d/test.list


# Debian Stretch, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ stretch main contrib non-free
# Debian Stretch, mises à jour de sécurité + paquets non libres
deb http://security.debian.org/ stretch/updates main contrib non-free
# Debian Stretch, mises à jour "volatiles" + paquets non libres
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
 

Hors ligne

#6 13-11-2018 22:43:53

sizy458
Membre
Distrib. : Debian Stretch
Noyau : 4.9.0-11-amd64
(G)UI : gnome
Inscription : 16-06-2018

Re : Erreur de rafraichissement de mise à jour

J'ai apparament résolu le probléme :

cat sources.list



#

# deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 NETINST 20180714-10:25]/ stretch main

# deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 NETINST 20180714-10:25]/ stretch main

#deb http://deb.debian.org/debian/ stretch main

#deprecier deb http://deb.debian.org/debian/ stretch/updates main
#deprecier deb-src http://deb.debian.org/debian/ stretch/updates main

# stretch-updates, previously known as 'volatile'
#deb http://deb.debian.org/debian/ stretch-updates main


#Added by my

# stretch-backports
#deb http://httpredir.debian.org/debian stretch-backports main contrib non-free

#https://blog.programster.org/debian-9-install-nvidia-drivers
#deb http://deb.debian.org/debian/ stretch contrib non-free

#deb http://deb.debian.org/debian/ stretch-updates contrib non-free

#deb http://security.debian.org/ stretch/updates main contrib non-free


 



cat test.list



# Debian Stretch, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ stretch main contrib non-free
# Debian Stretch, mises à jour de sécurité + paquets non libres
deb http://security.debian.org/ stretch/updates main contrib non-free
# Debian Stretch, mises à jour "volatiles" + paquets non libres
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
 

Dernière modification par sizy458 (13-11-2018 22:47:19)

Hors ligne

#7 14-11-2018 02:04:32

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Erreur de rafraichissement de mise à jour

sizy458 a écrit :

J'ai apparament résolu le probléme


Donc en pratique, tu ne conserves actives que les sources du fichier nommé : test.list qui sont les sources officielles dans ton cas.
Pour faire propre, je te propose de supprimer le fichier sources.list qui n'est plus activé en raison des # sur toutes les lignes :

rm /etc/apt/sources.list


et de mettre à la place le test.list en le renommant ainsi :

mv /etc/apt/sources.list.d/test.list /etc/apt/sources.list



Ce qui donnera une configuration basique de tes sources sans barguigner sur le nom des fichiers sources comme actuellement. smile

'Barguigner'. Voilà un verbe ancien qui a été très utilisé du XIIe au XVIe siècle et qui n'a survécu dans notre langue moderne que dans cette expression qui date du début du XVe.

À l'origine, 'barguigner', dont l'étymologie reste discutée, signifiait 'marchander longuement'.
C'est par référence à la longueur du marchandage et au temps passé avant de prendre la décision d'acheter ou de renoncer, qu'il a également et rapidement pris le sens d'hésiter.


Force et courage

Dernière modification par smolski (14-11-2018 02:08:04)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#8 14-11-2018 06:23:16

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Erreur de rafraichissement de mise à jour

Ah oui c’est de ma faute, j’ai fait un copier coller du wiki cat pour ne pas tout taper mais j’ai oublié de corriger le fichier ciblé.

Hors ligne

Pied de page des forums