Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-11-2018 16:52:56

nowanim
Membre
Distrib. : debian
Noyau : Linux 4.19.0-2-amd64
(G)UI : xfce
Inscription : 02-11-2018

Problèmes au démarage de debian [Résolu].

Bonjour,

A savoir : j'ai une batterie défectueuse peut être est-ce en lien.

J'ai un ou plusieurs  soucis  au démarrage de Debian, d'habitude juste un "ACPI error" que je voulais régler mais vu que ça marchais je n'ai pas insisté,je me disais plus tard...je sais c'est mal.

Un problème qui semblais plus important  a commencé depuis peu, j'avais impression que quand j'’éteignais l'ordi avec le wifi allumé au redémarrage il déconnais et figeais sur lldm. ou alors quelque temps après avoir mate démarre...sur ce point je comprends pas trop la cause mais une fois que je redémarrais avec wifi éteint et batterie branché plus de problème.

La je viens de redémarrer et l'ordi m'a dit:

systemdfsck@.service: 9 Failed to resolve unit specifiers on File System Check on %f, ignoring: invalid argument
systemd-fsck@.service: 20 Failed to resolve unit specifiers on %f ignoring: no such directory
service lacks both execstart= and execstop= setting. refusing



voilà à partir de là je ne comprends pas très bien, peut être qu j'ai mal installé ou mal mis à jour...en fait je sais pas mais j'aimerais comprendre et résoudre ce problème, donc merci de vos avis et orientation.

ps: J'essayerai de donner tout ce qui peut aider car j'ai accès à l'ordi avec la liveusb, donc si vous me dites où chercher je devrais pouvoir retrouver

Dernière modification par nowanim (18-11-2018 13:44:08)

Hors ligne

#2 17-11-2018 19:44:29

nowanim
Membre
Distrib. : debian
Noyau : Linux 4.19.0-2-amd64
(G)UI : xfce
Inscription : 02-11-2018

Re : Problèmes au démarage de debian [Résolu].

Voilà ce que donne la console au démarage:

ACPI error : No handler For Region [ec...] [EnbeddedControl]
ACPI error : Region EmbeddedControl (id=3) has no handler
ACPI error : Method parse/execution failed [\_SB.PCIO.LPCB.EC._REG] AE_NOT_EXIST
[FAILED] Failed to start Files System Check on /dev/disk/by_uuid/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx.
See 'systemctl status "systemd-fsck@dev-disk/by_uuid/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx.service"' for details.
[DEPEND] Dependency Failed for /tmp.
[DEPEND] Dependency Failed for Network Time Synchronization.
[DEPEND] Dependency Failed for Local File Systems.


puis après quelques lignes,que je n'ai retranscrit car elles sont précédées de [OK] et donc j'en déduit qu'elles ne présentaient pas de problèmes; pour finir la machine toujours aussi serviable me propose d'ouvrir de regarder les log et me demande le mot de passe root pour ce faire.
Je le rentre et c'est là que j'ai tapé la commande proposé après le [FAILED]:

systemctl status "systemd-fsck@dev-disk/by_uuid/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx.service"


systemdfsck@.service: 9 Failed to resolve unit specifiers on File System Check on %f, ignoring: invalid argument
systemd-fsck@.service: 20 Failed to resolve unit specifiers on %f ignoring: no such directory
service lacks both execstart= and execstop= setting. refusing



PS: pour la couleur faut imaginer [FAILED] et [DEPEND] j'ai pas réussi à mettre la couleur dans les bb code de ...code.

Dernière modification par nowanim (17-11-2018 19:58:24)

Hors ligne

#3 17-11-2018 22:52:13

raleur
Membre
Inscription : 03-10-2014

Re : Problèmes au démarage de debian [Résolu].

nowanim a écrit :

Dependency Failed for /tmp


On dirait qu'il y a un problème avec /tmp. On peut voir la sortie de la commande blkid et le contenu du fichier /etc/fstab ?

Hors ligne

#4 17-11-2018 23:10:27

nowanim
Membre
Distrib. : debian
Noyau : Linux 4.19.0-2-amd64
(G)UI : xfce
Inscription : 02-11-2018

Re : Problèmes au démarage de debian [Résolu].

cat /etc/fstab


# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=4ee34067-dcbb-4fd3-823e-25a0b92635b3 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda8 during installation
UUID=633281cc-f3be-4daa-a961-75c9a3bc7faf /home           ext4    defaults        0       2
# /tmp was on /dev/sda7 during installation
UUID=6585e700-00f7-4be6-92c8-dd3bdeca4d1f /tmp            ext4    defaults        0       2
# /var was on /dev/sda5 during installation
UUID=a64de58b-0062-4471-96c5-647e45801c53 /var            ext4    defaults        0       2
# swap was on /dev/sda6 during installation
UUID=fb1e5b8f-490e-4bbf-bf76-8b1acdda7e53 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
 


blkid


/dev/sda1: UUID="2017-09-08-11-09-10-00" LABEL="ParrotSec" TYPE="iso9660" PARTUUID="da383b8a-01"
/dev/sda2: SEC_TYPE="msdos" UUID="8022-4756" TYPE="vfat" PARTUUID="da383b8a-02"
/dev/sdb1: UUID="4ee34067-dcbb-4fd3-823e-25a0b92635b3" TYPE="ext4" PARTUUID="5a006f7c-01"
/dev/sdb5: UUID="a64de58b-0062-4471-96c5-647e45801c53" TYPE="ext4" PARTUUID="5a006f7c-05"
/dev/sdb6: UUID="fb1e5b8f-490e-4bbf-bf76-8b1acdda7e53" TYPE="swap" PARTUUID="5a006f7c-06"
/dev/sdb7: UUID="6585e700-00f7-4be6-92c8-dd3bdeca4d1f" TYPE="ext4" PARTUUID="5a006f7c-07"
/dev/sdb8: UUID="633281cc-f3be-4daa-a961-75c9a3bc7faf" TYPE="ext4" PARTUUID="5a006f7c-08"
/dev/loop0: TYPE="squashfs"
 

Dernière modification par nowanim (17-11-2018 23:10:49)

Hors ligne

#5 17-11-2018 23:26:44

raleur
Membre
Inscription : 03-10-2014

Re : Problèmes au démarage de debian [Résolu].

Pas d'incohérence. 6585e700-00f7-4be6-92c8-dd3bdeca4d1f est bien l'UUID qui figure dans les messages ? Si oui, que donne

df -hT
fsck /dev/sdb7

Dernière modification par raleur (17-11-2018 23:27:14)

Hors ligne

#6 18-11-2018 02:10:42

nowanim
Membre
Distrib. : debian
Noyau : Linux 4.19.0-2-amd64
(G)UI : xfce
Inscription : 02-11-2018

Re : Problèmes au démarage de debian [Résolu].

oui c'est bien ça

df -ht


Sys. de fichiers Type     Taille Utilisé Dispo Uti% Monté sur
udev             devtmpfs   3,9G       0  3,9G   0% /dev
tmpfs            tmpfs      789M    9,4M  780M   2% /run
/dev/sda1        iso9660    3,5G    3,5G     0 100% /lib/live/mount/medium
/dev/loop0       squashfs   3,3G    3,3G     0 100% /lib/live/mount/rootfs/filesystem.squashfs
tmpfs            tmpfs      3,9G       0  3,9G   0% /lib/live/mount/overlay
overlay          overlay    3,9G    120M  3,8G   4% /
tmpfs            tmpfs      3,9G    120K  3,9G   1% /dev/shm
tmpfs            tmpfs      5,0M    4,0K  5,0M   1% /run/lock
tmpfs            tmpfs      3,9G       0  3,9G   0% /sys/fs/cgroup
tmpfs            tmpfs      3,9G    4,0K  3,9G   1% /tmp
tmpfs            tmpfs      789M     40K  789M   1% /run/user/1000
/dev/sdb8        ext4       645G     44G  570G   8% /media/user/633281cc-f3be-4daa-a961-75c9a3bc7faf
/dev/sdb1        ext4        23G    5,0G   17G  23% /media/user/4ee34067-dcbb-4fd3-823e-25a0b92635b3
/dev/sdb5        ext4       9,2G    753M  7,9G   9% /media/user/a64de58b-0062-4471-96c5-647e45801c53
 


fsck /dev/sdb7


fsck from util-linux 2.29.2
e2fsck 1.43.6 (29-Aug-2017)
/dev/sdb7 contains a file system with errors, check forced.
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Unattached inode 22
Connect to /lost+found<y>? yes
Inode 22 ref count is 2, should be 1.  Fix<y>? yes
Pass 5: Checking group summary information

/dev/sdb7: ***** FILE SYSTEM WAS MODIFIED *****
/dev/sdb7: 18/122160 files (0.0% non-contiguous), 17306/487936 blocks
 


...à cette deuxième commande j'ai répond par l'affirmative aux deux questions ça me paraissait approprié,non?

Hors ligne

#7 18-11-2018 09:27:42

raleur
Membre
Inscription : 03-10-2014

Re : Problèmes au démarage de debian [Résolu].

Oui. Est-ce que l'erreur est toujours présente au démarrage maintenant ?

Dernière modification par raleur (18-11-2018 09:28:14)

Hors ligne

#8 18-11-2018 12:43:52

nowanim
Membre
Distrib. : debian
Noyau : Linux 4.19.0-2-amd64
(G)UI : xfce
Inscription : 02-11-2018

Re : Problèmes au démarage de debian [Résolu].

Merci! Et désolé je ne me suis pas reconnecté hier soir, mais oui c'est réglé.

Bon j'ai pas tout compris mais c'est un début et surtout ça me donne encore plus envie de comprendre ce qu'il se passe là dedans. Ça fait peu de temps que je m'y suis mis et je crois que je survole un peu trop. Un jour je serai sérieux et j’espère pouvoir aider aussi...dans quelques années.

Hors ligne

#9 18-11-2018 13:18:41

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : Problèmes au démarage de debian [Résolu].


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#10 18-11-2018 13:46:14

nowanim
Membre
Distrib. : debian
Noyau : Linux 4.19.0-2-amd64
(G)UI : xfce
Inscription : 02-11-2018

Re : Problèmes au démarage de debian [Résolu].

Oui, merci pour le lien je l'ai cherché un peu vite tout à l'heure, désolé.

Enfin voilà c'est fait !

Hors ligne

#11 18-11-2018 14:37:06

raleur
Membre
Inscription : 03-10-2014

Re : Problèmes au démarage de debian [Résolu].

nowanim a écrit :

Bon j'ai pas tout compris


A priori la vérification du système de fichiers de la partition montée sur /tmp provoquait une erreur à cause d'un "inode" (sorte de descripteur de fichier) "non attaché" (je suppose que c'est synonyme d'"orphelin", c'est-à-dire un fichier ou répertoire qui n'était attaché à aucun répertoire. Lors de la réparation il a été copié dans le répertoire /lost+found, tu peux l'examiner pour savoir ce que c'était.

Edit : si tu veux que le démarrage ne bloque pas sur ce type d'erreur, tu peux changer le "2" à la fin des lignes dans /etc/fstab par "0".

Dernière modification par raleur (18-11-2018 14:38:08)

Hors ligne

#12 18-11-2018 15:00:34

nowanim
Membre
Distrib. : debian
Noyau : Linux 4.19.0-2-amd64
(G)UI : xfce
Inscription : 02-11-2018

Re : Problèmes au démarage de debian [Résolu].

Merci pour cette explication. Je vais regarder ça et...

raleur a écrit :

tu peux changer le "2" à la fin des lignes dans /etc/fstab par "0".

...merci pour ça aussi.

Dernière modification par nowanim (18-11-2018 15:00:48)

Hors ligne

Pied de page des forums