Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-11-2018 22:21:23

Stephdeb
Membre
Distrib. : Debian 9.11 stretch
Noyau : Linux 4.9.0-11-amd64
(G)UI : Gnome
Inscription : 17-07-2017

[Résolu] Carte Wifi : failed to load ath10k

Bonjour !
Je vous sollicite pour un problème de carte wifi..
J'ai bien suivi le wiki https://debian-facile.org/doc:materiel:wifi:detecter
J'ai peut-être fait une erreur, néanmoins je progresse smile
Voici les résultats des commandes indiqués sur le wiki:

lspci -nnk | grep -i network -A 3


03:00.0 Network controller [0280]: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter [168c:0042] (rev 31)
  Subsystem: Lite-On Communications Inc QCA9377 802.11ac Wireless Network Adapter [11ad:08a6]
  Kernel driver in use: ath10k_pci
  Kernel modules: ath10k_pci
 



ip a


1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp2s0f1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether d8:c4:97:aa:80:c8 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.45/24 brd 192.168.1.255 scope global dynamic enp2s0f1
       valid_lft 86288sec preferred_lft 86288sec
    inet6 fe80::dac4:97ff:feaa:80c8/64 scope link
       valid_lft forever preferred_lft forever
 



dmesg | grep firmware


[    0.036723] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    5.004740] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:03:00.0.bin (-2)
[    5.004784] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:03:00.0.bin failed with error -2
[    5.004793] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/cal-pci-0000:03:00.0.bin (-2)
[    5.004846] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/cal-pci-0000:03:00.0.bin failed with error -2
[    5.004852] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/QCA9377/hw1.0/firmware-5.bin (-2)
[    5.004887] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-5.bin failed with error -2
[    5.004890] ath10k_pci 0000:03:00.0: could not fetch firmware file 'ath10k/QCA9377/hw1.0/firmware-5.bin': -2
[    5.004930] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/QCA9377/hw1.0/firmware-4.bin (-2)
[    5.004964] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-4.bin failed with error -2
[    5.004966] ath10k_pci 0000:03:00.0: could not fetch firmware file 'ath10k/QCA9377/hw1.0/firmware-4.bin': -2
[    5.005005] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/QCA9377/hw1.0/firmware-3.bin (-2)
[    5.005039] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-3.bin failed with error -2
[    5.005041] ath10k_pci 0000:03:00.0: could not fetch firmware file 'ath10k/QCA9377/hw1.0/firmware-3.bin': -2
[    5.005080] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/QCA9377/hw1.0/firmware-2.bin (-2)
[    5.005114] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-2.bin failed with error -2
[    5.005116] ath10k_pci 0000:03:00.0: could not fetch firmware file 'ath10k/QCA9377/hw1.0/firmware-2.bin': -2
[    5.005151] ath10k_pci 0000:03:00.0: could not fetch firmware files (-2)
[    5.382749] r8169 0000:02:00.1: firmware: direct-loading firmware rtl_nic/rtl8411-2.fw
 


apt-cache search rtl_nic/rtl8411-2.fw


firmware-realtek - Binary firmware for Realtek wired/wifi/BT adapters



sudo apt-get update && sudo apt-get install firmware-realtek


firmware-realtek installé



J'ai essayé de redémarrer, rien n'y change le firmware affiche toujours :
"failed to load ath10k/QCA9377/hw1.0/firmware-5.bin"

la commande

ls /lib/firmware/ath10k/QCA9377/hw1.0/


affiche bien la présence des fichiers

board-2.bin  board.bin  firmware-5.bin



Si vous avez une solution, je vous remercie grandement !
Merci d'avance smile

Dernière modification par Stephdeb (21-11-2018 13:46:14)

Hors ligne

#2 20-11-2018 23:05:07

Stephdeb
Membre
Distrib. : Debian 9.11 stretch
Noyau : Linux 4.9.0-11-amd64
(G)UI : Gnome
Inscription : 17-07-2017

Re : [Résolu] Carte Wifi : failed to load ath10k

Problème résolu je crois smile
J'ai supprimer la connexion automatique ethernet via network manager :
szQhgbtt2Lh0.png

Après redémarrage avec cette suppression de connexion auto le problème semble résolu car je peux maintenant me connecter au réseau sans fil
néanmoins la commande

sudo dmesg | grep firmware



me renvoie ça :

[    0.036713] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    5.107674] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:03:00.0.bin (-2)
[    5.107717] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:03:00.0.bin failed with error -2
[    5.107728] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/cal-pci-0000:03:00.0.bin (-2)
[    5.107761] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/cal-pci-0000:03:00.0.bin failed with error -2
[    5.110015] ath10k_pci 0000:03:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/firmware-5.bin
[    5.110495] ath10k_pci 0000:03:00.0: firmware ver WLAN.TF.1.0-00267-1 api 5 features ignore-otp crc32 79cea2c7
[    5.173973] ath10k_pci 0000:03:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/board-2.bin
[    5.415266] r8169 0000:02:00.1: firmware: direct-loading firmware rtl_nic/rtl8411-2.fw



Qu'en pensez-vous ?

Dernière modification par Stephdeb (20-11-2018 23:11:30)

Hors ligne

#3 20-11-2018 23:29:45

empanada
Membre
Distrib. : Debian 10 (Buster)
Noyau : 4.19.0-6-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Résolu] Carte Wifi : failed to load ath10k

Stephdeb a écrit :

Problème résolu je crois smile
J'ai supprimer la connexion automatique ethernet via network manager :
https://framapic.org/daND6Yp8kr1y/szQhgbtt2Lh0.png
Après redémarrage avec cette suppression de connexion auto le problème semble résolu car je peux maintenant me connecter au réseau sans fil


Cette manoueuvre n'a pas résolu le problème . Le problème était le manque du firmware. En fait tu n'avait pas même interface réseau créé (sortie ip a montre aucune interface wifi, suelement les interfaces loopback et ethernet). Après installer le firmware, la carte wifi ne se connectait pas par cette configuration de network-manager, mais ça ce n'était un problème mais une configuration non voulue. T'as tour résolu tout seul...et en plus t'as partagé avec le monde, donc bravo!! wink

Stephdeb a écrit :

néanmoins la commande

sudo dmesg | grep firmware


me renvoie ça :

[    0.036713] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    5.107674] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:03:00.0.bin (-2)
[    5.107717] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:03:00.0.bin failed with error -2
[    5.107728] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/cal-pci-0000:03:00.0.bin (-2)
[    5.107761] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/cal-pci-0000:03:00.0.bin failed with error -2
[    5.110015] ath10k_pci 0000:03:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/firmware-5.bin
[    5.110495] ath10k_pci 0000:03:00.0: firmware ver WLAN.TF.1.0-00267-1 api 5 features ignore-otp crc32 79cea2c7
[    5.173973] ath10k_pci 0000:03:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/board-2.bin
[    5.415266] r8169 0000:02:00.1: firmware: direct-loading firmware rtl_nic/rtl8411-2.fw



Qu'en pensez-vous ?



Rien d'important à mon avis. Je pense que le pilote cherche le firmware dans la carte même et comme il ne rencontre pas, il le cherche sur /lib/firmware...et il le rencontre, donc pas soucis.

Dernière modification par empanada (20-11-2018 23:30:07)


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#4 21-11-2018 07:50:35

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : [Résolu] Carte Wifi : failed to load ath10k

Il ne reste plus qu’a ajouter résolu dans le titre du fil en cliquant sur modifier en bas de ton premier message smile

Hors ligne

#5 21-11-2018 13:47:58

Stephdeb
Membre
Distrib. : Debian 9.11 stretch
Noyau : Linux 4.9.0-11-amd64
(G)UI : Gnome
Inscription : 17-07-2017

Re : [Résolu] Carte Wifi : failed to load ath10k

Merci pour ta réponse Empanada big_smile
A + !

Hors ligne

Pied de page des forums