Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 26-11-2018 14:38:55

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Problème démarrage Virtual Box

Bonjour

2.3.2 Le module noyau de VirtualBox
VirtualBox utilise un module spécial du noyau appelé vboxdrv pour effectuer des affectations de
mémoire physique et contrôler le processeur pour exécuter les systèmes invités. Sans ce mod-
ule du noyau, vous pouvez utiliser le gestionnaire de VirtualBox pour configurer des machines
virtuelles mais elles ne démarreront pas. En outre, existe des modules noyau vboxnetflt et
vboxnetadp requis pour les fonctionnalités réseau plus avancées de VirtualBox.
Le module noyau de VirtualBox est automatiquement installé sur votre système quand vous
installez VirtualBox. Pour le maintenir avec les futures mises à jour du noyau, pour les distri-
butions Linux qui le permettent – la plupart de celles actuelles – nous recommandons d’installer
Dynamic Kernel Module Support (DKMS) 2 . Cet environnement vous aide à construire et à mettre
à jour les modules du noyau.
Si DKMS n’est pas déjà installé, exécutez une des procédures suivantes :
• Sur un système Ubuntu :
sudo apt-get install dkms
• Sur un système Fedora :
yum install dkms
• Sur un système Mandriva ou Mageia :
urpmi dkms
Si DKMS est disponible et installé, le module du noyau VirtualBox devrait toujours fonctionner
automatiquement et il sera automatiquement reconstruit si vous mettez à jour le noyau de votre
hôte.
Sinon, il n’y a que deux situations où vous devrez vous préoccuper du module noyau :
1. L’installation échoue dès le départ. Cela signifie probablement que votre système Linux
n’est pas prêt à construire des modules noyau externes.
La plupart des distributions Linux peuvent être paramétrées simplement en installant les
bons paquets - en principe il s’agit du compilateur GNU (GCC), GNU Make (make) et des
paquets contenant les fichiers d’en-tête de votre noyau - et en s’assurant que toutes les
mises à jour du système sont installées et que le système exécute le noyau le plus récent
proposé par la distribution. Les numéros de version des paquets des fichiers d’en-tête doivent
être les mêmes que celui du noyau que vous utilisez.
• Avec les versions Debian et Ubuntu, vous devez installer la bonne version de
linux-headers et s’il existe, le paquet linux-kbuild . Les versions actuelles
d’Ubuntu devraient avoir installé les bons paquets par défaut.



https://debian-facile.org/viewtopic.php?id=21935

lsmod |grep vbox


doit renvoyer un résultat sinon c'est que le module n'a pas été construit

Dernière modification par Croutons (26-11-2018 14:40:56)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#27 26-11-2018 20:06:10

Jkart
Membre
Distrib. : Buster
Noyau : 4.19.0-6-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Problème démarrage Virtual Box

Bonjour,

Réponse à Debian Alain
L'option virtualisation matérielle n'existe pas sur mon Bios. Sous Vista (machine hôte) cette virtualisation était nécessaire pour des invités 64 b mais pas des invités 32 b. C'est comme cela que j'ai débuté avec Linux en installant Debian 32 b dans une VBox et sans virtualisation.
La VBox installé dans Vista est toujours fonctionnelle. J'ai abandonné les mise à jour depuis peu de temps.
J'espère que c'est la même chose avec une DF (toujours 32 b) qui tiendrait à présent le rôle de l'hôte.

Réponse à Croutons
La commande

lsmod |grep vbox



ne renvoie rien.

Là je suis un peu perdu que faut-il installer pour construire ce module vboxdrv?

Dernière modification par Jkart (26-11-2018 20:08:05)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Windows 10/Buster
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#28 26-11-2018 20:47:29

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Problème démarrage Virtual Box

L'option virtualisation matérielle n'existe pas sur mon Bios. Sous Vista (machine hôte) cette virtualisation était nécessaire pour des invités 64 b mais pas des invités 32 b. C'est comme cela que j'ai débuté avec Linux en installant Debian 32 b dans une VBox et sans virtualisation.
La VBox installé dans Vista est toujours fonctionnelle. J'ai abandonné les mise à jour depuis peu de temps.
J'espère que c'est la même chose avec une DF (toujours 32 b) qui tiendrait à présent le rôle de l'hôte.


Je suis plus trop sur de comprendre la machine hote tourne avec quel système Vista ou Debian?
Dans ton message 1 tu dis que la machine est sur Debian?


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#29 26-11-2018 20:54:57

Jkart
Membre
Distrib. : Buster
Noyau : 4.19.0-6-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Problème démarrage Virtual Box

J'ai installé un dual boot Debian Facile / Vista. Vista est l'OS d'origine que j'ai quasiment abandonné mais que j'ai conservé.
Debian Facile (32 bits) est ma machine principale, et j'aimerais y installer virtual box.
Cordialement

Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Windows 10/Buster
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#30 26-11-2018 21:15:25

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.3.0-2 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Problème démarrage Virtual Box

toutes mes recherches me répondent de commencer par mettre à jour le bios sur le site de HP. big_smile

par ailleurs , JKart , la désignation de ta machine n'est pas bonne . lol

il y a au moins 2 ou 3 modèles  qui portent ce nom . tongue

faudrait que tu sois plus précis ....  ops.gif

je suis systematiquement confirmé comme quoi il y a bien une fonction de virtualisation du proc. sur ta machine , dans ton bios . kernal_panic.gif

respectueusement ,

amicalement ,

Alain.

coyotus.png

Dernière modification par Debian Alain (26-11-2018 21:16:48)


CelKilt / Petit Papa Noël cover / Official video

RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#31 26-11-2018 21:25:43

Jkart
Membre
Distrib. : Buster
Noyau : 4.19.0-6-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Problème démarrage Virtual Box

Bonsoir,
je te promet que j'ai parcouru le bios sans jamais la trouver. La fonction de virtualisation est lié au processeur et si j'ai bien compris (site Intel) le mien ne le permet pas. Et je te garantis également que j'ai installé une VBox fonctionnelle (avec des invités 32 bit) sans virtualisation dans Vista (hôte).
Cordialement

Dernière modification par Jkart (26-11-2018 22:30:54)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Windows 10/Buster
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#32 26-11-2018 21:44:44

empanada
Membre
Distrib. : Debian 9 (Stretch)
Noyau : 4.9.0-7-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : Problème démarrage Virtual Box

Debian Alain a écrit :

as tu essayé de vérifier que la virtualisation  du processeur est bien en service (bios) ?


Ça n'a rien à avoir avec les échecs dans la compilation des modules du noyau. Rien du tout.

Croutons a écrit :

doit renvoyer un résultat sinon c'est que le module n'a pas été construit


C'est dit, au moins, quatre fois avant:

Building initial module for 4.9.0-8-686
Error! Bad return status for module build on kernel: 4.9.0-8-686 (i686)
Consult /var/lib/dkms/virtualbox/5.2.22/build/make.log for more information.



Debian Alain a écrit :

tu as fait beaucoup de tentatives et souvent les mêmes .


Sur ce point je suis d'accord. Ici ce n'est pas windows. Réinstaller normalement sert à rien...et t'as fait plusieurs fois. Si on ne change rien dans les procédures, on va rien obtenir de différent dans les résultats.
As-tu essayé à installer un noyau (et ses linux-headers) stretch-backports amd64 ? Je suspect que non.

En dehors d'essayer des autres noyaux (je ferais le premier), je ne vois pas que deux alternatives:
- Rapporter le bouge dans la page du paquet virtualbox-dkms sur le site debian , et attendre une réponse des responsables du paquet
- Essayer une autre version de virtualbox plus vieille. Les problèmes avec la compilation des modules virtualbox backports ne sont pas rares quand debian s'approche à la fin de son cycle.

Salut

Dernière modification par empanada (26-11-2018 21:49:15)


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#33 26-11-2018 21:45:09

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.3.0-2 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Problème démarrage Virtual Box

tu parles de  celui là ?  https://www.cnet.com/products/hp-pavili … ies/specs/

empanada a écrit :


Debian Alain a écrit :

as tu essayé de vérifier que la virtualisation  du processeur est bien en service (bios) ?


Ça n'a rien à avoir avec les échecs dans la compilation des modules du noyau. Rien du tout.



comme j'ai pas la science infuse , pourquoi pas ???

empanada a écrit :

En dehors d'essayer des autres noyaux (je ferais le premier), je ne vois pas que deux alternatives:
- Rapporter le bouge dans la page du paquet virtualbox-dkms sur le site debian , et attendre une réponse des responsables du paquet
- Essayer une autre version de virtualbox plus vieille. Les problèmes avec la compilation des modules virtualbox backports ne sont pas rares quand debian s'approche à la fin de son cycle.


je pencherai pour les deux :
- rapport du bogue à debian et
- installation d'une version plus vieille .

https://www.debian.org/Bugs/Reporting.fr.html

https://www.virtualbox.org/wiki/Downloads

j'ai pas trouvé mieux comme liens

Dernière modification par Debian Alain (26-11-2018 22:01:12)


CelKilt / Petit Papa Noël cover / Official video

RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#34 26-11-2018 22:07:00

Jkart
Membre
Distrib. : Buster
Noyau : 4.19.0-6-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Problème démarrage Virtual Box

Non ce n'est pas celui là.
Je suis retourné voir mais je n'ai pas trouvé grand chose.
N° de série CND 8434R2P
HP Pavilion dv7 notebook PC
n° du produit FP906EA#ABF

Je n'ai pas eu le temps de tenter autre chose.
je veux bien tenter avec un quatrième noyau (amd 64)

Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Windows 10/Buster
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#35 26-11-2018 22:17:49

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.3.0-2 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Problème démarrage Virtual Box

avec tes références , j'ai trouvé celui là :  https://www.ubaldi.com/informatique-tel … 580708.php

CelKilt / Petit Papa Noël cover / Official video

RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#36 26-11-2018 22:30:19

Jkart
Membre
Distrib. : Buster
Noyau : 4.19.0-6-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Problème démarrage Virtual Box

Les caractéristiques semblent les même.

J'ai essayé

sudo apt-get install linux-image-4.9.0-8-amd64 linux-headers-4.9.0-8-amd64



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet linux-image-4.9.0-8-amd64
E: Couldn't find any package by glob 'linux-image-4.9.0-8-amd64'
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « linux-image-4.9.0-8-amd64 »
E: Impossible de trouver le paquet linux-headers-4.9.0-8-amd64
E: Couldn't find any package by glob 'linux-headers-4.9.0-8-amd64'
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « linux-headers-4.9.0-8-amd64 »



Apparemment on ne passe pas si facilement d'un 32 b à un 64 b. ou alors ce n'est pas la bonne commande??

Ce sera tout pour moi ce soir, demain je bosse.
Bonne soirée et merci à tous

Dernière modification par Jkart (26-11-2018 22:32:44)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Windows 10/Buster
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#37 27-11-2018 18:21:53

empanada
Membre
Distrib. : Debian 9 (Stretch)
Noyau : 4.9.0-7-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : Problème démarrage Virtual Box

Pardon. Je viens de découvrir que les dépôts i386 ne contiennent plus les noyaux amd64. Jusqu'au jessie, ils les avaient. Ça fait longtemps que je n'utilise pas architecture i386 sur des ordinateurs 64 bits.
Alors, pour installer un noyau amd64 sur une installation i386:

dpkg --add-architecture amd64
apt-get update
apt-get install -t stretch-backports linux-image-amd64:amd64 linux-headers-amd64:amd64



Debian Alain a écrit :

comme j'ai pas la science infuse , pourquoi pas ???


Parce que les technologies de virtualisation hardware activés sur BIOS, ne sont pas obligatoires pour virtualiser des systèmes d'exploitation. Elles sont une aide pour améliorer la performance (et un certain risque de sécurité) , mais pas obligatoires. Regarde l'onglet "Système" sur VirtualBox: les options VT-x/AMD-v sont des casses à cocher, donc pas obligatoires.

Salut


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#38 27-11-2018 20:02:19

Jkart
Membre
Distrib. : Buster
Noyau : 4.19.0-6-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Problème démarrage Virtual Box

Bonsoir,

sudo dpkg --add-architecture amd64



[sudo] Mot de passe de jean-claude :

 


sudo apt-get update




Ign:1 http://deb.debian.org/debian stable InRelease
Réception de:2 http://security.debian.org stable/updates InRelease [94,3 kB]
Réception de:3 http://deb.debian.org/debian stable-updates InRelease [91,0 kB]
Réception de:4 http://deb.debian.org/debian stretch-backports InRelease [91,8 kB]
Réception de:5 http://security.debian.org stretch/updates InRelease [94,3 kB]  
Atteint:6 http://deb.debian.org/debian stable Release                          
Réception de:7 http://deb.debian.org/debian stable-updates/main amd64 Packages [5 152 B]
Réception de:8 http://deb.debian.org/debian stable-updates/main amd64 Contents (deb) [19,5 kB]
Réception de:9 http://security.debian.org stable/updates/main amd64 Packages [460 kB]
Réception de:10 http://deb.debian.org/debian stretch-backports/main i386 Packages.diff/Index [27,8 kB]
Réception de:11 http://deb.debian.org/debian stretch-backports/main i386 Contents (deb).diff/Index [27,9 kB]
Réception de:12 http://deb.debian.org/debian stretch-backports/main i386 Packages 2018-11-26-2017.19.pdiff [214 B]
Réception de:13 http://deb.debian.org/debian stretch-backports/main i386 Packages 2018-11-27-0214.19.pdiff [3 284 B]
Réception de:13 http://deb.debian.org/debian stretch-backports/main i386 Packages 2018-11-27-0214.19.pdiff [3 284 B]
Réception de:14 http://deb.debian.org/debian stretch-backports/main i386 Contents (deb) 2018-11-26-2017.19.pdiff [658 B]
Réception de:16 http://security.debian.org stable/updates/main i386 Packages [462 kB]
Réception de:17 http://deb.debian.org/debian stretch-backports/main i386 Contents (deb) 2018-11-27-0214.19.pdiff [118 B]
Réception de:17 http://deb.debian.org/debian stretch-backports/main i386 Contents (deb) 2018-11-27-0214.19.pdiff [118 B]
Réception de:18 http://deb.debian.org/debian stretch-backports/main amd64 Packages [515 kB]
Réception de:19 http://deb.debian.org/debian stretch-backports/main amd64 Contents (deb) [5 796 kB]
Réception de:20 http://security.debian.org stable/updates/contrib amd64 Packages [1 760 B]
Réception de:21 http://security.debian.org stable/updates/non-free amd64 Packages [1 600 B]
Réception de:22 http://security.debian.org stretch/updates/main i386 Packages [462 kB]
Réception de:23 http://security.debian.org stretch/updates/main amd64 Packages [460 kB]
Réception de:24 http://security.debian.org stretch/updates/contrib amd64 Packages [1 760 B]
Réception de:25 http://security.debian.org stretch/updates/non-free amd64 Packages [1 600 B]
Réception de:26 http://deb.debian.org/debian stretch-backports/contrib amd64 Packages [7 620 B]
Réception de:27 http://deb.debian.org/debian stretch-backports/contrib amd64 Contents (deb) [22,6 kB]
Réception de:28 http://deb.debian.org/debian stretch-backports/non-free amd64 Packages [29,1 kB]
Réception de:29 http://deb.debian.org/debian stretch-backports/non-free amd64 Contents (deb) [115 kB]
Réception de:30 http://deb.debian.org/debian stable/main amd64 Packages [7 089 kB]
Réception de:31 http://deb.debian.org/debian stable/main amd64 Contents (deb) [31,4 MB]
Réception de:32 http://deb.debian.org/debian stable/contrib amd64 Packages [50,9 kB]
Réception de:33 http://deb.debian.org/debian stable/contrib amd64 Contents (deb) [90,3 kB]
Réception de:34 http://deb.debian.org/debian stable/non-free amd64 Packages [78,6 kB]
Réception de:35 http://deb.debian.org/debian stable/non-free amd64 Contents (deb) [809 kB]
48,3 Mo réceptionnés en 52s (929 ko/s)                                        
Lecture des listes de paquets... Fait



sudo apt-get install -t stretch-backports linux-image-amd64:amd64 linux-headers-amd64:amd64




Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 linux-image-amd64:amd64 : Dépend: linux-image-4.18.0-0.bpo.1-amd64:amd64 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 




Cela donne des choses que je ne comprends pas.


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Windows 10/Buster
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#39 27-11-2018 20:12:31

Jkart
Membre
Distrib. : Buster
Noyau : 4.19.0-6-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Problème démarrage Virtual Box

J'ai donc tenté d'installer quelque chose de plus classique.

sudo apt-get install linux-image-4.9.0-8-amd64 linux-headers-4.9.0-8-amd64




Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.9.0-3-686 linux-headers-4.9.0-3-common linux-image-4.9.0-3-686
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
The following additional packages will be installed:
  gcc-6-base:amd64 irqbalance:amd64 libblkid1:amd64 libc6:amd64 libcap-ng0:amd64 libffi6:amd64 libgcc1:amd64 libgcrypt20:amd64 libglib2.0-0:amd64
  libgpg-error0:amd64 liblz4-1:amd64 liblzma5:amd64 libmount1:amd64 libnuma1:amd64 libpcre3:amd64 libselinux1:amd64 libsystemd0:amd64 libuuid1:amd64
  zlib1g:amd64
Paquets suggérés :
  glibc-doc:amd64 locales:amd64 rng-tools:amd64 linux-doc-4.9:amd64 debian-kernel-handbook:amd64
Les paquets suivants seront ENLEVÉS :
  irqbalance
Les NOUVEAUX paquets suivants seront installés :
  gcc-6-base:amd64 irqbalance:amd64 libblkid1:amd64 libc6:amd64 libcap-ng0:amd64 libffi6:amd64 libgcc1:amd64 libgcrypt20:amd64 libglib2.0-0:amd64
  libgpg-error0:amd64 liblz4-1:amd64 liblzma5:amd64 libmount1:amd64 libnuma1:amd64 libpcre3:amd64 libselinux1:amd64 libsystemd0:amd64 libuuid1:amd64
  linux-headers-4.9.0-8-amd64:amd64 linux-image-4.9.0-8-amd64:amd64 zlib1g:amd64
0 mis à jour, 21 nouvellement installés, 1 à enlever et 6 non mis à jour.
Il est nécessaire de prendre 47,4 Mo dans les archives.
Après cette opération, 219 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://deb.debian.org/debian stable/main amd64 gcc-6-base amd64 6.3.0-18+deb9u1 [180 kB]
Réception de:2 http://deb.debian.org/debian stable/main amd64 libgcc1 amd64 1:6.3.0-18+deb9u1 [38,0 kB]
Réception de:3 http://deb.debian.org/debian stable/main amd64 libc6 amd64 2.24-11+deb9u3 [2 693 kB]
Réception de:4 http://deb.debian.org/debian stable/main amd64 libpcre3 amd64 2:8.39-3 [337 kB]
Réception de:5 http://deb.debian.org/debian stable/main amd64 libgpg-error0 amd64 1.26-2 [112 kB]
Réception de:6 http://deb.debian.org/debian stable/main amd64 libgcrypt20 amd64 1.7.6-2+deb9u3 [524 kB]
Réception de:7 http://deb.debian.org/debian stable/main amd64 liblz4-1 amd64 0.0~r131-2+b1 [33,3 kB]
Réception de:8 http://deb.debian.org/debian stable/main amd64 liblzma5 amd64 5.2.2-1.2+b1 [234 kB]
Réception de:9 http://deb.debian.org/debian stable/main amd64 libselinux1 amd64 2.6-3+b3 [101 kB]
Réception de:10 http://deb.debian.org/debian stable/main amd64 libsystemd0 amd64 232-25+deb9u6 [280 kB]
Réception de:11 http://deb.debian.org/debian stable/main amd64 libuuid1 amd64 2.29.2-1+deb9u1 [70,1 kB]
Réception de:12 http://deb.debian.org/debian stable/main amd64 libblkid1 amd64 2.29.2-1+deb9u1 [168 kB]
Réception de:13 http://deb.debian.org/debian stable/main amd64 libmount1 amd64 2.29.2-1+deb9u1 [178 kB]
Réception de:14 http://deb.debian.org/debian stable/main amd64 zlib1g amd64 1:1.2.8.dfsg-5 [87,5 kB]
Réception de:15 http://deb.debian.org/debian stable/main amd64 libcap-ng0 amd64 0.7.7-3+b1 [13,8 kB]
Réception de:16 http://deb.debian.org/debian stable/main amd64 libffi6 amd64 3.2.1-6 [20,4 kB]
Réception de:17 http://deb.debian.org/debian stable/main amd64 libglib2.0-0 amd64 2.50.3-2 [2 691 kB]
Réception de:18 http://deb.debian.org/debian stable/main amd64 libnuma1 amd64 2.0.11-2.1 [33,3 kB]                                                          
Réception de:19 http://deb.debian.org/debian stable/main amd64 linux-headers-4.9.0-8-amd64 amd64 4.9.130-2 [450 kB]                                          
Réception de:20 http://deb.debian.org/debian stable/main amd64 linux-image-4.9.0-8-amd64 amd64 4.9.130-2 [39,1 MB]                                          
Réception de:21 http://deb.debian.org/debian stable/main amd64 irqbalance amd64 1.1.0-2.3 [40,4 kB]                                                          
47,4 Mo réceptionnés en 41s (1 155 ko/s)                                                                                                                    
Préconfiguration des paquets...
(Lecture de la base de données... 203004 fichiers et répertoires déjà installés.)
Suppression de irqbalance (1.1.0-2.3) ...
Sélection du paquet gcc-6-base:amd64 précédemment désélectionné.
(Lecture de la base de données... 202998 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../0-gcc-6-base_6.3.0-18+deb9u1_amd64.deb ...
Dépaquetage de gcc-6-base:amd64 (6.3.0-18+deb9u1) ...
Sélection du paquet libgcc1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../1-libgcc1_1%3a6.3.0-18+deb9u1_amd64.deb ...
Dépaquetage de libgcc1:amd64 (1:6.3.0-18+deb9u1) ...
Sélection du paquet libc6:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../2-libc6_2.24-11+deb9u3_amd64.deb ...
Dépaquetage de libc6:amd64 (2.24-11+deb9u3) ...
Sélection du paquet libpcre3:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../3-libpcre3_2%3a8.39-3_amd64.deb ...
Dépaquetage de libpcre3:amd64 (2:8.39-3) ...
Sélection du paquet libgpg-error0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../4-libgpg-error0_1.26-2_amd64.deb ...
Dépaquetage de libgpg-error0:amd64 (1.26-2) ...
Sélection du paquet libgcrypt20:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../5-libgcrypt20_1.7.6-2+deb9u3_amd64.deb ...
Dépaquetage de libgcrypt20:amd64 (1.7.6-2+deb9u3) ...
Sélection du paquet liblz4-1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../6-liblz4-1_0.0~r131-2+b1_amd64.deb ...
Dépaquetage de liblz4-1:amd64 (0.0~r131-2+b1) ...
Sélection du paquet liblzma5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../7-liblzma5_5.2.2-1.2+b1_amd64.deb ...
Dépaquetage de liblzma5:amd64 (5.2.2-1.2+b1) ...
Sélection du paquet libselinux1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../8-libselinux1_2.6-3+b3_amd64.deb ...
Dépaquetage de libselinux1:amd64 (2.6-3+b3) ...
Paramétrage de gcc-6-base:amd64 (6.3.0-18+deb9u1) ...
Paramétrage de libgcc1:amd64 (1:6.3.0-18+deb9u1) ...
Paramétrage de libc6:amd64 (2.24-11+deb9u3) ...
Paramétrage de libgpg-error0:amd64 (1.26-2) ...
Paramétrage de libgcrypt20:amd64 (1.7.6-2+deb9u3) ...
Paramétrage de liblz4-1:amd64 (0.0~r131-2+b1) ...
Paramétrage de liblzma5:amd64 (5.2.2-1.2+b1) ...
Paramétrage de libpcre3:amd64 (2:8.39-3) ...
Paramétrage de libselinux1:amd64 (2.6-3+b3) ...
Sélection du paquet libsystemd0:amd64 précédemment désélectionné.
(Lecture de la base de données... 203326 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../00-libsystemd0_232-25+deb9u6_amd64.deb ...
Dépaquetage de libsystemd0:amd64 (232-25+deb9u6) ...
Sélection du paquet libuuid1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../01-libuuid1_2.29.2-1+deb9u1_amd64.deb ...
Dépaquetage de libuuid1:amd64 (2.29.2-1+deb9u1) ...
Sélection du paquet libblkid1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../02-libblkid1_2.29.2-1+deb9u1_amd64.deb ...
Dépaquetage de libblkid1:amd64 (2.29.2-1+deb9u1) ...
Sélection du paquet libmount1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../03-libmount1_2.29.2-1+deb9u1_amd64.deb ...
Dépaquetage de libmount1:amd64 (2.29.2-1+deb9u1) ...
Sélection du paquet zlib1g:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../04-zlib1g_1%3a1.2.8.dfsg-5_amd64.deb ...
Dépaquetage de zlib1g:amd64 (1:1.2.8.dfsg-5) ...
Sélection du paquet libcap-ng0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../05-libcap-ng0_0.7.7-3+b1_amd64.deb ...
Dépaquetage de libcap-ng0:amd64 (0.7.7-3+b1) ...
Sélection du paquet libffi6:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../06-libffi6_3.2.1-6_amd64.deb ...
Dépaquetage de libffi6:amd64 (3.2.1-6) ...
Sélection du paquet libglib2.0-0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../07-libglib2.0-0_2.50.3-2_amd64.deb ...
Dépaquetage de libglib2.0-0:amd64 (2.50.3-2) ...
Sélection du paquet libnuma1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../08-libnuma1_2.0.11-2.1_amd64.deb ...
Dépaquetage de libnuma1:amd64 (2.0.11-2.1) ...
Sélection du paquet linux-headers-4.9.0-8-amd64:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../09-linux-headers-4.9.0-8-amd64_4.9.130-2_amd64.deb ...
Dépaquetage de linux-headers-4.9.0-8-amd64:amd64 (4.9.130-2) ...
Sélection du paquet linux-image-4.9.0-8-amd64:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../10-linux-image-4.9.0-8-amd64_4.9.130-2_amd64.deb ...
Dépaquetage de linux-image-4.9.0-8-amd64:amd64 (4.9.130-2) ...
Sélection du paquet irqbalance:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../11-irqbalance_1.1.0-2.3_amd64.deb ...
Dépaquetage de irqbalance:amd64 (1.1.0-2.3) ...
Paramétrage de libuuid1:amd64 (2.29.2-1+deb9u1) ...
Paramétrage de zlib1g:amd64 (1:1.2.8.dfsg-5) ...
Paramétrage de linux-headers-4.9.0-8-amd64:amd64 (4.9.130-2) ...
Paramétrage de libnuma1:amd64 (2.0.11-2.1) ...
Traitement des actions différées (« triggers ») pour libglib2.0-0:i386 (2.50.3-2) ...
Paramétrage de libsystemd0:amd64 (232-25+deb9u6) ...
Paramétrage de libblkid1:amd64 (2.29.2-1+deb9u1) ...
Paramétrage de linux-image-4.9.0-8-amd64:amd64 (4.9.130-2) ...
I: /vmlinuz.old is now a symlink to boot/vmlinuz-4.18.0-0.bpo.1-686-pae
I: /initrd.img.old is now a symlink to boot/initrd.img-4.18.0-0.bpo.1-686-pae
I: /vmlinuz is now a symlink to boot/vmlinuz-4.9.0-8-amd64
I: /initrd.img is now a symlink to boot/initrd.img-4.9.0-8-amd64
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-4.9.0-8-amd64
/etc/kernel/postinst.d/zz-update-grub:
Création du fichier de configuration GRUB…
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Image Linux trouvée : /boot/vmlinuz-4.18.0-0.bpo.1-686-pae
Image mémoire initiale trouvée : /boot/initrd.img-4.18.0-0.bpo.1-686-pae
Image Linux trouvée : /boot/vmlinuz-4.9.0-8-686-pae
Image mémoire initiale trouvée : /boot/initrd.img-4.9.0-8-686-pae
Image Linux trouvée : /boot/vmlinuz-4.9.0-8-amd64
Image mémoire initiale trouvée : /boot/initrd.img-4.9.0-8-amd64
Image Linux trouvée : /boot/vmlinuz-4.9.0-8-686
Image mémoire initiale trouvée : /boot/initrd.img-4.9.0-8-686
Image Linux trouvée : /boot/vmlinuz-4.9.0-3-686
Image mémoire initiale trouvée : /boot/initrd.img-4.9.0-3-686
Windows Vista trouvé sur /dev/sda1
Windows Vista trouvé sur /dev/sda2
fait
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u3) ...
Traitement des actions différées (« triggers ») pour systemd (232-25+deb9u6) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Paramétrage de libffi6:amd64 (3.2.1-6) ...
Paramétrage de libcap-ng0:amd64 (0.7.7-3+b1) ...
Paramétrage de libmount1:amd64 (2.29.2-1+deb9u1) ...
Paramétrage de libglib2.0-0:amd64 (2.50.3-2) ...
/var/lib/dpkg/info/libglib2.0-0:amd64.postinst: 39: /var/lib/dpkg/info/libglib2.0-0:amd64.postinst: /usr/lib/x86_64-linux-gnu/glib-2.0/glib-compile-schemas: Exec format error
/var/lib/dpkg/info/libglib2.0-0:amd64.postinst: 42: /var/lib/dpkg/info/libglib2.0-0:amd64.postinst: /usr/lib/x86_64-linux-gnu/glib-2.0/gio-querymodules: Exec format error
Paramétrage de irqbalance:amd64 (1.1.0-2.3) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u3) ...
 




Tout semble s'être bien passé.

sudo sudo apt --reinstall install virtualbox-dkms




[sudo] Mot de passe de jean-claude : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.9.0-3-686 linux-headers-4.9.0-3-common
  linux-image-4.9.0-3-686
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 6 non mis à jour.
Il est nécessaire de prendre 0 o/687 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
(Lecture de la base de données... 214987 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../virtualbox-dkms_5.2.22-dfsg-1~bpo9+1_all.deb ...

-------- Uninstall Beginning --------
Module:  virtualbox
Version: 5.2.22
Kernel:  4.9.0-8-amd64 (i686)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

vboxdrv.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-8-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetadp.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-8-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetflt.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-8-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxpci.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-8-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod......

DKMS: uninstall completed.

------------------------------
Deleting module version: 5.2.22
completely from the DKMS tree.
------------------------------
Done.
Dépaquetage de virtualbox-dkms (5.2.22-dfsg-1~bpo9+1) sur (5.2.22-dfsg-1~bpo9+1) ...
Paramétrage de virtualbox-dkms (5.2.22-dfsg-1~bpo9+1) ...
Loading new virtualbox-5.2.22 DKMS files...
Building for 4.9.0-8-amd64
Building initial module for 4.9.0-8-amd64
Done.

vboxdrv:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.9.0-8-amd64/updates/dkms/

vboxnetadp.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.9.0-8-amd64/updates/dkms/

vboxnetflt.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.9.0-8-amd64/updates/dkms/

vboxpci.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.9.0-8-amd64/updates/dkms/

depmod...

DKMS: install completed.

Dernière modification par Jkart (27-11-2018 20:27:22)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Windows 10/Buster
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#40 27-11-2018 20:33:39

empanada
Membre
Distrib. : Debian 9 (Stretch)
Noyau : 4.9.0-7-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : Problème démarrage Virtual Box

Loading new virtualbox-5.2.22 DKMS files...
Building for 4.9.0-8-amd64
Building initial module for 4.9.0-8-amd64
Done.


Alors, finalement, t'as tes modules virtualbox compilés sur le noyau amd64. Rédémarre avec ce noyau, et virtualbox doit bien fonctionner.

Salut


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#41 27-11-2018 20:37:59

Jkart
Membre
Distrib. : Buster
Noyau : 4.19.0-6-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Problème démarrage Virtual Box

sudo apt --reinstall install virtualbox


[

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.9.0-3-686 linux-headers-4.9.0-3-common
  linux-image-4.9.0-3-686
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 6 non mis à jour.
Il est nécessaire de prendre 0 o/16,9 Mo dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
(Lecture de la base de données... 214987 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../virtualbox_5.2.22-dfsg-1~bpo9+1_i386.deb ...
Dépaquetage de virtualbox (5.2.22-dfsg-1~bpo9+1) sur (5.2.22-dfsg-1~bpo9+1) ...
Paramétrage de virtualbox (5.2.22-dfsg-1~bpo9+1) ...
Traitement des actions différées (« triggers ») pour systemd (232-25+deb9u6) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...



sudo apt --reinstall install virtualbox-ext-pack



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.9.0-3-686 linux-headers-4.9.0-3-common linux-image-4.9.0-3-686
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 6 non mis à jour.
Il est nécessaire de prendre 0 o/13,8 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Préconfiguration des paquets...
(Lecture de la base de données... 214987 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../virtualbox-ext-pack_5.2.22-1~bpo9+1_all.deb ...
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Successfully uninstalled "Oracle VM VirtualBox Extension Pack".
Successfully performed extension pack cleanup
License has already been accepted.
Dépaquetage de virtualbox-ext-pack (5.2.22-1~bpo9+1) sur (5.2.22-1~bpo9+1) ...
Paramétrage de virtualbox-ext-pack (5.2.22-1~bpo9+1) ...
removing old virtualbox extension packs
virtualbox-ext-pack: downloading: http://download.virtualbox.org/virtualbox/5.2.22/Oracle_VM_VirtualBox_Extension_Pack-5.2.22.vbox-extpack
The file will be downloaded into /usr/share/virtualbox-ext-pack
License accepted.
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Successfully installed "Oracle VM VirtualBox Extension Pack".


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Windows 10/Buster
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#42 27-11-2018 20:41:59

Jkart
Membre
Distrib. : Buster
Noyau : 4.19.0-6-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Problème démarrage Virtual Box

lsmod |grep vbox



vboxpci                24576  0
vboxnetadp             28672  0
vboxnetflt             28672  0
vboxdrv               466944  3 vboxnetadp,vboxnetflt,vboxpci


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Windows 10/Buster
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#43 27-11-2018 20:42:10

empanada
Membre
Distrib. : Debian 9 (Stretch)
Noyau : 4.9.0-7-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : Problème démarrage Virtual Box

Il y avait certains messages dans le log de compilation qu'à vue de nez, avaient lien avec le longueur de mot, et c'est pour ça que je t'avais dit d'installer un noyau amd64.
Il ne manque que modifier le titre du sujet pour indiquer [RÉSOLU].
Salut

Dernière modification par empanada (27-11-2018 20:46:51)


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#44 27-11-2018 21:03:23

Jkart
Membre
Distrib. : Buster
Noyau : 4.19.0-6-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Problème démarrage Virtual Box

Pas encore, c'est une avancée.

Quand je cherche à démarrer Debian que je veux installer dans la VBox cela ne fonctionne pas. J'obtiens ces messages d'erreurs:


RTR3InitEx failed with rc=-1912 (rc=-1912)

The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing

'modprobe vboxdrv'

may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.

where: supR3HardenedMainInitRuntime what: 4 VERR_VM_DRIVER_VERSION_MISMATCH (-1912) - The installed support driver doesn't match the version of the user.



Échec de l'ouverture de session pour la machine virtuelle Debian 9.6.

The virtual machine 'Debian 9.6' has terminated unexpectedly during startup with exit code 1 (0x1).

Code d'erreur : NS_ERROR_FAILURE (0x80004005)
Composant : MachineWrap
Interface : IMachine {85cd948e-a71f-4289-281e-0ca7ad48cd89}

Dernière modification par Jkart (27-11-2018 21:09:06)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Windows 10/Buster
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#45 27-11-2018 21:07:36

Jkart
Membre
Distrib. : Buster
Noyau : 4.19.0-6-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Problème démarrage Virtual Box

Je tente

sudo modprobe vboxdrv



[sudo] Mot de passe de jean-claude :

 

 /sbin/vboxconfig



bash: /sbin/vboxconfig: Aucun fichier ou dossier de ce type



Par ailleurs sur le site d'Oracle il y a une version de VBox pour i386 et une autre pour amd64. Comment être sur que j'ai installé le bon paquet, avec tous ces changements de noyaux?

Il y avait de toute façon un bug avec le paquet virtualbox-dkms en 32b.

Ceci dit, cela ne fonctionne pas. Une idée?

En tout cas merci.
Cordialement

Dernière modification par Jkart (27-11-2018 21:31:41)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Windows 10/Buster
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#46 27-11-2018 22:17:43

empanada
Membre
Distrib. : Debian 9 (Stretch)
Noyau : 4.9.0-7-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : Problème démarrage Virtual Box

Jkart a écrit :

lsudo modprobe vboxdrv


Cette commande ne devrait pas être nécessaire, puisque les modules sont déjà chargés

Jkart a écrit :

lsmod |grep vbox



vboxpci                24576  0
vboxnetadp             28672  0
vboxnetflt             28672  0
vboxdrv               466944  3 vboxnetadp,vboxnetflt,vboxpci



Sauf si tu as rédémarré avec un autre noyau (par example le 686-pae), que évidement ne peut pas charger des modules compilés pour un autre noyau (moins encore puisque ce sont des architectures différents).
Quelle est la sortie de

uname -r

?

Aussi, c'est possible que virtualbox ne peut pas fonctionner qu'avec les modules dans la même architecture que le programme, mais j'ignore. Je n'ai jamais lu cette limitation...ni la contraire, non plus essayé. Ce message me fait méfier:

The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful


Mais avant tout il faut s'assurer que
1) t'as démarré avec le noyau amd64 (uname -r)
2) Que les modules sont chargés (lsmod|grep vbox)

Jkart a écrit :

Comment être sur que j'ai installé le bon paquet, avec tous ces changements de noyaux?


Maintenant tu as installé le programme virtualbox 5.2.22-dfsg-1~bpo9+1 (architecture i386)
virtualbox-dkms (les sources pour compiler les modules du noyau, qui est indépendant de l'architecture) 5.2.22-dfsg-1~bpo9+1
noyau et headers 4.9.0-8-amd64
modules virtualbox compilés pour ce noyau 4.9.0-8-amd64 .

Comme dit plus haut, par l'instant, je ne suis pas sure que cette combinaison ne soit pas possible, ni le contraire. Je vais chercher d'info sur ce sujet. En tout cas cette combinaison n'a aucun danger pour le système hôte debian. "Combinaison pas possible" c'est restreint à virtualbox, ça ne casse rien en dehors virtualbox.

Sinon, le prochain pas c'est essayer le paquet dès dépôts virtualbox. (en général, mieux éviter des installations en dehors des dépôts officiaux debian ,mais dans ce cas c'est pertinent. En tout cas toujours mieux utiliser les dépôts que télécharger le paquet):
Supprimer virtualbox, ajouter le dépôt deb https://download.virtualbox.org/virtualbox/debian stretch contrib au fichier /etc/apt/sources.list, actualiser la liste des paquets et installer:

apt-get remove virtualbox*
echo "deb https://download.virtualbox.org/virtualbox/debian stretch contrib" >> /etc/apt/sources.list
wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -
sudo apt-get update
sudo apt-get install virtualbox-5.2



Salut.

Dernière modification par empanada (27-11-2018 22:21:06)


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#47 27-11-2018 22:58:42

empanada
Membre
Distrib. : Debian 9 (Stretch)
Noyau : 4.9.0-7-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : Problème démarrage Virtual Box

Bon, il se confirment les suspects :
VirtualBox on i386 with amd64 Kernel
AMD64 kernel on i386 userspace problem

Donc pour arriver à utiliser virtualbox i386 avec un noyau amd64, il faut bidouiller un peu et installer dans un "chroot jail", comme expliqué dans le premier lien (et avec moins détail dans le second aussi).

J'essaierais en premier les dépôts virtualbox, comme expliqué dans le message précédent.

Des autres options, comme chalu avait dit il y a quelques messages, penser à changer vers l'architecture amd64, puisque le processeur l'admit. Là, il y a deux options:

a) Faire un "crossgrading" (changer le système de i386 vers amd64). Il y a certains risques de "casser" le système, donc il faut bien tenir en compte (peut-être faire des copies de sécurité du système complet pour faire une restauration si les problèmes sont graves et pas résolubles...ou rien du tout si tu t'en fou du système s'il casse). Des infos détaillées: CrossGrading

b) Faire une installation de nouveau...mais cette fois une amd64. En certaine façon, s'est se rendre avant de lutter.

Moi , j'essayerai le crossgrading avant. Si ça marche c'est plus rapide et tu conserves tous les logiciels, configurations, données. Pour faire une nouvelle installation, on a toujours cette possibilité. À toi de choisir.

Salut

Dernière modification par empanada (27-11-2018 23:06:21)


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#48 28-11-2018 19:58:19

Jkart
Membre
Distrib. : Buster
Noyau : 4.19.0-6-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Problème démarrage Virtual Box

Bonsoir,
J'avais bien vérifié que le bon noyau était installé


uname -r



4.9.0-8-amd64



lsmod|grep vbox



vboxpci                24576  0
vboxnetadp             28672  0
vboxnetflt             28672  0
vboxdrv               466944  3 vboxnetadp,vboxnetflt,vboxpci



Le démarrage de Debian dans VBox ne se fait pas.

sudo apt-get remove virtualbox*



[sudo] Mot de passe de jean-claude : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Note, selecting 'virtualbox-source' for glob 'virtualbox*'
Note, selecting 'virtualbox-guest-utils' for glob 'virtualbox*'
Note, selecting 'virtualbox-ose' for glob 'virtualbox*'
Note, selecting 'virtualbox-guest-modules' for glob 'virtualbox*'
Note, selecting 'virtualbox-guest-additions-iso' for glob 'virtualbox*'
Note, selecting 'virtualbox-guest-dkms' for glob 'virtualbox*'
Note, selecting 'virtualbox-dkms' for glob 'virtualbox*'
Note, selecting 'virtualbox-ext-pack' for glob 'virtualbox*'
Note, selecting 'virtualbox' for glob 'virtualbox*'
Note, selecting 'virtualbox-guest-source' for glob 'virtualbox*'
Note, selecting 'virtualbox-ose-fuse' for glob 'virtualbox*'
Note, selecting 'virtualbox-qt' for glob 'virtualbox*'
Note, selecting 'virtualbox-2.0' for glob 'virtualbox*'
Note, selecting 'virtualbox-2.1' for glob 'virtualbox*'
Note, selecting 'virtualbox-2.2' for glob 'virtualbox*'
Note, selecting 'virtualbox-modules' for glob 'virtualbox*'
Note, selecting 'virtualbox-3.0' for glob 'virtualbox*'
Note, selecting 'virtualbox-3.1' for glob 'virtualbox*'
Note, selecting 'virtualbox-3.2' for glob 'virtualbox*'
Note, selecting 'virtualbox-4.0' for glob 'virtualbox*'
Note, selecting 'virtualbox-4.1' for glob 'virtualbox*'
Note, selecting 'virtualbox-4.2' for glob 'virtualbox*'
Note, selecting 'virtualbox-4.3' for glob 'virtualbox*'
Note, selecting 'virtualbox-5.0' for glob 'virtualbox*'
Note, selecting 'virtualbox-5.1' for glob 'virtualbox*'
Note, selecting 'virtualbox-5.2' for glob 'virtualbox*'
Note, selecting 'virtualbox-guest-x11' for glob 'virtualbox*'
Note, selecting 'virtualbox-guest-additions' for glob 'virtualbox*'
Le paquet « virtualbox-ose » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-ose-fuse » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-5.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-5.1 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-5.2 » n'est pas installé, et ne peut donc être supprimé
Note : sélection de « virtualbox-dkms » au lieu de « virtualbox-modules »
Le paquet « virtualbox-2.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-2.1 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-2.2 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-3.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-3.1 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-3.2 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-4.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-4.1 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-4.2 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-4.3 » n'est pas installé, et ne peut donc être supprimé
Note : sélection de « virtualbox-guest-dkms » au lieu de « virtualbox-guest-modules »
Le paquet « virtualbox-guest-additions » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-guest-dkms » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-guest-source » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-guest-utils » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-guest-x11 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-source » n'est pas installé, et ne peut donc être supprimé
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libgsoap10 libqt5opengl5 libvncserver1 linux-headers-4.9.0-3-686
  linux-headers-4.9.0-3-common linux-image-4.9.0-3-686
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  virtualbox virtualbox-dkms virtualbox-ext-pack
  virtualbox-guest-additions-iso virtualbox-qt
0 mis à jour, 0 nouvellement installés, 5 à enlever et 0 non mis à jour.
Après cette opération, 171 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 214986 fichiers et répertoires déjà installés.)
Suppression de virtualbox-ext-pack (5.2.22-1~bpo9+1) ...
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Successfully uninstalled "Oracle VM VirtualBox Extension Pack".
Successfully performed extension pack cleanup
Suppression de virtualbox-qt (5.2.22-dfsg-1~bpo9+1) ...
Suppression de virtualbox (5.2.22-dfsg-1~bpo9+1) ...
Suppression de virtualbox-dkms (5.2.22-dfsg-1~bpo9+1) ...

-------- Uninstall Beginning --------
Module:  virtualbox
Version: 5.2.22
Kernel:  4.9.0-8-amd64 (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

vboxdrv.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-8-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetadp.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-8-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetflt.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-8-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxpci.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-8-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod......

DKMS: uninstall completed.

------------------------------
Deleting module version: 5.2.22
completely from the DKMS tree.
------------------------------
Done.
Suppression de virtualbox-guest-additions-iso (5.2.22-1~bpo9+1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Traitement des actions différées (« triggers ») pour shared-mime-info (1.8-1+deb9u1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-1) ...
 


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Windows 10/Buster
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#49 28-11-2018 20:12:22

Jkart
Membre
Distrib. : Buster
Noyau : 4.19.0-6-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Problème démarrage Virtual Box

Merci pour ses informations.

Je viens de créer un fichier (dans le répertoire sources.list.d) contenant

deb https://download.virtualbox.org/virtualbox/debian stretch contrib



wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -


bloc à supprimer si la commande n’affiche rien


OK



apt-get update


Ign:1 http://deb.debian.org/debian stable InRelease
Atteint:2 http://security.debian.org stable/updates InRelease
Atteint:3 http://deb.debian.org/debian stable-updates InRelease                
Atteint:4 http://security.debian.org stretch/updates InRelease                
Atteint:5 http://deb.debian.org/debian stretch-backports InRelease            
Atteint:6 http://deb.debian.org/debian stable Release          
Lecture des listes de paquets... Fait                          
E: Le pilote pour la méthode /usr/lib/apt/methods/https n'a pu être trouvé.
N: Is the package apt-transport-https installed?
E: Impossible de récupérer https://download.virtualbox.org/virtualbox/debian/dists/stretch/InRelease  
E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.



sudo apt-get install apt-transport-https


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libgsoap10 libqt5opengl5 libvncserver1 linux-headers-4.9.0-3-686 linux-headers-4.9.0-3-common linux-image-4.9.0-3-686
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les NOUVEAUX paquets suivants seront installés :
  apt-transport-https
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 174 ko dans les archives.
Après cette opération, 246 ko d'espace disque supplémentaires seront utilisés.
Réception de:1 http://deb.debian.org/debian stable/main i386 apt-transport-https i386 1.4.8 [174 kB]
174 ko réceptionnés en 0s (623 ko/s)    
Sélection du paquet apt-transport-https précédemment désélectionné.
(Lecture de la base de données... 214371 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../apt-transport-https_1.4.8_i386.deb ...
Dépaquetage de apt-transport-https (1.4.8) ...
Paramétrage de apt-transport-https (1.4.8) ...



sudo apt-get update



Atteint:1 http://security.debian.org stable/updates InRelease
Ign:2 http://deb.debian.org/debian stable InRelease
Atteint:3 http://security.debian.org stretch/updates InRelease                                  
Atteint:4 http://deb.debian.org/debian stable-updates InRelease                                  
Atteint:5 http://deb.debian.org/debian stretch-backports InRelease
Atteint:6 http://deb.debian.org/debian stable Release          
Réception de:7 https://download.virtualbox.org/virtualbox/debian stretch InRelease [7 782 B]
Réception de:9 https://download.virtualbox.org/virtualbox/debian stretch/contrib i386 Packages [1 730 B]
Réception de:10 https://download.virtualbox.org/virtualbox/debian stretch/contrib amd64 Packages [1 732 B]
Réception de:11 https://download.virtualbox.org/virtualbox/debian stretch/contrib amd64 Contents (deb) [4 163 B]
Réception de:12 https://download.virtualbox.org/virtualbox/debian stretch/contrib i386 Contents (deb) [4 167 B]
19,6 ko réceptionnés en 3s (5 186 o/s)      
Lecture des listes de paquets... Fait



sudo apt-get install virtualbox-5.2



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libgsoap10 libvncserver1 linux-headers-4.9.0-3-686 linux-headers-4.9.0-3-common linux-image-4.9.0-3-686
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
The following additional packages will be installed:
  libsdl-ttf2.0-0
Paquets recommandés :
  linux-image
Les NOUVEAUX paquets suivants seront installés :
  libsdl-ttf2.0-0 virtualbox-5.2
0 mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 68,2 Mo dans les archives.
Après cette opération, 167 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
 



Je poursuis? Je ne suis pas certain qu'il va m'installer virtualbox en 64 b.

Dernière modification par Jkart (28-11-2018 21:54:37)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Windows 10/Buster
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#50 28-11-2018 23:42:39

empanada
Membre
Distrib. : Debian 9 (Stretch)
Noyau : 4.9.0-7-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : Problème démarrage Virtual Box

Jkart a écrit :

Je poursuis? Je ne suis pas certain qu'il va m'installer virtualbox en 64 b.



Les paquets installés sont, par défaut, ceux dont l'architecture par défaut:

dpkg --print-architecture

Dans ton cas, ça va être i386.

La commande

dpkg --print-foreign-architectures

va donner amd64, et ces paquets doivent être installés avec

apt-get install nom_de_paquet:amd64



Mais l'objectif c'est de essayer le paquet virtualbox sous le noyau i686, donc mieux rédémarrer avec le noyau i686 (je suppose que maintenant le noyau par défaut sur GRUB c'est le amd64).
Salut


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

Pied de page des forums