Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-11-2018 01:14:56

crap0
Membre
Lieu : Bruxelles (Be)
Distrib. : debian 9 (LibraZik-2)
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate et LxQt
Inscription : 27-09-2018
Site Web

paquets cassé...

Bonjour
j'essaye d'installer supercollider
via terminal ou synaptique
rien ne s'installe, j'obtiens un message de l'ordre de réparer les paquets cassé.
via synaptique et l'option s'y référant, celui ci me donne comme message :

E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances



que dois je faire ?
merci

Edit à toto : Mis le retour de synaptic en utilisant le BBCode Autre code du forum. Plus lisible par tous ainsi.

Hors ligne

#2 28-11-2018 03:53:42

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : paquets cassé...

Pour réparer les paquets, c'est cette commande magique :

sudo apt install -f



Si ça retourne une erreur, donne-là nous.


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

En ligne

#3 28-11-2018 14:40:50

crap0
Membre
Lieu : Bruxelles (Be)
Distrib. : debian 9 (LibraZik-2)
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate et LxQt
Inscription : 27-09-2018
Site Web

Re : paquets cassé...

j'ai fait ta commande via le terminal
suivit d'un

apt-get update && apt-get install supercollider



il m'indique ceci ...:

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 supercollider : Dépend: supercollider-language mais ne sera pas installé
                 Dépend: supercollider-server mais ne sera pas installé
                 Dépend: supercollider-ide mais ne sera pas installé
                 Recommande: supercollider-supernova mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



Edit modération : ajout des balises codes

Hors ligne

#4 28-11-2018 15:14:35

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : paquets cassé...

Merci d'utiliser les boutons "Commande root", "Commande utilisateur" ou "Code" pour rendre les messages plus lisibles. Tu peux cliquer sur le bouton Modifier en bas de ton message pour voir ce que ça donne et aussi : Voir le tuto : Le code, ça pique moins les yeux en couleur

Merci de compléter ton profil que l'on verra sous ton pseudo à gauche des messages pour que l'aide soit la plus adaptée possible
Voir le tuto : Trop cool d'indiquer son installation dans son profil !

ça sent un problème de sources. Pour voir le paquet qui pose problème, essaie un par un et donne les retours de

apt install supercollider-language


apt install supercollider-server


apt install supercollider-ide


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

Pied de page des forums