Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-12-2018 01:37:19

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Debian ne démarre plus (ou très mal) Windows ne démarre plus [Résolu]

Historique:
J'ai commencé par installer Debian Stretch en dual boot avec Windows 10. Pour des problèmes de carte graphique je suis passé à Buster. Cela a fonctionné correctement pendant une semaine. Mon ordinateur a été arrêté proprement et débranché pendant 3-4 jours pour Noël.
A mon retour j'ai démarré Buster le démarrage ne se fait pas correctement (défilement ininterrompu du script), je n'ai pas la main. Arrêt avec le commutateur. J'arrive à démarrer Windows... mais cela se termine par un écran bleu... A force de tentative de démarrage j'y arrive. Debian une fois démarré semble plus stable, Windows finit en écran bleu (et en arrêt brutal en général).
Si Windows finit en écran bleu le démarrage de Buster est compliqué (multiple essai).
Mais les multiples arrêts brutaux finissent par perturber un peu plus le système, ni Windows ni Buster ne démarrent.
Je démarre sur le bios (Echap au démarrage), j'arrête la machine proprement, Buster démarre sans problème.
Voilà ou j'en suis.
Je dispose d'une sauvegarde sur clé USB de Windows 10, je dois avoir une DF Stretch sur USB (Easy2Boot) également et actuellement je travaille sur Buster, je peux accéder au Bios. Windows 10 je n'ose plus essayer de peur que cela rende une fois de plus le système instable.
Comment puis-je stabiliser le système?
Cordialement

Dernière modification par Jkart (04-02-2019 13:15:39)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#2 28-12-2018 01:57:39

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : Debian ne démarre plus (ou très mal) Windows ne démarre plus [Résolu]

Quand tu n'a rien modifié et que ça déconne subitement, c'est que le problème est très probablement matériel.

0) Si pas de backup, backuper : si le problème vient du disque dur tu es en train de risquer toutes tes données perso
1) Tenter de démarrer avec le MINIMUM NECESSAIRE de péripherique branchées (par exemple : que un écran)
2) Si le problème est toujours là : ça vient probablement d'un disque dur en train de mourir, d'une ram, d'une carte graphique, ou d'une carte mère qui fait son cri du signe. Il faut tester l'un après l'autre.
2a) Démarrer sur une clé et vérifier l'état SMART du disque dur, lancer un "test étendu" ; au passage ça permet de tester si la session live est stable ou non : si elle ne l'est pas, on sait que les problèmes ne viennent pas que du disque dur
2b) Si rien, lancer un memtest (le temps de faire une passe ou deux)
2c) Si rien beeeeh. Moi dans ce cas là, je prend un autre disque dur, et je regarde si j'ai le même problème. Et si vraiment y en a pas, je conclue que l'autre disque dur est hanté, et je le dissous dans le volcan le plus proche.

virtue_signaling.png
Pas de repos pour les oppresseurs ! (/me inclus)

Hors ligne

#3 28-12-2018 02:11:59

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Debian ne démarre plus (ou très mal) Windows ne démarre plus [Résolu]

Bonsoir,
Ai-je changé quelque chose? Des mise à jour de pilote sous Windows et dans Buster il y a souvent des mise à jour. C'est pas forcément une preuve mais l'ordinateur est neuf, si le disque ou une carte est fatiguée ce n'est pas à cause de l'usage.
Je veux bien faire toutes les manips que l'on veut mais il faudra être explicite.
Y a t'il un outil sous Debian pour faire l'état Smart?
Les données perso pour le moment ce n'est pas grave (l'ordi est neuf)
L'outil Recovery de HP me permettrais de retrouver un ordinateur "sortie usine" avec perte du partitionnement, de Debian... de Windows?
Qu'est ce qu'un back-up et comment le réalise-t'on?
Je vais aller me coucher et tenterai de trouver des réponses à mes questions demain.

Merci.

Dernière modification par Jkart (28-12-2018 02:36:18)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#4 28-12-2018 02:43:16

tux12
Membre
Lieu : ./
Distrib. : stable
Noyau : celui de la stable
(G)UI : KDE
Inscription : 27-02-2008

Re : Debian ne démarre plus (ou très mal) Windows ne démarre plus [Résolu]

Bonjour,

Je plussoie pour un problème matériel; bien que le matériel soit neuf il peut présenter des défauts du point de vue électronique lesquels apparaissent généralement en début de vie. Donc comme dit par otyugh tester la RAM et le disque dur, mais aussi ouvrir la machine et vérifier toutes les connexions entre les cartes et éléments (la RAM aussi peut présenter des faux-contacts dans les emplacements). Un problème d'instabilité de l'alimentation ou un composant défaillant sur la carte-mère peuvent aussi être envisagés.

Backup est le nom anglais pour sauvegarde. Il s'agit de récupérer sur un support externe (disque dur, clé USB,...) les fichiers perso et de configuration pour ne rien perdre en cas de perte du système.

Si ça peut aider,

Dernière modification par tux12 (28-12-2018 02:44:35)


Tout est un sauf zéro. - Wau Holland

Hors ligne

#5 28-12-2018 08:15:41

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : Debian ne démarre plus (ou très mal) Windows ne démarre plus [Résolu]

Bonjour
je suppose ici =>  https://debian-facile.org/viewtopic.php … 80#p284980

pour pas avoir de soucis j'utilise deux disques pour un dual boot win/debian , avec chacun sa partition de boot et grub ajoute win dans son menu.
je dis au bios de démarrer sur le disque debian (tu dois avoir la possibilité sur ton HP de sélectionner le boot je suppose (disque , clé usb , DVD )

je suis certain de ne pas avoir de problèmes , par exemple si je débranche le disque de win ça ne perturbe pas debian (et vice versa ).
je ne sais pas comment tu a fais l'installation mais je pense a une corruption des partitions systèmes des deux OS.

il faudrait donner des informations sur ton installation (par exemple les partitions et sur quel disque) . l'utilisation du ssd (espace libre)
une alternative a un problème matériel
nota: on trouve des ssd de 120Go a moins de 30 euros

tester en live (DVD) et si la machine est stable peu confirmer que le matériel n'a pas de soucis .

Machines : kabylake I7 7700 , AMD 1700(X) ,AMD 5700X ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#6 28-12-2018 17:50:16

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Debian ne démarre plus (ou très mal) Windows ne démarre plus [Résolu]

Bonsoir,

Voici la façon dont j'ai réalisé l'installation

Tout d'abord j'ai partitionné le SSD (128 G) à l'aide de l'outil Windows
J'ai réalisé une clé USB de sauvegarde de Windows 10 à l'aide de l'outil Windows

J’ai voulu modifier l’UEFI pour démarrer à partir de la clé de boot. Sans succès malgré les F1, F2, F3… (en fait il faut faire Echap) Finalement voir ci-dessous ;

Dans Windows 10 (version octobre 2018)
- Taper « bios » dans l’onglet de recherche
- Modifier les options de démarrage avancées
- Démarrage avancé (cliquer sur « redémarrer maintenant »)

D’abord :
- Dépannage
- Options avancées
- Changer les paramétrage du microprogramme UEFI
- redémarrage
- Taper F10 (Configuration du bios)
- Sécurité
- Configuration d’amorçage sécurisée
- Amorçage sécurisé (sécure boot) / désactivé
- Enregistrer (F10)

Puis :
- Stockage
- Ordre du démarrage
- Positionner « Disquette cd dvd usb » en tête
- Enregistrer (F10)/arrêt

Puis :
- Fichier
- Enregistrer modification et quitter
- Etes-vous certain… / oui

- Insérer clé de boot
- Redémarrage
- Taper le code (fourni) pour valider les modifications
- La clé USB ne boote pas, Windows démarre
- Taper « bios » dans l’onglet de recherche
- Modifier les options de démarrage avancées
- Démarrage avancé (cliquer sur « redémarrer maintenant »)

- Utiliser un périphérique
- Démarrer à partir d’une clé USB
- L’ordinateur redémarre et la clé boote

- Installation de Debian

L’installation se fait sans problème. Le Grub apparaît et propose Debian et Windows.
Après quelques démarrages le Grub disparaît !!! Windows démarre.
Avec le wiki je tente à l’aide de la console administrateur de Windows
bcdedit /set '{bootmgr}' path \EFI\debian\grubx64.efi
Je reçois un message de succès.
Démarrage mais toujours pas de Grub.


Dans Windows 10 (version octobre 2018)
- Taper « bios » dans l’onglet de recherche
- Modifier les options de démarrage avancées
- Démarrage avancé (cliquer sur « redémarrer maintenant »)

- Dépannage
- Options avancées
- Changer les paramétrage du microprogramme UEFI
- redémarrage
- Taper F9 (périphériques de démarrage)
- Choisir « sources de démarrage hérités »

Le Grub démarre à nouveau

Cela semble fonctionner pour le moment, à suivre.

Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#7 28-12-2018 18:28:06

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Debian ne démarre plus (ou très mal) Windows ne démarre plus [Résolu]

Des infos sur le système

cat /etc/apt/sources.list




#debian buster 10
deb http://deb.debian.org/debian/ buster main contrib non-free
deb http://security.debian.org/ buster/updates main contrib non-free
deb http://deb.debian.org/debian/ buster-updates main contrib non-free



ls /etc/apt/sources.list.d/



libdvdcss.list



apt-cache policy



Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://deb.debian.org/debian buster/non-free amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian buster/contrib amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian buster/main amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=main,b=amd64
     origin deb.debian.org
Paquets épinglés :


cat /etc/fstab



# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/nvme0n1p5 during installation
UUID=f8afc39f-e2f6-4626-b26b-6ab87d325bc2 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/nvme0n1p1 during installation
UUID=4EE9-D7CB  /boot/efi       vfat    umask=0077      0       1
# swap was on /dev/nvme0n1p6 during installation
UUID=919f23f8-b719-4f8d-a9d8-44a720fe56b1 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0


fdisk -l



Disque /dev/nvme0n1 : 119,2 GiB, 128035676160 octets, 250069680 secteurs
Modèle de disque : WDC PC SN520 SDAPNUW-128G-1006          
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : gpt
Identifiant de disque : 00FD1D1A-BE46-40E0-920C-B422DF9277FB

Périphérique       Début       Fin  Secteurs Taille Type
/dev/nvme0n1p1      2048    534527    532480   260M Système EFI
/dev/nvme0n1p2    534528    567295     32768    16M Réservé Microsoft
/dev/nvme0n1p3    567296 145649663 145082368  69,2G Données de base Microsoft
/dev/nvme0n1p4 248049664 250056703   2007040   980M Environnement de réccupératio
/dev/nvme0n1p5 145649664 231469055  85819392  40,9G Système de fichiers Linux
/dev/nvme0n1p6 231469056 248049663  16580608   7,9G Partition d'échange Linux

Les entrées de la table de partitions ne sont pas dans l'ordre du disque.


Disque /dev/sda : 931,5 GiB, 1000204886016 octets, 1953525168 secteurs
Modèle de disque : TOSHIBA DT01ACA1
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Type d'étiquette de disque : gpt
Identifiant de disque : 4DF557CC-B0FE-4419-8519-130F7F801D87

Périphérique      Début        Fin   Secteurs Taille Type
/dev/sda1          2048 1916645375 1916643328 913,9G Données de base Microsoft
/dev/sda2    1916645376 1953523711   36878336  17,6G Données de base Microsoft




Disque /dev/sdb : 465,8 GiB, 500107862016 octets, 976773168 secteurs
Modèle de disque : 5000AAV External
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0x44fdfe06

Périphérique Amorçage Début       Fin  Secteurs Taille Id Type
/dev/sdb1                63 976768064 976768002 465,8G  c W95 FAT32 (LBA)



blkid



/dev/nvme0n1: PTUUID="00fd1d1a-be46-40e0-920c-b422df9277fb" PTTYPE="gpt"
/dev/nvme0n1p1: UUID="4EE9-D7CB" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="461aaa93-bdc0-4276-8328-94074a509a5b"
/dev/nvme0n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="a6c7ab66-91ca-4b98-b782-b2123d04e85d"
/dev/nvme0n1p3: LABEL="Windows" UUID="EEFAFEEBFAFEAEC9" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="8286c768-a1ae-43e7-8099-96ab0ef675e5"
/dev/nvme0n1p4: LABEL="Windows RE tools" UUID="4828873428872054" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="64a5bd4d-9bf2-4774-adb4-58bdbdee7d87"
/dev/nvme0n1p5: UUID="f8afc39f-e2f6-4626-b26b-6ab87d325bc2" TYPE="ext4" PARTUUID="3baef006-2296-40c0-9fd5-a2270736dcc7"
/dev/nvme0n1p6: UUID="919f23f8-b719-4f8d-a9d8-44a720fe56b1" TYPE="swap" PARTUUID="4f5e82ab-c2da-421b-a5ca-523fed4a0245"
/dev/sda1: LABEL="DATA" UUID="EE36F65D36F625ED" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="ecdd2f7f-6ff8-4719-8020-310d1548eafa"
/dev/sda2: LABEL="RECOVERY" UUID="6270F88370F85F6B" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="b05914c5-86f7-47b1-b158-cf0dfd6b4ced"
/dev/sdb1: LABEL_FATBOOT="My Book" LABEL="My Book" UUID="4C77-09B3" TYPE="vfat" PARTUUID="44fdfe06-01"

Dernière modification par Jkart (28-12-2018 19:22:07)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#8 28-12-2018 18:37:12

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Debian ne démarre plus (ou très mal) Windows ne démarre plus [Résolu]

Back up

J'ai utilisé dans le bios les outils Hp pour faire un état des lieux.


B7dfBJgMSiYI.JPG

Remarque personnelle
L'échec pour l'audio c'est moi qui est fait une erreur.

Par contre:
Clavier: Certaines touches ne sont pas reconnues.

Réseau:

Problème avec l'UEFI. Le réseau n(est pas pris en charge

Avec Debian le réseau internet est très fluctuant cela fonctionne ou pas, il fonctionne puis il s'arrête.

Gestion de microprogramme/Bios:

L'mage bios sélectionnée n'est pas disponible. L'ID Bios est F. 12. un fichier de signature est également disponible dans le même répertoire.

Choix entre mise à jour /restauration puis choix entre EFI / Systeme Volume Information.

J'espère qu'à l'aide de ces informations vous pourrez me donner la meilleure marche à suivre pour récupérer le système.

J'ai désactivé le sécure boot faut-il l"activé?

Merci.

Dernière modification par Jkart (28-12-2018 18:52:40)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#9 28-12-2018 21:20:40

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Debian ne démarre plus (ou très mal) Windows ne démarre plus [Résolu]

Modifié
J'ai réactivé le secure boot. Le grub (et donc Debian) n'apparaît plus. Windows démarre et semble être stabilisé. Un problème cependant je n'ai plus d'internet!!!! Précédemment internet était aléatoire maintenant c'est terminé. Je fonctionne avec un cable Ethernet. Un paramétrage quelque part??? Un problème matériel???

Dernière modification par Jkart (29-12-2018 12:07:05)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#10 29-12-2018 12:06:25

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Debian ne démarre plus (ou très mal) Windows ne démarre plus [Résolu]

Bonjour,
J'ai refait le test "réseau" à partir du bios.

Le réseau UEFI semble ne pas être pris en charge ou activé sur le système. vérifier les paramètres Bios pour s'assurer que les ROM de l'option réseau UEFI sont activés et que le démarrage du réseau UEFI est activé



j'ai donc vérifié les paramètres Bios qui me semblent être en lien avec le réseau.

Contrôleur réseau disponible
Démarrage réseau activé
Réveil S4/S5 par réseau désactivé



J'ai donc activé "Réveil S4/S5 par réseau" mais je n'ai toujours pas d'internet.

Dans Windows le réseau Ethernet est qualifié de

non présent



J'hésite à utiliser une clé live car cela signifie de désactiver le secure boot et donc d'être à nouveau sur des OS instables qui mettent le bazar. De plus si les tests bios ne permettent pas d'obtenir le réseau je doute qu'un OS installé sur le bios le permet.
Les suggestions sont les bienvenues, notamment en ce qui concerne le paramétrage du bios ou comment être certain qu'il ne s'agisse pas d'un problème matériel?
Cordialement

Dernière modification par Jkart (29-12-2018 12:08:33)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#11 04-02-2019 13:13:13

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Debian ne démarre plus (ou très mal) Windows ne démarre plus [Résolu]

Pour info:
La carte mère a été changée au frais du vendeur (garantie)
J'espère que cela va fonctionner correctement maintenant.
Il faut tout réinstaller. Je vais sans doute attendre la date n°2 (12 février je crois) du freeze de Buster.

Dernière modification par Jkart (04-02-2019 13:14:58)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

Pied de page des forums