Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-12-2018 00:47:18

Papy7584
Membre
Lieu : 75, 84 et Flandres belges...
Distrib. : Debian Buster (4.19.67-2)
Noyau : Linux 4.19.0-6-amd64
(G)UI : default - GNOME
Inscription : 24-12-2018

[Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Débutant totalement et récemment sur Linux/debian, j’ai installé Debian en Dual Boot sur un pc Windows 10, et tout allait bien... smile jusqu’à ce que, soudainement, mon dual boot a « disparu » et le PC ne bootait plus qu’en Windows. Après avoir tenté quelques actions trouvées au hasard sur le net (et j’avoue que je regardais la télé d’un autre œil…ops.gif), j’ai pris l’option de tout reconstruire depuis le début… mais rebelotte: mon PC ne me montre pas GRUB, et démarre illico en Windows10… kernal_panic.gif

Voici donc mes actions :
1.    Réinstallation Windows10 (via restore OEM Windows du PC, avec donc les disques formatté en état initial, etc…)
2.    Réinstallation Debian en suivant https://debian-facile.org/doc:install:d … -de-l-uefi
3.    Désactivation du "démarrage rapide" de Windows (conseil donné sur certains sites..)
4.    Selon doc du point 2, dans le paragraphe « résolution des problèmes », on conseille d’exécuter sous Windows une des 2 commandes :

bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi


ou

bcdedit /set{bootmgr}’ path \EFI\ debian\grubx64.efi


(Executé avec un compte local administrateur ET compte Microsoft Administrateur) mais cela me donne systématiquement:

Impossible d’ouvrir le magazine des données de configuration de démarrage.
Accès refusé



5.    Ce lien semble traiter exactement mon problème : https://debian-facile.org/viewtopic.php … 80#p217880 Sauf que je n’ai pas compris comment le pb a été résolu … ??

Le PC est un ACER (Aspire 5), Debian 9.6 et Windows10…
A noter qu’en bootant sur la clé USB de récupération Windows, il y a une option «utiliser un périphérique » , où est affiché un « périphérique » debian, qui me permet de démarrer debian correctement….

Voilà, voilà…. votre aide serait le bienvenu , car avant avoir eu l'occasion de maîtriser un peu la « bête », je suis déjà coincé… et ne sais plus trop quoi faire, malgré mes recherches dans ce superbe forum (et d'autres...).
Je suis preneur de vos suggestions en mode « très débutant » help.gif:  je sais lancer des commandes dans un terminal, mais n'ai jamais édité des fichiers de configuration pe (ou utilisé vi,..).

Merci !

==> pour la synthèse des interventions: voir le dernier message -

Papy7584 old_geek.gif

Dernière modification par Papy7584 (01-01-2019 21:04:42)


If you're going through hell, keep going (Winston Churchill)
Vivez comme si vous deviez mourir demain, apprenez comme si vous deviez vivre toujours (Bouddha)
A winner is a dreamer who never gives up (Nelson Mandela)
Logic will get you from A to Z ; Imagination will get you everywhere (Albert Einstein)

Hors ligne

#2 29-12-2018 08:40:27

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Papy7584 a écrit :

(ou utilisé vi,..)


L'idéal est de prendre vim, son installation est automatiquement couplée pavec celle d'un excellent tutoriel avec des exemples d'utilisations les plus courantes :
https://debian-facile.org/doc:editeurs:vim:vim#vimtutor

Pour ma part j'ai choisi d'installer vim-nox.
Voir le tuto :
https://debian-facile.org/doc:editeurs:vim:vim#vim-nox


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 29-12-2018 12:13:47

raleur
Membre
Inscription : 03-10-2014

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Papy7584 a écrit :

bcdedit /set ‘{bootmgr}’ path \EFI\ debian\grubx64.efi


1) Il ne doit pas y avoir d'espace entre EFI\ et debian.
2) Il est préférable d'exécuter la commande avec l'invite de commande classique (cmd.exe) plutôt qu'avec powershell.
3) Il faut explicitement lancer l'invite de commande en tant qu'administrateur, et pas seulement avec un compte administrateur, sinon les privilèges d'administration ne sont pas forcément activés.

Papy7584 a écrit :

A noter qu’en bootant sur la clé USB de récupération Windows, il y a une option «utiliser un périphérique » , où est affiché un « périphérique » debian, qui me permet de démarrer debian correctement


Donc il y a une entrée "debian" dans les variables de boot EFI. Elle n'est peut-être pas en premier dans l'ordre de boot. Puisque tu peux démarrer Debian, qu'affiche la commande suivante (copie de texte brut svp, pas de capture d'écran) ?

efibootmgr


Il vaut mieux montrer que raconter.

Hors ligne

#4 29-12-2018 13:13:27

Papy7584
Membre
Lieu : 75, 84 et Flandres belges...
Distrib. : Debian Buster (4.19.67-2)
Noyau : Linux 4.19.0-6-amd64
(G)UI : default - GNOME
Inscription : 24-12-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Merci Smolski, je regarderai ça quand j'aurai besoin d'éditer des fichiers... et que mon dual boot refonctionne..

Merci Raleur pour ton retour, voici quelques informations supplémentaires:

1) Il ne doit pas y avoir d'espace entre EFI\ et debian.
=> mea culpa: c'est bien le cas (j'ai refait), mais comme je n'ai pas réussi à faire un copier/coller de l'écran des commandes, j'ai retapé malencontreusement une espace dans le message

2) Il est préférable d'exécuter la commande avec l'invite de commande classique (cmd.exe) plutôt qu'avec powershell.
=> je pense que c'est le cas: j'ai pris l'icone du terminal noir "invité de commandes" sous "système Windows" dans les applications (sous Windows)? En faisant une recherche sur cmd.exe, windows m'amène là
Si pas ok, merci de me dire comment y aller

3) Il faut explicitement lancer l'invite de commande en tant qu'administrateur, et pas seulement avec un compte administrateur, sinon les privilèges d'administration ne sont pas forcément activés.
=> là je ne suis pas sûr de comprendre: je n'ai que 2 users windows sur cette machine, et je l'ai essayé avec les 2 (les 2 ont des droits admin), l'un est un compte local (avec lequel j'ai installé windows), l'autre est un compte Microsoft (donc cloud), mais le même résultat pour les 2

4) efibootmgr
=> en bootant sur la clé de récupération Windows qui me permet de lancer debian comme "périphérique", j'obtiens ceci:

root@Debport01:/home/papay7584# efibootmgr


BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 2001,0002,0001,2002,2003
Boot0000* USB HDD: Sony    Storage Media
Boot0001* debian
Boot0002* Windows Boot Manager
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network



Merci pour tes retours!


If you're going through hell, keep going (Winston Churchill)
Vivez comme si vous deviez mourir demain, apprenez comme si vous deviez vivre toujours (Bouddha)
A winner is a dreamer who never gives up (Nelson Mandela)
Logic will get you from A to Z ; Imagination will get you everywhere (Albert Einstein)

Hors ligne

#5 29-12-2018 14:02:08

solar66
Membre
Distrib. : debian stable
Noyau : Linux 5.10.0-9-amd64
(G)UI : cinnamon
Inscription : 23-08-2016

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

si tu regardes le résultat de efibootmgr; tu as timeout=0  donc il démarre immédiatement dans l'ordre indiqué, soit:
Boot2001* EFI USB Device, puis Boot0002* Windows Boot Manager,
donc il faudrait modifié, dans un premier temps,timeout=0 en timeout=5 ou 4 ou....ce qui te permettra d'avoir la fenêtre de grub afin de démarrer le système de ton choix

Dernière modification par solar66 (29-12-2018 14:05:36)

Hors ligne

#6 29-12-2018 14:11:17

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

solar66 a écrit :

si tu regardes le résultat de efibootmgr; tu as timeout=0  donc il démarre immédiatement dans l'ordre indiqué, soit:
Boot2001* EFI USB Device, puis Boot0002* Windows Boot Manager,
donc il faudrait modifié, dans un premier temps,timeout=0 en timeout=5 ou 4 ou....ce qui te permettra d'avoir la fenêtre de grub afin de démarrer le système de ton choix


Et il ne serait mieux de modifier l'ordre d'amorçage, étant donné qu'il a démarré avec le média externe pour dépanner? roll 

efibootmgr -o 2001,0001,0002,2002,2003



Salut


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#7 29-12-2018 14:14:47

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Papy7584 a écrit :


2) Il est préférable d'exécuter la commande avec l'invite de commande classique (cmd.exe) plutôt qu'avec powershell.
=> je pense que c'est le cas: j'ai pris l'icone du terminal noir "invité de commandes" sous "système Windows" dans les applications (sous Windows)? En faisant une recherche sur cmd.exe, windows m'amène là


Correct, c'est cmd.exe.

Papy7584 a écrit :

3) Il faut explicitement lancer l'invite de commande en tant qu'administrateur, et pas seulement avec un compte administrateur, sinon les privilèges d'administration ne sont pas forcément activés.
=> là je ne suis pas sûr de comprendre: je n'ai que 2 users windows sur cette machine, et je l'ai essayé avec les 2 (les 2 ont des droits admin), l'un est un compte local (avec lequel j'ai installé windows), l'autre est un compte Microsoft (donc cloud), mais le même résultat pour les 2


Avec "explicitement" raleur veut dire (je crois) que'il faut faire bouton droit sur l'icône de cmd.exe et "Exécuter comme Administrateur".


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#8 29-12-2018 15:21:45

raleur
Membre
Inscription : 03-10-2014

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

solar66 a écrit :

si tu regardes le résultat de efibootmgr; tu as timeout=0  (...)
donc il faudrait modifier, dans un premier temps,timeout=0 en timeout=5 ou 4 ou....ce qui te permettra d'avoir la fenêtre de grub


Il s'agit des variables de boot EFI, rien à voir avec GRUB.

empanada a écrit :

il ne serait mieux de modifier l'ordre d'amorçage ?


Oui, c'est l'étape suivante pour que GRUB soit lancé automatiquement. En espérant que le firmware UEFI ne soit pas du type récalcitrant.

empanada a écrit :

Avec "explicitement" raleur veut dire (je crois) que'il faut faire bouton droit sur l'icône de cmd.exe et "Exécuter comme Administrateur".


Exactement.


Il vaut mieux montrer que raconter.

Hors ligne

#9 29-12-2018 16:10:25

Papy7584
Membre
Lieu : 75, 84 et Flandres belges...
Distrib. : Debian Buster (4.19.67-2)
Noyau : Linux 4.19.0-6-amd64
(G)UI : default - GNOME
Inscription : 24-12-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Merci à vous tous!

Je ne connaissais pas l'option de cmd.exe (exécution sous Admin), en exécutant

bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi


je n'ai plus eu d'erreur, mais cela n'a pas réglé le pb, j'ai donc exécuté

efibootmgr -o 2001,0001,0002,2002,2003


et cela fonctionne!!!! woohoo.gifwoohoo.gifwoohoo.gif (testé pour debian & Windows). je n'ai donc effectivement pas eu besoin de changer le time-out. Cela reste un mystère pourquoi cet ordre de boot a soudainement changé, mais cela fait partie des joies de l'informatique...

juste pour info: retour de

efibootmgr


BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000,2001,2002,2003
Boot0000* Windows Boot Manager
Boot0001* debian
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network
 



Bravo! réglé en moins de 24h un pb sur lequel je galère depuis 15 jours.... crash.gif Cela m'oblige à rester fan à vie de "Debian-Facile" wink

Merci à vous! je passe le pb en "résolu" et continue ma découverte de debian/python/.....

Papy7584


If you're going through hell, keep going (Winston Churchill)
Vivez comme si vous deviez mourir demain, apprenez comme si vous deviez vivre toujours (Bouddha)
A winner is a dreamer who never gives up (Nelson Mandela)
Logic will get you from A to Z ; Imagination will get you everywhere (Albert Einstein)

Hors ligne

#10 29-12-2018 18:30:28

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Papy7584 a écrit :

en exécutant

bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi


je n'ai plus eu d'erreur, mais cela n'a pas réglé le pb, j'ai donc exécuté


Bon, en fait, je n'aime pas trop cette commande, proposée partout dans la net , et aussi sur le lien que t'avais mis dans ton premier message (Dual-boot Windows-Debian avec UEFI -->grub-ne-se-lance-pas).
Cette commande écrase le chemin du Windows Boot Loader (nommée "{bootmgr}), et il me semble que peut être l'origine de pas mal d'ennuies avec les dual-boot. On n'écrase pas le fichier *.efi (\EFI\Microsoft\Boot\bootmgfw.efi), il reste à son emplacement...mais on écrase dans le entrée su firmware le chemin , et je crains que suite à des mises à jour par exemple, Windows (et/ou peut-être des Anti-Virus Anti-Malware peuvent le faire aussi), vérifie son entrée dans le firmware, et si ce n'est pas correcte (pour lui, évidement, elle n'est pas correcte), la substitue par l'originale. Je parie que c'est l'origine de nombreux problèmes, très fréquents du genre "le dual-boot fonctionnait bien pendant des mois et un jour c'est seulement Windows qui démarre" (comme ce fil lui même).
Dans ton cas ,la commande bcdedit, il me semble qu'elle ne fait rien du tout parce que Windows (ou un logiciel tiers (Anti-virus, Anti-malware...)), protège l'entrée sur le firmware, et, bien qu'il ne te lance pas d'erreur, ce logiciel écrase à nouveau la commande bcdedit sur {bootmgr}.

Si j'utilise bcdedit sous Windows, je préfère ajouter une entrée spécifique pour debian, qui n'écrase rien sur l'entrée Windows, et minimise les risques de tomber en panne à cause des interférences avec Windows. Les risques ne sont pas zéro puisque Windows ou des logiciels tiers (aussi logiciels de dépannage, copie de sécurité, etc (comme ceux des fabricants (HP, ACER...)) peuvent toujours se remettre comme entrée par défaut sur le firmware, et changer le comportement par défaut, mais, au moins, c'est plus difficile qu'ils touchent ailleurs, des entrées qui ne leur "appartient" pas, de façon que remettre l'ordre désiré par l'utilisateur, et non ceci désiré par un logiciel, c'est plus facile.

Moi, au lieu de la commande "bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi", qui écrase le chemin du exécutable *.efi Windows  je ferais ces trois pas, qui créent une nouvelle entrée sur le firmware UEFI pour debian, et la mettent comme option d'amorçage par défaut  (oui, ils sont trois au lieu d'un, mais le résultat c'est nettement plus propre à mon avis).
Comme dit pus haut par raleur, exécuter bcdedit avec cmd.exe (non powershell), et explicitement comme administrateur (bouton droit sur cmd.exe et "Exécuter comme administrateur"):

1) Créer un copie de l'entrée UEFI du type "Windows Boot Manager" , et nommée {bootmgr}, avec le nom "debian stretch":

bcdedit /copy {bootmgr} /d "debian stretch"

Cette commande nous montre le {guid} de la nouvelle entrée "debian stretch"

2) Établir le chemin du fichier *.efi de l'entrée récemment crée dans le pas antérieur (le {guid} c'est le retour de la commande antérieure. Si on a oublié ou pas noté, on peut vérifier avec la commande    bcdedit /enum firmware )

bcdedit /set {guid} path \EFI\debian\grubx64.efi



3) Établir l'entrée EFI {guid} comme option par défaut sur le gestionnaire d'amorçage du firmware UEFI:

bcdedit /set {fwbootmgr} displayorder {guid} /addfirst


Ça y est!!

Quelques autres commandes bcdedit qui peuvent être utiles:

Voir une liste de toutes les entrées et l'ordre d'amorçage sur le firmware UEFI:

bcdedit /enum firmware



Voir une liste des "Windows Boot Manager" (gestionnaire d'amorçage) et les "Windows Boot loader"

bcdedit /enum



Établir l'entrée EFI {bootmgr} ("Windows Boot Manager") comme option par défaut sur le gestionnaire d'amorçage du firmware UEFI:

bcdedit /set {fwbootmgr} displayorder {bootmgr} /addfirst



Établir à nouveau le chemin correct pour le fichier *.efi de l'entrée EFI {bootmgr} ("Windows Boot Manager")

bcdedit /set {bootmgr} path \EFI\Microsoft\Boot\bootmgfw.efi



Salut

Dernière modification par empanada (29-12-2018 18:36:24)


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#11 29-12-2018 19:01:07

raleur
Membre
Inscription : 03-10-2014

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Papy7584 a écrit :

je n'ai plus eu d'erreur, mais cela n'a pas réglé le pb


Cela m'étonne un peu. On peut voir la sortie de

efibootmgr -v


qui mentionne le chemin des exécutables EFI associés aux entrées Debian et Windows ?

Papy7584 a écrit :

Cela reste un mystère pourquoi cet ordre de boot a soudainement changé, mais cela fait partie des joies de l'informatique


Plutôt des joies de l'UEFI. Plus j'y suis confronté, plus je trouve que le comportement des diverses implémentations est imprévisible.

L'ordre de boot EFI peut avoir été modifié par Windows à l'occasion d'une de des mises à jour. Ne le blâmez pas, Debian fera la même chose en cas de mise à jour de GRUB. Blâmez plutôt les firmwares UEFI dont la gestion de l'amorçage est à chier alors que cela aurait pu être quelque chose de formidable, donnant à l'utilisateur un bien meilleur contrôle sur l'amorçage. que son prédécesseur BIOS. On savait très bien depuis bien avant l'UEFI que dans un environnement multi-boot les différents OS ont tendance à se tirer dans les pattes pour avoir la meilleure place dans l'ordre d'amorçage au lieu de coopérer. Bref, c'est une grosse déception en ce qui me concerne.

Papy7584 a écrit :

réglé en moins de 24h un pb sur lequel je galère depuis 15 jours


L'UEFI ajoute beaucoup de complexité pour finalement pas beaucoup d'avantages.


Il vaut mieux montrer que raconter.

Hors ligne

#12 29-12-2018 19:04:51

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

raleur a écrit :

L'UEFI ajoute beaucoup de complexité pour finalement pas beaucoup d'avantages.


Cent pour cent d'accord.


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#13 29-12-2018 22:06:14

Papy7584
Membre
Lieu : 75, 84 et Flandres belges...
Distrib. : Debian Buster (4.19.67-2)
Noyau : Linux 4.19.0-6-amd64
(G)UI : default - GNOME
Inscription : 24-12-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

@empanada,
Merci pour ces explications très complètes, qui me permettent de comprendre un peu ce qui se passe.... et je partage: ta solution me parait plus propre que le remplacement un peu "sous les radars" du fichier windows dans le chemin

@raleur
Par contre, je vais passer pour le vrai "bidouilleur" ops.gif : entre-temps, j'ai refait une nouvelle install Windows/debian (j'en suis au point que je peux la faire les yeux fermés maintenant... lol):
Pour remonter à il y a 3 ou 4 mois, j'avais installé Debian en dual boot sans problème, et sans nécessité de faire des commandes supplémentaires (type bcdedit, bootmgr,etc) (mais ce n'était sûrement pas la même version Debian). De plus, après mon dernier mail ci-dessous/dessus, j'ai continué et j'ai eu d'autres (nouveaux) petits problèmes:
- dans synaptic, il allait chercher des fichiers sur un DVD (qui était coché comme étant un source de paquets)
- des problèmes de clé de sécurité qui manquaient
...?
Cela me donnait l'impression d'une install qui n'était pas tout à fait propre. Au point où j'en étais, j'ai réinstallé une nouvelle fois le tout (Windows & Debian), en espérant que cela la rendrait plus propre...
- après l'install, le boot partait à nouveau sur Windows direct...
- j'ai refait sagement la commande bcdedit, avec le même résultat (pas d'erreur, mais pas de changement sur le boot)
- j'ai donc refait le changement sur l'ordre du boot
- et cela refonctionne.

voici efibootmgr -v dans l'état actuel, où je comprends que j'ai maintenant deux entrées boot Windows: l'un avec le fichier windows, l'autre avec grub.. d'ici à chercher un lien avec l'explication d'empanada.....

root@debport01:/home/papy7584# efibootmgr -v

BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000,0003,2001,2002,2003
Boot0000* Windows Boot Manager  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* debian  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)
Boot0003* Windows Boot Manager  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot2001* EFI USB Device  RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC

root@debport01:/home/papy7584#
 


Du coup, je me demande s'il ne faut pas que je refasse une nouvelle install Windows/Debian, et appliquer la procédure d'empanada, éventuellement avec un changement d'ordre du boot, si besoin....
(je vais bientôt changer mon pseudo en Mister ré-Install mrgreen.gif)
Merci à vous 2,
Papy7584


If you're going through hell, keep going (Winston Churchill)
Vivez comme si vous deviez mourir demain, apprenez comme si vous deviez vivre toujours (Bouddha)
A winner is a dreamer who never gives up (Nelson Mandela)
Logic will get you from A to Z ; Imagination will get you everywhere (Albert Einstein)

Hors ligne

#14 30-12-2018 01:16:37

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Papy7584 a écrit :


root@debport01:/home/papy7584# efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000,0003,2001,2002,2003
Boot0000* Windows Boot Manager  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* debian  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)
Boot0003* Windows Boot Manager  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot2001* EFI USB Device  RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC


voici efibootmgr -v dans l'état actuel, où je comprends que j'ai maintenant deux entrées boot Windows: l'un avec le fichier windows, l'autre avec grub.. d'ici à chercher un lien avec l'explication d'empanada.....


Papy7584 a écrit :

Pour remonter à il y a 3 ou 4 mois, j'avais installé Debian en dual boot sans problème, et sans nécessité de faire des commandes supplémentaires (type bcdedit, bootmgr,etc) (mais ce n'était sûrement pas la même version Debian). De plus, après mon dernier mail ci-dessous/dessus, j'ai continué et j'ai eu d'autres (nouveaux) petits problèmes:
- dans synaptic, il allait chercher des fichiers sur un DVD (qui était coché comme étant un source de paquets)
- des problèmes de clé de sécurité qui manquaient
...?
Cela me donnait l'impression d'une install qui n'était pas tout à fait propre. Au point où j'en étais, j'ai réinstallé une nouvelle fois le tout (Windows & Debian), en espérant que cela la rendrait plus propre...
- après l'install, le boot partait à nouveau sur Windows direct...
- j'ai refait sagement la commande bcdedit, avec le même résultat (pas d'erreur, mais pas de changement sur le boot)
- j'ai donc refait le changement sur l'ordre du boot
- et cela refonctionne.


Pas besoin du tout de réinstaller. Suite à ce réinstallation, il est resté une entrée orpheline sur le firmware UEFI, celle ci que sous Windows c'est nommée {bootmgr}. C'est la raison de que la commande  "bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi" n'arrivait pas à rendre grub comme gestionnaire d'amorçage par défaut, parce que cette entrée ce n'est pas celle-ci qui correspond au Windows présent mais au Windows antérieur.
C'est le problème de copier-coller des procédures sans comprendre ce qu'on fait. Sur la net c'est plein d'information...pas toujours correcte...et la plupart des fois rien expliqué: que des listes des commandes sans explications,donc des recettes qu'on peut pas suivre au pied de la lettre, parce que ce n'est pas courant de rencontrer deux problèmes comme deux goûtes d'eau. Il faut essayer de comprendre, sinon, c'est comme jouer au roulette.

Papy7584 a écrit :


Du coup, je me demande s'il ne faut pas que je refasse une nouvelle install Windows/Debian, et appliquer la procédure d'empanada, éventuellement avec un changement d'ordre du boot, si besoin....


Pourquoi réinstaller à nouveau? Je ne vois pas aucune raison. Cette procédure et autre quelconque peut être fait sans besoin de réinstaller.   Je ne vois pas qu'une petite tache: une entrée sur le firmware qui n'est pas utilisée, qui peut être virée avec

efibootmgr -b 0003 -B



Salut.

PS: réinstaller sad Réinstaller normalement ne sert à rien...et si oui, on n'apprend pas à résoudre

Dernière modification par empanada (30-12-2018 02:14:04)


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#15 30-12-2018 14:13:05

Papy7584
Membre
Lieu : 75, 84 et Flandres belges...
Distrib. : Debian Buster (4.19.67-2)
Noyau : Linux 4.19.0-6-amd64
(G)UI : default - GNOME
Inscription : 24-12-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Bonjour!

empanada a écrit :


C'est le problème de copier-coller des procédures sans comprendre ce qu'on fait. Sur la net c'est plein d'information...pas toujours correcte...et la plupart des fois rien expliqué: que des listes des commandes sans explications,donc des recettes qu'on peut pas suivre au pied de la lettre, parce que ce n'est pas courant de rencontrer deux problèmes comme deux goûtes d'eau. Il faut essayer de comprendre, sinon, c'est comme jouer au roulette.


Je comprends tout à fait ce raisonnement de quelqu'un qui maîtrise très bien, mais le problème, quand on est Débutant (avec un grand D), on ne sait pas :
- si on a compris le problème (voire s'il y a un problème... mrgreen.gif)
- si on s'attaque bien à sa cause, non pas à une conséquence
- si on a vu la totalité du problème
- par quel bout s'y attaquer
et dès qu'on regarde un truc, on a de nouveau 25 sujets totalement inconnus qui apparaissent.... Donc sans chercher à t'énerver tongue, quand on ne sait pas très bien ce qui se passe et/ou ce qu'on est en train de faire, le plus pragmatique peut donc être de laisser faire les scripts d'installation (surtout que dans mon cas, quand on encore un PC "vide" et que les scripts avaient très bien marché il y a 3 mois...). Clairement, sans votre aide, c'était cause perdue... je suis de nature de déranger les autres le moins possible... et je ne connaissais pas encore l'efficacité et l'esprit d'entre-aide de Debian-Facile lol. Mais je ferme là mon paragraphe de ma défense wink

J'ai donc sagement suivi tes conseils, et effectivement, avec la suppression de l'entrée Windows "orpheline" cela fonctionne à merveille ! yes.gif
J'ajoute à la fin, juste en documentation, les infos avant et après la commande de "nettoyage". En tout cas merci pour ton aide et, surtout tes explications ! merci.gif

Maintenant après tes 2 explications, je vais essayer d'aller au bout de ma compréhension: je comprends :
- au lancement du PC, UEFI boot (remplace l'ancien BIOS)
- il s'adresse à des programmes/périphériques de boot selon l'odre imposé (voir Bootorder), où il suit l'ordre jusqu'au moment qu'il y en un a qui arrive à "booter"? Donc en principe, il s'arrêtera toujours au debian (dans mon cas)?

du coup, le sens du changement de chemin du boot Windows (la commande bcdedit initialement utilisé: bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi) est de "tromper" le boot Windows, pour qu'il aille sur le fichier de boot grub, qui lui, en cas de choix de boot windows, exécute le "vrai" fichier boot windows? Et en cas de pb sur le boot debian, windows ne booterait donc pas...? Dans ce cas, je partage d'autant plus que cela n'est pas propre (du tout...)

Et dernière question: "A l'époque" (là je parle vraiment comme un vieux...), on mettait le boot disquette en premier, et du coup, en cas d'absence de disquette de boot, il passait ensuite sur le disque dur?  pourquoi donc ne pas mettre le boot "USB" en premier?

Papy7584



les infos avant et après la commande de "nettoyage":


root@debport01:/home/papy7584#

efibootmgr


BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000,0003,2001,2002,2003
Boot0000* Windows Boot Manager
Boot0001* debian
Boot0003* Windows Boot Manager
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network



root@debport01:/home/papy7584#

efibootmgr -v


BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000,0003,2001,2002,2003
Boot0000* Windows Boot Manager  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* debian  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)
Boot0003* Windows Boot Manager  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot2001* EFI USB Device  RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC



root@debport01:/home/papy7584#

efibootmgr -b 0003 -B



BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000,2001,2002,2003
Boot0000* Windows Boot Manager
Boot0001* debian
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network



root@debport01:/home/papy7584#

efibootmgr -v


BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000,2001,2002,2003
Boot0000* Windows Boot Manager  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* debian  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)
Boot2001* EFI USB Device  RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC



root@debport01:/home/papy7584#

Edit à toto : Mis chaque commande root séparée des autres dans l'ensemble présenté.


If you're going through hell, keep going (Winston Churchill)
Vivez comme si vous deviez mourir demain, apprenez comme si vous deviez vivre toujours (Bouddha)
A winner is a dreamer who never gives up (Nelson Mandela)
Logic will get you from A to Z ; Imagination will get you everywhere (Albert Einstein)

Hors ligne

#16 30-12-2018 16:44:48

raleur
Membre
Inscription : 03-10-2014

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Papy7584 a écrit :

- au lancement du PC, UEFI boot (remplace l'ancien BIOS)
- il s'adresse à des programmes/périphériques de boot selon l'odre imposé (voir Bootorder), où il suit l'ordre jusqu'au moment qu'il y en un a qui arrive à "booter"? Donc en principe, il s'arrêtera toujours au debian (dans mon cas)?


Oui.

Papy7584 a écrit :

du coup, le sens du changement de chemin du boot Windows (la commande bcdedit initialement utilisé: bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi) est de "tromper" le boot Windows, pour qu'il aille sur le fichier de boot grub


On ne trompe pas le boot Windows, puisque c'est Windows lui-même avec son programme bcdedit qui fait ce changement.

Papy7584 a écrit :

Et en cas de pb sur le boot debian, windows ne booterait donc pas...?


Si bcdedit n'a pas laissé une entrée de boot avec le chemin du chargeur de Windows, alors l'UEFI ne pourra pas lancer ce chargeur. Mais il pourra lancer le chargeur par défaut présent en tant que \EFI\Boot\bootx64.efi qui se trouve être le chargeur de secours de Windows. C'est pour cela que Windows arrive souvent à retomber sur ses pattes malgré les nombreux bugs des firmwares UEFI.

Dernière modification par raleur (30-12-2018 16:45:41)


Il vaut mieux montrer que raconter.

Hors ligne

#17 30-12-2018 17:39:55

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Papy7584 a écrit :

Je comprends tout à fait ce raisonnement de quelqu'un qui maîtrise très bien, mais le problème, quand on est Débutant (avec un grand D), on ne sait pas :
- si on a compris le problème (voire s'il y a un problème... mrgreen.gif)
- si on s'attaque bien à sa cause, non pas à une conséquence
- si on a vu la totalité du problème
- par quel bout s'y attaquer
et dès qu'on regarde un truc, on a de nouveau 25 sujets totalement inconnus qui apparaissent.... Donc sans chercher à t'énerver tongue, quand on ne sait pas très bien ce qui se passe et/ou ce qu'on est en train de faire, le plus pragmatique peut donc être de laisser faire les scripts d'installation (surtout que dans mon cas, quand on encore un PC "vide" et que les scripts avaient très bien marché il y a 3 mois...). Clairement, sans votre aide, c'était cause perdue... je suis de nature de déranger les autres le moins possible... et je ne connaissais pas encore l'efficacité et l'esprit d'entre-aide de Debian-Facile lol. Mais je ferme là mon paragraphe de ma défense wink


Je t'en prie de m'excuser, peut-être je fut un peu brusque. L'idée ce n'était pas de blâmer ou attaquer mais plutôt de pointer vers la direction correcte. On a tous été débutants donc on s'est tous senti perdu pas mal des fois. Je voulais renforcer l'idée d'investir plus temps à lire et comprendre, qu'à répéter des séquences des actions , par exemple tout réinstaller quand on rencontre le moindre problème(très courant quand on débute, donc courant sur ce forum aussi), c'est tuer des mouches avec de canons.

raleur a écrit :

Papy7584 a écrit :

du coup, le sens du changement de chemin du boot Windows (la commande bcdedit initialement utilisé: bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi) est de "tromper" le boot Windows, pour qu'il aille sur le fichier de boot grub


On ne trompe pas le boot Windows, puisque c'est Windows lui-même avec son programme bcdedit qui fait ce changement.

Papy7584 a écrit :

Et en cas de pb sur le boot debian, windows ne booterait donc pas...?


Si bcdedit n'a pas laissé une entrée de boot avec le chemin du chargeur de Windows, alors l'UEFI ne pourra pas lancer ce chargeur. Mais il pourra lancer le chargeur par défaut présent en tant que \EFI\Boot\bootx64.efi qui se trouve être le chargeur de secours de Windows. C'est pour cela que Windows arrive souvent à retomber sur ses pattes malgré les nombreux bugs des firmwares UEFI.


Bon , je vois la commande "bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi" plutôt comme "tromper", comme Papy7584 disait, puisque c'est modifier l'entrée Windows manuellement (entrée crée automatiquement par Windows), et , bien que je ne suis pas complètement sûr (difficile à savoir), je crains que Windows ou des logiciels tiers, suite à certains événements (par exemple des mises à jour), vérifie "son" entrée ,et s'il n'est pas "correcte", il rétablie le chemin original. C'est vrai que l'entrée \EFI\Boot\bootx64.efi permet toujours amorcer Windows, mais je parle de contourner l'écrasement du chemin de l'application *.efi de Windows pour éviter des problèmes futurs avec le dualboot, plutôt que pour éviter le problème de ne pas pouvoir démarrer Windows.
Quand même, cette vision est subjective...et peut pas fonctionner avec certaines implémentations UEFI mauvaises, qui parfois ne permettent que les chemins "Windows" comme chemins valables pour les exécutables *.efi, ou des autres conneries. C'est pour ces conneries que, par exemple, GRUB à l'option d'écraser le fallback bootloader

Salut.

Dernière modification par empanada (30-12-2018 18:02:05)


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#18 30-12-2018 22:38:54

Papy7584
Membre
Lieu : 75, 84 et Flandres belges...
Distrib. : Debian Buster (4.19.67-2)
Noyau : Linux 4.19.0-6-amd64
(G)UI : default - GNOME
Inscription : 24-12-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Bonjour à vous!

empanada a écrit :

peut-être je fut un peu brusque.

Pas du tout, ne t'inquiète pas - je ne pouvais pas m'empêcher de t'embêter un peu... tongue je comprends et partage tout à fait ta vision, et mon objectif est bien, justement, d'acquérir les connaissances suffisantes pour pouvoir aller creuser le tout en détail ! Vaste programme avant, pendant et jusqu'à la fin de ma retraite lol Mais comme tu l'indiques: on a souvent des listes de commandes sur le "comment" faire quelque chose (avec plus ou moins de précision et de fiabilité), pas trop sur le "pourquoi"...

Pour revenir sur notre débat "philosophique" ("propreté" de la commande : bcdedit /set ‘{bootmgr}’ path \EFI\ debian\grubx64.efi) : ce qui me gêne, hormis les arguments avancés par empanada, est que
1) dans les pointeurs vers les secteurs Boot, derrière le pointeur "Windows" se "cache" en réalité un fichier Grub (donc Linux)
2) du coup, 'il n'y a plus de secteur boot Windows en primaire (je comprends qu'il semble y avoir un ultime fallback avec l'entrée  \EFI\Boot\bootx64.efi, mais supprimer le primaire, sous prétexte qu'il y a un secours, me parait limite..  (cette entrée n'est d'ailleurs pas mentionné dans efibootmgr ou bdedit, je suppose parce qu'il n'est pas modifiable).
Mais il est vrai que les goûts et les couleurs ne se discutent pas (ou au contraire, peuvent se discuter très longtemps...:rolleyes:).

Par contre, j'ai une dernière question (promis, après j'arrête):
je comprends que BCD(edit) et efibootmgr accèdent en réalité les mêmes fichiers config ? mais je ne comprends pas le lien avec les infos de l'écran UEFI (*) (l'ordre du boot), où j'ai maintenant 3 (!!) entrées Windows (et rien sur debian)? je m'attendais à y trouver les mêmes infos que sous efibootmgr et/ou bcdedit?

(*) avec l'écran UEFI, je veux dire celui qu'on appelait le "BIOS" avant, qu'on obtient avec F2, F12,... lors du boot du PC.

A+
Papy7584

Dernière modification par Papy7584 (30-12-2018 22:40:25)


If you're going through hell, keep going (Winston Churchill)
Vivez comme si vous deviez mourir demain, apprenez comme si vous deviez vivre toujours (Bouddha)
A winner is a dreamer who never gives up (Nelson Mandela)
Logic will get you from A to Z ; Imagination will get you everywhere (Albert Einstein)

Hors ligne

#19 31-12-2018 00:58:19

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Papy7584 a écrit :

je comprends que BCD(edit) et efibootmgr accèdent en réalité les mêmes fichiers config ?

Oui, ils accèdent et/ou modifient les entrées sur le firmware UEFI. Ils sont des commandes équivalents.

Papy7584 a écrit :

mais je ne comprends pas le lien avec les infos de l'écran UEFI (*) (l'ordre du boot), où j'ai maintenant 3 (!!) entrées Windows (et rien sur debian)? je m'attendais à y trouver les mêmes infos que sous efibootmgr et/ou bcdedit?

  scratchhead.gif Tu es sûr? Ça ne serait pas des différentes options de démarrage Windows (comme GRUB a différentes options pour démarrer debian (mode dépannage, etc)) Ça n'a pas beaucoup de sens puisque tu as dit que debian démarre bien (bon, non seulement debian mais GRUB, donc Windows aussi). Est-ce qu'on peut voir une capture d'écran de cette liste?

Salut.


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#20 31-12-2018 11:26:35

Papy7584
Membre
Lieu : 75, 84 et Flandres belges...
Distrib. : Debian Buster (4.19.67-2)
Noyau : Linux 4.19.0-6-amd64
(G)UI : default - GNOME
Inscription : 24-12-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Bonjour!

Tu es sûr?


Sûr? Non! avec mon niveau de maîtrise, je ne suis sûr de rien ... tongue mais j'ai collecté un peu d'info sur ce que je vois (désolé, je n'ai pas su faire autrement que prendre des photos.... ), et du coup je vois que la deuxième entrée Windows est réapparue... (celle qui pointe sur grubx64.efi)????
Heureusement que j'avais pris des traces efibootmgr avant et après ma manip - sinon, j'aurais cru de perdre le cibouleau... (voir mon message de hier...)

Faut il faire une des commandes proposées par empanada ?

bcdedit /set {bootmgr} path \EFI\Microsoft\Boot\bootmgfw.efi


et ré-effacer l'entrée ensuite?

Ce n'est pas pour mettre de l'huile sur le feu, mais l'apparition d'un deuxième boot windows dans la fenêtre BIOS (mais il n'y avait que deux entrées, pas trois), était une des raisons qui m'avait incitée à tout réinstaller.

Bon, je pensais être au bout de cette histoire...scratchhead.gif
Papy7584

-----------------------------------------------------------------------------------------------------------------

UEFI: UEFI
Grub: GRUB




efibootmgr -v


BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0001,0000,2001,2002,2003
Boot0000* Windows Boot Manager    HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* debian    HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)
Boot0002* Windows Boot Manager    HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot2001* EFI USB Device    RC
Boot2002* EFI DVD/CDROM    RC
Boot2003* EFI Network    RC


bcdedit /enum firmware


Gestionnaire de démarrage du microprogramme
-------------------------------------------
identificateur          {fwbootmgr}
displayorder            {bootmgr}
                        {2a9bec83-0b87-11e9-b830-806e6f6e6963}
                        {4fdd297f-0b88-11e9-b831-806e6f6e6963}
                        {db33eb9f-0bc3-11e9-9d52-8b444adbb9fa}
                        {db33eba0-0bc3-11e9-9d52-8b444adbb9fa}
                        {db33eba1-0bc3-11e9-9d52-8b444adbb9fa}
timeout                 0

Gestionnaire de démarrage Windows
---------------------------------
identificateur          {bootmgr}
device                  partition=\Device\HarddiskVolume1
path                    \EFI\debian\grubx64.efi
description             Windows Boot Manager
locale                  fr-FR
inherit                 {globalsettings}
default                 {current}
resumeobject            {db33eba7-0bc3-11e9-9d52-8b444adbb9fa}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 0

Application logicielle (101fffff)
--------------------------------
identificateur          {2a9bec83-0b87-11e9-b830-806e6f6e6963}
device                  partition=\Device\HarddiskVolume1
path                    \EFI\debian\grubx64.efi
description             debian

Application logicielle (101fffff)
--------------------------------
identificateur          {4fdd297f-0b88-11e9-b831-806e6f6e6963}
device                  partition=\Device\HarddiskVolume1
path                    \EFI\Microsoft\Boot\bootmgfw.efi
description             Windows Boot Manager

Application logicielle (101fffff)
--------------------------------
identificateur          {db33eb9f-0bc3-11e9-9d52-8b444adbb9fa}
description             EFI USB Device

Application logicielle (101fffff)
--------------------------------
identificateur          {db33eba0-0bc3-11e9-9d52-8b444adbb9fa}
description             EFI DVD/CDROM

Application logicielle (101fffff)
--------------------------------
identificateur          {db33eba1-0bc3-11e9-9d52-8b444adbb9fa}
description             EFI Network
 

Dernière modification par Papy7584 (31-12-2018 17:01:30)


If you're going through hell, keep going (Winston Churchill)
Vivez comme si vous deviez mourir demain, apprenez comme si vous deviez vivre toujours (Bouddha)
A winner is a dreamer who never gives up (Nelson Mandela)
Logic will get you from A to Z ; Imagination will get you everywhere (Albert Einstein)

Hors ligne

#21 31-12-2018 19:04:53

Papy7584
Membre
Lieu : 75, 84 et Flandres belges...
Distrib. : Debian Buster (4.19.67-2)
Noyau : Linux 4.19.0-6-amd64
(G)UI : default - GNOME
Inscription : 24-12-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

smolski a écrit :

Pour ma part j'ai choisi d'installer vim-nox.
Voir le tuto :
https://debian-facile.org/doc:editeurs:vim:vim#vim-nox


Maintenant que mon debian tourne (malgré quelques bizarreries à régler), j'ai installé vim-nox, et m'y suis mis! cela est assez abordable pour démarrer, et me permettra de faire des changements basiques si besoin! merci.gif
Papy7584


If you're going through hell, keep going (Winston Churchill)
Vivez comme si vous deviez mourir demain, apprenez comme si vous deviez vivre toujours (Bouddha)
A winner is a dreamer who never gives up (Nelson Mandela)
Logic will get you from A to Z ; Imagination will get you everywhere (Albert Einstein)

Hors ligne

#22 31-12-2018 20:54:07

raleur
Membre
Inscription : 03-10-2014

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Les informations d'efibootmgr et de bcdedit correspondent.
Quant à la liste "boot priority order" des réglages UEFI, le contenu de chaque ligne 1 2 et 3 ne serait pas une parmi les différentes entrées de boot disponibles ? Vérifie si tu peux sélectionner une ligne et appuyer sur Entrée pour la modifier.

Il vaut mieux montrer que raconter.

Hors ligne

#23 01-01-2019 13:00:32

Papy7584
Membre
Lieu : 75, 84 et Flandres belges...
Distrib. : Debian Buster (4.19.67-2)
Noyau : Linux 4.19.0-6-amd64
(G)UI : default - GNOME
Inscription : 24-12-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Bonne année tux.pngdebian.pngD E B I A N 2 0 1 9 debian.pngtux.pngà vous tous!!

raleur a écrit :

Vérifie si tu peux sélectionner une ligne et appuyer sur Entrée pour la modifier.

Non: je peux uniquement monter ou descendre une ligne dans la liste (donc changer l'ordre). Quand je mets une clé USB, elle apparaît comme 4ième entrée dans la liste

raleur a écrit :

Quant à la liste "boot priority order" des réglages UEFI, le contenu de chaque ligne 1 2 et 3 ne serait pas une parmi les différentes entrées de boot disponibles ?

file-Ra0889311f346cde71abb364457b422be

BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0001,0000,2001,2002,2003
Boot0000* Windows Boot Manager  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* debian  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)
Boot0002* Windows Boot Manager  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot2001* EFI USB Device  RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC
 


Cela donne effectivement l'impression que UEFI affiche l'entrée "debian" (le deuxième boot dans UEFI et dans bootorder), comme une entrée "Windows Boot Manager", et que cela donne du coup l'impression que j'aie 3 boots Windows. Cela expliquerait peut-être aussi pourquoi l'affichage du 2ième Windows dans UEFI est différent: pas suivi d'un code (code disque?).

dans ce cas:
- Boot0000: le boot Windows qui pointe sur bootmgfw.efi est normal
- Boot0001: le boot debian qui pointe grubx64.efi également, avec un "bug" dans UEFI, affiché comme Windows au lieu de debian (supposons)
- Boot0002: par contre, je ne comprends pas d'où vient ce boot Windows qui pointe sur grubx64.efi....
car j'avais bien effacé celui-ci.... !?!?! (voir traces dans un de mes messages précédents)  scratchhead.gif

- A la limite, je peux comprendre que "quelque chose" rajoute à nouveau une entrée boot Windows (tel qu'empanada le mentionnait comme hypothèse),
- mais dans ce cas, elle pointerait sur bootmgfw.efi, pas sur grubx64.efi??
- de plus le bootorder interpelle: cette entrée est en premier dans le bootorder, d'ailleurs le PC boot sur cette ligne (BootCurrent: 0002) ?!?
A noter d'ailleurs que l'entrée Windows -> grubx64.efi est maintenant sur Boot0002, où avant il était sur Boot0003... il sembe donc bien concerner  une "nouvelle" install??

Je sens que je vais tout réinstaller - mais non, JE RIGOLE... !! lol



Papy7584old_geek.gif

Dernière modification par Papy7584 (01-01-2019 18:41:50)


If you're going through hell, keep going (Winston Churchill)
Vivez comme si vous deviez mourir demain, apprenez comme si vous deviez vivre toujours (Bouddha)
A winner is a dreamer who never gives up (Nelson Mandela)
Logic will get you from A to Z ; Imagination will get you everywhere (Albert Einstein)

Hors ligne

#24 01-01-2019 18:39:59

Papy7584
Membre
Lieu : 75, 84 et Flandres belges...
Distrib. : Debian Buster (4.19.67-2)
Noyau : Linux 4.19.0-6-amd64
(G)UI : default - GNOME
Inscription : 24-12-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Bon,
J'ai fait une nouvelle tentative...
1) supprimer l'option de démarrage rapide sous Windows (j'ai peur qu'il ne s'éteint pas totalement sinon..)
2) suppression de l'entrée "réapparue" (entrée Windows qui pointe sur grub)
3) pour "être sur": réinstallation de grub
avec un efibootmgr -v, avant et après chaque étape..... mad


1) prise de trace par efibootmgr -v

efibootmgr -v


BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0001,0000,2001,2002,2003
Boot0000* Windows Boot Manager  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* debian  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)
Boot0002* Windows Boot Manager  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot2001* EFI USB Device  RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC



2) supprimer entrée Windows "de trop"

efibootmgr -b 0002 -B


BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0001,0000,2001,2002,2003
Boot0000* Windows Boot Manager
Boot0001* debian
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network



3) prise de trace par efibootmgr -v

efibootmgr -v


BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0001,0000,2001,2002,2003
Boot0000* Windows Boot Manager  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* debian  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)
Boot2001* EFI USB Device  RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC


4) réinstall de grub

grub-install


Installation pour la plate-forme x86_64-efi.
Installation terminée, sans erreur.


5) prise de trace par efibootmgr -v

efibootmgr -v


BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0001,0000,2001,2002,2003
Boot0000* Windows Boot Manager  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* debian  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)
Boot2001* EFI USB Device  RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC



Après reboot debian, je garde une entrée Windows + 1 entrée Debian:

refibootmgr -v


BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000,2001,2002,2003
Boot0000* Windows Boot Manager  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* debian  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)
Boot2001* EFI USB Device  RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC




Papy7584old_geek.gif

Dernière modification par Papy7584 (01-01-2019 18:47:33)


If you're going through hell, keep going (Winston Churchill)
Vivez comme si vous deviez mourir demain, apprenez comme si vous deviez vivre toujours (Bouddha)
A winner is a dreamer who never gives up (Nelson Mandela)
Logic will get you from A to Z ; Imagination will get you everywhere (Albert Einstein)

Hors ligne

#25 01-01-2019 18:59:23

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Resolu] Dual-boot Windows-Debian démarre systématiquement sur Windows

Papy7584 a écrit :

BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0001,0000,2001,2002,2003
Boot0000* Windows Boot Manager  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* debian  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)
Boot0002* Windows Boot Manager  HD(1,GPT,ccc68363-eed6-4f52-b483-41c761ff8935,0x800,0x32000)/File(\EFI\debian\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot2001* EFI USB Device  RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC
 


Cela donne effectivement l'impression que UEFI affiche l'entrée "debian" (le deuxième boot dans UEFI et dans bootorder), comme une entrée "Windows Boot Manager", et que cela donne du coup l'impression que j'aie 3 boots Windows. Cela expliquerait peut-être aussi pourquoi l'affichage du 2ième Windows dans UEFI est différent: pas suivi d'un code (code disque?).

Oui, il le montre comme Windows Boot Manager.

Papy7584 a écrit :

dans ce cas:
- Boot0000: le boot Windows qui pointe sur bootmgfw.efi est normal
- Boot0001: le boot debian qui pointe grubx64.efi également, avec un "bug" dans UEFI, affiché comme Windows au lieu de debian (supposons)
- Boot0002: par contre, je ne comprends pas d'où vient ce boot Windows qui pointe sur grubx64.efi....
car j'avais bien effacé celui-ci.... !?!?! (voir traces dans un de mes messages précédents)  https://debian-facile.org/img/smilies/x … chhead.gif
- A la limite, je peux comprendre que "quelque chose" rajoute à nouveau une entrée boot Windows (tel qu'empanada le mentionnait comme hypothèse),


Oui, il semble que "quelque chose" a rajouté à nouveau cette entrée ( Boot0002) sur le firmware et en plus il l'a mis comme entrée par défaut. J'ai déjà rencontré ces événements "genre sorcière ":lol: liés aux Windows.

Papy7584 a écrit :

mais dans ce cas, elle pointerait sur bootmgfw.efi, pas sur grubx64.efi??

Oui, ça a du sens...mais rappelle que t'avais exécuté, sur Windows, la commande

bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi

et selon mon expérience, quand ces événements étranges arrivent, seulement certaines commandes exécutées dès Windows (donc avec bcdedit) restent . Il parait que Windows (ou des autres logiciels tiers), "protègent" leurs entrées sur le firmware à tout prix, sauf si supprimés explicitement dès Windows, et cette entrée {bootmgr} tu l'avais viré dès debian avec efibootmgr. Tu peux essayer à faire exactement le même mais dès Windows avec bcdedit. Peut être aussi Windows ait besoin d'une entrée {bootmgr}, donc...peut être le plus sage peut être de la laisser (en modifiant son chemin *efi pour qu'elle pointe vers le *.efi Windows), virer l'entrée 0000, et en dernier, marquer la 0001 (debian), comme entrée par défaut, mais tout ça fait dès Window avec bcdedit. Il faudrait quelqu'un qui maîtrise Windows pour nous expliquer vraiment comment et pourquoi cette entrée revient d'entre les morts comme par sorcellerie.
Donc, en résumé, ça pourrait être (rappelle que tout ça n'est pas du tout nécessaire puisque maintenant tout marche comme tu veux (démarrage grub en premier)!!. Ça n'est que pour le plaisir d'apprendre). Comme dit dans messages antérieurs, exécuter bcdedit dès un invite des commandes cmd.exe avec bouton droit sur l'icone cmd.exe --> "Exécuter comme administrateur":
1) Établir à nouveau le chemin correct pour le fichier *.efi de l'entrée EFI {bootmgr} ("Windows Boot Manager")

bcdedit /set {bootmgr} path \EFI\Microsoft\Boot\bootmgfw.efi


2) Supprimer l'entrée {4fdd297f-0b88-11e9-b831-806e6f6e6963}

bcdedit /delete {4fdd297f-0b88-11e9-b831-806e6f6e6963}


3) Activer debian comme entrée par défaut

bcdedit /set {fwbootmgr} displayorder {2a9bec83-0b87-11e9-b830-806e6f6e6963} /addfirst



Papy7584 a écrit :

Je sens que je vais tout réinstaller - mais non, JE RIGOLE... !! lol

  JAMAIS lol


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

Pied de page des forums