Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-01-2019 21:08:10

cemoi
Membre
Distrib. : Debian 10 Buster et une SID
Noyau : Linux 4.19.0-9-amd64
(G)UI : XFCE
Inscription : 21-10-2008

installation brother DCP-9020CDW

Hello,
j'ai une brother dcp-9020cdw que je me sers via la wifi. Je l'ai déja installé sur une debian stretch mais là ça ne passe pas...

# bash linux-brprinter-installer-2.2.1-1 DCP-9020CDW



You are going to install following packages.
   dcp9020cdwlpr-1.1.2-1.i386.deb
   dcp9020cdwcupswrapper-1.1.4-0.i386.deb
   brscan4-0.4.6-1.amd64.deb
   brscan-skey-0.2.4-1.amd64.deb
OK? [y/N] ->y

Atteint:1 http://security.debian.org stretch/updates InRelease
Ign:2 http://deb.debian.org/debian stretch InRelease                  
Ign:3 http://download.videolan.org/pub/debian/stable  InRelease      
Atteint:4 http://deb.debian.org/debian stretch-updates InRelease                                
Atteint:5 http://download.videolan.org/pub/debian/stable  Release                                
Atteint:6 http://deb.debian.org/debian stretch-backports InRelease
Atteint:7 http://deb.debian.org/debian stretch Release        
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Aucune version du paquet ia32-libs n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  lib32z1 lib32ncurses5

E: Le paquet « ia32-libs » n'a pas de version susceptible d'être installée
dpkg -x dcp9020cdwlpr-1.1.2-1.i386.deb /
dpkg -x dcp9020cdwcupswrapper-1.1.4-0.i386.deb /
dpkg-deb: building package 'dcp9020cdwlpr' in 'dcp9020cdwlpr-1.1.2-1a.i386.deb'.
dpkg -b ./brother_driver_packdir dcp9020cdwlpr-1.1.2-1a.i386.deb
dpkg-deb: building package 'dcp9020cdwcupswrapper' in 'dcp9020cdwcupswrapper-1.1.4-0a.i386.deb'.
dpkg -b ./brother_driver_packdir dcp9020cdwcupswrapper-1.1.4-0a.i386.deb
dpkg -i --force-all dcp9020cdwlpr-1.1.2-1a.i386.deb
Sélection du paquet dcp9020cdwlpr:i386 précédemment désélectionné.
(Lecture de la base de données... 219301 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de dcp9020cdwlpr-1.1.2-1a.i386.deb ...
Dépaquetage de dcp9020cdwlpr:i386 (1.1.2-1) ...
Paramétrage de dcp9020cdwlpr:i386 (1.1.2-1) ...
mkdir: impossible de créer le répertoire « /var/spool/lpd/dcp9020cdw »: Aucun fichier ou dossier de ce type
chown: impossible d'accéder à '/var/spool/lpd/dcp9020cdw': Aucun fichier ou dossier de ce type
chgrp: impossible d'accéder à '/var/spool/lpd/dcp9020cdw': Aucun fichier ou dossier de ce type
chmod: impossible d'accéder à '/var/spool/lpd/dcp9020cdw': Aucun fichier ou dossier de ce type
dpkg -i --force-all dcp9020cdwcupswrapper-1.1.4-0a.i386.deb
Sélection du paquet dcp9020cdwcupswrapper:i386 précédemment désélectionné.
(Lecture de la base de données... 219333 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de dcp9020cdwcupswrapper-1.1.4-0a.i386.deb ...
Dépaquetage de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
Paramétrage de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
lpinfo: Mauvais descripteur de fichier
lpadmin -p DCP9020CDW -E -v usb://dev/usb/lp0 -P /usr/share/cups/model/Brother/brother_dcp9020cdw_printer_en.ppd
lpadmin: Unable to connect to server: Mauvais descripteur de fichier
###############################ls: impossible d'accéder à '/usr/share/ppd/*.ppd': Aucun fichier ou dossier de ce type
ls: impossible d'accéder à '/usr/share/cups/model/*.ppd': Aucun fichier ou dossier de ce type
#
lpinfo: Mauvais descripteur de fichier

0 (I): Specify IP address.
1 (A): Auto. (usb://dev/usblp0)

select the number of destination Device URI. ->
 



il propose de faire un test d'impression et il me sort toujours lpinfo: Mauvais descripteur de fichier et rien ne sort...

Du coup je séche...

le driver vient du site de chez brother c'est un *.deb il se trouve là:
https://support.brother.com/g/b/downloa … &type3=625


Linux debDesk Linux 4.19.0-9-amd64

Hors ligne

#2 10-01-2019 23:32:49

pas-si-facile
Membre
Lieu : Paris
Distrib. : Debian 9 stable
Noyau : Linux 4.9.0-8-amd64
(G)UI : Xfce
Inscription : 09-01-2019
Site Web

Re : installation brother DCP-9020CDW

Salut,

Tu as esayé juste avec gutenprint ?

Je viens de configurer une Brother-MFC de cette façon :

- installation de printer-driver-gutenprint
- installation de system-config-printer

Lancement de system-config-printer -> imprimante réseau -> pilotes recommandés -> OK smile

Hors ligne

#3 11-01-2019 06:44:37

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : installation brother DCP-9020CDW

Bonjour,

Cependant les paquets suivants le remplacent :
  lib32z1 lib32ncurses5


Du coup tu as installé ces deux paquets ?

Il y a un wiki pour brother https://debian-facile.org/utilisateurs: … er-brother

Hors ligne

#4 11-01-2019 08:47:37

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : stretch Xfce et DFLinux
Noyau : Linux 4.18.0-0.bpo.3-rt-amd64
(G)UI : ??
Inscription : 11-02-2012

Re : installation brother DCP-9020CDW

@cemoi
Bonjour.
J'ai moi aussi une imprimante Brother (hl3040 cn) pénible à installer suivant les OS.
je m'en sors souvent avec le script de démonipuch....alors.
https://forum.ubuntu-fr.org/viewtopic.php?id=652931

N'achetez pas Windows !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#5 11-01-2019 08:55:08

phreg
Membre
Distrib. : MX Ubuntu LMDE Manjaro
Noyau : 4.9 à 4.20
(G)UI : Xfce Mate
Inscription : 02-04-2011

Re : installation brother DCP-9020CDW

Bonjour,
tu as essayé l'installation avec le script (énorme) qui fait rpm et deb et est sensé tout downloader et installer (wget et dpkg). Personnellement, je n'ai pas envie de débuger  les 140 kB du script big_smile .
Depuis la même page (https://support.brother.com/g/b/downloa … pe-566_0_1), tu peux aussi downloader puis installer toi même les drivers imprimante et scanner.

Hors ligne

#6 12-01-2019 12:10:34

cemoi
Membre
Distrib. : Debian 10 Buster et une SID
Noyau : Linux 4.19.0-9-amd64
(G)UI : XFCE
Inscription : 21-10-2008

Re : installation brother DCP-9020CDW

j'ai retenté l'installation à partir du meme fichier mais j'ai installé les deux paquet que chalu a relevé dans le log: ça fait la même erreure:

bash linux-brprinter-installer-2.2.1-1 DCP-9020CDW




You are going to install following packages.
   dcp9020cdwlpr-1.1.2-1.i386.deb
   dcp9020cdwcupswrapper-1.1.4-0.i386.deb
   brscan4-0.4.6-1.amd64.deb
   brscan-skey-0.2.4-1.amd64.deb

OK? [y/N] ->y

Atteint:1 http://security.debian.org stretch/updates InRelease
Ign:2 http://deb.debian.org/debian stretch InRelease                  
Atteint:3 http://deb.debian.org/debian stretch-updates InRelease                                
Ign:4 http://download.videolan.org/pub/debian/stable  InRelease                                  
Atteint:5 http://deb.debian.org/debian stretch-backports InRelease                              
Atteint:6 http://deb.debian.org/debian stretch Release                                          
Atteint:7 http://download.videolan.org/pub/debian/stable  Release    
Lecture des listes de paquets... Fait                          
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Aucune version du paquet ia32-libs n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  lib32z1 lib32ncurses5

E: Le paquet « ia32-libs » n'a pas de version susceptible d'être installée
dpkg -x dcp9020cdwlpr-1.1.2-1.i386.deb /
dpkg -x dcp9020cdwcupswrapper-1.1.4-0.i386.deb /
dpkg-deb: building package 'dcp9020cdwlpr' in 'dcp9020cdwlpr-1.1.2-1a.i386.deb'.
dpkg -b ./brother_driver_packdir dcp9020cdwlpr-1.1.2-1a.i386.deb
dpkg-deb: building package 'dcp9020cdwcupswrapper' in 'dcp9020cdwcupswrapper-1.1.4-0a.i386.deb'.
dpkg -b ./brother_driver_packdir dcp9020cdwcupswrapper-1.1.4-0a.i386.deb
dpkg -i --force-all dcp9020cdwlpr-1.1.2-1a.i386.deb
Sélection du paquet dcp9020cdwlpr:i386 précédemment désélectionné.
(Lecture de la base de données... 219325 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de dcp9020cdwlpr-1.1.2-1a.i386.deb ...
Dépaquetage de dcp9020cdwlpr:i386 (1.1.2-1) ...
Paramétrage de dcp9020cdwlpr:i386 (1.1.2-1) ...
mkdir: impossible de créer le répertoire « /var/spool/lpd/dcp9020cdw »: Aucun fichier ou dossier de ce type
chown: impossible d'accéder à '/var/spool/lpd/dcp9020cdw': Aucun fichier ou dossier de ce type
chgrp: impossible d'accéder à '/var/spool/lpd/dcp9020cdw': Aucun fichier ou dossier de ce type
chmod: impossible d'accéder à '/var/spool/lpd/dcp9020cdw': Aucun fichier ou dossier de ce type
dpkg -i --force-all dcp9020cdwcupswrapper-1.1.4-0a.i386.deb
Sélection du paquet dcp9020cdwcupswrapper:i386 précédemment désélectionné.
(Lecture de la base de données... 219357 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de dcp9020cdwcupswrapper-1.1.4-0a.i386.deb ...
Dépaquetage de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
Paramétrage de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
lpinfo: Mauvais descripteur de fichier
lpadmin -p DCP9020CDW -E -v usb://dev/usb/lp0 -P /usr/share/cups/model/Brother/brother_dcp9020cdw_printer_en.ppd
lpadmin: Unable to connect to server: Mauvais descripteur de fichier
###############################ls: impossible d'accéder à '/usr/share/ppd/*.ppd': Aucun fichier ou dossier de ce type
ls: impossible d'accéder à '/usr/share/cups/model/*.ppd': Aucun fichier ou dossier de ce type
#
lpinfo: Mauvais descripteur de fichier

0 (I): Specify IP address.
1 (A): Auto. (usb://dev/usblp0)

select the number of destination Device URI. ->

enter IP address ->192.168.0.14
lpadmin -p DCP9020CDW -v socket://192.168.0.14 -E
lpadmin: Unable to connect to server: Mauvais descripteur de fichier
Test Print? [y/N] ->

 



bien sur rien ne s'imprime quand je lance la page de test et apres ça passe à l'installation des drivers pour le scan.

Bizzare vu que j'ai bien installé les paquets cité:

apt install    lib32z1 lib32ncurses5



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
The following additional packages will be installed:
  lib32tinfo5
Les NOUVEAUX paquets suivants seront installés :
  lib32ncurses5 lib32tinfo5 lib32z1
0 mis à jour, 3 nouvellement installés, 0 à enlever et 0 non mis à jour.
 



bref je vais faire le menage et je vais tenter directement avec les fichiers d'installation des drivers comme  phreg le propose.

Je ferai un retour si j'arrive à qq chose...

EDIT:

Je viens de voir cette page:
https://support.brother.com/g/s/id/linu … ect=on#004

qui indique:

a32-libs or lib32stdc++ is required to be installed.



sauf que a32-libs ne peut etre installé elle est remplacée par un autre paquet:

apt install ia32-libs

 


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Aucune version du paquet ia32-libs n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  lib32z1 lib32ncurses5

E: Le paquet « ia32-libs » n'a pas de version susceptible d'être installée



du coup je tente l'installation de lib32stdc++ et surprise:

apt install lib32stdc++



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Note : sélection de lib32stdc++6-mips64el-cross pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.9-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++-6-dev-ppc64-cross pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-6-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6 pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.7-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.5-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-mips64-dcv1 pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-mips64-cross pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.3-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.1-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-6-dbg-mips64-cross pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++-6-dev-sparc64-cross pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-s390x-cross pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-ppc64-dcv1 pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-ppc64-cross pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-sparc64-cross pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++-6-dev-mips64-cross pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++-6-dev pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.8-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-5-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.6-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-sparc64-dcv1 pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.4-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-6-dbg-s390x-cross pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-6-dbg-ppc64-cross pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.2-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++-6-dev-mips64el-cross pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.0-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-s390x-dcv1 pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++-6-dev-s390x-cross pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-mips64el-dcv1 pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-6-dbg-mips64el-cross pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-6-dbg-sparc64-cross pour l'expression rationnelle « lib32stdc+ »
Note : sélection de « lib32stdc++6-mips64el-cross » au lieu de « lib32stdc++6-mips64el-dcv1 »
Note : sélection de « lib32stdc++6-s390x-cross » au lieu de « lib32stdc++6-s390x-dcv1 »
Note : sélection de « lib32stdc++6-mips64-cross » au lieu de « lib32stdc++6-mips64-dcv1 »
Note : sélection de « lib32stdc++6-ppc64-cross » au lieu de « lib32stdc++6-ppc64-dcv1 »
Note : sélection de « lib32stdc++6-sparc64-cross » au lieu de « lib32stdc++6-sparc64-dcv1 »
lib32stdc++6 is already the newest version (6.3.0-18+deb9u1).
The following additional packages will be installed:
  gcc-6-cross-base gcc-6-cross-base-ports lib32asan3 lib32asan3-ppc64-cross lib32asan3-sparc64-cross lib32atomic1
  lib32atomic1-mips64-cross lib32atomic1-mips64el-cross lib32atomic1-ppc64-cross lib32atomic1-s390x-cross lib32atomic1-sparc64-cross
  lib32cilkrts5 lib32gcc-6-dev lib32gcc-6-dev-mips64-cross lib32gcc-6-dev-mips64el-cross lib32gcc-6-dev-ppc64-cross
  lib32gcc-6-dev-s390x-cross lib32gcc-6-dev-sparc64-cross lib32gcc1-dbg lib32gcc1-mips64-cross lib32gcc1-mips64el-cross
  lib32gcc1-ppc64-cross lib32gcc1-s390x-cross lib32gcc1-sparc64-cross lib32gomp1 lib32gomp1-mips64-cross lib32gomp1-mips64el-cross
  lib32gomp1-ppc64-cross lib32gomp1-s390x-cross lib32gomp1-sparc64-cross lib32itm1 lib32itm1-ppc64-cross lib32itm1-s390x-cross
  lib32itm1-sparc64-cross lib32mpx2 lib32quadmath0 lib32ubsan0 lib32ubsan0-ppc64-cross lib32ubsan0-sparc64-cross libasan3-ppc64-cross
  libasan3-sparc64-cross libatomic1-mips64-cross libatomic1-mips64el-cross libatomic1-ppc64-cross libatomic1-s390x-cross
  libatomic1-sparc64-cross libc6-dev-mips64-cross libc6-dev-mips64el-cross libc6-dev-ppc64-cross libc6-dev-s390x-cross
  libc6-dev-sparc64-cross libc6-mips32-mips64-cross libc6-mips32-mips64el-cross libc6-mips64-cross libc6-mips64el-cross
  libc6-mipsn32-mips64-cross libc6-mipsn32-mips64el-cross libc6-powerpc-ppc64-cross libc6-ppc64-cross libc6-s390-s390x-cross
  libc6-s390x-cross libc6-sparc-sparc64-cross libc6-sparc64-cross libc6-x32 libgcc-6-dev-mips64-cross libgcc-6-dev-mips64el-cross
  libgcc-6-dev-ppc64-cross libgcc-6-dev-s390x-cross libgcc-6-dev-sparc64-cross libgcc1-mips64-cross libgcc1-mips64el-cross
  libgcc1-ppc64-cross libgcc1-s390x-cross libgcc1-sparc64-cross libgomp1-mips64-cross libgomp1-mips64el-cross libgomp1-ppc64-cross
  libgomp1-s390x-cross libgomp1-sparc64-cross libitm1-ppc64-cross libitm1-s390x-cross libitm1-sparc64-cross libn32atomic1-mips64-cross
  libn32atomic1-mips64el-cross libn32gcc1-mips64-cross libn32gcc1-mips64el-cross libn32gomp1-mips64-cross libn32gomp1-mips64el-cross
  libstdc++-6-dev libstdc++-6-dev-mips64-cross libstdc++-6-dev-mips64el-cross libstdc++-6-dev-ppc64-cross libstdc++-6-dev-s390x-cross
  libstdc++-6-dev-sparc64-cross libstdc++6-mips64-cross libstdc++6-mips64el-cross libstdc++6-ppc64-cross libstdc++6-s390x-cross
  libstdc++6-sparc64-cross libubsan0-ppc64-cross libubsan0-sparc64-cross libx32asan3 libx32atomic1 libx32cilkrts5 libx32gcc1 libx32gomp1
  libx32itm1 libx32quadmath0 libx32stdc++6 libx32ubsan0 linux-libc-dev-mips64-cross linux-libc-dev-mips64el-cross
  linux-libc-dev-ppc64-cross linux-libc-dev-s390x-cross linux-libc-dev-sparc64-cross
Paquets suggérés :
  libstdc++-6-doc
Les NOUVEAUX paquets suivants seront installés :
  gcc-6-cross-base gcc-6-cross-base-ports lib32asan3 lib32asan3-ppc64-cross lib32asan3-sparc64-cross lib32atomic1
  lib32atomic1-mips64-cross lib32atomic1-mips64el-cross lib32atomic1-ppc64-cross lib32atomic1-s390x-cross lib32atomic1-sparc64-cross
  lib32cilkrts5 lib32gcc-6-dev lib32gcc-6-dev-mips64-cross lib32gcc-6-dev-mips64el-cross lib32gcc-6-dev-ppc64-cross
  lib32gcc-6-dev-s390x-cross lib32gcc-6-dev-sparc64-cross lib32gcc1-dbg lib32gcc1-mips64-cross lib32gcc1-mips64el-cross
  lib32gcc1-ppc64-cross lib32gcc1-s390x-cross lib32gcc1-sparc64-cross lib32gomp1 lib32gomp1-mips64-cross lib32gomp1-mips64el-cross
  lib32gomp1-ppc64-cross lib32gomp1-s390x-cross lib32gomp1-sparc64-cross lib32itm1 lib32itm1-ppc64-cross lib32itm1-s390x-cross
  lib32itm1-sparc64-cross lib32mpx2 lib32quadmath0 lib32stdc++-6-dev lib32stdc++-6-dev-mips64-cross lib32stdc++-6-dev-mips64el-cross
  lib32stdc++-6-dev-ppc64-cross lib32stdc++-6-dev-s390x-cross lib32stdc++-6-dev-sparc64-cross lib32stdc++6-6-dbg lib32stdc++6-mips64-cross
  lib32stdc++6-mips64el-cross lib32stdc++6-ppc64-cross lib32stdc++6-s390x-cross lib32stdc++6-sparc64-cross lib32ubsan0
  lib32ubsan0-ppc64-cross lib32ubsan0-sparc64-cross libasan3-ppc64-cross libasan3-sparc64-cross libatomic1-mips64-cross
  libatomic1-mips64el-cross libatomic1-ppc64-cross libatomic1-s390x-cross libatomic1-sparc64-cross libc6-dev-mips64-cross
  libc6-dev-mips64el-cross libc6-dev-ppc64-cross libc6-dev-s390x-cross libc6-dev-sparc64-cross libc6-mips32-mips64-cross
  libc6-mips32-mips64el-cross libc6-mips64-cross libc6-mips64el-cross libc6-mipsn32-mips64-cross libc6-mipsn32-mips64el-cross
  libc6-powerpc-ppc64-cross libc6-ppc64-cross libc6-s390-s390x-cross libc6-s390x-cross libc6-sparc-sparc64-cross libc6-sparc64-cross
  libc6-x32 libgcc-6-dev-mips64-cross libgcc-6-dev-mips64el-cross libgcc-6-dev-ppc64-cross libgcc-6-dev-s390x-cross
  libgcc-6-dev-sparc64-cross libgcc1-mips64-cross libgcc1-mips64el-cross libgcc1-ppc64-cross libgcc1-s390x-cross libgcc1-sparc64-cross
  libgomp1-mips64-cross libgomp1-mips64el-cross libgomp1-ppc64-cross libgomp1-s390x-cross libgomp1-sparc64-cross libitm1-ppc64-cross
  libitm1-s390x-cross libitm1-sparc64-cross libn32atomic1-mips64-cross libn32atomic1-mips64el-cross libn32gcc1-mips64-cross
  libn32gcc1-mips64el-cross libn32gomp1-mips64-cross libn32gomp1-mips64el-cross libstdc++-6-dev libstdc++-6-dev-mips64-cross
  libstdc++-6-dev-mips64el-cross libstdc++-6-dev-ppc64-cross libstdc++-6-dev-s390x-cross libstdc++-6-dev-sparc64-cross
  libstdc++6-mips64-cross libstdc++6-mips64el-cross libstdc++6-ppc64-cross libstdc++6-s390x-cross libstdc++6-sparc64-cross
  libubsan0-ppc64-cross libubsan0-sparc64-cross libx32asan3 libx32atomic1 libx32cilkrts5 libx32gcc1 libx32gomp1 libx32itm1 libx32quadmath0
  libx32stdc++6 libx32ubsan0 linux-libc-dev-mips64-cross linux-libc-dev-mips64el-cross linux-libc-dev-ppc64-cross
  linux-libc-dev-s390x-cross linux-libc-dev-sparc64-cross
0 mis à jour, 127 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 69,0 Mo dans les archives.
Après cette opération, 300 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
 



o_O ...

Dernière modification par cemoi (12-01-2019 12:30:19)


Linux debDesk Linux 4.19.0-9-amd64

Hors ligne

#7 13-01-2019 12:08:42

èfpé
Membre
Inscription : 10-07-2016

Re : installation brother DCP-9020CDW

Salut cemoi,

bash linux-brprinter-installer-2.2.1-1 DCP-9020CDW

mkdir: impossible de créer le répertoire « /var/spool/lpd/dcp9020cdw »: Aucun fichier ou dossier de ce type
chown: impossible d'accéder à '/var/spool/lpd/dcp9020cdw': Aucun fichier ou dossier de ce type
chgrp: impossible d'accéder à '/var/spool/lpd/dcp9020cdw': Aucun fichier ou dossier de ce type
chmod: impossible d'accéder à '/var/spool/lpd/dcp9020cdw': Aucun fichier ou dossier de ce type


Ce problème en particulier est facilement reproductible. Il est résolu par l'installation du paquet lpr :

bash linux-brprinter-installer-2.2.1-1 DCP-9020CDW

You are going to install following packages.
   dcp9020cdwlpr-1.1.2-1.i386.deb
   dcp9020cdwcupswrapper-1.1.4-0.i386.deb
   brscan4-0.4.6-1.amd64.deb
   brscan-skey-0.2.4-1.amd64.deb
OK? [y/N] ->y


=========================================
Brother License Agreement

...
=========================================
Do you agree? [Y/n] ->y

wget -T 10 -nd --no-cache http://www.brother.com/pub/bsc/linux/packages/dcp9020cdwlpr-1.1.2-1.i386.deb
--2019-01-12 14:54:00--  http://www.brother.com/pub/bsc/linux/packages/dcp9020cdwlpr-1.1.2-1.i386.deb
Résolution de www.brother.com (www.brother.com)… 95.100.252.8, 95.100.252.35
Connexion à www.brother.com (www.brother.com)|95.100.252.8|:80… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 694570 (678K) [text/plain]
Sauvegarde en : « dcp9020cdwlpr-1.1.2-1.i386.deb »

dcp9020cdwlpr-1.1.2-1.i386.deb     100%[===============================>] 678,29K   794KB/s    in 0,9s

2019-01-12 14:54:01 (794 KB/s) — « dcp9020cdwlpr-1.1.2-1.i386.deb » sauvegardé [694570/694570]


=========================================
GPL License Agreement

...
=========================================

Do you agree? [Y/n] ->y

wget -T 10 -nd --no-cache http://www.brother.com/pub/bsc/linux/packages/dcp9020cdwcupswrapper-1.1.4-0.i386.deb
--2019-01-12 14:55:00--  http://www.brother.com/pub/bsc/linux/packages/dcp9020cdwcupswrapper-1.1.4-0.i386.deb
Résolution de www.brother.com (www.brother.com)… 95.100.252.35, 95.100.252.8
Connexion à www.brother.com (www.brother.com)|95.100.252.35|:80… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 13658 (13K) [text/plain]
Sauvegarde en : « dcp9020cdwcupswrapper-1.1.4-0.i386.deb »

dcp9020cdwcupswrapper-1.1.4-0.i386 100%[======================================>]  13,34K  --.-KB/s    in 0,02s

2019-01-12 14:55:00 (887 KB/s) — « dcp9020cdwcupswrapper-1.1.4-0.i386.deb » sauvegardé [13658/13658]

Ign:1 http://deb.debian.org/debian stretch InRelease
Atteint:2 http://deb.debian.org/debian stretch Release
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Aucune version du paquet ia32-libs n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  lib32z1 lib32ncurses5

E: Le paquet « ia32-libs » n'a pas de version susceptible d'être installée
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
The following additional packages will be installed:
  lib32gcc1 libc6-i386
Les NOUVEAUX paquets suivants seront installés :
  lib32gcc1 lib32stdc++6 libc6-i386
0 mis à jour, 3 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 3 056 ko dans les archives.
Après cette opération, 13,6 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://deb.debian.org/debian stretch/main amd64 libc6-i386 amd64 2.24-11+deb9u3 [2 597 kB]
Réception de:2 http://deb.debian.org/debian stretch/main amd64 lib32gcc1 amd64 1:6.3.0-18+deb9u1 [47,8 kB]
Réception de:3 http://deb.debian.org/debian stretch/main amd64 lib32stdc++6 amd64 6.3.0-18+deb9u1 [411 kB]
3 056 ko réceptionnés en 4s (756 ko/s)
Sélection du paquet libc6-i386 précédemment désélectionné.
(Lecture de la base de données... 177040 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libc6-i386_2.24-11+deb9u3_amd64.deb ...
Dépaquetage de libc6-i386 (2.24-11+deb9u3) ...
Sélection du paquet lib32gcc1 précédemment désélectionné.
Préparation du dépaquetage de .../lib32gcc1_1%3a6.3.0-18+deb9u1_amd64.deb ...
Dépaquetage de lib32gcc1 (1:6.3.0-18+deb9u1) ...
Sélection du paquet lib32stdc++6 précédemment désélectionné.
Préparation du dépaquetage de .../lib32stdc++6_6.3.0-18+deb9u1_amd64.deb ...
Dépaquetage de lib32stdc++6 (6.3.0-18+deb9u1) ...
Paramétrage de libc6-i386 (2.24-11+deb9u3) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u3) ...
Paramétrage de lib32gcc1 (1:6.3.0-18+deb9u1) ...
Paramétrage de lib32stdc++6 (6.3.0-18+deb9u1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u3) ...
dpkg -x dcp9020cdwlpr-1.1.2-1.i386.deb /
dpkg -x dcp9020cdwcupswrapper-1.1.4-0.i386.deb /
dpkg-deb: building package 'dcp9020cdwlpr' in 'dcp9020cdwlpr-1.1.2-1a.i386.deb'.
dpkg -b ./brother_driver_packdir dcp9020cdwlpr-1.1.2-1a.i386.deb
dpkg-deb: building package 'dcp9020cdwcupswrapper' in 'dcp9020cdwcupswrapper-1.1.4-0a.i386.deb'.
dpkg -b ./brother_driver_packdir dcp9020cdwcupswrapper-1.1.4-0a.i386.deb
dpkg -i --force-all dcp9020cdwlpr-1.1.2-1a.i386.deb
Sélection du paquet dcp9020cdwlpr:i386 précédemment désélectionné.
(Lecture de la base de données... 177354 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de dcp9020cdwlpr-1.1.2-1a.i386.deb ...
Dépaquetage de dcp9020cdwlpr:i386 (1.1.2-1) ...
Paramétrage de dcp9020cdwlpr:i386 (1.1.2-1) ...
dpkg -i --force-all dcp9020cdwcupswrapper-1.1.4-0a.i386.deb
Sélection du paquet dcp9020cdwcupswrapper:i386 précédemment désélectionné.
(Lecture de la base de données... 177386 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de dcp9020cdwcupswrapper-1.1.4-0a.i386.deb ...
Dépaquetage de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
Paramétrage de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
Stopping printer spooler: lpd.
Restarting cups (via systemctl): cups.service.
lpadmin -p DCP9020CDW -E -v usb://dev/usb/lp0 -P /usr/share/cups/model/Brother/brother_dcp9020cdw_printer_en.ppd
#
Will you specify the Device URI? [Y/n] ->n

Test Print? [y/N] ->n

You are going to install following packages.
   brscan4-0.4.6-1.amd64.deb

=========================================
Brother License Agreement

...
=========================================
Do you agree? [Y/n] ->y

wget -T 10 -nd --no-cache http://www.brother.com/pub/bsc/linux/packages/brscan4-0.4.6-1.amd64.deb
--2019-01-12 14:56:59--  http://www.brother.com/pub/bsc/linux/packages/brscan4-0.4.6-1.amd64.deb
Résolution de www.brother.com (www.brother.com)… 95.100.252.8, 95.100.252.35
Connexion à www.brother.com (www.brother.com)|95.100.252.8|:80… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 87658 (86K) [text/plain]
Sauvegarde en : « brscan4-0.4.6-1.amd64.deb »

brscan4-0.4.6-1.amd64.deb          100%[==========================>]  85,60K  --.-KB/s    in 0,1s

2019-01-12 14:57:00 (808 KB/s) — « brscan4-0.4.6-1.amd64.deb » sauvegardé [87658/87658]

dpkg -i --force-all brscan4-0.4.6-1.amd64.deb
Sélection du paquet brscan4 précédemment désélectionné.
(Lecture de la base de données... 177390 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de brscan4-0.4.6-1.amd64.deb ...
Dépaquetage de brscan4 (0.4.6-1) ...
Paramétrage de brscan4 (0.4.6-1) ...
This software is based in part on the work of the Independent JPEG Group.
You are going to install following packages.
   brscan-skey-0.2.4-1.amd64.deb

=========================================
Brother License Agreement

...
=========================================
Do you agree? [Y/n] ->y

wget -T 10 -nd --no-cache http://www.brother.com/pub/bsc/linux/packages/brscan-skey-0.2.4-1.amd64.deb
--2019-01-12 14:58:00--  http://www.brother.com/pub/bsc/linux/packages/brscan-skey-0.2.4-1.amd64.deb
Résolution de www.brother.com (www.brother.com)… 95.100.252.35, 95.100.252.8
Connexion à www.brother.com (www.brother.com)|95.100.252.35|:80… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 50852 (50K) [text/plain]
Sauvegarde en : « brscan-skey-0.2.4-1.amd64.deb »

brscan-skey-0.2.4-1.amd64.deb      100%[=============================>]  49,66K  --.-KB/s    in 0,06s

2019-01-12 14:58:00 (814 KB/s) — « brscan-skey-0.2.4-1.amd64.deb » sauvegardé [50852/50852]

dpkg -i --force-all brscan-skey-0.2.4-1.amd64.deb
Sélection du paquet brscan-skey précédemment désélectionné.
(Lecture de la base de données... 177436 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de brscan-skey-0.2.4-1.amd64.deb ...
Dépaquetage de brscan-skey (0.2.4-1) ...
Paramétrage de brscan-skey (0.2.4-1) ...
 


Ce rapport montre que l'installation du paquet lib32stdc++6 (et ses dépendances) est bien gérée.

Conditions du test : Live Debian 9.6 Stretch GNOME ; installation manuelle des paquets cups et lpr.

Hors ligne

#8 13-01-2019 18:32:08

cemoi
Membre
Distrib. : Debian 10 Buster et une SID
Noyau : Linux 4.19.0-9-amd64
(G)UI : XFCE
Inscription : 21-10-2008

Re : installation brother DCP-9020CDW

hello,
alors c'est curieux car effectivement je n'avais pas le paquet lpr d'installé mais quand je l'ai installé il a supprimer le paquet cups-bsd...et ses dépendances. du coup apres avoir installé lpr j'ai reinstallé cups qui ne vire pas lpr lui...

j'ai retenté une install via le script de brother et ça me raconte autre chose:



 apt install cups



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
The following additional packages will be installed:
  cups-browsed cups-core-drivers cups-daemon cups-filters
  cups-filters-core-drivers cups-ppdc cups-server-common libcupscgi1
  libcupsmime1 libcupsppdc1 libfontembed1 libgutenprint2 liblouis-data
  liblouis12 liblouisutdml-bin liblouisutdml-data liblouisutdml7 libqpdf17
  poppler-utils printer-driver-gutenprint qpdf
Paquets suggérés :
  cups-bsd foomatic-db-compressed-ppds | foomatic-db printer-driver-hpcups
  hplip cups-pdf smbclient antiword docx2txt gutenprint-locales ooo2dbk
  rtf2xml gutenprint-doc
Les NOUVEAUX paquets suivants seront installés :
  cups cups-browsed cups-core-drivers cups-daemon cups-filters
  cups-filters-core-drivers cups-ppdc cups-server-common libcupscgi1
  libcupsmime1 libcupsppdc1 libfontembed1 libgutenprint2 liblouis-data
  liblouis12 liblouisutdml-bin liblouisutdml-data liblouisutdml7 libqpdf17
  poppler-utils printer-driver-gutenprint qpdf
0 mis à jour, 22 nouvellement installés, 0 à enlever et 15 non mis à jour.
Il est nécessaire de prendre 6 484 ko dans les archives.
Après cette opération, 26,7 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://deb.debian.org/debian stretch/main amd64 libcupsmime1 amd64 2.2.1-8+deb9u2 [117 kB]
Réception de:2 http://deb.debian.org/debian stretch/main amd64 cups-daemon amd64 2.2.1-8+deb9u2 [405 kB]
Réception de:3 http://deb.debian.org/debian stretch/main amd64 libcupscgi1 amd64 2.2.1-8+deb9u2 [131 kB]
Réception de:4 http://deb.debian.org/debian stretch/main amd64 libcupsppdc1 amd64 2.2.1-8+deb9u2 [149 kB]
Réception de:5 http://deb.debian.org/debian stretch/main amd64 libqpdf17 amd64 6.0.0-2 [319 kB]
Réception de:6 http://deb.debian.org/debian stretch/main amd64 poppler-utils amd64 0.48.0-2+deb9u2 [153 kB]
Réception de:7 http://deb.debian.org/debian stretch/main amd64 cups-filters-core-drivers amd64 1.11.6-3 [205 kB]
Réception de:8 http://deb.debian.org/debian stretch/main amd64 cups-core-drivers amd64 2.2.1-8+deb9u2 [131 kB]
Réception de:9 http://deb.debian.org/debian stretch/main amd64 cups-server-common all 2.2.1-8+deb9u2 [579 kB]
Réception de:10 http://deb.debian.org/debian stretch/main amd64 cups-ppdc amd64 2.2.1-8+deb9u2 [131 kB]
Réception de:11 http://deb.debian.org/debian stretch/main amd64 libfontembed1 amd64 1.11.6-3 [96,2 kB]
Réception de:12 http://deb.debian.org/debian stretch/main amd64 cups-filters amd64 1.11.6-3 [520 kB]
Réception de:13 http://deb.debian.org/debian stretch/main amd64 cups amd64 2.2.1-8+deb9u2 [292 kB]
Réception de:14 http://deb.debian.org/debian stretch/main amd64 cups-browsed amd64 1.11.6-3 [150 kB]
Réception de:15 http://deb.debian.org/debian stretch/main amd64 libgutenprint2 amd64 5.2.11-1+b2 [1 053 kB]
Réception de:16 http://deb.debian.org/debian stretch/main amd64 printer-driver-gutenprint amd64 5.2.11-1+b2 [451 kB]
Réception de:17 http://deb.debian.org/debian stretch/main amd64 qpdf amd64 6.0.0-2 [240 kB]
Réception de:18 http://deb.debian.org/debian stretch/main amd64 liblouis-data all 3.0.0-3+deb9u4 [1 136 kB]
Réception de:19 http://deb.debian.org/debian stretch/main amd64 liblouis12 amd64 3.0.0-3+deb9u4 [87,5 kB]
Réception de:20 http://deb.debian.org/debian stretch/main amd64 liblouisutdml-data all 2.6.0-3 [37,8 kB]
Réception de:21 http://deb.debian.org/debian stretch/main amd64 liblouisutdml7 amd64 2.6.0-3+b2 [86,0 kB]
Réception de:22 http://deb.debian.org/debian stretch/main amd64 liblouisutdml-bin amd64 2.6.0-3+b2 [13,8 kB]
6 484 ko réceptionnés en 0s (8 742 ko/s)      
Préconfiguration des paquets...
Sélection du paquet libcupsmime1:amd64 précédemment désélectionné.
(Lecture de la base de données... 219375 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../00-libcupsmime1_2.2.1-8+deb9u2_amd64.deb ...
Dépaquetage de libcupsmime1:amd64 (2.2.1-8+deb9u2) ...
Sélection du paquet cups-daemon précédemment désélectionné.
Préparation du dépaquetage de .../01-cups-daemon_2.2.1-8+deb9u2_amd64.deb ...
Dépaquetage de cups-daemon (2.2.1-8+deb9u2) ...
Sélection du paquet libcupscgi1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../02-libcupscgi1_2.2.1-8+deb9u2_amd64.deb ...
Dépaquetage de libcupscgi1:amd64 (2.2.1-8+deb9u2) ...
Sélection du paquet libcupsppdc1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../03-libcupsppdc1_2.2.1-8+deb9u2_amd64.deb ...
Dépaquetage de libcupsppdc1:amd64 (2.2.1-8+deb9u2) ...
Sélection du paquet libqpdf17:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../04-libqpdf17_6.0.0-2_amd64.deb ...
Dépaquetage de libqpdf17:amd64 (6.0.0-2) ...
Sélection du paquet poppler-utils précédemment désélectionné.
Préparation du dépaquetage de .../05-poppler-utils_0.48.0-2+deb9u2_amd64.deb ...
Dépaquetage de poppler-utils (0.48.0-2+deb9u2) ...
Sélection du paquet cups-filters-core-drivers précédemment désélectionné.
Préparation du dépaquetage de .../06-cups-filters-core-drivers_1.11.6-3_amd64.deb ...
Dépaquetage de cups-filters-core-drivers (1.11.6-3) ...
Sélection du paquet cups-core-drivers précédemment désélectionné.
Préparation du dépaquetage de .../07-cups-core-drivers_2.2.1-8+deb9u2_amd64.deb ...
Dépaquetage de cups-core-drivers (2.2.1-8+deb9u2) ...
Sélection du paquet cups-server-common précédemment désélectionné.
Préparation du dépaquetage de .../08-cups-server-common_2.2.1-8+deb9u2_all.deb ...
Dépaquetage de cups-server-common (2.2.1-8+deb9u2) ...
Sélection du paquet cups-ppdc précédemment désélectionné.
Préparation du dépaquetage de .../09-cups-ppdc_2.2.1-8+deb9u2_amd64.deb ...
Dépaquetage de cups-ppdc (2.2.1-8+deb9u2) ...
Sélection du paquet libfontembed1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../10-libfontembed1_1.11.6-3_amd64.deb ...
Dépaquetage de libfontembed1:amd64 (1.11.6-3) ...
Sélection du paquet cups-filters précédemment désélectionné.
Préparation du dépaquetage de .../11-cups-filters_1.11.6-3_amd64.deb ...
Dépaquetage de cups-filters (1.11.6-3) ...
Sélection du paquet cups précédemment désélectionné.
Préparation du dépaquetage de .../12-cups_2.2.1-8+deb9u2_amd64.deb ...
Dépaquetage de cups (2.2.1-8+deb9u2) ...
Sélection du paquet cups-browsed précédemment désélectionné.
Préparation du dépaquetage de .../13-cups-browsed_1.11.6-3_amd64.deb ...
Dépaquetage de cups-browsed (1.11.6-3) ...
Sélection du paquet libgutenprint2 précédemment désélectionné.
Préparation du dépaquetage de .../14-libgutenprint2_5.2.11-1+b2_amd64.deb ...
Dépaquetage de libgutenprint2 (5.2.11-1+b2) ...
Sélection du paquet printer-driver-gutenprint précédemment désélectionné.
Préparation du dépaquetage de .../15-printer-driver-gutenprint_5.2.11-1+b2_amd64.deb ...
Dépaquetage de printer-driver-gutenprint (5.2.11-1+b2) ...
Sélection du paquet qpdf précédemment désélectionné.
Préparation du dépaquetage de .../16-qpdf_6.0.0-2_amd64.deb ...
Dépaquetage de qpdf (6.0.0-2) ...
Sélection du paquet liblouis-data précédemment désélectionné.
Préparation du dépaquetage de .../17-liblouis-data_3.0.0-3+deb9u4_all.deb ...
Dépaquetage de liblouis-data (3.0.0-3+deb9u4) ...
Sélection du paquet liblouis12:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../18-liblouis12_3.0.0-3+deb9u4_amd64.deb ...
Dépaquetage de liblouis12:amd64 (3.0.0-3+deb9u4) ...
Sélection du paquet liblouisutdml-data précédemment désélectionné.
Préparation du dépaquetage de .../19-liblouisutdml-data_2.6.0-3_all.deb ...
Dépaquetage de liblouisutdml-data (2.6.0-3) ...
Sélection du paquet liblouisutdml7:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../20-liblouisutdml7_2.6.0-3+b2_amd64.deb ...
Dépaquetage de liblouisutdml7:amd64 (2.6.0-3+b2) ...
Sélection du paquet liblouisutdml-bin précédemment désélectionné.
Préparation du dépaquetage de .../21-liblouisutdml-bin_2.6.0-3+b2_amd64.deb ...
Dépaquetage de liblouisutdml-bin (2.6.0-3+b2) ...
Paramétrage de cups-server-common (2.2.1-8+deb9u2) ...
Paramétrage de poppler-utils (0.48.0-2+deb9u2) ...
Paramétrage de liblouisutdml-data (2.6.0-3) ...
Paramétrage de libcupsmime1:amd64 (2.2.1-8+deb9u2) ...
Paramétrage de libgutenprint2 (5.2.11-1+b2) ...
Paramétrage de cups-daemon (2.2.1-8+deb9u2) ...
Created symlink /etc/systemd/system/multi-user.target.wants/cups.path → /lib/systemd/system/cups.path.
Created symlink /etc/systemd/system/printer.target.wants/cups.service → /lib/systemd/system/cups.service.
Created symlink /etc/systemd/system/sockets.target.wants/cups.socket → /lib/systemd/system/cups.socket.
Paramétrage de libcupsppdc1:amd64 (2.2.1-8+deb9u2) ...
Paramétrage de liblouis-data (3.0.0-3+deb9u4) ...
Paramétrage de libfontembed1:amd64 (1.11.6-3) ...
Paramétrage de libqpdf17:amd64 (6.0.0-2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u3) ...
Traitement des actions différées (« triggers ») pour systemd (232-25+deb9u6) ...
Paramétrage de cups-filters-core-drivers (1.11.6-3) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Paramétrage de qpdf (6.0.0-2) ...
Paramétrage de liblouis12:amd64 (3.0.0-3+deb9u4) ...
Paramétrage de libcupscgi1:amd64 (2.2.1-8+deb9u2) ...
Paramétrage de cups-filters (1.11.6-3) ...
.
Paramétrage de cups-browsed (1.11.6-3) ...
Created symlink /etc/systemd/system/multi-user.target.wants/cups-browsed.service → /lib/systemd/system/cups-browsed.service.
Paramétrage de liblouisutdml7:amd64 (2.6.0-3+b2) ...
Paramétrage de cups-ppdc (2.2.1-8+deb9u2) ...
Paramétrage de cups-core-drivers (2.2.1-8+deb9u2) ...
Paramétrage de liblouisutdml-bin (2.6.0-3+b2) ...
Paramétrage de cups (2.2.1-8+deb9u2) ...
Updating PPD files for cups ...
Updating PPD files for cups-filters ...
Updating PPD files for gutenprint ...
Paramétrage de printer-driver-gutenprint (5.2.11-1+b2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u3) ...
Traitement des actions différées (« triggers ») pour systemd (232-25+deb9u6) ...
root@HomeServ:~# cd /home/cemoi/Documents/driver_brother_dcp_9020/
root@HomeServ:/home/cemoi/Documents/driver_brother_dcp_9020# apt install lpr
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
lpr is already the newest version (1:2008.05.17.2+b1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 15 non mis à jour.




root@HomeServ:/home/cemoi/Documents/driver_brother_dcp_9020# bash linux-brprinter-installer-2.2.1-1 DCP-9020CDW

 


You are going to install following packages.
   dcp9020cdwlpr-1.1.2-1.i386.deb
   dcp9020cdwcupswrapper-1.1.4-0.i386.deb
   brscan4-0.4.6-1.amd64.deb
   brscan-skey-0.2.4-1.amd64.deb
OK? [y/N] ->y

Réception de:1 http://security.debian.org stretch/updates InRelease [94,3 kB]
Ign:2 http://deb.debian.org/debian stretch InRelease                                                                      
Réception de:3 http://deb.debian.org/debian stretch-updates InRelease [91,0 kB]                                          
Ign:4 http://download.videolan.org/pub/debian/stable  InRelease                                        
Atteint:5 http://download.videolan.org/pub/debian/stable  Release                                      
Réception de:6 http://deb.debian.org/debian stretch-backports InRelease [91,8 kB]                
Atteint:7 http://deb.debian.org/debian stretch Release        
Réception de:9 http://deb.debian.org/debian stretch-backports/main i386 Packages.diff/Index [27,8 kB]
Réception de:10 http://deb.debian.org/debian stretch-backports/main amd64 Packages.diff/Index [27,8 kB]
Réception de:12 http://deb.debian.org/debian stretch-backports/non-free i386 Packages.diff/Index [26,8 kB]
Réception de:13 http://deb.debian.org/debian stretch-backports/non-free amd64 Packages.diff/Index [27,8 kB]
Réception de:14 http://deb.debian.org/debian stretch-backports/non-free Translation-en.diff/Index [16,0 kB]
Réception de:15 http://deb.debian.org/debian stretch-backports/main i386 Packages 2019-01-13-0212.27.pdiff [293 B]
Réception de:16 http://deb.debian.org/debian stretch-backports/main i386 Packages 2019-01-13-0810.11.pdiff [345 B]
Réception de:17 http://deb.debian.org/debian stretch-backports/main amd64 Packages 2019-01-13-0212.27.pdiff [414 B]
Réception de:18 http://deb.debian.org/debian stretch-backports/main amd64 Packages 2019-01-13-0810.11.pdiff [215 B]
Réception de:19 http://deb.debian.org/debian stretch-backports/non-free i386 Packages 2019-01-12-2012.01.pdiff [5 044 B]
Réception de:20 http://deb.debian.org/debian stretch-backports/non-free amd64 Packages 2019-01-12-2012.01.pdiff [5 558 B]
Réception de:21 http://deb.debian.org/debian stretch-backports/non-free Translation-en 2019-01-12-2012.01.pdiff [1 068 B]
Réception de:16 http://deb.debian.org/debian stretch-backports/main i386 Packages 2019-01-13-0810.11.pdiff [345 B]
Réception de:21 http://deb.debian.org/debian stretch-backports/non-free Translation-en 2019-01-12-2012.01.pdiff [1 068 B]
Réception de:20 http://deb.debian.org/debian stretch-backports/non-free amd64 Packages 2019-01-12-2012.01.pdiff [5 558 B]
Réception de:18 http://deb.debian.org/debian stretch-backports/main amd64 Packages 2019-01-13-0810.11.pdiff [215 B]
Réception de:19 http://deb.debian.org/debian stretch-backports/non-free i386 Packages 2019-01-12-2012.01.pdiff [5 044 B]
416 ko réceptionnés en 0s (715 ko/s)                                                                                                    
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Aucune version du paquet ia32-libs n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  lib32z1 lib32ncurses5

E: Le paquet « ia32-libs » n'a pas de version susceptible d'être installée
dpkg -x dcp9020cdwlpr-1.1.2-1.i386.deb /
dpkg -x dcp9020cdwcupswrapper-1.1.4-0.i386.deb /
(Lecture de la base de données... 220967 fichiers et répertoires déjà installés.)
Suppression de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
lpadmin: The printer or class does not exist.
[ ok ] Restarting cups (via systemctl): cups.service.
Purge des fichiers de configuration de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
dpkg-deb: building package 'dcp9020cdwlpr' in 'dcp9020cdwlpr-1.1.2-1a.i386.deb'.
dpkg -b ./brother_driver_packdir dcp9020cdwlpr-1.1.2-1a.i386.deb
dpkg-deb: building package 'dcp9020cdwcupswrapper' in 'dcp9020cdwcupswrapper-1.1.4-0a.i386.deb'.
dpkg -b ./brother_driver_packdir dcp9020cdwcupswrapper-1.1.4-0a.i386.deb
dpkg -i --force-all dcp9020cdwlpr-1.1.2-1a.i386.deb
(Lecture de la base de données... 220963 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de dcp9020cdwlpr-1.1.2-1a.i386.deb ...
Dépaquetage de dcp9020cdwlpr:i386 (1.1.2-1) sur (1.1.2-1) ...
Paramétrage de dcp9020cdwlpr:i386 (1.1.2-1) ...
dpkg -i --force-all dcp9020cdwcupswrapper-1.1.4-0a.i386.deb
Sélection du paquet dcp9020cdwcupswrapper:i386 précédemment désélectionné.
(Lecture de la base de données... 220963 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de dcp9020cdwcupswrapper-1.1.4-0a.i386.deb ...
Dépaquetage de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
Paramétrage de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
Stopping printer spooler: lpd.
Restarting cups (via systemctl): cups.service.
lpadmin -p DCP9020CDW -E -v dnssd://Brother%20DCP-9020CDW._ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-3c2af41f3b25 -P /usr/share/cups/model/Brother/brother_dcp9020cdw_printer_en.ppd
#
Will you specify the Device URI? [Y/n] ->y

1
0: socket
1: http
2: https
3: lpd
4: beh
5: ipps
6: serial:/dev/ttyS0?baud=115200
7: ipp
8: ipp14
9: dnssd://Brother%20DCP-9020CDW._ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-3c2af41f3b25
10: lpd://BRW5413790FB07B/BINARY_P1
11 (I): Specify IP address.
12 (A): Auto. (dnssd://Brother%20DCP-9020CDW._ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-3c2af41f3b25)

select the number of destination Device URI. ->12

Test Print? [y/N] ->y

wait 5s.
lpr -P DCP9020CDW /usr/share/cups/data/testprint
lpr: connect: No such file or directory
Is lpd daemon running?
jobs queued, but cannot start daemon.



il faut démarrer le demon de cups apres son installation?


Linux debDesk Linux 4.19.0-9-amd64

Hors ligne

#9 13-01-2019 19:54:42

èfpé
Membre
Inscription : 10-07-2016

Re : installation brother DCP-9020CDW

Re-,

cemoi a écrit :

effectivement je n'avais pas le paquet lpr d'installé mais quand je l'ai installé il a supprimé le paquet cups-bsd... et ses dépendances [inverses].


Les paquets cups-bsd, lprng et lpr fournissent une implémentation de lpr/lpd. Ils entrent en conflit.

bash linux-brprinter-installer-2.2.1-1 DCP-9020CDW

...
Stopping printer spooler: lpd.
Restarting cups (via systemctl): cups.service.
...
lpr -P DCP9020CDW /usr/share/cups/data/testprint
lpr: connect: No such file or directory
Is lpd daemon running?
jobs queued, but cannot start daemon.

il faut démarrer le démon de cups après son installation ?


Oui, mais cela a été fait deux fois... là c'est le démon lpd qui est en rade ; tu peux peut-être tenter :

service lpd start


Mais en principe tu ne devrais pas avoir à le démarrer manuellement, le bazar est obsolète mais bon.

Dernière modification par èfpé (13-01-2019 20:24:42)

Hors ligne

#10 25-01-2019 22:31:22

cemoi
Membre
Distrib. : Debian 10 Buster et une SID
Noyau : Linux 4.19.0-9-amd64
(G)UI : XFCE
Inscription : 21-10-2008

Re : installation brother DCP-9020CDW

hello,
je rame toujours avec cette imprimante:

service lpd start



service lpd status
 


● lpd.service - LSB: BSD lpr/lpd line printer spooling system
   Loaded: loaded (/etc/init.d/lpd; generated; vendor preset: enabled)
   Active: active (running) since Fri 2019-01-25 20:30:57 CET; 1h 51min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 548 ExecStart=/etc/init.d/lpd start (code=exited, status=0/SUCCESS)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/lpd.service
           └─569 /usr/sbin/lpd -s

janv. 25 20:30:57 HomeServ systemd[1]: Starting LSB: BSD lpr/lpd line printer spooling system...
janv. 25 20:30:57 HomeServ lpd[548]: Starting printer spooler: lpd.
janv. 25 20:30:57 HomeServ lpd[569]: restarted
janv. 25 20:30:57 HomeServ lpd[572]: /dev/usb/lp0: No such file or directory
janv. 25 20:30:57 HomeServ systemd[1]: Started LSB: BSD lpr/lpd line printer spooling system.
 



je retente l'installation de l'imprimante:

bash linux-brprinter-installer-2.2.1-1 DCP-9020CDW
 


You are going to install following packages.
   dcp9020cdwlpr-1.1.2-1.i386.deb
   dcp9020cdwcupswrapper-1.1.4-0.i386.deb
   brscan4-0.4.7-1.amd64.deb
   brscan-skey-0.2.4-1.amd64.deb
OK? [y/N] ->y

Réception de:1 http://security.debian.org stretch/updates InRelease [94,3 kB]
Ign:2 http://deb.debian.org/debian stretch InRelease                                                                      
Réception de:3 http://deb.debian.org/debian stretch-updates InRelease [91,0 kB]                                          
Ign:4 http://download.videolan.org/pub/debian/stable  InRelease                                        
Atteint:5 http://download.videolan.org/pub/debian/stable  Release                                      
Réception de:6 http://deb.debian.org/debian stretch-backports InRelease [91,8 kB]                
Atteint:7 http://deb.debian.org/debian stretch Release        
Réception de:9 http://deb.debian.org/debian stretch-backports/main i386 Packages.diff/Index [27,8 kB]
Réception de:10 http://deb.debian.org/debian stretch-backports/main amd64 Packages.diff/Index [27,8 kB]
Réception de:11 http://deb.debian.org/debian stretch-backports/main Translation-en.diff/Index [27,8 kB]
Réception de:12 http://deb.debian.org/debian stretch-backports/non-free i386 Packages.diff/Index [27,8 kB]
Réception de:14 http://deb.debian.org/debian stretch-backports/non-free amd64 Packages.diff/Index [27,8 kB]
Réception de:15 http://deb.debian.org/debian stretch-backports/non-free Translation-en.diff/Index [17,0 kB]
Réception de:16 http://deb.debian.org/debian stretch-backports/main i386 Packages 2019-01-24-1439.27.pdiff [464 B]
Réception de:17 http://deb.debian.org/debian stretch-backports/main i386 Packages 2019-01-25-0813.48.pdiff [627 B]
Réception de:18 http://deb.debian.org/debian stretch-backports/main i386 Packages 2019-01-25-1412.54.pdiff [433 B]
Réception de:19 http://deb.debian.org/debian stretch-backports/main amd64 Packages 2019-01-24-1439.27.pdiff [465 B]
Réception de:20 http://deb.debian.org/debian stretch-backports/main amd64 Packages 2019-01-25-0813.48.pdiff [260 B]
Réception de:21 http://deb.debian.org/debian stretch-backports/main amd64 Packages 2019-01-25-1412.54.pdiff [431 B]
Réception de:22 http://deb.debian.org/debian stretch-backports/main Translation-en 2019-01-25-1412.54.pdiff [288 B]
Réception de:23 http://deb.debian.org/debian stretch-backports/non-free i386 Packages 2019-01-25-1412.54.pdiff [42 B]
Réception de:24 http://deb.debian.org/debian stretch-backports/non-free amd64 Packages 2019-01-25-1412.54.pdiff [40 B]
Réception de:25 http://deb.debian.org/debian stretch-backports/non-free Translation-en 2019-01-25-1412.54.pdiff [42 B]
Réception de:18 http://deb.debian.org/debian stretch-backports/main i386 Packages 2019-01-25-1412.54.pdiff [433 B]
Réception de:25 http://deb.debian.org/debian stretch-backports/non-free Translation-en 2019-01-25-1412.54.pdiff [42 B]
Réception de:24 http://deb.debian.org/debian stretch-backports/non-free amd64 Packages 2019-01-25-1412.54.pdiff [40 B]
Réception de:23 http://deb.debian.org/debian stretch-backports/non-free i386 Packages 2019-01-25-1412.54.pdiff [42 B]
Réception de:22 http://deb.debian.org/debian stretch-backports/main Translation-en 2019-01-25-1412.54.pdiff [288 B]
Réception de:21 http://deb.debian.org/debian stretch-backports/main amd64 Packages 2019-01-25-1412.54.pdiff [431 B]
436 ko réceptionnés en 0s (559 ko/s)                                                                                                      
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Aucune version du paquet ia32-libs n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  lib32z1 lib32ncurses5

E: Le paquet « ia32-libs » n'a pas de version susceptible d'être installée
dpkg -x dcp9020cdwlpr-1.1.2-1.i386.deb /
dpkg -x dcp9020cdwcupswrapper-1.1.4-0.i386.deb /
(Lecture de la base de données... 225207 fichiers et répertoires déjà installés.)
Suppression de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
[ ok ] Restarting cups (via systemctl): cups.service.
Purge des fichiers de configuration de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
dpkg-deb: building package 'dcp9020cdwlpr' in 'dcp9020cdwlpr-1.1.2-1a.i386.deb'.
dpkg -b ./brother_driver_packdir dcp9020cdwlpr-1.1.2-1a.i386.deb
dpkg-deb: building package 'dcp9020cdwcupswrapper' in 'dcp9020cdwcupswrapper-1.1.4-0a.i386.deb'.
dpkg -b ./brother_driver_packdir dcp9020cdwcupswrapper-1.1.4-0a.i386.deb
dpkg -i --force-all dcp9020cdwlpr-1.1.2-1a.i386.deb
(Lecture de la base de données... 225203 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de dcp9020cdwlpr-1.1.2-1a.i386.deb ...
Dépaquetage de dcp9020cdwlpr:i386 (1.1.2-1) sur (1.1.2-1) ...
Paramétrage de dcp9020cdwlpr:i386 (1.1.2-1) ...
dpkg -i --force-all dcp9020cdwcupswrapper-1.1.4-0a.i386.deb
Sélection du paquet dcp9020cdwcupswrapper:i386 précédemment désélectionné.
(Lecture de la base de données... 225203 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de dcp9020cdwcupswrapper-1.1.4-0a.i386.deb ...
Dépaquetage de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
Paramétrage de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
Stopping printer spooler: lpd.
Restarting cups (via systemctl): cups.service.
lpadmin -p DCP9020CDW -E -v dnssd://Brother%20DCP-9020CDW._ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-3c2af41f3b25 -P /usr/share/cups/model/Brother/brother_dcp9020cdw_printer_en.ppd
#
Will you specify the Device URI? [Y/n] ->y


0: socket
1: http
2: https
3: beh
4: ipps
5: ipp
6: lpd
7: ipp14
8: serial:/dev/ttyS0?baud=115200
9: parallel:/dev/lp0
10: dnssd://Brother%20DCP-9020CDW._ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-3c2af41f3b25
11: lpd://BRW5413790FB07B/BINARY_P1
12 (I): Specify IP address.
13 (A): Auto. (dnssd://Brother%20DCP-9020CDW._ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-3c2af41f3b25)

select the number of destination Device URI. ->13

lpadmin -p DCP9020CDW -v dnssd://Brother%20DCP-9020CDW._ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-3c2af41f3b25 -E
Test Print? [y/N] ->y

wait 5s.
lpr -P DCP9020CDW /usr/share/cups/data/testprint
lpr: connect: No such file or directory
Is lpd daemon running?
jobs queued, but cannot start daemon.
 



Je n'y comprend rien... je vais tenté une installation à partir du driver seul et pas à partir du script qui install tout...


Linux debDesk Linux 4.19.0-9-amd64

Hors ligne

#11 26-01-2019 02:40:42

èfpé
Membre
Inscription : 10-07-2016

Re : installation brother DCP-9020CDW

Bon{soir|ne nuit|jour},

cemoi a écrit :

Je vais tenter une installation à partir du pilote seul et pas à partir du script qui installe tout...


Cela ne change pas grand-chose à l'affaire, toutefois le test avec/sans le paquet lpr est intéressant :

# avec le paquet lpr
apt install ./dcp9020cdw*.i386.deb

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Note : sélection de « dcp9020cdwcupswrapper:i386 » au lieu de « ./dcp9020cdwcupswrapper-1.1.4-0.i386.deb »
Note : sélection de « dcp9020cdwlpr:i386 » au lieu de « ./dcp9020cdwlpr-1.1.2-1.i386.deb »
Les NOUVEAUX paquets suivants seront installés :
  dcp9020cdwcupswrapper:i386 dcp9020cdwlpr:i386
0 mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/708 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Réception de:1 /home/humain/Téléchargements/dcp9020cdwlpr-1.1.2-1.i386.deb dcp9020cdwlpr i386 1.1.2-1 [695 kB]
Réception de:2 /home/humain/Téléchargements/dcp9020cdwcupswrapper-1.1.4-0.i386.deb dcp9020cdwcupswrapper i386 1.1.4-0 [13,7 kB]
Sélection du paquet dcp9020cdwlpr:i386 précédemment désélectionné.
(Lecture de la base de données... 145681 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../dcp9020cdwlpr-1.1.2-1.i386.deb ...
Dépaquetage de dcp9020cdwlpr:i386 (1.1.2-1) ...
Sélection du paquet dcp9020cdwcupswrapper:i386 précédemment désélectionné.
Préparation du dépaquetage de .../dcp9020cdwcupswrapper-1.1.4-0.i386.deb ...
Dépaquetage de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
Paramétrage de dcp9020cdwlpr:i386 (1.1.2-1) ...
Stopping printer spooler: lpd.
Starting printer spooler: lpd.
Paramétrage de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
Stopping printer spooler: lpd.
[ ok ] Restarting cups (via systemctl): cups.service.
lpadmin -p DCP9020CDW -E -v usb://dev/usb/lp0 -P /usr/share/cups/model/Brother/brother_dcp9020cdw_printer_en.ppd
 


# sans le paquet lpr
apt install ./dcp9020cdw*.i386.deb

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Note : sélection de « dcp9020cdwcupswrapper:i386 » au lieu de « ./dcp9020cdwcupswrapper-1.1.4-0.i386.deb »
Note : sélection de « dcp9020cdwlpr:i386 » au lieu de « ./dcp9020cdwlpr-1.1.2-1.i386.deb »
Les NOUVEAUX paquets suivants seront installés :
  dcp9020cdwcupswrapper:i386 dcp9020cdwlpr:i386
0 mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/708 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Réception de:1 /home/humain/Téléchargements/dcp9020cdwlpr-1.1.2-1.i386.deb dcp9020cdwlpr i386 1.1.2-1 [695 kB]
Réception de:2 /home/humain/Téléchargements/dcp9020cdwcupswrapper-1.1.4-0.i386.deb dcp9020cdwcupswrapper i386 1.1.4-0 [13,7 kB]
Sélection du paquet dcp9020cdwlpr:i386 précédemment désélectionné.
(Lecture de la base de données... 145688 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../dcp9020cdwlpr-1.1.2-1.i386.deb ...
Dépaquetage de dcp9020cdwlpr:i386 (1.1.2-1) ...
Sélection du paquet dcp9020cdwcupswrapper:i386 précédemment désélectionné.
Préparation du dépaquetage de .../dcp9020cdwcupswrapper-1.1.4-0.i386.deb ...
Dépaquetage de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
Paramétrage de dcp9020cdwlpr:i386 (1.1.2-1) ...
mkdir: impossible de créer le répertoire « /var/spool/lpd/dcp9020cdw »: Aucun fichier ou dossier de ce type
chown: impossible d'accéder à '/var/spool/lpd/dcp9020cdw': Aucun fichier ou dossier de ce type
chgrp: impossible d'accéder à '/var/spool/lpd/dcp9020cdw': Aucun fichier ou dossier de ce type
chmod: impossible d'accéder à '/var/spool/lpd/dcp9020cdw': Aucun fichier ou dossier de ce type
Paramétrage de dcp9020cdwcupswrapper:i386 (1.1.4-0) ...
[ ok ] Restarting cups (via systemctl): cups.service.
lpadmin -p DCP9020CDW -E -v usb://dev/usb/lp0 -P /usr/share/cups/model/Brother/brother_dcp9020cdw_printer_en.ppd
 


On remarque indirectement que c'est le script qui gère l'installation de la dépendance lib32stdc++6 !

Quant au répertoire /var/spool/lpd/ absent je me suis peut-être enthousiasmé un peu vite pour lpr.
D'après Brother, la DCP-9020CDW a été testée avec LPR sous Debian 4.0 et CUPS sous Debian 6.0.

# mkdir /var/spool/lpd/
# ln -s /etc/init.d/cups /etc/init.d/lpd


Ces commandes font partie des divers contournements proposés... pas l'installation du paquet lpr...
Mais le plus étonnant est encore que rb, efk et toi avez déjà installé ce modèle sous Debian Stretch.

Hors ligne

#12 26-01-2019 17:35:07

cemoi
Membre
Distrib. : Debian 10 Buster et une SID
Noyau : Linux 4.19.0-9-amd64
(G)UI : XFCE
Inscription : 21-10-2008

Re : installation brother DCP-9020CDW

Je confirme, j'ai cette imprimante d'installée sur une buster et avant je l'avais sur une stretch... L'installation sur buster est sur un laptop alors que là je tente l'installation sur une tour branchée en rj45 sur ma box qui gére le reseau wifi.

mkdir /var/spool/lpd/


mkdir: impossible de créer le répertoire « /var/spool/lpd/ »: Le fichier existe



ln -s /etc/init.d/cups /etc/init.d/lpd


ln: impossible de créer le lien symbolique '/etc/init.d/lpd': Le fichier existe



Je suis complètement à la rue sur ce coup...bon on va dire que c'est pas trop grave car je peux imprimer à partir de mon laptop mais bon c'est pas pratique... hmm Comme je suis overbooké de taf sur les 4 prochains mois j'ai peu de temps pour gérer pleinement le problème...

service lpd start



service lpd status


● lpd.service - LSB: BSD lpr/lpd line printer spooling system
   Loaded: loaded (/etc/init.d/lpd; generated; vendor preset: enabled)
   Active: active (exited) since Sat 2019-01-26 16:41:49 CET; 1h 2min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 567 ExecStart=/etc/init.d/lpd start (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   CGroup: /system.slice/lpd.service

janv. 26 16:41:49 HomeServ systemd[1]: Starting LSB: BSD lpr/lpd line printer spooling system...
janv. 26 16:41:49 HomeServ lpd[567]: Starting printer spooler: lpd.
janv. 26 16:41:49 HomeServ lpd[578]: restarted
janv. 26 16:41:49 HomeServ systemd[1]: Started LSB: BSD lpr/lpd line printer spooling system.

 



dans la foulé je tente un:

lpr -P DCP9020CDW /usr/share/cups/data/testprint


lpr: connect: No such file or directory
Is lpd daemon running?
jobs queued, but cannot start daemon.



no such file?!! o_O du coup je gratte:

cemoi@HomeServ:/usr/share/cups/data$ ls


classified.pdf    default.pdf           form_english_in.odt  form_russian_in.odt  secret.pdf    testprint      unclassified.pdf
confidential.pdf  default-testpage.pdf  form_english.pdf     form_russian.pdf     standard.pdf  topsecret.pdf



cemoi@HomeServ:/usr/share/cups/data$ cat testprint


#PDF-BANNER
Template default-testpage.pdf
Show printer-name printer-info printer-location printer-make-and-model printer-driver-name printer-driver-version paper-size imageable-area job-id options time-at-creation time-at-processing




Pour moi ça n'a pas de sens:
il me dit que le deamon tourne (service lpd status)
la commande ls me confirme qu'il y a bien le fichier testprint (et ça confirme que le répertoire dans lequel se trouve le fichier existe...)
la commande cat me confirme que le fichier testprint n'est pas vide (impossible pour moi de savoir si il est valide ou pas...)


Merci pour toutes ces infos au passages smile

bref la misére hmm

Dernière modification par cemoi (26-01-2019 17:56:11)


Linux debDesk Linux 4.19.0-9-amd64

Hors ligne

#13 26-01-2019 18:36:42

èfpé
Membre
Inscription : 10-07-2016

Re : installation brother DCP-9020CDW

Re-,

mkdir /var/spool/lpd/

mkdir: impossible de créer le répertoire « /var/spool/lpd/ »: Le fichier existe


ln -s /etc/init.d/cups /etc/init.d/lpd

ln: impossible de créer le lien symbolique '/etc/init.d/lpd': Le fichier existe


Ces retours s'expliquent simplement par le fait que le paquet lpr est installé (l'idée serait de le virer).

CUPS et LPR faisaient bon ménage sous Wheezy (note que le paquet dcp9020cdwlpr date de 2013).
Il est possible que cela ne soit plus le cas sous Stretch, remarque que rb avait ignoré les messages.

mkdir: impossible de créer le répertoire « /var/spool/lpd/dcp9020cdw »: Aucun fichier ou dossier de ce type
chown: impossible d'accéder à '/var/spool/lpd/dcp9020cdw': Aucun fichier ou dossier de ce type
chgrp: impossible d'accéder à '/var/spool/lpd/dcp9020cdw': Aucun fichier ou dossier de ce type
chmod: impossible d'accéder à '/var/spool/lpd/dcp9020cdw': Aucun fichier ou dossier de ce type


Donc : peut-être désinstaller tout ça, lpr compris, et repartir sur une réinstallation propre de CUPS ?

Dernière modification par èfpé (26-01-2019 19:06:42)

Hors ligne

#14 17-06-2019 05:35:41

botojo
Membre
Lieu : Trois-Rivières
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-9-686-pae
(G)UI : Xfce
Inscription : 29-05-2019

Re : installation brother DCP-9020CDW

Bonjour,

Ton modèle est compatible avec le même pilote que mon imprimante.

Tous fonctionne vraiment bien:
Procédure d'installation:
https://support.brother.com/g/s/id/linu … edirect=on
Page de téléchargement:
https://support.brother.com/g/s/id/linu … ml#brscan4

Bonne chance.

Botojo

Hors ligne

#15 18-06-2020 23:45:58

rasalhague
Membre
Distrib. : Debian buster
Noyau : Linux 4.19.0-9-amd64
(G)UI : MATE
Inscription : 18-06-2020

Re : installation brother DCP-9020CDW

Bonjour,

Le souci date un peu mais ne semble pas avoir été résolu.
Je possède la même imprimante.

Dans la liste des messages, nous trouvons "mkdir: impossible de créer le répertoire « /var/spool/lpd/dcp9020cdw »: Aucun fichier ou dossier de ce type"
Chez moi, en vérifiant, le dossier /var/spool/lpd n'existe pas.
Perso, j'ai simplement créé ce dossier

mkdir -p /var/spool/lpd



J'ai également eu un souci sur la variable PATH qui avait pour valeur /usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
Je lui ai ajouté les dossiers /sbin, /usr/sbin et /usr/local/sbin

PATH=$PATH":/sbin:/usr/sbin:/usr/local/sbin"



L'installation fonctionne après ces 2 commandes !

Hors ligne

#16 19-06-2020 07:51:53

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : installation brother DCP-9020CDW

J'ai également eu un souci sur la variable PATH qui avait pour valeur /usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
Je lui ai ajouté les dossiers /sbin, /usr/sbin et /usr/local/sbin
PATH=$PATH":/sbin:/usr/sbin:/usr/local/sbin"


Sur Buster pour passer en root

su -


echo $PATH


/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin


alors que

su


echo $PATH


/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

Pied de page des forums