Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-01-2019 12:43:01

erbou
Membre
Distrib. : MX-16.1 Metamorphosis
Noyau : 4.7.0-0.bpo.1-amd64
(G)UI : XFCE
Inscription : 31-03-2016

Synaptic est bloqué par un autre programme

Bonjour,
Je ne peux plus rien installer ou supprimer dans Synaptic.

Lorsque je demande à Synaptic, la suppression complète d'un programme qui fonctionne, j'obtiens ce message d'erreur :

Suppression de chromium (57.0.2987.98-1~deb8u1) ...
Purge des fichiers de configuration de chromium (57.0.2987.98-1~deb8u1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.13-1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.58) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
Traitement des actions différées (« triggers ») pour menu (2.1.47) ...
Paramétrage de tvmosaic (1.0.0) ...
cp: impossible d'évaluer « /usr/local/bin/tvmosaic/shared.inst/* »: Aucun fichier ou dossier de ce type
dpkg: erreur de traitement du paquet tvmosaic (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 tvmosaic
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de récupération :
Paramétrage de tvmosaic (1.0.0) ...
cp: impossible d'évaluer « /usr/local/bin/tvmosaic/shared.inst/* »: Aucun fichier ou dossier de ce type
dpkg: erreur de traitement du paquet tvmosaic (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 tvmosaic



Lorsque je demande à Synaptic, l'installation d'un nouveau programme, j'obtiens ce message d'erreur :

(synaptic:5971): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed
Sélection du paquet python-simplejson précédemment désélectionné.
(Lecture de la base de données... 206795 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python-simplejson_3.6.5-1_amd64.deb ...
Dépaquetage de python-simplejson (3.6.5-1) ...
Sélection du paquet python-httplib2 précédemment désélectionné.
Préparation du dépaquetage de .../python-httplib2_0.9+dfsg-2_all.deb ...
Dépaquetage de python-httplib2 (0.9+dfsg-2) ...
Sélection du paquet python-sqlalchemy précédemment désélectionné.
Préparation du dépaquetage de .../python-sqlalchemy_0.9.8+dfsg-0.1_all.deb ...
Dépaquetage de python-sqlalchemy (0.9.8+dfsg-0.1) ...
Sélection du paquet python-beautifulsoup précédemment désélectionné.
Préparation du dépaquetage de .../python-beautifulsoup_3.2.1-1_all.deb ...
Dépaquetage de python-beautifulsoup (3.2.1-1) ...
Sélection du paquet python-pyaudio précédemment désélectionné.
Préparation du dépaquetage de .../python-pyaudio_0.2.8-1+b1_amd64.deb ...
Dépaquetage de python-pyaudio (0.2.8-1+b1) ...
Sélection du paquet libjs-jquery-ui précédemment désélectionné.
Préparation du dépaquetage de .../libjs-jquery-ui_1.10.1+dfsg-1_all.deb ...
Dépaquetage de libjs-jquery-ui (1.10.1+dfsg-1) ...
Sélection du paquet libjs-jquery-flot précédemment désélectionné.
Préparation du dépaquetage de .../libjs-jquery-flot_0.8.2+dfsg-1_all.deb ...
Dépaquetage de libjs-jquery-flot (0.8.2+dfsg-1) ...
Sélection du paquet anki précédemment désélectionné.
Préparation du dépaquetage de .../anki_2.0.31+dfsg-1_all.deb ...
Dépaquetage de anki (2.0.31+dfsg-1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.13-1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.58) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
Traitement des actions différées (« triggers ») pour menu (2.1.47) ...
Paramétrage de tvmosaic (1.0.0) ...
cp: impossible d'évaluer « /usr/local/bin/tvmosaic/shared.inst/* »: Aucun fichier ou dossier de ce type
dpkg: erreur de traitement du paquet tvmosaic (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de python-simplejson (3.6.5-1) ...
Paramétrage de python-httplib2 (0.9+dfsg-2) ...
Paramétrage de python-sqlalchemy (0.9.8+dfsg-0.1) ...
Paramétrage de python-beautifulsoup (3.2.1-1) ...
Paramétrage de python-pyaudio (0.2.8-1+b1) ...
Paramétrage de libjs-jquery-ui (1.10.1+dfsg-1) ...
Paramétrage de libjs-jquery-flot (0.8.2+dfsg-1) ...
Paramétrage de anki (2.0.31+dfsg-1) ...
Traitement des actions différées (« triggers ») pour menu (2.1.47) ...
Des erreurs ont été rencontrées pendant l'exécution :
 tvmosaic
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de récupération :
Paramétrage de tvmosaic (1.0.0) ...
cp: impossible d'évaluer « /usr/local/bin/tvmosaic/shared.inst/* »: Aucun fichier ou dossier de ce type
dpkg: erreur de traitement du paquet tvmosaic (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 tvmosaic



Lorsque j'essaie d'enlever tvmosaic par APT, j'obtiens ce message d'erreur :

$ sudo apt-get remove tvmosaic
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Les paquets suivants seront ENLEVÉS :
  tvmosaic
0 mis à jour, 0 nouvellement installés, 1 à enlever et 11 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 207600 fichiers et répertoires déjà installés.)
Suppression de tvmosaic (1.0.0) ...
/usr/local/bin/tvmosaic/tvmosaic_reg: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21'
not found (required by /usr/local/bin/tvmosaic/tvmosaic_reg)
dpkg: erreur de traitement du paquet tvmosaic (--remove) :
 le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'
exécution :
 tvmosaic
E: Sub-process /usr/bin/dpkg returned an error code (1)



Lorsque j'essaie de purger tvmosaic par APT, j'obtiens ce message d'erreur :

$ sudo apt-get purge tvmosaic
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Les paquets suivants seront ENLEVÉS :
  tvmosaic*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 11 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 207600 fichiers et répertoires déjà installés.)
Suppression de tvmosaic (1.0.0) ...
/usr/local/bin/tvmosaic/tvmosaic_reg: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21'
not found (required by /usr/local/bin/tvmosaic/tvmosaic_reg)
dpkg: erreur de traitement du paquet tvmosaic (--purge) :
 le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'
exécution :
 tvmosaic
E: Sub-process /usr/bin/dpkg returned an error code (1)



En outre, je ne peux plus faire aucune mise-à-jour système par APT.
Comment puis-je faire sans avoir à réinstaller tout mon système ?

Hors ligne

#2 19-01-2019 12:55:03

pas-si-facile
Membre
Lieu : Paris
Distrib. : Debian 9 stable
Noyau : Linux 4.9.0-8-amd64
(G)UI : Xfce
Inscription : 09-01-2019
Site Web

Re : Synaptic est bloqué par un autre programme

Salut,

que donne : apt-get check . (apt-get pas apt) ?

http://pwet.fr/man/linux/administration … e/apt_get/

Dernière modification par pas-si-facile (19-01-2019 12:59:09)

Hors ligne

#3 19-01-2019 13:25:58

erbou
Membre
Distrib. : MX-16.1 Metamorphosis
Noyau : 4.7.0-0.bpo.1-amd64
(G)UI : XFCE
Inscription : 31-03-2016

Re : Synaptic est bloqué par un autre programme

Ceci
$

sudo apt-get check


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait



Edit à toto : Séparé la commande seule de son retour est plus lisible par tous.

Hors ligne

#4 19-01-2019 14:02:51

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Synaptic est bloqué par un autre programme

Bonjour smile
As-tu essayé de réinstaller le paquet, il a été installé à partir d'un .deb téléchargé non ?

sudo dpkg -i /cheminversle paquet/nompaquet.deb


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#5 19-01-2019 14:23:17

raleur
Membre
Inscription : 03-10-2014

Re : Synaptic est bloqué par un autre programme

erbou a écrit :

/usr/local/bin/tvmosaic/tvmosaic_reg: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/local/bin/tvmosaic/tvmosaic_reg)


Qu'est-ce que c'est que ce paquet et d'où vient-il ? Non seulement un paquet n'est pas censé utiliser /usr/local (réservé à l'installation manuelle de programmes) mais en plus il a accepté de s'installer alors que ses dépendances ne sont visiblement pas satisfaites.

Dernière modification par raleur (19-01-2019 14:23:53)

Hors ligne

#6 20-01-2019 05:33:16

erbou
Membre
Distrib. : MX-16.1 Metamorphosis
Noyau : 4.7.0-0.bpo.1-amd64
(G)UI : XFCE
Inscription : 31-03-2016

Re : Synaptic est bloqué par un autre programme

Réponse à raleur :
Le paquet .deb vient de ce site qui commercialise un serveur TV :
https://tv-mosaic.com/en/download/
et je l'ai désinstallé lorsque le fournisseur m'a répondu que si tvmosaic ne fonctionnait pas c'est parce que j'avais un noyau trop ancien (celui de debian 8.0)

Réponse à chalu :
Je précise qu'avant d'installer tvmosaic, j'ai demandé au fournisseur si il fonctionnait bien sur debian et pas seulement sur ubuntu; il m'a assuré que oui.
Lorsque je lance la commande suggérée, voici ce que cela donne :
$

sudo dpkg -i tvmosaic-pc-linux-ubuntu-x86_64-1.0.0.deb


Sélection du paquet tvmosaic précédemment désélectionné.
(Lecture de la base de données... 207601 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de tvmosaic-pc-linux-ubuntu-x86_64-1.0.0.deb ...
/usr/local/bin/tvmosaic/tvmosaic_reg: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/local/bin/tvmosaic/tvmosaic_reg)
dpkg : avertissement : le sous-processus ancien script pre-removal a retourné une erreur de sortie d'état 1
dpkg: tentative d'exécution du script du nouveau paquet à la place...
dpkg: ... on dirait que tout a fonctionné correctement.
Dépaquetage de tvmosaic (1.0.0) sur (1.0.0) ...
upgrade
Paramétrage de tvmosaic (1.0.0) ...
/usr/local/bin/tvmosaic/tvmosaic_reg: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/local/bin/tvmosaic/tvmosaic_reg)
dpkg: erreur de traitement du paquet tvmosaic (--install) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Traitement des actions différées (« triggers ») pour systemd (215-17+deb8u8) ...
Des erreurs ont été rencontrées pendant l'exécution :
 tvmosaic


Je crois comprendre que l'état de sortie 1 qui me bloque a été généré par le processus de désinstallation de tvmosaic que j'ai lancé après avoir appris que mon noyau n'était pas à la hauteur.

Edit à toto : Modif faire - Dans le BBCode séparation de la commande root de son retour pour plus de lisibilité par tous.

Hors ligne

#7 20-01-2019 09:15:30

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Synaptic est bloqué par un autre programme

J’ai tenté l’installation en VM sur une stretch et c’est passé.

je l'ai désinstallé lorsque le fournisseur m'a répondu que si tvmosaic ne fonctionnait pas c'est parce que j'avais un noyau trop ancien (celui de debian 8.0)


A ce propos, tu devrais compléter ton profil qui n’est pas très explicite qu’or ceux qui ne suivent pas MX... en ajoutant la version du noyau obtenue avec

uname -a


et le bureau utilisé : xfce ou autre

Il reste à désinstaller ou à tenter de voir si avec un noyau plus récent des backports ça passe.
Pour l’erreur de sortie 1 quand tu veux supprimer, tu peux regarder ici https://doc.ubuntu-fr.org/probleme_apt# … e_d_etat_1 si quelque chose fonctionne.


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#8 20-01-2019 12:14:05

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : Synaptic est bloqué par un autre programme

Bonjour
tu dois pouvoir installer "gdebi" (outil graphique) , il vérifie les dépendances . (et il installe les .deb)

un truc malin c'est d'extraire le contenu du .deb , et de voir ce qu il fait . (différent sous dossiers et fichier )
tu saura en autre ou il installe les fichiers.

si ton programme est installé , il te proposera de le désinstaller. ( clic droit sur le .deb , ouvrir avec gdebi ). sur Mate , gdebi fonctionne (quelques dépendances a installer)

nota: tu trouvera de la documentation sur le net , comment est fait un .deb et comment le construire.

Dernière modification par robert2a (20-01-2019 12:14:43)

Hors ligne

#9 20-01-2019 12:37:55

raleur
Membre
Inscription : 03-10-2014

Re : Synaptic est bloqué par un autre programme

chalu a écrit :

le fournisseur m'a répondu que si tvmosaic ne fonctionnait pas c'est parce que j'avais un noyau trop ancien (celui de debian 8.0)


Visiblement il n'y a pas que le noyau qui est trop ancien ; la version de libstdc++6 aussi, et il n'y en a pas de plus récente dans jessie-backports. Ce paquet a l'air d'être une grosse merde (qui colle aux doigts). erbou peut essayer de forcer la désinstallation en passant --force=all à la commande dpkg, mais sans garantie que ça suffira.

Hors ligne

#10 23-01-2019 03:16:47

erbou
Membre
Distrib. : MX-16.1 Metamorphosis
Noyau : 4.7.0-0.bpo.1-amd64
(G)UI : XFCE
Inscription : 31-03-2016

Re : Synaptic est bloqué par un autre programme

Quand je fais :

$ sudo dpkg --force-all --purge tvmosaic
 


j'obtiens :

(Lecture de la base de données... 207373 fichiers et répertoires déjà installés.)
Suppression de tvmosaic (1.0.0) ...
/usr/local/bin/tvmosaic/tvmosaic_reg: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/local/bin/tvmosaic/tvmosaic_reg)
dpkg: erreur de traitement du paquet tvmosaic (--purge) :
 le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 tvmosaic
 


Dans le fichier .deb que j'ai dégroupé, j'accède au script pre-removal (dénommé prerm) qui contient ceci :

#! /bin/sh
# prerm script for sample1
#
# see: dh_installdeb(1)

TVM_ROOT_DIR="/usr/local/bin/tvmosaic"

set -e

# summary of how this script can be called:
#        * <prerm> `remove'
#        * <old-prerm> `upgrade' <new-version>
#        * <new-prerm> `failed-upgrade' <old-version>
#        * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
#        * <deconfigured's-prerm> `deconfigure' `in-favour'
#          <package-being-installed> <version> `removing'
#          <conflicting-package> <version>
# for details, see /usr/share/doc/packaging-manual/
 


Maintenant, je suis bloqué pour aller plus loin dans la mesure où le fichier .deb ne contient aucun répertoire /usr/share/doc/ et mon Linux non plus.

Hors ligne

#11 23-01-2019 03:20:33

erbou
Membre
Distrib. : MX-16.1 Metamorphosis
Noyau : 4.7.0-0.bpo.1-amd64
(G)UI : XFCE
Inscription : 31-03-2016

Re : Synaptic est bloqué par un autre programme

Oups ! Je me suis trompé, il fallait lire :

"le fichier .deb ne contient aucun répertoire /usr/share/doc/packaging-manual/ et mon Linux non plus".

Hors ligne

#12 23-01-2019 07:19:21

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Synaptic est bloqué par un autre programme

chalu a écrit :


Pour l’erreur de sortie 1 quand tu veux supprimer, tu peux regarder ici https://doc.ubuntu-fr.org/probleme_apt# … e_d_etat_1 si quelque chose fonctionne.


Tu as regardé dans le lien déjà donné si tu avais des pistes ?


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#13 23-01-2019 13:11:39

raleur
Membre
Inscription : 03-10-2014

Re : Synaptic est bloqué par un autre programme

erbou a écrit :

Dans le fichier .deb que j'ai dégroupé, j'accède au script pre-removal (dénommé prerm) qui contient ceci :


C'est tout ? Il y a bien l'initialisation d'une variable d'environnement avec le chemin du répertoire contenant le programme  tvmosaic_reg qui pose problème, mais aucune exécution de ce programme.

PS : pas besoin d'extraire le fichier du .deb, il est déjà installé dans le répertoire /var/lib/dpkg/info/ (préfixé par le nom du paquet).

Hors ligne

#14 23-01-2019 13:24:15

erbou
Membre
Distrib. : MX-16.1 Metamorphosis
Noyau : 4.7.0-0.bpo.1-amd64
(G)UI : XFCE
Inscription : 31-03-2016

Re : Synaptic est bloqué par un autre programme

Réponse à chalut :
Oui, la que j'ai trouvée consistait à s'assurer de la présence d'une commande "set" en début de script et de paramétrer une commande exit à la fin. J'ai effectué tout cela et ça plante pour les mêmes raisons. C'est cela que je me suis tourné vers le fichier . deb

Hors ligne

#15 23-01-2019 15:02:47

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Synaptic est bloqué par un autre programme

Et tu ne pourrais pas migrer vers stretch, elle passe dans 6 mois environ en oldstable et en plus tu pourrais installer ton logiciel.
Édit : c’est idiot apt ne fonctionne plus ! Je n’ai pas réfléchi roll

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#16 23-01-2019 17:14:47

erbou
Membre
Distrib. : MX-16.1 Metamorphosis
Noyau : 4.7.0-0.bpo.1-amd64
(G)UI : XFCE
Inscription : 31-03-2016

Re : Synaptic est bloqué par un autre programme

En fait, j'ai déjà installé MX-17.1 sous Debian Stable 9.4 sur une autre partition : ce fichu tvmosaic fonctionne mais quelques-uns de mes logiciels que j'utilise tous les jours sous MX-16 ne fonctionnent pas sur MX-17 et je tiens absolument à disposer de ma panoplie logicielle que j'ai mis des mois à me créer sur mesure et qui me procure une grande satisfaction chaque jour. Je laisse donc MX-17.1 de côté comme outil de dépannage plus rapide qu'un Live-CD.
Et les rares fois où j'ai besoin de tvmosaic pour programmer un enregistrement TV, je boote sur une partition Windows pour le lancer dans cette version; mais je préfèrerais réduire encore davantage ma dépendance à ce logiciel qui représente moins de 5 % de toute mon activité.

Merci à tous de vos remarques et suggestions.

Hors ligne

#17 23-01-2019 17:33:03

raleur
Membre
Inscription : 03-10-2014

Re : Synaptic est bloqué par un autre programme

Sauf erreur, tu n'as pas répondu à ma question : tu as posté tout le contenu du fichier prerm ?

Hors ligne

#18 23-01-2019 23:34:44

erbou
Membre
Distrib. : MX-16.1 Metamorphosis
Noyau : 4.7.0-0.bpo.1-amd64
(G)UI : XFCE
Inscription : 31-03-2016

Re : Synaptic est bloqué par un autre programme

Désolé, le voici :

#! /bin/sh
# prerm script for sample1
#
# see: dh_installdeb(1)

TVM_ROOT_DIR="/usr/local/bin/tvmosaic"

set -e

# summary of how this script can be called:
#        * <prerm> `remove'
#        * <old-prerm> `upgrade' <new-version>
#        * <new-prerm> `failed-upgrade' <old-version>
#        * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
#        * <deconfigured's-prerm> `deconfigure' `in-favour'
#          <package-being-installed> <version> `removing'
#          <conflicting-package> <version>
# for details, see /usr/share/doc/packaging-manual/

case "$1" in
    remove|upgrade|deconfigure)
  #stop tvmosaic server if it is already running
  if [ -f $TVM_ROOT_DIR/stop.sh ]; then
    $TVM_ROOT_DIR/stop.sh
  fi

        $TVM_ROOT_DIR/reg.sh -reginstall "${TVM_ROOT_DIR}/data/common/product_info/tvmosaic.xml" uninstall

        ;;
    failed-upgrade)
        ;;
    *)
        echo "prerm called with unknown argument \`$1'" >&2
        exit 0
    ;;
esac

# dh_installdeb will replace this with shell code automatically
# generated by other debhelper scripts.

exit 0
 

Hors ligne

#19 23-01-2019 23:51:24

raleur
Membre
Inscription : 03-10-2014

Re : Synaptic est bloqué par un autre programme

Contournement radical : insère la commande suivante en ligne 2.

exit 0

Hors ligne

#20 24-01-2019 04:31:59

erbou
Membre
Distrib. : MX-16.1 Metamorphosis
Noyau : 4.7.0-0.bpo.1-amd64
(G)UI : XFCE
Inscription : 31-03-2016

Re : Synaptic est bloqué par un autre programme

C'est exactement ce que je cherchais sans le trouver : un moyen de rester maître de ma machine en effaçant tout ce que je veux.
J'ai appliqué ta suggestion et ça marche nickel : j'ai lancé Synaptic et fait trois opérations avec succès : suppression complète de tvmosaic, puis installation de anki et, pour finir, suppression complète de anki.
Merci raleur !

Hors ligne

#21 24-01-2019 07:56:06

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Synaptic est bloqué par un autre programme

Quand tu avais essayé plus haut d’ajouter exit 0 d’après le lien que je t’avais donné, ça ne fonctionnait pas car tu l’avais placé tout à la fin du fichier ou à quel endroit ?

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#22 24-01-2019 14:47:03

erbou
Membre
Distrib. : MX-16.1 Metamorphosis
Noyau : 4.7.0-0.bpo.1-amd64
(G)UI : XFCE
Inscription : 31-03-2016

Re : Synaptic est bloqué par un autre programme

J'avais mis

exit 0


à la toute dernière ligne

La solution proposée indiquait aussi de mettre en début de script

set -e


mais je n'avais pas eu à le faire puisque cette ligne existait déjà.

Hors ligne

Pied de page des forums