Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-01-2019 16:03:39

laguespa
Membre
Distrib. : Stretch
Noyau : 4.9.0-4-amd64
(G)UI : Mate
Inscription : 25-09-2009

Installation de rstudio dans testing.

Bonjour.

J'installe rstudio dans buster et je suis embếté avec des dépendances non satisfaites.

J'ai installé r-base et r-base-dev qui sont dans les dépots

aptitude show r-base
 



Paquet : r-base                                        
Version : 3.5.2-1
État: installé
Automatiquement installé: non
Priorité : optionnel
Section : gnu-r
Responsable : Dirk Eddelbuettel <edd@debian.org>
Architecture : all
Taille décompressée : 62,5 k
Dépend: r-base-core (>= 3.5.2-1), r-recommended (= 3.5.2-1)
Recommande: r-base-html, r-doc-html
Suggère: ess, r-doc-info | r-doc-pdf
Description : système de calcul statistique et de graphique GNU R
 R est un système de calcul statistique et de graphiques. Il est composé d'un langage ainsi que d'un environnement
 d'exécution avec des graphiques, un débogueur, un accès à certaines fonctions système et la possibilité d'exécuter des
 programmes stockés dans des fichiers de script.
 




aptitude show r-base-dev
 



Paquet : r-base-dev                                    
Version : 3.5.2-1
État: installé
Automatiquement installé: non
Priorité : optionnel
Section : gnu-r
Responsable : Dirk Eddelbuettel <edd@debian.org>
Architecture : all
Taille décompressée : 15,4 k
Dépend: r-base-core (>= 3.5.2-1), build-essential, gcc, g++, gfortran, libblas-dev | libatlas-base-dev, liblapack-dev |
        libatlas-base-dev, libncurses5-dev, libreadline-dev, libjpeg-dev, libpcre3-dev, libpng-dev, zlib1g-dev, libbz2-dev,
        liblzma-dev, libicu-dev, xauth, pkg-config
Suggère: texlive-base, texlive-latex-base, texlive-generic-recommended, texlive-fonts-recommended, texlive-fonts-extra,
         texlive-extra-utils, texlive-latex-recommended, texlive-latex-extra, texinfo
Description : GNU R installation of auxiliary GNU R packages
 



On trouve l'interface graphique ici : https://www.rstudio.com/products/rstudi … /#download mais apparemment que pour les versions debian 9+.

Toujours est-il que lorsque je fais


dpkg -i rstudio-xenial-1.1.463-amd64.deb
 



Préparation du dépaquetage de rstudio-xenial-1.1.463-amd64.deb ...
Dépaquetage de rstudio (1.1.463) sur (1.1.463) ...
dpkg: des problèmes de dépendances empêchent la configuration de rstudio :
 rstudio dépend de libssl1.0.0 | libssl1.0.2 ; cependant :
  Le paquet libssl1.0.0 n'est pas installé.
  Le paquet libssl1.0.2 n'est pas installé.

dpkg: erreur de traitement du paquet rstudio (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour shared-mime-info (1.10-1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-4) ...
Traitement des actions différées (« triggers ») pour mime-support (3.61) ...
Des erreurs ont été rencontrées pendant l'exécution :
 rstudio
 



J'ai bien essayé apt --fix-broken install et apt-get dist-upgrade mais c'est toujours pareil. J'ai évidemment cherché libssl1.0.0 et libssl1.0.2 mais aucune trace dans les dépots

A+

Dernière modification par laguespa (23-01-2019 16:14:32)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#2 23-01-2019 16:16:02

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.2.0-3-amd64
(G)UI : mutter 3.34.1+git20191022-1
Inscription : 15-02-2016

Re : Installation de rstudio dans testing.

rstudio dépend de libssl1.0.0 | libssl1.0.2 ; cependant :
  Le paquet libssl1.0.0 n'est pas installé.
  Le paquet libssl1.0.2 n'est pas installé.



Ton https://download1.rstudio.org/rstudio-x … -amd64.deb retarde, libssl est trop vieux. Avec buster, nous en sommes à libssl1.1

aptitude search libssl1

i   libssl1.1                       - trousse à outils SSL - bibliothèques parta
p   libssl1.1-dbgsym                - debug symbols for libssl1.1              

Hors ligne

#3 23-01-2019 16:33:20

laguespa
Membre
Distrib. : Stretch
Noyau : 4.9.0-4-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : Installation de rstudio dans testing.

Je me réponds. Visiblement ces paquets sont dans sid. Va falloir que je fasse du pinning buster/sid parce que je ne crois pas qu'installer des paquets plus récents fonctionne.

A+

Dernière modification par laguespa (23-01-2019 16:34:41)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#4 23-01-2019 17:42:07

laguespa
Membre
Distrib. : Stretch
Noyau : 4.9.0-4-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : Installation de rstudio dans testing.

Pour finir j'ai mis sid dans le sources.list et un fichier préférences.

Ça donne :

cat /etc/apt/sources.list



#

# deb cdrom:[Debian GNU/Linux testing _Buster_ - Official Snapshot amd64 NETINST 20190121-04:49]/ buster main

deb http://deb.debian.org/debian/ buster main contrib non-free
#deb-src http://deb.debian.org/debian/ buster main

deb http://security.debian.org/debian-security buster/updates main contrib non-free
#deb-src http://security.debian.org/debian-security buster/updates main

# buster deb-multimedia
deb http://www.deb-multimedia.org buster main non-free

# sid pour rstudio et librairies libssl1.0.0 et libssl1.0.2
deb http://deb.debian.org/debian sid main contrib non-free
 



cat /etc/apt/preferences.d/40sid-et-testing



Package: *
Pin: release n=sid
Pin-Priority: 100
 



A+


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#5 23-01-2019 19:40:25

laguespa
Membre
Distrib. : Stretch
Noyau : 4.9.0-4-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : Installation de rstudio dans testing.

Vous avez sans doute remarqué que dans le sources.list j'ai mis buster et pas testing. Pour quelqu'un qui fait un usage courant de sa machine vous pensez qu'il ne risque pas d'y avoir trop de casse lors des mises à jour de buster ? Je pensais faire un sources.list stable + sid mais bon, ça risque d'être encore plus chiant.
Je rappelle qu'il me faut absolument des paquets qui sont dans sid. Je me suis dit qu'ils descendraient forcément dans buster et que buster deviendrait la nouvelle stable dans pas longtemps. Mon autre hypothèse c'est que la version gratuite de rstudio allait passer à des versions plus récentes des paquets obsolètes que je dois aller cherchre dans sid.

A+

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#6 26-02-2019 12:01:48

close
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-2-amd64
(G)UI : KDE
Inscription : 25-02-2019

Re : Installation de rstudio dans testing.

J'ai eu le même problème. Pour le résoudre, il me semble que j'ai juste téléchargé le package libssl1.0.2 ici https://packages.debian.org/sid/amd64/l … 2/download, je l'ai installé (j'ai pas eu de problème pour les dépendances) et après j'ai pu lancer

 dpkg -i rstudio-xenial-1.1.463-amd64.deb


Et depuis ça marche !

Dernière modification par close (26-02-2019 12:02:03)

Hors ligne

Pied de page des forums