Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-02-2019 21:12:29

debianux
Membre
Distrib. : debian-stretch-9.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.9.0-8-amd64
(G)UI : Xfce 4.12
Inscription : 19-05-2014

netinstall stretch-9.7 sur lenovo x1 extreme: écran noir

Bonjour,

bios efi, mis à jour sous windows en version 1.18, avec 'secureboot', 'csm' et 'quickboot' disabled, démarrage sur clé usb: l'installer démarre : les choix 'graphical expert', 'expert install', 'graphical rescue mode' conduisent à un écran noir.

ce pc a un mode graphique hybride :
https://wiki.archlinux.org/index.php/Hybrid_graphics

It allows power save and low-end 3D rendering by using an Integrated Graphics Processor (IGP); or a major power consumption with 3D rendering performance using a Dedicated/Discrete Graphics Processor (DGP)



il semblerait que c'est l'origine des difficultés rencontrées par l'installateur.
il y a la carte graphique intégrée 'intel uhd graphics 630' et la 'nvidia geforce gtx 1050 ti'.

ici, il semblerait que la gestion 'hybride' ne soit pas maîtrisée :
https://forums.lenovo.com/t5/ThinkPad-X … -p/4286292

ce qui ne donne pas envie de modifier le bios pour passer le mode graphique  en 'discrete' au lieu de 'hybride'.

certains conseillent d'installer 'pop os':
https://dunia-it.com/heres-the-best-lin … 1-extreme/

avez-vous entendu parler d'expérience d'installation réussie d'une version debian sur ce pc ?

merci d'avance.
cordialement
debianux

Hors ligne

#2 12-02-2019 00:38:21

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : netinstall stretch-9.7 sur lenovo x1 extreme: écran noir

Bonjour
si j'avais une machine de ce genre entre les mains personnellement je vais au bout des choses. tongue
déjà installateur Buster , si possible avec nomodeset en options , installation minimale classic (pas graphique) CSM et EFI activé , le reste désactivé
la difficulté est de réussir une install minimale et de passer le petit bout de noyau qui sert initialiser l'installation. (juste après le choix du type d'installation )
il y a des choses a désactiver comme l'option "tpm" (module de sécurité) et autres (je connais pas les bios des portables , certains a priori sont tordus roll  )

au niveau matériel Buster est a la hauteur , passé ce souci d'installation (écran noir au lancement de l'installation) , il a ce qu il faut , y compris bumblebee pour le mode hybrid

il y a pas longtemps un lenovo 330  => https://debian-facile.org/viewtopic.php?id=23548
a priori pour lui pas de souci avec l'installation (juste un problème de luminosité et sa carte nvidia)
pas trouvé de fils sur ta marque et type de portable sur le forum D_F
j'ai lu ton lien a propos de Pop! _OS ,   pas de précision sur le démarrage de l'installation avec cet OS , il utilise le nonfree ce qui résous pas mal de problèmes . roll

nota: pour le mode 'hybride' n' hésite pas a le désactiver , après il peut être remit en fonction quand l'installation est correcte .
pour le choix du type d'installation , il doit y avoir moyen de passer des options au noyau et peut être éviter cet écran noir.

iso buster =>  https://www.debian.org/devel/debian-installer/

Dernière modification par robert2a (12-02-2019 02:53:51)

En ligne

#3 12-02-2019 20:33:52

debianux
Membre
Distrib. : debian-stretch-9.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.9.0-8-amd64
(G)UI : Xfce 4.12
Inscription : 19-05-2014

Re : netinstall stretch-9.7 sur lenovo x1 extreme: écran noir

Bonjour robert2a,
et merci de t'intéresser à cette question !

1/ ici:
https://debian-facile.org/doc:install:d … -de-l-uefi

Désactiver le mode CSM ou Launch CSM : le mettre en mode DISABLED ou NEVER.
    Sous l'onglet “Security” ou “Authentication”, vérifions que “secure boot” est bien en mode DISABLED ou NEVER (Désactivé). Si ce n'est pas le cas, faisons la modification.
    Il est aussi conseillé de désactiver Fast Boot (démarrage rapide) si l'option existe dans notre UEFI.

  pour quelle raison penses-tu qu'il faut activer le 'csm' dans ce cas ?

2/

EFI activé

: qu'est-ce et dans quelle page du bios en principe ?

3/

pour le mode 'hybride' n' hésite pas a le désactiver

ici: https://forums.lenovo.com/t5/ThinkPad-X … 92/page/24

This is the first time that making a change in the BIOS has resulted in the motherboard needing to be replaced.

  apparemment ce n'est pas si simple avec ce bios et pas très encourageant sad

mon projet était de refaire une installation comme celle de mon profil : debian-stretch-9.7_LVM-chiffré_dual-boot-uefi-w10, qui n'est pas non plus d'une grande simplicité
alors me lancer dans une installation testing, je crains de ne pas avoir le niveau.

ici:
https://www.forbes.com/sites/jasonevang … 1a51596bb3
test non concluant avec ubuntu 18.10, basé, sauf erreur, sur le kernel 4.18, alors que debian buster est effectivement basé sur la version 4.19.
j'ai cru comprendre que buster ne sortirait pas avant mars.
donc peut-être tenter pop-os en attendant...

Hors ligne

#4 13-02-2019 02:57:36

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : netinstall stretch-9.7 sur lenovo x1 extreme: écran noir

Bonsoir

oui je raisonne PC de bureau , le mode CSM  pour moi c'est boot mbr et EFI (compatibilité maximum) pour le disque système
et EFI sans sécure key (OS windows => autres)
pour Buster je te le conseille en fonction du matériel de ce portable
Pour Mars 2019 buster stable , il ne faut pas y compter , plutôt juin ou plus tard .
Oui ubuntu 18.10 est l'équivalent de debian testing .
J'ai répondu un peu vite vue que je connais pas ce matériel et son bios , ni du LVM-chiffré et encore moins du dual boot
Désolé hmm

En ligne

#5 06-04-2019 10:30:07

debianux
Membre
Distrib. : debian-stretch-9.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.9.0-8-amd64
(G)UI : Xfce 4.12
Inscription : 19-05-2014

Re : netinstall stretch-9.7 sur lenovo x1 extreme: écran noir

bonjour,
donc en attendant une version debian 'compatible', j'ai installé pop-os en dual boot sur lvm chiffré, avec les 'péripéties' racontées ici https://www.reddit.com/r/pop_os/comment … ypted_lvm/, si ça peut dépanner smile

Hors ligne

Pied de page des forums