Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-02-2019 13:44:00

wawananda
Membre
Distrib. : MX-18.1_x64 Continuum
Noyau : Linux 4.19.0-1-amd64
Inscription : 21-07-2017

Problème pour installer vlc [RÉSOLU]

Je ne parviens pas à installer vlc via le terminal :

GASNIERAC@GASNIERAC:~
$ sudo apt-get install vlc
[sudo] Mot de passe de GASNIERAC :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 vlc : Dépend: vlc-plugin-base (= 3.0.6-0.1~mx17+1) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
GASNIERAC@GASNIERAC:~
 



voilà ce que donne :

GASNIERAC@GASNIERAC:~
$ inxi -r
Repos:     Active apt repos in: /etc/apt/sources.list.d/antix.list
           1: deb http://la.mxrepo.com/antix/stretch/ stretch main
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list
           1: deb http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list
           1: deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
           2: deb http://security.debian.org/ stretch/updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/mx.list
           1: deb http://mxrepo.com/mx/repo/ stretch main non-free
           Active apt repos in: /etc/apt/sources.list.d/sources.list
           1: deb http://deb.debian.org/debian/ stretch main contrib non-free
           2: deb-src http://deb.debian.org/debian/ stretch main contrib non-free
           3: deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
           4: deb-src http://deb.debian.org/debian/ stretch-updates main contrib non-free
           No active apt repos in: /etc/apt/sources.list.d/various.list
           No active apt repos in: /etc/apt/sources.list.d/wine.list
GASNIERAC@GASNIERAC:~




Et lorsque j'utilise le gestionnaire de paquets synaptics, il m'indique des paquets cassés impossibles à réparer.

Merci d'avance

Dernière modification par wawananda (24-02-2019 02:39:43)

Hors ligne

#2 23-02-2019 06:43:06

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : Problème pour installer vlc [RÉSOLU]

Bonjour

au vue du nombre des sources.list utilisés trop compliqué pour moi
a priori tu est en testing  =>  https://en.wikipedia.org/wiki/MX_Linux

il serait bien de donner ici la listes des paquets cassés. (que te signale synaptic )
nota: tu a des outils comme apt , apt-get , dpkg , aptitude , synaptic pour tenter de réparer.
déjà pas évident sur une pure debian , aucune idée pour te sortir de ce problème.

je suppose que ton système est bloqué , impossible de retirer ou installer quelque chose et mettre a jour roll

PS: si j'ai bien compris , la base est une debian stretch avec des paquets plus récents comme le noyau par exemple

Dernière modification par robert2a (23-02-2019 06:47:40)

Hors ligne

#3 23-02-2019 07:37:45

Herve33
Membre
Lieu : Mérignac 33
Distrib. : Debian 10
(G)UI : Xfce
Inscription : 21-09-2016

Re : Problème pour installer vlc [RÉSOLU]

Bonjour,
non il est sur MX Linux apparemment. As-tu été sur leur forum voir si d'autres ont ce problème ?
Je vois que tu as des dépendances non satisfaites:

Les paquets suivants contiennent des dépendances non satisfaites :
 vlc : Dépend: vlc-plugin-base (= 3.0.6-0.1~mx17+1) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


Essaye déjà de commencer par là.


Acer Aspire 5733 - Debian 10 Xfce

Hors ligne

#4 23-02-2019 07:39:23

Herve33
Membre
Lieu : Mérignac 33
Distrib. : Debian 10
(G)UI : Xfce
Inscription : 21-09-2016

Re : Problème pour installer vlc [RÉSOLU]

Oui je vois que tu as déjà exposé ton problème:
https://forum.mxlinux.org/viewtopic.php?t=48645

Acer Aspire 5733 - Debian 10 Xfce

Hors ligne

#5 23-02-2019 07:45:02

Herve33
Membre
Lieu : Mérignac 33
Distrib. : Debian 10
(G)UI : Xfce
Inscription : 21-09-2016

Re : Problème pour installer vlc [RÉSOLU]

Essaye d'aller dans sources de logiciels ( par les paramètres généraux ou menu/préférences/sources de logiciels, dans l'onglet autres logiciels enlever tout ce qui concerne videolan et vlc et reinstaller vlc normalement via la logithèque MX.
Dis nous ce que ça donne.

Acer Aspire 5733 - Debian 10 Xfce

Hors ligne

#6 23-02-2019 14:58:38

potemkine17
Membre
Distrib. : Débian Buster
Noyau : i386
(G)UI : LXDE
Inscription : 17-09-2014

Re : Problème pour installer vlc [RÉSOLU]

Bonjour,
je n'ai pas eu  ce problème. Quand tes paquets seront réparés ( "dpkg --configure -a" suffit souvent), regarde du côtè de ce  dépot: "http://www.deb-multimedia.org/ stretch non-free main". Est-il decommenté dans ton fichier /etc/apt/sources.list.d/debian.list ? Essaye de relancer l'installation après l'avoir fait.

Hors ligne

#7 24-02-2019 02:38:05

wawananda
Membre
Distrib. : MX-18.1_x64 Continuum
Noyau : Linux 4.19.0-1-amd64
Inscription : 21-07-2017

Re : Problème pour installer vlc [RÉSOLU]

j'ai appliqué ce que préconise potemkine17 en ajoutant

deb http://www.deb-multimedia.org/ stretch non-free main


dans le fichier

/etc/apt/sources.list.d/debian.list



et j'ai pu installer vlc sans problème.
Merci beaucoup

Edit à toto :  J'ai édité ton message pour le rendre plus lisible. Je te laisse cliquer sur le lien Modifier au bas à droite de ce post pour voir comment le bb-code est utilisé pour ça.
Voir le tuto : Le code, ça pique moins les yeux en couleur

Hors ligne

Pied de page des forums