Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-03-2019 15:15:51

Elliiana
Membre
Distrib. : Debian 8.8
Noyau : Linux 3.16.0-4-amd64
Inscription : 21-06-2017

[Résolu] Problème installation paquet Samba et Bind9

Bonjour à tous,

J'ai un problème dans l'installation de paquet.
Je suis sur Debian 8 (oui, on est passé sur 9, mais je travail dans un centre de formation, et les sujets d'examen sont encore sur Debian 8).
J'essaye de transformer ma machine Debian 8 en serveur Samba AD en installant les paquets :

apt-get install samba winbind libnss-winbind krb5-user smbclient



Cela me renvoi :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libnss-winbind : Dépend: samba-libs (= 2:4.2.14+dfsg-0+deb8u9) mais ne sera pas installé
 samba : Dépend: python-ntdb mais ne sera pas installé
         Dépend: python-samba mais ne sera pas installé
         Dépend: samba-common-bin (= 2:4.2.14+dfsg-0+deb8u9) mais ne sera pas installé
         Dépend: samba-dsdb-modules mais ne sera pas installé
         Dépend: libpython2.7 (>= 2.7) mais ne sera pas installé
         Dépend: samba-libs (= 2:4.2.14+dfsg-0+deb8u9) mais ne sera pas installé
         Recommande: samba-vfs-modules mais ne sera pas installé
 smbclient : Dépend: libsmbclient (>= 2:4.0.3+dfsg1) mais ne sera pas installé
             Dépend: samba-libs (= 2:4.2.14+dfsg-0+deb8u9) mais ne sera pas installé
 winbind : Dépend: samba-libs (= 2:4.2.14+dfsg-0+deb8u9) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 



Je suis connectée à internet, je ping Google, ma résolution de nom fonctionne.
Mon fichier /etc/apt/sources.list est :

deb http://ftp.fr.debian.org/debian/ jessie main
#deb-src http://ftp.fr.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
#deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ jessie-updates main
#deb-src http://ftp.fr.debian.org/debian/ jessie-updates main
 


J'ai bien évidemment fait un update et un upgrade.

J'ai toujours le même problème, idem en voulant faire de mon serveur un serveur DNS en installant "bind9 bind9utils dnsutils".

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
dnsutils est déjà la plus récente version disponible.
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 bind9 : Dépend: libbind9-90 (= 1:9.9.5.dfsg-9+deb8u15) mais 1:9.9.5.dfsg-9+deb8u16 devra être installé
         Dépend: libdns100 (= 1:9.9.5.dfsg-9+deb8u15) mais 1:9.9.5.dfsg-9+deb8u16 devra être installé
         Dépend: libisc95 (= 1:9.9.5.dfsg-9+deb8u15) mais 1:9.9.5.dfsg-9+deb8u16 devra être installé
         Dépend: libisccc90 (= 1:9.9.5.dfsg-9+deb8u15) mais 1:9.9.5.dfsg-9+deb8u16 devra être installé
         Dépend: libisccfg90 (= 1:9.9.5.dfsg-9+deb8u15) mais 1:9.9.5.dfsg-9+deb8u16 devra être installé
         Dépend: liblwres90 (= 1:9.9.5.dfsg-9+deb8u15) mais 1:9.9.5.dfsg-9+deb8u16 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 



J'ai vraiment besoin de votre aide pour résoudre ce problème, qui arrive de manière assez récurrente et qui me bloque vraiment.
Merci d'avance de votre aide précieuse !

Dernière modification par Elliiana (04-03-2019 16:36:33)

Hors ligne

#2 04-03-2019 15:50:03

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu] Problème installation paquet Samba et Bind9

Bonjour,

Essaie avec des sources oldstables non libres.
Le tuto :
https://debian-facile.org/doc:systeme:a … -non-libre

Sinon migrer tes sources oldstables vers la stable actuelle :
https://debian-facile.org/doc:apt:sourc … -non-libre

Dernière modification par smolski (04-03-2019 15:54:09)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 04-03-2019 16:18:08

Elliiana
Membre
Distrib. : Debian 8.8
Noyau : Linux 3.16.0-4-amd64
Inscription : 21-06-2017

Re : [Résolu] Problème installation paquet Samba et Bind9

Bonjour Smolski,

Ta première solution fonctionne ! Merci beaucoup !!!

Donc si je comprends bien, dans les paquets que je souhaite installer, il y a des dépendances qui ne sont pas libres, donc elles ne s'installent pas ? Arrête-moi si je me trompe !
Mais comment cela se fait-il qu'assez régulièrement cela fonctionne quand même ? Car une fois sur 3 je rencontre ce problème de téléchargement, mais les deux autres fois je n'ai pas de soucis.

De plus, concernant ta seconde proposition, je peux mettre les sources de Debian 9 alors que je suis sur la 8 ? Cela ne pose pas de problème ?
Je ne savais pas qu'on pouvait faire cela.

En restant dans le thème de serveur Samba / DNS, y a -t-il beaucoup de différences entre l'administration : installation / configuration de ces serveurs entre jessie et stretch ?

Hors ligne

#4 04-03-2019 16:28:21

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Problème installation paquet Samba et Bind9

Elliiana a écrit :

Donc si je comprends bien, dans les paquets que je souhaite installer, il y a des dépendances qui ne sont pas libres, donc elles ne s'installent pas ? Arrête-moi si je me trompe !


Je t'arrête. Tous ces paquets et leurs dépendances sont libres. C'est juste une coincidence.
La liste des paquets n'était pas à jour, apt-get cherchait à installer d'anciennes versions. Je soupçonne que c'est juste la mise à jour de la liste avec apt-get update qui a corrigé la situation.

Elliiana a écrit :

je peux mettre les sources de Debian 9 alors que je suis sur la 8 ? Cela ne pose pas de problème ?


Il s'agit d'une mise à niveau (ou migration) de Debian 8 vers 9, et cela implique un peu plus que changer les sources et faire un upgrade pour que ça se passe bien. Il est important de suivre le chapitre dédié dans les notes de publication de Debian 9 (lien sur la page d'accueil du site officiel Debian).


Il vaut mieux montrer que raconter.

Hors ligne

#5 04-03-2019 16:36:05

Elliiana
Membre
Distrib. : Debian 8.8
Noyau : Linux 3.16.0-4-amd64
Inscription : 21-06-2017

Re : [Résolu] Problème installation paquet Samba et Bind9

raleur a écrit :

Elliiana a écrit :

Donc si je comprends bien, dans les paquets que je souhaite installer, il y a des dépendances qui ne sont pas libres, donc elles ne s'installent pas ? Arrête-moi si je me trompe !


Je t'arrête. Tous ces paquets et leurs dépendances sont libres. C'est juste une coincidence.
La liste des paquets n'était pas à jour, apt-get cherchait à installer d'anciennes versions. Je soupçonne que c'est juste la mise à jour de la liste avec apt-get update qui a corrigé la situation.


Ok je comprends. Mais ca m'étonnes quand même car j'ai réalisé plusieurs fois le apt-get update.


raleur a écrit :

Il s'agit d'une mise à niveau (ou migration) de Debian 8 vers 9, et cela implique un peu plus que changer les sources et faire un upgrade pour que ça se passe bien. Il est important de suivre le chapitre dédié dans les notes de publication de Debian 9 (lien sur la page d'accueil du site officiel Debian).


D'accord, je comprends mieux, cela me paraît plus logique.

Merci beaucoup à vous deux pour votre aide !

Dernière modification par Elliiana (04-03-2019 16:48:42)

Hors ligne

#6 04-03-2019 16:55:44

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu] Problème installation paquet Samba et Bind9

Pour la migraton de la oldstable à la stable, y'a un tuto df :
https://debian-facile.org/doc:migrer cool

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#7 04-03-2019 17:31:54

Elliiana
Membre
Distrib. : Debian 8.8
Noyau : Linux 3.16.0-4-amd64
Inscription : 21-06-2017

Re : [Résolu] Problème installation paquet Samba et Bind9

Merci !

Mais dans ma dernière question, je ne parlais pas de migration. Je m'explique.
J'ai appris à monter ces serveurs sur Debian 8.
Est-ce que si je reprends mes cours et mes procédures, et que je les applique sur une Debian 9 cela va fonctionner, ou bien y a -t-il des changements ? Dans ce cas il faut que je m'actualise sur ces parties-là.

Dernière modification par Elliiana (04-03-2019 18:07:32)

Hors ligne

#8 04-03-2019 17:59:47

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu] Problème installation paquet Samba et Bind9

Elliiana a écrit :

dans ma dernière question, je ne parlais pas forcément de migration


Effectivement, ton post est résolu maintenant.

Ouvre un nouveau topic dans la section Installation debian pour ce qui concerne la migration.

Tu peux y mettre un lien vers ce post-ci et vice et versa si tu veux les relier... wink


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums