Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 16-04-2019 14:36:54

Mak-chan
Membre
Inscription : 15-06-2018

[Résolu] Erreur de GPG, sources.list -Debian 8-

Bonjour à tous,
Oui ceci est un Post/Problème vraiment très similaire à celui de Mr.Robot.
Je ne savais pas s'il était préférable de rallonger le siens de mon problème où d'en créer un nouveau car les différentes solutions amenées sur son billet ne mènent à rien chez moi...

Depuis peu, il m'est impossible de mettre à jour mes paquets sur une Debian Jessie 8.7

Linux server-vehiclefs 3.16.0-7-amd64 #1 SMP Debian 3.16.59-1 (2018-10-03) x86_64 GNU/Linux


Un Update me renvoyant toujours à une erreur de GPG tel que :

 [...]
Ign https://packages.sury.org jessie/main Translation-fr_FR
Réception de : 21 https://packages.sury.org jessie/main Translation-fr [1 441 B]
Ign https://packages.sury.org jessie/main Translation-fr
Réception de : 22 https://packages.sury.org jessie/main Translation-en [1 441 B]
Ign https://packages.sury.org jessie/main Translation-en
Atteint https://packages.sury.org jessie/main amd64 Packages [1 441 B]
6 747 o réceptionnés en 4s (1 561 o/s)
Lecture des listes de paquets... Fait
W: Erreur de GPG : https://packages.sury.org jessie InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY B188E2B695BD4743



J'ai essayé :

1) De minimiser/nettoyer mon source.list tel que :

#
# deb cdrom:[Debian GNU/Linux 8.7.1 _Jessie_ - Official amd64 NETINST Binary-1 $
#deb cdrom:[Debian GNU/Linux 8.7.1 _Jessie_ - Official amd64 NETINST Binary-1 2$

deb http://deb.debian.org/debian/ jessie main
deb-src http://deb.debian.org/debian/ jessie main

#deb http://ftp.fr.debian.org/debian/ jessie main
#deb-src http://ftp.fr.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
#deb http://ftp.fr.debian.org/debian/ jessie-updates main
#deb-src http://ftp.fr.debian.org/debian/ jessie-updates main


Je n'ai techniquement laissé que le principal et le Security, testé sur le FTP.FR comme le dépôt global (deb.debian.org) sans différence.

2) De nettoyer les paquets téléchargés/les clés :

rm /var/lib/apt/lists/*
rm /var/lib/apt/lists/partial/*
apt clean
rm /etc/apt/trusted.gpg
apt-get update


Mais cela ne change rien

3) De suivre des Directives de Correction :

apt-get install gnupg
gpg --keyserver hkp://wwwkeys.eu.pgp.net --recv-keys B188E2B695BD4743


gpg: demande de la clef 95BD4743 sur le serveur hkp wwwkeys.eu.pgp.net
gpgkeys: key B188E2B695BD4743 can't be retrieved
gpg: aucune donnée OpenPGP valable n'a été trouvée.
gpg:       Quantité totale traitée : 0


J'ai aussi essayé avec les 3 serveurs à interroger (hkp://wwwkeys.eu.pgp.net || hkp://wwwkeys.pgp.net || pgpkeys.mit.edu)
Tenté d'installé le paquet conseillé :

apt-get install deb-multimedia-keyring


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet deb-multimedia-keyring




4) D'ajouter les sources non-libres :

#debian jessie 8
deb http://deb.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/debian-security jessie/updates main contrib non-free
deb http://deb.debian.org/debian/ jessie-updates main contrib non-free
deb http://deb.debian.org/debian/ jessie-backports main contrib non-free
 


Mais cela renvois la même erreur :


Ign http://deb.debian.org jessie-backports/contrib Translation-fr_FR
Ign http://deb.debian.org jessie-backports/contrib Translation-fr
Ign http://deb.debian.org jessie-backports/contrib Translation-en
Ign http://deb.debian.org jessie-backports/main Translation-fr_FR
Ign http://deb.debian.org jessie-backports/main Translation-fr
Ign http://deb.debian.org jessie-backports/main Translation-en
Ign http://deb.debian.org jessie-backports/non-free Translation-fr_FR
Ign http://deb.debian.org jessie-backports/non-free Translation-fr
Ign http://deb.debian.org jessie-backports/non-free Translation-en
13,7 Mo réceptionnés en 27s (504 ko/s)
W: Erreur de GPG : https://packages.sury.org jessie InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY B188E2B695BD4743
W: Impossible de récupérer http://deb.debian.org/debian/dists/jessie-updates/InRelease  Impossible de trouver l'entrée « main/binary-amd64/Packages » attendue dans le fichier « Release » : ligne non valable dans sources.list ou fichier corrompu
 


Avec quelques erreurs sur les backports mais rien de nouveau autrement ..

J'en suis à ne plus savoir quoi faire ni où chercher ..
Des courageux/volontaires ? 8)

Dernière modification par Mak-chan (16-04-2019 16:59:27)

Hors ligne

#2 16-04-2019 14:44:21

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : [Résolu] Erreur de GPG, sources.list -Debian 8-

Bonjour,
Tu peux supprimer la ligne avec jessie-updates du point 4) car ce dépôt n’existe plus.
Pour le problème initial sur la clé du dépôt externe sury, il me semble qu’il a été posé sur le forum mais n’est peut-être pas résolu.
Édit :
D'après èfpé, ton problème devrait être résolu avec ceci

apt-key adv --recv-keys B188E2B695BD4743


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#3 16-04-2019 16:51:26

Mak-chan
Membre
Inscription : 15-06-2018

Re : [Résolu] Erreur de GPG, sources.list -Debian 8-

Merci pour ce retour très rapide en premier lieu =)
J'ai eu un très léger espoir mais la commande me retourne que GPG à besoin d'un serveur :

apt-key adv --recv-keys B188E2B695BD4743
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.YvJtEcyvOI --no-auto-check-trustdb --trust-model always --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-security-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-stretch-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-stretch-security-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-stretch-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-stable.gpg --keyring /etc/apt/trusted.gpg.d/php.gpg --recv-keys B188E2B695BD4743
gpg: pas de serveur de clefs connu (utilisez l'option --keyserver)
gpg: échec de réception depuis le serveur de clefs : mauvais URI



Et malheureusement, j'ai déjà essayé quelque chose de semblable avec l'option --keyserver :

Mak-chan a écrit :

[...]

apt-get install gnupg
gpg --keyserver hkp://wwwkeys.eu.pgp.net --recv-keys B188E2B695BD4743


gpg: demande de la clef 95BD4743 sur le serveur hkp wwwkeys.eu.pgp.net
gpgkeys: key B188E2B695BD4743 can't be retrieved
gpg: aucune donnée OpenPGP valable n'a été trouvée.
gpg:       Quantité totale traitée : 0


J'ai aussi essayé avec les 3 serveurs à interroger (hkp://wwwkeys.eu.pgp.net || hkp://wwwkeys.pgp.net || pgpkeys.mit.edu)
Tenté d'installé le paquet conseillé :

apt-get install deb-multimedia-keyring


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet deb-multimedia-keyring


[...]



Et un mélange des 2 amène au même résultat ;_; :

root@mamachine:/etc/apt# apt-key adv --keyserver hkp://wwwkeys.eu.pgp.net --recv-keys B188E2B695BD4743
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.WCCMwwPF4t --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-security-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-stretch-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-stretch-security-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-stretch-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-stable.gpg --keyring /etc/apt/trusted.gpg.d/php.gpg --keyserver hkp://wwwkeys.eu.pgp.net --recv-keys B188E2B695BD4743
gpg: demande de la clef 95BD4743 sur le serveur hkp wwwkeys.eu.pgp.net
gpgkeys: key B188E2B695BD4743 can't be retrieved
gpg: aucune donnée OpenPGP valable n'
a été trouvée.
gpg:       Quantité totale traitée : 0




[EDIT]
C'est bon au final ! :'D
Un mélange des 2 solutions ET l'utilisation d'un autre serveur PGP (pgpkeys.mit.edu) à résolu mon problème !! :


apt-key adv --keyserver pgpkeys.mit.edu --recv-keys B188E2B695BD4743


gpg: demande de la clef 95BD4743 sur le serveur hkp pgpkeys.mit.edu
gpg: clef 95BD4743 : clef publique « DEB.SURY.ORG Automatic Signing Key <deb@sury.org> » importée
gpg:       Quantité totale traitée : 1
gpg:                     importées : 1  (RSA: 1)
 



Merci infiniment de m'avoir aiguiller, je n'étais pas si loin mais j'y ai passé mon aprèm et suis on ne peux plus ravis que ce problème se soit vu résolu dans la journée au final !
Je passe mon billet en Résolu et je suis refait pour la journée ! ♫
Un gros MERCI !
[/EDIT]

Dernière modification par Mak-chan (16-04-2019 17:10:38)

Hors ligne

Pied de page des forums