Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-04-2019 11:46:51

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

[obtenu] commande pour vérifier version opengl ?

Salut à tous le monde,

Je suis en discusssion avec le support d'un soft d'impression 3D (Flashprint)
Leur dernière version ne pouvait pas s'installer sur mon Debian9 mais grace à èfpé l'installation a été rendue possible wink
Je suis tombé aussi sur un moins mauvais de leur support qui va sortir une nouvelle version avec tests faits sur Debian9 wink

Il m'a demandé si j'avais des sugestions et comme j'ai du bug dans l'affichage, je ne me suis pas privé...
Problème il me demande de lancer la commande suivante que je ne connais pas du tout :

gcc OpenGL_version.c -o OpenGL_version -lglut -lGL -lGLU


Et comme j'ai pas envie de casser mon beau Debian, je me renseigne wink

Dernière modification par statis (24-06-2019 15:28:20)


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#2 29-04-2019 18:47:23

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : [obtenu] commande pour vérifier version opengl ?

Tu peux installer mesa-utils

apt install mesa-utils


et ensuite

glxinfo | grep OpenGL


Ça te permettra de connaître ta version d'OpenGL.

Ta commande permet de compiler du code en C (ne cassera pas ton système), qui sort (pour les gens du forum) d'on ne sais où
et on ne sait pas exactement ce qu'il fait. Ta commande par ailleurs ne fait que compiler et n’exécute rien.
Tu nous donnes pas assez d'infos de ce côté là, sur les essais et les problèmes que tu as pu avoir, le comment tu es arrivé là smile.

Bon courage

PS: si tu pouvais nous donner un peu plus d'info sur ta démarche smile

Dernière modification par naguam (29-04-2019 18:53:55)

Hors ligne

#3 29-04-2019 22:50:45

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : [obtenu] commande pour vérifier version opengl ?

merci naguam,

Cette commande m'a été donnée par le support du logiciel sans aucune explication.
Les problèmes que je rencontre sont dans l'affichage du modèle 3D après opérations de découpe.
En impression 3D l'objet est découpé en tranches avec les mouvements de dépot de matière couche par couche.
L'objet est vu correctement mais une fois "découpé" les couches forment un brouillard 3D  qui ne permet pas de voir les détails, ce qui ne devrait pas être le cas.
Le logiciel ne prend pas bien en charge des cartes graphiques anciennes ou le driver "non-free" nvidia a du bug...
Perso je pense que c'est au logiciel de s'adapter d'autant plus que les détails 3D "quand çà fonctionne" ne sont pas d'un niveau élevé comme par exemple dans Blender qui lui fonctionne sur des cartes graphiques encore plus vieilles que la mienne.
Si la commande en donne pas d'infos et ne sert à rien je vais encore me fâcher avec la support...

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#4 30-04-2019 18:34:08

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : [obtenu] commande pour vérifier version opengl ?

Le commandes que je t'ai donné te permettent de connaitre ta version d'OpenGL sans leur programme, après, cela pourrait être bien que tu nous donne ta configuration matérielle exacte (si laptop, ou tour pré montées par un constructeur, le modèle, ou la référence sur une étiquette quelque part sur la machine).

Leur commande est censé compiler un programme que tu peux exécuter mais ils te disent pas comment (mais ça c'est pas dur on pourra te le dire), seulement tu nous dis pas si tu as le fichier OpenGL_version.c dans le répertoire ou tu te trouve avec ton terminal.

Bref, peux-tu appliquer les deux commandes que je t'ai donné (en prenant bien en compte, en root et en user) et me donner le retour de la seconde.
Aussi nous donner, comme dis dans ce post les info de ton matériel, ou donner le retour de

lspci

Dernière modification par naguam (30-04-2019 18:35:44)

Hors ligne

#5 30-04-2019 21:30:14

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : [obtenu] commande pour vérifier version opengl ?

merci naguam,

mesa-utils était déjà installé

glxinfo | grep OpenGL


OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 610/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 390.116
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 390.116
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 390.116
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
 



lspci



00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 2 (rev 01)
00:1c.2 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 3 (rev 01)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation NM10/ICH7 Family SATA Controller [IDE mode] (rev 01)
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 01)
01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 610] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GF119 HDMI Audio Controller (rev a1)
03:00.0 Ethernet controller: Qualcomm Atheros AR8132 Fast Ethernet (rev c0)
 



Comme tu peux le voir ma carte graphique est une nvidia GT610
Je ne supporte pas les "PC constructeur", j'aime choisir ce que je met dans mon boîtier.
Ma tour est maintenant très "vieille", la carte mère une MSI G41M-P28 a été configuré au maximum de ses possibilités, proc 4 cœurs 3g et 8g de RAM.
La carte graphique intégrée a été supplantée par l'ajout de la GT610.

Dans le retour de commande, je ne vois pas bien quelle est la version openGL il y du 4.5 du 4.6 et du 3.2...

Je sens que la réponse du support Flashforge va être "carte trop vieille" donc ne te fatigue pas naguam
Le support m'a demandé des suggestions mais ils ne feront jamais l'effort de penser au vieux matériel.

Franchement je suis très fatigué de toutes ces évolutions matérielles...
J'ai connu le Sinclair ZX80 et ma première machine était un Jupiter Ace (en Forth résident), cette époque était géniale maintenant j'envie les moines tibétains qui vivent une vie magique en "rêve lucide" car ce niveau ne sera jamais atteint avec la réalité virtuelle du 4ème millénaire wink

Petit rajout...
Je viens d'essayer Cura, un autre soft d'impression 3D (qui ne peut piloter la Flashforge) et leurs programmeurs ont pensé au vieux matos, non seulement la "découpe" n'est pas un brouillard graphique mais en plus on peut voir les déplacements et donc les chemins pris par la buse d'impression.
Cura est un logiciel open source qui ne se restreint pas à une imprimante constructeur mais qui est ouvert à tous...

Dernière modification par statis (30-04-2019 21:50:27)


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#6 30-04-2019 22:25:15

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : [obtenu] commande pour vérifier version opengl ?

Vu la version du driver installé et la version d'OpenGL, ta carte graphique n'est certainement pas trop ancienne, je réfléchis aux possibilitées les plus simples. (Le 3.2 c'est OpenGL ES, 4.5, c'est le core et 4.6 c'est le maximum dispo par le driver il me semble).

Dernière modification par naguam (30-04-2019 22:26:30)

Hors ligne

#7 30-04-2019 22:57:59

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : [obtenu] commande pour vérifier version opengl ?

merci naguam...

Dernière modification par statis (30-04-2019 22:58:15)


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#8 17-06-2019 18:48:31

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : [obtenu] commande pour vérifier version opengl ?

petite mise à jour,
le support Flashprint n'a toujours pas trouvé de solution...

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#9 21-06-2019 22:33:00

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : [obtenu] commande pour vérifier version opengl ?

Faudrait que je teste sur mon ordi (qui n'a pas ton gpu et est sous debian buster et vérifier le fonctionnement) ça, mais ça devra attendre la semaine prochaine

Hors ligne

#10 22-06-2019 11:13:20

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : [obtenu] commande pour vérifier version opengl ?

Merci naguam,

Mais ne te fatigue pas, je pense que Flashprint version linux et la GT610 ne font pas bon ménage.
Sur Windows 10 (problème de driver f.ck MS) il n'y a que la plus ancienne version qui rencontre 0 défaut dans l'affichage et un max d'insuffisances sur le reste.
Flashforge est une marque chinoise dite de qualité qui n'a pas moins de 11 modèles dans sa gamme :
http://www.flashforge.com
Cura, le même type de soft qui pilote toute imprimante 3D GPL, fonctionne très bien sur la GT610 mais pas sur ma Flashforge Dreamer.
Et dire que la 5G qui va arriver pour nos téléphones mobiles sera sur du matos chinois...

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#11 22-06-2019 11:36:25

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : [obtenu] commande pour vérifier version opengl ?

Tu sais les 2/3 3/4 du matos dis pas chinois est fabriqué en chine...
Moi ce qui m’embête c'est que les grands/gros pays contrôle le monde, les Us se permettent tout jusqu'à imposer à tout pays leurs principes : notamment ceux qui ont déjà fait des échanges en dollars.
Voir Iran, voir d'autres.... Même tentés d'interdire Huawei en Europe et certains pays ont pliés, ARM entreprise Anglaise, pour design de processeurs, qui ont pliés avec les US.
La Chine aussi a des problème, c'est pas à qui la faute, elle est globale... Mais oui le fait que les gros pays imposent leurs principes au reste du monde.... sad

Mais ce n'est pas le sujet de ce topic smile, je verrais quand même ce que je peux faire si ça peut te dépanner, quand j'aurais temps libre.

Dernière modification par naguam (22-06-2019 11:43:17)

Hors ligne

#12 22-06-2019 11:54:12

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : [obtenu] commande pour vérifier version opengl ?

statis a écrit :

Il m'a demandé si j'avais des sugestions et comme j'ai du bug dans l'affichage, je ne me suis pas privé...
Problème il me demande de lancer la commande suivante que je ne connais pas du tout :


gcc  OpenGL_version.c -o OpenGL_version -lglut -lGL -lGLU
 



Et comme j'ai pas envie de casser mon beau Debian, je me renseigne wink


Ça dépend de ce qu'il y a dans le fichier OpenGL_version.c.
D'ailleurs j'aimerais bien voir son contenu.

Hors ligne

#13 23-06-2019 22:06:15

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : [obtenu] commande pour vérifier version opengl ?

Merci naguam,

Oui je me suis un peu écarté du sujet de mon post mais c'était une bonne occasion de dire qu'il faut se méfier des chinois, si on leur donne un plan et qu'il y a des contrôles qualité externes et que la partie soft n'est pâs de leur ressort il y a déjà des problèmes...
Quand au neveu de Picsou, pas celui de la bande déssinée, celui qui est plus riche que son oncle, il n'a pas envie de perdre le pouvoir de la planète et c'sst nous qui lui donnons...

Merci enicar,

Je ne sais pas comment "récupérer" OpenGL_version.c, j'ai lancé une recherche sur mon disque et ce fichier n'a pas été trouvé...

Je pense que la version max de OpenGL du driver Linux (pas que Debian) pour la GT610 est insuffisante avec le soft Flashforge.
Le .run de chez Nvidia lancé sur un autre debian9 (vive les racks extractibles) se met en erreur, Nvidia seraient-ils des chinois...
Avec le bon driver, sur le même PC et un W10 monté (j'ai un rack extractible) la GT610 fonctionne bien avec Flashforge.

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#14 23-06-2019 22:11:13

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : [obtenu] commande pour vérifier version opengl ?

statis a écrit :

Merci enicar,

Je ne sais pas comment "récupérer" OpenGL_version.c, j'ai lancé une recherche sur mon disque et ce fichier n'a pas été trouvé...


Tant pis alors. Ce n'est pas important.

Hors ligne

#15 24-06-2019 14:26:00

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [obtenu] commande pour vérifier version opengl ?

Bonjour
voila pour moi avec une GTX980 (Maxwell , la tienne est une Fermi (entre il y a eu Keppler ) ).


glxinfo | grep OpenGL
 



OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 980/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 390.116
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 390.116
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 390.116
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
 



pour faire simple , ne pas confondre les versions des chipsets graphiques et la version du driver.
j'ai le même retour que toi mais mon matériel prend en charge une version supérieure (matériel ).
pour OpenCL (ou cuda) même chose , la version logicielle ne prouve pas que tout soit pris en compte si le matériel ne suit pas .
la personne qui te pose la question devrait savoir quel gpu est pris en charge.
ps: je donne un exemple récent sur nvidia , les cartes RTXxxxx prennent en charge les cores RT (matériel) .
les cartes de la génération avant (GTX 10xx) certaines le prennent en charge logiciellement (mais moins performantes )
donc les jeux qui utilisent l'option "cores RT" ont besoin d'un matériel performant.
pour OpenGL même choses , le code logiciel (du driver) a besoin du matériel qui va bien
nota: comme pour un cpu qui gère SSE , ou SSE2 etc ..... , l'OS ne pourra utiliser que ce que le matériel prend en charge.
les derniers drivers graphiques ne prennent plus en charge des cartes trop anciennes .
je sais pas si je suis clair, mais le retour de glxinfo -B renvoie les possibilités du driver nvidia , pas de la carte.

Hors ligne

#16 24-06-2019 15:27:40

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : [obtenu] commande pour vérifier version opengl ?

Merci robert2a,

Comme dit en #13, ce n'est pas la partie matérielle qui manque de performance.
Même PC, même GPU, uniquement driver/soft différents entre D9 et W10...
Pour W10 Nvidia fournit le driver compatible (fonctionnel une fois le bon trouvé) de la GT610.
Ils fournissent aussi un driver Linux (le fameux .run dont j'ai parlé dans le sujet https://debian-facile.org/viewtopic.php?id=23576&p=3 #55) mais il fait boguer D9...

Ce que me demande Flasforge est du n'importe quoi.
Je ne vais pas plus vous embêter avec la partie OpenGL, le support Flashforge a eu les infos et ils sont nuls.
Dommage d'être obligé de passer sur W10 pour faire fonctionner correctement un soft...

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#17 24-06-2019 18:15:50

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : [obtenu] commande pour vérifier version opengl ?

robert2a a écrit :

pour OpenCL (ou cuda) même chose , la version logicielle ne prouve pas que tout soit pris en compte si le matériel ne suit pas .

Oui mais il a du coup d'après ce qui est vu au dessus une version d'OpenGL et OpenGL ES correcte, son logiciel devrait fonctionner.

La version du driver si il est encore compatible avec la carte est qu'il est plutôt récent, car pas mal de carte nvidia plus anciennes sont bloquées au legacy 340 ou encore le legacy 304 (plus dispo après stretch)
De plus sauf si le dev du logiciel utilise les toutes dernières normes ce qui est peu probable, ça devrait passer.

C'est ce que je voulais dire plus haut.

Je vois, c'est la galère pour ton flash forge, surtout que j'ai pas d'imprimante 3D de mon côté pour tester.

Dernière modification par naguam (24-06-2019 18:16:43)

Hors ligne

#18 24-06-2019 18:47:26

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : [obtenu] commande pour vérifier version opengl ?

Merci naguam,

En fait pas besoin d'imprimante 3D pour tester Flashprint car c'est un problème dans l'affichage de l'objet "préparé" pour l'impression qui pose problème.
Les impressions se passent relativement bien sauf quand il y a un détail "pas vu" avant de lancer l'imprimante.
Exemple, en impression 3D on utilise des supports pour les "ponts", avec une technologie additive le filament fondu ne peut pas tenir tout seul en l'air.
Voir comment les supports sont faits est importants car à certains endroits d'une pièce ils peuvent être impossibles à enlever par la suite, sans la visu avant impression c'est de la roulette russe...
Je pourrais expliquer comment faire un test avec le soft mais cela ne serait intéressant qu'avec les mêmes GPU/distribution/(G)UI.
Donc ne te casse pas la tête wink
Cependant je te remercie pout tant de prévenance smile

En ce qui concerne "les dernières normes", je pense que le dev a choisi la facilité car en prenant du récent cela lui évite pas mal de lignes de code.
Cette utilisation est confirmée par l'installation du dernier driver sur W10 qui a rendu l'utilisation de Flashprint optimale sur ce KKOS.

C'est mon obstination à ne pas vouloir utiliser WinCriseDeNerfs qui est une galère.
Et il n'y a pas que Flashprint tournant mieux sur W10 mais aussi d'autres softs dédiés impression 3D qui n'existent pas sur Linux...
Je suis aussi en galère parce que j'ai pris une "Dreamer" chère avec du soft dédié alors qu'il existe moins cher et plus "free" :
http://musictonic.com/music/Alfawise+U3 … aKYJ-ceveg
Attention je ne m'associe pas à l'avis de Heliox car je suis comme St Thomas, je ne crois que ce que je touche, et encore...
J'ai bien fait d'émettre des réserves, l'AlfaWise U30 n'est pas Open Source :
http://socialcompare.com/fr/comparison/ … d-printers

Dernière modification par statis (24-06-2019 19:01:36)


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#19 26-06-2019 00:23:24

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [obtenu] commande pour vérifier version opengl ?

Bonjour
voila les caractéristiques de ta carte "OpenGL 4.2" et "directX11"
=>  https://www.nvidia.fr/object/geforce-gt … pContent=2

si tu regarde la GTX980 , tu a "directX12"  level 12_1 et "OpenGL 4.5"

le retour de glxinfo nous donne la même chose pour les deux cartes , (version du driver pris en charge).


pour rappel le retour de glxinfo donne :


OpenGL core profile version string: 4.5.0 NVIDIA 390.116
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL version string: 4.6.0 NVIDIA 390.116
OpenGL shading language version string: 4.60 NVIDIA
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 390.116
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
 


sinon pour ton souci , pas tout lu , mais si correct avec win10 , normalement le matériel est hors de cause (pour la même application).

pour OpenGL ES  => https://fr.wikipedia.org/wiki/OpenGL_ES

bon souvent le descriptif chez nvidia est pas terrible , dans ton cas je comprend direct X 11 max pris en charge et le langage OpenGL version 4.2 . (version a l'époque de la sortie de la carte ou elle ne supporte pas au dessus de 4.2 ? ).
tout ceci correspond a la prise en charge des effets vidéo. (plus ou moins gourmand en mémoire et ressources gpu/cpu ).
il sort des nouveaux type de traitement vidéo assez souvent (matériel et logiciel) , ça reste assez complexe  roll
pour ton utilisation je connais pas , donc pas de retour d'expérience.

PS: ne pas oublier que une carte vidéo contient un bios ( normal ou firmware EFI si récente ) , en relation avec l'OS et le driver . (identifie le matériel installé )

Dernière modification par robert2a (26-06-2019 00:29:03)

Hors ligne

Pied de page des forums