Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-05-2019 09:50:10

tuxrouge
Membre
Inscription : 04-04-2014

erreur 502 Bad Gateway

Bonjour à tout le monde

j'ai un serveur debian tout propre que j'ai un peu cassé

dessus j'ai flectra installé qui tourne sur le port 7073 et nginx le renvoi depuis le port 80
j'ai voulu tester tracim et j'ai betement suivi la doc https://hub.docker.com/r/algoo/tracim

docker run -e DATABASE_TYPE=sqlite -p 8080:80 -v $TRACIM_STORAGE/etc/:/etc/tracim -v $TRACIM_STORAGE/var:/var/tracim algoo/tracim




je me suis évidemment aperçu une fois que je l'avais envoyé que j'avais un problème sur le port mais je me suis aussi rendu compte juste après que flectra n'était plus accessible (502 Bad Gateway nginx/1.10.3)
j'ai stoppé puis désinstallé le docker sans que ça ne règle quoique ce soit

Je ne comprends pas quels fichiers ont été modifiés par la commande docker et je ne sais pas comment y remédier. Du coup je viens vous voir tongue

Dernière modification par tuxrouge (22-05-2019 11:05:03)

Hors ligne

#2 29-05-2019 11:33:18

bux
Membre
Distrib. : debian
Inscription : 29-05-2019
Site Web

Re : erreur 502 Bad Gateway

Salut,

Est-ce que lorsque tu as entré cette commande tu avais bien entré cette ligne juste avant ?

TRACIM_STORAGE=~/tracim



Si ce n'es pas le cas (ou que tu pense l'avoir entré mais que non, genre dans un autre terminal) je me demande l'impact qu'à pu avoir les parties

$TRACIM_STORAGE/etc/:/etc/tracim


$TRACIM_STORAGE/var:/var/tracim algoo/tracim



Qui, sans cette variable, ce sont en fait exécuté comme (puisque $TRACIM_STORAGE vide):

/etc/:/etc/tracim


/var:/var/tracim algoo/tracim



Tu peux afficher le résultat des deux commandes suivantes ?

ls -l /etc


ls -l /var



bux

Hors ligne

#3 29-05-2019 17:50:17

xandercagexxx
Membre
Inscription : 29-05-2019

Re : erreur 502 Bad Gateway

tuxrouge a écrit :

Bonjour à tout le monde

j'ai un serveur debian tout propre que j'ai un peu cassé

dessus j'ai flectra installé qui tourne sur le port 7073 et nginx le renvoi depuis le port 80
j'ai voulu tester tracim et j'ai betement suivi la doc https://hub.docker.com/r/algoo/tracim

docker run -e DATABASE_TYPE=sqlite -p 8080:80 -v $TRACIM_STORAGE/etc/:/etc/tracim -v $TRACIM_STORAGE/var:/var/tracim algoo/tracim




je me suis évidemment aperçu une fois que je l'avais envoyé que j'avais un problème sur le port mais je me suis aussi rendu compte juste après que flectra n'était plus accessible (502 Bad Gateway nginx/1.10.3)
j'ai stoppé puis désinstallé le docker sans que ça ne règle quoique ce soit

Je ne comprends pas quels fichiers ont été modifiés par la commande docker et je ne sais pas comment y remédier. Du coup je viens vous voir tongue




Bonjour tuxrouge,

Voici ce qui est créé lors du démarrage de la commande docker que tu as effectué :
Dans le dossier /etc/ ce sont les fichiers suivant :

- apache2.conf
- color.json
- development.ini
- logo.png
- tracim_web.ini

et dans /var/ les dossiers suivant :

- assets/
- data/
- logs/

Le fonctionnement de l'image docker est de ne pas recréer/supprimer les fichiers qui existe déjà dans les volumes.

Pour ton soucis de port je ne vois pas de relation direct entre ton app et l'image docker de tracim.

Philippe

Hors ligne

#4 30-05-2019 20:10:43

tuxrouge
Membre
Inscription : 04-04-2014

Re : erreur 502 Bad Gateway

bonjour Philippe

je viens de refaire la manipulation sur une machine virtuelle et j'ai les mêmes symptômes
est-ce que je peux te donner comme info pour déceler le problème ?

Hors ligne

#5 31-05-2019 10:52:15

xandercagexxx
Membre
Inscription : 29-05-2019

Re : erreur 502 Bad Gateway

Bonjour,

Quand tu dis que tu as les mêmes symptômes, tu veux dire que Flectra n'est plus accessible après le lancement de l'image docker de tracim ?
En relisant ton premier post je vois que tu dis avoir eu un problème de port, quel était-il ? Tu avais déjà le port 8080 d'utilisé sur ton serveur ?

Ton souci est-il de ne pouvoir faire marcher tracim ou que de faire marcher tracim t'empêche d'utiliser Flectra ?

Pour ce qui est de tracim :

Il semblerait que le tag latest n'est pas été mis à jour correctement lors de la publication de l'image docker 2.2.0, je te conseille donc dans un premier temps de faire un

docker pull algoo/tracim:latest



Dans un second temps si le pull de la latest ne te permet pas d'utiliser correctement l'image docker de tracim, peux-tus nous donner quelques informations supplémentaires :

- Utilises-tu un proxy (nginx / apache) sur ton serveur pour servir l'image docker ?
    Si oui peux-tu nous montrer la config ?
- Quel type d'OS (version) est installé sur ton serveur/VM ?
- Flectra utilise une image docker ?
- As-tu suffisamment de ressource sur la machine pour faire tourner tracim en plus de Flectra ? Tracim consomme environ 400-500Mo de mémoire vive. Il n'y a pas pour le moment d'indication sur le repo github des ressources nécessaire pour faire fonctionner tracim.

Merci d'avance pour ton retour.
Philippe

Hors ligne

#6 31-05-2019 16:20:53

tuxrouge
Membre
Inscription : 04-04-2014

Re : erreur 502 Bad Gateway

le port 8080 n'était pas utilisé (mais le port 80 était redirigé vers flectra soit, 7073)
après le lancement de l'image docker de tracim non seulement flectra n'est plus accessible (même pas directement par le port 7073) mais sur ma page web j'ai

502 Bad Gateway
nginx/1.10.3



or flectra semble bien tourner

n# service flectra status
● flectra.service - Flectra Open Source ERP and CRM
   Loaded: loaded (/lib/systemd/system/flectra.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2019-05-31 16:05:06 CEST; 14min ago
 Main PID: 353 (flectra)
    Tasks: 4 (limit: 4915)
   Memory: 130.3M
      CPU: 6.538s
   CGroup: /system.slice/flectra.service
           └─353 /usr/bin/python3 /usr/bin/flectra --config /etc/flectra/flectra.conf --logfile /var/log/flectra/flectra-server.log

May 31 16:05:33 sd-101288 flectra[353]: 2019-05-31 14:05:33,165 353 INFO ? flectra: Using configuration file at /etc/flectra/flectra.conf
May 31 16:05:33 sd-101288 flectra[353]: 2019-05-31 14:05:33,165 353 INFO ? flectra: addons paths: ['/usr/lib/python3/dist-packages/flectra/addons']
May 31 16:05:33 sd-101288 flectra[353]: 2019-05-31 14:05:33,167 353 INFO ? flectra: database: flectra@default:default
May 31 16:05:34 sd-101288 flectra[353]: 2019-05-31 14:05:34,281 353 INFO ? flectra.service.server: HTTP service (werkzeug) running on sd-101288.dedibox.fr:7073
May 31 16:05:36 sd-101288 flectra[353]: 2019-05-31 14:05:36,337 353 INFO ? flectra.addons.base.ir.ir_actions_report: You need Wkhtmltopdf to print a pdf version of the repor
May 31 16:05:37 sd-101288 flectra[353]: 2019-05-31 14:05:37,274 353 WARNING ? flectra.addons.base.res.res_currency: The num2words python library is not installed, l10n_mx_ed
May 31 16:09:44 sd-101288 flectra[353]: 2019-05-31 14:09:44,577 353 WARNING ? flectra.addons.rest_api.controllers.main: Warning: To proper setup OAuth - it's necessary to se
May 31 16:09:44 sd-101288 flectra[353]: 2019-05-31 14:09:44,584 353 WARNING ? flectra.addons.rest_api.models.oauth_provider: OAuth library not found. If you plan to use it,
May 31 16:09:45 sd-101288 flectra[353]: 2019-05-31 14:09:45,044 353 INFO ? flectra.addons.sms.wizard.send_sms: The `phonenumbers` Python module is not available. Phone numbe
May 31 16:09:47 sd-101288 flectra[353]: 2019-05-31 14:09:47,627 353 INFO ? flectra.http: HTTP Configuring static files
 



~$ uname -a
Linux sd-101288 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1+deb9u2 (2019-05-13) x86_64 GNU/Linux



flectra n'utilise pas l'image docker

les ressources sont suffisantes normalement (4GO de mémoire vive)

j'utilise nginx pour felctra

etc/nginx/nginx.conf

user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
    worker_connections 768;
    # multi_accept on;
}

http {

    ##
    # Basic Settings
    ##

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 65;
    types_hash_max_size 2048;
    # server_tokens off;

    # server_names_hash_bucket_size 64;
    # server_name_in_redirect off;

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    ##
    # SSL Settings
    ##

    ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
    ssl_prefer_server_ciphers on;

    ##
    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    ##
    # Gzip Settings
    ##

    gzip on;
    gzip_disable "msie6";

    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

    ##
    # Virtual Host Configs
    ##

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;

}

#mail {
#    # See sample authentication script at:
#    # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
#
#    # auth_http localhost/auth.php;
#    # pop3_capabilities "TOP" "USER";
#    # imap_capabilities "IMAP4rev1" "UIDPLUS";
#
#    server {
#        listen     localhost:110;
#        protocol   pop3;
#        proxy      on;
#    }
#
#    server {
#        listen     localhost:143;
#        protocol   imap;
#        proxy      on;
#    }
#}



/etc/nginx/sites-enabled/flectra

server {
    listen 80 default_server;
    listen [::]:80 default_server;
    server_name mon-serveur.fr;
    root /var/www/html;
    location / {
        proxy_pass http://localhost:7073;
            # force timeouts if the backend dies
            proxy_next_upstream error timeout invalid_header http_500 http_502 http_503 http_504;
            proxy_redirect off;

            # set headers
            proxy_set_header    Host            $host;
            proxy_set_header    X-Real-IP       $remote_addr;
            proxy_set_header    X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_set_header    X-Forwarded-Proto https;
    }
}



résultat de la commande en user:

$ docker pull algoo/tracim:latest
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post http://%2Fvar%2Frun%2Fdocker.sock/v1.39/images/create?fromImage=algoo%2Ftracim&tag=latest: dial unix /var/run/docker.sock: connect: permission denied

Hors ligne

#7 31-05-2019 17:12:07

xandercagexxx
Membre
Inscription : 29-05-2019

Re : erreur 502 Bad Gateway

Pour la commande docker, si docker n'est pas utilisable directement depuis votre compte d'utilisateur, il faut alors exécuter la commande depuis le compte root.

Je ne vois pas ce qui peut poser problème entre l'image docker et flectra en l'état actuel.

Hors ligne

#8 31-05-2019 17:46:51

tuxrouge
Membre
Inscription : 04-04-2014

Re : erreur 502 Bad Gateway

xandercagexxx a écrit :

Je ne vois pas ce qui peut poser problème entre l'image docker et flectra en l'état actuel.



moi non plus et c'est bien ça qui m'embête




# docker run -e DATABASE_TYPE=sqlite -p 8080:80 -v ~/tracim/etc:/etc/tracim -v ~/tracim/var:/var/tracim algoo/tracim
Enabling module proxy.
Considering dependency proxy for proxy_http:
Module proxy already enabled
Enabling module proxy_http.
Considering dependency proxy for proxy_ajp:
Module proxy already enabled
Enabling module proxy_ajp.
Enabling module rewrite.
Considering dependency filter for deflate:
Module filter already enabled
Module deflate already enabled
Enabling module headers.
Considering dependency proxy for proxy_html:
Module proxy already enabled
Considering dependency xml2enc for proxy_html:
Enabling module xml2enc.
Enabling module proxy_html.
Considering dependency dav for dav_fs:
Enabling module dav.
Enabling module dav_fs.
Module dav already enabled
To activate the new configuration, you need to run:
  service apache2 restart
Starting redis-server: 88:C 31 May 15:30:49.777 # Fatal error, can't open config file '/etc/redis/redis.conf'
failed
Restarting Apache httpd web server: apache2AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 172.17.0.2. Set the 'ServerName' directive globally to suppress this message
.
Restarting app server(s): uwsgi -> ! failed!
2019-05-27 08:43:21 startup packages configure
2019-05-27 08:43:21 trigproc mime-support:all 3.60 <none>
2019-05-27 08:43:21 status half-configured mime-support:all 3.60
2019-05-27 08:43:21 status installed mime-support:all 3.60
2019-05-27 08:43:21 trigproc sgml-base:all 1.29 <none>
2019-05-27 08:43:21 status half-configured sgml-base:all 1.29
2019-05-27 08:43:21 status installed sgml-base:all 1.29
2019-05-27 08:43:21 trigproc libc-bin:amd64 2.24-11+deb9u4 <none>
2019-05-27 08:43:21 status half-configured libc-bin:amd64 2.24-11+deb9u4
2019-05-27 08:43:21 status installed libc-bin:amd64 2.24-11+deb9u4

Hors ligne

#9 31-05-2019 19:04:15

xandercagexxx
Membre
Inscription : 29-05-2019

Re : erreur 502 Bad Gateway

Là l'image docker de tracim est bien démarré. Tracim est accessible sur http://localhost:8080

Attention si tu souhaites utiliser tracim depuis une autre machine, par exemple via le réseau, il va falloir effectuer des modifications dans le development.ini situé dans /tracim/etc/
(ce référer à la documentation de tracim présente sur http://github.com/tracim/tracim )

Ainsi que configurer un proxy (apache2 est conseillé pour tracim).

Hors ligne

#10 31-05-2019 19:19:44

tuxrouge
Membre
Inscription : 04-04-2014

Re : erreur 502 Bad Gateway

effectivement tracim est accessible sur le port 8080 (j'avais pas regardé tongue)
me reste à trouver pourquoi nginx est parti en carafe

par contre concernant tracim c'est étrange, une fois loggé je n'ai accès qu'à la configuration du compte admin, je ne peux même pas créer d'autre compte. Le menu est vide

Dernière modification par tuxrouge (31-05-2019 19:24:18)

Hors ligne

#11 31-05-2019 19:31:26

xandercagexxx
Membre
Inscription : 29-05-2019

Re : erreur 502 Bad Gateway

La création de compte ce fait depuis le bouton administration puis utilisateur présent en haut de page.

La doc utilisateur de tracim est malheureusement pas encore dispo.

Hors ligne

#12 31-05-2019 19:41:26

tuxrouge
Membre
Inscription : 04-04-2014

Re : erreur 502 Bad Gateway

ben je dois être méchamen neuneu parce que je ne trouve pas l'option
j'ai ou modifier le compte admin avec de nouvelles données. Ca c'est bon
mais je n'ai pas de bouton administration
et dans le chemin affiché en haut à gauche (Accueil->Administration->Mon compte), administration n'est pas accessible

j'ai déjà testé tracim sur une autre machine et je n'avais pas rencontré ce problème

Hors ligne

#13 31-05-2019 20:26:33

xandercagexxx
Membre
Inscription : 29-05-2019

Re : erreur 502 Bad Gateway

Peux tu mettre ici un screenshot de ta page web ?

Le menu Administration est dans un bouton avec une liste deroulante. A gauche du bouton du choix de langue.

Hors ligne

#14 31-05-2019 21:14:42

tuxrouge
Membre
Inscription : 04-04-2014

Re : erreur 502 Bad Gateway

et voilà

jlmk.png

testé sous chrome aussi, même résultat

Hors ligne

#15 31-05-2019 21:41:00

xandercagexxx
Membre
Inscription : 29-05-2019

Re : erreur 502 Bad Gateway

Je viens de comprendre. Il y a un ticket sur github pour remettre en place la description des profils des utilisateurs (comme dans la v1), ton problème est là.

Dans tracim il y a 3 profils possible pour les comptes des utilisateurs :
- Administrateur (en gros cest le super admin, il peut tout faire et à accès a tout.les boutons/menu)
- Utilisateur de confiance (peut créer des espaces partagé et inviter des utilisateurs ou membres dans les espaces partagé)
- Utilisateur (peut juste être invité dans un/des espace(s) partagé)

Là, tu as créé/utilisé un compte qui n'a qu'un profil d'utilisateur  : )

En général ce type de compte est à destination des gens que tu vas inviter dans tracim pour collaborer avec eux.

Reconnecte toi avec le compte d'admin et modifie ton profil d'utilisateur dans Administration puis utilisateur.

Dernière modification par xandercagexxx (31-05-2019 21:43:57)

Hors ligne

#16 31-05-2019 23:42:43

tuxrouge
Membre
Inscription : 04-04-2014

Re : erreur 502 Bad Gateway

mais c'est mon compte d'admin
en tout cas c'est celui avec lequel je me suis connecté juste après le lancement de tracim (avec les codes par défaut)
j'ai ensuite changé le nom du compte et le mot de passe. D'ailleurs l'accès avec les codes par défaut n'est plus valable (admin@admin.admin / admin@admin.admin)
du coup est-ce que ça veut dire que changer le nom de l'admin a transformé le compte en compte utilisateur ?

Hors ligne

#17 01-06-2019 11:41:41

xandercagexxx
Membre
Inscription : 29-05-2019

Re : erreur 502 Bad Gateway

Non, le renommage ne change pas les droits de l'utilisateur (jai revérifié) mais dans ton cas il y a peut-être eu un bug.

Ce que je pense qui a pu ce passer est la chose suivante :
- tu a démarré l'image docker une premiere fois mais ce nétait pas en réalité la dernière version stable (je pense que cétait la 2.1 car le logo de tracim a changé dans la 2.2)
- suite aux manip mentionné plus haut et suite a la mise a jour de la latest sur le hub docker ;  tu a récupéré la vrai latest (2.2). Je pense qu il y a eu un bug soit au renommage de ton compte soit lors de la migration de la bdd entre la premiere version démarré et la dernière.

Si cest possible pour toi et si tu na pas encore vraiment mis de contenu dans tracim ni modifié le fichier development.ini, voici ce que je te propose :
- Tu efface le contenu du dossier /tracim/etc/ afin de recréer les fichier correctement lors du démarrage de l'image docker (vu que l image ne modifie pas les fichier déjà en place, ta config n'utilise pas les derniers fichier pour la 2.2 . cest plutôt comme si tu avait voulu faire une migration de la 2.1 à la 2.2).
- si cest possible :  tu efface aussi la bdd sqlite qui ce trouve dans /tracim/var/data/ (si tu utilise bien la bdd sqlite)

Cela va t'obliger a refaire ton compte mais sa devrait résoudre ton problème sans aller modifier la bdd.

Si ce n'est pas possible pour toi, il faudra que l'on vois pour faire une modif dans la bdd sqlite pour te redonner le droit d'administrateur.

Pour profiter de l'agenda dans la 2.2 il faut ajouter "-e START_CALDAV=1"  a la commande docker run. (plus d'info dans la documentation sur github).

Dans le futur le démarrage d'une nouvelle version de tracim via docker prendra en compte les ancienne configuration de façon automatique mais ce n'est pas le cas pour le moment. D'où la difficulté dans ton cas.

Merci pour tes retours d'information.

Hors ligne

Pied de page des forums