Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-06-2019 14:47:01

sebr
Membre
Inscription : 31-01-2019

Problème installation de phpmyadmin

Bonjour,
J'avance doucement sur l'installation de mon VPS j'ai installé le FTP, MariaDB 10 mais la je souhaite installer phpmyadmin et durant l'installation j'ai cette erreur.

Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u4) .                     ..
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/apache2-bin_2.4.25-3+deb9u7_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@sebr:~# apt-get install libc-bin
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
libc-bin est déjà la plus récente version disponible.
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 libapache2-mod-php7.0 : Dépend: apache2-api-20120211
                         Dépend: apache2-bin (>= 2.4.16) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
root@sebr:~# apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  apache2-bin
Paquets suggérés :
  apache2-suexec-pristine apache2-suexec-custom
Les NOUVEAUX paquets suivants seront installés :
  apache2-bin
0 mis à jour, 1 nouvellement installés, 0 à enlever et 45 non mis à jour.
36 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/1 187 ko dans les archives.
Après cette opération, 4 185 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 47662 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../apache2-bin_2.4.25-3+deb9u7_amd64.deb ...
Dépaquetage de apache2-bin (2.4.25-3+deb9u7) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/apache2-bin_2.4.5-3+deb9u7_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/apache2/modules/httpd.exp », qui appartient aussi au paquet apache2.2-bin 2.2.22-13+deb7u11
dpkg-deb: erreur: le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/apache2-bin_2.4.25-3+deb9u7_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



Je ne vois pas du tout qu'elle est l'erreur ce n'est pas clair "error code 1" !

Merci de votre aide.

Hors ligne

#2 25-06-2019 19:47:26

lagrenouille
Adhérent(e)
Lieu : Toulouse, con !
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : env i3-openbox_bépo
Inscription : 28-03-2012
Site Web

Re : Problème installation de phpmyadmin

quelle distribution ? stretch ? buster ?


si c'est buster faut mettre les non-free, et je crois j'ai mis les sources unstable, ou les backports ? je sais plus


rmadison phpmyadmin
phpmyadmin | 4:4.2.12-2+deb8u2 | oldstable  | source, all
phpmyadmin | 4:4.6.6-4         | stable     | source, all
phpmyadmin | 4:4.6.6-5         | unstable   | source, all
 

Dernière modification par lagrenouille (25-06-2019 19:49:35)


Veuillez laisser l’État dans la malpropreté ou vous avez trouvé en y entrant.

Hors ligne

#3 26-06-2019 07:25:53

sebr
Membre
Inscription : 31-01-2019

Re : Problème installation de phpmyadmin

Bonjour,
Merci pour ta réponse je suis en stretch 9.9 du coup pas besoin d'ajouter de source je pense.

J'ai stoppé le service apache et relancé l'installation mais il me parle de dépendances non satisfaites maintenant.

 apt-get install phpmyadmin



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
phpmyadmin est déjà la plus récente version disponible.
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 libapache2-mod-php7.0 : Dépend: apache2-api-20120211
                         Dépend: apache2-bin (>= 2.4.16) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
 



Si je fait ce qu'il me recommande:

apt-get -f install


 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  apache2-bin
Paquets suggérés :
  apache2-suexec-pristine apache2-suexec-custom
Les NOUVEAUX paquets suivants seront installés :
  apache2-bin
0 mis à jour, 1 nouvellement installés, 0 à enlever et 45 non mis à jour.
36 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/1 187 ko dans les archives.
Après cette opération, 4 185 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 47662 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../apache2-bin_2.4.25-3+deb9u7_amd64.deb ...
Dépaquetage de apache2-bin (2.4.25-3+deb9u7) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/apache2-bin_2.4.25-3+deb9u7_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/apache2/modules/httpd.exp », qui appartient aussi au paquet apache2.2-bin 2.2.22-13+deb7u11
dpkg-deb: erreur: le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/apache2-bin_2.4.25-3+deb9u7_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

Dernière modification par sebr (26-06-2019 07:35:01)

Hors ligne

#4 26-06-2019 14:20:48

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.8 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Problème installation de phpmyadmin

Tu as un paquet "apache2.2-bin" qui traîne sur ton serveur, et n'a clairement rien à y faire.

Essaye cette série de commandes qui va peut-être débloquer la situation :

apt-get remove apache2.2-bin
apt-get install phpmyadmin libapache2-mod-php7.0 apache2-bin


Jouer sous Debian ? Facile !

En ligne

#5 26-06-2019 14:51:31

sebr
Membre
Inscription : 31-01-2019

Re : Problème installation de phpmyadmin

Merci pour ton aide, ça ne change rien sad

apt-get remove apache2.2-bin



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 apache2-mpm-prefork : Dépend: apache2.2-bin (= 2.2.22-13+deb7u11) mais ne sera pas installé
 apache2.2-common : Dépend: apache2.2-bin (= 2.2.22-13+deb7u11) mais ne sera pas installé
 libapache2-mod-php7.0 : Dépend: apache2-api-20120211
                         Dépend: apache2-bin (>= 2.4.16) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
 


apt-get install phpmyadmin libapache2-mod-php7.0 apache2-bin



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
libapache2-mod-php7.0 est déjà la plus récente version disponible.
phpmyadmin est déjà la plus récente version disponible.
Paquets suggérés :
  apache2-suexec-pristine apache2-suexec-custom
Les NOUVEAUX paquets suivants seront installés :
  apache2-bin
0 mis à jour, 1 nouvellement installés, 0 à enlever et 45 non mis à jour.
36 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/1 187 ko dans les archives.
Après cette opération, 4 185 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 47662 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../apache2-bin_2.4.25-3+deb9u7_amd64.deb ...
Dépaquetage de apache2-bin (2.4.25-3+deb9u7) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/apache2-bin_2.4.25-3+deb9u7_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/apache2/modules/httpd.exp », qui appartient aussi au paquet apache2.2-bin 2.2.22-13+deb7u11
dpkg-deb: erreur: le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/apache2-bin_2.4.25-3+deb9u7_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#6 26-06-2019 15:39:22

lagrenouille
Adhérent(e)
Lieu : Toulouse, con !
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : env i3-openbox_bépo
Inscription : 28-03-2012
Site Web

Re : Problème installation de phpmyadmin

essaie de toujours faire -- purge quand tu désinstalles

apt-get remove --purge  ton paquet

tu peux aussi regarder si il te reste des résidus de dépendances avec

dpkg -l | grep -v ^ii



tu purges le tout avec

dpkg -P $(dpkg -l | awk '$1~/^rc$/{print $2}')



histoire de nettoyer un peu

Dernière modification par lagrenouille (26-06-2019 15:39:46)


Veuillez laisser l’État dans la malpropreté ou vous avez trouvé en y entrant.

Hors ligne

#7 26-06-2019 19:48:33

sebr
Membre
Inscription : 31-01-2019

Re : Problème installation de phpmyadmin

Je vous remercie pour votre aide c'est très sympa mais ça bloque toujours je ne comprends pas.
Voici ce que j'ai fait:

apt-get remove --purge apache2.2-bin



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 apache2-mpm-prefork : Dépend: apache2.2-bin (= 2.2.22-13+deb7u11) mais ne sera pas installé
 apache2.2-common : Dépend: apache2.2-bin (= 2.2.22-13+deb7u11) mais ne sera pas installé
 libapache2-mod-php7.0 : Dépend: apache2-api-20120211
                         Dépend: apache2-bin (>= 2.4.16) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).



dpkg -l | grep -v ^ii



Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                             Version                            Architecture Description
+++-===============================-==================================-============-===============================================================================
iU  dbconfig-common                 2.0.8                              all          framework that helps packages to manage databases
iU  dbconfig-mysql                  2.0.8                              all          dbconfig-common MySQL/MariaDB support
iU  javascript-common               11                                 all          Base support for JavaScript library packages
iU  libapache2-mod-php7.0           7.0.33-0+deb9u3                    amd64        server-side, HTML-embedded scripting language (Apache 2 module)
iU  libjs-jquery                    3.1.1-2+deb9u1                     all          JavaScript library for dynamic web applications
iU  libjs-sphinxdoc                 1.4.9-2                            all          JavaScript support for Sphinx documentation
iU  libjs-underscore                1.8.3~dfsg-1                       all          JavaScript's functional programming helper library
iU  liblua5.2-0:amd64               5.2.4-1.1+b2                       amd64        Shared library for the Lua interpreter version 5.2
rc  libsnmp15                       5.4.3~dfsg-2.8+deb7u1              amd64        SNMP (Simple Network Management Protocol) library
iU  libzip4:amd64                   1.1.2-1.1+b1                       amd64        library for reading, creating, and modifying zip archives (runtime)
rc  perl-modules                    5.14.2-21+deb7u5                   all          Core Perl modules
iU  php                             1:7.0+49                           all          server-side, HTML-embedded scripting language (default)
iU  php-bz2                         1:7.0+49                           all          bzip2 module for PHP [default]
iU  php-common                      1:49                               all          Common files for PHP packages
iU  php-curl                        1:7.0+49                           all          CURL module for PHP [default]
iU  php-gd                          1:7.0+49                           all          GD module for PHP [default]
iU  php-mbstring                    1:7.0+49                           all          MBSTRING module for PHP [default]
iU  php-mysql                       1:7.0+49                           all          MySQL module for PHP [default]
iU  php-pear                        1:1.10.1+submodules+notgz-9+deb9u1 all          PEAR Base System
iU  php-php-gettext                 1.0.12-0.1                         all          read gettext MO files directly, without requiring anything other than PHP
iU  php-phpseclib                   2.0.4-1                            all          implementations of an arbitrary-precision integer arithmetic library
iU  php-tcpdf                       6.2.12+dfsg2-1                     all          PHP class for generating PDF files on-the-fly
iU  php-xml                         1:7.0+49                           all          DOM, SimpleXML, WDDX, XML, and XSL module for PHP [default]
iU  php-zip                         1:7.0+49                           all          Zip module for PHP [default]
iU  php7.0                          7.0.33-0+deb9u3                    all          server-side, HTML-embedded scripting language (metapackage)
iU  php7.0-bz2                      7.0.33-0+deb9u3                    amd64        bzip2 module for PHP
iU  php7.0-cli                      7.0.33-0+deb9u3                    amd64        command-line interpreter for the PHP scripting language
iU  php7.0-common                   7.0.33-0+deb9u3                    amd64        documentation, examples and common module for PHP
iU  php7.0-curl                     7.0.33-0+deb9u3                    amd64        CURL module for PHP
iU  php7.0-gd                       7.0.33-0+deb9u3                    amd64        GD module for PHP
iU  php7.0-json                     7.0.33-0+deb9u3                    amd64        JSON module for PHP
iU  php7.0-mbstring                 7.0.33-0+deb9u3                    amd64        MBSTRING module for PHP
iU  php7.0-mysql                    7.0.33-0+deb9u3                    amd64        MySQL module for PHP
iU  php7.0-opcache                  7.0.33-0+deb9u3                    amd64        Zend OpCache module for PHP
iU  php7.0-readline                 7.0.33-0+deb9u3                    amd64        readline module for PHP
iU  php7.0-xml                      7.0.33-0+deb9u3                    amd64        DOM, SimpleXML, WDDX, XML, and XSL module for PHP
iU  php7.0-zip                      7.0.33-0+deb9u3                    amd64        Zip module for PHP
iU  phpmyadmin                      4:4.6.6-4                          all          MySQL web administration tool



dpkg -P $(dpkg -l | awk '$1~/^rc$/{print $2}')



(Lecture de la base de données... 47660 fichiers et répertoires déjà installés.)
Purge des fichiers de configuration de libsnmp15 (5.4.3~dfsg-2.8+deb7u1) ...
Purge des fichiers de configuration de perl-modules (5.14.2-21+deb7u5) ...
root@sebr:~# dpkg -l | grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                             Version                            Architecture Description
+++-===============================-==================================-============-===============================================================================
iU  dbconfig-common                 2.0.8                              all          framework that helps packages to manage databases
iU  dbconfig-mysql                  2.0.8                              all          dbconfig-common MySQL/MariaDB support
iU  javascript-common               11                                 all          Base support for JavaScript library packages
iU  libapache2-mod-php7.0           7.0.33-0+deb9u3                    amd64        server-side, HTML-embedded scripting language (Apache 2 module)
iU  libjs-jquery                    3.1.1-2+deb9u1                     all          JavaScript library for dynamic web applications
iU  libjs-sphinxdoc                 1.4.9-2                            all          JavaScript support for Sphinx documentation
iU  libjs-underscore                1.8.3~dfsg-1                       all          JavaScript's functional programming helper library
iU  liblua5.2-0:amd64               5.2.4-1.1+b2                       amd64        Shared library for the Lua interpreter version 5.2
iU  libzip4:amd64                   1.1.2-1.1+b1                       amd64        library for reading, creating, and modifying zip archives (runtime)
iU  php                             1:7.0+49                           all          server-side, HTML-embedded scripting language (default)
iU  php-bz2                         1:7.0+49                           all          bzip2 module for PHP [default]
iU  php-common                      1:49                               all          Common files for PHP packages
iU  php-curl                        1:7.0+49                           all          CURL module for PHP [default]
iU  php-gd                          1:7.0+49                           all          GD module for PHP [default]
iU  php-mbstring                    1:7.0+49                           all          MBSTRING module for PHP [default]
iU  php-mysql                       1:7.0+49                           all          MySQL module for PHP [default]
iU  php-pear                        1:1.10.1+submodules+notgz-9+deb9u1 all          PEAR Base System
iU  php-php-gettext                 1.0.12-0.1                         all          read gettext MO files directly, without requiring anything other than PHP
iU  php-phpseclib                   2.0.4-1                            all          implementations of an arbitrary-precision integer arithmetic library
iU  php-tcpdf                       6.2.12+dfsg2-1                     all          PHP class for generating PDF files on-the-fly
iU  php-xml                         1:7.0+49                           all          DOM, SimpleXML, WDDX, XML, and XSL module for PHP [default]
iU  php-zip                         1:7.0+49                           all          Zip module for PHP [default]
iU  php7.0                          7.0.33-0+deb9u3                    all          server-side, HTML-embedded scripting language (metapackage)
iU  php7.0-bz2                      7.0.33-0+deb9u3                    amd64        bzip2 module for PHP
iU  php7.0-cli                      7.0.33-0+deb9u3                    amd64        command-line interpreter for the PHP scripting language
iU  php7.0-common                   7.0.33-0+deb9u3                    amd64        documentation, examples and common module for PHP
iU  php7.0-curl                     7.0.33-0+deb9u3                    amd64        CURL module for PHP
iU  php7.0-gd                       7.0.33-0+deb9u3                    amd64        GD module for PHP
iU  php7.0-json                     7.0.33-0+deb9u3                    amd64        JSON module for PHP
iU  php7.0-mbstring                 7.0.33-0+deb9u3                    amd64        MBSTRING module for PHP
iU  php7.0-mysql                    7.0.33-0+deb9u3                    amd64        MySQL module for PHP
iU  php7.0-opcache                  7.0.33-0+deb9u3                    amd64        Zend OpCache module for PHP
iU  php7.0-readline                 7.0.33-0+deb9u3                    amd64        readline module for PHP
iU  php7.0-xml                      7.0.33-0+deb9u3                    amd64        DOM, SimpleXML, WDDX, XML, and XSL module for PHP
iU  php7.0-zip                      7.0.33-0+deb9u3                    amd64        Zip module for PHP
iU  phpmyadmin                      4:4.6.6-4                          all          MySQL web administration tool
 



apt-get install phpmyadmin



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
phpmyadmin est déjà la plus récente version disponible.
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 libapache2-mod-php7.0 : Dépend: apache2-api-20120211
                         Dépend: apache2-bin (>= 2.4.16) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).

Hors ligne

#8 26-06-2019 19:53:35

lagrenouille
Adhérent(e)
Lieu : Toulouse, con !
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : env i3-openbox_bépo
Inscription : 28-03-2012
Site Web

Re : Problème installation de phpmyadmin

tente un

apt full-upgrade



normalement ça prends en compte les dépendances


Veuillez laisser l’État dans la malpropreté ou vous avez trouvé en y entrant.

Hors ligne

#9 26-06-2019 19:59:10

sebr
Membre
Inscription : 31-01-2019

Re : Problème installation de phpmyadmin

En faite c'est ce paquet apache2.2-bin que j'arrive pas à virer et je pense que c'est lui qui bloque tout.

apt-get -f install



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  apache2-bin
Paquets suggérés :
  apache2-suexec-pristine apache2-suexec-custom
Les NOUVEAUX paquets suivants seront installés :
  apache2-bin
0 mis à jour, 1 nouvellement installés, 0 à enlever et 45 non mis à jour.
36 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/1 187 ko dans les archives.
Après cette opération, 4 185 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 47662 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../apache2-bin_2.4.25-3+deb9u7_amd64.deb ...
Dépaquetage de apache2-bin (2.4.25-3+deb9u7) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/apache2-bin_2.4.25-3+deb9u7_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/apache2/modules/httpd.exp », qui appartient aussi au paquet apache2.2-bin 2.2.22-13+deb7u11
dpkg-deb: erreur: le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/apache2-bin_2.4.25-3+deb9u7_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 



lagrenouille a écrit :

tente un

apt full-upgrade



normalement ça prends en compte les dépendances



Si je fais ta commande j'ai une erreur.

apt full-upgrade



-su: apt : commande introuvable
root@sebr:~# apt-get full-upgrade
E: L'opération full-upgrade n'est pas valable
 



Cette installation et sur un VPS qui commence à être pas mal et ça m'embête car j'ai pas envie de tout refaire, un collègue à pris le même et il a les mêmes erreurs ce apache2.2-bin doit être de base dans l'image Debian.
Merci de votre aide.

Quand je fais

dpkg-query -l


ii  apache2-doc                                   2.4.25-3+deb9u7             all                         Apache HTTP Server (on-site documentation)
ii  apache2-mpm-prefork                           2.2.22-13+deb7u11           amd64                       Apache HTTP Server - traditional non-threaded model
ii  apache2-utils                                 2.4.25-3+deb9u7             amd64                       Apache HTTP Server (utility programs for web servers)
ii  apache2.2-bin                                 2.2.22-13+deb7u11           amd64                       Apache HTTP Server common binary files
ii  apache2.2-common                              2.2.22-13+deb7u11



On vois que tout est encore la, le +deb7 signifie debian 7 ? Donc c'est pas tout jeune.

Dernière modification par sebr (26-06-2019 20:02:04)

Hors ligne

#10 26-06-2019 20:05:47

lagrenouille
Adhérent(e)
Lieu : Toulouse, con !
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : env i3-openbox_bépo
Inscription : 28-03-2012
Site Web

Re : Problème installation de phpmyadmin

alors laisse apt-get 
apt suffit


fais un su -l
mot de pass root

et

apt remove --purge apache2.2-bin




apt full-upgrade




que donne

dpkg -l | grep apache2

Dernière modification par lagrenouille (26-06-2019 20:13:09)


Veuillez laisser l’État dans la malpropreté ou vous avez trouvé en y entrant.

Hors ligne

#11 26-06-2019 20:16:45

sebr
Membre
Inscription : 31-01-2019

Re : Problème installation de phpmyadmin

Je peux rien faire en apt

su -l



Mot de passe :
root@sebr:~# apt remove --purge apache2.2-bin
-su: apt : commande introuvable
 



Apt est aussi une ancienne version

ii  apt  0.9.7.9+deb7u7

Hors ligne

#12 26-06-2019 21:24:59

lagrenouille
Adhérent(e)
Lieu : Toulouse, con !
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : env i3-openbox_bépo
Inscription : 28-03-2012
Site Web

Re : Problème installation de phpmyadmin

alors là ! je ne pige rien à ton installation, ni ce que c'est, ni comment c'est installé, pour moi c'est du jamais vu..

tu installes comment ta debian ?

Veuillez laisser l’État dans la malpropreté ou vous avez trouvé en y entrant.

Hors ligne

#13 26-06-2019 21:28:02

sebr
Membre
Inscription : 31-01-2019

Re : Problème installation de phpmyadmin

C'est un VPS de chez Dedigo, je choisi la distrib dans une liste et le VPS et installé.
Je suis pas un pro Linux mais je comprends pas comment un debian 9 possède des paquets de deb 7 surtout quand on par de zéro avec un OS vide.

Hors ligne

#14 27-06-2019 08:05:51

sebr
Membre
Inscription : 31-01-2019

Re : Problème installation de phpmyadmin

Je confime on a remis à 0 le VPS du collègue et apache et en apache2.2 deb7 sad

Dernière modification par sebr (27-06-2019 08:31:39)

Hors ligne

#15 28-06-2019 07:12:19

sebr
Membre
Inscription : 31-01-2019

Re : Problème installation de phpmyadmin

Bon j'ai contacté dedigo pour une éventuel aide car leur distrib et pourri la réponse "Pas de support logiciel" du coup je recommence tout !
Merci pour votre aide.

Hors ligne

#16 28-06-2019 07:25:32

lagrenouille
Adhérent(e)
Lieu : Toulouse, con !
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : env i3-openbox_bépo
Inscription : 28-03-2012
Site Web

Re : Problème installation de phpmyadmin

effectivement, c'est des ordures et des voleurs , faut mieux louer un espace chez ovh et tout installer sois-même

Veuillez laisser l’État dans la malpropreté ou vous avez trouvé en y entrant.

Hors ligne

#17 28-06-2019 12:57:27

sebr
Membre
Inscription : 31-01-2019

Re : Problème installation de phpmyadmin

Je viens de faire une belle prépa avec mise à jour de la distrib, des paquets de apache 2 tout était OK et au reboot plus rien. Sur l'espace client plus que 3 services en route pour un collègue pareil. On a pris ça pour tester commencer à ce faire la main donc le prix à 1€ été bien.
Du coup y a mieux niveau config à 1.99€ chez Onetsolution on va voir. Si c'est encore chiant bin je passe chez OVH smile

Hors ligne

#18 29-06-2019 11:48:45

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.8 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Problème installation de phpmyadmin

sebr a écrit :

Bon j'ai contacté dedigo pour une éventuel aide car leur distrib et pourri la réponse "Pas de support logiciel" du coup je recommence tout !


Vu ce que tu nous as montré, « Pas de support logiciel » est totalement justifié.
Bah oui, ils semblent incapables de faire quelque chose d’aussi simple qu’une installation de Debian stable avec Apache, tu leur confierais vraiment du support logiciel ?

Quelle bande d’escrocs…

-----

Pour ma part, à titre pro je prends nos VPS chez Digital Ocean et c’est aussi ce que j’utiliserai je pense quand j’en aurai besoin à titre perso.
Par contre, c’est plus cher que les exemples que tu donnes (le plus petit VPS est à 5€ par mois) et je ne pense pas qu’il y ait une équipe de support francophone.

Une alternative francophone que j’apprécie aussi est Infomaniak.
Chez eux ce n’est vraiment pas donné, le plus petit VPS est à 30€ par mois.


Jouer sous Debian ? Facile !

En ligne

#19 29-06-2019 12:57:43

eZoulou
Membre
Lieu : St Antoine l'Abbaye
Distrib. : Debian GNU/Linux 7.2 (wheezy)
Noyau : Linux 3.8.13-xxxx-grs-ipv6-64-vps
Inscription : 29-06-2019
Site Web

Re : Problème installation de phpmyadmin

Bonjour,
Je rencontre exactement le même problème, mais sur un VPS de OVH.
Et votre thread m'a redonné espoir :-)

En gros, apt-get bloque suite à ma tentative de passer de php 5.4 à 7.0
Voici ce que j'ai dans le terminal :

apt-get remove --purge apache2.2-bin
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 apache2-mpm-prefork : Dépend: apache2.2-bin (= 2.2.22-13) mais ne sera pas installé
 apache2.2-common : Dépend: apache2.2-bin (= 2.2.22-13) mais ne sera pas installé
 libapache2-mod-php7.0 : Dépend: apache2-api-20120211
                         Dépend: apache2-bin (>= 2.4.16) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).


apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libaio1 libclass-isa-perl libdbi-perl libhtml-template-perl libnet-daemon-perl libplrpc-perl libswitch-perl mysql-server-core-5.5
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  apache2-bin
Paquets suggérés :
  apache2-doc apache2-suexec-pristine apache2-suexec-custom
Les NOUVEAUX paquets suivants seront installés :
  apache2-bin
0 mis à jour, 1 nouvellement installés, 0 à enlever et 264 non mis à jour.
70 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/1 187 ko dans les archives.
Après cette opération, 4 185 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? O
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/^(.*?)(\\)?\${ <-- HERE ([^{}]+)}(.*)$/ at /usr/share/perl5/Debconf/Question.pm line 72.
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/\${ <-- HERE ([^}]+)}/ at /usr/share/perl5/Debconf/Config.pm line 30.
(Lecture de la base de données... 30115 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../apache2-bin_2.4.25-3+deb9u7_amd64.deb ...
Dépaquetage de apache2-bin (2.4.25-3+deb9u7) ...
dpkg: erreur de traitement de l'
archive /var/cache/apt/archives/apache2-bin_2.4.25-3+deb9u7_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/apache2/modules/httpd.exp », qui appartient aussi au paquet apache2.2-bin 2.2.22-13
dpkg-deb: erreur: le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/apache2-bin_2.4.25-3+deb9u7_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



QQ'un aurait une piste pour débloquer apt-get?
Merci d'avance,
Florent

Dernière modification par eZoulou (29-06-2019 12:58:41)

Hors ligne

#20 29-06-2019 13:32:17

sebr
Membre
Inscription : 31-01-2019

Re : Problème installation de phpmyadmin

Bon me revoilà avec un nouveau VPS de chez Onetsolution, rien à voir au niveau de la distrib qui est à jour et pas avec des paquets d'un déb 7.
J'ai donc tout refait sans problème jusqu’à ce que je bloque ici durant la configuration de phpmyadmin.
J'ai installé MariaDB 10 (Avec ce tuto https://www.geek17.com/fr/content/debia … mariadb-65 ) puis ensuite phpmyadmin. la connexion à la base de donnée est OK mais durant l'installation ça bloque pourtant le mot de passe est bon.

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)



Mreci de votre aide.

Dernière modification par sebr (29-06-2019 13:56:36)

Hors ligne

#21 29-06-2019 13:44:16

lagrenouille
Adhérent(e)
Lieu : Toulouse, con !
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : env i3-openbox_bépo
Inscription : 28-03-2012
Site Web

Re : Problème installation de phpmyadmin

ça semble être l’accès à mysql

tu as un mot de pass mysql ?

mysql -u root

Enter password: xxxxxxxx

GRANT ALL PRIVILEGES on *.* to 'root'@'localhost' identified by 'ton nouveaumotdepasse';
flush privileges;


Veuillez laisser l’État dans la malpropreté ou vous avez trouvé en y entrant.

Hors ligne

#22 29-06-2019 13:48:07

sebr
Membre
Inscription : 31-01-2019

Re : Problème installation de phpmyadmin

J'ai pas fini l'assistant, j'ai ignoré pour reprendre la main sur la console et quand je test ma connexion à phpmyadmin ça fonctionne en root je sais pas pourquoi.
Pour ta commande ça me donne cela

mysql -u root


ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
 

Dernière modification par sebr (29-06-2019 13:48:37)

Hors ligne

#23 29-06-2019 13:49:41

lagrenouille
Adhérent(e)
Lieu : Toulouse, con !
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : env i3-openbox_bépo
Inscription : 28-03-2012
Site Web

Re : Problème installation de phpmyadmin

essaie ça


mysql -u root -p
Enter Password : (vous tapez entrer)
 
MariaDB [(none)]> UPDATE mysql.user SET plugin = NULL WHERE user = 'root' AND plugin = 'unix_socket';
MariaDB [(none)]> FLUSH PRIVILEGES;
MariaDB [(none)]> SET PASSWORD FOR root@'localhost'=PASSWORD('mon_nouveau_mot-de_passe');




voir autrement plus simple

http://www.octetmalin.net/linux/tutorie … e-root.php

Dernière modification par lagrenouille (29-06-2019 13:59:16)


Veuillez laisser l’État dans la malpropreté ou vous avez trouvé en y entrant.

Hors ligne

#24 29-06-2019 14:00:02

sebr
Membre
Inscription : 31-01-2019

Re : Problème installation de phpmyadmin

mysql -u root -p
Enter password:


Si je fais entré j'ai
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
ici le login fonctionne avec le code que j'ai créé


Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 575
Server version: 10.1.38-MariaDB-0+deb9u1 Debian 9.8
Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.
Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
MariaDB [(none)]> UPDATE mysql.user SET plugin = NULL WHERE user = 'root' AND plugin = 'unix_socket';
Query OK, 0 rows affected (0.00 sec)
Rows matched: 0  Changed: 0  Warnings: 0
 



Une truc c'est que dans le tuto que j'ai suivi il dit de supprimer unix_socket du coup pendent la config de phpmyadmin j'ai choisi TCP/IP m'avait quand même l'erreur j'aurais pas du suivre son tuto ?

C'est à cause de ce plugin unix_socket que la connexion root est refusée lorsqu'on se connecte à la base sans sudo.
Pour remédier au problème, tapez la requête UPDATE user SET plugin='' WHERE User='root'; qui supprimera ce plugin pour l'utilisateur root.



Merci pour ton aide j'avance bien.

Dernière modification par sebr (29-06-2019 14:03:52)

Hors ligne

#25 29-06-2019 14:01:09

lagrenouille
Adhérent(e)
Lieu : Toulouse, con !
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : env i3-openbox_bépo
Inscription : 28-03-2012
Site Web

Re : Problème installation de phpmyadmin

oui, c'est pour ça que j'ai rajouté un lien

Veuillez laisser l’État dans la malpropreté ou vous avez trouvé en y entrant.

Hors ligne

Pied de page des forums