Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-07-2019 13:48:53

redelap
Membre
Lieu : SAINTES 17
Distrib. : Buster en Xfce & Raspbian
Noyau : Linux 4.19.0.6 - amd64
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

Les codecs et Débian Stretch

Bonjour
Après avoir installé sur une vieille machine une distribution LinuxMint LMDE3, j'ai procédé à l'installation des "codecs propriétaires" proposée dans ses menus système.
Très bonne chose, puisque Netflix fonctionne parfaitement sur cette machine, ainsi que tous les autres utilitaires multimédia (CD-DVD etc...)
Problème... Comment installer ces codecs dans ma distribution Stretch ?  Car Netflix ne fonctionne pas sur ma machine... et cette proposition d'installation n'existe pas...
FireFox, Chromium et Opéra échouent...
Et je ne sais pas où trouver ces codecs compatibles Débian
Merci de vos lumières

Dernière modification par redelap (04-07-2019 14:21:08)


Debian-10.1-Xfce buster sur Lenovo LEGION Y520- SSD128 + HD1000 - 8Go
Vieux MacBook X.6.8 - Raspbian Buster sur Raspberry Pi4

Hors ligne

#2 04-07-2019 14:47:19

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : Les codecs et Débian Stretch

Les DVDs c'est libdvdcss2 qui s'installe comme ça chez debian :

apt instal libdvd-pkg
dpkg-reconfigure libdvd-pkg



Pour le CDs j'ai jamais eu de souci, et pour netflix je suis contre les DRM, donc je veux même pas savoir comment on fait wink


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

En ligne

#3 05-07-2019 12:10:59

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Les codecs et Débian Stretch

Hello
apparemment il faut installer un module pour changer l'user agent

et même plus besoin d’âpres des articles plus récent netflix est en html5 et fonctionne sous firefox

Dernière modification par Croutons (05-07-2019 12:17:11)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#4 06-07-2019 16:46:22

redelap
Membre
Lieu : SAINTES 17
Distrib. : Buster en Xfce & Raspbian
Noyau : Linux 4.19.0.6 - amd64
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

Re : Les codecs et Débian Stretch

Merci croutons pour ta réponse toujours avisée.
Oui.. ça fonctionne sous Firefox d'une distribution LMDE3, (qui permet une install de quelques codecs propriétaires) mais pas sous une distribution Stretch.... malgré les mises à Jour Firefox dans Stretch. Même chose pour Opéra et Chromium..... C'est ce qui m'amène à penser un cause du coté système et non du coté  navigateur.(s)..

La connexion à Netflix se fait... On voit les propositions de films défiler, et je peux cliquer sur un d'eux.. et Bing ! "Oups ... un problème est survenu..."... erreur de lecture..
Code d'erreur : F7701-1003

J'ai une version qui semblerait adhoc (60.7.2esr), et qui est déjà installée (en vert dans synaptic)...Je vais retenter une onstall avec synaptic.

Après réinstall avec synaptic j'obtiens ceci en update et upgrade

root@debian:/home/remy#  apt-get update
Atteint:1 http://download.virtualbox.org/virtualbox/debian stretch InRelease
Ign:2 http://deb.debian.org/debian stretch InRelease                                                                  
Réception de:3 http://security.debian.org stretch/updates InRelease [93,6 kB]                                          
Atteint:4 http://linux.teamviewer.com/deb stable InRelease                                                            
Atteint:5 http://www.deb-multimedia.org stable InRelease                                                              
Réception de:6 http://deb.debian.org/debian stretch-updates InRelease [90,3 kB]                                        
Réception de:7 http://deb.debian.org/debian stretch-backports InRelease [91,1 kB]                
Réception de:8 https://deb.opera.com/opera-stable stable InRelease [2 591 B]                    
Réception de:9 http://security.debian.org/debian-security stretch/updates InRelease [93,6 kB]                          
Réception de:10 https://deb.opera.com/opera-stable stable/non-free amd64 Packages [1 804 B]      
Atteint:11 http://deb.debian.org/debian stretch Release                                                  
Réception de:12 http://security.debian.org stretch/updates/main i386 Packages [501 kB]          
Réception de:14 http://security.debian.org stretch/updates/main amd64 Packages [499 kB]
Réception de:15 http://security.debian.org/debian-security stretch/updates/main Sources [208 kB]
1 580 ko réceptionnés en 1s (834 ko/s)                      
Lecture des listes de paquets... Fait

root@debian:/home/remy# apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  libdvdcss-dev libdvdcss2
0 mis à jour, 0 nouvellement installés, 0 à enlever et 2 non mis à jour.
root@debian:/home/remy# apt-get upgrade libdvdcss-dev libdvdcss2
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Calcul de la mise à jour... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'
ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'
information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libdvdcss2-dbgsym : Dépend: libdvdcss2 (= 1.4.0-1~local)
E: Paquets défectueux
 



là je ne sais plus faire..... Help !

Dernière modification par redelap (06-07-2019 17:06:28)


Debian-10.1-Xfce buster sur Lenovo LEGION Y520- SSD128 + HD1000 - 8Go
Vieux MacBook X.6.8 - Raspbian Buster sur Raspberry Pi4

Hors ligne

#5 06-07-2019 19:04:53

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Les codecs et Débian Stretch

que donne

apt policy libdvdcss2


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#6 06-07-2019 23:11:35

redelap
Membre
Lieu : SAINTES 17
Distrib. : Buster en Xfce & Raspbian
Noyau : Linux 4.19.0.6 - amd64
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

Re : Les codecs et Débian Stretch

Retour de "apt policy libdvdcss2"

 


remy@debian:~$ apt policy libdvdcss2
libdvdcss2:
  Installé : 1.4.0-1~local
  Candidat : 1.4.0-dmo1
 Table de version :
     1.4.0-dmo1 100
        100 http://www.deb-multimedia.org stable/main amd64 Packages
 *** 1.4.0-1~local 100
        100 /var/lib/dpkg/status
 


Debian-10.1-Xfce buster sur Lenovo LEGION Y520- SSD128 + HD1000 - 8Go
Vieux MacBook X.6.8 - Raspbian Buster sur Raspberry Pi4

Hors ligne

#7 07-07-2019 08:25:42

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Les codecs et Débian Stretch

Je suis jamais très chaud avec les sources qui contiennent stable car cela pose problème quand Debian change de version, puisque maintenant Buster est la nouvelle stable
il vaux mieux préciser quand le dépôt le permet le non de la distribution Stretch ou Buster
Je crois bien que le conflit de dépendance vient de la, c'est comme si tu avais mis Buster dans tes sources
vois icihttp://www.deb-multimedia.org/

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#8 07-07-2019 21:04:37

redelap
Membre
Lieu : SAINTES 17
Distrib. : Buster en Xfce & Raspbian
Noyau : Linux 4.19.0.6 - amd64
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

Re : Les codecs et Débian Stretch

Merci.. je vais regarder ça de près mardi ou mercredi.. Pa sle temps maintenant.
A bientôt

Debian-10.1-Xfce buster sur Lenovo LEGION Y520- SSD128 + HD1000 - 8Go
Vieux MacBook X.6.8 - Raspbian Buster sur Raspberry Pi4

Hors ligne

Pied de page des forums