Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 06-07-2019 18:23:17

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : Pb mpd

Jean-Pierre Pinson a écrit :

bon allons y je fais comme toi: je préfère utiliser systemd et une socket unix.

donc je fais comment ? parce que je ne suis pas très fort en informatique https://debian-facile.org/img/smilies/x … chhead.gif


Bien, alors il va falloir de nouveau éditer les fichiers


~/.mpd/mpd.conf
 


et


~/.ncmpcpp/config
 



Dans le fichier ~./.mpd/mpd.conf tu as :


bind_to_address   "localhost"
 


À la place tu mets :


bind_to_address   "/run/user/1000/mpd/socket"
 



Dans le fichier ~/.ncmpcpp/config tu as :


mpd_host = localhost
 


À la place tu remets :


mpd_host = /run/user/1000/mpd/socket
 



Ensuite tu crées le répertoire ~/.config/systemd/user si il n'existe
pas déjà :


mkdir -p ~/.config/systemd/user
 



Maintenant on va créer deux fichiers dans le répertoire
~/.config/systemd/user, mpd.service et mpd.socket.

Pour le fichier mpd.service tu mettras :


[Unit]
Description=Music player daemon
Require=mpd.socket

[Service]
Type=notify
ExecStart=/usr/bin/mpd --no-daemon
Restart=on-failure

[Install]
WantedBy=default.target
 



Pour le fichier mpd.socket tu mettras :


[unit]
Description=Music player daemon socket

[Socket]
ListenStream=%t/mpd/socket
Backlog=5
PassCredentials=true
SocketMode=0600
DirectoryMode=0700

[Install]
WantedBy=sockets.target
 



Puis tu feras depuis le shell :


systemctl --user --now enable mpd
 


Ça va créer les 2 répertoires .config/systemd/user/default.target.wants
et .config/systemd/user/sockets.target.wants.
Dans ces répertoires il y aura des liens symboliques vers les deux
fichiers précédemment créés. En plus de cela ça va démarrer
le service, c'est à dire que ça devrait créer le répertoire
/run/user/1000/mpd et le fichier socket dedans. Puis ça va démarrer
mpd qui devrait écouter sur cette socket.

Important : Mais avant tout il faut pouvoir le démarrer manuellement.
En attendant que ça marche tu peux mettre cette configuration en
suspens. Tu le feras quand tu pourras démarrer manuellement mpd, et
que ça ne causera pas de message d'erreur, et que tu pourras accéder à
ta musique depuis ncmpcpp.

Hors ligne

#27 06-07-2019 19:03:23

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Pb mpd

je ne touche pas aux répertoires playlists et tagcache dans ~/.mpd ?

Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#28 06-07-2019 19:08:18

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : Pb mpd

Jean-Pierre Pinson a écrit :

je ne touche pas aux répertoires playlists et tagcache dans ~/.mpd ?


enicar a écrit :

Tu devrais effacer des fichiers dans ~/.mpd, tous sauf le mpd.conf bien sûr.



Tu effaces tous les fichiers dans le répertoires ~/.mpd/ sauf le fichier mpd.conf.
Y a-t-il de quelque chose de pas clair dans cette phrase ?

EDIT :Le répertoire playlists on s'en fiche, quant à tagcache ça
ne devrait pas être un répertoire mais un fichier !

Dernière modification par enicar (06-07-2019 19:12:18)

Hors ligne

#29 06-07-2019 19:11:31

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Pb mpd

ok c'était pour être sur

donc je n'ai pas touché au répertoirs

Dernière modification par Jean-Pierre Pinson (06-07-2019 19:13:34)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#30 06-07-2019 19:15:42

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : Pb mpd

Jean-Pierre Pinson a écrit :

ok c'était pour être sur


Mais ça ne résoudra pas le problème du répertoire /media/jpp/T/Music.

Hors ligne

#31 06-07-2019 19:17:02

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : Pb mpd

Jean-Pierre Pinson a écrit :

donc je n'ai pas touché au répertoirs


Euh, tu as bien supprimé tagcache quand même ? Parce que tagcache
ne doit pas être un répertoire !

Hors ligne

#32 06-07-2019 19:22:18

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : Pb mpd

Tiens au fait tu me diras ce que répond cette commande :


grep /media/jpp/T /proc/mounts
 


Et si ça retourne rien, tu voudras me donner le résultat de


cat /proc/mounts
 

Hors ligne

#33 06-07-2019 19:47:12

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Pb mpd

quand je fais en user

systemctl --user --now enable mpd


j'ai comme retour

Failed to execute operation: No such file or directory

Dernière modification par Jean-Pierre Pinson (06-07-2019 19:47:34)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#34 06-07-2019 19:51:11

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : Pb mpd

Jean-Pierre Pinson a écrit :

quand je fais en user

systemctl --user --now enable mpd


j'ai comme retour

Failed to execute operation: No such file or directory



De toute façon, je t'avais dis qu'on passerait à cette étape, lorsque tu pourras démarrer mpd sans erreurs et que tu pourras générer.

D'autre part, que dit :


ls ~/.config/systemd/user
 

Hors ligne

#35 06-07-2019 20:00:17

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Pb mpd

le résultat de

cat /proc/mounts


https://debian-facile.org/paste-72533AF7A6


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#36 06-07-2019 20:04:32

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : Pb mpd

Bon pas étonnant que mpd ne puisse pas fonctionner. Le  répertoire /media/jpp/T/
ne fait pas partie des répertoires montés.
Et maintenant que donne


ls /media/jpp/T
 


juste pour confirmer.

Hors ligne

#37 06-07-2019 20:16:18

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Pb mpd

oui donc j'ai compris, Il fallait que je clique sur T, dans Thunar, pour que le répertoire soit monté wink

et là j'ai

 ls /media/jpp/T
Music

Dernière modification par Jean-Pierre Pinson (06-07-2019 20:18:11)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#38 06-07-2019 20:18:57

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : Pb mpd

Jean-Pierre Pinson a écrit :

oui donc j'ai compris, Il fallait que je clique sur T, dans Thunar, pour que le répertoire soit monté


Ça va être problématique, car quand mpd va être démarré au début de ta session,
ce répertoire ne sera pas monté. Enfin, il faut tester.
Sinon, c'est possible de faire un montage automatique, mais ça sort largement
du propos de ce fil.

Hors ligne

#39 06-07-2019 20:23:08

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Pb mpd

bon ok que fait je maintenant ?

 $ mpd
Jul 06 21:24 : socket: Failed to bind to '/run/user/1000/mpd/socket': No such file or directory

Dernière modification par Jean-Pierre Pinson (06-07-2019 20:26:17)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#40 06-07-2019 20:26:09

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : Pb mpd

Jean-Pierre Pinson a écrit :

bon ok que fait je maintenant ? Je lance ncmpcpp ?



Si mpd à démarrer sans erreur et que tu as bien le même réglage pour l'utilisation
de la socket. Oui tu démarre ncmpcpp, et tu tapes « u ».

Mais était-il besoin de demander ?

Hors ligne

#41 06-07-2019 20:26:58

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Pb mpd

$ mpd
Jul 06 21:24 : socket: Failed to bind to '/run/user/1000/mpd/socket': No such file or directory

Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#42 06-07-2019 20:32:02

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : Pb mpd

Jean-Pierre Pinson a écrit :

$ mpd
Jul 06 21:24 : socket: Failed to bind to '/run/user/1000/mpd/socket': No such file or directory


C'est ce que je craignais. Tu as changé la config pour utiliser
la socket unix, mais comme le répertoire /run/user/1000/mpd n'existe
pas, ça provoque une erreur car mpd ne peut créer le fichier.
Donc pour faire court, on va créer ce répertoire :


mkdir -m 700 /run/user/1000/mpd
 



Et ensuite tu redémarreras mpd.

Hors ligne

#43 06-07-2019 20:43:30

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Pb mpd

mpd
Jul 06 21:42 : errno: Failed to open /home/jpp/.mpd/tagcache: No such file or directory
 


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#44 06-07-2019 20:48:20

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : Pb mpd

Jean-Pierre Pinson a écrit :

mpd
Jul 06 21:42 : errno: Failed to open /home/jpp/.mpd/tagcache: No such file or directory
 


Bon est-ce que mpd tourne :


ps -C mpd
 

Hors ligne

#45 06-07-2019 20:58:18

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Pb mpd

ps -C mpd
  PID TTY          TIME CMD
 3654 ?        00:11:16 mpd


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#46 06-07-2019 21:08:15

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : Pb mpd

Bref, il fonctionne. Donc tu démarres ncmpcpp et tapes « u ».

Hors ligne

#47 06-07-2019 21:22:24

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Pb mpd

C'est bon ça fonctionne j'arrive a lire ma musique smile Merci enicar wink

Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#48 06-07-2019 21:33:06

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : Pb mpd

Jean-Pierre Pinson a écrit :

C'est bon ça fonctionne j'arrive a lire ma musique smile Merci enicar wink


Ce n'est pas fini. Quand tu vas redémarrer ta machine mpd ne sera pas démarré.
et si tu essayes de le démarrer manuellement, ça ne fonctionnera pas
à cause de la socket dans /run/user/1000/mpd.

Bref à présent il faut le démarrer depuis systemd et ce n'est pas sûr que ça fonctionne
non plus à cause du fait que le répertoire n'est pas monté au moment où tu démarres
mpd.

Hors ligne

#49 06-07-2019 21:38:40

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Pb mpd

ah ok donc il faut faire quoi maintenant ?

Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#50 06-07-2019 21:45:09

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : Pb mpd

Jean-Pierre Pinson a écrit :

ah ok donc il faut faire quoi maintenant ?


On verra ça un autre jour. Pour aujourd'hui c'est assez. Normalement tu as tous les
éléments dans le post #26 en ce qui concerne les deux fichiers pour systemd.

Hors ligne

Pied de page des forums