Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#51 09-07-2019 23:32:08

trapik
Membre
Lieu : bretagne
Distrib. : buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : xfce
Inscription : 14-03-2013

Re : buster: pas de son (résolu)

tempest
c'est la même que pour les haut-parleurs

Beta-Pictoris
timidity est déjà installé , par contre je ne trouve pas de fichier .asoundrc

Hors ligne

#52 09-07-2019 23:37:41

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : buster: pas de son (résolu)

Désinstalle, donc, timidity et toutes ses dépendances et teste le son.
N'hésite pas à redémarrer ta machine si nécessaire.

Vérifie que tu as bien supprimé tous les paquets timidity:

dpkg -l timidity\*

Dernière modification par Beta-Pictoris (09-07-2019 23:41:52)

Hors ligne

#53 09-07-2019 23:40:08

tempest
Membre
Inscription : 09-07-2019

Re : buster: pas de son (résolu)

trapik ,

Tu peux déjà faire un test que j'ai fais....

Tu branches un casque et tu executes la commande hdajacksensetest , cela permet de valider que le driver de la carte semble fonctionner puisqu'il reconnait si quelque chose est branché sur la prise jack .

De mon côté, je viens de supprimer pulseaudio de mon système et du coup je n'ai même plus "sortie factice" dans la colonne sortie de paramètres/sons !

Cela confirme donc qu'il y a un problème entre les drivers de la carte et la gestion par pulseaudio ....

Hors ligne

#54 09-07-2019 23:53:03

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : buster: pas de son (résolu)

A noter, dans un premier temps, au lieu de désinstaller timidity, tu peux, juste, arrêter le daemon timidity et tester :

service timidity stop


Vérifie que le processus est bien arrêté :

pgrep -l timidity

Dernière modification par Beta-Pictoris (09-07-2019 23:58:21)

Hors ligne

#55 10-07-2019 00:01:58

trapik
Membre
Lieu : bretagne
Distrib. : buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : xfce
Inscription : 14-03-2013

Re : buster: pas de son (résolu)

Beta-Pictoris
timidity est installé depuis 3~4 heures donc pas la cause du manque de sons ( j'ai voulu tester le son MIDI  , si des fois que...)

tempest
désolé , pas de casque ...
d'où tu sors hdajacksensetest ? j'ai pas ça $ hdajacksensetest
bash: hdajacksensetest : commande introuvable


je suis d'accord avec toi , la gestion de pulseaudio laisse plus qu'à désirer...!!
par contre , comme disait Debian Alain ,  probleme de noyau ? (#8) , mais ce qui me parait bizarre c'est qu'il y ait si peu de gens qui ont ce problème

Hors ligne

#56 10-07-2019 00:14:21

tempest
Membre
Inscription : 09-07-2019

Re : buster: pas de son (résolu)

Trapik ....

hdajacksensetest est inclus dans le paquet des hda-tools, il y a plusieurs outils et celui la permet de voir si quelque chose est branché sur la prise jack !!

Beta-pictoris....

La solution de SUPPRESSION de TIMIDITY a fonctionné dans mon cas, je n'ai même pas eu à re-démarrer le PC, dès la suppression effectué, pulseaudio daemon a du reprendre la main sur le hardware qui devait être pris en exclusivité par TIMIDITY !! J'avais lu cette possibilité sur un autre forum mais je n'y ai pas cru !!

Bonne chance à toi Trapik, j'espère que cela fonctionnera aussi, je reste sur ce fil pour continuer à aider !

Hors ligne

#57 10-07-2019 00:45:06

trapik
Membre
Lieu : bretagne
Distrib. : buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : xfce
Inscription : 14-03-2013

Re : buster: pas de son (résolu)

tempest
veinard !! tongue
j'ai desinstallé , purgé   timidity et toujours rien , mais bon je m'y attendais vu que le problème était là bien avant l'installation de timidity
quant au paquet hda-tools , j'ai pas ça ! tu sors ça d'où ?
c'est p't être pour les intel  et pas les amd ?

la dessus , j'vais aller faire dormir les yeux  vu qu'j'en ai plein la tête ( pas de z'yeux: de tests et autres lignes de commande )

Hors ligne

#58 10-07-2019 03:58:01

enicar
Membre
Lieu : ailleurs
Inscription : 26-08-2010

Re : buster: pas de son (résolu)

Autre idée. Je voudrais voir l'intégralité du dmesg. Ce sont les messages du noyau.
On y voit les messages d'initialisations des pilotes. Ça permettrait de voir si il n'y a pas
un soucis de ce côté. Pour récupérer ces messages :


dmesg >dmesg.txt
 


Après il ne restera plus qu'à copier le contenu du fichier dmesg.txt.

Hors ligne

#59 10-07-2019 04:11:27

enicar
Membre
Lieu : ailleurs
Inscription : 26-08-2010

Re : buster: pas de son (résolu)

Aussi, pour info. J'ai une carte


 HDA ATI SB, ALC662
 


et elle est parfaitement reconnu et fonctionne. J'utilise debian/sid. Donc les pilotes sont à peu
près les mêmes que sur une buster actuellement (mais ça ne va pas durer).

Hors ligne

#60 10-07-2019 05:34:22

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 4.19.77-1-lts & 5.3.1-arch1-1-ARCH
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : buster: pas de son (résolu)

trapik a écrit :



golgot200
je ressaie ta commande ... et là elle passe !!! https://debian-facile.org/img/smilies/x … chhead.gif
pc1:~$ speaker-test -c2 -Dplug:front -t wav

speaker-test 1.1.8

Le périphérique de lecture est plug:front
Les paramètres du flux sont 48000Hz, S16_LE, 2 canaux
fichier(s) WAV
La fréquence est 48000Hz (demandée 48000Hz)
L'intervalle de la taille du tampon est de 64 à 524288
L'intervalle de la taille de la période est de 32 à 262144
Taille max. de tampon 524288 utilisée
Périodes = 4
was set period_size = 131072
was set buffer_size = 524288
0 - Front Left
1 - Front Right
Temps par période = 5,471858



Mais viré moi ce pulseaudio  big_smile big_smile big_smile

Dernière modification par golgot200 (10-07-2019 05:38:06)

En ligne

#61 10-07-2019 05:37:11

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 4.19.77-1-lts & 5.3.1-arch1-1-ARCH
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : buster: pas de son (résolu)

trapik a écrit :

tempest
veinard !! tongue
j'ai desinstallé , purgé   timidity et toujours rien , mais bon je m'y attendais vu que le problème était là bien avant l'installation de timidity
quant au paquet hda-tools , j'ai pas ça ! tu sors ça d'où ?
c'est p't être pour les intel  et pas les amd ?

la dessus , j'vais aller faire dormir les yeux  vu qu'j'en ai plein la tête ( pas de z'yeux: de tests et autres lignes de commande )




systemctl stop timidity
pulseaudio --kill
pulseaudio --start

En ligne

#62 10-07-2019 05:37:52

enicar
Membre
Lieu : ailleurs
Inscription : 26-08-2010

Re : buster: pas de son (résolu)

golgot200 a écrit :

Mais viré moi ce pulseaudio  big_smile big_smile big_smile


Je ne pense pas que le problème vienne de là. Mais ça vaudrait le coup d'essayer
de virer pulseaudio pour voir si on peut sortir du son directement via alsa.

Hors ligne

#63 10-07-2019 05:39:38

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 4.19.77-1-lts & 5.3.1-arch1-1-ARCH
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : buster: pas de son (résolu)

enicar a écrit :

golgot200 a écrit :

Mais viré moi ce pulseaudio  big_smile big_smile big_smile


Je ne pense pas que le problème vienne de là. Mais ça vaudrait le coup d'essayer
de virer pulseaudio pour voir si on peut sortir du son directement via alsa.



Regardes le post 44 wink

En ligne

#64 10-07-2019 05:47:29

enicar
Membre
Lieu : ailleurs
Inscription : 26-08-2010

Re : buster: pas de son (résolu)

golgot200 a écrit :

Regardes le post 44 wink


En effet, ça ne marche pas avec pulseaudio. Avec alsa seul ça fonctionnerait.
Il y aussi la solution d'utiliser jackd… et de dire à pulseaudio d'utiliser jackd…
bon d'accord, ça fait compliqué, mais ça permet au application qui ne savent
pas causer à jackd directement de pouvoir sortir du son quand même.
Chez moi, j'ai fait même mieux, j'ai deux cartes sons, une interne et l'autre externe
(sur firewire), l'interne est gérée par pulseaudio et l'externe est gérée par jackd avec
un renvoi de pulseaudio vers jackd.

Hors ligne

#65 10-07-2019 05:52:30

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 4.19.77-1-lts & 5.3.1-arch1-1-ARCH
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : buster: pas de son (résolu)

Un jour, il faudra qu'on m'explique à quoi sert vraiment pulseaudio. Chez moi, si je l'installe, je sais qu'à un moment donné ça me mettra le boxon au niveau de mes réglages. smile

Dernière modification par golgot200 (10-07-2019 05:53:45)

En ligne

#66 10-07-2019 07:42:21

seb95
Membre
Distrib. : openSUSE Leap et Tumbleweed
(G)UI : GNOME, Xfce et KDE
Inscription : 19-02-2017
Site Web

Re : buster: pas de son (résolu)

Bon de mon coté apres cette upgrade qui me donnait plus de son, j'ai réinstallé debian 10 et j'avais du son, sauf que par la suite j'ai ajouté le contrib et nonfree dans source.liste, puis installé les drivers linux-nonfree et depuis plus rien.

Avant ça j'avais bien les noms de mes cartes son, et depuis j'ai carte factice....

Si ça peut aider quelqu'un.

Hors ligne

#67 10-07-2019 07:44:45

seb95
Membre
Distrib. : openSUSE Leap et Tumbleweed
(G)UI : GNOME, Xfce et KDE
Inscription : 19-02-2017
Site Web

Re : buster: pas de son (résolu)

Bon je reprends, avant de desinstaller linuxnonfree pour voir si ça venait bien de la, j'ai stopper timidity et de nouveau j'ai mes cartes sons, peut on me dire car je ne vois pas qu'est que c'est que ce truc la sequenceur de reseau, me dire ce qu'est timidity? Et est il installé par défaut?

Et le bug est connu:
https://bugs.debian.org/cgi-bin/bugrepo … bug=929505

Dernière modification par seb95 (10-07-2019 08:23:49)

Hors ligne

#68 10-07-2019 12:55:36

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 4.19.77-1-lts & 5.3.1-arch1-1-ARCH
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : buster: pas de son (résolu)

seb95 a écrit :

Bon je reprends, avant de desinstaller linuxnonfree pour voir si ça venait bien de la, j'ai stopper timidity et de nouveau j'ai mes cartes sons, peut on me dire car je ne vois pas qu'est que c'est que ce truc la sequenceur de reseau, me dire ce qu'est timidity? Et est il installé par défaut?

Et le bug est connu:
https://bugs.debian.org/cgi-bin/bugrepo … bug=929505



Non timidity n'est pas installé par défaut sur une "Debian stretch". (du moins chez moi).
Je m'en servais pour lire mes fichiers midi ".mid"

Dernière modification par golgot200 (10-07-2019 13:54:51)

En ligne

#69 10-07-2019 13:01:25

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 4.19.77-1-lts & 5.3.1-arch1-1-ARCH
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : buster: pas de son (résolu)

Je lance une mise à jour d'une debian stretch "main" avec pulseaudio sur buster. Je verrai bien si j'ai des problème de son.

Dernière modification par golgot200 (10-07-2019 13:53:34)

En ligne

#70 10-07-2019 14:07:09

tempest
Membre
Inscription : 09-07-2019

Re : buster: pas de son (résolu)

seb95 a écrit :

Bon je reprends, avant de desinstaller linuxnonfree pour voir si ça venait bien de la, j'ai stopper timidity et de nouveau j'ai mes cartes sons, peut on me dire car je ne vois pas qu'est que c'est que ce truc la sequenceur de reseau, me dire ce qu'est timidity? Et est il installé par défaut?

Et le bug est connu:
https://bugs.debian.org/cgi-bin/bugrepo … bug=929505



C'est un synthetiseur de son MIDI .... donc principalement cela permet de lire des fichiers au format MIDI.

J'ai eu le problème lors de la migration de Debian 9 vers 10 avec "sortie factice" dans la liste des sorties sur le menu paramètre/son et lorsque j'ai désinstallé TIMIDITY, la carte son est ré-apparu immédiatement sans avoir à démarrer le PC.

donc il semble que TIMIDITY prend le contrôle sur la carte son (entre pulseaudio et les drivers ALSA) et cela empêche d'avoir le son et de voir la carte dans paramètre/son !

Hors ligne

#71 10-07-2019 14:30:44

trapik
Membre
Lieu : bretagne
Distrib. : buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : xfce
Inscription : 14-03-2013

Re : buster: pas de son (résolu)

ça marche ! woohoo.gif
fais une nouvelle réinstall : je m'étais aperçu qu'y avait un message au boot qui demandait des drivers radeon que j'avais installés, mais  cette fois j'ai fait dpkg-reconfigure linux-image-$(uname -r)
que je n'avais pas fait les fois précédentes
j'ai eu mon écran nickel , tout seul pas besoin de xrand   ouaip !
par contre toujours pas de son kernal_panic.gif
j'ai retripatouillé alsa : hdajackretask , alsamixer  et toujours "sortie ligne (unplugged ) ", pis après 2~3 reboot , j'ai du son !??...  et toujours  "sortie ligne (unplugged ) " yikes
me demandez pas pourquoi 1) ça marche  2) j'ai toujours ligne unplugged     ça doit faire partie des grands mystères de pulseaudio cool
par contre , pour pouvoir faire des recherches sur 'ternet,pendant l'install , j'ai repris mon portable ( asus) et me suis aperçu qu'il était en buster ( je ne m'en rappellais plus roll),
et pour lui tout s'est passé "fingers in nose" , pourquoi  alors que c'est pratiquement la configuration materielle (amd, ati ..)
mais  la carte son est la même que celle d' enicar et là , j'ai eu aucun problème ....

bon , je viens de ré-installé timidity  (parce que je me sers pas mal du MIDI) , mais j'ai toujours pas rebooté ..
j'ose pas parce que les ré-install et reboot   pfff   hmm


un grand
merci.gif 
à tous

Hors ligne

#72 10-07-2019 15:13:49

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 4.19.77-1-lts & 5.3.1-arch1-1-ARCH
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : buster: pas de son (résolu)

golgot200 a écrit :

Je lance une mise à jour d'une debian stretch "main" avec pulseaudio sur buster. Je verrai bien si j'ai des problème de son.



RAS pour ma part.

Dernière modification par golgot200 (10-07-2019 15:14:21)

En ligne

#73 10-07-2019 18:01:28

tempest
Membre
Inscription : 09-07-2019

Re : buster: pas de son (résolu)

golgot200 a écrit :

Je lance une mise à jour d'une debian stretch "main" avec pulseaudio sur buster. Je verrai bien si j'ai des problème de son.



Afin de confirmer le diagnostique précédent (TIMIDITY) , j'ai effectué les manipulations suivantes :

- Ré-installation de TIMIDITY (avec Synaptic)
- Re-démarrage du système
- Nouvelle perte du son avec "Sortie Factice" au niveau de Paramètre/sons !
- Nouvelle Désinstallation du paquet TIMIDITY (avec Synaptic)
- Re-démarrage du système
- Retour du son avec "Haut-parleurs - Audio Interne" au niveau de paramètre/sons !

A noter que avant de désinstaller de nouveau TIMIDITY, j'avais démarré une vidéo sur youtube avec Chromium pour voir si la désinstallation avec une vidéo en cours permettrait de retrouver le son sans re-démarrer le PC... Le résultat est que l'interface de lecture de youtube sur Chromium est devenu instable et que j'ai dû arrêter chromium sauvagement avant de re-démarrer le PC !!

Cela signifie que dans mon cas (LAPTOP LENOVO X201 avec son intégré sur la carte mère), il y a un problème sur buster avec l'installation de TIMIDITY. Je ne peux pas comparer avec Stretch parce que je ne me souviens pas d'avoir fait une installation de TIMIDITY mais que le paquet était peut-être déjà installé dans la version précédente.

Hors ligne

#74 10-07-2019 20:24:20

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : buster: pas de son (résolu)

Pour information, chez moi avec buster, j'ai le son qui se désactivait au bout d'un certain temps.

Pour régler le problème, j'ai dû passer les paramètres, ci-dessous, au module audio en les mettant dans un fichier .conf du répertoire /etc/modprobe.d/ :

cat /etc/modprobe.d/alsa.conf

options snd-hda-intel probe_mask=1


D'une manière générale, si vous avez des problèmes avec votre carte audio hda, vous pouvez tester pleins de paramètres en consultant le lien suivant :

https://www.kernel.org/doc/html/latest/ … index.html
.

Dernière modification par Beta-Pictoris (10-07-2019 20:26:05)

Hors ligne

#75 11-07-2019 15:01:22

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : buster: pas de son (résolu)

bonjour big_smile

si ton problème , c'est le mute automatique de pulse audio , hmm

j'ai eu un problème analogue avec ma carte son pcie . tongue

je te donne le lien . attention , car j'utilise la sortie optique . lol

ce n'est peut être pas ton cas .  ops.gif

http://linuxmao.org/Asus+Xonar+DGX+Unmu … l+Materiel

en cas de besoin , tu as le site (forums) de linuxMAO  guantas.png

aussi les canaux irc ( #linuxmao entre autres) 56kPowaa.gif

n.b.: dans mon exemple , j'ai désactivé la carte intégrée .
la carte pcie prenant sa place .
donc avec le même no puisque c'est devenu la carte par défaut .

pacmd "dump"|grep set-sink


set-sink-volume alsa_output.pci-0000_09_04.0.iec958-stereo 0x10955
set-sink-mute alsa_output.pci-0000_09_04.0.iec958-stereo no
set-sink-volume alsa_output.pci-0000_0c_00.3.iec958-stereo 0x10000
set-sink-mute alsa_output.pci-0000_0c_00.3.iec958-stereo no
 



amixer scontrols



Simple mixer control 'Master',0
Simple mixer control 'Capture',0
 



amixer


Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 67925 [104%] [on]
  Front Right: Playback 67925 [104%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 63068 [96%] [on]
  Front Right: Capture 63068 [96%] [on]
 



lspci -nnk | grep -ie multimedia -A 3



09:04.0 Multimedia audio controller [0401]: C-Media Electronics Inc CMI8788 [Oxygen HD Audio] [13f6:8788]
  Subsystem: ASUSTeK Computer Inc. CMI8788 [Oxygen HD Audio] (CMI8786 (Xonar DGX)) [1043:8521]
  Kernel driver in use: snd_oxygen
  Kernel modules: snd_oxygen
 

Dernière modification par Debian Alain (11-07-2019 15:40:19)


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

Pied de page des forums