Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-07-2019 16:39:32

Jim
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19
(G)UI : Gnome
Inscription : 14-07-2019

[Résolu] Problème d'installation de Debian Buster

Bonjour, suite à une installation en dual boot avec windows, au démarrage de Debian j'ai l'erreur suivante

amdGPU error



Je décide donc de modifier mon sources.list afin de pouvoir installer les paquets qui pourrait corriger mes problèmes



Il m'est impossible de lancer un

apt update







Si quelqu'un peut m'aider ce serait top ! big_smile

Dernière modification par Jim (14-07-2019 22:41:38)

Hors ligne

#2 14-07-2019 16:41:56

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : [Résolu] Problème d'installation de Debian Buster

Pas de réseau ?
Que donne ? :

ip a


nmcli

Dernière modification par Beta-Pictoris (14-07-2019 16:42:38)

Hors ligne

#3 14-07-2019 16:50:40

Jim
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19
(G)UI : Gnome
Inscription : 14-07-2019

Re : [Résolu] Problème d'installation de Debian Buster

Beta-Pictoris a écrit :

Pas de réseau ?
Que donne ? :

ip a


nmcli




file-R0e020685ccffa61809968fb6f4988ba0

file-Rb4b4ea15a61a6685b88d28922041f89b

Je suis branché en Ethernet pourtant

Hors ligne

#4 14-07-2019 17:19:55

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : [Résolu] Problème d'installation de Debian Buster

Lance un dhclient pour récupérer une adresse ip.

Cela dit, ta machine est en mode maintenance ?

Hors ligne

#5 14-07-2019 17:30:24

Jim
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19
(G)UI : Gnome
Inscription : 14-07-2019

Re : [Résolu] Problème d'installation de Debian Buster

Beta-Pictoris a écrit :

Lance un dhclient pour récupérer une adresse ip.

Cela dit, ta machine est en mode maintenance ?



Voila le retour du dhclient smile

file-R0d797a13022cf05c87d2baa818ce3456

Oui, l'interface graphique ne se lance pas à cause d'un firmware du GPU non installé je pense

Hors ligne

#6 14-07-2019 17:46:33

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : [Résolu] Problème d'installation de Debian Buster

Tu peux récupérer le firmware ici: http://ftp.fr.debian.org/debian/pool/no … -1_all.deb
Copie le sur une clé usb en fat.

monte la clé, par exemple ici /dev/sdx :

mount /dev/sdx1 /mnt


Et l'installe le paquet comme ceci:

dpkg -i /mnt/firmware-realtek_20190114-1_all.deb

Dernière modification par Beta-Pictoris (14-07-2019 17:49:03)

Hors ligne

#7 14-07-2019 18:12:17

Jim
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19
(G)UI : Gnome
Inscription : 14-07-2019

Re : [Résolu] Problème d'installation de Debian Buster

Beta-Pictoris a écrit :

Tu peux récupérer le firmware ici: http://ftp.fr.debian.org/debian/pool/no … -1_all.deb
Copie le sur une clé usb en fat.

monte la clé, par exemple ici /dev/sdx :

mount /dev/sdx1 /mnt


Et l'installe le paquet comme ceci:

dpkg -i /mnt/firmware-realtek_20190114-1_all.deb



Voila le retour de la commande

file-R426596ad07e564c7309338e002bcb974

Apparemment ma machine ne veut absolument pas de Debian crash.gif

Hors ligne

#8 14-07-2019 18:16:59

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : [Résolu] Problème d'installation de Debian Buster

Récupère et  installe, aussi, le firmware amd-graphics :

wget http://ftp.fr.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-amd-graphics_20190114-1_all.deb


Pour information, tu peux lancer ton système en mode console vt et non pas en mode graphique comme ceci:

systemctl set-default multi-user.target


Cela t'évitera de passer par la console de maintenance le temps que tu installes les firmwares.

Dernière modification par Beta-Pictoris (14-07-2019 18:29:21)

Hors ligne

#9 14-07-2019 18:27:47

Jim
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19
(G)UI : Gnome
Inscription : 14-07-2019

Re : [Résolu] Problème d'installation de Debian Buster

Beta-Pictoris a écrit :

Récupère et  installe, aussi, le firmware amd-graphics :

wget http://ftp.fr.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-amd-graphics_20190114-1_all.deb




file-R058ec0d8406d36da98d9aeafc9012347

Hors ligne

#10 14-07-2019 18:29:55

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : [Résolu] Problème d'installation de Debian Buster

Pour information, tu peux lancer ton système en mode console vt et non pas en mode graphique comme ceci:

systemctl set-default multi-user.target


Cela t'évitera de passer par la console de maintenance le temps que tu installes les firmwares.

Hors ligne

#11 14-07-2019 18:33:21

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : [Résolu] Problème d'installation de Debian Buster

scratchhead.gif
Je t'ai donné le lien avec un wget, mais tu dois bien-sûr lancer la commande d'une autre machine linux. smile

Ou télécharger les firmwares via un navigateur web. tongue

Dernière modification par Beta-Pictoris (14-07-2019 18:34:22)

Hors ligne

#12 14-07-2019 18:49:52

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : [Résolu] Problème d'installation de Debian Buster

Bonjour
pour utiliser le réseau en mode dépannage , il faut utiliser un fichier /etc/network/interfaces
et lorsque tu entre en mode depannage en root (entrer ton mdp root)
tu fais :


service networking start
 


tu a juste a vérifier que tu est bien en dhcp avec un fichier "interfaces" ou sinon si ça fonctionne pas c'est que tu utilise network-manager
un fichier interfaces ressemble a ceci (sauf le nom de la carte pour toi )


cat /etc/network/interfaces
 


le retour pour moi


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# enp2s0
auto enp2s0
iface enp2s0 inet dhcp
 



ensuite tu tape


apt-get update
 



apt-get install firmware-realtek firmware-amd-graphics
 


et reboot


reboot
 



tu a installé quoi comme bureau ?

si tu peu enlever toutes les photos , ce serait plus agréable a lire
pas besoin a chaque fois de poster une image , si tu donne une description de ton matériel on peu te dire ce qu'il te manque

teste ceci sur le mode maintenance , avec un peu de chance network-manager n'est pas utilisé


service networking start
 


et tu aura le réseau.

Dernière modification par robert2a (14-07-2019 18:58:49)

Hors ligne

#13 14-07-2019 19:37:48

Jim
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19
(G)UI : Gnome
Inscription : 14-07-2019

Re : [Résolu] Problème d'installation de Debian Buster

robert2a a écrit :

Bonjour
pour utiliser le réseau en mode dépannage , il faut utiliser un fichier /etc/network/interfaces
et lorsque tu entre en mode depannage en root (entrer ton mdp root)
tu fais :


service networking start
 


tu a juste a vérifier que tu est bien en dhcp avec un fichier "interfaces" ou sinon si ça fonctionne pas c'est que tu utilise network-manager
un fichier interfaces ressemble a ceci (sauf le nom de la carte pour toi )


cat /etc/network/interfaces
 


le retour pour moi


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# enp2s0
auto enp2s0
iface enp2s0 inet dhcp
 



ensuite tu tape


apt-get update
 



apt-get install firmware-realtek firmware-amd-graphics
 


et reboot


reboot
 



tu a installé quoi comme bureau ?

si tu peu enlever toutes les photos , ce serait plus agréable a lire
pas besoin a chaque fois de poster une image , si tu donne une description de ton matériel on peu te dire ce qu'il te manque

teste ceci sur le mode maintenance , avec un peu de chance network-manager n'est pas utilisé


service networking start
 


et tu aura le réseau.




Salut et merci pour ta réponse !

Du coup je ne suis pas en dhcp

auto lo
iface lo inet loopback


C'est tout ce qu'il me donne.

J'ai installé GNOME, Désolé pour la présentation un peu bordélique, je vais supprimer tout ça de ce pas big_smile

Après ça le

apt update

me renvoi toujours le même code d'erreur scratchhead.gif

Dernière modification par Jim (14-07-2019 19:39:54)

Hors ligne

#14 14-07-2019 19:52:52

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : [Résolu] Problème d'installation de Debian Buster

tu a juste a rajouter ceci a la fin de ton fichier "interfaces"
l'occasion d utiliser "nano"


nano /etc/network/interfaces
 



pour enregistrer "CTRL+ o" , pour sortir "CTRL + x"
juste a ajouter ceci a la fin


# enp2s0
auto enp2s0
iface enp2s0 inet dhcp
 



ta carte porte le même nom que la mienne
quand tu aura finit la mise au point , pour revenir a network-manager il te suffit d enlever ce que tu vient d'ajouter

fait un reboot et repasse en maintenance pour être sur que la modification est prise en compte

Dernière modification par robert2a (14-07-2019 19:55:12)

Hors ligne

#15 14-07-2019 20:02:42

Jim
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19
(G)UI : Gnome
Inscription : 14-07-2019

Re : [Résolu] Problème d'installation de Debian Buster

Malheureusement j'ai toujours le même résultat hmm

Ah non je n'avais pas vu ton édit !

Je vais finir mes mises au points et je te fait part du résultat après big_smile

Dernière modification par Jim (14-07-2019 20:04:53)

Hors ligne

#16 14-07-2019 20:25:24

Jim
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19
(G)UI : Gnome
Inscription : 14-07-2019

Re : [Résolu] Problème d'installation de Debian Buster

J'ai finalement réussi à faire toutes les manips que tu m'as conseillé avec succès big_smile

Malheureusement je n'ai toujours pas l'interface graphique quand je lance Debian scratchhead.gif

Je dois réinstaller l'environnement GNOME depuis le terminal ?

Dernière modification par Jim (14-07-2019 20:48:27)

Hors ligne

#17 14-07-2019 20:56:57

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : [Résolu] Problème d'installation de Debian Buster

As tu réussi à installer les firmwares ?
Que donne ?

dpkg -l firmware\*

Dernière modification par Beta-Pictoris (14-07-2019 20:57:54)

Hors ligne

#18 14-07-2019 21:08:38

Jim
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19
(G)UI : Gnome
Inscription : 14-07-2019

Re : [Résolu] Problème d'installation de Debian Buster

Beta-Pictoris a écrit :

As tu réussi à installer les firmwares ?
Que donne ?

dpkg -l firmware\*




Le firmware du GPU à l'air installer

Dernière modification par Jim (14-07-2019 21:20:00)

Hors ligne

#19 14-07-2019 21:16:02

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : [Résolu] Problème d'installation de Debian Buster

Est-ce que tu peux poster le résultat en texte avec des balises de code ?

Mets à jour ton système:

apt update
apt full-upgrade

Dernière modification par Beta-Pictoris (14-07-2019 21:17:40)

Hors ligne

#20 14-07-2019 21:22:36

Jim
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19
(G)UI : Gnome
Inscription : 14-07-2019

Re : [Résolu] Problème d'installation de Debian Buster

Beta-Pictoris a écrit :

Est-ce que tu peux poster le résultat en texte avec des balises de code ?

Mets à jour ton système:

apt update
apt full-upgrade



Ah oui pardon, la photo est supprimé big_smile

Je n'ai aucune mise à jour de proposé

Hors ligne

#21 14-07-2019 21:27:01

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : [Résolu] Problème d'installation de Debian Buster

Je suppose que tu as redémarré ta machine.

Tu vois toujours des messages d'erreur au démarrage ?

Que donne ?

systemctl get-default

Hors ligne

#22 14-07-2019 21:32:39

Jim
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19
(G)UI : Gnome
Inscription : 14-07-2019

Re : [Résolu] Problème d'installation de Debian Buster

Beta-Pictoris a écrit :

Je suppose que tu as redémarré ta machine.

Tu vois toujours des messages d'erreur au démarrage ?

Que donne ?

systemctl get-default



Oui bien-sûr tongue

Non je n'en ai plus !

Voilà le retour

multi-user.target

Hors ligne

#23 14-07-2019 21:36:55

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : [Résolu] Problème d'installation de Debian Buster

Ok lance :

systemctl set-default graphical.target


Puis :

systemctl isolate graphical.target

Hors ligne

#24 14-07-2019 21:48:04

Jim
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19
(G)UI : Gnome
Inscription : 14-07-2019

Re : [Résolu] Problème d'installation de Debian Buster

Beta-Pictoris a écrit :

Ok lance :

systemctl set-default graphical.target

:|:|
Puis :

systemctl isolate graphical.target



Debian ne se lance plus et j'ai un tiret blanc qui clignote neutral

Hors ligne

#25 14-07-2019 21:51:32

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : [Résolu] Problème d'installation de Debian Buster

Tu avais installé un bureau ? : gnome, kde, ou un gestionnaire de fenêtre ?
Que donne ?

cat /var/log/Xorg.0.log

Dernière modification par Beta-Pictoris (14-07-2019 21:51:47)

Hors ligne

Pied de page des forums