Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-07-2019 05:44:49

cdarsac
Membre
Lieu : Toulouse, con ! :)
Distrib. : Debian GNU/Linux 10 \n \l (cat /etc/issue)
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome 3.22.3-3
Inscription : 04-06-2019

[résolu] Pb installation imp HP-ENVY sous Buster (Debian 10)

Bonjour,

Je ne parviens pas à installer HP Linux Imaging and Printing System (ver. 3.19.6) sur debian-10 buster pour installer mon imprimante HP-ENVY4527.

Qu'en pensez-vous ?       smile

Merci d'avance de vos réponses.


Système d'exploitation : Debian 10 (Buster)
Kernel : Linux 4.19.0-5-amd64
Imprimante : HP ENVY 4527
Driver utilisé : ?
Procédure d'installation :
HP Linux Imaging and Printing System (ver. 3.19.6)
HPLIP Installer ver. 5.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Sun-28-Jul-2019_06:23:56.log

\
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
|Gtk-Message: 06:23:58.107: Failed to load module "canberra-gtk-module"
error: debian-10.0 version is not supported, so all dependencies may not be installed. However trying to install using debian-9.8 version packages.

Dernière modification par cdarsac (28-07-2019 14:11:13)


Élève en "Systèmes et réseaux" (école informatique LDNR (www.ldnr.fr) de Toulouse)
Membre du club DebianFacile

Hors ligne

#2 28-07-2019 11:04:52

Antic Bomber
CA Debian-Facile
Lieu : P.O. 66
Distrib. : buster
Noyau : Linux 4.19-amd64
(G)UI : xfce
Inscription : 10-08-2014

Re : [résolu] Pb installation imp HP-ENVY sous Buster (Debian 10)

Salut cdarsac,

j’y connais pas grand-chose , mais as tu installé les paquets « hplip » et « printer-driver-hpcups » ?

comme dit tonton Jo « force et courage »

@pluch, old_geek.gif

La connaissance s'acquiert par l'expérience, tout le reste n'est que de l'information.  Albert Einstein
https://framacarte.org/en/map/debian-fa … 160/2.8606

Hors ligne

#3 28-07-2019 11:37:52

cdarsac
Membre
Lieu : Toulouse, con ! :)
Distrib. : Debian GNU/Linux 10 \n \l (cat /etc/issue)
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome 3.22.3-3
Inscription : 04-06-2019

Re : [résolu] Pb installation imp HP-ENVY sous Buster (Debian 10)

Antic Bomber a écrit :

Salut cdarsac,

j’y connais pas grand-chose , mais as tu installé les paquets « hplip » et « printer-driver-hpcups » ?

comme dit tonton Jo « force et courage »

@pluch, https://debian-facile.org/img/smilies/x … d_geek.gif




Pas du tout, je n'ai fait que suivre ceci:

Re : imprimanter HP ENVY 4527 Pas de scanner avec linux
Options

le 21-03-2017 10h59

Bonjour @Antoine39



En premier lieu , je vous invite à installer l'imprimante à l'aide de l'assistant HPLIP :

http://hplipopensource.com/hplip-web/index.html



Suite à ça , vous pouvez vérifier la rubrique « Comment numériser » :

http://hplipopensource.com/node/189


Élève en "Systèmes et réseaux" (école informatique LDNR (www.ldnr.fr) de Toulouse)
Membre du club DebianFacile

Hors ligne

#4 28-07-2019 11:42:42

cdarsac
Membre
Lieu : Toulouse, con ! :)
Distrib. : Debian GNU/Linux 10 \n \l (cat /etc/issue)
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome 3.22.3-3
Inscription : 04-06-2019

Re : [résolu] Pb installation imp HP-ENVY sous Buster (Debian 10)

Antic Bomber a écrit :

Salut cdarsac,

j’y connais pas grand-chose , mais as tu installé les paquets « hplip » et « printer-driver-hpcups » ?

comme dit tonton Jo « force et courage »

@pluch, https://debian-facile.org/img/smilies/x … d_geek.gif



Apparemment, celà s'est déjà fait:       yes.gif

root@desktop-christophe:~# apt install hplip
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
hplip est déjà la version la plus récente (3.18.12+dfsg0-2).
hplip passé en « installé manuellement ».
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.
root@desktop-christophe:~# apt install printer-driver-hpcups
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
printer-driver-hpcups est déjà la version la plus récente (3.18.12+dfsg0-2).
printer-driver-hpcups passé en « installé manuellement ».
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.
 


Élève en "Systèmes et réseaux" (école informatique LDNR (www.ldnr.fr) de Toulouse)
Membre du club DebianFacile

Hors ligne

#5 28-07-2019 11:45:33

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.8.0-2-amd64
(G)UI : mutter 3.38.0-2
Inscription : 15-02-2016

Re : [résolu] Pb installation imp HP-ENVY sous Buster (Debian 10)

cdarsac a écrit :

Bonjour,

Je ne parviens pas à installer HP Linux Imaging and Printing System (ver. 3.19.6) sur debian-10 buster pour installer mon imprimante HP-ENVY4527.

Qu'en pensez-vous ?       smile

Merci d'avance de vos réponses.


Système d'exploitation : Debian 10 (Buster)
Kernel : Linux 4.19.0-5-amd64
Imprimante : HP ENVY 4527
Driver utilisé : ?
Procédure d'installation :
HP Linux Imaging and Printing System (ver. 3.19.6)
HPLIP Installer ver. 5.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Sun-28-Jul-2019_06:23:56.log

\
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
|Gtk-Message: 06:23:58.107: Failed to load module "canberra-gtk-module"
error: debian-10.0 version is not supported, so all dependencies may not be installed. However trying to install using debian-9.8 version packages.

Tu es allé ici : https://developers.hp.com/hp-linux-imag … g/gethplip et tu as téléchargé le script d'installation hplip.

https://developers.hp.com/sites/default … ll_1_2.png

Ce n'est nécessaire que pour une imprimante HP qui vient juste d'être mise sur le marché et dont le pilote n'est pas encore empaqueté par Debian, autant dire presque jamais nécessaire. De plus même si c'était le cas, le script réalise une compilation qui doit être aidée à poursuivre en installant certains paquets de développement et d'autres paquets, si on n'a aucune notion de compilation, c'est mort. Cette méthode n'est donc presque jamais valable puisqu'il y a des paquets debian adaptés qui font mieux le travail.

Je crois qu'il y a une commande de désinstallation du script, un genre de unsinstall.sh si je me souviens bien, il faut la lancer pour enlever les résidus d'installation.

Ensuite il faut juste installer le serveur d'impression task-print-server qui installe les pilotes et installe, configure le serveur d'impression CUPS.


J'ai modifié car c'est plus sûr d'avoir tous les pilotes avec --install-recommends :

apt-get install --install-recommends task-print-server

Dernière modification par --gilles-- (28-07-2019 13:17:36)


La liberté est liée à la qualité du langage, et les bureaucrates qui veulent détruire la liberté ont tous tendance à mal écrire et à mal parler, à se servir d’expressions pompeuses ou confuses, à user de clichés qui occultent ou oblitèrent le sens. Georges Orwell

Hors ligne

#6 28-07-2019 12:05:01

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.8.0-2-amd64
(G)UI : mutter 3.38.0-2
Inscription : 15-02-2016

Re : [résolu] Pb installation imp HP-ENVY sous Buster (Debian 10)

D'ailleurs je recommande de sélectionner ☑ serveur d'impression à l'installation, tous les bons pilotes seront installés, le serveur d'impression configuré et quasiment toutes les imprimantes fonctionneront directement dès qu'elles seront branchées, vraiment du Linux Facile !


debian-9_desktop-550x360.png

Une fois que l'on a installé le serveur d'impression, soit au départ à l'installation, soit plus tard avec task-printer-server, on peut vérifier juste par acquis de conscience qu'elle est prise en charge, pour une HP-ENVY4527 cherchez avec HP Envy 4520 Series :

lpinfo -m | grep 'HP Envy 4520 Series'

drv:///hpijs.drv/hp-envy_4520_series-hpijs.ppd HP Envy 4520 Series hpijs, 3.18.12
hplip:0/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip:1/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip:2/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip:3/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip-data:0/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip-data:1/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip-data:2/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip-data:3/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
drv:///hpcups.drv/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
root@tapez-ici-vos-commandes:~#
 



Source de l'information : https://debian-facile.org/doc:reseau:cups

Dernière modification par --gilles-- (28-07-2019 13:26:12)


La liberté est liée à la qualité du langage, et les bureaucrates qui veulent détruire la liberté ont tous tendance à mal écrire et à mal parler, à se servir d’expressions pompeuses ou confuses, à user de clichés qui occultent ou oblitèrent le sens. Georges Orwell

Hors ligne

#7 28-07-2019 13:57:33

cdarsac
Membre
Lieu : Toulouse, con ! :)
Distrib. : Debian GNU/Linux 10 \n \l (cat /etc/issue)
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome 3.22.3-3
Inscription : 04-06-2019

Re : [résolu] Pb installation imp HP-ENVY sous Buster (Debian 10)

--gilles-- a écrit :

cdarsac a écrit :

Bonjour,

Je ne parviens pas à installer HP Linux Imaging and Printing System (ver. 3.19.6) sur debian-10 buster pour installer mon imprimante HP-ENVY4527.

Qu'en pensez-vous ?       smile

Merci d'avance de vos réponses.


Système d'exploitation : Debian 10 (Buster)
Kernel : Linux 4.19.0-5-amd64
Imprimante : HP ENVY 4527
Driver utilisé : ?
Procédure d'installation :
HP Linux Imaging and Printing System (ver. 3.19.6)
HPLIP Installer ver. 5.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Sun-28-Jul-2019_06:23:56.log

\
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
|Gtk-Message: 06:23:58.107: Failed to load module "canberra-gtk-module"
error: debian-10.0 version is not supported, so all dependencies may not be installed. However trying to install using debian-9.8 version packages.

Tu es allé ici : https://developers.hp.com/hp-linux-imag … g/gethplip et tu as téléchargé le script d'installation hplip.

https://developers.hp.com/sites/default … ll_1_2.png

Ce n'est nécessaire que pour une imprimante HP qui vient juste d'être mise sur le marché et dont le pilote n'est pas encore empaqueté par Debian, autant dire presque jamais nécessaire. De plus même si c'était le cas, le script réalise une compilation qui doit être aidée à poursuivre en installant certains paquets de développement et d'autres paquets, si on n'a aucune notion de compilation, c'est mort. Cette méthode n'est donc presque jamais valable puisqu'il y a des paquets debian adaptés qui font mieux le travail.

Je crois qu'il y a une commande de désinstallation du script, un genre de unsinstall.sh si je me souviens bien, il faut la lancer pour enlever les résidus d'installation.

Ensuite il faut juste installer le serveur d'impression task-print-server qui installe les pilotes et installe, configure le serveur d'impression CUPS.


J'ai modifié car c'est plus sûr d'avoir tous les pilotes avec --install-recommends :

apt-get install --install-recommends task-print-server



root@desktop-christophe:~# apt-get install --install-recommends task-print-server
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
task-print-server est déjà la version la plus récente (3.53).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.
 

Dernière modification par cdarsac (28-07-2019 13:57:57)


Élève en "Systèmes et réseaux" (école informatique LDNR (www.ldnr.fr) de Toulouse)
Membre du club DebianFacile

Hors ligne

#8 28-07-2019 14:00:01

cdarsac
Membre
Lieu : Toulouse, con ! :)
Distrib. : Debian GNU/Linux 10 \n \l (cat /etc/issue)
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome 3.22.3-3
Inscription : 04-06-2019

Re : [résolu] Pb installation imp HP-ENVY sous Buster (Debian 10)

--gilles-- a écrit :

D'ailleurs je recommande de sélectionner ☑ serveur d'impression à l'installation, tous les bons pilotes seront installés, le serveur d'impression configuré et quasiment toutes les imprimantes fonctionneront directement dès qu'elles seront branchées, vraiment du Linux Facile !


https://cdn-02.memo-linux.com/wp-conten … 50x360.png

Une fois que l'on a installé le serveur d'impression, soit au départ à l'installation, soit plus tard avec task-printer-server, on peut vérifier juste par acquis de conscience qu'elle est prise en charge, pour une HP-ENVY4527 cherchez avec HP Envy 4520 Series :

lpinfo -m | grep 'HP Envy 4520 Series'

drv:///hpijs.drv/hp-envy_4520_series-hpijs.ppd HP Envy 4520 Series hpijs, 3.18.12
hplip:0/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip:1/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip:2/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip:3/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip-data:0/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip-data:1/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip-data:2/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip-data:3/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
drv:///hpcups.drv/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
root@tapez-ici-vos-commandes:~#
 



Source de l'information : https://debian-facile.org/doc:reseau:cups



root@desktop-christophe:~# lpinfo -m | grep 'HP Envy 4520 Series'
drv:///hpijs.drv/hp-envy_4520_series-hpijs.ppd HP Envy 4520 Series hpijs, 3.18.12
hplip:0/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip:1/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip:2/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip:3/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip-data:0/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip-data:1/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip-data:2/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
hplip-data:3/ppd/hplip/HP/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
drv:///hpcups.drv/hp-envy_4520_series.ppd HP Envy 4520 Series, hpcups 3.18.12
root@desktop-christophe:~#
 


Élève en "Systèmes et réseaux" (école informatique LDNR (www.ldnr.fr) de Toulouse)
Membre du club DebianFacile

Hors ligne

#9 28-07-2019 14:00:31

cdarsac
Membre
Lieu : Toulouse, con ! :)
Distrib. : Debian GNU/Linux 10 \n \l (cat /etc/issue)
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome 3.22.3-3
Inscription : 04-06-2019

Re : [résolu] Pb installation imp HP-ENVY sous Buster (Debian 10)

Super, tout fonctionne parfaitement !         yes.gif

merci.gif

Dernière modification par cdarsac (28-07-2019 14:12:21)


Élève en "Systèmes et réseaux" (école informatique LDNR (www.ldnr.fr) de Toulouse)
Membre du club DebianFacile

Hors ligne

Pied de page des forums