Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-08-2019 05:33:23

cdarsac
Membre
Lieu : Toulouse, con ! :)
Distrib. : Debian GNU/Linux 10 \n \l (cat /etc/issue)
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome 3.22.3-3
Inscription : 04-06-2019

Comment configurer exim4, pour recevoir des emails de logwatch ?

Bonjour,

J'utilise logwatch, mais je ne parviens pas à recevoir ses emails sur ma messagerie perso.

Je suspecte un pb de configuration de "exim4", mais je n'ai pas assez de compétences pour en venir à bout.

J'ai lancé "dpkg-reconfigure exim4-config", mais je ne sais pas vraiment quoi choisir parmi les différentes options proposées:
mgvcED.png



Quelqu'un peut-il m'aider ?      smile

Voici mes logs:

/var/mail:

A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

      ma-messagerie-perso@outlook.com
        Mailing to remote domains not supported

    --1564577476-eximdsn-2079256939
    Content-type: message/delivery-status

    Reporting-MTA: dns; desktop-christophe

    Action: failed
    Final-Recipient: rfc822; ma-messagerie-perso@outlook.com
    Status: 5.0.0

    --1564577476-eximdsn-2079256939
    Content-type: text/rfc822-headers

    Return-path: <root@desktop-christophe>
    Received: from root by desktop-christophe with local (Exim 4.92)
        (envelope-from <root@desktop-christophe>)
        id 1hso4Z-0000zz-QA
        for  ma-messagerie-perso@outlook.com; Wed, 31 Jul 2019 14:51:16 +0200
    To:  ma-messagerie-perso@outlook.com
    From: logwatch@desktop-christophe
    Subject: Logwatch for desktop-christophe (Linux)
    Auto-Submitted: auto-generated
    Precedence: bulk
    MIME-Version: 1.0
    Content-Transfer-Encoding: 7bit
    Content-Type: text/html; charset="UTF-8"
    Message-Id: <E1hso4Z-0000zz-QA@desktop-christophe>
    Date: Wed, 31 Jul 2019 14:51:16 +0200
    X-Exim-DSN-Information: Due to administrative limits only headers are returned


    --1564577476-eximdsn-2079256939--

    From MAILER-DAEMON Wed Jul 31 16:47:37 2019
    Return-path: <>
    Envelope-to: root@desktop-christophe
    Delivery-date: Wed, 31 Jul 2019 16:47:37 +0200
    Received: from Debian-exim by desktop-christophe with local (Exim 4.92)
        id 1hsptB-0001O3-SS
        for root@desktop-christophe; Wed, 31 Jul 2019 16:47:37 +0200
    X-Failed-Recipients:  ma-messagerie-perso@outlook.com
    Auto-Submitted: auto-replied
    From: Mail Delivery System <Mailer-Daemon@desktop-christophe>
    To: root@desktop-christophe
    Content-Type: multipart/report; report-type=delivery-status; boundary=1564584457-eximdsn-2019737634
    MIME-Version: 1.0
    Subject: Mail delivery failed: returning message to sender
    Message-Id: <E1hsptB-0001O3-SS@desktop-christophe>
    Date: Wed, 31 Jul 2019 16:47:37 +0200

    --1564584457-eximdsn-2019737634
    Content-type: text/plain; charset=us-ascii

    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

     ma-messagerie-perso@outlook.com
        Mailing to remote domains not supported




/var/log/exim4:

2019-07-31 18:02:51 1hsr3y-0003ok-IY <= root@outlook.com U=root P=local S=134345
    2019-07-31 18:02:51 1hsr3y-0003ok-IY no IP address found for host mail.desktop-christophe
    2019-07-31 18:02:51 1hsr3y-0003ok-IY ==  ma-messagerie-perso@outlook.com R=smarthost defer (-1): lookup failed for all hosts in smarthost router: host_find_failed=ignore host_all_ignored=defer

Dernière modification par cdarsac (01-08-2019 09:09:39)


Élève en "Systèmes et réseaux" (école informatique LDNR (www.ldnr.fr) de Toulouse)
Membre du club DebianFacile

Hors ligne

#2 01-08-2019 08:39:37

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Comment configurer exim4, pour recevoir des emails de logwatch ?

Bonjour
j'utilise Exim4 pour envoyer mes emails local sur ma messagerie internet , donc option 3 en partant du bas
toujours en partant du bas :
option 1 , pas de configuration tu sort sans rien modifier
option 2 , uniquement en local sur la machine (127.0.0.1 ou localhost )
option 3 , tu ne stocke rien sur la machine , ta machine fait office de serveur pour le réseau local (en écoute uniquement sur l'IP choisi (ou le domaine)

les options 4 et 5 tu écoute coté internet (a mon avis la 5 ton serveur exim4 gère tous tes mails et remplace ta messagerie externe (écoute et envoie de mail ).

moi je l'utilise uniquement en local sur une passerelle coté "sous réseau"  pour archiver mes "mails système" sur ma messagerie de mon fournisseur de l'ADSL.

a l'époque de jessie j'ai fait un wiki "exim4 pour les nulls"
il y a des logs dans /var/log/exim4/
selon ton utilisation , il faudra peut être modifier directement les scripts de configuration de exim4
je pourrai pas t' aider plus roll
je te met quelques liens :

=> https://debian-facile.org/doc:reseau:ex … -les-nulls
=> https://wiki.debian.org/Exim
=> https://www.debian.org/releases/stretch … 05.html.fr

ps: tu fais une recherche avec les mots clé "debian exim4"

pour logwatch =>  https://wiki.debian-fr.xyz/Logwatch

si c'est pour récupérer tes rapports sur une messagerie externe (internet) , mon wiki doit faire l' affaire , selon ta configuration . (smarthost)
depuis jessie il fonctionne toujours , jusqu' a "debian 11"

il faut donner la structure de ton réseau (combien de machines ? qui fait office de serveur smarthost ? )
pour ton smtp externe (internet) avec ou sans mot de passe ?
respecter la sécurité , dans ton cas refuser les mails exterieurs (internet) en écoute.

pour un client en IPV4 uniquement le log "/var/log/exim4/mainlog  du sous réseau


2019-08-01 08:59:16 exim 4.92 daemon started: pid=1026, -q30m, listening for SMTP on [127.0.0.1]:25
2019-08-01 08:59:16 Start queue run: pid=1028
2019-08-01 08:59:16 End queue run: pid=1028
2019-08-01 09:08:27 exim 4.92 daemon started: pid=978, -q30m, listening for SMTP on [127.0.0.1]:25
2019-08-01 09:08:27 Start queue run: pid=980
2019-08-01 09:08:27 End queue run: pid=980
2019-08-01 09:38:27 Start queue run: pid=1527
2019-08-01 09:38:27 End queue run: pid=1527
 


il écoute uniquement sur 127.0.0.1
le serveur "smarthost" lui va écouter sur "127.0.0.1" et sur l'IP "192.168.xxx.xxx" pour gérer ses mails (localhost) et envoyer ceux des clients du sous réseau (192.168.xxx.xxx) vers l'extérieur

sur le wiki "exim4 pour les nulls" :
1) - si tu n'a qu une seule machine , c'est le paragraphe "première configuration"
2) - pour un client le second (sur un sous réseau) avec une passerelle qui fait office de serveur smarthost
3) - pour le serveur smarthost d'un sous réseau le troisième

a mon avis pour toi c'est le "1)" , le 2 et le 3 c'est avec une passerelle et un domaine bidon sur le "sous réseau local" dans mon exemple .
pour "logwatch" ce sera "127.0.0.1" le serveur de mail (je ne connais pas ce paquet)
j'ai actuellement les erreurs de smartmontools (disques) , de "apt-listchanges" (mise a jour) et les erreurs systèmes (root)

Dernière modification par robert2a (01-08-2019 09:31:30)

En ligne

#3 01-08-2019 09:59:12

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Comment configurer exim4, pour recevoir des emails de logwatch ?

j'ai installé le paquet logwatch
tu a le man


man logwatch
 


pas encore testé mais le principal


Output = mail
Format = text
MailTo = root (ou tout autre adresse fonctionnelle)
MailFrom = logwatch@votredomaine.org (ou tout autre adresse fonctionnelle)
 



moi par exemple "root" ou "robert" doit fonctionner pour "MailTo"  (nom du destinataire)
pour "MailFrom" l'adresse du serveur de mail local , a modifier.

par contre je sais pas comment il fonctionne  tongue , faut le lancer manuellement ou il fait ça tout seul ?   tongue

pour exim4 il faut que tu commence par tester ton serveur exim4. (en fin du wiki quelques commandes utiles)


echo "test mail "   |  mail -s "test"  root
 


tu dois recevoir sur ta boite mail externe "test mail" de root

pour logwatch , j' ai modifié ceci


MailFrom = root@localhost
 


normalement le rapport doit arriver sur ma boite mail internet

Dernière modification par robert2a (01-08-2019 10:30:14)

En ligne

#4 01-08-2019 10:29:52

cdarsac
Membre
Lieu : Toulouse, con ! :)
Distrib. : Debian GNU/Linux 10 \n \l (cat /etc/issue)
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome 3.22.3-3
Inscription : 04-06-2019

Re : Comment configurer exim4, pour recevoir des emails de logwatch ?

Bonjour,

Merci pour ta réponse très détaillée.     smile

Dans mon cas, c'est effectivement ton wiki qui convient parfaitement.

J'ai bien suivi toutes les étapes de configurations, pour autant je ne reçois pas d'email dans ma mesagerie perso après

echo "test mail "   |  mail -s "test"  toto@debian40



Voici ce que j'ai dans les logs de /var/log/exim4/mainlog:

2019-08-01 11:27:13 1ht7Mf-0001AI-9h <= desktop-christophe@local.net U=root P=local S=391
2019-08-01 11:27:13 1ht7Mf-0001AI-9h H=MRS-efz.ms-acdc.office.com [2603:1026:700:1::2] Network is unreachable
2019-08-01 11:27:13 1ht7Mf-0001AI-9h H=MRS-efz.ms-acdc.office.com [52.97.173.2] Connection refused
2019-08-01 11:27:13 1ht7Mf-0001AI-9h == toto@debian40 R=smarthost T=remote_smtp_smarthost defer (111): Connection refused


Élève en "Systèmes et réseaux" (école informatique LDNR (www.ldnr.fr) de Toulouse)
Membre du club DebianFacile

Hors ligne

#5 01-08-2019 10:47:15

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Comment configurer exim4, pour recevoir des emails de logwatch ?

ta configuration n'est pas bonne
pour logwatch j'ai laissé ceci : hier (par défaut)


# The default time range for the report...
# The current choices are All, Today, Yesterday
Range = yesterday
 


nota: option all (tout) , today (aujourd'hui) today (hier)

pour ton retour ci dessus il faut un utilisateur valide (exemple pour moi root ou robert  wink   )

pour /etc/aliases


# /etc/aliases
mailer-daemon: postmaster
postmaster: root
nobody: root
hostmaster: root
usenet: root
news: root
webmaster: root
www: root
ftp: root
abuse: root
noc: root
security: root
root: robert
robert: utilisateur@orange.fr   => ici une adresse mail valide de tes mails externes ( dans mon cas chez orange)
 



pour /etc/email-addresses


# This is /etc/email-addresses. It is part of the exim package
#
# This file contains email addresses to use for outgoing mail. Any local
# part not in here will be qualified by the system domain as normal.
#
# It should contain lines of the form:
#
#user: someone@isp.com
#otheruser: someoneelse@anotherisp.com
root: raven2200g@local.net
robert: raven2200g@local.net
 


j'ai mit le nom de la machine , et bien sur "local.net" est bidon , juste me permet de savoir qui a envoyé le mail , ici "raven2200G"

donc ses deux fichiers a mettre a jour (AVEC tes VALEURS , ne pas copier/coller wink   ) et redémarrer la machine.(sur qu ils soient pris en compte )
pour le premier très important de mettre une adresse mail valide de ta boite mail externe .

pour tester utilise "root" par exemple


echo "test mail "   |  mail -s "test"  root
 


ps: le wiki c'est des exemples , faut utiliser des choses valides pour ta machine  smile

voila ce que ça donne pour moi sur ma messagerie extérieure


Subject : test

Date : Thu, 01 Aug 2019 09:00:53 GMT

From : robert <raven2200g@local.net>

To : root@mondomaine <root@mondomaine>

Content-Type : text/plain

MIME-Version : 1.0
 



pour le from tu vois qui la envoyé (mon user "robert" et la machine "raven2200G")
le "To" pour toi pas de domaine , ce sera root@localhost

tu a fait la première configuration ? avec des valeurs qui correspondent a ta configuration ?
je peu pas te donner les retours a partir de mon serveur , uniquement d un client sur un domaine , mais si tu suis le début du wiki jusqu'a la fin de première configuration ça doit fonctionner.
donc une seule machine avec exim4 en smarthost et uniquement les mails locaux (localhost ou 127.0.0.1) (configuration 3 a partir du bas ( a partir du menu de exim4 )).

la configuration de "aliases" et "email-addresses" (les valeurs comme "robert" a remplacer par ton "user" de ta session sur le bureau. )

puis pour la config de exim4
pour avoir le nom de la machine (netbios)


cat /etc/hostname
 


la configuration dans ton cas


configuration du serveur de courrier.
type de configuration : =>
"envoi par relais (smarthost)-pas de courrier local."
on sélectionne "OK" puis "enter".

Nom du courrier système: => "nom-machine" (le nom netbios de votre machine).
on sélectionne "OK" puis "enter".

Liste des adresses IP où exim sera en attente de connexions SMTP entrantes: => "127.0.0.1"
Attention ne jamais laisser vide ce champ , personnellement j'enlève l'ipv6 local.
exim sera à l'écoute sur 127.0.0.1 pour les messages entrants
on sélectionne "OK" puis "enter"

Autres destinations dont le courrier doit être accepté : => "localhost"  => ici a mon avis on doit pouvoir laisser le champ vide (teste les deux façon )
on sélectionne "OK" puis "enter"

Nom de domaine visible pour les utilisateurs locaux: => "localhost"  => ici aussi on doit pouvoir laisser vide (teste les deux façon )
on sélectionne "OK" puis "enter"

Nom réseau ou adresse IP du systeme smarthost: => "smtp.orange.fr" (j'ai mis celui d'Orange vous remplacez par le vôtre)
C'est ici que vous précisez comment le serveur distribue les mails vers l'extérieur
ps: une adresse pour le smtp valide sinon ça ne fonctionnera pas (au dessus un exemple , si tu n'est pas chez orange ne fonctionnera pas )
on sélectionne "OK" puis "enter"

Faut-il minimiser les requêtes DNS (connexion à la demande ): => "NON"
on sélectionne "NON" puis "enter"

Faut-il séparer la configuration dans plusieurs fichiers: => "NON"
on sélectionne "NON" puis "enter"
 



teste comme ci dessus la configuration de exim4 , tu n'a pas de domaine , et exim4 n'écoute que sur 127.0.0.1 (localhost).
il faudra peut être que je modifie le wiki  (prévu au départ pour une configuration bien particulière )

ps: pour bien faire il faudrait que j'ai un machine derrière ma box et la configurer en smarthost  roll
si tu peu donner qui te fourni la boite mail externe ( sfr , orange , .......  etc )

pour "logwatch" je te tien informé , je le découvre ..........

liste des messages gelés


mailq | grep "frozen"
 


qui ne renvoie rien pour moi

Dernière modification par robert2a (01-08-2019 12:13:40)

En ligne

#6 01-08-2019 15:42:44

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Comment configurer exim4, pour recevoir des emails de logwatch ?

re,
en console a tu un retour comme ceci (pour ma machine)


logwatch
 


retour


 ################### Logwatch 7.4.3 (04/27/16) ####################
        Processing Initiated: Thu Aug  1 16:36:12 2019
        Date Range Processed: yesterday
                              ( 2019-Jul-31 )
                              Period is day.
        Detail Level of Output: 0
        Type of Output/Format: stdout / text
        Logfiles for Host: raven2200g
 ##################################################################
 
 --------------------- Kernel Begin ------------------------

 WARNING:  Kernel Errors Present
    [drm:construct [amdgpu]] *ERROR* construct: Inva ...:  2 Time(s)
 
 ---------------------- Kernel End -------------------------

 
 --------------------- pam_unix Begin ------------------------

 lightdm:
    Unknown Entries:
       Couldn't open /etc/securetty: No such file or directory: 4 Time(s)
       session opened for user robert by (uid=0): 2 Time(s)
       session closed for user robert: 1 Time(s)
 
 lightdm-greeter:
    Unknown Entries:
       session closed for user lightdm: 2 Time(s)
       session opened for user lightdm by (uid=0): 2 Time(s)
 
 polkit-1:
    Sessions Opened:
       robert -> root: 2 Time(s)
 
 su-l:
    Sessions Opened:
       robert -> root: 1 Time(s)
    Unknown Entries:
       Couldn't open /etc/securetty: Aucun fichier ou dossier de ce type: 2 Time(s)
 
 
 ---------------------- pam_unix End -------------------------

 
 --------------------- rsyslogd Begin ------------------------

 **** Unmatched entries ****
     imuxsock: Acquired UNIX socket '/run/systemd/journal/syslog' (fd 3) from systemd.  [v8.1907.0] : 2 Times
 
 ---------------------- rsyslogd End -------------------------

 
 --------------------- Connections (secure-log) Begin ------------------------

 
 User Logins:
    robert : 2 Time(s)
 
 **Unmatched Entries**
    su: (to root) robert on pts/0: 1 Time(s)
    systemd-logind: New session c1 of user lightdm.: 2 Time(s)
    systemd-logind: System is powering down.: 1 Time(s)
    systemd-logind: System is rebooting.: 1 Time(s)
 
 ---------------------- Connections (secure-log) End -------------------------

 
 --------------------- Smartd Begin ------------------------

 
 /dev/sda [SAT] :
    Usage: Airflow_Temperature_Cel (190) changed to
      75, 67, 63,
    Usage: Temperature_Celsius (194) changed to
      25, 33, 37,
 
 /dev/sdb [SAT] :
    Usage: Temperature_Celsius (194) changed to
      69, 56,
 
 ---------------------- Smartd End -------------------------

 
 --------------------- Disk Space Begin ------------------------

 Filesystem      Size  Used Avail Use% Mounted on
 /dev/sdb2       236G   29G  195G  13% /
 /dev/sdb1       511M  140K  511M   1% /boot/efi
 /dev/sda1       458G   47G  388G  11% /home/robert/Films
 
 
 ---------------------- Disk Space End -------------------------

 
 --------------------- lm_sensors output Begin ------------------------

 amdgpu-pci-0800
 Adapter: PCI adapter
 vddgfx:           N/A  
 vddnb:            N/A  
 fan1:             N/A
 temp1:        +44.0 C  (crit = +80.0 C, hyst =  +0.0 C)
 
 k10temp-pci-00c3
 Adapter: PCI adapter
 Tdie:         +44.8 C  (high = +70.0 C)
 Tctl:         +44.8 C  
 
 asus-isa-0000
 Adapter: ISA adapter
 cpu_fan:        0 RPM
 
 
 ---------------------- lm_sensors output End -------------------------

 
 ###################### Logwatch End #########################
 



j'utilise ce lien pour le configurer  =>  https://doc.ubuntu-fr.org/logwatch

Important: il faut créer un dossier pour qu'il fonctionne bien (n'existe pas par défaut chez moi)


mkdir /var/cache/logwatch
 



sous forme de mail texte ma messagerie ne le prend pas en compte (il n'arrive pas sur ma messagerie externe (internet) )
la commande


logwatch --mailto root@localhost
 


exim4 me dit "ok" (coté client) le message est bien partit jusqu'au serveur exim4 smarthost .


2019-08-01 16:45:16 1htCKR-0000bX-Fu Completed
 


ps: il faut que je regarde coté serveur , le log de exim4
coté serveur c'est ok aussi
juste un peu long chez Orange  tongue


Subject : Logwatch for raven2200g (Linux)

Date : Thu, 01 Aug 2019 14:45:16 GMT

From : root <raven2200g@local.net>

To : root@localhost <root@localhost>

Content-Type : text/plain

Precedence : bulk
 



et j'ai bien mon rapport dans le mail  smile

je te conseille de lire le chapitre 4 "Configuration" du lien Ubuntu
pas encore fait , mais je compte bien le faire smile
donc la suite


cp /usr/share/logwatch/default.conf/logwatch.conf /etc/logwatch/conf/
 


L'adresse de destination de vos rapports
pour moi j'utilise simplement "root" , exim4 prend les emails local uniquement


MailTo = root
 



pour le dernier paragraphe 4.2 , je sais pas si nécessaire de faire quelque chose , pour l'instant les dossiers /etc/logwatch/conf/services et logfiles sont vide
il est possible de traiter sous forme de logs ,http ou mail  . ( mais pas en même temps , choisir un parmi les trois )
je sais pas si un service journalier , a priori il faut le lancer manuellement en console.
donne nous tes retours smile
il faut configurer ta messagerie (exim4) et la tester
configurer logwatch (pas grand chose a faire) et le tester en console , puis par mail

remarque:
Après lecture de ton #1 , tu utilise une messagerie "Microsoft"
je sais pas si il est possible d'utiliser "smtp" avec ce genre de messagerie
normalement ton fournisseur pour l'ADSL doit te fournir ce service (avec ou sans mot de passe)
dans mon exemple j'utilise une boite mail du dit fournisseur (ADSL) , que j'ai créer pour recevoir mes emails de mon réseau debian.

encore un bon lien  =>  http://www.partage-it.com/surveillez-le … -logwatch/
donc bien une surveillance journalière wink
attention a ne pas saturer ta boite mail par l'envoi de trop de mail et trop lourd.
je vais voir si possible sur mon serveur et les services a activer.
ps: par rapport au wiki de ubuntu un doute sur la nécessité de copier les scripts dans /etc/logwatch/

Dernière modification par robert2a (01-08-2019 17:34:48)

En ligne

#7 03-08-2019 10:33:11

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Comment configurer exim4, pour recevoir des emails de logwatch ?

Bonjour
pour moi logwatch fonctionne bien avec exim4 , tous les jours il envoie un rapport sur la messagerie externe.
je l'ai supprimé avec synaptic , pas très utile sur une machine de bureau (a purger manuellement avec "rm -R" le dossier /etc/logwatch si tu l'a créé (wiki ubuntu) )
je sais pas ou tu en set de tes tests , mais si exim4 est fonctionnel , cela ne doit pas poser de problème.
la configuration par défaut de logwatch est déjà correcte .

En ligne

Pied de page des forums