Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-08-2019 09:32:47

lagrenouille
Adhérent(e)
Lieu : Saturne
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : i3w- openbox- awesome
Inscription : 28-03-2012
Site Web

configuration clavier bépo et azerty

bonjour

Depuis que j'ai installé buster, j'ai pas réussi à faire mon changement de clavier via la commande :

dpkg-reconfigure keyboard-configuration



je trouve bien mon clavier : TypeMatrix EZ-Reach 2030 USB
mais par la suite il ne me propose pas comme sous stretch: - français bépo ergonomique façon devorak
J'ai essayé plusieurs choix dans les propositions, aucune ne fonctionne

j'ai donc mis ceci dans ma config /etc/default/keyboard

nano /etc/default/keyboard
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="tm2030USB"
XKBLAYOUT="fr,fr"
#XKBVARIANT="us"
XKBVARIANT="bepo"

XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"

BACKSPACE="guess"



mais au redémarrage de la session ou au reboot j'étais toujours en azerty et le fait de faire un  alt+shift n'y fait rien
je dois mettre mon login et mon pass sous clavier  azerty, et une fois sous mon bureau je bascule en bépo avec  alt+shift

Dans xfce4 j'ai ceci :
.
file-Rcd7e28ed17415721724a200680f81223

je pensais le problème réglé..  ben non
ce matin suite à reboot, je me retrouve en azerty au login

Dernière modification par lagrenouille (08-08-2019 10:21:38)


je tape en bépo

Mort aux vaches ! vive l'anarchie

Hors ligne

#2 08-08-2019 11:08:54

lagrenouille
Adhérent(e)
Lieu : Saturne
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : i3w- openbox- awesome
Inscription : 28-03-2012
Site Web

Re : configuration clavier bépo et azerty

sous le conseil de framend j'ai viré fr,fr dans /etc/default/keyboard
ce qui donne
XKBLAYOUT="fr"

donc au reboot, je suis en bépo, login et passw
et dans le bureau, je suis en azerty
et je passe en bépo avec "alt shift "

voila voila

sur un forum ubuntu, je trouve ceci :

XKBMODEL="pc105"
XKBLAYOUT="fr,fr"
XKBVARIANT="bepo,latin9"
XKBOPTIONS="grp:alt_shift_toggle"



tout en gardant mon modèle de clavier
qu'en pensez vous ?

Dernière modification par lagrenouille (08-08-2019 11:26:33)


je tape en bépo

Mort aux vaches ! vive l'anarchie

Hors ligne

#3 08-08-2019 11:52:14

framend
Modo-Moule zébrée
Lieu : /home/framend
Distrib. : Sid
Noyau : 5.10.0-7-amd64
(G)UI : i3-wm/tty
Inscription : 17-11-2018

Re : configuration clavier bépo et azerty

Plop
Pour moi si tu ne veux que le bépo, ce que j'ai cru comprendre sur IRC, je pense que c'est la config suivante qui doit se trouver dans ton /etc/default/keyboard :

XKBMODEL="tm2030USB"
XKBLAYOUT="fr"
XKBVARIANT="bepo"
BACKSPACE="guess"

Dernière modification par framend (08-08-2019 11:53:19)


“It is not daily increase but daily decrease, hack away the unessential. The closer to the source, the less wastage there is.” - Bruce Lee (philosophe)

Hors ligne

#4 08-08-2019 12:10:37

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : configuration clavier bépo et azerty

Oui cela est expliqué ici : https://bepo.fr/wiki/X.org

Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#5 08-08-2019 12:14:13

lagrenouille
Adhérent(e)
Lieu : Saturne
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : i3w- openbox- awesome
Inscription : 28-03-2012
Site Web

Re : configuration clavier bépo et azerty

Oui cela est expliqué ici



???? moi je veux bien mais ça ne me va pas

XKBMODEL="tm2030USB"
XKBLAYOUT="fr"
XKBVARIANT="bepo"
BACKSPACE="guess"


.
j'essaierai avant le prochain reboot

Dernière modification par lagrenouille (08-08-2019 13:37:57)


je tape en bépo

Mort aux vaches ! vive l'anarchie

Hors ligne

#6 08-08-2019 13:46:12

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : configuration clavier bépo et azerty

pardon je crois que c'est mieux ici: http://gulliver.eu.org/ml-archives/sept … 00075.html

Dernière modification par Jean-Pierre Pinson (08-08-2019 13:52:44)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#7 08-08-2019 20:38:46

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : configuration clavier bépo et azerty

Hello
je crois bien que le fichier /etc/default/keyboard  c'est juste la configuration sur la console
dans la session graphique mon clavier n'est pas le même

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#8 10-08-2019 09:32:42

lagrenouille
Adhérent(e)
Lieu : Saturne
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : i3w- openbox- awesome
Inscription : 28-03-2012
Site Web

Re : configuration clavier bépo et azerty

voila où j'en suis
mon fichier est:

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="tm2030USB"
XKBLAYOUT="fr"
XKBVARIANT="bepo"
XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"
BACKSPACE="guess"
 



au reboot, je suis en bépo pour le login et le pass
choix de la sessions,
si  je choisis xfce, une fois dans ce bureau, je suis en azerty, et je dois faire alt+shift pour passer en bépo
si je choisis i3 alors dans le bureau, je suis d'entrée en bépo.

j'ai essayé d'enlever: XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"  mais je restais en azerty sous xfce ???
pour l'instant ça fonctionne bien comme ça
je me tâte d'essayer ceci, histoire de n'avoir que le bépo partout,
si je pouvais avoir la conf de personnes ayant ces deux bureaux, ce serait bien sympa scratchhead.gif

XKBMODEL="tm2030USB"
XKBLAYOUT="bépo"
XKBOPTIONS=" "
BACKSPACE="guess"



voili voila où keke j'en suis  smile


je tape en bépo

Mort aux vaches ! vive l'anarchie

Hors ligne

#9 10-08-2019 12:44:30

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : configuration clavier bépo et azerty

Hello comme je te dis pareil pour moi sous mate
quand tu es dans ta session xfce tu peux avoir un clavier différent celui réglé avec l'application graphique des paramètres xfce

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#10 10-08-2019 13:14:14

lagrenouille
Adhérent(e)
Lieu : Saturne
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : i3w- openbox- awesome
Inscription : 28-03-2012
Site Web

Re : configuration clavier bépo et azerty

donc que penses tu, si dans la conf graphique, on enlève "changer l'option de disposition" alt+maj
et que l'on vire "français"
penses tu que l'on aura bépo sous xfce (ou mate)??
c'est la question que je me pose
avec bien sur dans keyboard

XKBMODEL="tm2030USB"
XKBLAYOUT="bépo"
XKBOPTIONS=" "
BACKSPACE="guess"
.
mystère et goule de bomme yikes

je tape en bépo

Mort aux vaches ! vive l'anarchie

Hors ligne

#11 11-08-2019 09:02:44

lagrenouille
Adhérent(e)
Lieu : Saturne
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : i3w- openbox- awesome
Inscription : 28-03-2012
Site Web

Re : configuration clavier bépo et azerty

et comme j'ai galéré la première fois pour taper mon nom en bépo, avec mon clavier azerty, ou vice-versa e me suis fait ce pense-bête en dessin woohoo.gif

file-Rf42e42197d52cf736a97dbdad7fd739c

Dernière modification par lagrenouille (11-08-2019 09:19:27)


je tape en bépo

Mort aux vaches ! vive l'anarchie

Hors ligne

#12 13-02-2021 01:33:31

maxenceul
Membre
Lieu : Louerre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : xFce
Inscription : 10-01-2020

Re : configuration clavier bépo et azerty

Bonsoir,
Je suis sous Debian 10.8 xfce 4.12 et j'ai cherché pour arriver à installer le TypeMatrix 2030 Bépo afin qu'il soit actif au démarrage ou lorsqu'on reboote.

1- Paramètres/clavier (voir messages précédents).
2- sudo dpkg-reconfigure keyboard-configuration (voir messages précédents) pour obtenir : /etc/default/keyboard

# KEYBOARD CONFIGURATION FILE
# Consult the keyboard(5) manual page.

XKBMODEL="tm2030USB"
XKBLAYOUT="fr"
XKBVARIANT="bepo"
XKBOPTIONS=""

BACKSPACE="guess"

3- Modifier /etc/x11/xorg.conf.d/00-keyboard.conf
[sudo mousepad /etc/x11/xorg.conf.d/00-keyboard.conf]
comme ci-dessous

# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "fr"
        Option "XkbModel" "tm2030USB"
        Option "XkbVariant" "bepo"
EndSection

…si cela peut aider quelqu'un, j'en serai heureux.

Asus VivoBook x570zd - AMD Rysen 5 2500 U - 8 Go ram - GeForce GTX 1050 - SSD 128 Go + HD 1To - Dual boot Linux Mint 20.2 xFce/Windows10
Nuc-Intel Intel core i5 1135G7 2,4 Ghz - 16 Go ram - Intel Xe Graphics  - SSD 500 Go - Debian 11 xFce
Mac mini [2010] Intel core 2 Duo 2,4 Ghz - 8 Go ram - GeForce 320M - HD 320 Go - Debian 10 xFce

Hors ligne

Pied de page des forums