Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-08-2019 20:27:34

patrickSe
Membre
Inscription : 09-08-2019

ipp14 cups debian buster

Bonjour . Plus de protocole ipp14 dans cups , suite installation  de debian 10  ...   comment faire  ??!!! 
imprimante  hl2030  brother  fonctionnait   sur  usb  Livebox   avec ce protocole sur la 9 . merci  de me proposer une solution .

Hors ligne

#2 10-08-2019 07:41:55

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.9.0-4-amd64
(G)UI : mutter 3.38.1-2
Inscription : 15-02-2016

Re : ipp14 cups debian buster

Bonjour, avec buster cela a changé. Dès que l'on pense utiliser une imprimante, je recommande de sélectionner ☑ serveur d'impression à l'installation, tous les bons pilotes seront installés, le serveur d'impression configuré et quasiment toutes les imprimantes fonctionneront directement dès qu'elles seront branchées, vraiment du Debian Facile !

debian-9_desktop-550x360.png

Une fois que l'on a installé le serveur d'impression, soit au départ à l'installation comme sélectionné dans l'image ou bien plus tard avec :

apt-get install --install-recommends task-print-server



Tu pourra voir que c'est maintenant foomatic qui est recommandé pour l'imprimante BROTHER HL-2030 :

lpinfo -m | grep HL-2030

foomatic-db-compressed-ppds:0/ppd/foomatic-ppd/Brother-HL-2030-hl1250.ppd Brother HL-2030 Foomatic/hl1250 (recommended)
foomatic-db-compressed-ppds:0/ppd/foomatic-ppd/Brother-HL-2030-hpijs-pcl5e.ppd Brother HL-2030 Foomatic/hpijs-pcl5e
foomatic-db-compressed-ppds:0/ppd/foomatic-ppd/Brother-HL-2030-lj4dith.ppd Brother HL-2030 Foomatic/lj4dith
foomatic-db-compressed-ppds:0/ppd/foomatic-ppd/Brother-HL-2030-lj5gray.ppd Brother HL-2030 Foomatic/lj5gray
foomatic-db-compressed-ppds:0/ppd/foomatic-ppd/Brother-HL-2030-ljet4.ppd Brother HL-2030 Foomatic/ljet4


Nos vies commencent à prendre fin le jour où nous devenons silencieux à propos des choses qui comptent. Martin Luther King

Hors ligne

#3 10-08-2019 10:42:03

patrickSe
Membre
Inscription : 09-08-2019

Re : ipp14 cups debian buster

Ok ; à ce niveau pas de problème .... mais c'est  le protocole Ipp14  qui gère les imprimantes usb  branchées en réseau sur la livebox  qui n'est plus présent   dans  les protocoles  fournis par cups .   mon imprimante est branché sur port usb liveboxe et accessible par les ordinateurs accesssibles sur la livebox  .
   Donc  paramétrage  par  interface cups  ( navigateur mozila)  http://localhost:631/printers    ou menu  gestion imprimante    :  uri peripherique  doit etre : ipp14:// livebox:631
   Hors plus de ipp14   ;les autres non jamais fonctionné sur la livebox . Merci

Hors ligne

#4 10-08-2019 11:16:06

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.9.0-4-amd64
(G)UI : mutter 3.38.1-2
Inscription : 15-02-2016

Re : ipp14 cups debian buster

Comme ipp14 n'est plus présent, il faut envisager d'autres solutions. Quelles sont les connectiques disponibles sur la BROTHER HL-2030 ? USB, oui, mais encore ethernet ? wifi ? autres ?

Nos vies commencent à prendre fin le jour où nous devenons silencieux à propos des choses qui comptent. Martin Luther King

Hors ligne

#5 10-08-2019 13:07:57

patrickSe
Membre
Inscription : 09-08-2019

Re : ipp14 cups debian buster

Effectivement  ; mais j'aurais bien aimer  récupérer ce protocole  , pour ne pas avoir un autre appareil en plus sur mon réseau .
  Solution  trouvée après réflexion en attendant !!!!  : petit switch  usb/ethernet non utilisé   qui a fait l'affaire  ; protocole utilisé lpd://adresse ip .

Dernière modification par patrickSe (10-08-2019 13:08:32)

Hors ligne

#6 01-10-2019 12:31:41

lee
Membre
Distrib. : Debian 10 (buster)
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome
Inscription : 01-10-2019

Re : ipp14 cups debian buster

--gilles-- a écrit :


Une fois que l'on a installé le serveur d'impression, soit au départ à l'installation comme sélectionné dans l'image ou bien plus tard avec :

apt-get install --install-recommends task-print-server



Grand merci --gilles--, cela m'a permis d'installer ma Samsung CLX-2160, les drivers fournis par HP [ils ont rachetés les imprimantes Samsung] ainsi que les anciens que j'avais conservé ne fonctionnent pas avec Debian 10 Buster.

Pour le scanner, en revanche il faut les drivers constructeurs.

encore merci !

Hors ligne

#7 02-10-2019 08:15:58

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.9.0-4-amd64
(G)UI : mutter 3.38.1-2
Inscription : 15-02-2016

Re : ipp14 cups debian buster

Merci de cette marque d'estime lee, il faut aussi souligner que si tous pilotes de toutes les marques n'y sont pas encore intégrés les développeurs ont quand même beaucoup travaillé à intégrer de nouveaux pilotes imprimantes dans task-print-server.

Nos vies commencent à prendre fin le jour où nous devenons silencieux à propos des choses qui comptent. Martin Luther King

Hors ligne

Pied de page des forums